Extreme Management Center Suite
Installation

This document provides instructions for installing and launching Extreme
Management Center, and for launching Extreme Management Center
applications on remote Extreme Management Center clients. It also includes
information for those upgrading from an earlier version of Extreme Management
Center.

IMPORTANT: Backup the Extreme Management Center database prior to performing the upgrade
and save it to a safe location. Use the Administration > Backup/Restore tab.

To upgrade to version 8.0, you must be on version 7.1or later.

General Information

Before you install Extreme Management Center, read the Extreme Management
Center Release Notes. The most recent version of these release notes can be
found on the Extremme Management Center (NMS) Documentation web page:
http://extranet.extremenetworks.com/downloads. After entering your email
address and password, follow this path to the document: Software & Security >
NetSight (NMS) > Documentation > Manuals & Release Notes > NetSight 8.1>
NetSight Suite.

Additionally, if installing Extreme Management Center on an EXOS system on
which version 16.1 or later is installed, you need to initialize the system in
enhanced security mode. Additional information is available in the EXOS User
Guide.

NOTE: The terms engine, gateway, and appliance are used interchangeably throughout Extreme
Management Center documentation.

Operating System Requirements

These are the operating system requirements for both the Extreme Management
Center server and remote Extreme Management Center client machines.
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General Information

IMPORTANT: Beginning in Extreme Management Center version 7.0, only 64-bit operating systems are
officially supported on the Extreme Management Center server and remote Extreme
Management Center client machines. Upgrade any Extreme Management Center server
or client machine currently running a 32-bit OS to a 64-bit OS.

Operating System

Windows (qualified on the English version of the operating systems)

Windows Server” 2012 and 2012 R2
Windows Server” 2016
Windows” 7

Linux

Red Hat Enterprise Linux WS and ES v6 and v7
Ubuntu 14

Mac OS X° (remote Extreme Management Center client only)

El Capitan
Sierra

VMware’ (Extreme Management Center Virtual Engine

VMware ESXi™6.0 server
VMware ESXi™6.5 server
vSphere (client only)™

Hyper-V (Extreme Management Center Virtual Engine)

Hyper-V Server 2012 R2
Hyper-V Server 2016

Extreme Management Center Server and Client Hardware

Requirements

These are the hardware requirements for the Extreme Management Center
server and Extreme Management Center client machines:

Extreme Management Center Server

Small Medium Enterprise Large Enterprise
Total CPUs 1 2 2 2
TotalCPUCores 8 16 16 16
Memory 16 GB 32GB 64 GB 64 GB
Disk Size 240GB 480GB 960 GB 1927B
IOPS 200 200 10,000 10,000

Extreme Management Center Client

Requirements

CPU Speed 3.0 GHz Dual Core Processor
Memory 4GB
Disk Size 300MB (User's homedirectory requires 50 MB for file storage)

Java Runtime Environment (JRE) (Oracle Java only)

Version 8

Browser* (Enable JavaScript and Cookies)

Microsoft Edge (version 41.16.199.10000.0 in compatibility mode)
Internet Explorer (version 11in compatibility mode)

Mozilla Firefox (version 34 or later*)

Google Chrome (version 33.0 or later)
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General Information

Extreme Access Control Engine Version Requirements

For complete information on Extreme Access Control engine version
requirements, see the Upgrade Information section of these Installation
Instructions.

Application Analytics Engine Installation Requirements

After installing a version 8.0.1.1SO image on a physical Application Analytics
engine, open the /etc/sysctl.conf file and locate the vim.nr hugepages
row. Remove any number following a decimal point to change the value to a
whole number.

For example, if the sysctl.conf file displays vim.nr hugepages = 2667.67,
change thevaluetovm.nr hugepages = 2667.

Save the file and enter sysctl -pinthe command line to update the engine
with the new configuration.

Running the engine without editing this value results in performance issues.

Screen Resolution

For optimum display of Extreme Management Center windows and tables, the
recommended minimum screen resolution setting for Extreme Management
Center clients is 1024 by 768 pixels. For optimum display of graphs and tables,
the recommended minimum screen resolution setting is 1280 by 1024 pixels.

Evaluation License

If you request a Extreme Management Center evaluation license, you receive an
Entitlement ID. This Entitlement ID allows you to generate a product evaluation
license key. Refer to the instructions included with the Entitlement ID to
generate the license key. Use the key when you install the product.

To install Extreme Management Center using an evaluation license, refer to the
Extreme Management Center Installation instructions for Windows or Linux
contained in this guide.

To upgrade from an evaluation license to a purchased license, see the instruction
in the Upgrading an Evaluation License section.
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Extreme Management Center Services

During the Extreme Management Center installation, you can enable the
Extreme Management Center Services, allowing it to run in the background on
the Extreme Management Center server. The service starts automatically by
default, and if you shut down and restart the machine, the service is restarted
automatically.

You can also restart the services manually or disable a service so it does not start
automatically when you restart the server. For information on how to do these
procedures, see Extreme Management Center Services under the Suite-Wide
Tools User Guide.

The services offered depend on whether your platform is Windows or Linux.

o SNMPTrap Service (Windows and Linux) - Enables SNMP trap messages to be
received and logged when problems or irregularities are detected on network
devices. Only one trap service may be running at a time on a server. If you are also
running a network management system on the server, you may wish to use the
network management trap service.

Windows Users: Windows users should check for and stop any other SNMP trap
service before enabling the Extreme Management Center version (see Stop Other
Services).

e TFTP (Windows and Linux) - Enables you to upload and download configuration
files, and download firmware to devices. Only one TFTP service may be running at a
time on a machine.

NOTE: The Extreme Management Center TFTP Service does not support IPv6.

Windows Users: Windows users should check for and stop any other TFTP service
before enabling the Extreme Management Center version (see Stop Other Services).
Linux Users: Typically, the TFTP service that exists in Linux is disabled; however, if it
is enabled, you may wish to disable it and enable the Extreme Management Center
version of TFTP which provides additional features for Extreme Management Center.
If you elect to enable the Extreme Management Center version on the Linux
platform, you must first disable the Linux TFTP service and perform some
configuration as follows:

1. Using a text editor, edit the file /etc/xinetd.d/tftp

2. Setdisable = yes
Sample file:
service tftp
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Upgrade Information

{ flags = REUSE

socket type = stream

wait = no

user = root

server = /usr/sbin/in.tftp

disable = yes

}
3. Thenrun: /etc/rc3.d/S56xinetd restart

o BOOTP (Windows only) - Enables the Extreme Management Center server to also be
a BOOTP server. This allows the server to supply devices with firmware images (or
other basic identity information) in the event the device's current firmware image
becomes corrupt. Only one BOOTP service can be running at a time on a machine.

o Syslog (Windows only) - Extreme Management Center Console maintains a record
of syslog messages in the Syslog tab of the Event View.

Upgrade Information

Extreme Management Center 8.1 supports upgrades from Extreme Management
Center version 7.1.2 or later. If you are upgrading from a version prior to 7.1.2, you
must perform an intermediate upgrade. For example, if you are upgrading from
Extreme Management Center 7.0, you must first upgrade to Extreme
Management Center 7.1.2 (or later), and then upgrade to Extreme Management
Center 8.1.

IMPORTANT: When performing an upgrade, be sure to backup the Extreme Management Center
database prior to performing the upgrade, and save it to a safe location. Use the
Administration > Backup/Restore tab to perform the backup. Backup functionality is
enhanced in version 8.0 of Extreme Management Center and may function differently
depending on the method used by your version of Extreme Management Center.

When upgrading the Extreme Management Center server, Application Analytics
engine, or Extreme Access Control engine to version 8.1, ensure the DNS server |P
address is correctly configured. Additionally, upgrading requires an internet
connection. If no internet connection is available, see Upgrading a Hardware Engine.

When upgrading the Application Analytics engines to version 8.0.2 after upgrading
from version 6.1to 7.1.2, the upgrade does not complete successfully. To successfully
upgrade the engine to version 8.0.2 after upgrading from version 6.1to 7.1.2, enter
dpkg --purge postgresqgl* inthecommand ling then upgrade the
Application Analytics engine to version 8.0.2.
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Upgrade Information

During the installation you have the option to backup additional user files by
selecting a checkbox on the Previous Installation Detected screen. This option
lets you backup user files such as Inventory Manager archive files not
automatically backed up during the install because the backup could take
several minutes.

Important Upgrade Considerations

If your network is using Application Analytics engines, you must first perform the
Extreme Management Center upgrade to version 8.1 and then upgrade the
Application Analytics engines.

If you are running Data Center Manager (DCM), a Mobile Device Management (MDM)
integration, or other OneFabric Connect or Fusion integration with Extreme
Management Center:

e The OneFabric connect module is disabled on upgrade, and requires a new
version in order to operate with Extreme Management Center 8.1. You must
install an updated module that supports Extreme Management Center 8.1.
Contact your account team for information on obtaining this update.

e You must install a Extreme Management Center Advanced (NMS-ADV) license
with 8.1 when you upgrade. Contact your account team for information on
obtaining this license.

If you are accessing Web Services directly or through OneFabric Connect you need
to install a Extreme Management Center Advanced (NMS-ADV) license. Contact your
account team for information on obtaining this license.

When upgrading a 64-bit Extreme Management Center server or when upgrading
from a 32-bit to a 64-bit Extreme Management Center server, if the -Xmx setting is
set below 1536m, it is increased to 1536m.

Older NetSight licensing keys (starting with INCREMENT) are no longer supported
as of NetSight 5.0 and later. If you have one of these keys, please contact Extreme
Networks Support for license upgrade information.

The 4.xx version of the NAC Request Tool is not compatible with the 8.1 Extreme
Management Center server. If you are using the NAC Request Tool you need to
upgrade the version of NAC Request Tool to version 8.1.
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Upgrading an Evaluation License

To upgrade from an evaluation license to a purchased copy, contact your
Extreme Networks Representative to purchase the software and receive an
Entitlement ID. You do not need to reinstall the software to perform the
conversion.

Prior to installing Extreme Management Center, you should redeem your
Entitlement ID for a product license key. Refer to the instructions included with
the Entitlement sent to you.

If your Evaluation copy has not expired:

1. Open the Administration > Diagnostics > Server > Server Licenses.

2. Inthe tab, click Add.

3. Enter the license text that you received when you generated the product license key.
4

. Click OK. The license file is updated with the new license text.

If you have let your Evaluation Copy expire, when you launch Extreme
Management Center a window opens where you can enter the license text.

Upgrading to Extreme Management Center NAC Manager
8.1

Important Captive Portal Changes

In NetSight 6.0, the NAC captive portal was enhanced to provide a more modern
look and feel. If you have used the custom style sheet, you need to review pages,
as there are likely be changes required to allow the custom styles to display
correctly with the new page layout. After upgrading, Extreme Access Control
administrators should log on to the screen preview page (https://<Extreme
Access ControlenginelP>/screen_preview) of the NAC captive portal to verify
that the portal still looks acceptable for display to end users. If your portal
configuration is limited to setting colors and images, there should be no problem
with the new portal look and feel, although you may want to set some of the new
color options.
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Upgrade Information

General Upgrade Information

When upgrading to Extreme Management Center NAC Manager 8.1, you are not
required to upgrade your Extreme Access Control engine version to 8.1.
However, both NAC Manager and the Extreme Access Control engine must be
at version 8.1in order to take advantage of the new Extreme Access Control 8.1
features. Extreme Management Center NAC Manager 8.1 supports managing
Extreme Access Control engine versions 6.3 and 6.2.

NOTE: NAC 8.1is not supported on the 2S Series and 7S Series NAC Controllers. You cannot upgrade
NAC Controllers to version 8.1, but you can use NAC Manager 8.1to manage controllers running
version 4.3.xx.

You can download the latest Extreme Access Control engine version at the
Network Management Suite (NMS) Download web page
http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx. Be sure to
read through the Upgrading to NAC 8.1 document (available on the Extreme
Management Center (NetSight) Documentation web page > Manuals & Release
Notes > NetSight 8.1 > Network Access Control [NAC]) for important
information.

In addition, if your NAC solution utilizes a Nessus assessment server, you should
also upgrade your assessment agent adapter to version 8.1if you upgrade to
NAC 8.1.

Agent Version for NAC Agent-Based Assessment

If you are using onboard agent-based assessment, be aware that the agent
version is upgraded during the Extreme Access Control engine software
upgrade. If you would like end-systems to update their agent to the new version,
you must configure your assessment test set to test for the new agent version.
Refer to the Upgrade Information section in the Extreme Management Center
Release Notes for the agent version included in the Extreme Access Control
engine software.

Upgrading NAC Reqguest Tool

The 4.xx version of the NAC Request Tool is not compatible with the 8.1 Extreme
Management Center server. If you are using the NAC Request Tool, you need to
upgrade your version of the NAC Request Tool to version 8.1.
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Upgrading to Extreme Management Center 8.1

e Beginningin 51, all Extreme Management Center maps intended to utilize the
advanced map features of wireless coverage and client location triangulation should
be created with a Base Map type of Floor Plan. Extreme Management Center maps
created in NetSight version 4.4 or 5.0 that include both APs and walls are
automatically converted to the Floor Plan Base Map type when the upgrade is
performed. This allows Floor Plan map features to be available for those maps.

e Beginning in 5.1, managed wireless controllers (8.32 or later) are automatically
synchronized to match Extreme Management Center map floor plan data. If the floor
plan data defined in Extreme Management Center maps is not consistent with data
on the controller, the controller is updated accordingly.

Upgrading to Policy Manager 8.1

o Policy Manager 8.1 only supports ExtremeWireless Controller version 8.01.03 and
higher. If you upgrade to Extreme Management Center 8.1 prior to upgrading your
controllers, then Policy Manager does not allow you to open a domain where the
controllers already exist or add them to a domain. A dialog is displayed indicating
your controllers do not meet minimum version requirements and that they must be
upgraded before they can be in a domain.

e Policy Manager 5.0 changed how it handles rule containment VLANs and Role VLAN
Egress VLANSs. This may cause Verify to fail following an upgrade to 8.1. If this
happens, enforce the domain configuration to update the static VLAN table.

o Following an upgrade to Wireless Controller version 8.31 and higher, a Policy
Manager enforce fails if it includes changes to the default access control or any
rules that are set to contain. To allow Policy Manager to modify the default access
control or set rules to contain, you must disable the "Allow" action in policy rules
contains to the VLAN assigned by the role checkbox accessed from the Wireless
Controller's web interface on the Roles > Policy Rules tab. This will allow the enforce
operation to succeed.

Upgrading to Wireless Manager 8.1

Following a Wireless Manager upgrade, you should clear the Java Cache before
starting the Extreme Management Center client.
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Pre-Installation Checklist

Pre-Installation Checklist

Please review the following checklist prior to performing an Extreme
Management Center software installation or upgrade.

o Backup database. If performing an upgrade, be sure to backup the Extreme
Management Center database prior to performing the upgrade. Use the Server
Information window to perform the backup (Tools > Server Information > Database
tab).

« Disable antivirus software. Disable any antivirus software running on the Extreme
Management Center server prior to beginning the installation. Be sure to re-enable
the antivirus software following the install. If you have installed or upgraded
Extreme Management Center on a Windows platform system, follow the instructions
in Configure Antivirus Software before you re-enable the antivirus software.

« Generate your Extreme Management Center product license key. When you
purchased Extreme Management Center, you received a Licensed Product
Entitlement ID for the license that you purchased. This Entitlement ID allows you to
generate a product license key. Refer to the instructions included with the
Entitlement ID to generate the license key. The key will be used when you install the
product.

Extreme Management Center Installation -
Windows

Use the following instructions to install Extremme Management Center on a
Windows platform system where you have administrative rights.

Stop Other Services

If you are using the Extreme Management Center version of SNMPtrap and/or
TFTP service, you cannot be running another version of that service on your
system. If you are running one of these non-Extreme Management Center
services on your system, you must shut it down before installing Extreme
Management Center, as follows:
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Extreme Management Center Installation - Windows

1. Open the Services window on your system (Control Panel > Administrative Tools >
Services).

Scroll down to find the service in the list.

Right click on the service and select Stop from the popup menu.

Right click on the service again and select Properties from the popup menu.
In the Properties window, set the Startup Type for the service to Manual.
Repeat for any other services, if necessary.

Close the Services windows and Control Panel.

Open the Task Manager and check to be sure that the process is not running.

O © N O A N

Close the Task Manager.

Install and Launch Extreme Management Center

1. Download the Extreme Management Center (formerly NetSight) software from the
Network Management Suite (NMS) Download web page
http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx. If you are
installing from a CD, insert the CD into your system's CD drive.

2. Navigate to the NetSight Suite.exe file and double-click it.

3. The Extreme Management Center Installer leads you through a series of windows
that asks for all the information required in order to install Extreme Management
Center. You need the following information for the Installer Program:

o License Text - Enter the license text for the Extreme Management Center
license you purchased. You received the license text when you generated your

Extreme Management Center product license key. If you choose not to enter
the license text during the installation, you are asked to enter it the first time
you launch an individual Extreme Management Center application.

« Service Configuration - Enable and start the Extreme Management Center
Services. (For more information on the services offered on the Windows
platform, see Extreme Management Center Services.)

o Destination Directory - This is the path to your Extreme Management Center
Installation Directory. In the Destination Directory window, click Choose to
navigate to the directory, or type the path in manually.

When you have finished with this series of windows, Extreme Management Center is
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Extreme Management Center Installation - Windows

installed according to your specifications.

4. When the installation is complete, the database and server are started automatically.
You must wait until the Extreme Management Center server has started all its
various server components before you can connect to the server and launch the
Extreme Management Center applications. On the installation screen, you see an
hourglass icon while the server starts its components. When the server is ready for
connections, the installation screen displays a green check.

5. On the installation screen, click on the Show Launch Page link to open the Extreme
Management Center Launch Page. (You can also use the desktop shortcut to open
the Extreme Management Center Launch Page.)

6. The Extreme Management Center Launch Page opens. At the top of the web page
are tabs for the following functions:

o Home - Launch your Extreme Management Center applications by clicking on
the names or icons of any of the listed applications.

o Getting Started - In order to launch your Extreme Management Center
applications, you must have Java Runtime Environment (JRE) 6 (also referred
to as 1.6) or higher installed on your system. This page tells you if you have
met this requirement and provides instructions for installing the Java Runtime
Environment (JRE), if required.

« Administration - Provides access to specific server administration functions
such as client and server diagnostics, server utilities, the server log, and
Extreme Access Control server diagnostics. To access the server diagnostics
and utilities, you will need to login with your username and password. (If the
Extreme Management Center server is a Windows platform system, in the
Username field you must enter a domain name and a username using the
following format; <domain name>\<username>).

7. Verify that you have met the JRE requirement by accessing the Getting Started tab,
and install the JRE according to the instructions on the Install Java tab, if required.

8. Click on the Home tab and launch the desired Extreme Management Center
application by clicking the name or icon.

9. Alogin window appears. Extreme Management Center requires a user login as a way
to restrict access to the Extreme Management Center server, perform audit trails,
and assign user capabilities according to the Authorization Group the user belongs.
It is important to note that when you log in, you are authenticating to the operating
system of the Extreme Management Center server system to which you are
connecting.
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Extreme Management Center Installation - Linux

a. Select the Extreme Management Center server to which you wish to connect.
b. Enter your domain name\username.

c. Enter your password and click OK.

NOTE: Theinitial user to log in must be the user that performed the Extreme
Management Center installation. This is because the Extreme Management
Center server has a single pre-defined user that is the user who performed the
Extreme Management Center installation. On Windows, this is the
domain\username of the person logged in to the Windows system when the
installation was performed. Once the initial user has logged in, additional users
can be defined.

10. The application main window opens.

Configure Antivirus Software

Using antivirus software such as McAfee” on Extreme Management Center
servers installed on a Windows platform system requires special consideration. If
the virus scanning software is used on directories containing MySQL data and
temporary tables, problems can result in both the performance of MySQL and
the virus-scanning software.

After installing or upgrading Extreme Management Center, we recommend you
add the MySQL data and tmp directories (<install directory>\mysgl\data\tmp)
to the virus scanning exclusion list. Refer to your antivirus software
documentation for instructions.

Extreme Management Center Installation - Linux

Use the following instructions to install Extreme Management Center on a Linux
platform system. Please read through the following items before beginning the
installation.

e Theuser performing the installation must be the root user. During the installation
process you can specify another user to launch and run the server, if desired.

o If you areinstalling Extreme Management Center on a Linux system that doesn't
support a GUI, see Performing a Silent Install for information on installing Extreme
Management Center without using its GUI Installation wizard.
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Extreme Management Center Installation - Linux

« Prior to beginning installation, verify that your /etc/hosts file has the local host

name specified. It should have an entry that looks like:
127.0.0.1 localhost

You may encounter a Java exception during the install when becoming the root user
with the su - command. Be sure that your system's root environment has a proper
DISPLAY variable setting. The Installation program reports a Java exception
(InvocationTargetException) if the DISPLAY variable is undefined. If this occurs:

Before using the su - command, set the system display variable to accept a remote
display with the command:

/usr/openwin/bin/xhost +test 111 111

After using the su - command, set the display variable in the environment where the
su - was done.

For Cshell: setenv DISPLAY :0.0

For Korn shell:lexport DISPLAY=:0.0

Preparing for CD Installation

Perform the following steps if you will be installing the Extreme Management
Center software from a CD. The following procedures assume that the CD drive
from which you are installing is physically attached to the system where Extreme
Management Center is being installed.

1.
2.

Insert the Extreme Management Center (NetSight) CD into the CD drive.

Use an xterm where you are logged in as root. (Be sure that your system's root
environment has a proper DISPLAY variable setting. For more information see the
above note.)

3. Using the cd command, cd to the /mnt/cdrom directory.

Using the Is command, check to see if the CD drive is mounted. If no files are listed,
issue the following commands:
mount /mnt/cdrom
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Install and Launch Extreme Management Center

1.

Download the Extreme Management Center (NetSight) software from the Network
Management Suite (NMS) Download web page
http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx.

Use an xterm where you are logged in as root. (Be sure that your system's root
environment has a proper DISPLAY variable setting. For more information see the
above note.)

Start the Installer.

« If you have downloaded the software, cd to the directory where you
downloaded the installer and start the Installer with the following command:
./NetSight Suite <version> install.bin

« If you are installing from a CD, start the installer with the command:
/mnt/cdrom/netsight.bin

The Extreme Management Center Installer leads you through a series of windows
that asks for all the information required in order to install Extreme Management
Center. You need the following information for the Installer Program:

o License Text - Enter the license text for the Extreme Management Center
license you purchased. You received the license text when you generated your

Extreme Management Center product license key. If you choose not to enter
the license text during the installation, you will be asked to enter it the first
time you launch an individual Extreme Management Center application.

« Service Configuration - There are two Service Configuration screens.

o Inthe first screen, you can specify a user other than root to own the
Extreme Management Center server and its supporting files, if desired.
This user becomes the admin user for the server. Select Use existing user
if you already have a user defined on the machine and enter the user
name. Select Create local netsight user if you want to create a new
"netsight” user (netsight is the user name) and enter the password for
this new user. Leave the Use existing user option set to root if you do not
want to specify another user.

o In the second screen, enable and start the Extreme Management Center
Services. (For more information on the services offered on the Linux
platform, see Extreme Management Center Services.)
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Extreme Management Center Installation - Linux

10.

« Destination Directory - This is the path to your Extreme Management Center
Installation Directory. In the Destination Directory window, click Choose to
navigate to the directory, or type the path in manually.

When you have finished with this series of windows, Extreme Management Center is
installed according to your specifications.

When the installation is complete, the database and server are started automatically.
You must wait until the Extreme Management Center server has started all its
various server components before you can connect to the server and launch the
Extreme Management Center applications. On the installation screen, you see an
hourglass icon while the server starts its components. When the server is ready for
connections, the installation screen displays a green check.

On the installation screen, click on the Show Launch Page link to open the Extreme
Management Center Launch Page.

The Extreme Management Center Launch Page opens. At the top of the web page
you will see tabs for the following functions:

o Home - Launch your Extreme Management Center applications by clicking on
the names or icons of any of the listed applications.

o Getting Started - In order to launch your Extreme Management Center
applications, you must have Java Runtime Environment (JRE) 6 (also referred
to as 1.6) or higher installed on your system. This page tells you if you have
met this requirement and provides instructions for installing the Java Runtime
Environment (JRE), if required.

o Administration - Provides access to specific server administration functions
such as client and server diagnostics, and server utilities.

Verify that you have met the JRE requirement by accessing the Getting Started tab,
and install the JRE according to the instructions on the Install Java tab, if required.

Click on the Home tab and launch the desired Extreme Management Center
application by clicking the name or icon.

A login window appears. Extreme Management Center requires a user login as a way
to restrict access to the Extreme Management Center server, perform audit trails,
and assign user capabilities according to the Authorization Group the user belongs.

a. Select the Extreme Management Center server to which you wish to connect.

b. Enter your username.
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c. Enter your password and click OK.

NOTES: The initial user to log in must be the user that performed the Extreme
Management Center installation, which is either root or the user defined in the
Service Configuration screen during the installation. This is because the Extreme
Management Center server has a single pre-defined user. Once the initial user
has logged in, additional users can be defined.

The password for the root user does not expire. To configure the password to
age so it expires after 60 days, see How to Configure Your Password to Expire.

1. The application main window opens.

Performing a Silent Install

If you are installing Extreme Management Center on a Linux system that doesn't
support a GUI, you must add the cli flag (--cli) to the install command, in order
to allow the Extreme Management Center installer to prompt for any required
input.

Start the installation with the following command:
./NetSight Suite <version> install.bin --cli

If you are installing as a user other than root, you must use the --user coommand
to specify the different user. The user must already be configured on the
machine before you install. For example:

./NetSight Suite <version> install.bin --cli --user <username>

To perform the install and create a new local "netsight” user (where netsightis
the user name), use the --password command to set the password for the new
"netsight” user. For example:

./NetSight Suite <version> install.bin --cli --password
<password>

Restoring a Database from a Windows Server to a Linux
Server

This section describes several Extremme Management Center configuration
changes required if you are moving your Extreme Management Center
installation from a Windows platform system to a Linux platform system. The
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steps are performed after restoring your database to the new server. (For
information on restoring a database, see the Server Information help in the
Extreme Management Center Suite-Wide Tools User Guide.)

When restoring a saved database to a new Extreme Management Center server
installation, any memory or database configuration changes on the original
server require a manual change on the new server in order to replicate the
configuration of the original Extreme Management Center server.

o Changes to the default -Xmx memory settings in the
<install directory>\services\nsserver.cfg file need to be duplicated on the new
server when the database is restored. To change the memory setting to match the
previous server, stop the Extreme Management Center server and edit the
nsserver.cfg file.

o The mySQL my.ini file also need to be manually updated to match any changes made
on the original server. For instructions on modifying the my.ini file, see the Change
the MySQL my.ini File section in the NAC Deployment Guide.

In addition, there are two changes that must be made in the legacy Console java
application and one change in the legacy Inventory Manager application.

Console

Use the following instructions to change the location of syslog and trap
information to the new location on the Linux system.

Syslog

Change the Syslog Log Manager to point to the new location on the Linux
system. This allows the display of syslog information in the Syslog Event View
tab.

1. From the Console menu bar, select Tools > Alarm/Event > Event View Manager.

2. Click on the Syslog entry under Available Log Managers, and click the Edit button.
The Log Manager Parameters window opens.

3. Change the path in the Log Directory field to /var/log/syslog.
4. Change the Pattern to Red Hat LINUX Syslog Pattern.
5. Click OK.
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Traps

Change the Traps Log Manager to point to the new location on the Linux
system. This allows the display of trap information in the Traps Event View tab.

1. From the Console menu bar, select Tools > Alarm/Event > Event View Manager.

2. Click on the Traps entry under Available Log Managers, and click the Edit button.
The Log Manager Parameters window opens.

3. Change the path in the Log Directory field to %logdir%/traps.
4. Click OK.

Inventory Manager

If you are using Inventory Manager, you need to change the Data Storage
Directory path to point to the new location on the Linux system. The Data
Storage directory is where all Inventory Manager data is stored, including
capacity planning reports, configuration templates, archived configurations, and
property files.

1. From the Inventory Manager menu bar, select Tools > Options. Expand the Inventory
Manager options folder and select Data Storage Directory Path.

2. Change the path to the correct new location. On a default Linux install, the path
would be: <user's home directory>/appdata/InventoryMgr

3. Click OK.

Systems with Multiple NICs

This section provides instructions for configuring Extreme Management Center
servers with multiple NICs (Network Interface Cards). During the startup
process, the Extremme Management Center server automatically binds to the first
available NIC, which may not be the correct interface for the server to use. In
addition, changes on the network can cause the server to bind to an incorrect
interface, should the server restart during a change.

If the system has multiple NICs installed, it is a good practice to either:

o configure the server to bind to a preferred IP address, if using only one interface for
connections or

19 of 23



Systems with Multiple NICs

o configure multiple network interfaces, if using more than one interface for
connections.

This ensures that local and remote clients, as well as Extreme Access Control
engines, are able to connect to the Extremme Management Center server.

Binding to One Interface

If the Extreme Management Center server has multiple NICs installed but only
one interface is used to access Extreme Management Center, use the following
instructions to configure the preferred interface for the Extreme Management
Center server.

On Windows systems, you will need to set the binding order of the network
interface cards and configure the Extreme Management Center server to bind to
the correct address. On Linux systems, you need to configure the Extreme
Management Center server to bind to the correct address.

Windows Systems

Set the binding order of multiple network interface cards and configure the
Extreme Management Center server to bind to the correct IP address. These
steps may vary depending on your operating system.

1. Open the Network Connections window:

a. Click Start> Run.
b. Enter ncpa.cpl and click OK.

The Network Connections window opens. You can view the available connections in
the LAN and High-Speed Internet section of the window.

2. From the Network Connections window menu bar, select Advanced > Advanced
Settings. The Advanced Settings window opens.

3. The Adapters and Bindings tab lists the connections in the order in which the
connections are accessed by network services. The NIC that the Extreme
Management Center server connects to must be first in the list. You can use the
arrow buttons to change the binding order.

4. Open the .netsight file. Edit the line JBOSS HOSTNAME=<server IP> to add
the correct NIC IP address. (On Windows Server 2008 and Windows 7, the file is
located at C:\ProgramData\Extreme Networks. On Windows Server 2003, the file is
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located at C:\Documents and Settings\All Users\Application Data\Extreme
Networks.)

5. Restart the Extreme Management Center server.

Linux Systems

Configure the Extreme Management Center server to bind to the correct IP
address.

1. Openthe /var/Extreme Networks/.netsight file. Editthe line JBOSS
HOSTNAME=<server IP>toadd the correctNIC IP address.

2. Restart the Extreme Management Center server.

Configuring Multiple Interfaces

If the Extremme Management Center server has multiple NICs installed and you
need to access Extreme Management Center on multiple interfaces, use the
following instructions to configure multiple network interfaces for the Extreme
Management Center server.

1. On the Extreme Management Center server, add the following text to the
<install directory>/appdata/NSJBoss.properties file. In the second to last line,
specify the hostname of the Extreme Management Center server.
# In order to connect to a NetSight server behind a NAT fi
rewall or a
# NetSight server with multiple interfaces you must define
these two
# variables on the NetSight server. The java.rmi.server.ho
stname
# should be the hostname
(not the IP) if multiple IPs are being used
# so that each client can resolve the hostname to the corr
ect IP that
# they want to use as the IP to connect to.
java.rmi.server.hostname=<hostname of NetSight server>
java.rmi.server.uselLocalHostname=true

2. Save thefile.

3. Add the Extreme Management Center server hostname to your DNS server.
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NOTE: Multiple interface support has been added to provide support for clients accessing the Extreme
Management Center server in a configuration where the primary Extreme Management Center
interface may not be accessible/routable to remote clients, such as in an MSSP environment.
This support provides for both visibility and management of network devices for clients
accessing Extreme Management Center from an additional interface, however some
functionality may be limited. For example, TETP configuration and firmware management of
devices located off a second Extreme Management Center interface may not function properly.

Remote Client Launch

Extreme Management Center is a web-based application you access from the
Extreme Management Center Login page. Remote Extreme Management Center
clients can use the following steps to access the Extreme Management Center
Launch Page and run Extreme Management Center applications from the
remote client machine.

1. Open a browser window and enter your Extreme Management Center information as
a URL in the following format:

http://servername:8080/

where servername is the Extreme Management Center server's IP address
or hostname, and 8080 is the required port numlber. For example,

http://10.20.30.40:8080/

2. The Extreme Management Center Login page opens.

Extreme Management Center requires a user login as a way to restrict access to the
Extreme Management Center server, perform audit trails, and assign user capabilities
according to the Authorization Group the user belongs. It is important to note that
when you log in, you are authenticating to the operating system of the Extreme
Management Center server system to which you are connecting.

3. Enter your username if you are authenticating to a Linux platform server or enter
your domain name\username if you are authenticating to a Windows platform
server.

4. Enter your password and click Login.

5. The application main window opens.

The first time you log in, the embedded help window displays the Getting Started
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NOTE: User preferences and application data (such as FlexViews and MIBs) for remote clients are
stored in the following local directory on the client machine: C:\Documents and
Settings\<username>\Application Data\NetSight.

Uninstalling Extreme Management Center

Use the procedures below to uninstall your Extreme Management Center Suite
of products. The uninstall removes all Extreme Management Center data from
the database. Be sure to backup your database prior to uninstalling.

Uninstalling on Windows
From the Start menu, select Programs > Extreme Networks
> NetSight > Uninstall.

Uninstalling on Linux

Navigate to the <install directory>/uninstaller directory and start the Uninstaller
by issuing the command:
./uninstall.sh

Extreme Networks Support

If you require assistance, contact Extreme Networks Global Technical Assistance
Center using one of the following methods.

Web www.extremenetworks.com/support/

Phone 1-800-872-8440 (toll-free in US. and Canada) or 1-603-952-5000
For the Extreme Networks Support phone number in your country:
www.extremenetworks.com/support/contact/

Email support@extremenetworks.com
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