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A3 Installation and Usage Guide

No Registration VLAN Version

This document is the Installation and Configuration Guide for the A3 system. It includes installation
and usage instructions for A3 version 4.0.0 or later.

There are two versions of this manual, one using a registration VLAN and one with no registration
VLAN. This is the version for no registration VLAN. Further detailed usage instruction is included in
the online help that accompanies the A3 administrative GUI.
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Introduction

Overview

A3 provides complete functionality for securing, managing and controlling all devices on
your access network — from standard wired and wireless clients, to loT and BYOD clients.

A3is a mature software system for NAC (Network Access Control) used to control network
access for client and loT devices. It includes a captive portal for registration and
remediation, centralized management for wireless and wired networks, and 802.1X
support. A3 integrates with IDS (Intrusion Detection Systems), vulnerability scanners, and
firewalls. It scales well can be used for very large heterogeneous networks.

Major Features of A3

Web-based Management

A3's weh-based management provides easy access to all of its features. No command line
interface is required.

Cloud-based Management

The A3 GUI is available in Extreme Networks’s cloud management system. All A3
installations associated with a cloud account can be remotely managed.

Clustering

Multiple A3 instances can be used as an integrated A3 cluster that provides load
balancing, redundancy, and fail-over.

Wired and Wireless Integration

Wired and wireless networks are handled uniformly by A3 using the same CWP (captive
portal) and user database. APs (Access Points), wireless controllers, and switches from
multiple vendors may be used in the same controlled network.

Guest Access

Guest access is easily configured based on CWP-based authentication with a variety of
techniques, including no authentication, email, SMS, and social media.
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Major Features of A3
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Introduction

802.1X Support
802.1X authentication is supported through the embedded FreeRADIUS software module.

Permanent Registration

A3 automatically determines which client devices have been registered and optionally
allows them continued network access without re-authentication. Such registrations can
be automatically ended, for example at the end of a school term.

Security Events

Abnormal network activity, including computer malware, prohibited, and exceeded limits
traffic can be detected using remote sensors.

Proactive vulnerability scans can be performed on registration, scheduled, or on an ad-
hoc basis. A3 correlates scan engine vulnerability IDs to the specific vulnerability, offering
content-specific web pages for each found vulnerability.

A3's security event manager integrates events from multiple sources with customized
alerting, reporting, isolation, and remediation actions.

Firewall Integration

SSO0 (single sign-on) integration is supported for several model firewalls. Upon successful
registration, A3 can dynamically update a firewall's IP to client association. The firewall
can apply per-user or per-group filtering policies.

VolP (Voice over IP) Support

VolP, or IPT (IP Telephony) is fully supported in heterogeneous environment for multiple
switch vendors including Cisco, Avaya, and HP.

Virtual System Support

A3 provides OVA and HYPERV virtual images supported by a wide variety of virtualization
systems, including Microsoft HYPERV.

A3 Installation and Usage Guide Community 2
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Deployment Modes

Overview

There are several modes of deploying A3 within a network. The deployment mode often
dictates the type of A3 Enforcement Modes possible. Two classes of deployment are used
with A3 depending on how unregistered clients are isolated prior to authentication:

* Isolation through a registration VLAN. Unregistered clients are associated with a
unique VLAN that is not routed beyond the network that connects A3 to access
devices. When working with a registration VLAN, two deployments are generally
used:

e layer 2 Hybrid Out-of-Band Deployment - connects access devices to A3 within a
single Layer 2 network.

e layer 3 Across a Routed Network - connects a remote Layer 2 set of access
devices to an A3 via Layer 3 connections.

¢ Isolation through firewall rules. Unregistered clients are restricted from accessing
the general network by firewall rules enforced in the access device. All authentication
required devices are connected through Layer 3 networks. A single deployment mode
is used:

e Layer 3 Hybrid Out-of-Band Deployment

This version of the Installation and Usage manual discusses deployments that do not utilize
a registration VLAN.

Layer 2 Hybrid Out-of-Band Deployment

Part Number:

Layer 2 hybrid 00B (out-of-band) deployments requires that all of the elements in network
access control be connected through layer 2 networks. This means that VLANs must be
pushed from the core to the access networks, which can be an issue for larger network
deployments. A Layer 3 Across a Routed Network deployment may be a better choice.

To ensure correct IP and VLAN assignments, A3 must receive all client DHCP and DNS
requests. In layer 2 deployments, this is accomplished by connecting the A3 server to the
access point via a switch. A3 receives DHCP requests and responds with an IP address on
the local registration or isolation network. A3 also responds with its own IP address as the
DNS server and the default gateway.

This deployment mode is shown in the figure below. An Extreme Networks AP is used in
this figure, but an access switch or other intelligent network device can be used. This
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Layer 3 Across a Routed Network Deployment Modes

deployment model may be used with VLAN, Web Auth, and RADIUS enforcement as
described in Enforcement Modes.

Wireless client Access point Access switch L3 switch/router

)))
g 4 / \
=

Uses DHCP, DNS,
HTTP and HTTPS

DHCP, DNS
RADIUS A3
Management VLAN
— Guest VLAN HTTP/HTTPS
Reg/ISO VLANs
----- Logical

Layer 3 Across a Routed Network

This deployment mode allows for complete, fine-grained network control and scales better
than Layer 2 Hybrid Out-of-Band Deployment mode. This is the most common deployment
model for A3.

A3 may be hosted in a data center in a layer 3 deployment. Clients and their access
devices can be remotely located from A3 as long as the latency between clients and the A3
servers is under 5 ms. VPN access can be used between sites for added security.

This deployment mode is shown in the figure below. An Extreme Networks access pointis
used in this figure, but an access switch or other intelligent network device can be used.
This deployment model may be used with VLAN, Web Auth, and RADIUS enforcement as
described in Enforcement Modes.

Access point Access switch L3 switch/router

Wireless client

-

——=

DHCP relay

agent
Uses DHCP, DNS, I
HTTP and HTTPS |
| DHCP, DNS
RADIUS == mmm e e e m A3
Management VLAN
— Guest VLAN HTTP/HTTPS

Reg/ISO VLANs
——— DHCP requests
----- Logical

DHCP requests on the local registration or isolation network are forwarded to the A3
server on a remote network using a DHCP relay agent. Although DHCP relay agents may be
enabled on an access point or access switch, best practice is to run it on a member of the
larger layer 3 network. The relay agent receives layer 2 DHCP requests, encapsulates
them in layer 3 packets and transmits them using the L3/VPN network to A3.

The steps needed to use A3 in a routed network are:
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Layer 3 Hybrid Out-of-Band Deployment

Deployment Modes

1. Define routed networks for interfaces in A3.

2. Setup up a DHCP relay on the L3 switch/router connected to A3.

3. Configure firewall rules on the access point or access switch to limit client access to

A3 and required services.

An example of a Layer 3 configuration is available in the Initial A3 Configuration chapter.

Layer 3 Hybrid Out-of-Band Deployment

Layer 3 hybrid 00B (out-of-band) deployments are a new means of connecting
authenticating clients. As opposed to earlier techniques a registration VLAN is not
required and Layer 2 connectivity between clients and A3 is likewise not required. The A3
server and access point or switches need only have Layer 3 connectivity.

This deployment mode is shown in the figure below. An Extreme Networks AP is used in
this figure, but an access switch or other intelligent network device can be used. This
deployment model may be used with VLAN, Web Auth, and RADIUS enforcement as
described in Enforcement Modes.

Wireless client Access point

e

Uses DHCP, DNS,
HTTP and HTTPS DHCP, DNS

RADIUS
HTTP/HTTPS

Management VLAN
----- Logical

DNS
DHCP

L3 switch/router

\f}
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Inline Deployment

Deployment Modes

Inline Deployment

Part Number:

In an inline deployment A3 acts as the router that connects devices to the enterprise's
internal networks and the internet. An inline deployment is shown below.

Access point

< —~—P

Wireless client

Uses DHCP, DNS,
HTTP and HTTPS

Management
Access
Registration

All devices connect through the A3 server. Unregistered devices connect to A3, which
assigns an IP address. Web traffic is directed to the internal CWP while all other traffic is
blocked. Clients are registered through the CWP as in other forms of enforcement, and are
granted access through the internal IPtables and IPSet facilities.

This deployment mode does not scale very well, as all network traffic must go through the
A3 server. Further, the A3 server hecomes the single point of failure for the network as
clustering is not supported. For these reasons, this deployment mode is not supported with
A3.
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Enforcement Modes

A3 may be used with a number of enforcement mechanisms to implement network access
control. The techniques describe here are:

e  Firewall Enforcement - using access device firewall rules clients use A3's embedded
web portal or other authentication mechanisms. Clients are assigned to distinct
networks by the access device.

e WebAuth Enforcement - clients use a captive web portal hosted by A3, a switch or
other device. Although clients can be assigned to distinct VLANS, this form of
enforcement is generally used for a go/no-go access decision.

e RADIUS Enforcement - A3 acts as a RADIUS server for an access device. A3
responses are used to implement VLAN-based, ACL-based, or firewall-based access
control.

e WebAuth (ACL) Enforcement - A3 is used as in VLAN enforcement, but A3 writes new
ACL (access control list) elements to the access switch.

Firewall Enforcement

In this Layer 3 mode, new clients attempting to first associate with a network are restricted
by their access device via firewall rules. The firewall rules allow access to the A3 server
and the local DHCP and DNS servers, but redirects any web (HTTP or HTTPS) traffic to A3's
CWP.

The client steps through the registration process with A3, which provides the access
device information used to assign a new set of firewall rules or VLAN to the client that
implement appropriate network access.

In this configuration, clients are restricted to communication with the A3 server until they
have been registered and authenticated in A3, at which point they are allowed access to
the general network. The A3 software, with its included RADIUS server, is used to
authenticate clients. A3 serves as the secure access server using information from the
supporting databases and networking devices to allow or deny clients access. Clients
allowed access can be further restricted by VLAN, firewall rules, and QoS settings
orchestrated by A3.

Firewall enforcement is used for all of the use cases in this guide.

WebAuth Enforcement

WebAuth enforcement, also known as E-CWP (external captive web portal) is illustrated in
the figure below.
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RADIUS Enforcement Enforcement Modes

(\

/\‘1\\
Traffic I

1 él !
I 1 !
1 Registration 1 |
1 [] M
: : Approved + VLAN ',
! Traffic I '

>

In this mode, the registration process uses A3 as an E-CWP. The client authenticates
through the portal, where A3 indicates success or failure, and assigns a new VLAN.
Several restrictions apply when used with Extreme Networks equipment:

1. The E-CWPis setupinanaccess policy in ExtremeCloud I1Q. This process is described
in the Use Case 6: Guest Access with External Captive Web Portal.

2. Only asingle ExtremeCloud 1Q access policy is applied.

3. Some external A3 authentication sources may not work.

4. Role by VLAN ID must be used in Network Devices roles in A3.

An example of WebAuth enforcement usage is at Use Case 6: Guest Access with External
Captive Web Portal.

RADIUS Enforcement

RADIUS enforcement is illustrated in the figure below.

/\

RADIUS
RADIUS + Attibutes

>

In this mode, A3 acts as a RADIUS server with and may optionally be used as a captive
web portal. A3 returns roles or VLANs via RADIUS attributes, which the switch uses to
allow or restrict access.
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WebAuth (ACL) Enforcement Enforcement Modes

WebAuth (ACL) Enforcement

WebAuth (ACL) enforcement is illustrated in the figure below.

Write ACL

>

In this mode, the switch ACLs (access control lists) restrict initial traffic through the switch
and redirect the client to A3 for authentication using a captive web portal. If the

authentication is successful A3, writes new ACLs to the switch that allow appropriate
traffic based on the client's role.
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Equipment Requirements

A computer system that meets the following requirements is needed to install and operate

A3.

VMware VSphere Hypervisor

VMware VSphere Hypervisor (ESXi) may be used with an x86-based host. ESXi
requirements include a host:

1.
2.
3.
4.

Running ESXi version 6.0 or higher
4 or more cores
16GB or more RAM

250GB or more storage

Administrative access to an ESXi host is also required. If the host is included in a vCenter
domain, then access to that domain will be needed as well.

Microsoft Windows Server 2019

An x86-based host running Microsoft Windows Server 2019 with a Hyper-V role may be
used. The host requirements include:

1.

2
3.
4

Running Microsoft Windows Server 2019 with a Hyper-V role defined.
4 or more cores
16GB or more RAM

250GB or more storage

Extreme Networks Requirements

If Extreme Networks APs are used in the network then the following is also needed:

1.
2.

3.

Extreme Networks APs must run version 10.41 software or higher.

ExtremeCloud 1Q is a configuration platform for Extreme Networks access points. Self-
registration for a ExtremeCloud 1Q account is available at https://extremecloudig.com.

An Extreme Networks Community login provides access to the latest A3 software.

Extreme Networks related logins may be obtained from your Extreme Networks sales
manager or other Extreme Networks employee.
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Download the Software

Installation

Download the Software

An OVA file with the A3 software and Linux operating system is available through the
Extreme Networks Support Portal. Search for “A3”. Versions of A3 will be highlighted by a

& symbol.

A3 Installation on VMware ESXi

Network Interfaces

Instantiation

Part Number:

Note the ESXi resource requirement detailed in Equipment Requirements. The ESXi web
management interface is used to initialize a virtual machine and start A3. vSphere-based
operation is similar, but not covered here.

There are two basic choices for the registration and isolation VLAN interfaces. These
choices affect the virtual interfaces that are presented to the guest 0S, and not the
physical ports on the actual VMware host.

e One virtual Ethernet interface. In this instance, all VLANs are connected to A3 on one
virtual interface inside the VM. This deployment is more common in smaller networks,
or labs. A LAN port group is defined in vswitch0 as a trunk that allows trunking of the
VLANSs associated with management, registration, and isolation in A3.

e Multiple virtual Ethernet interfaces. This deployment option is more common in larger
VMware environments where a management port group has already been established
and new VLANSs will avoid affecting other VMs that are also using that same port
group. For example:

¢ An A3ManagementNetwork port group can be defined in vswitch0, tagged with
the management VLAN. Referring to Table of Addresses and VLANSs, this guide
uses VLAN 1 (V1).

The virtual machine may be instantiated by following these instructions:
1. Login to the ESXi web management interface.

2. Click Create/Register VM and select Deploy a virtual machine from and OVF or VA
file.

3. Click Next and name the virtual machine. This is not the name of the A3 system, only
how ESXi will refer to the virtual machine.

4. Click in the box below the name to select the name of the OVA file that you
downloaded. See Equipment Requirements for instructions on finding and
downloading the appropriate OVA.

ol

Click Next. Select a datastore from your system that has at least 250GB free.
6. Click Next. Select:

a. Network mappings: Check that your assigned port group(s) are configured as
discussed in Network Interfaces above.

b. Disk provisioning: Thick.
c. Power on automatically.
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7. Click Nextto review your settings.
8. Click Finish to start the installation.

9.  When the installation is finished, you can navigate to your A3 virtual machine under
Virtual Machines to view the VM settings.

10. Click the black box to open the browser console window. If the display appears as
below, then A3 has not been assigned a DHCP address from your network and you
must set up A3’s basic networking yourself.

Welcome to A3.

In ord to configure your A3 installation, please connect to the following URL:

https:s/:1443

A3 login:

a. Fromthe console, enter:

Username: netcfg

Password: aerohive

b. Enter ? to see the basic help screen.

A3 login: netcfg

elcome netcfg it is Thu May 2 21:39:88 UTC Z819

Display an overview of the CLI syntax
logout console

some utility commands for network related details
Ping

Reboot the system

show system related details

c. Enterthe following commands to set up your network using parameters
applicable to the network that A3 is installed in.

network ip 10.150.1.4

network netmask 255.255.255.0
network gateway 10.150.1.1
network dns 10.150.1.5

show network

d. Verify your settings in the display.
e. Enterthe following:

reboot

y
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11. The display should appear as below. Note the address shown in that window. This is
the IP address assigned to the A3 instance by DHCP from your assigned server or
manually in step 10. This will be changed during initial configuration.

B A3

ent0S Linux release 7.4.1788 (Core)

[System ID: 2495-6284-EEAS-843D-C6AA-381B-FEZ9-32841

[Kernel 3.18.8-693.11.6.e17.xB6_64 on an xB6_64
elcome to A3.

In order to configure your A3 installation, please commect to the following URL:
http=s:-~-18.158.1.173:1443

A3 Installation on Windows Server 2019 Hyper-V

Note the Hyper-V resource requirement detailed in Equipment Requirements. The Hyper-V
Manager is used to install A3.

Network Interfaces

A3 must be attached to an “External” type of virtual switch. An external virtual switch binds to the physical network
adapter so that the virtual machine can access a physical network.Installation
A3 may be installed by following these instructions:

1. Download an A3 Hyper-V release image, for example A3-HYPERV-4.0.0-6.zip, from the
Extreme Networks support site. Unzip the file into a folder, for example C:tmp\A3-
HYPERV.temp.

Invoke the Hyper-V Manager.
Select Import Virtual Machine from the Actions panel.

Select Next >.

o B w N

Select a folder with the virtual machine to import. For example C:\tmp\A3-
HYPERV.temp.

6. Select Next>.

7. Inthe Select Virtual Machine step, select the virtual machine to import, which must
have been previously created. For example, A3-HYPERV.

8. Select Next>.

9. Inthe Choose Import Type step, select Copy the virtual machine (create a new unique
ID).

10. Select Next >.

11. Inthe Choose Folder for Virtual Machine Files step, check the Store the virtual
machine in a different location check box.

12. Select the first Browse... button, and then navigate to a folder for use in holding the
VM files. For example, c:tmp\hyper-w\. Copy and past this value into all three fields.

13. Select Next >.
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A3 Installation on Windows Server 2019 Hyper-V Installation

14. Inthe Choose Folder to Store Virtual Hard Disks step, select the Browse... button and
navigate to a folder to hold the disks. For example, c:tmp\hyper-Wdisks\

15. Select Next >.

16. In the Completing Import Wizard step, review the settings.
17. Select Finish.

18. The Hyper-V Manager will import the image.

19. When complete, the virtual machine will appear on the main Hyper-V Manager
display.

20. Select Edit Disk... from the Actions panel.

21. Select Next >.

22. Inthe Locate Virtual Hard Disk step, select Browse...

23. Navigate to a3-disk2.vhd in the folder where disks were specified in step 14.
24, Select Open.

25. Back in the Locate Virtual Hard Disk step, select Next >.

26. Inthe Choose Action step, select Convert.

27. Select Next >.

28. Inthe Convert Virtual Hard Disk, Choose Disk Format step, verify that VHD is selected.
29. Select Next >.

30. Inthe Convert Virtual Hard Disk, Choose Disk Type step, select Fixed size.
31. Select Next>.

32. Inthe Convert Virtual Hard Disk, Configure Disk step, select Browse...

33. Navigate to the folder with the disks (c:\tmp\hyper-Wdisks\in this example) and select
a3-disk2.vhd.

34. Inthe File name field at the bottom of the dialog, change the name to a3-disk2-fix.vhd.
35. Select Save.

36. Back in the Convert Virtual Hard Disk, Configure Disk step, verify that the Name: field
contains the renamed disk (c:tmp\hyper-Wdisks\a3-disk2.vhd).

37. Select Next >.

38. Inthe Completing the Edit Virtual Hard Disk Wizard, Summary step, verify the
conversion from a VHD dynamically expanding disk to a VHD, fixed size disk.

39. Select Finish.
40. The wizard will now convert the disk. This can take several minutes.

41. When the process is complete, the main page for the Hyper-V Manager will be
displayed.

42. Selectthe A3-HYPERV virtual machine in the top list. The details for the VM will be
displayed in a panel entitled with its name.

43. In the Actions panel, under the A3-HYPERV title. Select Settings...

44. Inthe Hardware section of the Settings page, under SCSI Controller, select the Hard
Drive named a3-disk2.vhd.

45. Select Remove. There should be no change in the display.
46. Under Virtual hard disk:, select the Browse... button. Select the a3-disk2-fix.vhd disk.
47. Select OK.
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48. Back in the main Hyper-V Manager window, right-click on the A3-HYPERV machine
and select Connect...

49. Inthe A3-HYPERYV on ... - Virtual Machine Connection window, select Start from the
Action menu.

50. The A3 instance will start.

51. If the display appears as below, then A3 has not been assigned a DHCP address from
your network and you must set up A3’s basic networking yourself.

Welcome to A3.

In ord to configure your A3 installation, please connect to the following URL:
https:/s:1443

A3 login:

a. Fromthe console, enter:

Username: netcfg
Password: aerohive

b. Enter ? to see the basic help screen.

A3 login: netcfg

elcome netcfg it is Thu May 2 21:39:88 UTC Z819

Display an overview of the CLI syntax

logout console

some utility commands for network related details
Ping

Reboot the system

show system related details

c. Enterthe following commands to set up your network using parameters
applicable to the network that A3 is installed in.

network ip 10.150.1.4

network netmask 255.255.255.0
network gateway 10.150.1.1
network dns 10.150.1.5

show network

d. Verify your settings in the display.

e. Enterthe following:

reboot

y
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52. The display should appear as below. Note the address shown in that window. This is
the IP address assigned to the A3 instance by DHCP from your assigned server or
manually in step 10. This will be changed during initial configuration.

B A3

ent03 Linux release 7.4.1788 (Core)

[System ID: 2495-6284-EEA5-843D-C6nAA-381B-FEZ9-32841
[Kernel 3.18.8-693.11.6.e17.xB6_64 on an xB6_64

elcome to A3.

In order to configure your A3 installation, please commect to the following URL:
http=s:-~-18.158.1.173:1443
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Network Topology

Connectivity and Security

A3 interfaces with many connectivity and security devices, as shown below.

1nitI=9
HInI=0

HiveManaEer Directory Server

Posture
Assessment

Clients Access Network

The pictured components are:

1. Clients - networked devices, including computers, phones, tables, and headless loT
(Internet of Things) devices. Clients access an organization’s networks through the
access network.

2. Access network - one or more devices that serve to connect clients to networks.
Access networks enforce security policies governing who is able to connect to what.
The devices used in this capacity are discussed below in Enforcement Devices.

3. Extreme Networks A3 - software that works with other components to enforce
access and security policy. Of critical importance in the manner in which A3 connects
to and controls the access network.

4. DS - intrusion detection systems watch clients and network traffic to detect unusual
network activity. A3 uses alerts from IDS systems to trigger security events that can
isolate clients and send alerts.
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Enforcement Devices

Network Topology

5. Firewall - firewalls control connections between networks. They can be used to limit

client access to parts of the internal network through VLAN assignment, IP address

restriction, or other means. A3 can send user identity information to firewalls to
implement single sign-on.

6. Cloud control (ExtremeCloud 1Q) - cloud-based control of network devices has

become the gold standard for network administration. Most network device vendors

offer a cloud and web based system. Pictured here, Extreme Networks's
ExtremeCloud 1Q is used to configure all Extreme Networks devices.

7. Directory server - one or more servers that are used to hold user and device identity

information. LDAP (Lightweight Directory Access Protocol) compatible servers,
including Microsoft's Active Directory, are the most common type.

8. MDM (Mobile Device Management) - central management systems used to

configure, update, and control client devices. These are responsible for ensuring that
the correct, updated software is installed on clients. A3 can request client status from

such system, restricting client access.

9. Posture assessment - scanning tools that evaluate client acceptability for network
access. Posture assessment tools can ensure that up-to-date software is installed
and whether client systems manifest any security vulnerabilities.

Enforcement Devices

Part Number:

A3 registers and authenticates clients, but enforcement devices ensure that clients are
allowed or denied network access with appropriate restrictions. For example, a facility

guest may be granted Wi-Fi access to the internet. An organization’s employees may be
assigned to networks appropriate for their jobs: engineering, management, finance, etc.

A3 inter-operates with different classes of enforcement devices:

*  Wi-Fi access points with integrated controller. These devices allow Wi-Fi enabled
devices to connect to a wired network while controlling that access. Extreme
Networks access points fit in this category; their usage with A3 is described in this
guide and in the ExtremeCloud I1Q documentation.

*  Wi-Fi access points using a separate controller. The access points provide
connectivity and control access using the controller for decision making. A3
communicates with the controller to perform its functions.

* Intelligent switches. These devices enforce access on wired connections. Multiple

clients connected to switch ports can be individually controlled. Wi-Fi clients
connected to access points that have no controller function can be individually
registered and authenticated.

e Other devices. Security appliances such as Cisco ASA can perform registration and

authentication in conjunction with A3.

Extreme Networks access point usage with A3 is described in this guide and in the
ExtremeCloud 1Q documentation. All other supported devices are describe in the A3
Network Devices Configuration Guide.
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Infrastructure Devices

Network Topology

Infrastructure Devices

Layer 3 Topology

Several other infrastructure devices are critical components of an A3-based system:

Switches. Switches connect the various network components. Unmanaged switches
can be used to connect A3 to other network components, but managed switches are
preferred. A managed switch can be used to isolate clients on the registration and
isolation networks from any elements that they should not be accessing.

Routers. Routers connect networks together. When used with A3 they are used to
connect the registration, isolation, and other networks used during authentication
with the larger network. Routers can also be used as managed switches in smaller
networks.

DHCP Servers. DHCP servers provide clients with network addresses during client
startup. Unless a client has been assigned a static address, they will broadcast a
request to any available DHCP server. During registration A3 serves as the DHCP
server, providing an IP address, gateway, and DNS server address(es).

DNS Servers. DNS servers provide name to IP address mapping. During registration
clients use A3's DNS server, which redirects them to the captive web portal and allow
them access to limited external servers used for authentication.

Email. Email messages are sent from A3 for administration, security events, and
several types of registration. Email servers can be external or internal, but must
always be publicly accessible.

Wireless client

e

Uses DHCP, DNS,
HTTP and HTTPS

Management VLAN
----- Logical

Part Number:

The A3 Layer 3 topology is straightforward and is shown below.

DNS
DHCP
Access point — L3 switch/router
D
\ -
DHCP, DNS
RADIUS A3
HTTP/HTTPS

The figure uses a wireless client and Extreme Networks AP, but the concepts apply equally
well with Wi-Fi access points and wireless controllers or wired computers and an
intelligent switch. Physical connections are pictured as solid line, while logical
connections are shown as dashed lines.

A single management VLAN is used to register clients. The access device is configured to
work with a local DNS and DHCP server. The access device and the A3 server have Layer
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Layer 3 Topology

Part Number:

Network Topology

3 connectivity. Following authentication, one or more other VLANSs or firewall rule sets may
be used to provide appropriate client access.

A3 contains the web-based captive web portal and RADIUS server used during
authentication. The client accesses these services using Layer 3 (IP) addressing.

Initial configuration of A3 requires the following addresses:

A3 permanent IP address - as discussed in Installation, the address that A3 is initially
assigned may come from a DHCP pool defined in DHCP server for the network that A3
is attached to. This DHCP server is the organization’s responsibility. During initial
configuration, a permanent address will be assigned to the A3 server. This address
must be statically assigned to an address not in the DHCP pool.

A3 permanent virtual IP address - another IP address is required in the same network
as the A3 permanent IP address to be used to access a cluster of A3 instances. This
address must likewise be a static address notincluded in the DHCP pool. This address
should be used in all cases when an A3 server address is required.

Domain name of the A3 server - the domain in which the A3 server resides.

Access network enforcement device - pictured as an Extreme Networks AP, it could
be a Wi-Fi controller or switch. This address must likewise use a static address. Itis
needed even if the device is managed by a cloud management system.

Email information - A3's alerting should be set up as part of initial configuration. This
requires an administrator's email address and access to a publicly accessible email

server. The latter item requires a email server name, protocol information, and email
account and password.

Optional server certificate - although an SSL certificate can be later installed, if one exists
for the server then initial configuration is a good time to install it.
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Clustering

A3 clusters provide load balancing and failover. There are some basic rules when using A3
clustering:

e Serversthat form a cluster should always be installed using odd numbers, that is 3, 5,
1.

e Servers should not be installed on the same platform. Where possible they should use
separate independent power sources and be connected to separate switches.

e Servers must all be on the same LAN segment (layer 2 connectivity).

Cluster Installation

Each server in a cluster is referred to as a member. Cluster installation is straightforward:

1. Install the first member using the New Deployment option during A3 installation. This
member is referred to as the master, or primary.

2. Install subsequent members using the Join Cluster option (instead of New
Deployment).

a. Provide the address of the primary, and the administrator name and password
used to install the master.

b. Clusters must be managed using the VIP (B) address instead of individual
member addresses. The VIP address is the IP address assigned to the first A3
server installed in the cluster.

c. Configure network devices, including Extreme Networks AP configured through
ExtremeCloud 1Q, to use the VIP address of the cluster as their RADIUS server.

You can monitor and manage clusters from multiple A3 administration pages:
e The Status page displays informational graphs for each member.

e The Cluster > Services option on the Configuration > System Configuration > Status
page displays a column for each member's services.

e The Configuration > System Configuration > Cluster option page shows the cluster
members and their states.
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Cluster Operation Clustering

Cluster Operation

During normal operation network devices send their RADIUS requests to the VIP address
of the cluster. The acting A3 master distributes the requests to one of the members.

If a cluster member fails, the master stops using that member and sends an alert to the
administrator.

If the cluster master fails, one of the other members is automatically elected as the new

master. When the original master again becomes active on the network, it thinks that it is
still the master. The other cluster members then vote on which of these two will become

the new master.

Restarting Services

When advised to restart any A3 service, the administrative interface for each cluster
member must be used individually to perform the operation. Restart services in each
member one at a time, waiting for all services to completely restart.

Graceful Shutdown and Restart

The best way to shut down all members is to shut down the non-master members first, and
the master last. Restart the cluster devices using the opposite process (start the master
first, then the cluster members). For example, if there are three members named 1, 2, and 3
with 1 as the master, then you should shut down using the order 3, 2, 1, and restart should
inthe order 1, 2, 3.

For each shutdown or restart step, make sure that operation has completed before starting
the next step.

Cluster Backup and Recovery

( )D[) not take a snapshot of To guard against unexpected shutdowns, Extreme Networks recommends that you take
((B)

1" 3 running member. This snapshots of all the members of a cluster. Shut down the clusters as described in Graceful
will temporarily cause it Shutdown and Restart. Take snapshots of all members, then restart the members in
to halt and result in reverse order. In the event of an ungraceful shutdown, restore the snapshots, then restart
service disruption and a the members in the reverse order of the snapshot order.
corrupt snapshot. To When a snapshot is restored changes to the A3 configuration after the snapshots will be
make an appropriate lost.
snapshot, stop the VM
first.
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Table of Addresses and VLANs

() Ensure that none of the
" permanent addresses
used are covered by a

DHCP range.

Part Number:

There are many components involved in a robust A3 implementation. Components are
characterized by network names, real and virtual IP addresses, netmasks, gateways,
VLANSs, passwords, and configurations. A3 and many of the other components require
configuration by IP addresses rather than symbolic names.

The tables in this chapter of the guide can be used to keep track of addresses, VLANs, and
other values. The table keys are labeled with upper and lower case letters (A..Z, a..z) and V
followed by a number for VLANSs. The table items and are used throughout this guide,
within parenthesis. For example,

10.150.1.254 (B)

Refers to row B in the Addresses and VLANs table, which corresponds to the virtual
address of the A3 server. The address 10.150.1.254 is one of the set of addresses used in
this guide and corresponds to the value in the Example Assignment column of the table.

The tables include example values as a consistent set; an additional column is provided for
administrators to insert their own values. Extreme suggests that you print out and use the
tables for A3 configuration and maintenance.

If there should ever be a need to change any of the addresses or other values in an
implementation, this guide can provide a handy reference for the locations in A3 where the
address or values is used. The PDF for this guide can be used to searched for the
corresponding (X) value.

Most use cases in this guide use Firewall Enforcement. Other forms of enforcement use
addressing that is similar or identical.
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Network Implementation
VLANs

Table of Addresses and

Network Implementation
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Refer to the following figures when referencing the Addresses and VLANs and Other
Values tables. Separate figures are provided for Layer 2 and Layer 3 network topologies.
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Network Implementation
VLANs

A3 Server

IP Address - (A)
VIP - (B)

S

Access Swﬁch D f

Table of Addresses and

Refer to the following figures when referencing the Addresses and VLANs and Other

Values tables. Separate figures are provided for Layer 2 and Layer 3 network topologies.

Access Point (C)

Registration Network
IP Address (J)

VIP - (K)

VLAN - (V2)

Isolation Network

IP Address - (L)

VIP - (M)

VLAN - (V3)
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Client Networks
IP Addresses - (N)
VLANS - (V4)

Management Network
Registration/Isolation Networks =mmmmm=

Client Networks = = = =«
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Router - (H)

DHCP Server - (E)

DHCP Server - (F)

Active Directory - (G)
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Network Implementation

Table of Addresses and

VLANs
Table 1: Addresses and VLANs
Example Actual
1 LD Assignr':lent Assignment
A |Address of the A3 server instance. The A3 server must be assigned to the manage- |10.150.1.4/24
ment VLAN. This address is initially assigned by DHCP or manually during installa-
tion and initial configuration. The VIP address (B) is normally used for A3
administration, unless a cluster is in place and the specific server must be
accessed.
B |Virtual IP address of the A3 cluster. This address is assigned as part of the initial 10.150.1.254
configuration of the master A3 server. It is the address used by all other compo-
nents, even when the cluster only has one member.
C |Access Point address. This is used only once in ExtremeCloud IQ when bringing the {10.150.1.19
access point under management and once in A3 to define an access control device.
D  [Access switch. This switch is used to connect A3 to all other network components.
E DHCP server for the network. 10.150.1.3
F |DNS server for the network. In this example, it is hosted on the Active Directory 10.150.1.5
server.
G  |Active Directory server. User and computer information used for several types of ~ {10.150.1.5
authentication.
H |Router. The router is used to connect to the rest of the organization’s network or to a | 10.5.1.240
remote site.
N |Client networks. One or more networks used for authenticated clients. A3 associates |10.150.10.0/24
the clients with a VLAN (V4) and the DHCP server (E) assigns them an address in that
network.
V1 |VLAN 1, the management VLAN is connected to all components. 1
V4 |One or more client networks assigned after successful authentication. Connected to |2, 5, 8
clients, access point (C), access switch (D), router (G), and infrastructure servers (D,
E, and F).
Table 2: Other Values
Key Usage Ex'ample I-\.ctual
Assignment Assignment
a |SSIDs defined in the access point (C). A3-Guest,
A3-Corp,
A3-WA,
A3-loT
b |Shared secret for RADIUS communications. This should be a strong password used to |8AB7tHkP
protect communications between A3 and the access point.
¢ |Name of the A3 server. This name is configured during Initial A3 Configuration. A3-Main
d [Domain for network. example.com
g RADIUS Filter_ID for guest role. guest
h RADIUS Filter_ID for sales role. sales
i RADIUS Filter_ID for marketing role. marketing
i RADIUS Filter_ID for employee role. employee
k  |ExtremeCloud 1Q policy name for corporate access. Corp-Policy
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Initial A3 Configuration

Setup IP Addresses

The initial configuration of A3 sets up some basic networking and naming parameters. In
most cases, this guide uses tables and descriptive text to describe configuration. Two
different Quick Start Guide performs the same functions, for registration VLAN and no
registration VLAN configurations. Here are the steps for initial A3 configuration.

1. Getstarted. Access A3 with a browser using the URL obtained from the last step of
Installation. This is not the (A) or (B) address; those will be defined in this chapter.

2. Warning. A warning about your connection not being private will likely be displayed.
This is due to the fact that A3 generates its own SSL certificate at installation time.
Certificate generation to handle this problem is discussed in A3 Server Certificate.
Click the Advanced/Details button and select the appropriate button to proceed
anyway.

3. New Deployment. For the first or only server in a cluster select GET STARTED from the
New Deployment box.

4. Clusters. For the second and subsequent servers in a cluster, select GET STARTED
from the Join Cluster box. Rules for non-primary cluster members is discussed in
Clustering.

5. Email. The next screen asks for the administrator’s email address and a password.
The email address will be your primary login name for all cluster members. Make sure
to use a valid email address that you have access to. Select Next.

6. License. Agree to the licensing terms. Select SUBMIT.

8. Addressing. The next screen is used to set IP addresses for A3. Use the following
steps in order.

a. VIP. Inthe VIP field, enter the (B) address. The VIP address is the main point of
contact for network devices and A3 for all cluster members. All cluster members
use the same VIP address. Erase all the characters in the field and type in your
new address. Press the check box to accept the setting.

b. IP Address. Change the IP Address to the (A) address. Press the check box to
accept the setting. A3 will change the address reload the page at the new
address. This may take a few minutes. If for some reason it does not restart, you
can refresh it with the https://<new IP address>:1443.

All A3 instances default c. Hostname. Change the host name to something appropriate for your installation.
P “A3” as their host A3-Main (c) is used in this guide.
name. Only one member d.  Select Next.
in a cluster can use the
“A3” name.
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Domain and Time Zone

11.

Initial A3 Configuration

Link to Cloud. (Highly suggested) The next screen links your A3 instance with
ExtremeCloud 1Q for configuration and monitoring. Extreme Networks strongly
suggests that an account be established and linked to the A3 instance. Beginning with
A3 version 4.0.0, licenses are distributed from you cloud account. The use of NAC
entitlements is mandatory for all production environments. If you skip this step, you
will only have a limited time to link with ExtremeCloud 1Q.

Enter the ExtremeCloud 1Q specifics that you obtained in Extreme Networks
Requirements and select LINK WITH CLOUD ACCOUNT. Once this A3 instance is
registered with ExtremeCloud 1Q, you will be able to distribute NAC Entitlements
between installations. Further, accessing A3 from ExtremeCloud 1Q will automatically
pass down authentication information so that administrative login will not be required.

A3 automatically generates a device certificate to authenticate the A3 server to
ExtremeCloud 1Q. The status of the certificate can be found at Configuration > System
Configuration > Cloud Integration.

When the cloud link is active, after upgrading to a 4.0 version from a 3.x version, the
XIQ Cloud Admin password previously used to connect to the cloud must be re-
entered.

To skip this step, select Continue without a Cloud Account.

. License. The next screen offers a choice for a 30-day trial of A3. Select START A 30-

DAY TRIAL PERIOD unless you have a legacy entitiement key. A key can be entered at
a later date unless you have linked to ExtremeCloud 1Q and configured ExtremeCloud
1Q to distribute NAC entitlements as part of the new licensing model.

Startup. When A3 says configuration is complete, its services will start.
a. This may take up to 10 minutes. Wait for all services to start.

b. Enterthe A3 configuration interface by selecting GO TO ADMINISTRATIVE
INTERFACE or invoking the interface via https://<VIP address (B)>:1443.

c. Login with the administrator’s credentials.

Domain and Time Zone

The domain and time zone are best configured next.

1.

Part Number:

General Configuration. Select Configuration > System Configuration > General
Configuration.

Domain and hest name. The domain and host name configured on this page are only
used for the captive web portal URL offered to clients. For example, if the Domain is
set to example.com (d) and the Host Name is set to A3-Main (c), then the CWP will be
invoked as A3-Main.example.com.

DHCP Servers. Comma-separated list of DHCP servers on the network. These are
used after A3 releases a user from the isolation and registration networks.

Time zone. Set the Time Zone to your local time zone. Note that the U.S. cities are
listed under America/<city> and sometimes America/<state>/<city>.
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Alerting

(o SETvices must be

" individually restarted on
each member of a
cluster. Restarting
services will disable
authentication for a

period of time.

Alerting

Initial A3 Configuration

5. Press Save. If you have changed the host name or added a domain name, a warning
message will prompt you to restart the haproxy-portal service. Press Save again after
haproxy-portal has restarted.

6. DNS setup (external configuration). Add an A record for the A3 VIP address to the
network’s DNS service. The A record should resolve to the VIP address.

e DNS zone: example.com (d)
e Host name: A3-Main (c)
e [P address: 10.150.1.254 (B)

Alerting must be set up to receive any messages from A3 and for authentication
techniques that involve SMS or email.

1. Alert Configuration. Select Configuration > System Configuration > Alerting.

2. SMTP. Enter the following essential changes:.

Entry Example Value Notes
Recipients admin@example.com One or more email addresses for those
who will receive alert messages.
SMTP server smtp.gmail.com Either a local SMTP server, a public

web server such as gmail or any pub-
lic mail service for which you have
credentials. Gmail's mail server is
smtp.gmail.com.

SMTP encryption | ssl The type of encryption appropriate for
your SMTP server. Gmail's uses ssl.
SMTP port 465 The port number appropriate for your

SMTP server. Gmail’s uses port 465.

SMTP user name |example-admin@gmail.com |The SMTP account name onthe SMTP
server.

SMTP password bigsecret The SMTP password associated with
the account.

3. Test. The SMTP configuration can be tested by selecting Tools > SMTP. Enter one or
more email addresses and select Test; the box below will indicate the particulars of
the test and its success or failure. If GMAIL is used, the settings on your account may
prohibit use from “less secure apps”, such as A3. Google “gmail access from less
secure apps” and follow instructions to enable access.

Change Admin Password

Part Number:

The administrator name and password entered during installation stays with the A3 data
forever. Itis most common to use the form <user-name>@<company.com> for the user
name. Names of that form are convenient because alert email is sent to that address and
the address may be used for Active Directory lookup. In fact, as soon as a join to an active
directory is performed (as in Use Case 2: Active Directory Authentication), the active
directory is queried when it is used for administrative access.
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Initial A3 Configuration

If the Active Directory should ever fail, it will be impossible for the administrator to login. To
provide a backup A3 in the form of an Admin user in the Users tab of the GUI. The
password was automatically generated, but can and should be changed at this juncture:

1. Navigate to Users.

2. Select Admin

3. Selectthe Password tab.
4

Enter a new password in the Password field. The same password used during
installation might make it easier to remember.

5. Press

To provide an alternative account that you can use to access A3, update the password for
the admin user in the Users GUI tab.

A3 Server Certificate

Part Number:

The browser warnings encountered in the first step of Initial A3 Configuration are due to
the fact that the web administration page uses HTTPS. During the initial handshake
between the browser and A3 administrative server, A3 sends its SSL certificate to the
browser.

A3's initial certificate is generated during installation and is a self-signed certificate. That
is, the certificate is for the server and is signed by the server. All modern browsers will
generate warnings when they see self-signed certificates. If the certificate is not replaced,
then administrators and clients will continue to receive these warnings.

To resolve this, a new certificate generated by a well-trusted certificate authority should
be installed. A3 provides the means to request a certificate and install it in the appropriate
place in A3. These techniques are covered in Certificates and PKI.
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ExtremeCloud 1Q Setup

This chapter covers two common configuration of ExtremeCloud 1Q for use with A3. Other
access devices are configured in similar ways, especially intelligent access points and
access controllers.

The two configurations covered in this chapter are:
e MAC Authentication
e 802.1X Authentication

This discussion assumes that ExtremeCloud 1Q account discussed in Extreme Networks
Requirements has been used to log in to ExtremeCloud IQ. The access points to be used
must have been on-boarded.

Devices are on-boarded by selecting the [+] in the menu bar at the top and entering the
device's serial number when requested.

MAC Authentication

The instructions in this section of the guide explain how to set up ExtremeCloud 1Q for MAC
authentication for use in guest access to a Wi-Fi network. This chapter is essentially the
same as the Quick Start Guides that cover registration VLAN and no registration VLAN
environments.

There are four major steps in setting up access points for MAC authentication:
1. Network Policy. The A3-Guest (a) SSID is defined.
2. Authentication. Open SSID with MAC authentication is selected.

3. Guest User Profile. A user profile is defined that uses a firewall rule sets to restrict
network access for registration.

4, |solation User Profile. A user profile is defined to handle cases when A3 determines a
client violation has occurred.

5. Deploy Policy. The configuration is pushed to the access point.

Network Policy
A new network policy is defined by selecting CONFIGURE > NETWORK POLICIES. Select

ADD NETWORK POLICY

1. Policy Details. Check the Wireless box only and enter Corp-Policy (k) as the Policy
Name. Click SAVE; the Wireless Networks tab is displayed.

2. Network. Select and then All Other Networks (Standard). Enter A3-Guest (a) in
the Name (SSID) field. The Broadcast Name is automatically filled in as A3-Guest as
well.
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Open Unsecured. Since the SSID will be used for guest access, select .
Clients will not need to enter any credentials to associate with the SSID, nor will any
802.1x credentials be transmitted. Open unsecured also means that data is not
encrypted over the air, which is suitable for guest access but not sensitive employee
data.

MAC Authentication. Select the MAC Authentication tab and enable MAC
Authentication.

RADIUS Server. A RADIUS Server group is defined next. This is a set of RADIUS
servers that can be queried by access points.

a. Clickthe + sign beside Default RADIUS Server Group.

b. Inthe Configure RADIUS Servers dialog, select Extreme Networks A3 and click
the + sign to add a new RADIUS server.

c. Fillin the Extreme Networks A3 Server dialog:
i.  Name as A3-RADIUS. Description as desired.

ii.  IP/Host Name: use the £} sign to add the A3 VIP address 10.150.1.254 (B) as
the Name and IP Address.

iii. Shared Secret as 8AB7tHkP (b). This is used to hash and unhash information
exchanged with the A3 server.

iv. Click

v. Enter A3-RADIUS-SERVER-GROUP in the RADIUS Server Group Name field,
check the box next to A3-RADIUS and click

Default User Profile. The means by which A3 ensures proper guest access is by
sending RADIUS attributes to the access point upon MAC authentication. The access
point uses these attributes to assign user profiles. To start authentication, every user
must register with A3. The default profile is used when no RADIUS attribute rules have
been satisfied. A set of firewall rules are used that restrict client access. Clients may
access A3, use DNS and DHCP on their network, but are redirected to A3 when they
try any http: or https: access.
a. Selectthe & sign on the line containing Default User Profile to access the
Create User Profile dialog.

b. Enter Registration-NV in the User Profile Name.

c. Ifthe VLAN number listed is not your management VLAN, then select *»= sign. If
your management VLAN is in the list, select it. If not, select ™%, and then define
your new VLAN number. Enter the number in both the Name and VLAN ID fields.

¢, Soloct [TV
e. Turnon Firewall Rules and then name the IP Firewall Registration-NV-FW.

f.  Firewall rules must now be defined to ensure that users in the registration state
can only access the services and places that are needed for registration.

Pressthe -~ sign to define the first firewall rule.

The first rule allows the client to communicate with the A3 server using any
protocol.

i.  Selectthe =, select Any from the list, and then select [FTT==N.

ii. Selectthe **= beside Destination IP, and then the IP address of the A3
server, 10.150.1.254 (B).

iii.  Select to save the rule.
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d. Similarly define additional rules as per the table below in the order indicated.

Services Source IP Destination IP Action
DHCP-Client, any any Permit
DHCP-Server, DNS
HTTP, HTTPS any any Redirect
any any any Deny

e. Setthe Redirecting URL to https://A3-Main.example.com/Aerohive::AP. This
invokes A3 when a registering user attempts to reach any web page.

5. Select to save the new user profile.

1. Select “Allow a different user profile to various clients and user groups”.

2. Guest Profile. Select above User Profile Name to create a Guest User Profile
with VLAN 2 (V4).

a. Enter Guestinto the User Profile Name.

b. The VLAN to Connecttois either selected from a list of those already defined with
the ism=, or if the VLAN number is not found in the list, use the < icon to view
the New VLAN Object dialog to create VLAN 2 (H). Select

3. Assignment Rule. After the profiles have been created, it is necessary to tell the
access point to assign these profiles when A3 sends back the proper RADIUS
attribute. Before adding an assignment rule based on a filter ID, the “Allow user
profile assignment using RADIUS attributes in addition to the three tunnel RADIUS
attributes” must be set.

a. Selectthe on the Guest line in the Assignment Rules column.
b. Enter the name A3-Guest-Rule in the Name field
c. Selectthe 4 symbol, and select RADIUS Attribute.

d. Note that 11_Filter-Id has been preselected. Fill in the Attribute Values field with
guest (g). It is important that the value be entered in this way, since the field is
case sensitive and it must match an entry we will make in A3. Click and
then

4. Click

An isolation user profile is necessary to handle exception cases signaled by A3. A3 will
send the access point a isolation RADIUS attribute in that case, which will be treated as a
return to an isolation state.

1. Select *»= above User Profile Name and select Registration-NV.
2. Selectthe on the Registration-NV line in the Assignment Rules column.
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3. Enter the name Isolation-Rule in the Name field, click the 4= symbol, and select
RADIUS Attribute.

4. Note that 11_Filter-ld has been preselected. Fill in the Attribute Values field with
isolation (g). It is important that the value be entered in this way, since the field is
case sensitive and it must match an entry we will make in A3. Click OK and then SAVE.

5. Under Assignment Description click the = button to expand both descriptions. Click
Save .

Before continuing, note the IP Address of your access point, this corresponds to the (C)
address.

Select the Deploy Policy tab, then check the box for your access point, and then
. Check Complete Configuration Update and Configuration and select Delta
Configuration Update or Complete Configuration Update. Click

This completes ExtremeCloud 1Q configuration for MAC authentication.
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Network Policy

Authentication
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The instructions in this section of the guide explain how to set up ExtremeCloud 1Q for
802.1X authentication for use in employee access to a Wi-Fi network.

ExtremeCloud 1Q will be used to program the access point used in this Active Directory
example. There are four major steps:

1.

2
3.
4

Network Policy. The A3-Corp (a) SSID is defined.
Authentication. Enterprise authentication is selected.
User Profiles. Three user profiles are associated with the network policy.

Deploy Policy. The configuration is pushed to the access point.

A new network policy is defined by selecting CONFIGURE > NETWORK POLICIES. Select
ADD NETWORK POLICY.

1.

Policy details. If a network policy has previously been defined, as would be the case if
you followed the instructions for the MAC Authentication example, then the
CONFIGURE page with a listing for the Corp-Policy network policy will be displayed.

a. Ifanetwork policy is displayed, then:
i.  Click the network policy name (Corp-Policy).
i. Selectthe Wireless Networks tab.

b. If no existing network policy is displayed, then:
i. Select ADD NETWORK POLICY.

ii.  Fillin the Policy Details: check the Wireless box only and enter Corp-Policy
as the Policy Name.

iii. Click SAVE to move to the Wireless Networks tab.

Network. Select ADD and then All Other Networks (Standard). Enter A3-Corp (c) in the
Name (SSID) field. The Broadcast Name is automatically filled in as A3-Corp as well.

Enterprise. Since the SSID will be used for employee access, select Enterprise below
SSID Authentication.

RADIUS Server. A RADIUS Server group is a set of RADIUS servers that can be
queried by access points.

a. Ifyou have previously defined a RADIUS server group in a previous example, you
canreuse it.

i.  Clickthe **= icon beside Default RADIUS Server Group.
i. Place acheck mark beside the previously defined server group name.
iii. Click SELECT.

b. If a server group has not been defined yet.

i.  Inthis example, only one RADIUS server will be usedA3. Click the 4= sign
beside Default RADIUS Server Group.

i. Inthe Configure RADIUS Servers dialog, select Extreme Networks A3 and
clickthe 4 signto add a new group.
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c. Fillinthe Extreme Networks A3 Server dialog:
i.  Name as A3-RADIUS. Description as desired.

ii. IP/HostName:usethe == signto addthe A3VIP address 10.150.1.254 (B) as
the Host Name and IP Address.

iii. Shared Secret as 8AB7tHkP (b). This is used to hash and unhash information
exchanged with the A3 server.

iv. Click SAVE Extreme Networks A3.

v. Enter A3-RADIUS-SERVER-GROUP in the RADIUS Server Group Name field,
check the box next to A3-RADIUS and click SAVE RADIUS.

Default User Profile. A3 ensures proper employee access by sending RADIUS
attributes to the access point upon authentication. The access point uses these
attributes to assign appropriate user profiles. The default profile is used when no
RADIUS attribute rules have been satisfied, placing the user in the VLAN associated
with the default-profile.

a. Continue down the screen to Authenticate via RADIUS Server, User Access
Settings.

b. Selectthe <= sign on the line containing Default User Profile to access the
Create User Profile dialog.

a. Enter Employee in the User Profile Name.

b. Selectthe **= and choose 8 if it is in the list, otherwise select plus sign to add
VLAN 8 (V4).

i.  Enter 8(V4)in both the Name and VLAN ID fields.
i. Select SAVE to save the VLAN object.
iii. Select SAVE USER PROFILE to save the new user profile.

Select the Apply a different user profile to various clients and user groups check box.
This enables the use of multiple user profiles on a single SSID.

Select the Allow user profile assignment using RADIUS attributes in addition to three
tunnel RADIUS attributes check box. This results in a selection of Standard RADIUS
Attribute and a value of 11_Filter-Id. The access point’s profile assignment will key off
of the value of the 11_Filter-ld RADIUS attribute received from A3.

Sales Profile. Select ADD above User Profile Name to obtain create a Sales User
Profiles with VLAN 2 (H).

a. Enter Sales into the User Profile Name.

b. The VLAN to Connecttois either selected from a list of those already defined with
the :F, or if the VLAN number is not found in the list, use the == icon to view
the New VLAN Object dialog to create VLAN 2 (H). Select SAVE.

Marketing Profile. Select ADD again to obtain a Marketing User Profile with VLAN 5
(1) using the same procedure as in the previous step.

Assignment Rules. After the profiles have been created, it is necessary to tell the
access point to assign these profiles when A3 sends back the proper RADIUS
attribute.

a. Selectthe on the Sales line in the Assignment Rules column.
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b. Enter the name A3-Sales-Rule in the Name field, click the + symbol, and select
RADIUS Attribute.

c. Note that 11_Filter-Id has been preselected. Fill in the Attribute Values field with
sales (h). It is important that the value be entered in this way, since the field is
case sensitive and it must match an entry we will make in A3. Click OK and then
SAVE.

d. Repeatthe procedure for the Marketing profile, using the name A3-Marketing-
Rule and attribute value of marketing (i).

e. Under Assignment Description click the = button to expand both descriptions.
The display should appear as below. Click

Deploy Policy

Select the Deploy Policy tab, then check the box for your access point, and then UPLOAD.
Check Update Network Policy and Configuration and select Complete Configuration. Click
PERFORM UPDATE.

Before continuing, note the IP Address of your access point, this corresponds to the (E)
address in table.

This completes ExtremeCloud IQ configuration for 802.1X authentication.
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A3 using a number of technologies to authenticate users. Its authentication methods are
divided in four broad categories:

e  External Authentication Sources

¢ Internal Authentication Sources

e Exclusive Authentication Sources

e Billing Authentication Sources

Description of authentication technologies is included at the end of the chapter.
This chapter also discusses:

e 802.1X

e EAP and X.509 Certificates

e Social Login Authentication Technology

External Authentication Sources

External authentication sources utilize identity information obtained either directly or
indirectly from the client. An identity confirmation is used in all cases except for the null
authentication source. All external authentication sources work in conjunction with the
CWP (captive web portal), customization of which is discussed in Portal Modules. The
CWP can require the client to agree to a Terms of Service/Acceptable Use Policy
agreement before being allowed access.

A wide range of social media authentication mechanisms are used.
The external authentication sources are:
e Null - noidentification is required.

¢ Email - the client enters their email address, which A3 uses to send a message. The
message that the client receives includes a link that will complete the authentication.
This form of authentication requires that Alerting be set up during Initial A3
Configuration.

e SMS - the client enters their cell phone number, which A3 uses to send an SMS
message. The message that the client receives includes a PIN (personal identification
number) that is entered into the CWP page to complete the authentication. This form
of authentication requires that Alerting be set up during Initial A3 Configuration.

e Sponsor - the client enters their name and the email address of a sponsor within the
organization authorized to allow sponsored access. The sponsor receives an email
that includes a link that will complete the users authentication. This form of
authentication requires that Alerting be set up during Initial A3 Configuration.
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e Social login - any of a number of social media sites are used to authenticate the
client. Social media technology is described in Social Login Authentication
Technology. Clients are directed to log in to the social media site if they have not
already done so. Their authentication information is returned to A3.

The A3 administrator must pre-configure access on the social media site to obtain
several security parameters. These parameters are entered into A3 as part of the
definition of a social media authentication source.

The registration for social media authentication methods supported by A3 are:
e (Clickatell API Registration

* Facebook APl Registration

e Github API Registration

*  (Google API Registration

e Instagram API Registration

¢  Kickbox API Registration

e LinkedIn API Registration

e OpenlD API Registration

e  Pinterest APl Registration

e Twilio APl Registration

e Twitter API Registration

¢ WindowsLive APl Registration

Note that the registration process for each of the sites is maintained by the social
media vendor and may change without notice.

Clickatell API Registration

To use Clickatell as an SMS source:
1. Register at https://www.clickatell.com to get an API Key for the SMS integration.

2. Additas an authentication source the same way as for SMS, except choosing
‘Clickatell" instead of 'SMS' in 'Add source ? External'.

3. Enter aname, description and your Clickatell APl key in the source configuration, then
add the authentication rule.

Facebook API Registration

The Facebook API registration is located at https://developers.facebook.com/apps.

1. Create an App; the URI for the Website URL field should be https://<hostname>/
oauth2/callback, where <hostname> should be the A3's CWP, or other location if it is
hosted elsewhere. This same value is entered into the Portal URL field in A3. This
should be the same name as found in Configuration > System Configuration > General.

2. The Facebook API site will provide the App ID and App Secret fields at Settings >
Basic.

Github API Registration

The Github API registration is located at https://github.com/settings/applications.
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Google API Registration

The

Instagram API Registration

The Instagram API registration is located at https://www.instagram.com/developer/
clients/manage/.

Kickbox API Registration

1.

Authentication Methods

Create an App; the URI for the Callback URL field should be https://<hostname>/
oauth2/callback, where <hostname> should be the A3's CWP, or other location if it is
hosted elsewhere. This same value is entered into the Portal URL field in A3. This
should be the same name as found in Configuration > System Configuration > General.

The Github API site will provide the App ID and App Secret fields.

Google API registration is located at https://console.developers.google.com/.

In the Google APIs Console, select Credentials > Create Credentials > Oauth client ID.
Select Configure consent screen.

a. Fillin the Application name as A3.

b. Enter example.com (d) in the Authorized domains field and press ENTER.

c. Click Save.

Select Web application, enter Name as A3, and then select Create.

Enter a name; the URI for the Authorized redirect URI field should be https://
<hostname>/oauth2/callback, where <hostname> should be the A3's CWP, or other
location if it is hosted elsewhere. This same value is entered into the Portal URL field
in A3. This should be the same name as found in Configuration > System Configuration
> General.

The Google API site will provide the App ID (Client ID) and App Secret (Client Secret)
fields.

Create an App; the URI for the Website URL field should be https://<hostname>/
oauth2/callback, where <hostname> should be the A3's CWP, or other location if it is
hosted elsewhere. This same value is entered into the Portal URL field in A3. This
should be the same name as found in Configuration > System Configuration > General.

The Instagram API site will provide the App ID and App Secret fields.

An APl key is required to use Kickbox. Use the following guidelines:

1.
2.

3.

Linkedin API Registration

Part Number:

Create an account on https://kickbox.io.

Navigate to https://app.kickbox.com/settings/keys. Select APl Keys > Create Key.
Select a name and choose Production mode and Single verification.

The website will provide the API Key.

The LinkedIn API registration is located at https://developer.linkedin.com/.

1.

Create an App: the URI for the Callback URL field should be https://<hostname>/
oauth2/callback, where <hostname> should be the A3's CWP, or other location if it is
hosted elsewhere. This same value is entered into the Portal URL field in A3. This
should be the same name as found in Configuration > System Configuration > General.
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OpenlD API Registration

2.

Authentication Methods

The LinkedIn API site will provide the App ID and App Secret fields

The OpenlID API registration is located at http://openid.net/connect along with information

on how to create your own host or get one from a provider.

1.

Pinterest APl Registration

Twilio API Registration

Twitter APl Registration

The
1.

Create your App; the URI for the Portal URL field should be https://<hostname>/
oauth2/callback, where <hestname> should be the A3's CWP, or other location if it is
hosted elsewhere. This same value is entered into the Portal URL field in A3. This
should be the same name as found in Configuration > System Configuration > General.

The OpenlID API site will provide the App ID and App Secret fields.

Pinterest APl registration is located at https://developers.pinterest.com/apps.

Create your App; the URI for the Redirect URL field should be https://<hostname>/
oauth2/callback, where <hoestname> should be the A3's CWP, or other location if it is
hosted elsewhere. This same value is entered into the Portal URL field in A3. This
should be the same name as found in Configuration > System Configuration > General.

The OpenlD API site will provide the App ID and App Secret fields.

Create an account at https://www.twilio.com.

From the console (dashboard) at https://www.twilio.com/console create a 3rd Party
Integration. Note the Account SID and Auth Token for later use.

From the Phone Manager https://www.twilio.com/console/phone-numbers/incoming,
click the "+" button to Buy a number with SMS capability - no payment is needed to
start using this phone number right away.

The Twitter API registration is located at http://apps.twitter.com.

1.

Create an App; the URI for the Redirect URI field should be https://<hostname>/
oauth2/callback, where <hestname> should be the A3's CWP, or other location if it is
hosted elsewhere. This same value is entered into the Portal URL field in A3. This
should be the same name as found in Configuration > System Configuration > General.

The Twitter API site will provide the App ID and App Secret fields.

WindowsLive APl Registration

The Twitter APl registration is located at https://developers.pinterest.com/apps.

Part Number:

1.

Create an App; the URI for the Redirect URI field should be https://<hostname>/
oauth2/callback, where <hestname> should be the A3's CWP, or other location if it is
hosted elsewhere. This same value is entered into the Portal URL field in A3. This
should be the same name as found in Configuration > System Configuration > General.

Check Live SDK support.
The Twitter API site will provide the App ID and App Secret fields.
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Internal authentication sources are methods for which the organization deploying A3 has
control. Only internal authentication sources may be used for 802.1x/EAP authentication.
The sources that are available are:

Active Directory (AD) / LDAP - uses an LDAP compatible directory, including
Window's Active Directory, for identity and group information. The Associated Realm
parameter in the LDAP Authentication definition ties the definition to particular
domain controllers.

Authorization - performs authorization without client input.

EAP-TLS - uses the EAP-TLS protocol for LDAP access. Requiring client certificates,
EAP-TLS is a common EAP method used. The client and server perform mutual
authentication and form encryption keys based on certificate contents. The
Associated Realm parameter in the LDAP Authentication definition ties the definition
to particular domain controllers. EAP technology is discussed in EAP and X.509
Certificates.

Edirectory - uses a NetlQ Edirectory for authentication.

Google Workspace LDAP - an LDAP integration what works in conjunction with
Google Workspaces.

Htpasswd - uses a flat file with name and password commonly used in basic
authentication on Apache HTTP servers.

HTTP - permits access to A3 via an API that uses basic authentication. Itis used, for
example, to allow AD servers to send notice of user changes. See Active Directory
Integration.

Kerberos - uses a Kerberos server. A Kerberos server is embedded within the A3
server and may be referenced with an IP address of 127.0.0.1. A list of users may be
maintained in the Users top level menu option.

Password of the Day - generates a password regularly that is mailed to an
administrator. The administrator then distributes it to clients who use the password
for authentication.

RADIUS - uses a RADIUS server. A FreeRADIUS is embedded within the A3 server and
may be referenced with an IP address of 127.0.0.1. A list of users may be maintained in
the Users top level menu option.

SAML - SAML (Security Assertion Markup Language) is an open standard based on
XML for exchanging authentication and authorization data. It was initially designed to
support single sign-on for web browsers.
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Exclusive Authentication Sources

When used, exclusive authentication sources must be the only authentication source used
in a connection profile. Several authentication sources are included in the exclusive
category:

e AdminProxy - an authentication mechanism used in Microsoft systems for
administrator single sign-on.

¢ Blackhole - an authentication mechanism that denies authentication for the client.
This can be used to deny clients access that would otherwise be granted.

¢ Eduroam (education roaming) - a global example of realm-based authentication. The
technology behind Eduroam is based on the IEEE 802.1X standard and a hierarchy of
RADIUS proxy servers. Eduroam is a secure, worldwide roaming access service
developed for the international research and higher education community. Use Case
8: Eduroam describes how to configure A3 to work with eduroam.

Billing Authentication Sources

AuthorizeNet

Mirapay

Part Number:

Billing authentication sources provide authentication following successful payment. The
A3 administrator must pre-configure access on the billing site to obtain several security
parameters. These parameters are entered into A3 as part of the definition of a billing
authentication source.

Billing tiers are defined in Configuration > Advanced Configuration > Billing Tiers. The
means by which each is pre-configured is described below. Note that the registration
process for each of the sites is maintained by the vendor and may change without notice.

The sources that are available are described in:
e AuthorizeNet

e  Mirapay
e PayPal
e Stripe

Registration for the AuthorizeNet authentication APl is located at https:/
account.authorize.net. (A sandbox account may be set up at https:/
developer.authorize.net/).

1. When you create the account, the AuthorizeNet API site will provide an API login ID
and Transaction Key which should be used in the authentication definition.

2. Login into your new account. Click Settings under Account.

3. Inthe Security settings of that page click MD5-Hash. Enter a shared secret in the
Hash Value field.

Mirapay account and API registration is available at https://www.eigenpayments.com/.
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Use the following guidelines to create a Sandbox account:

1. Registration for use of the PayPal authentication APl is located at https:/
developer.PayPal.com/.

2. Click Accounts in the Sandbox menu.

3. Create an account that has the type Personal and one that has the type Business.
4. Go back to Accounts and expand the Business account, then click Profile.

5. Change the password and make a note of it.

6. Repeat steps 4 and 5 for the Personal account.

Use the following guidelines to create a Merchant account:

1. Registration for use of the PayPal authentication APl is at https://PayPal.com/.

Go to My Account > Profile to access your profile configuration.

Set Auto Return to On.

Set Return URL to https://<hostname>/billing/PayPal/verify, where <hostname> is the
A3.

6. Note the ldentity Token in the form.

7. Submit the form and note the Cert ID.

8. Go back to My Account > Profile and select Encrypted Payment Settings.
9

2
3. Next, in Selling Preferences, select Website Payment Preferences.
4
5

Select the A3 public certificate in the Your Public Certificates section.

10. Download the PayPal Public Certificate and put it in the A3 server at/usr/local/A3/
conf/ssl/PayPal.pem.

Registration for use of the Stripe authentication APl is located at https://
dashboard.stripe.com. Use the following guidelines:

1. Click on Your account then Account settings.

2. Navigate to the APl keys tab and note your key and secret. Two sets of keys and
secrets are provided for testing and live operation.

A subscription-based service is available with Stripe. Configure a billing tier for each
subscription plan to be made available to the client. Configure a very long Access Duration
in this case since Stripe will contact A3 when the subscription has expired. In order to
receive subscription expiration or cancellation notices:

1. A3 must be publicly available through a FQDN that resolves to the server. Port 80 must
be open.

2. In Stripe, configure a Webhook that Strip will use to inform A3 of events. Go to Your
Account > Account Settings > Webhooks and click Add endpoint.

3. Enter the URL as http://<hostname>/hook/billing/stripe, where <hostname> should be
the A3's CWP.

4. Mode can be set for testing or live mode.
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RBAC (Role-based Access Control) authenticates users and their devices with information
provided by device-resident supplicant software. This information is matched against
internal databases such as AD. 802.1X protocols define the way in which the components
talk to each other. A variety of encryption techniques are used to ensure the security of
802.1X protocol messages, including the EAP (Extensible Access Protocol). EAP variants
are covered in EAP and X.509 Certificates. EAP requires X.509 digital certificates, which
are covered in Certificates and PKI.

The figure below illustrates the components involved in RBAC.

Authentication
Supplicants Authenticators Servers

% Access Point A3
C — E LDAP
) ) \é server
) Generic AP and
Clients Wi-Fi controller
RADIUS server

Enterprise switch

Supplicants are client devices that seek access to the network. They run device-resident
supplicant software that supplies credential information to the authentication server.

Some common credentials include:

e Username and password

* MAC address

* Digital certificates

e Dynamic and one-time passwords

e Smart cards or credentials stored on USB devices
e Machine credentials

e  Pre-shared keys

One or more credentials may be required by the authenticator. Supplicants can be
integrated with the client 0S, or supplied by third parties. Installing and configuring
supplicants can be a time-consuming and complex task. You can automate this and other
configuration tasks using automation and MDM (mobile device managers), which are
described in Provisioning.

An authenticator is a device that blocks or allows traffic to pass through its ports. Many
types of devices can serve as authenticators:

¢ Extreme Networks access points: APs provide both wireless access and
authentication.
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e  Generic APs: APs may require the use of a separate Wi-Fi controller that performs
authentication in addition to AP control.

¢ Enterprise switches: An advanced wired network switch can also be an
authenticator.

Depending on the type of authentication you use, a number of servers may be involved. At
a minimum they include:

e A3:the A3 server acts as a proxy for access to the other authentication servers. It
matches information returned from these servers for extensive control over access
control. A3 uses a built-in RADIUS server.

*  RADIUS Server: RADIUS is the key protocol used for authentication. The RADIUS
server may contain its own database of users and roles, and works with additional
authentication servers. A3 uses a built-in FreeRADIUS server.

e LDAP Server: LDAP (lightweight directory access protocol) is used to access
databases that contain user, machine, roles, and other information organized in
multiple hierarchies. Microsoft's AD and OpenLDAP are two of a number of LDAP
servers in common use.

EAP and X.509 Certificates

Part Number:

EAP is an authentication framework that facilitates secure communications between
clients and authentication servers. The figure below is a simplified network diagram
featuring Extreme Networks components.

Authentication

Supplicants Authenticator Servers
RADIUS A3 @
Access Point LDAP
Clients
Supplicant software F-RADIUS -st-e;v-e-r‘:
RootCA | —— —
certificate | =— Server =Y
Client certificate | =—
certi_ficate _— RootCA | —
(optional) certificate | =

An access point serves as the Authenticator. Messages from clients to the AP are sent
using the EAPoL (EAP over LAN) protocol. They are then encapsulated in RADIUS
messages and sent to A3.

Most EAP methods use X.509 digital certificates to ensure identity and to set up encryption.
Three possible certificates are required:
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¢ Server Certificate: uniquely identifies the RADIUS server as an authorized part of an
entity. Server certificates also provide the public key used to encrypt communications
with the authentication server. Clients request this certificate as part of an EAP
exchange to ensure that they are talking to the correct server. The server certificate is
signed by a Root CA (Certificate Authority), described below.

* Root CA Certificate: identifies the authority that generates certificates. Clients and
others use these certificates to further validate server certificates. Root CA
certificates must be pre-loaded into clients. Most client operating systems contain an
extensive list of Root CA certificates in their certificate store that have been validated
by the 0S vendor. Enterprises may choose to be their own certificate provider, in
which case they must generate their own Root CA certificate and arrange to
download it to clients. Windows environments that use AD can accomplish this using
the GPO (Group Policy Object). Provisioners (see Provisioning) may also be used to
download Root CA certificates to users.

¢ Client Certificate: Identifies individual clients. Certificate data is used in lieu of other
credentials that the client might have. When a client certificate is used, the server
must have the corresponding Root CA certificate.

X.509 certificates are generated and maintained as part of a Public Key Infrastructure
(PKI), which is covered in Certificates and PKI.

The EAP framework makes possible a number of methods for the secure exchange of
identity. The client dictates which EAP methods are acceptable. The client and server
negotiate which of the acceptable methods they have in common will be used. The EAP
methods that are available in A3 are shown below. You can select more supported
methods using the administrative interface.

e EAP-TLS: this is one of the most common method used, and requires client
certificates. TLS (transport layer security) is the same protocol used for secure web
pages, although client certificates are not required in most TLS cases. The client and
server perform mutual authentication and form encryption keys based on certificate
contents.

e PEAP: the PEAP (protected extensible authentication protocol) encapsulates EAP
within a potentially encrypted and authenticated TLS tunnel. Any of the other methods
listed may be used within the tunnel.

e EAP-TTLS: the TTL (tunneled transport layer security) protocol extends TLS. The client
need not be authenticated initially by the server using a certificate, although the
server's certificate is used by the client. Once this occurs a secure tunnel is
established for user authentication. User authentication may use any of a number of
methods, including legacy credentials or certificates.

e EAP-GTC: this technique is used in conjunction with GTC (generic token cards). In this
method, the RADIUS server sends a challenge to the security token on the client. The
response is sent back and validated by the server.

e EAP-MD5: an older technique that uses an MD5 hash to authenticate the client to the
RADIUS server, but not vice versa. Itis currently deprecated.

e EAP-FAST: the FAST (Flexible Authentication via Secure Tunneling) protocol
establishes a tunnel without the need for client or server certificates. The tunnel is
established using PAC (Protected Access Credentials), either dynamically generated
or pre-stored. Once a tunnel is established any of a number of mechanisms can be
used, as in EAP-TTLS.
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Social Login Authentication Technology

A3 works with a number of social media web sites using the 0Auth2 protocol defined in
RFP 6749 - The OAuth 2.0 Authorization Framework.

These social media sites include Facebook, Github, Google, Instagram, Kickbox, Linkedin,
OpenlD, Pinterest, Twilio, Twitter, and WindowsLive. To use any of these sites in a web-
based authentication, the A3 administrator must register with the OAuth provider to obtain
two pieces of information: an API ID that identifies the site or sites, and an API Secret that
authenticates the site or sites. During the registration process the administrator provides
identification information and a callback URL into A3, which is used at run-time.

The figure below describes the run-time steps associated with social media
authentication. The definition of a social media authentication source requires a number of
pieces of information that are highlighted in the table below the illustration. These terms,
with slight naming variations, are used in the definition of social media authentication
sources.

1. User authorization request

A3

[
2. User authorizes applicatio
User agent
(browser)

Auth
server
(service API)

3. Authorization code
| T

4. Access token request
5. Access token grant

| 6. Access token Resource
server
7. User information (service)
N——

The steps in the process are described in this table:

Key Usage Example Assignment
1 User Authorization Request. The user chooses a social e API URL: The URL of the social media OAuth2 site.

media authentication from a captive web portal. « API Auth Path: A sub-location within the AP URL used
for authorization.

e APIID: The ID of A3 obtained during registration.

¢ Portal URL: The callback URL on the A3 to which to
return an authorization.

* Scope: A description of the information that A3 will
require from the social media database

2 |User Authorizes Application. The user is asked to log in to
the social media site, if necessary, and is then asked to
grant A3 access to their identification information.

3 |Authorization Code Grant. The social media site responds | ¢ Portal URL
to the A3 callback URL, providing an authorization code.
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Key Usage Example Assignment
4  |Access Token Request. A3 requests an access token thatis | ¢ API URL

used to retrieve the user's information. « APl Token Path: A sub-location within the AP URL
used for token access

e APIID

¢ API Secret: The shared secret that allows A3 to
access the social media site.

5 |Access Token Grant. The response to the access token Access Token Parameter: The label associated with the

request containing the access token. received access token

6 |Access Token. A3 presents the access token along with a

request for user information.

7 User Information. User identification information is

returned to A3.
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Overview
There are seven key elements to a working A3 authentication configuration. The figure
below illustrates the general layout and suggested configuration order of ExtremeCloud 1Q
and A3 elements.
[ ExtremeCloud 1Q Configuration ) 4 A3 Configuration )
3 Domains 4 Realms
L Authentication

e = Dependency

Part Number:

Sources

/

B Y

Connection
Profiles

. J

Either five or seven steps are required to configure ExtremeCloud 1Q and A3 for

authentication. Seven steps are required if AD (Active Directory) lookups are required, and

other devices may also need to be configured. Use the following steps:

1. ExtremeCloud 1Q Network Policy: define the network SSID and the network
connections to be made based on A3 role identification.

2. Roles: define distinct role names for categorizing users.

3. Domains: define A3 domains only when you need AD or LDAP domains to identify
users. Domains and domain controllers are identified in this step.

4. Realms: define realms to dictate which network regions apply.

5. Authentication Sources: define the ways in which users are authenticated and
assigned to roles.

6. Devices: define the manner in which access points and switches will receive A3
information.

7. Connection Profiles: tie ExtremeCloud 1Q SSIDs and network policy to authentication

sources.
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Guest Access Configuration Example

This example uses an Extreme Networks AP connected to an A3 server to allow guest
access to the internet, but not internal networks. The authentication methods in this
example are supported by the captive web portal hosted on the A3 server:

1. Null (no user authentication, presents the user with an Acceptable Use Policy)
2. SMS message

3.  Email message

The configured elements are pictured below.

The colors in this illustration correlate configured items. Text on a colored background
designates configured items that are used in multiple elements. Black text indicates a
setting name.

ExtremeCloud 1Q Configuration

ExtremeCloud 1Q is configured in the following manner:
1. MAC Authentication. Clients are authorized based on their MAC address.

2. User Access Settings. A default user profile is defined that limits access by guests
during the registration process using firewall rules. A guest user profile specifies that
when the access point receives the guest RADIUS attribute from A3 it will connect the
client to the internet, but not to any internal networks.

A3 Configuration

Four elements are required for this guest access scenario:
1. Roles. The names of roles that clients will assume, in this case the A3GuestRole.

2. Authentication sources. The authentication sources used in this example are null,
sms, and email. Each source has a set of authentication rules that indicate the
conditions under which the authentication succeeds and what actions to perform
when it does.

In this example, the client satisfies authentication through the captive web portal; no
conditions are set in the authentication source. All sources have the same action: to
assign the A3GuestRole to the client. The role is used in the Devices element.

3. Devices. The device configuration ties the roles to the returned RADIUS attribute
returned. The IP address of the AP indicates which AP is to be contacted with the role
assignment. To map the A3GuestRole to the guest RADIUS attribute, select Role by
Device Role.

4. Connection Profile. The connection profile creates a correspondence between the
AP connection profile and the authentication sources that can be used within that
profile.

802.1X Configuration Example

This role-based access example uses an AP connected to an A3 server which is in turn
connected to an AD server. User credentials are matched against AD entries. Clients
whose users are in the Sales group are attached to VLAN 10 in the internal network and
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those in the Marketing group are attached to VLAN 8. The configured elements are
pictured below.

ExtremeCloud 1Q Configuration

A3 Configuration

IP address: AP/Switch

Enterprise authentication

User access settings
User profiles

VLAN 10
RADIUS attribute
sales

VLAN 8
RADIUS attribute
mktg

SSID: [CaFpNEfwoTk——

Connection Profiles
A3RoleProfile
Filter

Name: HM-CORP-SALES

Name: HM-CORP-MKTG

SSID: CBTBNENOHK

Source
LocalADSource

Roles
A3SalesRole
A3MktgRole

Devices
IP address: AP/Switch
Device: Aerohive AP

Role by Device Role
A3SalesRole

sales
A3MktgRole
mktg

Authentication Sources
Names
LocalADSource

Host: Y.Y.Y.Y
AD Settings: CN=Users,...
Associated Realms
default
null
Authentication Rules
Name: LocalADSalesRule
Conditions

MemberOf: CN=Sales, CN=Users,...

Actions
Role: A3SalesRole

Name: LocalADMktgRule
Conditions

MemberOf: CN=Marketing, CN=Users,...

Actions
Role: A3MktgRole

Domains

Active Directory Domain

ID: MyDomain
’7 AD settings: Workgroup,

DNS, AD server, DNS server

Realms
default ' MyDomain

null MyDomain

The colors in this illustration correlate configured items. Text on a colored background
designates configured items that are used in multiple elements. Black text indicates a
setting name, and red text indicates an element name that is not used elsewhere.

ExtremeCloud 1Q Configuration

A3 Configuration

Part Number:

Configure the following AP-related items for this example:
1.

Enterprise Authentication. Clients are authorized utilizing 802.1X with EAP.

Certificates and shared secrets have been omitted from this example.

User Access Settings. These settings specify that when the AP receives the sales

RADIUS attribute from A3, it connects the client to VLAN 10. Similarly, the mktg
attribute is mapped to VLAN 8.

Configure the following five elements for this user access example:

1.

A3MktgRole.

to this domain.

Roles. Define the role names that clients will assume, in this case A3SalesRole and

Domain. Define an AD domain named MyDomain. Map two realms (null and default)

Authentication Source. Configure a single, local AD source named LocalADSource.

This source is associated with the Local AD server through associated realms.
Configure two authentication rules to locate the client's credentials in the CN=Sales
or CN=Marketing section of the CN=Users tree in AD. In both cases, the action
associated with the authentication rules assigns the A3SalesRole and A3MktgRole,

respectively.
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4. Devices. Configure devices to tie the roles to the RADIUS attribute returned to each
device, based on the IP address of each device. Select Role by Device Role to map
the A3SalesRole to the sales RADIUS attribute and the A3MktgRole to the mktg
attribute.

5. Connection Profile. Configure a connection profile to create a correspondence
between the AP SSID and connection profile and the authentication sources that can
be used within that profile.
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Certificates are blocks of data used as part of a network communications technique that
ensures authentication and encryption of data. Certificates are issued and signed by CAs
(certificate authorities). A list of well-known and trusted CAs is often included in operating
system releases. The list below, for example, is from a Windows 10 system:

(=] AddTrust External CA Root [/ Hotspot 2.0 Trust Root CA - 03

= Baltimore CyberTrust Root (5] Microsoft Authenticode(tm) Root Authority
(=] Certification Authority of WoSign [ Microsoft ECC Product Root Certificate Authority 2013
[l Certurn CA (=] Microsoft Intune Root Certification Authority
(= Certurn Trusted Network CA = Microsoft Root Authority

(5] Class 3 Public Primary Certification Authority  [5] Microsoft Root Certificate Authority

[/ COMODQ RSA Certification Authority [ Microsoft Root Certificate Authority 2010

(=] Copyright () 1997 Microsoft Corp. [ Microsoft Root Certificate Authority 2011
_gJDigiCert Aszured ID Root CA _gJNO LIABILITY ACCEPTED, (c)97 VeriSign, Inc.
[/ DigiCert Global Root CA (=] QuoVadis Root CA 2

(= DigiCert Global Root G2 (=] QueVadis Root Certification Authority

[ DigiCert Global Root G3 (= SecureTrust CA

(5] DigiCert High Assurance EV Root CA (= Starfield Class 2 Certification Authority

[ DST Root CA X3 (] Starfield Root Certificate Authority - G2

(=5l Entrust Root Certification Authority (= Starfield Services Root Certificate Authority

[ Entrust Root Certification Authority - G2 (= Symantec Enterprise Mobile Root for Microsoft
(=5l Entrust.net Certification Authority (2048) = Thawte Premium Server CA

[ Equifax Secure Certificate Authority [/ thawte Primary Root CA

=] GeoTrust Global CA [l Thawte Timestamping CA

(= GlobalSign (] USERTrust RSA Certification Authority

(= GlobalSign ] UTN-USERFirst-Object

(= GlobalSign Root CA (= VeriSign Class 3 Public Primary Certification Authority - G5
(=] Go Daddy Class 2 Certification Autherity [ VeriSign Commercial Software Publishers CA
(= Go Daddy Root Certificate Authority - G2 [ VeriSign Universal Root Certification Authority

Other CAs can be created that are trusted by these CAs, or other CAs. A chain of trust can
be established as CAs trust other CAs, called a certificate chain. On the other end of the
scale, a self-signed CA can be created. A3's initial configuration generates a self-signed
certificate for use with encrypted web traffic.

SSL (secure socket layer) is a technique that authenticates and encrypts HTTPS traffic
between clients and web servers, including A3's administrative interface. The server
sends its certificate to clients as part of the initial connection. As noted earlier, most
modern browsers object to A3's use of a self-signed certificate. This can be overridden by
the client, but best practice calls for installation of a certificate from a well-known CA.
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Public and Private Keys

Public and private keys are associated with certificates. Keys are blocks of data, usually

2048 hits or longer in length. They can be generated by CAs, and are always generated in
pairs. The intent is that private keys are kept on the client machine in a secure repository,
while public keys are attached to certificates.

The public and private keys are interrelated such that data encrypted with a public key can
only be unencrypted with the corresponding private key, and vice versa. Using certificates
and public/private keys, two parties can establish encrypted communication and
authenticate the identity of the party that they are talking to.

Only the server is authenticated in most HTTPS communications although mutual
authentication is possible.

Public/private key encryption is a compute-intensive operation and is normally not used for
bulk encryption of data. Instead, the initial connection between parties is used to establish
a single symmetric key used by both parties for bulk encryption. The symmetric key is
changed frequently during a session.

Public Key Infrastructure

Certificates need to be:
* |ssued
e Re-issued upon expiration
¢ Revoked upon request
e Validated

The facilities that perform these functions are called the PKI (public key infrastructure).
PKI providers offer facilities for:

¢ Issuing certificates. Clients format their own certificates and submit request to
PKI providers to sign the certificates. Signing is the process by which the
provider encrypts a digest of the certificate with their private key. Their signature
can be validated against the public key included in their own certificate. Signed
certificates are returned to their clients via download. Certificates are installed
by operating system specific software.

¢ Re-issuing certificates. Every certificate has an expiration date. Providers often
monitor these expirations, sending out warnings to their owners when the
expiration time is near. Providers generate new certificates with new expiration
dates for installation on systems.

* Revoking certificates. An organization can revoke the certificates of its
members, if necessary. The revocation is usually accomplished by adding the
certificate to a revocation list that can be distributed or requested. Timely
distribution can be problematic for large CA trust chains.

¢ Validated. An alternative to distribution of revocation lists is the use of on-
demand validation of certificates. Clients wishing to check the validity of a
certificate can request an immediate validation from the certificate issuer. This
too can be problematic in heavy usage scenarios.

A3 provides the means of designating one or more PKI providers.
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- Itis a very good idea to

I do this before creating a
cluster. A restart is
required after
certificates are installed
in order to make them
effective.

SSL Certificate

A3 uses two types of certificates:

e SSL/HTTPS certificate. This type of certificate is issued for the A3 host and
offered to clients connecting to its web services: A3 administration, client
registration, and A3 sponsor approval.

* RADIUS certificate. This certificate is used for communications between clients,
access points, and A3s that use the RADIUS protocol. Certificates are used by the
PEAP and EAP-TLS authentication protocols. A server certificate is always
present on the A3 server; client certificates may be placed on individual hosts to
facilitate authentication.

A3 provides two facilities for signing and installation of a certificate for SSL
communications:

e Let's Encrypt. Let's Encrypt is a cost-free facility for certificate signing. A3's Ul
automatically requests the signing and installs the certificate. This form of certificate
installation is demonstrated below.

¢ Certificate Authority - an organization can hosts its own certificate server or use one
of a number of commercial certificate authorities. A multi-step procedure is used to
obtain and install a certificate:

a. Usethe A3interface to Generate a Signing Request. This involves filling out a
form with identifying information. The result is a block of text that is a request for
a signed certificate.

b. Copythe block to the clipboard and then paste it into the appropriate place on the
certificate authority’s web site to request the certificate.

c. The certificate authority will send the requested certificate that is download to
the client machine.

d. The A3 Ul is used to install the certificates. Although a new certificate may be
installed, the Ul may not reflect the new certificate until the next A3 reboot.

This form of certificate installation is not illustrated in this guide.

Let's Encrypt
There are several prerequisites for the use of Let's Encrypt:

e Thevalue of A3's common name (e.g. a3.company.com) must resolve to a publicly
accessible address that is mapped to the VIP address of the cluster (B).

e The A3 server must be publicly accessible at that host name.
e The HTTP protocol (port 80) must be enabled to the A3 server via firewall rules.!

Note that this configuration leaves the A3 server accessible from the internet. Controlling
or limiting such access may enhance the security of the A3 system.

The certificates issued by Let's Encrypt have an expiration of 60 days. A warning will be
issued 30 days before expiration as long as the prerequisites listed above remain in effect.

1. During sponsored authentication, the FQDN of the A3 server is sent to the sponsor for use in authorizing a client. Port 443 is used for
this connection and must be accessible internally and/or externally as well. This might be a good time to enable that access.

Part Number:
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Use the following steps to obtain a Let's Encrypt certificate:

1.

2
3.
4
5

Navigate to Configuration > System Configuration > SSL Certificates.

Select E

Select the HTTPS tab.
Ensure that Use Let's Encrypt is enabled.

Enter the externally accessible FQDN of the A3 VIP (A3-Main(c).example.com(d)) in
the Common Name field. Remember, (c) and (d) are just references back to the Table
of Addresses and VLANs; they are not entered into the form.

Click | Testpublicaccess | |f the prerequisites have not been properly implemented a
Request failed with status code 422 message will be displayed.; the 422 code is used
for all problems. Troubleshooting for this problem involves testing for port 80 access to
A3 on port 80 via its FQDN address mapped to its VIP address (B).

If the test succeeded, a Success validating domain message will be displayed.

SSL Certificates
@ HTTPS = RADIUS

Uploading Certificate files requires a restart of radiusd service.

Use Let's Encrypt ()
Comman Name | A3-Main.example.com
Test public access | Success validating domain A3-Main.example.com

Save Cancel

Select the button. A3 takes care of all additional steps: a signing request is
submitted, Let's Encrypt signs the certificate, the certificate is downloaded, and
installed on A3.

Restart the radiusd service on the Status > Services page.

RADIUS certificates are most often handled internally within an organization due to the
possibility of a man-in-the-middle attack. A3 will operate with any CA that supports SCEP
(simple certificate enroliment protocol).

The MS AD CS (Microsoft Active Directory Certificate Service) supports SCEP through an
NDES (Network Device Enroliment Service) add-on module. This section of the guide
outlines the elements needed to integrate MS AD Certificate Service with A3.

The MS CS requires:

A Microsoft Windows 2008 R2 Enterprise server or later on which the certificate
service is installed as an Enterprise Certificate Authority.

A'local DNS service that provides an A-record for the MS AD CS server.
An AD CS Role with the following add-on role services:

e  C(Certificate Authority as an Enterprise CA
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*  Certificate Authority Web Enrollment with all required features.
¢ Online Responder with all required features

¢ Network Device Enrollment Service

The following steps can be used to setup A3 for use with an MS AD CS for EAP-TLS
authentication.

1. Navigate to System Configuration > SSL Certificates > RADIUS.

2. Select | Generate Signing Reguest (CSR) |,

3. Enter appropriate values for your organization:

Field Usage Example
2-Letter Country A two letter country code for your loca- |US
Code tion. Country codes are defined here.
State State for US and Canadian entities. Do | California
not use abbreviations
Locality The city in which the organization is Anywhere

located. Do not use abbreviations.
International entities must enter either a
City/Locality or a State/Province field.

Organization The Organization’s name, as registered |Widgets Plus, Inc.

Name with a government agency. Do not
abbreviate or use any of these symbols: !
@#S D A*()~7></\.

Common Name  The FQDN used for DNS lookups for your | A3-Main.example.com
server. This may a network-local name
for use internally.

Request for RADIUS certific

t
=
m

2-Letter Country Code  US
State  California
Locality ~ Anywhere
Organization Name  Widgets Plus, Inc.

Common Name  A3-Main.example.com

e
4. Select . The text of the signing request is displayed.

5. Select to copy the signing request.

6. The certificate is generated by direct interaction with the CA.

a. Inaweb browser, enter the address of your CA. For example: http://10.150.1.5(G)/
CertSrv.
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b. Log in with your administrator credentials for the certificate server.

Sign in
hittp://10.150.1.5

Your connection to this site is not private

Username administrator

Password | ............ |

m Cancel

c. SelectRequest a certificate.

Welcome

Use this Web site to request a certificate for your Web browser, e-mail client, or
other program. By using a certificate, you can verify your identity to people you
communicate with over the Web, sign and encrypt messages, and, depending upon
the type of certificate you request, perform other security tasks.

You can also use this Web site to download a certificate authority (CA) certificate,
certificate chain, or certificate revocation list (CRL), or to view the status of a
pending request.

For more information about Active Directory Certificate Services, see Active
Directory Certificate Services Documentation.

Select a task:

Request a certificate

View the status of a pending_certificate request
Download a CA certificate_certificate chain, or CRL

d. Selectadvanced certificate request.

Request a Certificate

Select the certificate type:
User Certificate

Or, submit an|advanced cerlificate request. |

e. Paste the previously copied CSR from the clipboard, select Web Server from the
list of Certificate Templates, and press Submit>.

Submit a Certificate Request or Renewal Request

To submit a saved request to the CA, paste a base-64-encoded
CMC or PKCS #10 certificate request or PKCS #7 renewal request
generated by an external source (such as a Web server) in the
Saved Request box.

Saved Request:

Base-64-encoded |1
certificate request Jv:
(CMC or
PKCS #10 or
PKCS #7):

Certificate Template:
[ Web Server v ]

Additional Attributes:

Attributes:
A

Submit »
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f.  Choose Base 64 encoded and select Download certificate.

Certificate Issued

The certificate you requested was issued to you

DER encoded or| '® Base 64 encoded

h.  Find the downloaded file in your operating system and rename it to a3-cert.pem.

7. The MS CA s also used to install the certificate for the CA itself. Continuing from the
previous step:

a. Select @ from the upper-right of the screen and then Download a CA
certificate.

Welcome

Use this Web site to request a certificate for your Web browser, e-mail client,
or other program. By using a certificate, you can verify your identity to people
you communicate with over the Web, sign and encrypt messages, and,
depending upon the type of certificate you request, perform other security
tasks.

You can also use this Web site to download a certificate authority (CA)
certificate, certificate chain, or certificate revocation list (CRL), or to view the
status of a pending request

For more information about Active Directory Certificate Services, see Active
Directory Certificate Services Documentation

Select a task:
Request a certificate
View the status of a pending certificate request

| Download a CA certificate] certificate chain, or CRL

b. Choose Base 64 encoding method and select Download CA certificate.

Download a CA Certificate, Certificate Chain, or CRL

To trust certificates issued from this certification authority, install this CA
certificate

To download a CA certificate, certificate chain, ar CRL, select the certificate
and encoding method.

CA certificate:

Current [wh-lab-DC -CA

Encoding method:

DER
Install CA certificate
Download CA certificate chain
Download latest base CRL
Download latest delta CRL

c. Find the downloaded file in your operating system and rename it to ca-cert.pem.
( )Services must be 8. These two certificates (a3-cert.pem and ca-cert.pem) are both needed for EAP-TLS.
({(B)

" individually restarted on 9. Navigate to Configuration > System Configuration > SSL Certificates > RADIUS.

each member of a
cluster. Restarting 10. Select m

services will disable 11. Select and select a3-cert.pem from the list of downloaded files.
authentication for a 12. Select Choose Certificate Authority
period of time.

and select ca-cert.pem from the list of downloaded files.
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13. Select BESN.

14. Restart all A3 services by navigating to Status > Services and selecting

A PKI provider must be defined to interface with the MS AD CA.
1. Navigate to Configuration > Advanced Access Configuration > PKI Providers.
2. Select | ewriirevee | 5 SCEP PKI.

3. Fill'in the form as suggested below.

Field Usage Example
PKI Provider A name for the provider MSPKI
Name
URL The URL for the SCEP service for | http://10.150.1.5(G)/CertSrv/

the PKI Provider. The URL must end | mscep/

in a forward slash.
CA Certificate The path to the CA certificate to be |/usr/local/A3/raddb/certs/

used to generate client certificate |01.pen

and key combinations.
Server Certificate The path to the RADIUS server /usr/local/A3/raddb/certs/

authentication certificate. 01.pen

4,  Select

Provisioning plays an important partin the proper configuration of clients. Provisioners are
executed as part of the Connection Profiles operation as a result of a successful
authentication. Provisioners deliver configuration information to clients or verify a device's
management status with third-party MDM solutions. On-device agents deliver wireless
network settings to client devices. For i0S-based Apple devices, the required functions are
built-in. A3 includes agents for Android- and Windows-based devices.

The following steps define a provisioner for Windows clients connected through the A3-
Guest and A3-Corp (a) SSIDs.

1. Navigate to Configuration > Advanced Access Configuration > Provisioners.

2. Select | Mewrrovsons - ‘ and then Windows.
3. Fillin the form as suggested below.

Field Usage Example
Provisioning ID  An ID for the provisioner EAP-TLS
Description An description of the provisioner’s Provisioner for EAP-TLS on

scope. Windows systems
Roles The list of roles that the provisioner | Sales, Marketing
will apply to.
SSID The SSID that will invoke the usage of |A3-Corp (a)
the provisioner.
Security Type  The type of security to be used for the |WPA2
SSID.
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Field Usage Example

EAP Type The EAP type to be used with the EAP-TLS
SSID. This should be left blank for no
EAP. Note that this field will not
appear until Security Type is set to
WPA2.

PKI Provider The name of the PKI provider to be MSPKI
used by the provisioner.

4,  Select
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Portal Modules

A3's CWP (captive web portal) is used to authenticate users and their devices to the
network through a set of web pages. The captive web portal may be customized for each
Connection Profile.

There are two principal locations where the captive web portal is specified: in
Configuration > Policies and Access Control > Connection Profiles and in Configuration
> Advanced Access Configuration > Portal Modules. The relationships between the
different types of portal modules are shown in the figure below:

Root

Choice

Authentication
OR
Authentication
OR

Chain

Authentication
Authentication

Install Certificate

-

Message
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Connection Profile Settings

Two particular settings are significant:

¢ Root Portal Module: the name of a root module in the Portal Module configuration.
This refers to the top of the tree for the Connection Profiles.

¢ Logo: the name of the file in the file system where the organization's logo is found. The
logo file is displayed at the top of most authentication pages. The file containing the
logo is defined in Configuration > Policies and Access Control > Connection Profile >
profile name. In the Captive Portal tab, the first entry (Logo) defines where the file is
downloaded from. There are two choices for specification of this file:

e Use an external web server. For example, if example.com has a web server, then
https://www.example.com/my_image.jpg could be used to host the image. The
URL must be available on the internal network. If it is hosted external to the site
the domain (example.com in this example) must be included in Passthrough and
Isolation Passthrough Domains in Configuration > Network Configuration >
Fencing.

e Upload the files to the A3 servers. This operation requires root access to each of
the A3 servers. Contact Extreme Networks support to perform this operation. The
file must be uploaded to each server in an A3 cluster.

Type of Portal Modules

Several type of portal modules can be used to build a portal. Each module can have one or
more actions that set client roles, access duration, and bandwidth limits.

¢  Root. Defines the basic portal sequence. The modules listed in this type of module
operate in a chained manner - each in the order defined. For example, the default root
module shipped with A3 includes three other portal modules, executed in a chain:

Partal Module default_policy gz X

Name default_policy

Description Default portal policy

Modules 1 default_registration_policy ®
default_show_local_account )
default_provisioning_policy )

‘ Reset || Clone

o default_registration_policy - a list of possible authentication mechanisms, which
will be covered in Choice, below.

e default_show_local_account - a module intended to display a local account if
one was specified in an authentication source used for registration. The
operation(s) performed are defined in Actions associated with the module. In the
default case, there are no Actions defined, so this is just a place holder.
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o default_provisioning_policy - a module intended to provide provisioning actions
for clients. The operation(s) performed are defined in Actions associated with the
module. In the default case, there are no Actions defined, so this is just a place
holder.

Choice. Allows clients to choose between selected chained, authentication, and
provisioning modules. The order of modules in the list dictates the order of the
modules as presented to clients. For example, the default registration policy shipped
with A3 includes authentication modules for most types of authentication available in
A3. Each choice is only offered if there is an applicable Source defined in the
Connection Profile, or the module specifies Authentication Sources.

Chained. Specifies a list of modules, all of which must be executed in the order
specified to complete authentication.

Authentication. Several authentication types are available. New modules may be
defined to override required fields, sources, templates, or other modules. The
available types include those listed above in addition to those described in Source by
Options.

All authentication modules have a Mandatory Fields and Fields to Save option. The
values entered by clients during registration are available to the Templates used in
information display.

¢ Choice: a set of authentication sources. This type has the same name as Choice
listed above, but is different in content. It is referred to as Authentication::Choice
in the following discussions.

¢ External: email, null, SMS, sponsor, and OAuth2 sources.

¢ Internal: Login, which covers user name/password-based authentication from
multiple internal sources, including Active Directory and LDAP.

¢ Password: requires a user password.

e Billing: one or more billing sources.

e Blackhole: causes authentication to fail.

e SAML: performs SAML-based authentication.

Provisioning. Triggers provisioning to occur as specified in the Connection Profile.
Message. Displays a message to the client being registered.

URL. This module redirects a client to a local or external URL. This feature is currently
not supported in A3.

Fixed Role. Performs one or more actions for a filtered set of roles.

Select Role. Used to define a module that overrides the role matched when a device is
registered. For example, an administrator can directly set a device’s role, bypassing
authentication rules.

Finer control over authentication sources is available by using the Source by options in the
Authentication::Choice module.

Source by Class. One or more specifications of the form
pf::Authentication::Source::<name> can be used in a Choice module. The <name>
component may be any of the authentication sources defined in Configuration >
Policies and Access Control > Authentication Sources or one of the predefined
classes. In some cases a class may only contain one authentication type:
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¢ Internal sources: ADSource, EAPTLSSource, HtpasswordSource, HTTPSource,
LDAPSource, PotdSource, RADIUSSource, and SAMLSource

¢  External sources: EmailSource, NullSource, SMSSource, and
SponsorEmailSource

e  Social login sources: 0AuthSource (all of the following), FacebookSource,
GithubSource, GoogleSource, InstagramSource, KerberosSource,
KickboxSource, LinkedInSource, OpenlDSource, PinterestSource, TwilioSource,
TwitterSource, WindowsLiveSource

e Authorization sources: AuthorizationSource

¢ Billing sources: BillingSource (all of the following), AuthorizeNet,
ClickatellSource, AuthorizeNetSource, MirapaySource, PaypalSource, and
StripeSource

¢ Exclusive sources: AdminProxySource, BlackholeSource, and EduroamSource

e  Source by Type. One or more type names, indicating individual authentication

methods:
¢ Internal sources: AD, EAPTLS, Htpassword, HTTP, LDAP, Potd, RADIUS, and
SAML

¢  External sources: Email, Null, SMS, and SponsorEmail

e Social login sources: 0Auth (all of the following), Facebook, Github, Google,
Instagram, Kerberos, Kickbox, LinkedIn, OpenlD, Pinterest, Twilio, Twitter,
WindowsLive

e Authorization sources: Authorization

e Billing sources: Billing (all of the following): AuthorizeNet, Clickatell,
AuthorizeNet, Mirapay, Paypal, and Stripe

¢ Exclusive sources: AdminProxy, Blackhole, and Eduroam

¢ Source by Authentication Class. One or more class names, as used in Configuration >
Policies and Access Control > Authentication Sources:

e internal
e external
e hilling

e exclusive

Templates are HTML files that used throughout the portal modules to display static and
dynamic information. In general, the supplied templates are used as shown in the default
portal modules. Templates, however, may be previewed and edited in the Files tab of
Configuration > Policies and Access Control > Connection Profile.

The button will show the template contents, without any dynamic data such as
authentication choices. The button at the top of the page shows a preview for the
Root Portal Module and Authentication Sources associated with the Connection Profile.

Any template can be edited by selecting its name in the Files directory. Modifications
create separate copies of the files that are used only for that Connection Profiles. Be very
careful editing these files; they are often used in multiple contexts. Variables entered and
saved as part of an Authentication portal module may be used via the [« net=rase - | button.
Place the cursor where the variable reference should go and then press the insert variable
button to select the variable.
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As a side note, the authentication type shown to a registering client is dictated by the
Description field for the portal module. For example, the Description field for the null portal
module is initially configured as Null Source. A more user friendly setting might be Free
Wi-Fi.

Example 1: Reorder Choices

Part Number:

The default portal modules display authentication choices in the following order:
¢ Login - user name and password logins
e Guest - email, SMS, sponsored email, null
¢ QOAuth - all social logins
e Billing
¢ SAML
e Blackhole
For example, a particular connection profile may use:
e Guest: null and email
e 0OAuth: Google
e Username and password

In that case, a client authenticating through A3 is offered choices in the following order.

Select an authentication method

This ordering is somewhat unintuitive. A more useful ordering is shown below.

Select an authentication method

( Anonymous Login )
( Register )
( Already Have A Password? )
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The organization of modules to accomplish this can be envisioned as below.
Root
Choice

Anonymous
OR

Choice

Email
OR
Google

OR

Username/Password

Use the following steps to accomplish the desired layout.

1. Defining portal modules from the bottom up, first define a new Anonymous
authentication choice module by cloning the default_guest_policy:

a. Select Configuration > Advanced Access Configuration > Portal Modules.

b. Select the Guest signup module from the (second) Choice category.

» Choice Billing Login ® Provisioning New Module ~

Choice Choice Choice Choice

Guest signup 0Auth login SAML login Refuse Login

c. When selected, the module changes to a graphic that offers the ability to edit or
delete the entry. Select the editicon as shown below.

d. The definition of the default_guest_policy is shown. Select to copy the
entry.

e. Make the following changes to the definition:

Field Usage Setting
Name Name of the module Anonymous
Description Further description Anonymous Registration

Sources by Class A list of possible sources, |pf::Authentica-
by class. See Source by tion::Source::NullSource
Options for a list.
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f.  Select
2. Create a Register module by cloning the Anonymous module, with the following
changes:
Field Usage Setting
Name Name of the module Register
Description Further description Register for Access

Sources by Class A list of possible sources, |pf::Authentication::Source::EmailSource
by class, used in the order |pf::Authentication::Source::0AuthSource
specified. See Source by | pf::Authentication::Source::SponsorEmailSource
Options for a list.

3. Create new login portal module by cloning the default_login_policy.

a. Select Username/password login from the Login category.

e Choice Billing Choice Login ® Provisioning New Module ~
Login
Username/password login

b. Select the editicon and then clone the entry.

c. Make the following changes to the entry:

Field Usage Setting
Name Name of the module HaveAccount
Description Further description Already have a password?
Authentication  Any of the defined authen- |local (As defined in Use Case 3: Local User
Sources tication sources in A3. Authentication)
d. Select

4. Create a new top Choice module by cloning the default_registration_policy.
a. Select Default registration policy from the (first) Choice category.

» Chaice Billing Chaice Login  Provisioning | Mew Module ~
@ Choice
Default registration policy

b. Select the editicon and then clone the entry.

c. Make the following changes to the entry:

Field Usage Setting
Name Name of the module GuestRegistration
Description Further description Guest Registration Policy
Template The template used to display |content-with-choice.html
the options.
Modules The modules to use, in order. |Anonymous
This order dictates the order |Register
shown in the CWP. HaveAccount
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Portal Modules

d. Select

5. Create a new Root module to tie to the Connection Profile.

a. Select New Root Module |

b. Fillin the page with the following contents:

Field Usage Setting
Name Name of the module GuestRoot
Description Further description Guest Root
Modules The modules to use, in order. |GuestRegistration
c. Select

Navigate to Configuration > Policies and Access Control > Connection Profiles.
Select the Guest_Profile profile from the list.
Modify the Root Portal Module setting to Guest Root.

Select to preview the CWP display. Verify the desired ordering as
discussed at the beginning of this example.

© ® N o

Example 2: Two Factor Authentication

Part Number:

Authenticating by a sequence of two methods is a common means for ensuring security in
an organization. In this example, the two methods are:

e Username and password
e SMS text message
The organization of modules to accomplish this can be envisioned as:

Username/Password

SMS

Use the following steps to accomplish the desired layout.
1. Navigate to Configuration > Advanced Access Configuration > Portal Modules.
and then SMS from the list.

2. Create a new SMS Portal Module by selecting

a. Fillin the module’s definition as below:

Field Usage Setting
Name Name of the module SMS_Module
Description Further description SMS Module

Require AUP Indicates whether the Acceptable off
Use Policy will be displayed.

b. Select
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3. Create a new Root module to tie to the Connection Profile.
a. Select [ e |

b. Fillin the page with the following contents:

Field Usage Setting
Name Name of the module Custom_Root
Description Further description Custom Root Module
Modules The modules to use, in order. |default_login_policy
SMS_Module
c. Select

. The default login policy Navigate to Configuration > Policies and Access Control > Connection Profiles.
(53)

" checks all configured
databases (local/LDAP).

Select the Guest_Profile module from the list.
Modify the Root Portal module setting to Custom Root Module.

N o o A

Test as in Use Case 1: Guest Access with Captive Web Portal to verify a two stage
verification.
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() In pre-V3.0 versions of
1" A3 security events were

known as violations.

Fingerbank

Security events are configured by accessing Configuration > Compliance > Security
Events. Security events can detect and handle a wide variety of normal and abnormal
conditions. For example:

¢ Condition detected by a scanning engine, such as Nessus or OpenVAS
e Access by particular types of devices or applications, based on:
* MAC vendor
e 0Sversions
e Browsertype
e  Peer-to-peer connections
e Exceeded limits:
e Bandwidth
e Connection time
e Unusual device operations:
¢  Rogue DHCP message
e Change of host name
e Change of transport method
e Need for provisioning
Security events can be handled using a variety of actions, including:
e Automatic client registration with role
e Isolate client
e Email administrator and/or client’s owner

Isolated clients can receive event-specific messages explaining the event and suggesting
remediation.

Part Number:

Fingerbank performs device profiling or fingerprinting using the Fingerbank system. It
accurately identifies endpoints on your network including type, operating system, and
class. Fingerbank updates are downloaded automatically. Local device definitions are also
supported. Fingerbank tables are found at Configuration > Compliance.

A3's integration with Fingerbank offers the following features and databases that are used
to identify clients or their improper behavior:

¢ Devices - a tree of known device types organized by type

*  DHCP Fingerprints - known combinations of DHCP options used by clients
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Scan Engines

Security Events and Scan

¢ DHCP Vendors - DHCP software vendors and versions

¢ DHCPv6 Fingerprints - known combinations of DHCPv6 options used by clients
e DHCPv6 Enterprises - known DHCPv6 enterprises (like DHCP vendors)

¢ MAC Vendors - known MAC vendors, by OUI (organizationally unique identifier)
e User Agents - user agent strings sent from the browser used by the client

e Combinations - user defined combinations of Fingerprint specifications

¢ Client Change Detection - specifies when a device class change alert should be
triggered

Nessus

The Nessus server
should be installed on a
separate server from the
A3 server.

(((i)))

OpenVAS

) The OpenVAS server

1" should be installed on a
separate server from the
A3 server.
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A3 scan engines entries define the interface to freeware and commercial software
packages that find and flag conditions present on a client. For example:

e Qutdated OS versions
*  Non-existent, unapproved, or out-of-date anti-virus or other security software
e QOpen TCP/IP ports

Scan engines must be defined in A3 in order for security events that use their violations to
have effect. Scan engines are defined in Configuration > Compliance > Scan Engines. The
definition of scan engines is covered by A3's online help.

A3 supports several scan engine products:

e Nessus
e OpenVAS
e Rapid7

e Microsoft WMI (Windows Management Instrumentation)

Nessus can be downloaded from http://www.nessus.org/download. Download and install
the package for your operating systems. You will also need to register for the HomeFeed
(or the ProfessionalFeed) to get plug-ins.

After installing Nessus, follow the Nessus documentation for the configuration of the
Nessus Server, and to create a user for A3. A3 imposes the following requirements:

1. A3 must be able to communicate with the Nessus server on the port specified in the
installation.

2. The Nessus server must be able to access the client systems. Local network access is
required if scan on registration is enabled.

Please visit http://www.openvas.org/install-packages.html#openvas4_centos_atomic to
configure the correct repository to be able to install the latest OpenVAS scanning engine.

Once installed, follow the instructions to correctly configure the scanning engine and
create a scan configuration that will fit your needs. You'll also need to create a user for A3
to be able to communicate with the server.
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Engines

Rapid7

Rapid7 Installation

Rapid7 A3 User
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Security Events and Scan

Itis important to get the correct scan config ID and NBE report format ID to populate the
parameters in the A3 configuration file. The easiest way to get these IDs is by downloading
both of the scan configuration and report format from the OpenVAS web Ul and retrieve
the IDs in the filenames.

For example report-format-fsc2a364-47d2-4700-b21d-0a7693daddab.xml gives report
format ID f5c2a364-47d2-4700-b21d-0a7693daddab.

A3 imposes the following requirements:

1.

A3 must be able to communicate with the OpenVAS server on the port specified in the
installation and in the OpenVAS scan engine definition.

The OpenVAS server must be able to access the client systems. Local network access
is required if scan on registration is enabled.

The OpenVAS server must be able to reach A3's administrative interface on port 1443
using its DNS entry.

A valid SSL certificate must be installed on the A3 server.

Rapid7 can be integrated with A3 to automatically start a scan with a client connects to the
network. Alert generation via syslog integration is currently not available.

Install the InsightVM application from https://insightvm.help.rapid7.com/docs/
installing-in-linux-environments#section-installing-in-red-hat.

Run the application. Refer to https://insightvm.help.rapid7.com/docs/running-the-
application#section-managing-the-application-in-linux.

Log into the Rapid7 server: https://<Rapid7ServerIP>:3780, where <Rapid7ServerlP> is
the IP address of the Rapid7 server.

Create a site for the devices you want to manage in Rapid7, you will need to reference
itin the A3 configuration.

Navigate to Administration > Users.
Click Create.

Configure an appropriate name and password for a Rapid7 account that will be used
by A3 to perform API calls on Rapid7.

In the roles for that user, select the Custom role and assign the following privileges:
* Manage Sites

e Manage Scan Engines

e View Site Asset Data

e Specify Scan Targets

e View Group Data

In SITE PERMISSIONS, grant access to all sites.

In ASSET GROUP PERMISSIONS, grant access to all asset groups.

Click SAVE.
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A3 Configuration
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Security Events and Scan

Scan Engine Definition

Configure a new scan engine for Rapid7:

1. Navigate to Configuration > Compliance > Scan Engines.
2. Cligk | renzencrane -
3. Fill'in the following fields:

and select Rapid7.

Field Value

Name Rapid7

Host Name or IP Address  |Rapid7ServerlP

User Name User name defined in Rapid7 A3 User.

Password Password defined in Rapid7 A3 User.

Verify Host Name Off unless a valid certificate has been generated and
installed for Rapid7ServerlP.

Roles Employees (or a role defined for all applicable users)

0S The operating systems that the scan engine will be
applied to.

Scan Before Registration | On. Leave this and the two following off if scanning will
only be performed manually.

Scan on Registration Off

Scan After Registration Off

4. The scan template, site, and scan engine will be configured after the scan engine is
defined.

5. Click
6. Select the Rapid7 scan engine from the list of defined scan engines to edit the
settings.

7. Selectthe Scan Engine, Scan template, and Site from the drop down lists populated
from Rapid7.

Connection Profile

For each connection profile associated with users who need to be scanned, select the
Rapid7 scanner from the Scanners setting in the connection profile.

Viewing Rapid7 Results

The results of Rapid7 can be viewed in the entry for a client in the Clients table. A separate
Rapid7 tab is shown, with sub-tabs for Summary, Device Profiling, Top Vulnerabilities, and

Last Scan.
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Microsoft WMI (Windows Management Instrumentation)

WNMI can be used on Windows-based PCs that have been joined to the domain to scan for
violations and suspect conditions. A3's interface connects any violations found to security
events. WMI must be enabled on each windows device with a GPO (global policy object) in

Part Number:

Active Directory.

Multiple steps are required to use WMI A3 for each security event. For example, 0S
version out of date, no anti-virus software, or anti-virus software is out of date.

1. In Configuration > Compliance > Security Events set up a new security event. Set up a
desired enforcement action for the violation.

Field Value
Enable Security Event On
Identifier xxxx (used suggested number)
Trigger Client, Client Profiling, Data Usage - all default

Event: Internal xxxx

Event Actions

Isolate, Email Administrator

2. In Configuration > Compliance > WMI Rules, Rules Actions component add in a
snippet for the violation. For example, the following snippet detects if Google is
running. The tid value corresponds to the security event ID found in Configuration >
Compliance > Security Events. A list of the example security events for WMl is found

at Miscellaneous.

3. Theitems in bold will trigger the violation established in step 1 above.

[Google]

attribute = Caption
operator = match
value = Google

[1:Google]

action=trigger_violation
action_param = mac = $mac, tid = xxxx, type = INTERNAL

4.  Setupthe WMI scanner on the Windows PC.
5. Associate the WMI scanner with a Connection Profile.
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Security Events

Security Events and Scan

The key components of a security event are:
e EventTriggers - controls when a security event is invoked

e EventActions - what to do when the event is triggered

Event Triggers
A security event can use multiple individual triggers, any of which can occur. Each trigger
has four components: client, client profiling, data usage, and event. For example,
Event Triggers Client Client Profiling Data Usage Event
No condition R All device types DR Any data usage [0 1':?,}%35 =
[ OR |
2 Mo condition EHE) All device types QR Any datausage (DD 1'.’2".":[?;';. =
[ OR
3 No condition R All device types EOE) Any data usage [0 1_.Jz”'.TEE;"7 e
[ OR
4 No condition  ENE) Ac Any data usage (O3 Any event =]
specifies four possible conditions, any of which can invoke the event. Each trigger is based
on four clauses:

e Client - based on role, MAC address, IP address, or connecting device (accessing
point).

e Client Profiling - client profiling uses information gathered from Fingerprint
identification. Client profiling clauses are based on the device classification, DHCP
fingerprint, DHCP vendor, or MAC vendor.

¢ Data Usage - based on upstream and/or downstream data consumption over a period
of time.

* Event- based on other security events, events from scan engines, or internally
triggered events. Internal events include host name change, new DHCP information,
device parking, change of connection type, or client discovery.

Event Actions

Part Number:

Any combination of the following actions may be executed when the event s triggered:
e Unregister - removes a devices registration status
* Register - register clientin a role for a period of time

¢ Isolate - move clientinto a specific role (such as isolation). The client can receive a
browser message indicating the nature of the problem and offering the ability to retry
access.
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Built-in and Sample Events Security Events and Scan

Engines
( )Execute Scripts must be ¢  Email administrator - the administrator is apprised of the violation
((B)
" downloaded to each Email Client Owner - the client receives a copy of the administrator’s email with
cluster member using additional text
root access. Contact . E te Scrint d loaded scriot i ted
support for assistance, xecute Script - a user downloaded script is execute

e Close Another Security Event - stops other events from triggering an action

Built-in and Sample Events

A3includes a number of predefined security events, some of which are ready-to-go and
some of which must be enabled or require triggers or other parameters to be useful. The

pre-defined events are described in the tables below

Scan Engine Related

Internal

Description Trigger Action

Pre Reg System Scan |Just prior to registration.

Client is placed into the Isolation network.

Required to be Useful

Define script to be exe-
cuted.

Post Reg System Scan |Just after registration.

Nessus

Description Trigger Action

Nessus Scan Any of a number of Nessus viola- |Clientis placed back into the Registration

Client is placed into the Isolation network.

Define script to be exe-
cuted.

Required to be Useful

Nessus scan engine defi-

tions. network and an email is sent to t he admin- | nition.
istrator.
Suricata
Description Trigger Action Required to be Useful

P2P Isolation An ET P2P event. Client is placed into the Isolation network |Suricata scan engine
and an email is sent to the administrator. | definition.

Malware An ET MALWARE condition. Client is placed into the Isolation network |Suricata scan engine
and an email is sent to the administrator. | definition.

IRC Trojan An ET TROJAN condition. Client is placed into the Isolation network |Suricata scan engine
and an email is sent to the administrator. | definition.
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OpenVAS
Description Trigger Action Required to be Useful
OpenVAS Scan Any of a number of OpenVAS vio- |Clientis placed back into the Registration |OpenVAS scan engine
lations. network and an email is sent to the admin- | definition.
istrator.
WMI Related
Description Trigger Action Required to be Useful
Telnet Scan WMI event Client is placed into the Isolation network |Define WMI Rules.
and an email is sent to the administrator.
Remote Desktop Scan |WMI event Client is placed into the Isolation network |Define WMI Rules.

and an email is sent to the administrator.
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Device Isolation

Policy
Description Trigger
MAC Vendor isolation |Any device with MAC QID of 29.
example Refer to Configuration > Compli-

ance > Devices for a description.

Action

Client is placed into the Isolation network
and an email is sent to the administrator.

Security Events and Scan

Required to be Useful

Change/add device spec-
ifications.

Three old versions of Windows,
plus two device numbers.

Ancient 0S isolation
example

Client is placed into the Isolation network
and an email is sent to the administrator.

Change/add device spec-
ifications.

Devices that have a MAC address
starting with 01:23:45

MAC isolation example

Client is placed into the Isolation network
and an email is sent to the administrator.

Change/add MAC
address specifications.

Bandwidth Limit exam- | More than 20GB within a month. |Client is placed into the Isolation network |Change limit.
ple and an email is sent to the administrator.
Device based Band- |Any Android device exceeding 1 |Clientis placed into the Isolation network |Change/add device types
width Limit Example  |GB in a month. and an email is sent to the administrator. |and limits.
Time Expiration None Client is placed back into the Registration |Settime limitin Data
network, so that re-registration is required. | Usage column. Enabled
by default.
Bandwidth Limit None Client is placed back into the Registration |Set bandwidth limitin
network, so that re-registration is required. | Data Usage column.
Enabled by default.
Lost or Stolen None Client is place into the Isolation network | Add triggers to specify
and an email is sent to the administrator  |individual devices by
and client owner. The clientis not given a |MAC address.
remediation button.
Generic None Client is placed into the Isolation network |Assign triggers.

and an email is sent to the administrator.

Block all mobile Any phone, tablet, or wearable.

Client is placed into the Isolation network

None, disabled by

devices and an email is sent to the administrator. | default.
Block Apple iPod, Any Apple mobile device. Client is placed into the Isolation network |None, disabled by
iPhone oriPad and an email is sent to the administrator. | default.
Block BlackBerries Any RIM Blackberry device. Client is placed into the Isolation network |None, disabled by
and an email is sent to the administrator. | default.
Block PS3 and PSP Any Sony Gaming Console. Client is placed into the Isolation network |None, disabled by
and an email is sent to the administrator. | default.
Block Slingbox Any Slingbox device. Client is placed into the Isolation network |None, disabled by
and an email is sent to the administrator. | default.
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Description
Rogue DHCP

Suspicious Behavior or Conditions

Trigger
Rogue DHCP request.

Action

Client is placed into the Isolation network
and an email is sent to the administrator.

Security Events and Scan

Required to be Useful
None, enabled by default.

Connection transport
change

Client changed their connection
type. E.g. wired to wireless.

Client is placed into the Isolation network
and an email is sent to the administrator.

None, enabled by default.

Fingerbank device
class change

A change in Fingerbank device
classification.

Client is placed into the Isolation network
and an email is sent to the administrator.

None, enabled by default

LSASS Exploit

An attempt to circumvent Micro-
soft LSASS security enforcement.

Client is placed into the Isolation network
and an email is sent to the administrator.
Further stinger.exe is invoked to remove
specific viruses.

None, disabled by
default.

NetBIOS Scan

One of several NetBIOS condi-

Clientis placed into the Isolation network

None, disabled by

tions detected. and an email is sent to the administrator. | default.
Zotob (W.32.Zotob and |Detects Zotob virus Clientis placed into the Isolation network |None, disabled by
variants) and an email is sent to the administrator. |default.
Miscellaneous
Description Trigger Action Required to be Useful

Provisioning Enforce-
ment

Internal. If registration occurs
outside of a CWP, the trigger
occurs two minutes after registra-
tion.

Perform provisioning actions specified in
the Connection Profile.

Specify provisioning
actions in Connection
Profile.

Generic None Client is placed into the Isolation network |Assign triggers.
and an email is sent to the administrator.
defaults None. Client is placed into the Isolation network |Default values used for a
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and an email is sent to the administrator.
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Provisioning

Provisioning plays an important part in proper client configuration. Provisioners are
executed as part of Connection Profile operation as part of the authentication process.
Provisioners deliver configuration information to clients or verify a device's management
status with third-party MDM (mobile device management) solutions. On-device agents
deliver wireless network settings to client devices. The required functions are built into
i0S-based Apple devices. The required agents to Android- and Windows-based devices
must be downloaded.

The figure below shows an overview of the components involved in provisioning.

Connection
Profiles
Roles Fingerbank
+ Others
PKI Providers Android, Apple, Windows
+ . Third Party
PKI Servers Captive Portal Provisioners/MDMs
Android Arlple Winiows Clients
Android Play A3 Windows
Sfcle ApplI WL Profile
Apple Access

The key elements are:

¢ Connection Profiles: multiple provisioners can be invoked in the final step of
authentication, tying together all other configuration elements. Provisioners are
performed in the order they are defined until one that satisfies operating system and
role constraints is executed.

*  Provisioners: provisioners provide configuration for possible clients, filtering based

on operating system, roles, and other conditions. Several provisioners are built into A3

to perform common tasks:
e Android - configures a wireless profile for Wi-Fi connection
®  Apple- configures a wireless profile for Wi-Fi connection

e Windows- configures a wireless profile for Wi-Fi connection
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e Accept: accepts client (filtering on role and 0S) without any further provisioning
¢ Deny: denies clients based on role and 0S
¢ Interfaces: connect to third party provisioners and MDMs

* Roles: the list of all possible roles. Each provisioner has an optional set of roles to use
as afilter. Client roles are set as part of authentication as described in Configuration >
Policies and Access Control > Authentication Sources. A client's role must match one
of the settings in the provisioner role list unless the list is empty.

* Fingerbank: provides operating system identities used by provisioners to filter
inapplicable clients.

*  PKI Providers: provide an interface to PKI servers that generate certificates used to
sign other certificates and trust third parties.

e Captive Portal: the captive web portal is used by Android, Apple, and Windows
provisioners to configure clients with these operating systems. Android clients are
redirected to obtain their agents through the Android Play Store. Apple clients
incorporate agent functionality. Windows agents are contained within A3 and are
automatically downloaded. Each of these provisioners may specify a new wireless
connection from the access pointincluding SSID, EAP, and security type.

¢ Access point: Android, Apple, and Windows provisioners may specify a new
connection from the access point, including SSID, EAP, and security type during their
execution.

e Third party provisioners and MDMs: A3 provisioners are interfaces to online systems
associated with an MDMs. A3 uses these interfaces to query the MDM to determine if
the clientis included in their databases. If not, the client is transitioned to a isolation
status. If the clientis in the MDMs database, then it is assumed that the client has
been previously configured by the MDM. The compatible MDMs are described in the
following sections.

Mobile Device Managers

The following MDMs are compatible with A3. Configuration of each takes place in
Configuration > Advanced Access Configuration > Provisioners.

Cisco DPSK

The Cisco DPSK (dynamic pre-shared keys) provisioner causes A3 keys to be dynamically
generated.

Jamf

The A3 interface to Jamf requires the use of a cloud account. The cloud account provides
the necessary keys and other information for a connection.

Microsoft Intune
Microsoft Intune using the Azure portal.
1. Loginto the Azure portal and ensure that you have Intune licenses.

2. Fromthe Azure portal , you'll need to create an application to enable access to the
Graph API:

a. Select Azure Active Directory.
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b. Select App registrations.
c. Select New registration.
3. Onthe Register an application form, enter:
a. A3, or some other name, in the Name field.
b. Select Accounts in this organizational directory only (company name).
c. Select Done.
4.  On the following form entitled with the Name from above:

a. Copy the following that will be used to configure A3: Application (client) ID,
Directory (tenant) ID, and Object ID.

b. Select Certificates & secrets.
c. Select New client secret.

d. This will present a password for use for the application. Copy it now; there will
not be an opportunity later.

e. Add permissions to the API:
i. Select APl permissions.
i. SelectMicrosoft Graph.

iii. Inthe right pane select Application permissions and add two lines:
Device.ReadWrite.All and DeviceManagementManagedDevices.Read.All.

f.  Select Grant admin consent.

Mobhilelron

Mobilelron supports provisioning of Android, Apple, and Windows devices. Use the
following steps to prepare for Mobilelron for use with A3:
1. Loginto your Mobilelron account and select SETTINGS.
a. Create an MDM certificate for use with Apple devices by clicking Install MDM
Certificate.
2. Create a user with rights to access Mobilelron's API:
a. Select USERS & DEVICES, then Users, and then click Add local user.
b. Enterinformation for a user (e.g. a3user), noting the user name and password.
c. Click SAVE.
d. Selectthe ADMIN tab, check the box for the just-entered user, then click Actions
and choose Assign to Space.
e. Select Global space at the top and check API at the bottom.
3. Obtain the name of the boarding host by adding a fake device to Mobilelron. At the
end of the process the registration instructions will be displayed. The boarding host is
labeled as the Server Address on that page.

OPSWAT

OPSWAT Metadefender Endpoint provides information about device compliance before
and during network access. The following discussion assumes that OPSWAT server
components have been installed on a separate host from the A3 host and are referred to
via an IP address of 10.150.1.55 or name of localhest. The following steps are used to
configure an OPSWAT account:

1. Create an OPSWAT Metadefender Endpoint account at https://www.opswat.com/
products/metadefender/endpoint/management/.

2. Create a developer account at https://gears.opswat.com/developers.
a. Register a new application with a callback URL of http://10.150.1.55/opswat.
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Mobile Device Managers

SentinelOne

d.

Provisioning

Note the client key and client secret.

Obtain an install URL by clicking +Devices, then Enable Metadefender Endpoint
client on another device, then Download or send link for guest Metadefender
Endpoint clients.

Note the URL at the bottom of the screen.

3. Generate an OAuth2 access and refresh token:

a.

Access the web page at https://gears.opswat.com/o/oauth/
authorize?client_id=<clientid>&response_type=code&redirect_uri=http://
10.150.1.55/opswat, where <clientid> is your client key obtained in step 2b.

When the application is authorized, the browser will be redirected to a non-
existent web page: http://10.150.1.55/opswat?code=<code>.

Generate the access and refresh tokens using: https://gears.opswat.com/o/
oauth/ token?client_id=<clientid>&client_secret=<clientsecret>
&grant_type=authorization_code&redirect_uri=http://10.150.1.55/
opswat&code=<code>. <clientid> and <clientsecret> were obtained in step 2b,
while <code> is from step 3b.

The access token and refresh token will be embedded in a message of the form:

{"access_token":"ab3aec71-faba-4752-8804-

00c37f934059","token_type":"bearer","refresh_token":"f9e7¢698-4d88-42ch-b9ae-
c067557e8385","expires_in":43199,"'scope™:"read", "client_id":"1234567890'}

SentinelOne performs provisioning for Windows and Mac 0SX clients. SentinelOne
requires root access to the A3 server, which is not currently supported.

SEPM (Symantec Endpoint Protection Manager)

SEPM is used for provisioning Windows 32- and 64-bit clients. SentinelOne requires root
access to the A3 server, which is not currently supported.
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Barracuda
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A3's firewall integration informs firewalls which clientis using a particular IP address. This
information can be used by the firewall to apply per-user or per-role policies, effectively

establishing single-signon. The firewalls supported by A3 include:

Barracuda
Checkpoint
FamilyZone
FortiGate
Iboss
JSON-RPC
JuniperSRX
LightSpeed Rocket
Palo Alto
SmoothWall
WatchGuard

A3 Configuration
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Assuming that the host name for the firewall is barracudaNG, create a Firewall SSO:

1.
2.
3.

Navigate to Configuration > Integration > Firewall SSO.

Click | newriewa- | and select BarracudaNG.

Fill in the following fields:

Field

Host Name or IP address

barracudaNG

User Name Administrator login name on the firewall
Secret or Key Password or secret key defined on the firewall
Roles Employees (or a role defined for all applicable users)

SS0-Enabled Networks

The subnets on which SSO will apply

Default Realm

Click

default
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Checkpoint

Verification

Checkpoint

Firewall Integration

SSH to the Barracuda NG system and type the command:

‘ acpfctrl auth show

The response should be similar to:

[root@baracudafw:~J# acpfctrl auth show
1 entries

172.20.20.152/0

origin=A3

service=A3

user=Jdoe

Setting up the Checkpoint Firewall
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Enable Identity Awareness

To enable Identity Awareness on the Checkpoint Security Gateway:

1.

2
3.
4

Navigate to the SmartDashboard.
From the Network Objects tree, expand the Check Point branch.
Double-click the Security Gateway on which to enable Identity Awareness.

In the Software Blades section, select Identity Awareness on the Network Security
tab. The Identity Awareness Configuration wizard opens.

Select one or more options. These options set the methods for acquiring identities of
managed and unmanaged assets.
Select AD Query to allow the Security Gateway seamlessly identify Active Directory

users and computers and click Next. The Integration With Active Directory window
opens.

Select the Active Directory to configure from the list that shows configured LDAP
account units or create a new domain. If you have not set up Active Directory, you
need to enter a domain name, username, password and domain controller credentials.

Enter the Active Directory credentials and click Connect to verify the credentials.
Important - For AD Query you must enter domain administrator credentials.

Click Finish.

Enable RADIUS Accounting
To enable RADIUS Accounting for a Security Gateway:

1.
2.

In the SmartDashboard Network Objects tree, open the Security Gateway.

On the General Properties page, make sure that the Identity Awareness Blade is
enabled.

On the Identity Awareness page, select RADIUS Accounting.
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A3 Configuration

FortiGate

Firewall Integration

Configure RADIUS Accounting

1. Inthe Check Point Gateway Window > Identity Awareness panel, click Settings to the
right of the RADIUS Accounting option.

2. Inthe RADIUS Accounting Settings window, configure the Message Attribute Indices:
e Device Name: Calling-Station-1d (31) (MAC Address of the AP)
e User Name: User-Name (1) (Username on the A3 Portal)

e Device Name: Framed-IP-Address (8) (IP Address of the device in the production
network)

RADIUS Client Access Permissions

Gateway interfaces must be authorized to accept connections from A3 RADIUS
Accounting. To select gateway interfaces:

1. Inthe RADIUS Client Access Permissions section, click Edit.

2. Select All Interfaces - All Security Gateway interfaces can accept connections from
RADIUS Accounting clients.

3. Leave the default port to 1813.
4.  Click OK on both windows to submit the configuration.

5. Select Policy > Install from the SmartDashboard menu.

Assuming that the host name of the Checkpoint firewall is cpfw, and the name of the
default realm is default, configure the A3 SSO definition as per the following instructions:

1. Navigate to Configuration > Integration > Firewall SSO.
2. Click | newrrewai~ | and select Checkpoint.
3. Fill'in the following fields:

Field Value
Host Name or IP address  |epfw
Secret or Key The RADIUS shared secret from the Checkpoint config-
uration.
Roles Employees (or a role defined for all applicable users)
SS0-Enabled Networks The subnets on which SSO will apply.
Default Realm default

4. Click

Setting up FortiGate Firewall

Part Number:

Configuration of RSSO Agent

1. Navigate to the FortiGate administration web page in User & Device > User > User
Groups > Create New.
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FortiGate

A3 Configuration

Part Number:

Firewall Integration

2. Fillin the form as per the following:

Field Value
Name RSSO_group
Type RADIUS Single Sing-On (RSSO)
RADIUS Attribute Value Employee (to match the A3 Role)

3. Click OK.

Configure the Endpoint Attribute
Change the endpoint attribute to User-Name via CLI:

config user radius

edit RSSO_agent

set rsso-endpoint-attribute User-Name
end

Activate Account Listening

1. Navigate to System > Network > Interfaces.

2. Selectthe interface that will communicate with A3.
3. Check Listen for RADIUS Accounting Messages.

Assuming that the host name of the Checkpoint firewall is fgfw, and the name of the default
realm is default, configure the A3 FortiGate definition as per the following instructions:

1. Navigate to Configuration > Integration > Firewall SSQO.
2. Click | "=*"==~ | and select FortiGate.

3. Fillin the following fields:

Field Value
Host Name or IP address  |fgfw
Secret or Key The RADIUS shared secret from the FortiGate configu-
ration.
Roles Employees (or a role defined for all applicable users)
SS0-Enabled Networks The subnets on which SSO will apply.
Default Realm default

4. Click
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JSON-RPC Firewall Integration

JSON-RPC

The JSONRPC module shipped with A3 is a generic firewall SSO module for use with Linux
or BSD firewalls that do not ship by default with a vendor-specific SSO interface.

A simple JSON-RPC server written in Python that is compatible with this specification and
creates ipsets based on the SSO information provided by A3 can be found at https://
github.com/tribut/ipset-rpcd.

A compatible server must implement the Start and Stop methods, both with the identical
set of parameters provided below:

Field Value
Protocol JSON-RPC 2.0 over HTTPS
Authentication HTTP Basic authentication
Methods Start, Stop

Parameters

user (string)| Username that registered the device
mac (string) | MAC address of the device

ip (string) | IP address of the device
role (string)| A3 role assigned to the device
timeout (int) | Registration expiration in seconds

Response Success must be indicated by “result”: [*0K"]. Any-
thing other than OK is considered an error message.

A3 Configuration
Assuming that the host name of the firewall is json, and the name of the default realm is
default, configure the A3 SSO definition as per the following instructions:
1. Navigate to Configuration > Integration > Firewall SSQO.
2. Click [ newrrenai- | and select JSONRPC.
3. Fill'in the following fields:

Field Value
Host Name or IP address  |json
Username HTTP Basic credentials
Password HTTP Basic credentials
Roles Employees (or a role defined for all applicable users)
SS0-Enabled Networks The subnets on which SSO will apply.
Default Realm default

4. Click
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Palo Alto Firewall Integration

Palo Alto

The integration between This section describes how to set up A3 to communicate the identity of authenticated

Eid A3 and a Palo Alto clients with a Palo Alto Networks firewall. This allows the Palo Alto Networks firewall to
Networks firewalls create identity-based security rules instead of subnet/VLAN/host-based rules. The
requires the use of network is then able to assign and enforce security policy based on the identity of the user,
PANOS 6.0 or higher on no matter what device they use.
the Palo Alto firewall.

Setting up the Palo Alto Networks Firewall

In order to create user-based firewall policies, the firewall must be enabled to connect to
the domain using LDAP, and set up WMI authentication. The firewall can be set up
according to the documentation at https://www.paloaltonetworks.com/documentation/81/
pan-os/pan-os/user-id/enable-user-id.

Create PA API XML Role

A security best practice is to not use the default admin account to generate the token, but
rather to create a separate local account on the firewall. First define a role to assign to the
new local account.

Log on to the management interface of the Palo Alto Firewall.
Select Device > Admin Roles > Add.

Setthe name to SS0_Role or something similar.

Disable all rights in the Web Ul tab.

Enable all features in the XML API tab.

Select OK.

Save and Commit the configuration.

N o ok~ wnNh -

Create PA XML API User Account

1. Log on to the management interface of the Palo Alto Firewall.
2. Select Device > Administrator > Add.

3. Fill'in the following fields:

Field Value
Name xmluser
Password FREFIHHRE
Confirm Password ERRKRKKHK
Administrator Type Role Based
Profile SSO_Role

4,  Select OK.

5. Save and Commit the configuration.
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Palo Alto

A3 Configuration

Verification

Part Number:

Firewall Integration

Assuming that the host name of the Palo Alto firewall is pafw, and the name of the default
realm is default, configure the A3 SSO definition as per the following instructions:

1. Generate the token (secret or key) using the following URL: https://pafw/api/
2type=keygen&user=[xmlapiaccount]&password=[password], where [xmlapiaccount]
and [password] are as defined in Create PA XML APl User Account.

2. Navigate to Configuration > Integration > Firewall SSO.
3. Click | newrrawai~ | and select PaloAlto.

4. Fillin the following fields:
Field

Host Name or IP address

Value

pafw

Vsys

1if not used in a virtual environment, or the vsys num-
ber otherwise

Secret or Key

As generated in step 1) above.

Roles

Employees (or a role defined for all applicable users)

Networks on which to do
SSO

The subnets on which SSO will apply.

Default Realm

5. Click

default

The Palo Alto firewall should now show the identity of users authenticating to A3. Refer to
the Monitor tab > traffic in the Source User column.
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networks

Use Case 1: Guest Access with Captive Web Portal

Part Number:

This use case implements guest authentication using most of A3's external authentication
sources (see External Authentication Sources):

e Null - no identification is required.

e Email - the client enters their email address, which A3 uses to send a message. The
message that the client receives includes a link that will complete the authentication.
This form of authentication requires that Alerting be set up during Initial A3
Configuration.

e SMS - the client enters their cell phone number, which A3 uses to send an SMS
message. The message that the client receives includes a PIN (personal identification
number) that is entered into the CWP (captive web portal) page to complete the
authentication. This form of authentication requires that Alerting be set up during
Initial A3 Configuration.

The sponsor external authentication types will be demonstrated in Use Case 4: Sponsored
Access, for use with Active Directory.

A3 is configured through its administration interface. Access point configuration through
ExtremeCloud 1Q is covered in MAC Authentication.

A3 configuration requires definition or modification of several A3 settings:
1. Roles - classifies the type of user. In this case, a predefined guest role will be used.

2. Authentication Sources - defines how user information is to be gathered and ties
users to roles.

3. Devices - defines the network devices that authenticate clients against A3, in this
case the Extreme Networks access point.

4. Connection Profile - ties together the authentication source with a connection source,
in this case an access point’s A3-Guest SSID. The connection profile also determines
the RADIUS type and value attributes that will be sent to network devices upon
connection and registration.

When configuration is completed, authentication will be tested, and audit logs will be
examined.

Start by entering the A3 configuration interface, either continuing from the initial
installation or invoking the interface via https://<(B) address>:1443.
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Roles

with Captive Web Portal

Roles

Use Case 1: Guest Access

Roles are accessed through the following steps:

1. Select Configuration > Policies and Access Control > Roles.

2. The list of predefined roles is shown. Verify that the guest role is visible.
All of the authentication sources in this use case will use the guest role.

Authentication Sources

Email

SMS

Part Number:

Inspect the null authentication source.

1. Select Authentication Source from the list on the left, below Roles.

2. Selectthe null source in the External Sources drop-down list.

3. Select Authentication Rules > Rule - catchall () at the bottom of the page.
4

The catchall Authentication Rule states that anyone authenticating against this
source will be assigned to the role of guest and allowed to use the network for 1 day
before needing to re-register. No modification to this rule is required.

5. Click Authentication Sources from the left-hand menu to return to the main
Authentication Sources page.

Inspect the Email authentication source.

1. Select Authentication Source from the list on the left, below Roles.

2. Selectthe email source in the External Sources drop-down list.

3. Select Authentication Rules > Rule - catchall () at the bottom of the page.
4

The catchall Authentication Rule states that anyone authenticating against this
source will be assigned to the role of guest and allowed to use the network for 1 day
before needing to re-register. No modification to this rule is required.

5. Click Authentication Sources from the left-hand menu to return to the main
Authentication Sources page.

The next steps involve selection and modification of the SMS authentication source.
1. Select Authentication Source from the list on the left, below Roles.
2. Selectthe sms source in the External Sources drop-down list.

3. The smsdialog is displayed. The SMS Carriers box is pre-populated with a large
number of supported carriers. You may leave the list alone, or pare it down.

4. Click Save to save the authentication source if any changes were made or click
Authentication Sources from the left-hand menu to return to the main Authentication
Sources page.
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Devices
with Captive Web Portal

Devices

Use Case 1: Guest Access

Connection Profile

Device configuration is next:

1.
2.

Click Devices beneath Network Devices. The list of predefined entries is displayed.

A device for an access point must be defined. Click the New Device drop down
control and then select Aerohive_AP.

In the New Device form:

a. Enterthe IP address of your access point 10.150.1.19 (C) or an entire subnet using
CIDR format in the IP Address/MAC Address/Range (CIDR) field.

b. Enter a Description.
c. Ensurethatthe Use CoA box is selected.

Select the Roles tab, ensure that only Role by Device Role is enabled. Enter
registration (e), isolation (f), and guest (g) next to the same-named entries. This
dictates which RADIUS value will be returned to the access point for each A3 role and
must match what was entered in ExtremeCloud 1Q. Values are case sensitive.

Select the RADIUS tah. Enter 8AB7tHkP (b) into the Secret Passphrase field. This
matches the setting entered in the ExtremeCloud 1Q.

Click Create.

Part Number:

The connection profile ties together the access point’s SSID with authentication sources.
To define a new profile:

1.

2
3.
4

Select Configuration > Connection Profiles
Select New Connection Profile.
Fill in Guest_Profile as the profile name and enter a description.

Uncheck 802.1X Recompute Role from Portal since we are not using 802.1x
authentication in this example.

Filters. Move down the page to the Filters section.
a. Select Add Filter

b. Select SSID from the list, and enter A3-Guest (a) beside the SSID. This tells A3 to
use this connection profile when anyone connects to the access point using the
A3-Guest (a) SSID.

Sources. Just below is the Sources section:
a. Select Add Source

Select null as the authentication source. This tells A3 to authenticate users against
the sms authentication source.

Repeat for email.

Repeat for sms.

. Click Create.
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Testing
with Captive Web Portal

Testing

Use Case 1: Guest Access

. Clients must be

" unregistered between
tests as per the
instructions to right.

If any Apple devices are used in the test, make sure to use a full browser for
authentication, as opposed to Apple’s Captive Network Assistant (CNA).

To test the A3 and ExtremeCloud I1Q configurations for SMS authentication, use a laptop,
smart phone, or tablet to connect to the A3-Guest (a) SSID.

Depending on your configuration, your default browser might automatically open with a
reference to the URL https://A3-Main(c).example.com(d)/, or it may be necessary for you to
reference a popular web site such as http://extremenetworks.com (note that http:// must
be used and not https://).

If your browser complains about the site or certificates, please reread the A3 Server
Certificate section of this guide. The browser warnings relate to the use of a default self-
signed certificate on A3. With persistent effort’, a banner page with a logo, terms of
service, and offers for authentication will be shown.

ExtremeCloud™ A3

Select an authentication method

Null Source

Email-based registration

N N Y

NN AN

SMS-based registration

If you have questions about this page, contact your local support staff for assistance. Please provide the following information:

IP 10.150.1.216
MAC 38:53:2e:0c:eT:16

Each of the alternatives can be selected for further testing. If more than one authentication
type is used for the same client, the client must be unregistered in the A3 GUI:

1. Select Clients.

2. Double click on the line corresponding to the client. The client should show a

) status.
3. Make the following changes to the entry:

a. Owner to default.
b. Status to Unregistered.
c. Roleto No Role.

4, Select Save.

1. This mightinvolve selecting Advanced or Details and then accepting warnings. In some Chrome versions itis necessary to disable a
check by entering a URL of chrome://flags/#allow-insecure-localhost and then Enable that option.

Part Number:
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Testing
with Captive Web Portal

SMS Test

Created At D
2019-12-06 01:12:31 2
2019-12-06 01:12:31 3

2019-12-06 01:08:25 1

Part Number:

Auth Status

0]

Use Case 1: Guest Access

A screen that asks you for your phone number and choice of mobile carrier.

SMS-based registration

TELEPHONE
1234567890

MOBILE PROVIDER

AT&T Wireless

When Continue is selected, A3 sends an email to the mobile number for the carrier. The
mobile number will receive an SMS with a PIN. The PIN is then entered into the web page,
followed by Continue.

925042 I

don't have a PIN

P 10.100.100.172
MAC 00:08:ca:et:da:21

A success page is displayed with a progress bar letting you know that internet access is
being enabled.

When the progress bar is finished, internet access will have been enabled. The browser is
redirected to the site that is predefined in the captive web portal section of the Connection
Profile. You can also test this by selecting extremenetworks.com or other site in your

browser address bar.

In addition to successful authentication and network access, using A3's auditing function
to check on the status of the authentication. Select Auditing from the top menu bar. ltems
are displayed in reverse order.

MAC Address IP Address Is a Phone
@@:@8:cael:da:21 0 reg
o2:08:caielidai2l 0 reg
@2:08:catelidai2l 0 unreg

A3 Installation and Usage Guide

Client Status.

User Name

8185995145

0008cae1da2l

0008cae1da2l

Unique ID NAS IP Address
10.150.1.19
10.150.1.19

10.150.1.19
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Testing

with Captive Web Portal

Use Case 1 Complete

Part Number:

MAC 00:db:df:1e:4f:e7

Edit nfo Fingarbank Timeline Pvd 25

Status  Registered

Role  guest - Guests

This completes the External Authentication example.

A3 Installation and Usage Guide

Use Case 1: Guest Access

If you click the MAC Address for the row (00:08:ca:e1:da:21 in this case), you can see the
status of the node associated with the client device.

Community

The Owner will be the phone number used to obtain the PIN, the Status will be registered
and the Role will be guest.
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F= Extreme

networks

Use Case 2: Active Directory Authentication

This use case describes differentiated authentication based on Active Directory
information. Users in marketing and sales security groups in the organization’s Active
Directory are assigned to user profiles that allow them access to potentially different
network resources. Users in neither group will be assigned to a third VLAN associated
with all other employees.

o Alerting must be Authentication setup then requires definition or modification of several A3 settings:
" configured for this use 1. Active Directory Domain Join - adds the A3 server to the Active Directory used for
case. See Alerting. authentication.

2. Roles - classifies the type of user, in this case three roles for employees, sales group
members, and marketing group members will be used.

3. Authentication Sources - defines how user information is gathered and ties users to
roles. The internal AD authentication source will be used.

4. Devices - defines the network devices that authenticate clients against A3, in this
case the Extreme Networks access point.

5. Connection Profile - ties together the authentication source with a connection source,
in this case an access point’s A3-Corp SSID. The connection profile also determines
the RADIUS type and value attributes that will be sent to network devices upon
connection and registration.

When configuration is completed, a directory-based authentication will be tested and
audit logs will be examined.

Start by entering the A3 configuration interface, either continuing from the initial
installation or invoking the interface via https://<(B) address>:1443.

Active Directory Domain Join

Requirements

The following pieces of information are needed to join A3 to a domain:
e Domain name of the AD Domain. E.g. example.com.

e NETBIOS name of the AD Domain. E.g example.

¢ Domain Controller IP Address. This is the 10.150.1.5 (G) address.
e Domain DNS Server IP Address. This is the 10.150.1.5 (F) address.

e Administrator account (name and password) with the necessary privilege to join a
computer to the AD. This will only be used once during this configuration step.

e The OU of the AD node where the A3 computer is to be added, usually COMPUTERS.

e The Base DN is the base location in the directory where search queries will be
performed. E.g. CN=Users,DC=example,DC=com.

e The Bind DN is the distinguished name for the user account that A3 will use to
conduct user lookups. This does not need to be the Administrator’s account. E.g.
CN-=jstaff,CN=Users,DC=example,DC=com.

Part Number: A3 Installation and Usage Guide Community 99

2021 © Extreme Networks, Inc. Extreme is a U.S. registered trademark of Extreme Networks, Inc.


https://boundless.aerohive.com/

Active Directory Domain Join Use Case 2: Active Direc-
tory Authentication

Active Directory Domain

Follow these steps to add the A3 server to your Active Directory domain:

1. Select Configuration > Policies and Access Control > Active Directory Domains.
2. Select | mewbemain |,

3. Enter the information as shown below, based on the information gathered earlier:

Field Value
Identifier CorpActive
Workgroup example
DNS Name of the Domain example.com
Active Directory Server 10.150.1.5 (G)
DNS Server(s) 10.150.1.5 (F)
Organizational Unit Computers

Select

When prompted, enter the administrator account and password that has privileges to
join the domain.

6. You may receive an error indicating that a DNS record for the AD server could not be
defined. If this is the case, please add an A-record for your A3 server (A3-Main (c)) to
your DNS server that refers to the A3 cluster address (B).

The success of the operation can be checked by using the Active Directory Users and
Computers snap-in on the Windows server hosting the AD. Check the location in your AD
tree where the OU for computer accounts is located (Computers in the example above) to
ensure that your computer has been added.

Realms

REALMS must be modified to use the Active Directory that you just defined.
1. Select Configuration > Policies and Access Control > Realms.
2. Three realms are pre-defined:

e DEFAULT - defines the realm used when no other realm applies

e LOCAL - a realm for use with local lookups, instead of forwarding to another
server

¢ NULL - the realm to use when no domain information is provided by user. For
example, user instead of user@domain

3. Select DEFAULT.

a. Inthe Realm DEFAULT titled dialog, under NTLM Auth Configuration, select
CorpActive from the Domain drop-down.

Enable Strip in the Captive Portal.

Enable Strip in the Administrative Interface.
Enable Strip in RADIUS Authorization.

Click SAVE.

4. Repeatthe previous step for NULL.

® 20T

Itis common practice to use this the DEFAULT and NULL realms in this manner for simple
Active Directory configurations.
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Roles
tory Authentication

Roles

Use Case 2: Active Direc-

Roles are accessed through the following steps:

1
2
3
4

Select

Authentication Sources

Select Configuration > Policies and Access Control > Roles.

Create a Sales role by entering Sales into the Name field. Click SAVE.
Repeat the last step for the Marketing and Employee roles.

The next steps involve creation of the CorpAD authentication source.

1.

Select Configuration > Policies and Access Control > Authentication Source.

2. Inside the Internal Sources box, click New Internal Source, and choose Active
Directory.
3. Fillin the form as shown below, with:
Field Comment Value
Name CorpAD
Description Corporate Active Directory
Host The Active Directory server 10.150.1.5 (G)
Base DN The base AD tree location from which to CN=Users,DC=EXAMPLE,DC=COM
start a user search
Scope Allows the search to progress to the entire |Subtree
tree beneath the Base DN
User Name Attribute | The normal AD entry for the user's name  |[sAMAccountName
Email Attribute The normal AD entry for the user’s email, | mail

used for sponsored access.

Bind DN The distinguished name for the user CN=jstaff,CN=Users,DC=example,DC=com
account that A3 will use to conduct user
lookups; this does not need to be the
Administrator’s account

Password The Bind DN user’s password. At this point | ******

the TEST button beside the password can
be used to check for a working connection.

Part Number:

Associated Realms default, null
4. Click Authentication Rules at the bottom of the page.
5. Add a Sales rule that matches Sales group membership in Active Directory:
Field Value
Name Sales
Description Sales department members
Conditions memberOf--equals--CN=Sales,CN=Users,DC=EXAMPLE,DC=COM
Actions Role--Sales, Access Duration--1day.
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Devices

tory Authentication

Use Case 2: Active Direc-

6. Click the plus sign to the right of Sales (Sales department members). Repeat for the
Marketing role:
Field Value
Name Marketing
Description Marketing department members
Conditions memberOf--equals--CN=Marketing,CN=Users,DC=EXAMPLE,DC=COM
Actions Role--Marketing, Access Duration--1day.
7. Click the plus sign again to create a catchall rule that will place all users not in either
the Sales or Marketing role into the Employee role:
Field Value
Name catchall
Description All other employees
Conditions <none>
Actions Role--Employee, Access Duration--1day.
8. Click to save the authentication source.
Devices
Device configuration is next:
1. Click Devices beneath Network Devices. The list of defined entries is displayed.
2. Ifthe listincludes the highlighted device, i.e. the address of your access point
10.150.1.19 (C), then select that entry and skip to step 5.
Identifier | Description Group Type Mode
10.150.1.19 QSG AP (C) Aerchive AP Aerchive::AP production | Delete || Clone |
192.168.0.1 Test Access Point Aerohive_AP Aerohive::AP production | Delste || Clone |
192.168.1.0/24 Test Range of Access  Aerohive AP Aerohive::AP production | Delete || Clone |
Points -

Part Number:

A device for our access point must be defined. Select | N and then select

Aerohive_AP.

Inthe New Device form, enter the IP address of your access point 10.150.1.19 (C) in the
IP Address/MAC Address/Range (CIDR) field, enter a Description, and ensure that the
Use CoA box is checked.

Select the Roles tab, ensure that only Role by Device Role is enabled.
a. Nexttoisolation, enter isolation (f).

b. Nextto Sales, enter sales (h). Note that the entry is all lower case. This matches
what the access pointis expecting from A3.

c. Nextto Marketing, enter marketing (i).

Select the RADIUS tah. Enter 8AB7tHKkP (b) into the Secret Passphrase field. This
matches the setting entered in the ExtremeCloud 1Q inAuthentication. Click Create.
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Connection Profile

Use Case 2: Active Direc-

The connection profile ties together the access point’s SSID with authentication sources.
To define a new profile:

1.
2.
3.

Select Configuration > Connection Profiles, and then click
Fill in a Profile Name as Corp_Conn and Profile Description as desired.

Check Automatically Register Clients. This ensures the device is registered to A3 and
allowed to connect to the 802.1X-secured SSID.
Uncheck 802.1X Recompute Role from Portal.

Under Filters, click Add a filter and enter A3-Corp (a) next to SSID. This tells A3 to use

this connection profile when anyone connects to the access point using the A3-Corp
(a) SSID.

Under Sources, select Add a source and then select CorpAD as the authentication
source. This tells A3 to authenticate users against the CorpAD Authentication Source.

Click

Testing Active Directory

) Clients must be
" unregistered between
tests as per the

instructions to right.

Part Number:

To test the A3 and ExtremeCloud 1Q configurations for Active Directory authentication, use
a laptop, smart phone, or tablet to connect to the A3-Corp (c) SSID.

Active Directory Contents

The testing in this guide section depends on a particular configuration of your Active
Directory server. In particular, the following users and groups are required:

User Login Name Group Membership
A3User A3User
Jane Staff jstaff Employees
Joe Sales jsales Employees, Sales
Mike Marketing mmarketing Employees, Marketing

Testing

If a client has previously been authenticated, the client must be unregistered in the A3 GUI:

1.
2.

4.

Select Clients.

Double click on the line corresponding to the client. The client should show a
) status.
Make the following changes to the entry:

a. Owner to default.
b. Status to Unregistered.
c. Roleto No Role.

Select Save.

The following screen shots were taken using a Windows 10 client. Similar steps will be
required for other clients.
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Testing Active Directory Use Case 2: Active Direc-
tory Authentication

1. Connect to the A3-Corp (c) SSID and enter credentials for jstaff, who is an employee
but not a member of either the Sales or Marketing AD security groups:

Enter your user name and password

jstaff

Cancel

2. After the successful connection, look at the properties for the WiFi connection:

Properties

SSID:
Protocol:

Security type:
Type of sign-in info: Microsoft: Protected EAP (PEAP)
Network band: 2.4 GHz

Network channel:
IPv4 address:
IPv4 DNS servers: 10.150.8.1

3. Ifyou intend to retest with the same client, then you need to ask A3 to forget the
device registration as per the instructions above.

4. Connectto the A3-Corp (c) SSID and enter credentials for jsales, who is a member of
either the Sales AD group:

Enter your user name and password

jsales

Cancel

5. After the successful connection, look at the properties for the WiFi connection:

Properties

SsID: A3-Corp

Protocol: 80

Security type: WPA2-Enterg

Type of sign-in info: Microsoft: ted EAP (PEAP)
Network band: 2.4 GHz

Network channel:

1Pv4 address: 5

IPv4 DNS servers: 10.150.2.1

Note that the address assigned is from the Sales User Profile configured in
ExtremeCloud 1Q.

6. Repeat step 3 if you intent to reuse the same client for further testing.
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tory Authentication

Created At T ID
2019-12-06 02:04:08 7
2019-12-06 02:03:35 6

2019-12-06 02:01:50 5

Part Number:

Auth Status

Use Case 2: Active Direc-

7. Connectto the A3-Corp (c) SSID and enter credentials for mmarketing, who is a
member of the Marketing AD group:

ﬁ A3-Corp

Enter your user name and password

mmarketing

8. After the successful connection, look at the properties for the WiFi connection:

Properties

SSID:

Protocol:

Security type: WPA2-Enterprise
Type of sign-in info:
Network band:
Network channel:
IPv4 address:

IPv4 DNS servers:

Microsoft: Protected EAP (PEAP)

2.4 GHz

10.150.5.1

Note that the address assigned is from the Marketing User Profile configured in
ExtremeCloud 1Q.

Verifying Operation

In addition to successful authentication and network access, you can use A3's auditing
function to check on the status of the authentication. Select AUDITING from the top menu
bar. Items are displayed in reverse order. You should see an Accept Auth Status for your
client.

MAC Address IP Address IsaPhone | ClientStatus | User Name Unigue ID NAS IP Address
@0:88:cael:da: 21 0 reg mmarketing 10.150.1.19
@9:88:catelida: 2l 0 reg jsales 10.150.1.19
@0:88:ca:elida:2l 0 reg jstaff 10.150.1.19
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Testing Active Directory Use Case 2: Active Direc-
tory Authentication

If you click the + sign next to Accept for any entry and select the RADIUS tab, you can see
the RADIUS messages exchanged between A3 to the access point.

RADIUS Audit Log Entry 13

Mode Information Dren nformation RADIUS
request_time 0
RADIUS Reguest User-Name = "mmarketing
MAS-IP-Address = 10.130.1.19
MAS-Port=0

Service-Type = Framed-User

Framed-MTU = 1300

State = Oxe9425fc7e8cb455F6592015b5be 173365
Called-Station-Id = "8&:5b:dd:00:85:14:A3-Corp"
Calling-5tation-ld =" ca:elda?l
MAS-Identifier = "AH-008500"

MAS-Port-Type = Wireless-802.11

Acct-Session-ld = "C1AZ4EABESFGBETE
Acct-Multi-5ession-ld = "S0BEZ43857937ADD"
Event-Timestamp = "Apr 23 2012 00:24:50 UTC"
Connect-Info ="11ng

EAP-Message = 0x028500061303
WLAN-Painwise-Cipher = 1027076
WLAN-AKM-Suite = 102707
FreeRADIUS-Proxied-To =
EAP-Type = MSCHAPY2
Stripped-User-Name = "mmarketing

7.0.01

Realm = "null"
Called-5Station-5510 = "A3-Corp
PacketFence-Domain = "CorpAD
Anr-26.26928 6 = 0x00000004
Arr-26.26928.1 = 0x00000000
User-Password = "&#sdss!
5QL-User-Name = "mmarketing

RADIUS Reply EAP-Message = 0x03850004
Message-Authenticator = Ow00000000000000000000000000)
User-Mame = "mmarketing”
Filter-ld = "marketing”

Use Case 2 Example Complete

This completes the Active Directory Authentication example for A3.
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Use Case 3: Local User Authentication

(o Alerting must be
1" configured for this use
case. See Alerting.

User Manager

Another guest access alternative is referred to as local user, in which credentials are pre-
defined and stored within A3. This type of authentication can be used for:

*  Employees visiting from a remote site
e Contractors

e Visitors

e Temporary access for any reason

e Experimentation

Local user registrations are characterized by a user login, password, email address, usage
time window, and network access role. The local user facility, however, cannot be used for
802.1X authentication.

Part Number:

The person creating a local user account must have appropriate A3 administration access
rights. This can be done by any member of the User Manager Admin Role or by creation of
a custom rule. The administrator login created when A3 was first installed is automatically
a User Manager. If there will only ever be a single administrator, then this step can be
skipped; proceed to Create a Local User.

The rights associated with the User Managers can be viewed by selecting Configuration >
System Configuration > Admin Access and then User Manager. These rights may be
modified, or an alternate User Manager type Admin Role can be defined.

Employees are given User Manager access by creating or modifying an authentication
source’s administrative rule. Administrative rules are like authentication rules, but relate to
A3 administration.

For example, all marketing department members may be given User Manager access. This
example uses alocal Active Directory. The following uses the same setup as in Use Case 1:
Guest Access with Captive Web Portal.

1. Navigate to Configuration > Policies and Access Control > Active Directory Domains.
If there is no domain definition, create one as in Active Directory Domain Join.
Navigate to Configuration > Policies and Access Control > Authentication Sources.

2

3

4. Ifthereis no AD type definition, create one as in Authentication Sources.

5. Within the AD type authentication source, scroll down to Administration Rules.
6

Select e | to add an Administration Rule. These are different and distinct from
Authentication rules. Enter the following values.

Field Value

Name UserManager
Description |Allow all marketing members to be User Managers
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Local User Authentication
Authentication

Use Case 3: Local User

Value

Conditions | member0Of--equals--CN=Marketing,CN=Users,DC=EXAMPLE,DC=COM

Field
Matches All
Actions Access level--User Manager
7. Click Save.

Local User Authentication

The final step adds the local authentication source to the Guest connection profile:

1. Navigate to Configuration > Policies and Access Control > Connection Profiles.

2. If a Guest connection profile does not exist, then create one as described in

Connection Profile.

3. Select the Guest connection profile.

4.  Scroll down to sources. Add a new source, for local.

5. Click Save.

Create a Local User

At this point, the initial administrator can log out of A3 and any member of the company’s
Marketing group can log into A3's administrative interface with their company’s Active
Directory login name and password. That person has User Manager privileges, allowing

them to create a local user.

The steps to create a local user are:

1. Navigate to Users > Create.

2. Fill in the form with the following fields:

Field Value Comment
User Name (PID) contractor A unique name for use on the
captive web portal.
Password secret1234 A password for use on the cap-
tive web portal.
Email bill@contractor.com An email address used for an

invitation.

Registration Window

2019-08-22 --> 2019-08-25

A range of dates during which
the user may login.

Actions

Role - Guest
Access duration - 1 day

The role for the user and how
long they can stay logged in.

3. Click Send to send an email message at the address used in the form inviting them to

log in to the local network when they arrive on-site.

4,  Click Save.
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Authentication

Testing Local User Authentication

Use Case 3: Local User

Clients must be
() .
" unregistered between
tests as per the

instructions to right.

If a client has previously been authenticated, the client must be unregistered in the A3 GUI:

1. Select Configuration > Clients.

2. Click on the line corresponding to the client. The client should show a gz

status.
3. Make the following changes to the entry:
a. Owner to default.
b. Status to Unregistered.
c. Roleto NoRole.
4.  Select Save.

To test local user authentication.

1. Create a new user with your email address. The login contractor is used in this

example.

2. Choose a device to access your network on the guest SSID. Connect to the guest
SSID. An additional authentication choice will be displayed.

Select an authentication method

( Guest signup )
( OAuth login )

Username/password login

USERNAME

contractor

PASSVORD

essssssssssns SHOW

4. Ifthe user name and password are correct, then guest access will be provided.

Use Case 3 Example Complete

Part Number:

This completes the Local User Authentication example for A3.
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Use Case 4: Sponsored Access

- Alerting must be
" configured for this use
case. See Alerting.

This use case involves guest access requiring employee approval. The flow in this
scenario is:

1. Aclient connects to the registration network, A3-Guest (a), for example.
2. Theclient accepts a standard acceptable use policy.
3. Theclient enters:

a. Their own email address.

b. The email address of the employee/sponsor. A3 will check that the sponsor is
approved or not.

4. A3 sends an email to the sponsor. The sponsor must click through the email to
activate the connection.

Authentication setup requires inspection, definition, or modification of several A3 settings:

1. Active Directory Domain Join - this was accomplished in a previous use case. Follow
the link for details.

2. Roles - the guest role will be used.

3. Authentication Sources - an administration rule is used to designate authorized
sponsors.

4. Active Directory Source - modifies the CorpAD active directory source and verifies
the sponsor external source.

5. Devices - defines the network devices that authenticate clients against A3, in this
case the access point. The same device is used as in previous use cases; follow the
link for details.

6. Connection Profile - adds the local sponsor to the Guest connection profile from Use
Case 1: Guest Access with Captive Web Portal.

Start by entering the A3 configuration interface, either continuing from the initial
installation or invoking the interface via https://<(A) address>:1443.

Authentication Sources

Active Directory Source

Part Number:

The next steps modify the CorpAD authentication source which was defined in Use Case 2:
Active Directory Authentication.

1. Select Configuration > Policies and Access Control > Authentication Source.

2. Inside the Internal Sources box, select CorpAD.

3. Under Administration Rules: select to add a new Administration rule.
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Connection Profile Use Case 4: Sponsored
Access

4. Add a Sponsor rule that matches Sponsor group membership in Active Directory. The
members of the Sponsor group must have valid email addresses in their mail

attributes.
Field Value
Name Sponsor
Description Employees who can sponsor access
Conditions memberOf--equals--CN=Sponsors,
CN=Users,DC=EXAMPLE,DC=COM
Actions Mark as Sponsor

5. Click BEY to save the authentication source.

Sponsor Source

The next steps verify the settings for the sponsor authentication source.
1. Select Configuration > Policies and Access Control > Authentication Source.

2. Inside the External Sources box, select sponsor.

3. Under Authentication Rules verify that a catchall rule exists with an action that sets
Role to guest, and a reasonable Access Duration.

Connection Profile

The connection profile in this use case was builtin Use Case 1: Guest Access with Captive
Web Portal. The following modifications are made to support sponsored access.

1. Navigate to Configuration > Policies and Access Control > Connection Profiles.
2. Selectthe Guest-Connection profile.

3. Inthe Sources category, add sponsor as an additional source. This adds another
choice to the guest CWP.

4. Click to save the connection profile.

Testing Sponsored Access

If a client has previously been authenticated, the client must be unregistered in the A3 GUI:

Clients must be 1. Select Configuration > Clients.

" unregistered between 2. Click on the line corresponding to the client. The client should show a gz
tests as per the status.
instructions to right.

3. Make the following changes to the entry:
a. Owner to default.
b. Status to Unregistered.
c. Roleto NoRole.

4. Select Save.
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Testing Sponsored Access
Access

A DNS entry for the A3
VIP (B) must be
configured for this to
work.

(((i)))

Part Number:

To test the A3 and ExtremeCloud I1Q configurations for sponsored access, use a laptop,
smart phone, or tablet to connect to the A3-Guest (a) SSID.

1.

Depending on the configuration of the guest connection profile, the user will be

offered an additional choice for registration.

Select an authentication method

Null Source

Email-based registration

(
C
(

SMS-based registration

)
)
)

(¢

Sponsor-based registration

)

2.

After selecting Sponsor-based registration, the client will be asked for their email

address as well as that of their sponsor.

Sponsor-based registration

EMAIL

george@vendor.com

SPONSOR EMAIL

bpeterson@example.com

3.

The user will be held while the sponsor is contacted.

Use Case 4: Sponsored

4.

A ourregistration is pending approval. Once approved you will be automatically

redirected

The employee designated in the SPONSOR EMAIL field will receive an email

requesting

Enabling netwark access

Registration pending

approval for the user.
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Testing Sponsored Access
Access

Guest request

Hello
requested guest access to your network.
Do NOT authorize access if you were not expecting this guest

Here s the information the guest provided with registration form:

FRSTNAME
LasThAME

EmaL

george@vendor com

Activate Access

Until you click on the activation link this guest will have NO Interet access.

Thank you for your cooperation

5. Clicking the link invokes an administrative login for A3.

Guest Sponsor Login

Before we proceed with guest activation, we need you to authenticate.
USERNAME

jstaff@example.com -]

PASSWORD

an email to the same effect.

Access Authorized

Hello
Your guest access to the network was authorized.

If you have any questions regarding the registration process please contact your local support
sta

Verifying Operation

In addition to successful authentication and network access, you can use A3's auditing
function to check on the status of the authentication. Select AUDITING from the top menu
bar. Items are displayed in reverse order. You should see an Accept Auth Status for your

Use Case 4: Sponsored

Upon successful login, the client will be granted access. The client will also receive

client.
IP Isa Client Unique NAS IP
Created At ID T Auth Status MAC Address Address Phone Status User Name 1D Addres:
201%-09-16 20:22:59 52 @a:db:df:le:af:e7 0 reg 00dbdf1edfe? 10.150.

Use Case 4 Example Complete

Part Number:

This completes the Sponsored Authentication example for A3.
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Use Case 5: EAP-TLS Authentication

This case utilizes RADIUS certificates to perform EAP-TLS authentication between
Windows clients and A3. The installation of RADIUS certificates on A3 is discussed in
RADIUS Certificate. This use case assumes that PKI Provider and Provisioner setup has
been performed.

EAP-TLS Authentication Source

A new EAP-TLS authentication source is defined to match all organization members.
Authentication and authorization rules will be inherited from the Active Directory
authentication source.

1. Navigate to Configuration > Policies and Access Control > Authentication Sources.
2. Inthe Internal Source category, select \ wew nterna souree = | and select EAP-TLS.
3. Fill'in the form as per the following:

Field Usage Example
Name Name of the authentication source. | EAPTLS
Description Further description EAPTLS used for employees
Associated The realm to associate with the default
Realms source. See Use Case 2: Active

Directory Authentication for a
description of how realms are

established.
Authentication New rule to catch all EAP-TLS See below.
Rule users

The authentication rule should include:

Field Usage
Name catchall
Description Match all employees
Matches All
Conditions None
Actions Role -- default, Access duration -- 5 days
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Connection Profile Use Case 5: EAP-TLS
Authentication

Connection Profile

This section assumes that the configuration associated with Use Case 2: Active Directory
Authentication has been performed. The Corp_Conn and Guest_Profile should be modified
as per the directions below.

Corporate Profile

1. Navigate to Configuration > Policies and Access Control > Connection Profile.
2. Selectthe Corp_Conn profile.

3. Enable 802.1X Recompute Role from Portal. This will cause the client’s role to be
recomputed from the 802.1X user name instead of re-using the value initially
computed from the Guest_Profile.

4, Add the EAPTLS authentication source to the Sources.

5. Click BEE5Y.

Guest Profile
1. Navigate to Configuration > Policies and Access Control > Connection Profile.
2. Selectthe Guest_Profile profile.
3. Ensure that the CorpAD authentication source is included in the Sources.
4. Select |ﬁ\ to add the EAP-TLS provisioner defined in Provisioner.
5. Click BEEEY.

Testing EAP-TLS

This sequence demonstrates the on-boarding and provisioning of a Windows client using
the configuration described above, including PKI Provider and Provisioner setup. The
client first connects to the A3-Guest SSID. Upon completion of the provisioning process,
the client is directed to connect to the A3-Corp SSID. The client is then connected without
any further interaction.

If a client has previously been authenticated, the client must be unregistered in the A3 GUI:

Clients must be 1. Select Configuration > Clients.

" unregistered between 2. Double click on the line corresponding to the client. The client should show a
tests as per the ) status.
instructions to right. '

3. Make the following changes to the entry:
a. Owner to default.
b. Status to Unregistered.
c. Roleto NoRole.

4. Select Save.
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Testing EAP-TLS Use Case 5: EAP-TLS
Authentication

The client first connects to the A3-Guest SSID.

1. After connecting to the guest SSID, the client is offered several choices, depending on
the configuration of the Guest_Profile connection profile. User name/password login
is selected.

Select an authentication method

[( Username/password login )]
( Guest signup )
( OAuth login )

2. The client must agree to acceptable usage policy and is then offered a user name/
password form. Domain-specific credentials must be entered.

Username/password login

USERNAME

mmarketing @

PASSWORD

LYY TTTYYYYIYY

3. A3will generate a certificate for the client, but first asks for a password to be used to
protect the certificate. The client accepts the offered password or enters their own.

Certificate generation for EAP TLS connection

In order to complete the registration process, you need to generate your user cerfificate. A random
certificate password has been generated for you. Please note it as it will be necessary to complete the
process.

You can also modify the password below.

PASSWORD

funnik

Generate certificate

4. An agent program must next be downloaded and installed. Click on the Install Agent
button.

Provisioning : MSPKI

In order to complete your connection to the secure SSID, you will need to run the agent available
below.

Install Agent

Continue
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Use Case 5: EAP-TLS
Authentication

5. The a3-windows-agent.exe file is downloaded. Locate and execute the file. Since the
client is only connected to the registration network, any security scanners that
require internet access may complain. This can be avoided through configuration of
Passthrough Domains in Configuration > Network Configuration > Fencing. For the
purpose of this example, any warning should be overridden. The agent prompts the
client to configure the certificate. Select the Configure button.

6. The clientis next prompted for the password entered in step 3 above.

4 Certificate Password - m} X

Flease enter your cerificate password

ARk ARRIARIAR

oK Cancel

7. Asequence of three prompts are displayed. Answer in the affirmative for each.

& Success - O X

Your certificate was succeszafully installed, please press CK to continue.

Security Waming

Vou are about to install a certificate from a certification authority (CA)
L. claiming to represent:

Windows cannot validate that the certificate is actually from
You should confirm its origin by contacting
The following number will assist you in this process:

Thumbprint (shal): 738953E3 7C1498E1 EB3310A9 CAEB3AAF TED111EG
Warning:

If you install this roct certificate, Windows will automatically trust any
certificate issued by this CA. Installing a certificate with an unconfirmed
thumbprint is a security risk. If you click "Yes" you acknowledge this

risk,

Do you want to install this certificate?

74 Information [m] X

The profile was successfully added to the machine, please select your newly
added profile A3-Corp in the Wifi networks.

8. Atthis point, the client can connect to the A3-Corp SSID. No login screen is needed
since EAP-TLS is configured in A3 and the client’s certificate has been installed on the
computer.

Use Case 5 Example Complete

This completes the EAP-TLS Authentication example for A3.
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Use Case 6: Guest Access with External Captive Web Portal

The requirement to extend registration and isolation VLANs out to each edge of a network
may be inconvenient for an organization. An alternative authentication technique is
available that uses an E-CWP (external captive web portal), which simplifies network
configuration. Several restrictions apply:

Client authentication may use any of the following techniques:

¢ Internal sources: Active Directory, EAP-TLS

e  External sources: sms, email, sponsored, and null. 0Auth2-based logins, such as
Google and Facebook) may be used, but require the applicable servers to be
added to the walled garden defined in Network Policy below.

Only one access policy is used per SSID in ExtremeCloud 1Q configuration.

This use case will use an E-CWP to authenticate guest access using VLAN 2. VLAN 2 is
used for the default VLAN in ExtremeCloud 1Q and is also returned by A3 as the selected
VLAN.

In general, A3 may specify different VLANs based on different authentication mechanisms.
The Role tab in the Device's configuration will use Role by VLAN ID; a VLAN should be
specified for each role used in the Connection Profile.

ExtremeCloud 1Q Configuration

Itis necessary to configure a network policy for E-CWP that is different to the
configurations covered in ExtremeCloud |Q Setup. Use the following steps to configure a
network policy named A3-WA (web authentication) in ExtremeCloud IQ.

Network Policy
1. Anew network policy is defined by selecting CONFIGURE > NETWORK POLICIES.
2. Inthe box entitled Corp-Policy, selectthe [ icon.
3. Selectthe Wireless Networks tab.
4. Selectthe button, and then the All other Networks (standard) choice.
5. Fillin the page with the following settings.
Field Usage Setting

Name (SSID) Name of the SSID to be used for E-CWP A3-WA

SSID Usage The type of authentication for the SSID. Open

Enable Captive Web Portal Enables the use of the E-CWP On

Captive Web Portal

The options for the E-CWP.

User Auth on Captive Web Portal (only)

Choose Authentication Type

How to perform authentication.

Redirect to External URL for Authentica-
tion

Default Captive Web Portal

Part Number:

Defines were to find the E-CWP web page.
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A3 Configuration
with External Captive Web Portal

Field
Authentication Settings -

Authenticate via RADIUS Server

Usage

Defines the RADIUS server connection to
A3.

Use Case 6: Guest Access

Setting

See the RADIUS Server step in Authen-
tication.

User Access Settings

Sets up the Default User Profile with the sin-
gle VLAN that will be used while the clientis
registering.

6. Do not press SAVE yet.

7. Beside Default Captive Web Portal, select the

the following settings:

See the Default User Profile step in
Authentication. Use the VLAN for your
network associated with guests. VLAN 2
is used in this example.

button. Fill in the dialog with

Field Usage Setting
Name A name to identify the E-CWP server A3-V3
Password Encryption The form of encryption used between the access |UAM Basic
point and the E-CWP server.
Authentication Method The form of authentication used between the PAP
access point and the E-CWP.
Client Redirection - Use | Click on Advanced Configuration. Scroll down to |Checked.

HTTP 302

Client Redirection. Select Use HTTP 302

Walled Garden

A3 Configuration

Clients will have no network access until they
have authenticated. This includes the E-CWP
server. To allow necessary access to the A3
server, an entry must be added.

8. Press

Add a new entry using the + sign.
Select All and add the 10.150.1.254 <B>

address in the box. Press

and then to save the new A3-WA network.

Devices

Part Number:

A3 configuration requires definition or modification of several A3 settings:

1. Roles - the guest role will be used, as defined in Roles. The intention is to identify

allow guest access through the E-CWP.

2. Authentication Source - multiple alternative
used, as defined in Authentication Sources.

guest authentication sources will be

3. Devices - the device definition is modified as discussed below.

4. Connection Profile - a new profile is defined to tie together the authentication source
with a connection source, in this case an access point’'s A3-WA SSID.

When configuration is completed, authentication

Navigate to Network Devices > Devices.
Select the device to be used in Devices.
Select the Roles tab at the top.

Enable Role by VLAN ID and disable Role by

o R W =

will be tested.

Device Role.

The settings beneath Role by VLAN ID are used sent to the AP as the VLAN to be used

by registered clients. Enter 2 beside the guest role.

6. Click EX.
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Testing E-CWP Access
with External Captive Web Portal

Connection Profile

Use Case 6: Guest Access

The connection profile ties together the access point’s SSID with authentication sources.
To define a new profile:

1. Select Configuration > Connection Profiles

2. Select New Connection Profile.

3. Fillin the page as per the table:

Field Usage Setting
Profile Name The name of the connection profile. AD-WebAuth
Filter Used to ensure that this connection profile is only |SSID -- A3-WA
used for the A3-WA SSID.
Sources The authentication sources to be used for the null, email, sms

authentication.

4. Click E3.

Testing E-CWP Access

Part Number:

If any Apple devices are used in the test, make sure to use a full browser for
authentication, as opposed to Apple’s Captive Network Assistant (CNA).

To test the A3 and ExtremeCloud I1Q configurations for SMS authentication, use a laptop,
smart phone, or tablet to connect to the A3-WA (b) SSID.

Depending on your configuration, your default browser will reference https://
10.150.1.254(B)/captive-portal... and open up an authentication challenge window.

Select an authentication method

C

SMS-based registration )

(

Email-based registration )

(

Null Source )

Before going through authentication, note two things:

1. The client has been assigned an address in VLAN 2.

Properties

SSID:
Protocol:

Security type:

Open

Network band:
Network channel:
IPv4 address:
IPv4 DNS servers:
Manufacturer:
Description:

Driver version:

Physical address (MAC):

2.4 GHz
1

10.150.2.1

AzureWave Technologies, Inc.

eless LAN Card

00-08-CA-E1-DA-21
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Testing E-CWP Access
with External Captive Web Portal

2.

Use Case 6: Guest Access

If an external web site, such as extremenetworks.com, is referenced in a new
browser tab that another authentication challenge is issued. This verifies that the
clientis completely isolated from the organization’s network.

Each of the alternatives can be selected for testing. If more than one authentication type is
used for the same client, the client must be unregistered in the A3 GUI:

Select Configuration > Clients.

Double click on the line corresponding to the client. The client should show a
) status.
Make the following changes to the entry:

a. Owner to default.

b. Status to Unregistered.
c. Roleto NoRole.
Select Save.

Select Null Source and click | accept the terms on the subsequent page.

The login successful message should display.

You are now connected to the network.

oy Clients must be 1.
1" unregistered between 2.
tests as per the
instructions to right. 3
4,
Null Authentication Test
1.
2.
3.
4.

Use Case 6 Complete

Verify that the client’s network address has not changed.

Verify that internet access is permitted by referencing an external web site, such as
cnn.com.

This completes the External Captive Web Portal example.

Part Number:
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Use Case 7: Headless loT Devices

Devices that do not have any means of performing interactive authentication are often
referred to as headless or loT (internet of things) devices. They must be registered by other

means.

Two options exist to manually register headless client devices:

1. Manual:
a. Login as an administrator.
b. Navigate to Clients > Search.
c. Todefine a single device found in the client list.
i. The device can be located by its Fingerprint identification and/or MAC
address.
ii. Register the client device with a role and access duration.
d. To define a single device by entering its MAC address.
i. SelectCreate.
ii. Enterthe MAC address, Role, and access duration (Unregistration time).
e. Toimport a list of devices from a csv (comma-separated values) file.

i.  Navigate to Import.
ii. Click L="®" ] Select your CSV file.

iii. Usethe Import Data tab to define the column layout in the file. Details on how
to use this tab can be found in the A3 online help.

iv. Click on Import XX selected rows.

2. Automatic: set up a security event based on Fingerprint ID or other identification that
registers the client device with a role and access duration. Security events can also
be triggered manually for one or more client devices.

Manual configuration does not scale very well. Automatic registration will be discussed in
this chapter.

Extreme Networks suggests the following configuration on ExtremeCloud 1Q and A3

Field

Usage Example

ExtremeCloud IQ > Configure |SSID. Set up a separate SSID for loT devices. A3-loT

> Add Network

Broadcast SSID Using... Many devices require ini- | Enable WIFi0 Radio

tial discovery over 2.4 GHz netwaorks. @ Enable WiFi1 Radio

MAC Authentication On

SSID Authentication Personal WPA/WPA2/WPA3

Key Value loTDevicE2358

User Access Settings: Default User Profile default profile - Registration (VLAN: 11)

Part Number:

User Access Settings: Apply a different user pro- |On
file to various clients and user groups
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Automatic Registration Security Event Use Case 7: Headless loT
Devices

Field Usage Example

User Access Settings: Allow user profiles assign- |On
ment using RADIUS attributes in addition to three
tunnel RADIUS attributes.

User Access Settings: Add User Profile User Profile Name = iot
VLAN 2 (Guest VLAN)
Assignment: RADIUS attribute = iot
A3 Role. Any role can be used in conjunction with loT

ExtremeCloud 1Q access settings.

Device. In the role tab for the device, map the role |loT -> iot
to something that will be matched in Extreme-
Cloud IQ access settings.

Connection Profile. Filter: SSID = loT.

a.  Most loT devices require initial Wi-Fi discovery over 2.4 GHz connections (802.11b/g/n/ax). Check your devices require-
ments and set up your Wi-Fi network to match them.

Automatic Registration Security Event

A security event is defined to trigger on the appearance of a headless loT device:

1. Navigate to Configuration > Compliance > Security Events.

2. Click [ M=ty &t | Fill in the form as per the table below:

Field Usage Example
Enable Security Event Enabled for use or not On
Identifier A unique number that identifies the security event. | 3000006
Description A further descriptive name shown in the Security |Automatic registration of loT devices
Events list.
Event Actions What to do when the device is detected. Register

Role. A role should be specified that maps to con- |loT
nectivity needed for loT devices.
Duration. Any duration will work since A3 will re- |1 day
evaluate the role at each expiration.

Event Actions Email Administrator. This is optional, but will allow
the administrator to keep track of new loT
devices.
Event Triggers Client Profiling. Device -- Internet of Things (loT)
3. Click

The devices contained in the Internet of Things (loT) category is listed in Configuration >
Compliance > Devices. Search for Internet of Things; expand the list by selecting the plus
sign.

The Security Event is now completely configured and will trigger for any device that
profiles as an Internet of Things (loT) device.
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Manual Use of Security Event
Devices

Use Case 7: Headless loT

Manual Use of Security Event

Use Case 7 Complete

Part Number:

If a headless loT device is not currently in the Fingerprint database or was otherwise
missed by the security event trigger, the security event can still be used

1.
2
3.
4

5.

Select Clients
Find and select the device in the client list.
Select the Security Events tab.

Select Automatic registration of loT devices in the drop-down at the bottom of the
form.

Select . The security event will appear in the listing.

loT registration can also be performed in bulk from the Clients view.

1.

2
3.
4

Select Clients.
Place a beside all loT devices to be registered.
Select the &% at the top of the table.

Select Automatic registration of loT devices from the Apply Security Event part of the

list.

This completes the Headless loT Devices example.
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Use Case 8: Eduroam

Overview

Eduroam (education roaming) is a secure, world-wide federated roaming access service
used by the international research and education community. Eduroam allows students,
researchers, and staff from participating institutions to obtain internet connectivity across
campus and when visiting other participating institutions. Further information on eduroam
is available at http://www.eduroam.org/.

Eduroam is a global example of realm-based authentication. The technology behind
Eduroam is based on the IEEE 802.1X standard and a hierarchy of RADIUS proxy servers.
An eligible organization can provide students, researchers, staff and faculty with wireless
access at participating institutions through the use of their home institution credentials.

When a user connects with any participating wireless network using the eduroam SSID,
the home RADIUS server does the authentication, while the host institution does the
authorization.

Wireless client

NTLM
Authentication

A3's eduroam integration is shown in the figure below.
Access point

Remote eduroam

Local AD/LDAP
Service

Part Number:

yes

institutions
RADIUS,
port 11812 ‘
RADIUS response
_ A3 P or request
L internet
inbound
Client in local Realm? no ' A
- > outbound
internet —
eduroam
Servers
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ExtremeCloud 1Q Configuration

Local Users

Remote Users

Use Case 8: Eduroam

Eduroam users who are associated with the institution local to your A3 can use the
eduroam SSID for internet access. When they do so, the access point connects to A3 via
RADIUS on port 11812 (1812 is the normal RADIUS port). This port lets A3 know that
eduroam authentication is to be applied.

Based on configuration of the eduroam-based authentication source, A3 decides whether
the user is in the local realm or not. If the user is in the local realm, A3 performs normal
NTLM-based authentication using an AD or LDAP service.

Eduroam users who are associated with some other institution, but connect through your
local A3 may also use the eduroam SSID for internet access. When they do so, the AP
connects the eduroam SSID to A3 for internet access via RADIUS on port 11812, as before.

Based on the configuration of the authentication source, A3 decides that the client is not
part of a local realm. A3 then contacts one of the eduroam servers for authentication. The
eduroam server proxies the request to the appropriate institution using RADIUS. The
success/failure response is fed back to A3 and thence to the AP for enforcement.

Local Users at Remote Sites

Eduroam users from your institution can use the eduroam SSID at another institution. That
institution’s authentication mechanism will find that the user is not local to their site, thus
sending an authentication request to the eduroam servers. That request will be forwarded
to your local site via RADIUS. A3 performs local NTLM authentication and sends the
success/failure response back to the eduroam server.

ExtremeCloud 1Q Configuration

A3 Configuration

ExtremeCloud 1Q must be configured for an eduroam SSID, but using port 11812 for RADIUS
communications with A3 instead of the normal 1812. The same shared secret used for
normal operation (port 1812) should be used. Other configuration requirements are
dictated by the eduroam configuration documents.

Part Number:

A3 must be configured for both local and remote eduroam-related authentication. This
involves creation or editing of five items:

e Local Domain and Realm - named ExampleUAD and exampleu.edu.
e Local Authentication Source - named LocalADAuth.

e Eduroam Authentication Source - named eduroamAS.

* Local Connection Profile - named LocalEduroamCP.

e Eduroam Connection Profile - named eduroamCP.
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Local Domain and Realm

If not already defined, both an Active Directory domain and realm that refers to the domain
must be defined. The domain will be named ExampleUAD and the realm will be named
exampleu.edu.

Active Directory Domain

1. Navigate to Configuration > Policies and Access Control > Active Directory Domains.
2. Select [ =veeme

3. Fillin the form with the values below.

Field Usage Example
Identifier A name for the AD. ExampleUAD
Workgroup Name of the workgroup. exampleu
DNS Name of the Domain|DNS name for the institution’s DNS exampleu.edu
Active Directory Server [The IP address of the AD server. 10.150.1.5 (G)
DNS Server(s) The IP address(es) of the domain’s DNS |10.150.1.5 (F)

server(s).

Organizational Unit The computer account name in the AD. |Computers

4, Select

5. When prompted, enter the administrator account and password that has privileges to
join the domain.

6. You may receive an error indicating that a DNS record for the AD server could not be
defined. If this is the case, please add an A-record for your A3 server (A3-Main (c)) to
your DNS server that refers to the A3 cluster address (B).

Realm

A realm must be created to use the Active Directory that you just defined.
1. Select Configuration > Policies and Access Control > Realms.

2. Select [ =i

3. Fill in the form with the values below:

Field Usage Example
Realm A name for the realm. exampleu.edu
Domain The domain used for authen- | ExampleUAD

tication in the realm.

4. (Optional) If the Eduroam Realm will use a RADIUS proxy, fill in the form with the

values below:

Field Usage Example
Eduroam Realm Options for FreeRADIUS proxying to a local  |strip
Options server.

Eduroam RADIUS Auth |The RADIUS server(s) used to proxy Eduroam |eduradius
authentication. The listis composed of entries
from RADIUS Internal Authentication sources.

5. Click
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Local Authentication Source

Alocal AD authentication source must be defined that references the LocalRealm just
defined. The authentication source will be named LocalADAuth.

1. Select Configuration > Policies and Access Control > Authentication Source.

2. Inside the Internal Sources box, click , and choose Active Directory.

3. Fillinthe form as shown below:

Field Value
Name LocalADAuth
Description Local authentication for eduroam users
Host 10.150.1.5 (G)
Base DN CN=Users,DC=exampleu,DC=edu
Scope Subtree
User Name Attribute  |sAMAccountName
Email Attribute mail
Bind DN CN=admin,CN=Users,DC=exampleu,DC=org
Associated Realms LocalRealm

4. Click Authentication Rules at the bottom of the page.

5. Click | “2%< | tg create a catchall rule that will place all users into the Guest role:
Field Value
Name catchall
Description All local eduroam users
Conditions <none>
Actions Role--Student?, Access Duration--1day.

a. Orother appropriate role for internal eduroam authenticated users.

6. Click to save the authentication source.

Eduroam Authentication Source

) The iptables service An eduroam authentication source must be defined. The authentication source will be
()]
I must be restarted after named eduroamAS.
the eduroam 1. Select Configuration > Policies and Access Control > Authentication Source.
authentication source is

2. Inside the Exclusive Sources box, click | "=*=*=*==>>=" | ‘and choose Eduroam.
created.
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A3 Configuration

3. Fillinthe form as shown below:

Use Case 8: Eduroam

Field Value

Name eduroamAS
Description Eduroam authentication
Server 1 Address 1234
Eduroam Server 1 Port 1812
Server 2 Address 2345
User Name Attribute 1812
RADIUS Shared Secret Value supplied by eduroam.
Local Realms exampleu.edu

4.  Click Authentication Rules at the bottom of the page.

5. Click [ “™** | to create a catchall rule that will place all users into the Guest role:

Field Value

Name catchall
Description All eduroam users
Conditions <none>
Actions Role--Guest, Access Duration--1day.

6. Click to save the authentication source.

7. Restartthe iptables service using Status > Services.

Local Connection Profile
LocalEduroamCP must The local connection profile will be named LocalEduroamCP.
)
1" appear before 1. Select Configuration > Connection Profiles, and then click | e connetion profie |

eduroamCP in the list of
all connection profiles.

2. Fillin the form with the following values:

Field Value
Profile Name LocalEduroamCP
Profile Description Connection for local eduroam users
Automatically Register Clients On
802.1X Recompute Role from Portal off
Filters SSID -- eduroam
Sources LocalADAuth
3. Click

Eduroam Connection Profile

The eduroam connection profile will be named eduroamCP.

1. Select Configuration > Connection Profiles, and then click

2. Fill in the form with the following values:

Field

Profile Name

Value

eduroamCP

New Connection Profile

Profile Description
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Field Value
Automatically Register Clients On
802.1X Recompute Role from Portal off
Filters Filters all

SSID -- eduroam
Realm -- eduroam

Sources eduroamAS

3. Click

Use Case 8 Complete

This completes the Eduroam use case.
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Advanced Topics

Best Deployment Practices

Memory and vSwap

vMotion

Fault Domains

RARP

Link Capacity

Part Number:

A3's database is a distributed database, requiring high performance and low latency to
operate correctly. This section discusses best deployment practices to ensure latency and
stability.

VMware vSwap should be turned off for A3. vSwap may cause latency as a cluster
member attempts to swap memory. It's also best to set 100% Memory Reservation by
entering the amount of RAM required in the VM configuration and selecting Reserve all
guest memory (All locked). An additional benefit of this approach is to eliminate physical
memory fragmentation - another factor in controlling latency.

vMotion is not supported for A3 VMs.

vSphere's affinity model allows a set of VMs to be spread across ESXi hosts in a vSphere
cluster. A3 is already a distributed system that handles its own data replication. A3 VM
affinity should be configured so that vSphere will not put any two A3 VMs on the same
physical host.

Switches must be notified to modify the ARP entries for virtual machines as they migrate.
This avoids long pauses while forwarding paths are resolved. All switches in the network
must support ARP in a VMware-compatible manner. vMotion's notify switches option must
also be enabled to send RARP packets.

vMotion requires significant bandwidth to transfer gigabytes of VM RAM between hosts.
Although it is normally configured to limit its bandwidth to 10Gbps, it can be configured for
larger links. If possible, dedicated links should be used for vMotion traffic. Those links
should be configured with jumbo packets of 9000 bytes, if possible.
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Paravirtualization

Snapshots

Advanced Topics

Under certain heavy 1/0 load from multiple VMs, paravirtualization can cause A3 VMs to
slow by a factor of 20%. Beneficially, however, paravirtualization improves stability and
performance reliability and linearity.

VM snapshots affect the performance of running VMs. Copy-on-write snapshots have a
further detrimental affect, since two disk accesses are performed for each application
write operation. It is desirable, therefore, to disable snapshotting of A3 VMs.

If snapshots are used, only VM disks should be snapshot and not the RAM. Memory
snapshots will introduce extended latency in A3 operation.

Administrative Access

Although a single administrator is defined at A3 installation, lesser administrative access
can be given to other A3 administrators. The admin access roles are used in
Authentication Sources under Administrative Rules. See the example below; a larger scale
example is included in Use Case 3: Local User Authentication.

1. Navigate to Configuration > System Configuration > Admin Access.
2. The built-in roles are listed below. These can be used as-is:
e ALL: provides the user with all the admin roles without any exception

e ALL_PF_ONLY: provides the user with all the admin roles related to the A3
deployment (excludes switch login rights)

¢ Node Manager: provides the user the ability to manage the nodes
¢ User Manager: provides the user the ability to manage other users

e  Security Event Manager: provides the user the ability to manage the security
events (trigger, open, close) for the nodes

3. Otherwise a new role can be defined, select |'
4. Fill in the form as per the following table:

Field Usage Example
Name Name for the type of administrator, not the User admin
name of the administrator.
Description | A further description Can administer user
entries
Actions Which actions this type of admin can perform. |Select all the actions
under Users.

Creating Dynamic Reports

Part Number:

Using the /usr/local/pf/conf/report.conf configuration file, you can define reports that
create SQL queries to view tables in the A3 database. These reports will appear under the
Reports > Dynamic Reports menu of the A3 GUI.
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In order to configure a report, you need to edit /usr/local/pf/conf/report.conf and add a
section that defines your report. Then execute the command:

/usr/local/pf/bin/pfcmd configreload hard.

The following attributes are available to define your report:

Field Usage Example
type Determines what type of report this is. Setting type=built-in will
cause this report to appear
under Other reports in the A3 GUI. If this field is left blank the report
will appear under Dynamic reports.
description (Mandatory) The text that will be displayed under the appropriate Authentication report
heading for the report.
base_table (Mandatory) The base SQL table that will be used to create the auth_log
report.
columns (Mandatory) The columns to select from the table(s). auth_log.*
date_field (Mandatory) The field to use for date filtering. This will also be used |attempted_at
as the default sorting field unless order_fields is defined.
joins The tables to join in the base table and how to join them. See below
for an example.
group_field The field to group the entries b y. No grouping is performed if this field
is empty.
order_fields A comma separated field indicating the ordering of the report. The  |-node.regdate,

field should be prefixed
with a minus sign (-) if the sort should be made in descending order
for the field.

locationlog.start_time,
+iplog.start_time

base_conditions

A comma separated field indicating conditions that should be applied
to the report. This can be

used to filter the report without requiring that the user use the search
facility. Conditions should use the following format: field:opera-
tor:value.

auth_log.source:=:sms,
auth_log.status:!=:completed

base_conditions_operator

One of all or any, indicating how the base conditions should be
matched.

person_fields

The comma separated fields in the report that represent a user in the
A3 database. Field values in this field will be clickable, allowing the
user to view or modify values for the selected user. The fields must
be listed with the name they have in the report header without any
quotes.

node_fields

The comma separated fields in the report that represent a node in the
A3 database. Field

values in this field will be clickable, allowing the user to view or mod-
ify values for the selected node. The fields must be listed with the
name they have in the report header without any quotes.

mac

searches

Part Number:

A comma separated list of searches that should be available in the
report. Each entry should be in the following format type:Display
Name:field.

* type defines the type of the search, the only type currently
supported is string.

* Display Name is the user friendly name of the field for display.
e field is the SQL name of the field to search.
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Notes:
1. The operators IS and <> should be replaced by = and !=, respectively.

2. You should always prefix the fields with the table name and a dot (e.g. node.mac,
locationlog.role) so that they are not ambiguous. Although your query may work with a
single table, it will not if you decide to add joins that contain column name(s) that are
the same as the base table.

View of the authentication log

In this simple example, you will be able to select the whole content of the auth_log table
and use the date range on the attempted_at field as well as search on the pid field when
viewing the report.

[auth_log]

description=Authentication report

# The table to search from

base_table=auth_log

# The columns to select

columns=auth_log.*

# The date field that should be used for date ranges
date_field=attempted_at

# The mac field is a node in the database
node_fields=mac

# Allow searching on the PID displayed as Username

searches=string:Username:auth_log.pid

View of opened security events

In the following example, the security_event table is left joined to the class, node and
locationlog tables. All security events are listed, even on deleted nodes. Base conditions
are added to filter out outdated locationlog entries as well as include devices without
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locationlog entries. Removing those conditions would lead to duplicate entries being
shown since the report would reflect all the historical locationlog entries.

[open_security_events]

description=0pen security events

# The table to search from

base_table=security_event

# The columns to select

columns=security_event.vid as "Security event ID", security_event.mac as "MAC

Address’, class.description as "Security event description”, node.computername
as

"Hostname’, node.pid as "Username”, node.notes as “Notes’, locationlog.switch_ip
as "Last switch IP", security_event.start_date as "Opened on"

# Left join node, locationlog on the MAC address and class on the security event
D

joins=<<EQT

=>{security_event.mac=node.mac} node|node
=>{security_event.mac=locationlog.mac} locationlog|locationlog
=>{security_event.vid=class.vid} class|class

EOT

date_field=start_date

# filter on open locationlog entries or null locationlog entries via the end_date
field

base_conditions_operator=any
base_conditions=locationlog.end_time:=:0000-00-00,locationlog.end_time:IS:

# The MAC Address field represents a node

node_fields=MAC Address

# The Username field represents a user

person_fields=Username

Performance Enhancements

DHCP - IP Helpers

Part Number:

A3 works best when it sees IP DHCP assignment for devices on its networks. For any
networks or VLANs where client isolation or IP address lookup is required, IP helpers can
be used.

No action is required for the registration or isolation networks or VLANs since A3 performs
DHCP functions.
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(o 011 SOme versions of

" Windows, the getmac
command will return
invalid output when
running the installer in a
language other than
English. In order to
workaround the issue,
change your Windows
language to English, then
logout/login and run the
installer again.
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IP helpers are the simplest and best solution for production networks that already use IP
helpers. To use this feature on Extreme Networks Access Points, set the secondary DHCP
server to A3's management VIP address (B).

To use this feature on other equipment, add A3's management VIP address as the last
ip-helper-address statement in your network equipment. This will cause A3 to receive a
copy of all DHCP requests for that VLAN and will record what IP addresses were
distributed to what client.

The DHCP remote sensor is a lightweight binary that can be installed on a production
DHCP server in order to replicate the DHCP traffic 1:1 to the A3 server. This solution is
more reliable than the DHCP relaying since A3 will receive a copy of all DHCP traffic, not
just the broadcast DHCP traffic. Supported DHCP servers are Microsoft DHCP server and
CentOS6and7.

Microsoft DHCP Sensor

DHCP-Forwarder is an optimized version of udp-reflector, which installs easily and only
copies DHCPREQUESTS and DHCPACK packets to the destination.

Download the installer from here. This will
1. Install WinPCAP and nssm.

2. Launch a configurator to set interface, IP, and port. Specify A3's VIP address (B) and
port 767 as the UDP port.

3. Save the configuration.
4, Install and launch the DHCP-Forwarder service.

Linux-based Sensor
1. Download the RPM on your non-A3 DHCP server.
a. Cent0S 6 servers:

waget http://inverse.ca/downloads/PacketFence/Cent0S6/extra/x86_64/RPMS/
udp-reflector-1.0-6.1.x86_64.rpm

b. ForCent0ST7:

waget http://inverse.ca/downloads/PacketFence/Cent0S7/extra/x86_64/RPMS/
udp-reflector-1.0-6.1.x86_64.rpm

2. Install the sensor:

rpm -i udp-reflector-*.rpm

3. Configure the sensor. Place the following line in /ete/rc.local:

Jusr/local/bin/udp_reflector -s pcap0:67 -d 10.150.1.254(B):767 -b 25000 &

where pcap0 is the pcap interface that the DHCP server listens on (the interfaces can
be listed using the udp_reflector -1 command) and 10.150.1.254(B) is the management
VIP of your A3 server.
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4,  Startthe sensor:

Jusr/local/bin/udp_reflector -s pcap0:67 -d 10.150.1.254(B):767 -b 25000 &

DHCP traffic should now be reflected on the A3 server.

Active Directory Integration

A complete active directory integration requires that A3 be kept aware of deleted,
disabled, and locked accounts. This allows A3 to disconnect a user whose account has
been deleted, disabled, or locked. How quickly this takes effect is dependent on the
frequency of the scheduled job used to run these scripts.

Deleted Account

1. Create the script unreg_node_deleted_account.ps1 on the Windows Server with the
following content. Make sure to change @IP_A3 to the IP address of your A3 server’s
VIP address (B). The user name and password must match the credentials defined in
the A3's administrative interface under Configuration > Integration > Web Services.

FHE A AR AR A A A R R R R R R
#Powershell script to unregister deleted Active Directory account based on the UserName.#
FHEH A R S R R R

Get-EventLog -LogName Security -InstanceId 4726 |

Select ReplacementStrings, "Account name" |

>3
©

{

Surl "https://@QIP_A3:9090/"

$username = "admin" # Username for web services

$password = "admin" # Password for web services

[System.Net.ServicePointManager]::ServerCertificateValidationCallback = {S$true}

$command = '{"jsonrpc": "2.0", "method": "unreg node for pid", "params": ["pid",
"'+$ .ReplacementStrings[0]+'"]}"'

Sbytes [System.Text.Encoding] : :ASCII.GetBytes ($Scommand)

Sweb
Sweb
Sweb
Sweb
Sweb

Sstream

[System.Net.WebRequest]::Create ($url)
.Method = "POST"
.ContentLength = $bytes.Length

.ContentType = "application/json-rpc"
.Credentials = new-object System.Net.NetworkCredential (Susername, S$password)
Sweb.GetRequestStreamn ()

Sstream.Write ($bytes, 0, $bytes.Length)

$Sstream.close ()

Sreader

New-Object System.IO.Streamreader -ArgumentList
Sweb.GetResponse () .GetResponseStreamn ()

Sreader.ReadToEnd ()

Sreader.Close ()
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2. Create the scheduled task based on an event ID in Start > Run > Taskschd.msc, Task

Scheduler > Task Scheduler Library > Event Viewer Task > Create Task. Settings:

Field Usage

General Name: A3-Unreg_node-for-deleted-account
Check: Run whether user is logged on or not

Check: Run with highest privileges

Triggers > New A fyrther Begin on the task: On an event
Log: Security
Source: Microsoft Windows security auditing.
Event ID: 4726

Actions > New Which actions this type of admin can Action: Start a program
Program/script: powershell.exe

Add arguments (optional):
C:\scripts\unreg_node_deleted_account.ps1

Settings Run a new instance in parallel

3. Validate with Ok and designate the account that will run this task. (Usually
DOMAIN\Administrator)
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Disabled Account

1. Create the script unreg_node_disabled_account.ps1 on the Windows Server with the
following content. Make sure to change @IP_A3 to the IP address of your A3 server.
The user name and password must match the credentials defined in the A3
administrative interface under Configuration > Integration > Web Services.

FHEF A A A R R R R
#Powershell script to unregister disabled Active Directory account based on the UserName.#

FHAAAF AR R R R R R R R R R R R R R R R

Get-EventLog -LogName Security -InstanceId 4725 |
Select ReplacementStrings, "Account name" |

5 |

$url = "https://@IP_A3:9090/"

Susername = "admin" # Username for the webservices

$password = "admin" # Password for the webservices
[System.Net.ServicePointManager]::ServerCertificateValidationCallback = {S$true}
$command = '{"jsonrpc": "2.0", "method": "unreg node for pid", "params": ["pid",

"'+S .ReplacementStrings[0]+'"]}"'

Sbytes = [System.Text.Encoding]::ASCII.GetBytes ($command)
Sweb = [System.Net.WebRequest]::Create(Surl)
Sweb.Method = "POST"

Sweb.ContentLength = $bytes.Length

Sweb.ContentType = "application/Jjson-rpc"

Sweb.Credentials = new-object System.Net.NetworkCredential ($Susername, S$password)
$Sstream = S$web.GetRequestStream /()

Sstream.Write ($bytes, 0, Sbytes.Length)

Sstream.close ()

Sreader = New-Object System.IO.Streamreader -ArgumentList
Sweb.GetResponse () .GetResponseStreamn ()

Sreader.ReadToEnd ()

Sreader.Close ()
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Advanced Topics

2. Create the scheduled task based on an event ID in Start > Run > Taskschd.msc¢, Task

Scheduler > Task Scheduler Library > Event Viewer Task > Create Task. Settings:

Field

General

Usage

Name: A3-Unreg_node-for-disabled-account
Check: Run whether user is logged on or not

Check: Run with highest privileges

Triggers > New

Begin on the task: On an event

Log: Security

Source: Microsoft Windows security auditing.
Event ID: 4725

Actions > New

Action: Start a program
Program/script: powershell.exe

Add arguments (optional):
C:\scripts\unreg_node_disabled_account.ps1

Settings

Run a new instance in parallel

3. Validate with Ok and designate the account that will run this task. (Usually
DOMAIN\Administrator)
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Locked Account

1. Create the script unreg_node_locked_account.ps1 on the Windows Server with the
following content. Make sure to change @IP_A3 to the IP address of your A3 server.
The user name and password must match the credentials defined in the A3
administrative interface under Configuration > Integration > Web Services.

FHA A A R R R S R R R
#Powershell script to unregister locked Active Directory account based on the UserName.#

FHEHEFHH AR R R R R R R R R R R

Get-EventLog -LogName Security -InstanceId 4740 |
Select ReplacementStrings, "Account name" |
o
3 |

$url = "https://@QIP_A3:9090/"

Susername = "admin" # Username for the webservices

$password = "admin" # Password for the webservices

[System.Net.ServicePointManager]::ServerCertificateValidationCallback = {S$true}

Scommand = '{"jsonrpc": "2.0", "method": "unreg node for pid", "params": ["pid",
"'+$_.Replacementstrings[O]+'"]}'

Sbytes = [System.Text.Encoding]::ASCII.GetBytes ($Scommand)

Sweb = [System.Net.WebRequest]::Create (Surl)

Sweb.Method = "POST"

Sweb.ContentLength = S$bytes.Length

Sweb.ContentType = "application/json-rpc"

Sweb.Credentials = new-object System.Net.NetworkCredential ($username, S$password)
Sstream = $web.GetRequestStream()

Sstream.Write (Sbytes, 0, $bytes.Length)

$Sstream.close ()

Sreader = New-Object System.IO.Streamreader -ArgumentList
Sweb.GetResponse () . GetResponseStream ()

Sreader.ReadToEnd ()

Sreader.Close ()
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Advanced Topics

2. Create the scheduled task based on an event ID in Start > Run > Taskschd.msc. Task

Scheduler > Task Scheduler Library > Event Viewer Task > Create Task. Settings:

Field

General

Usage

Name: A3-Unreg_node-for-locked-account
Check: Run whether user is logged on or not

Check: Run with highest privileges

Triggers > New

Begin on the task: On an event

Log: Security

Source: Microsoft Windows security auditing.
Event ID: 4740

Actions > New

Action: Start a program
Program/script: powershell.exe

Add arguments (optional):
C:\scripts\unreg_node_locked_account.ps1

Settings

3. Validate with Ok and designate the account that will run this task. (Usually

Run a new instance in parallel

DOMAIN\Administrator)
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networks

A3 Troubleshooting

This chapter discusses the means by which A3 problems can be diagnosed. This chapter
assumes that troubleshooting will be performed by IT professionals with experience in
network diagnostics and A3 administration. All navigation and settings used in this chapter
refer to the A3 administrative interface unless otherwise specified.

Administration

Unable to Run A3 Administration

1.

Check the URL for A3 administration using the VIP address. For example: https://
10.150.1.254:1443 (B). An https:// prefix is required.

a. Checkthatyou are using the correct VIP address as entered in Initial A3
Configuration.

b. Checkthatthe address is not covered by a local DHCP server.

Check access via the direct address of the A3 cluster member. For example https://
10.150.1.4:1443 (A). If this succeeds, then get the VIP address (B) from Configuration >
Network Configuration > Interfaces and try step 1 again.

Check that the virtual machine hosting A3 is running and has at least 16 GB of memory.

Browser Complains That A3 Is Unsafe

1.

See A3 Server Certificate in Initial A3 Configuration if the client’s browser complains
about an unsafe site.

Internet Explorer Cannot Display the A3 Admin Page

1.

Changes Don’t Take Effect

1.
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Internet Explorer versions 8 through 10 may raise an “Internet Explorer cannot display
the webpage” error while attempting to access A3 administration interface.

Internet Explorer 11 or later must be used for A3 administration.

If there are any Restart ... buttons at the bottom of the page where changes were
made, make sure to use them.
If you're not sure, then use the Restart All button on the Status > Services page.

Within clusters services must be individually restarted on each A3 member.

a. Loginto the administrative instance for each A3 member using its individual
address, not the VIP address.

b. Restart the appropriate or all services on each member.
c. Waitfor services have restarted on each member.
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The Auditing Tab

The Auditing Tab

A3 Troubleshooting

Getting Started

The Auditing tab and RADIUS Debug feature A3 are two of the most valuable

troubleshooting tools. Since they are used in most troubleshooting techniques, they are

described here and referenced where used.

1.

Use the Auditing page to determine if the AP and A3 are communicating correctly and

what information A3 is returning to the AP. Select Auditing > RADIUS Audit Logs.

a. Clicking on a RADIUS log entry for the MAC address of the clientin the correct
time frame. The page may require a refresh. The Auth Status column may show
Reject or Accept for the client. If there is no current entry for the MAC address

skip to the next step.

b. Onthe Device Information tab confirm that the Wi-Fi Network SSID is correct.

c. Onthe RADIUS tab,

i. Ifthe entry for the MAC address was Reject, then look for the error reply.

ii. Ifthe entry for the MAC address was Accept, note the Filter-Id in the
RADIUS Reply. This is the value that A3 returned to ExtremeCloud 1Q.

If the Auditing page had no timely entry for the client’'s MAC address, then use the

Tools > RADIUS Debug tool’s Log Viewer facility.

a. Leave all fields blank or enter the Client MAC address.
b. START the viewer.

c. Trythe client authentication.

d. STOP the viewer.

e. Look for errors, especially shared secret failures.

Clients Don’t See Captive Web Portal

Part Number:

Basic Issues

1.

Recall that if a client has already been authenticated that the authentication must be

cleared from A3. Use the following steps:
a. Navigate to Configuration > Clients.
b. Double click on the line corresponding to the client. The client should show a

) Sstatus.
c. Make the following changes to the entry:

i.  Owner to default.
ii. Status to Unregistered.
iii. Role to No Role.
d. Select Save.
Check that the client is connected to the appropriate SSID.

Use the Auditing tab as described in The Auditing Tab.

A3 Installation and Usage Guide Community

144


https://boundless.aerohive.com/

Getting Started

A3 Troubleshooting

Check thatthe SSID is used in the Connection Profile and that the profile uses external
authentication sources.

Check in ExtremeCloud 1Q that the AP has been set up with a default user profile that
uses the registration VLAN.

Check that the client’s IP address is in the range associated with the registration
VLAN by using ipconfig on the client.

In most cases, the client's default web browser will pop up with the CNP (captive
network assistant) display. Some browsers, however, will require further
“encouragement”. Use a well known URL (such as http://cnn.com) to force the CWP.
When using such a URL, make sure to type all of http:// since the browser may auto-
complete the entry with https://)

See A3 Server Certificate in Initial A3 Configuration if the client’s browser complains
about an unsafe site.

VLAN Setup is Incorrect

1.
2.
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Use the Auditing tab as described in The Auditing Tab.
Check that the registration VLAN has been setup in A3.

a. The VLANs were configured during Initial A3 Configuration, during Setup IP
Addresses.

b. The VLANs can be viewed and adjusted at Configuration > Network
Configuration > Networks > Interfaces.

VLAN setup can be further checked using Tools > Netstat, Display routing table
information or Tools > IP Configuration, Display IP configuration:

a. Each of the registration and isolation networks should be listed. For example,
10.100.100.0 in the examples used in this guide.

b. The Iface column will also show the eth interface used for each.

c. Foreach Domainthathas been joined, a new interface named <Domain Name>-b
will be listed.

Check that switches, routers, and VPN devices have been correctly configured to
connect the access point to A3 using the registration VLAN.

ExtremeCloud 1Q’s VLAN probe utility (Manage > Tools > Utilities > VLAN Probe) can
be used to see if appropriate VLANSs are set up at the access point. Limit the range of
VLANSs probed to save time.

Check layer 3 connectivity in a layer 3 deployment using A3’s traceroute (Tools >
Traceroute). Check that A3 is able to reach the far end routers.

A3's Tcpdump (Tools > Tcpdump) may be needed to further diagnose problems.

a. Selectthe registration network, either eth0.<reg VLAN #> if a port group is used
or eth<#> if a separate interfaces was use. Otherwise leave all other fields blank.

b.  Run Tcpdump while the client attempts a registration.

c. Download the dump and use a display utility, such as Wireshark, to inspect the
results.

d. Look for DHCP discover messages to A3 to establish VLAN connectivity.
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Authentication Issues

Clients No Longer See CWP

1. Recall thatif a client has already been authenticated that the authentication must be
cleared from A3. Use the following steps:

a. Navigate to Configuration > Clients.
b. Double click on the line corresponding to the client. The client should show a

) status.
c. Make the following changes to the entry:

i.  Owner to default.
ii.  Status to Unregistered.
iii. Role to No Role.

d. Select Save.

Clients Cannot Successfully Authenticate with the CWP

1. See Clients No Longer See CWP with respect to multiple authentication attempts.

2. Ifyouare unsure whether services were restarted after an Active Directory, restart all
services now.

3. Ifemail, SMS, or sponsored authentication is being used check that Alerting has been
setup. Test the alerting setup with Tools > SMTP test.

4. Use the Tools > Authentication Test tool.

a. Check each Authentication Source in the order listed in the Connection Profile to
see which one is matched.

b. If Username or Password is not applicable to a particular type of authentication,
justfill in nonsense.

c. Note thatif the Authentication Source is filtered by an SSID in a Condition for an
Authentication Rule, then the Authentication Test tool will fail.

5. If Domain-based authentication is used, recheck domain setup.

a. Use Tools > NTLM Authentication to check if the client’'s name and password are
correct. The diagnostics available with this tool are more illuminating that with
other methods.

b. Checkthat the Domain join is still valid. In Configuration > Active Directory
Domains, use the Unjoin and Rejoin buttons to check. Remember that you'll need
administrative credentials to complete the Rejoin.

Clients Cannot Use Social Login Authentication

1. Check Authentication Sources for each of the social login sources. The Authorized
Domain setting should include a comma separated list of domains used by the social
login site. Check the list against A3’s online help.

2. The domains used by social login sites can change over time. Check the URL of the
social login site that failed and add its domain to the authentication source’s
Authorized Domain list.
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A3 Troubleshooting

Some Clients Cannot Join with Active Directory Authentication

1.

In a cluster configuration, each A3 member must individually perform a JOIN
operation with the Active Directory. Make sure that this is the case by using the Join/
Rejoin button on the Configuration > Active Directory Domains page. Remember that
you'll need administrative credentials to complete the operation.

Recheck domain setup.

a. Use Tools > NTLM Authentication to check if the client’s name and password are
correct. The diagnostics available with this tool are more illuminating that with
other methods.

b. Check that the Domain join is still valid. In Configuration > Active Directory
Domains, use the Unjoin and Rejoin buttons to check. Remember that you'll need
administrative credentials to complete the Rejoin.

Post-Authentication Issues

Clients Assigned to Incorrect Role

Part Number:

1.

Recheck Role, Device, Authentication Sources, and Connection Profile settings.
Refresh A3's Ul for the individual pages to ensure that there have been no browser-
related mixups.

Recall that if a client has already been authenticated that the authentication must be
cleared from A3. Use the following steps:

a. Navigate to Configuration > Clients.

b. Double click on the line corresponding to the client. The client should show a

) Status.
c. Make the following changes to the entry:

i.  Owner to default.
ii.  Status to Unregistered.
iii. Role to No Role.

d. Select Save.

Check that the client is connected to the appropriate SSID.

Check the order in which Authentication Sources are defined in the Connection
Profile. These are used in the order in which they are listed. An earlier source may
match resulting in an unanticipated role assignment.

Use the Tools > Authentication Test tool.

a. Check each Authentication Source in the order listed in the Connection Profile to
see which one is matched.

b. If Username or Password is not applicable to a particular type of authentication,
justfill in nonsense.

c. Note thatif the Authentication Source is filtered by an SSID in a Condition for an
Authentication Rule, then the Authentication Test tool will fail.

Check the Device’s Roles assignments.
a. Navigate to Configuration > Policies and Access Control > Devices.
b. Selectthe AP, then Roles tab.
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Cluster Problems

1.

A3 Troubleshooting

c. Checkthat Role by Device Role is exclusively selected.

d. Checkthatthe role name filled into the form matches exactly (including case) that
defined in ExtremeCloud 1Q.

e. The ExtremeCloud 1Q setting is located in the Wireless Network's User Profile
settings under Assignment Rules. The Type field should be RADIUS Attribute and
the Value should match that used in A3.

Use the Auditing tab as described in The Auditing Tab.

Authenticated Clients Can’t Access Internet or Local Sites

If authenticated users cannot access the intended local or internet sites, use one or more
of the following techniques:

Cluster Problems

1.

On the client, use ipconfig to check that the client has been assigned to the network
associated with their production VLAN, and that the gateway is correct. If this is
incorrect, see Clients Assigned to Incorrect Role.

In layer 2 deployments, use the ping utility in A3 to check if there is a systemic
network problem that would limit access. Note that ping does not always work even
when a site is accessible; sites may refuse to respond to ping (ICMP echo) requests.

Use ExtremeCloud 1Q’s ping command to test from the perspective of the AP:
a. Navigate to Manage > Tools > Utilities.

b. Select Device Diagnostics from the drop-down list.

c. Checkthe box beside the AP of concern.

d. Clickon

e. Select ping.

If the ping test fails, try using traceroute from A3 and/or ExtremeCloud 1Q.

Part Number:

If all A3 operations stop, refer to Graceful Shutdown and Restart and Cluster Backup
and Recovery for suggestions.

Failure of one or more, but not all, cluster members may be evident from:
e Slow client authentication

¢ Inability to perform configuration updates in the administration GUI
e Aredwarning in the administration GUI

The identity of the failed cluster member may be viewed in Configuration > System
Configuration > Cluster. Take whatever steps are necessary to restart the cluster
members. Normal operation should ensue after all members are completely restarted.

If a member cannot be restarted and must be reloaded, refer to Cluster Backup and
Recovery for suggestions.
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Term Definition

X See 802.1X.

802.1X The IEEE 802.1X standard defines how to provide authentication for devices trying to connect with
other devices on LANs or wireless LANs.

-A-

A3 Extreme Networks software product for authentication, authorization, and accounting. Works in
conjunction with Exireme Networks APs and many switches.

A3 services Software processes running on A3 that perform both internal tasks and interfaces with external

services.

access control list

A list of permissions associated with a network connection.

access network

The means by which a client enters the corporate network. This is usually an AP, Wi-Fi controller,
or enterprise switch.

ACL

See access control list.

Active Directory

Microsoft's name for an LDAP directory that holds information about corporate organization,
users, machines, and devices.

administration rules

Administration rules dictate what administrative privileges will be granted to the user when an
authentication source is applied.

AdminProxy An authentication mechanism used in Microsoft systems for administrator single sign-on.

agent In the context of A3, a user agent s a client-resident component that aids in certificate deployment
and authentication.

alert An email, sms, or other message sent to one or more administrators triggered by a security event
or other action.

Android An open-source operating system used for smart phones and tablets.

AP See access point.

Apache The name of a web server often distributed with Linux-based systems, in particular A3.

auditing The process of reviewing details of transpired connections.

authentication

The process of verifying a user’s identity.

authentication module

A captive portal module used to perform a particular type of authentication.

authentication rules

Authentication rules are associated with most authentication sources. They dictate what actions
are performed when the authentication source is triggered.

authentication server

A server or service that validates user credentials.

authentication source

The means by which a user is authenticated. These can be internal, external, billing, and exclusive
authentication sources.

authenticator

A device that enforces authentication, only allowing properly identified clients to access the net-
work. Often an Extreme Networks AP.

AuthorizeNet
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See billing authentication.
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Term Definition
BaracudaNG See firewall.
billing authentication Authentication after paying for service with a payment provider, such as Paypal.
billing module A captive portal module that is used to perform billing operations as part of the client authentica-

tion process.

billing tier A level of usage for billing purposes. For example, Gold, Silver, and Bronze tiers that provide lower
bandwidth at each step.

Blackhole An authentication mechanism that denies authentication for the client. This can be used to deny
clients access that would otherwise be granted.

CA See certificate authority.

captive web portal

A set of weh pages offered to users in lieu of their requested web site. The CWP is used to perform
authentication with users.

certificate

See x.509 certificate.

certificate authority

An entity that generates x.509 certificates. These can be commercial entities such as RSA, or
organization’s own mechanisms.

chained module

A captive portal module thatis used to step through a number of other modules in order.

Checkpoint

See firewall.

choice module

A portal module that offers clients a choice of authentication methods or procedures.

Cisco Mobile Services Engine

A software agent resident on access points and other devices as part of CMSE.

cul See command line interpreter.

client A person or device seeking access to a network.

client certificate An x.509 certificate issued to a client.

cluster The use of multiple computer systems, each running the same software to share load and to pro-
vide graceful degradation in the face of failure.

CMSE See Cisco Mobile Service Engine.

comma-separated values

Afile type in which the fields are separated by commas or other designated character.

command line interpreter

An interface to a network device that relies on command line instructions.

common name

Used in certificates, usually the host plus domain name. E.g. www.yoursite.com.

compliance

The requirement that clients and devices conform to rules related to operating system, update sta-
tus, and vulnerability protection.

connection profile

Connection profiles tie access points together with the authentication sources and captive portal
to be used.

content security policy

A set of security policies that detects and mitigates certain types of attacks.

CSP

See content security policy.

CSV See comma-separated values.

Cwp See captive web portal.

deployment The manner in which a network service, such as A3 is included in a larger network.
device A client or network component. In A3, it specifies access network components.

device group

A shorthand technique for defining A3 devices; a group of settings related to a type of device. For
example, Extreme Networks APs.

device parking

The process of putting devices that are not able to register in a low overhead state.

device profile
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Used in Fingerbank, a profile of a device in terms of DHCP data items.
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DHCP See dynamic host control protocol.
DHCP Option82 A DHCP option that allows a controller to act as a DHCP relay agent to prevent DHCP clients
requests from untrusted sources.
DHCP relay agent A software component that accepts and forwards DHCP requests via layer 3 messages to a

remote DHCP server.

distinguished name

A DN is also a fully qualified path of names that trace the entry back to the root of an LDAP/AD
tree.

DN See distinguished name.
DNS See domain name service.
domain A Windows domain is a form of a computer network in which all user accounts, computers, print-

ers and other security principals, are registered with a central database.

domain name service

A service that translates network names (such as www.google.com) to IP addresses.

dot1X

See 802.1X.

dynamic host control protocol

A software server that hands out IP addresses in response to client requests using the DHCP pro-
tocol.

-E-

EAP See extensible access protocol.

EAP-FAST The Flexible Authentication via Secure Tunneling (FAST) protocol establishes a tunnel without the
need for client or server certificates. See EAP.

EAP-GTC A technique used in conjunction with Generic Token Cards In this method, the RADIUS server
sends a challenge to the security token on the client. The response is sent back and validated by
the server. See EAP.

EAP-MD5 An older technique that uses an MD5 hash to authenticate the client to the RADIUS server, but not
vice versa. Itis currently deprecated. See EAP.

EAP-TLS Requires client certificates. The client and server perform mutual authentication and form encryp-
tion keys based on certificate contents. See EAP.

EAP-TTLS The Tunneled Transport Layer Security (TTLS) protocol extends TLS. The client need not be
authenticated initially by the server using a certificate, although the server’s certificate is used by
the client. See EAP.

E-CWP See external captive web portal.

eduroam Eduroam is a global wireless network access service for research and education.

email authentication

Authentication via a CWP that sends an email message to a client. The client must click on a link in
the email to complete authentication.

enforcement

The process of implementing an authentication decision. This is often done in APs and switches.

ESXi

VMware ESXi is an operating system-independent hypervisor based on the VMkernel operating
system that interfaces with agents that run on top of it.

exclusive authentication

A set of miscellaneous authentication techniques in A3. An exclusive authentication technique
must be used by themselves.

extensible access protocol

The EAP framework makes possible a number of methods for secure exchange of identity.

external authentication

Authentication sources that perform user identification through the captive web portal or other
Web interface where the A3 owner does not control the information.

external captive web portal

A captive portal invoked from the access device rather than A3.

ExtremeCloud 1Q

A cloud-based service for management of Extreme Networks devices, including APs.
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Facebook See social login.

filter engine An A3 file that is used to process information from VLAN, RADIUS, Apache, DHCP, DNS, and
devices.

Fingerbank A shared database of DHCP fingerprints that identify devices.

fingerprint In Fingerbank, a specification of the DHCP-specific options handled by a device - which can be
used to identify the device type, vendor, or model.

firewall Network software that denies, permits, or restrict access from one side of a network to another.
A3's firewall integration can be used to implement single-sign on (SS0).

FortiGate See firewall.

-G-
Github See social login.
Google See social login.

-H-

headless loT devices

Devices that lack an interactive interface, requiring special authentication techniques.

HiveManager

A deprecated name for ExtremeCloud 1Q.

Htpassword An authentication technique that uses a flat file with name and password commonly used in basic
authentication on Apache HTTP servers.
HTTP See hypertext transport protocol.

hypertext transport protocol

The communications protocol on which the Web is based. HTTP sets rules for how information is
passed between the server and the browser software.

Iboss

See firewall.

IDS

An intrusion detection system detects network traffic and system modifications due to malicious
traffic.

intrusion detection system

See IDS.

loT

Internet of Things. See headless loT devices.

Instagram

See social login.

integration

In A3, the process by which third-party networking products are integrated into A3 operation.

internal authentication

Authentication sources that use internal information and servers. In this case, the A3 owner con-
trols the authentication data.

internet of things

See loT.

isolation The process of placing devices that have been refused authentication on an isolated network so
that they may repair any problem.
-Jd-
jamf A commercial Apple management solution for IT.
JSON RPC See firewall.
JuniperSRX See firewall.

-K-

Kerberos authentication

Authentication using the Kerberos protocol and associated services.

Kickbox

See social login.
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Term Definition
layer 2 A layer in the OSI network stack that utilizes local network communications using MAC addresses.
layer 3 Alevel in the OSI network stack where communications occur based on IP addresses across mul-
tiple networks.
LDAP See lightweight directory access protocol

lightweight directory access
protocol

A protocol that provides access to hierarchically organized data bases such as Active Directory.

LinkedIn

See social login.

load balancer

A device that sits between a service requester and multiple servers, dividing work between the
Servers.

MAC authentication

A method of authentication whereby clients and devices are associated with their MAC addresses
as opposed to directory or certificate contents.

MDM

See mobile device management.

Mirapay

See billing authentication.

mobile device management

A central management systems used to configure, update, and control client devices. These are
responsible for ensuring that the correct, updated software is installed on clients. A3 can request
client status from such system, restricting client access.

Mobhilelron A commercial provisioning tool supported by A3.
MSE See Cisco Mobile Services Engine.

NAC See network access control.

Nessus A commercial scanning tool supported by A3.
netstat A network tool that reports on network status.

network access control

The technology associated with denying, allowing, and/or restricting access to network
resources.

network time protocol

A protocol by which computers obtain the current time from reliable sources.

node In A3 a node is any client or network device identified during normal or scanning operation.

NTLM NTLM uses a challenge-response mechanism for authentication, in which clients are able to prove
their identities without sending a password to the server.

NTP See network time protocol.

null authentication

A form of authentication using a CWP in which the user merely agrees to terms of service.

-0-

0Auth2 A convention used by multiple social media cites to forward user information on request.

00B See out-of-band.

OpenlD See social login.

OpenVAS A scanning tool supported by A3.

OPSWAT A vulnerability scanning tool supported by A3.

Option82 See DHCP Option 82.

out-of-band A network technique where communications is handled by other than the normal in-band commu-
nications method.

OVA A single file distribution of an OVF file package.

OVF A file format that supports exchange of virtual appliances across products and platforms.
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Term Definition
Palo Alto See firewall.
parking See device parking.
passthrough The ability to allow certain internet address to pass through A3 for the process of authentication.

password of the day

An authentication technique that generates a password on a regular basis. The password is sent
to the administrator who distributes it to users.

PayPal See billing authentication.

PEAP See protected extensible authentication protocol.

ping A network tool that measures round-trip message time between systems, using the ICMP protocol.
Pinterest See social login.

PKI See public key infrastructure.

portal See captive web portal.

portal module Any of a number of modules used to construct a captive web portal site.

POTD See password of the day.

protected extensible authen-
tication protocol

Encapsulates EAP within a potentially encrypted and authenticated TLS tunnel. Any of the EAP
methods may be used within the tunnel.

provisioner An A3 description of an agent that will set up clients for authentication and communications.

provisioning A method of automatically providing clients with identification information, certificates, and soft-
ware.

proxy An intermediary that sits between clients and the servers that they which to access, usually for

buffering or security purposes.

public key infrastructure

The comprehensive system required to provide public-key encryption and digital signature ser-
vices.

public/private keys

Ppublic and private keys are interrelated such that data encrypted with a public key can only be
unencrypted with the corresponding private key, and vice versa.

RADIUS see Remote Authentication Dial-In User Service.

Rapid7 A scanning system supported by A3.

RBAC See role-based access control.

realm A user account location, often a Microsoft domain or internet domain name.
regex See regular expression.

regexp See regular expression.

registration

The process by which a device, or node, becomes known to A3 and associated with a user.

regular expression

A special text string for describing a search pattern. You can think of regular expressions as wild
cards on steroids.

Remote Authentication Dial-
In User Service

A networking protocol that provides centralized Authentication, Authorization, and Accounting
management for users who connect and use a network service.

rogue DHCP

A DHCP server on a network not under control of the network administrators.

role

A means of distinguishing users, most often used to match their activity in an organization.

role-based access control

RBAC is used to restrict access to networked resources based on a user’s role within the enter-
prise.

root CA

A self-signed certificate that designates the start of a x.509-based public key infrastructure. A
number of well-known public root CAs exist and organizations may create their own.

root CA certificate

An x.509 certificate that identifies a root CA.

root module

Part Number:

The top level portal module used in an authentication tree.
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Term Definition
sAMAccountName The user login name contained in AD/LDAP directories.
SAML authentication A standard protocol for web browser single sign-on using secure tokens.
scanner Software used to check computers or networks for vulnerabilities.
SCEP A protocol used for enroliment and other PKI operations.

security event

Any of a set of programmed exceptions, including scanner-found vulnerabilities, network irregu-
larities, and over usage.

SentinelOne

A scanner supported by A3.

secure socket layer

SSL provides a secure channel between two machines or devices. SSL has been replaced by TLS
(transport layer security), but both techniques are often referred to as SSL.

SEPM

See Symantec Endpoint Protection Manager.

server certificate

An x.509 certificate that defines a server to client systems. It also references the certificate
authority that generated it.

services

See A3 services.

shared secret

A password shared by two or more communicating entities. A3 and ExtremeCloud 1Q use a shared
secret for RADIUS communications.

single sign-on

In A3 Firewall single sign-on is an integration in which A3 can inform firewalls of successful
authentications that allow firewalls to permit future access without additional authentication.

SMS

Short messaging service - a text messaging service component of most mobile devices.

SMS authentication

A means by which a user receives a personal identification number (PIN) used in an associated
web page to authenticate their identity.

SNMP

An application-layer protocol used to manage and monitor network devices and their functions.

social login

A form of single sign-on using existing information from a social networking service such as Face-
book, Twitter or Google+, to sign into a third party website instead of creating a new login account
specifically for that website.

sponsor email authentication

An authentication technique in which a user fills in identification for himself and a company spon-
sor. The sponsor receives an email to approve access.

SSL See secure socket layer.

SSO See single sign-on.

Stripe See billing authentication.

supplicant An entity at one end of a LAN segment that seeks to be authenticated by an authenticator attached

to the other end of that link.

Symantec Endpoint Protec-
tion Manager

A client-server solution that protects laptops, desktops, and servers in your network against mal-
ware, risks, and vulnerabilities.

syslog Short for system log, it is an aggregation of log messages from many services that can be scanned
for problems and auditing.

TLS See secure socket layer.

traceroute A network utility that displays the route that packets take from a source to a destination.

transport layer security

See secure socket layer.

trigger

A condition that causes actions to occur.

-U-

user

A person or autonomous device seeking access to a network.

user agent

Part Number:

See agent.
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Term Definition

vCenter VMware vCenter Server is advanced server management software that provides a centralized
platform for controlling VMware vSphere environments.

violation A deprecated term for security events.

VLAN A group of devices on one or more LANSs that are configured to communicate as if they were
attached to the same wire, when in fact they can be located on a number of different LAN seg-
ments.

WatchGuard See firewall.

Web Auth A web-browser API for the creation and use of strong authentication credentials based on public

key cryptography.

web services

In A3, the ability of external services to access A3's database.

whitelist

A list of internet addresses that are allowed access despite any other restrictions.

Windows

A Microsoft operating system used on desktop, laptop, and server computers.

Windows Management Inter-
face

A set of specifications from Microsoft for consolidating the management of devices and applica-
tions in a network from Windows computing systems.

WISPr A protocol that allows users to roam between wireless internet service providers in a fashion sim-
ilar to that which allows cellphone users to roam between carriers.

WMI See Windows Management Interface.

WRIX Wireless Roaming Intermediary eXchange is a modularized set of standard service specifications

designed to facilitate commercial roaming between operators.

-X-

x.509 certificate

Part Number:

A file that documents the identity of an entity, along with a public key that can be used to commu-
nicate securely.
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