![]() |
Aggregate and Redundant Interfaces
Read about and configure aggregate and redundant Ethernet interfaces in this topic.
By default ETH0 and ETH1 act as two individual Ethernet interfaces. When both interfaces are connected to the network and are in backhaul mode, the AP transmits broadcast traffic only through ETH0. The AP transmits broadcast traffic through ETH1 only when ETH0 does not have network connectivity. When both Ethernet interfaces are connected to the network and are in access mode, then the AP transmits broadcast traffic through all the access interfaces: ETH0, ETH1, and all wireless subinterfaces in access mode.
In addition to using ETH0 and ETH1 as individual interfaces, you can combine them into an aggregate interface (agg0) to increase throughput, or combine them into a redundant interface (red0) to increase reliability. The logical red0 and agg0 interfaces support all the settings that you can configure for Ethernet interfaces except those pertaining to physical link characteristics such as link speed. See the sections below for configuration information.
Note
For many AP models, when you use 802.3af PoE on ETH0, ETH 1 is automatically turned off, which prevents you from aggregating ETH0 and ETH1.Aggregate Interface
You can increase throughput onto the wired network by combining ETH0 and ETH1 into a single logically aggregated interface called “agg0”. The aggregate interface effectively doubles the bandwidth that each physical interface has when used individually. In this configuration, both Ethernet ports actively forward traffic, the AP applying an internal scheduling mechanism based on the source MAC address of each packet to send traffic through the aggregate member interfaces. To configure an aggregate interface, enter the following commands:
interface eth0 bind agg0
interface eth1 bind agg0
In addition to configuring the AP, you must also configure the connecting switch to support EtherChannel. For example, the following commands bind two physical Ethernet ports—0/1 and 0/2—to the logical interface port-channel group 1 on a Cisco Catalyst 2900 switch running Cisco IOS 12.2:
Switch#conf t
Switch(config)#interface port-channel 1
Switch(config-if)#switchport mode access
Switch(config-if)#spanning-tree portfast
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#channel-group 1 mode on
Switch(config-if)#spanning-tree portfast
Switch(config-if)#exit
Switch(config)#int fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#channel-group 1 mode on
Switch(config-if)#spanning-tree portfast
Switch(config-if)#exit
Switch(config)#exit
Switch#wr mem
Finally, you must cable the Cisco switch and the AP together: Cisco 0/1 to AP eth0, and Cisco 0/2 to AP eth1.
Redundant Interface
If a single Ethernet link provides sufficient bandwidth and speed, such as a 1000 Mbps link, but you want to ensure link redundancy, you can connect the two Ethernet ports to the same switch—or to two different switches—and configure them to act as a redundant interface called “red0”. In this mode, only one Ethernet interface is actively forwarding traffic at any one time. If eth0 is active and eth1 is passive and eth0 loses its connection, the AP switches over to eth1. To configure a redundant interface, enter these commands:
interface eth0 bind red0 primary
interface eth1 bind red0
The interface that you specify as primary is the one the AP uses when both interfaces have network connectivity. Because the AP uses eth0 as the primary interface by default, it is unnecessary to specify “primary” in the first command above. However, it is included to make the role of eth0 as the primary interface obvious.
Note
No extra configuration is necessary on connecting switches to support a redundant interface.Interface Selection for the Default Route
In cases where there are multiple active interfaces in backhaul mode, the AP uses the following logic to choose which interface to use in its default route:
Copyright © 2020 Extreme Networks. All rights reserved. Published March 2020.