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NetSight® Suite Installation

This document provides instructions for installing and launching NetSight, and for
launching NetSight applications on remote NetSight clients. It also includes information
for those upgrading from an earlier version of NetSight.

IMPORTANT: When performing an upgrade, be sure to backup the NetSight database prior
to performing the upgrade, and save it to a safe location. Use the Server
Information window to perform the backup. From the menu bar, access
Tools > Server Information and select the Database tab. 

General Information
Before you install NetSight, it is recommended that you read the NetSight Release
Notes. The most recent version of these release notes can be found on the NetSight
(NMS) Documentation web page: http://extranet.extremenetworks.com/downloads. After
entering your email address and password, follow this path to the document: Software &
Security > NetSight (NMS) > Documentation > Manuals & Release Notes > NetSight 6.3
> NetSight Suite.

Operating System Requirements

These are the operating system requirements for both the NetSight server and remote
NetSight client machines.

IMPORTANT:Beginning in NetSight version 6.4, only 64-bit operating systems will be
officially supported on the NetSight server and remote NetSight client
machines. Any NetSight server or client machine currently running a 32-bit OS
must be upgraded to a 64-bit OS.

l Windows 32-bit (qualified on the English version of the operating systems)

l Windows Server® 2003 w/ Service Pack 2

l Windows Server® 2008 Enterprise

l Windows Server® 2008 R2

l Windows® 7

l Windows® 8 and 8.1

http://extranet.extremenetworks.com/downloads
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l Windows 64-bit (qualified on the English version of the operating systems)

l Windows Server® 2003 w/ Service Pack 2

l Windows Server® 2008 Enterprise

l Windows Server® 2008 R2

l Windows Server® 2012

l Windows® 7

l Windows® 8 and 8.1

l Linux 32-bit

l Red Hat Enterprise Linux WS and ES v5 and v6

l SuSE Linux versions 10, 11, and 12.3

l Ubuntu 11.10 Desktop version (remote NetSight client only)

l Linux 64-bit

l Red Hat Enterprise Linux WS and ES v5 and v6

l SuSE Linux versions 10, 11, and 12.3

l Ubuntu 11.10, 12.04, and 13.04

l Mac OS X® 64-bit (remote NetSight client only)

l Lion

l Mountain Lion

l Mavericks

l Yosemite

NetSight Server and Client Hardware Requirements

These are the hardware requirements for the NetSight server and NetSight client
machines:

NetSight Server
Minimum Medium Large Enterprise

Operating System 32-bit
Windows

64-bit Desktop

l Windows

l Ubuntu

l Red Hat

l SUSE

64-bit Server

l Ubuntu

l Red
Hat

l SUSE

64-bit Ubuntu Server
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Minimum Medium Large Enterprise

CPU Dual Core Quad Core Dual Quad
Core

Dual Hex Core

Memory 2 GB 8 GB 12 GB 24 GB

Free Disk Space 10 GB 40 GB 100 GB Greater than 100 GB

Storage Capacity NA NA NA Dual 1 TB hard drives with RAID
controller

NetSight Client
l Recommended - Dual-Core 2.4 GHz Processor, 2 GB RAM

l Free Disk Space - 100 MB
(User's home directory requires 50 MB for file storage)

l Java Runtime Environment (JRE):

l version 6

l version 7, update 40 or higher

l version 8

l Supported Web Browsers:

l Internet Explorer versions 10 and 11

l Mozilla Firefox 34 and later

l Google Chrome 33.0 and later

NAC Appliance Version Requirements

For complete information on NAC appliance version requirements, see the Upgrade
Information section of these Installation instructions.

Screen Resolution

For optimum display of NetSight windows and tables, the recommended minimum
screen resolution setting for NetSight clients is 1024 by 768 pixels. For optimum display
of OneView graphs and tables, the recommended minimum screen resolution setting is
1280 by 1024 pixels.

Evaluation License

If you have requested a NetSight evaluation license, you will receive an Entitlement ID.
This Entitlement ID allows you to generate a product evaluation license key. Refer to the
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instructions included with the Entitlement ID to generate the license key. The key will be
used when you install the product.

To install NetSight using an evaluation license, refer to the NetSight Installation
instructions for Windows or Linux contained in this guide.

To upgrade from an evaluation license to a purchased license, see the instruction in the
Upgrading an Evaluation License section.

NetSight Services

During the NetSight installation, you have the option of enabling (configuring to launch
automatically) the NetSight Services. When you enable a NetSight service, it runs in the
background on the NetSight server. The service starts automatically by default, and if
you shut down and restart the machine, the service is restarted automatically.

There may be times when you want to stop or restart the services manually. In addition,
you may want to disable a service so that it does not start automatically when you restart
the server. For information on how to do these procedures, see NetSight Services under
the Suite-Wide Tools User Guide.

The services offered depend on whether your platform is Windows or Linux.

l SNMPTrap Service (Windows and Linux) - Enables SNMP trap messages to be
received and logged when problems or irregularities are detected on network
devices. Only one trap service may be running at a time on a server. If you are also
running a network management system on the server, you may wish to use the
network management trap service.
Windows Users: Windows users should check for and stop any other SNMP trap
service before enabling the NetSight version (see Stop Other Services).

l TFTP (Windows and Linux) - Enables you to upload and download configuration
files, and download firmware to devices. Only one TFTP service may be running at
a time on a machine.

NOTE: The NetSight TFTP Service does not support IPv6.

Windows Users: Windows users should check for and stop any other TFTP service
before enabling the NetSight version (see Stop Other Services).
Linux Users: Typically, the TFTP service that exists in Linux is disabled; however,
if it is enabled, you may wish to disable it and enable the NetSight version of TFTP
which provides additional features for NetSight. If you elect to enable the NetSight
version on the Linux platform, you must first disable the Linux TFTP service and
perform some configuration as follows:
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1. Using a text editor, edit the file /etc/xinetd.d/tftp

2. Set disable = yes
Sample file:
service tftp
{ flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.tftp
disable = yes
}

3. Then run: /etc/rc3.d/S56xinetd restart

l BOOTP (Windows only) - Enables the NetSight server to also be a BOOTP server.
This allows the server to supply devices with firmware images (or other basic
identity information) in the event the device's current firmware image becomes
corrupt. Only one BOOTP service can be running at a time on a machine.

l Syslog (Windows only) - NetSight Console maintains a record of syslog messages
in the Syslog tab of the Event View.

Upgrade Information
NetSight 6.3 supports upgrades from NetSight 6.2, 6.1, 6.0, and 5.1. If you are upgrading
from a NetSight version prior to 5.1, you must perform an intermediate upgrade. For
example, if you are upgrading from NetSight 5.0, you must first upgrade to NetSight 5.1,
and then upgrade to NetSight 6.3.

IMPORTANT: When performing an upgrade, be sure to backup the NetSight database prior
to performing the upgrade, and save it to a safe location. Use the Server
Information window to perform the backup. From the menu bar, access
Tools > Server Information and select the Database tab.

During the installation you will have the option to backup additional user files by
selecting a checkbox on the Previous Installation Detected screen. This option lets you
backup user files such as Inventory Manager archive files that are not automatically
backed up during the install because the backup could take several minutes.
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Important Upgrade Considerations
l If your network is using Purview appliances, you must first perform the NetSight
upgrade to version 6.3 and then upgrade the Purview appliances.

l If you are running Data Center Manager (DCM), a Mobile Device Management
(MDM) integration, or other OneFabric Connect or Fusion integration with
NetSight:

l The OneFabric connect module is disabled on upgrade, and requires a new
version in order to operate with NetSight 6.3. You must install an updated
module that supports NetSight 6.3. Contact your account team for information
on obtaining this update.

l You must install a NetSight Advanced (NMS-ADV) license with 6.3 when you
upgrade. Contact your account team for information on obtaining this license.

l If you are accessing Web Services directly or through OneFabric Connect you
need to install a NetSight Advanced (NMS-ADV) license. Contact your account
team for information on obtaining this license.

l When upgrading a 64-bit NetSight server or when upgrading from a 32-bit to a 64-
bit NetSight server, if the -Xmx setting is set below 1536m, it will be increased to
1536m.

l Older NetSight licensing keys (starting with INCREMENT) are no longer supported
as of NetSight 5.0 and later. If you have one of these keys, please contact Extreme
Networks Support for license upgrade information.

l The 4.xx version of the NAC Request Tool is not compatible with the 6.3 NetSight
server. If you are using the NAC Request Tool you need to upgrade the version of
NAC Request Tool to version 6.3.

Upgrading an Evaluation License

To upgrade from an evaluation license to a purchased copy, contact your Extreme
Networks Representative to purchase the software and receive an Entitlement ID. You
do not need to reinstall the software to perform the conversion.

Prior to installing NetSight, you should redeem your Entitlement ID for a product license
key. Refer to the instructions included with the Entitlement that was sent to you.

If your Evaluation copy has not expired:

1. From the NetSight Console menu bar, select Tools  > Server Information.

2. In the Server Information window, click the License tab.
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3. Select NetSight Evaluation from the table and click Add License.

4. Read and accept the License and click OK.

5. Enter the license text that you received when you generated the product license
key.

6. Click Update. The license file will be updated with the new license text.

If you have let your Evaluation Copy expire, when you launch NetSight Console a
window opens where you can enter the license text.

Upgrading to NetSight NACManager 6.3

Important Captive Portal Changes

In NetSight 6.0, the NAC captive portal was enhanced to provide a more modern look
and feel. If you have used the custom style sheet, you will need to review pages, as
there will most likely be changes required to allow the custom styles to display correctly
with the new page layout. After upgrading, NAC administrators should log on to the
screen preview page (https://<NAC appliance IP>/screen_preview) of the NAC captive
portal to verify that the portal still looks acceptable for display to end users. If your portal
configuration is limited to setting colors and images, there should be no problem with the
new portal look and feel, although you may want to set some of the new color options.

General Upgrade Information

When upgrading to NetSight NAC Manager 6.3, you are not required to upgrade your
NAC appliance version to 6.3. However, both NetSight NAC Manager and the
NAC appliance must be at version 6.3 in order to take advantage of the new NAC 6.3
features. NetSight NAC Manager 6.3 supports managing NAC appliance versions 6.2,
6.1, 6.0, and 5.1.

NOTE:NAC 6.3 is not supported on the 2S Series and 7S Series NAC Controllers. You cannot
upgrade NAC Controllers to version 6.3, but you can use NAC Manager 6.3 to manage
controllers running version 4.3.xx.

You can download the latest NAC appliance version at the Network Management Suite
(NMS) Download web page
http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx. Be sure to read
through the Upgrading to NAC 6.3 document (available on the NetSight Documentation
web page > Manuals & Release Notes > NetSight 6.3 > Network Access Control [NAC])
for important information.

http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx
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In addition, if your NAC solution utilizes a Nessus assessment server, you should also
upgrade your assessment agent adapter to version 6.3 if you upgrade to NAC 6.3.

Agent Version for NACAgent-Based Assessment

If you are using onboard agent-based assessment, be aware that the agent version is
upgraded during the NAC appliance software upgrade. If you would like end-systems to
update their agent to the new version, you must configure your assessment test set to
test for the new agent version. Refer to the Upgrade Information section in the NetSight
Release Notes for the agent version included in the NAC appliance software.

Upgrading NAC Request Tool

The 4.xx version of the NAC Request Tool is not compatible with the 6.3 NetSight
server. If you are using the NAC Request Tool, you will need to upgrade your version of
the NAC Request Tool to version 6.3.

Upgrading to NetSight OneView 6.3
l Beginning in 5.1, all OneView maps intended to utilize the advanced map features
of wireless coverage and client location triangulation should be created with a
Base Map type of Floor Plan. OneView maps that were created in NetSight version
4.4 or 5.0 that include both APs and walls are automatically converted to the Floor
Plan Base Map type when the upgrade is performed. This allows Floor Plan map
features to be available for those maps.

l Beginning in 5.1, managed wireless controllers (8.32 or later) are automatically
synchronized to match OneView map floor plan data. If the floor plan data defined
in OneView maps is not consistent with data on the controller, the controller will be
updated accordingly.

Upgrading to NetSight Policy Manager 6.3
l Policy Manager 6.3 only supports IdentiFi Wireless Controller version 8.01.03 and
higher. If you upgrade to NetSight 6.3 prior to upgrading your controllers, then
Policy Manager will not allow you to open a domain where the controllers already
exist or add them to a domain. You will see a dialog indicating that your controllers
do not meet minimum version requirements and that they must be upgraded before
they can be in a domain.

l Policy Manager 5.0 changed how it handles rule containment VLANs and Role
VLAN Egress VLANs. This may cause Verify to fail following an upgrade to 6.3. If
this happens, enforce the domain configuration to update the static VLAN table.
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l Following an upgrade to Wireless Controller version 8.31 and higher, a Policy
Manager enforce will fail if it includes changes to the default access control or any
rules that are set to contain. To allow Policy Manager to modify the default access
control or set rules to contain, you must disable the "Allow" action in policy rules
contains to the VLAN assigned by the role checkbox accessed from the Wireless
Controller's web interface on the Roles > Policy Rules tab. This will allow the
enforce operation to succeed.

Upgrading to NetSight Wireless Manager 6.3

Following a Wireless Manager upgrade, you should clear the Java Cache before starting
the NetSight client.

Pre-Installation Checklist
Please review the following checklist prior to performing a NetSight software installation
or upgrade.

l Backup database. If performing an upgrade, be sure to backup the NetSight
database prior to performing the upgrade. Use the Server Information window to
perform the backup (Tools > Server Information > Database tab).

l Disable antivirus software. Disable any antivirus software that is running on the
NetSight server prior to beginning the installation. Be sure to re-enable the
antivirus software following the install. If you have installed or upgraded NetSight
on a Windows platform system, follow the instructions in Configure Antivirus
Software before you re-enable the antivirus software.

l Generate your NetSight product license key. When you purchased NetSight, you
received a Licensed Product Entitlement ID for the license that you purchased.
This Entitlement ID allows you to generate a product license key. Refer to the
instructions included with the Entitlement ID to generate the license key. The key
will be used when you install the product.

NetSight Installation - Windows
Use the following instructions to install NetSight on a Windows platform system where
you have administrative rights.
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Stop Other Services

If you will be using the NetSight version of SNMPtrap and/or TFTP service, you cannot
be running another version of that service on your system. If you are running one of
these non-NetSight services on your system, you must shut it down before installing
NetSight, as follows:

1. Open the Services window on your system (Control Panel > Administrative Tools
> Services).

2. Scroll down to find the service in the list.

3. Right click on the service and select Stop from the popup menu.

4. Right click on the service again and select Properties from the popup menu.

5. In the Properties window, set the Startup Type for the service to Manual.

6. Repeat for any other services, if necessary.

7. Close the Services windows and Control Panel.

8. Open the Task Manager and check to be sure that the process is not running.

9. Close the Task Manager.

Install and Launch NetSight

1. Download the NetSight software from the Network Management Suite (NMS)
Download web page
http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx. If you are
installing from a CD, insert the CD into your system's CD drive.

2. Navigate to the NetSight_Suite.exe file and double-click it.

3. The NetSight Installer leads you through a series of windows that asks for all the
information required in order to install NetSight. You will need the following
information for the Installer Program:

l License Text – Enter the license text for the NetSight license that you
purchased. You received the license text when you generated your NetSight
product license key. If you choose not to enter the license text during the
installation, you will be asked to enter it the first time you launch an individual
NetSight application.

l Service Configuration – Enable and start the NetSight Services. (For more
information on the services offered on the Windows platform, see NetSight
Services.)

http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx
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l Destination Directory – This is the path to your NetSight Installation
Directory. In the Destination Directory window, click Choose to navigate to
the directory, or type the path in manually.

When you have finished with this series of windows, NetSight will be installed
according to your specifications.

4. When the installation is complete, the database and server are started
automatically. You must wait until the NetSight server has started all its various
server components before you can connect to the server and launch the NetSight
applications. On the installation screen, you will see an hourglass icon while the
server starts its components. When the server is ready for connections, the
installation screen will display a green check.

5. On the installation screen, click on the Show Launch Page link to open the
NetSight Launch Page. (You can also use the desktop shortcut to open the
NetSight Launch Page.)

6. The NetSight Launch Page opens. At the top of the web page you will see tabs for
the following functions:

l Home – Launch your NetSight applications by clicking on the names or icons
of any of the listed applications.

l Getting Started – In order to launch your NetSight applications, you must
have Java Runtime Environment (JRE) 6 (also referred to as 1.6) or higher
installed on your system. This page tells you if you have met this requirement
and provides instructions for installing the Java Runtime Environment (JRE),
if required.

l Administration – Provides access to specific server administration functions
such as client and server diagnostics, server utilities, the server log, and
NAC server diagnostics. To access the server diagnostics and utilities, you
will need to login with your username and password. (If the NetSight server is
a Windows platform system, in the Username field you must enter a domain
name and a username using the following format: <domain
name>\<username>).

7. Verify that you have met the JRE requirement by accessing the Getting Started
tab, and install the JRE according to the instructions on the Install Java tab, if
required.

8. Click on the Home tab and launch the desired NetSight application by clicking the
name or icon.

9. A login window appears. NetSight requires a user login as a way to restrict access
to the NetSight server, perform audit trails, and assign user capabilities according
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to the Authorization Group the user belongs. It is important to note that when you
log in, you are authenticating to the operating system of the NetSight server system
you are connecting to.

a. Select the NetSight server you wish to connect to.

b. Enter your domain name\username.

c. Enter your password and click OK.

NOTE: The initial user to log in must be the user that performed the NetSight
installation. This is because the NetSight server has a single pre-defined
user that is the user who performed the NetSight installation. On
Windows, this is the domain\username of the person logged in to the
Windows system when the installation was performed. Once the initial
user has logged in, additional users can be defined.

10. The application main window opens.

Configure Antivirus Software

Using antivirus software such as McAfee® on NetSight servers installed on a Windows
platform system requires special consideration. If the virus scanning software is used on
directories containing MySQL data and temporary tables, problems can result in both the
performance of MySQL and the virus-scanning software.

After installing or upgrading NetSight, it is recommended that you add the MySQL data
and tmp directories (<install directory>\NetSight\mysql\data\tmp) to the virus scanning
exclusion list. Refer to your antivirus software documentation for instructions.

NetSight Installation - Linux
Use the following instructions to install NetSight on a Linux platform system. Please read
through the following items before beginning the installation.

l The user performing the installation must be the root user. During the installation
process you can specify another user that will be able to launch and run the server,
if desired.

l If you are installing NetSight on a Linux system that doesn't support a GUI, see
Performing a Silent Install for information on installing NetSight without using its
GUI Installation wizard.

l Prior to beginning installation, verify that your /etc/hosts file has the local host
name specified. It should have an entry that looks like:

127.0.0.1  localhost
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l You may encounter a Java exception during the install when becoming the root
user with the su - command. Be sure that your system's root environment has a
proper DISPLAY variable setting. The Installation program will report a Java
exception (InvocationTargetException) if the DISPLAY variable is undefined. If this
occurs:

Before using the su - command, set the system display variable to accept a remote
display with the command:
/usr/openwin/bin/xhost +test 111 lll

After using the su - command, set the display variable in the environment where
the su - was done.

For C shell: setenv DISPLAY :0.0

For Korn shell:export DISPLAY=:0.0

Preparing for CD Installation

Perform the following steps if you will be installing the NetSight software from a CD. The
following procedures assume that the CD drive from which you are installing is
physically attached to the system where NetSight is being installed.

1. Insert the NetSight CD into the CD drive.

2. Use an xterm where you are logged in as root. (Be sure that your system's root
environment has a proper DISPLAY variable setting. For more information see the
above note.)

3. Using the cd command, cd to the /mnt/cdrom directory.

4. Using the ls command, check to see if the CD drive is mounted. If no files are
listed, issue the following commands:
mount /mnt/cdrom

Install and Launch NetSight

1. Download the NetSight software from the Network Management Suite (NMS)
Download web page
http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx.

2. Use an xterm where you are logged in as root. (Be sure that your system's root
environment has a proper DISPLAY variable setting. For more information see the
above note.)

http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx
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3. Start the Installer.

l If you have downloaded the software, cd to the directory where you
downloaded the installer and start the Installer with the following command:
./NetSight_Suite_<version>_install.bin

l If you are installing from a CD, start the installer with the command:
/mnt/cdrom/netsight.bin

4. The NetSight Installer leads you through a series of windows that asks for all the
information required in order to install NetSight. You will need the following
information for the Installer Program:

l License Text – Enter the license text for the NetSight license that you
purchased. You received the license text when you generated your NetSight
product license key. If you choose not to enter the license text during the
installation, you will be asked to enter it the first time you launch an individual
NetSight application.

l Service Configuration – There are two Service Configuration screens.

o In the first screen, you can specify a user other than root to own the
NetSight server and its supporting files, if desired. This user becomes
the admin user for the server. Select Use existing user if you already
have a user defined on the machine and enter the user name. Select
Create local netsight user if you want to create a new "netsight" user
(netsight is the user name) and enter the password for this new user.
Leave the Use existing user option set to root if you do not want to
specify another user.

o In the second screen, enable and start the NetSight Services. (For more
information on the services offered on the Linux platform, see NetSight
Services.)

l Destination Directory – This is the path to your NetSight Installation
Directory. In the Destination Directory window, click Choose to navigate to
the directory, or type the path in manually.

When you have finished with this series of windows, NetSight will be installed
according to your specifications.

5. When the installation is complete, the database and server are started
automatically. You must wait until the NetSight server has started all its various
server components before you can connect to the server and launch the NetSight
applications. On the installation screen, you will see an hourglass icon while the
server starts its components. When the server is ready for connections, the
installation screen will display a green check.
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6. On the installation screen, click on the Show Launch Page link to open the
NetSight Launch Page.

7. The NetSight Launch Page opens. At the top of the web page you will see tabs for
the following functions:

l Home – Launch your NetSight applications by clicking on the names or icons
of any of the listed applications.

l Getting Started – In order to launch your NetSight applications, you must
have Java Runtime Environment (JRE) 6 (also referred to as 1.6) or higher
installed on your system. This page tells you if you have met this requirement
and provides instructions for installing the Java Runtime Environment (JRE),
if required.

l Administration – Provides access to specific server administration functions
such as client and server diagnostics, and server utilities.

8. Verify that you have met the JRE requirement by accessing the Getting Started
tab, and install the JRE according to the instructions on the Install Java tab, if
required.

9. Click on the Home tab and launch the desired NetSight application by clicking the
name or icon.

10. A login window appears. NetSight requires a user login as a way to restrict access
to the NetSight server, perform audit trails, and assign user capabilities according
to the Authorization Group the user belongs.

a. Select the NetSight server you wish to connect to.

b. Enter your username.

c. Enter your password and click OK.

NOTE: The initial user to log in must be the user that performed the NetSight
installation, which will either be root or the user defined in the Service
Configuration screen during the installation. This is because the NetSight
server has a single pre-defined user. Once the initial user has logged in,
additional users can be defined.

11. The application main window opens.

Performing a Silent Install

If you are installing NetSight on a Linux system that doesn't support a GUI, you must add
the cli flag (--cli) to the install command, in order to allow the NetSight installer to prompt
for any required input.

Start the installation with the following command:
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./NetSight_Suite_<version>_install.bin --cli

If you are installing as a user other than root, you must use the --user command to
specify the different user. The user must already be configured on the machine before
you install. For example:

./NetSight_Suite_<version>_install.bin --cli --user <username>

To perform the install and create a new local "netsight" user (where netsight is the user
name), use the --password command to set the password for the new "netsight" user. For
example:

./NetSight_Suite_<version>_install.bin --cli --password
<password>

Restoring a Database from a Windows Server to a Linux Server

This section describes several NetSight configuration changes that are required if you
are moving your NetSight installation from a Windows platform system to a Linux
platform system. The steps are performed after restoring your database to the new
server. (For information on restoring a database, see the Server Information help in the
NetSight Suite-Wide Tools User Guide.)

When restoring a saved database to a new NetSight server installation, any memory or
database configuration changes on the original server will require a manual change on
the new server in order to replicate the configuration of the original NetSight server.

l Changes to the default -Xmx memory settings in the
<install directory>\NetSight\services\nsserver.cfg file will need to be duplicated on
the new server when the database is restored. To change the memory setting to
match the previous server, stop the NetSight server and edit the nsserver.cfg file.

l The mySQL my.ini file will also need to be manually updated to match any
changes made on the original server. For instructions on modifying the my.ini file,
see the Change the MySQL my.ini File section in the NAC Deployment Guide.

In addition, there are two changes that must be made in NetSight Console and one
change in NetSight Inventory Manager.

Console

Use the following instructions to change the location of syslog and trap information to the
new location on the Linux system.
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Syslog

Change the Syslog Log Manager to point to the new location on the Linux system. This
will allow the display of syslog information in the Syslog Event View tab.

1. From the Console menu bar, select Tools > Alarm/Event > Event View Manager.

2. Click on the Syslog entry under Available Log Managers, and click the Edit button.
The Log Manager Parameters window opens.

3. Change the path in the Log Directory field to /var/log/messages.

4. Change the Pattern to Red Hat LINUX Syslog Pattern.

5. Click OK.

Traps

Change the Traps Log Manager to point to the new location on the Linux system. This
will allow the display of trap information in the Traps Event View tab.

1. From the Console menu bar, select Tools > Alarm/Event > Event View Manager.

2. Click on the Traps entry under Available Log Managers, and click the Edit button.
The Log Manager Parameters window opens.

3. Change the path in the Log Directory field to %logdir%/traps.

4. Click OK.

Inventory Manager

If you are using Inventory Manager, you will need to change the Data Storage Directory
path to point to the new location on the Linux system. The Data Storage directory is
where all Inventory Manager data is stored, including capacity planning reports,
configuration templates, archived configurations, and property files.

1. From the Inventory Manager menu bar, select Tools > Options. Expand the
Inventory Manager options folder and select Data Storage Directory Path.

2. Change the path to the correct new location. On a default Linux install, the path
would be: <user's home directory>/NetSight/appdata/InventoryMgr

3. Click OK.

Systems with Multiple NICs
This section provides instructions for configuring NetSight servers with multiple NICs
(Network Interface Cards). During the startup process, the NetSight server automatically
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binds to the first available NIC, which may not be the correct interface for the server to
use. In addition, changes on the network can cause the server to bind to an incorrect
interface, should the server restart during a change.

If the system has multiple NICs installed, it is a good practice to either:

l configure the server to bind to a preferred IP address, if only one interface will be
used for connections or

l configure multiple network interfaces, if more than one interface will be used for
connections.

This ensures that local and remote clients, as well as NAC appliances, will be able to
connect to the NetSight server.

Binding to One Interface

If the NetSight server has multiple NICs installed but only one interface will be used to
access NetSight, use the following instructions to configure the preferred interface for the
NetSight server.

On Windows systems, you will need to set the binding order of the network interface
cards and configure the NetSight server to bind to the correct address. On Linux
systems, you will need to configure the NetSight server to bind to the correct address.

Windows Systems

Set the binding order of multiple network interface cards and configure the NetSight
server to bind to the correct IP address. These steps may vary depending on your
operating system.

1. Open the Network Connections window:

a. Click Start > Run.

b. Enter ncpa.cpl and click OK.

The Network Connections window opens. You can view the available connections
in the LAN and High-Speed Internet section of the window.

2. From the Network Connections window menu bar, select Advanced > Advanced
Settings. The Advanced Settings window opens.

3. The Adapters and Bindings tab lists the connections in the order in which the
connections are accessed by network services. The NIC that the NetSight server
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should connect to must be first in the list. You can use the arrow buttons to change
the binding order.

4. Open the .netsight file. Edit the line JBOSS_HOSTNAME=<server IP> to
add the correct NIC IP address. (On Windows Server 2008 and Windows 7, the file
is located at C:\ProgramData\Extreme Networks. On Windows Server 2003, the file
is located at C:\Documents and Settings\All Users\Application Data\Extreme
Networks.)

5. Restart the NetSight server.

Linux Systems

Configure the NetSight server to bind to the correct IP address.

1. Open the /var/Extreme_Networks/.netsight file. Edit the line JBOSS_
HOSTNAME=<server IP> to add the correct NIC IP address.

2. Restart the NetSight server.

Configuring Multiple Interfaces

If the NetSight server has multiple NICs installed and you need to access NetSight on
multiple interfaces, use the following instructions to configure multiple network interfaces
for the NetSight server.

1. On the NetSight server, add the following text to the
<install directory>/NetSight/appdata/NSJBoss.properties file. In the second to last
line, specify the hostname of the NetSight server.
# In order to connect to a NetSight server behind a NAT fi
rewall or a
# NetSight server with multiple interfaces you must define
 these two
# variables on the NetSight server. The java.rmi.server.ho
stname
# should be the hostname (not the IP)
 if multiple IPs are being used
# so that each client can resolve the hostname to the corr
ect IP that
# they want to use as the IP to connect to.
java.rmi.server.hostname=<hostname of NetSight server>
java.rmi.server.useLocalHostname=true
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2. Save the file.

3. Add the NetSight server hostname to your DNS server.

NOTE:Multiple interface support has been added to provide support for clients accessing the
NetSight server in a configuration where the primary NetSight interface may not be
accessible/routable to remote clients, such as in an MSSP environment. This support
provides for both visibility and management of network devices for clients accessing
NetSight from an additional interface, however some functionality may be limited. For
example, TFTP configuration and firmware management of devices located off a
second NetSight interface may not function properly.

Remote Client Launch
The NetSight Suite products are web applications that will install and run when
accessed from the NetSight Launch Page. Remote NetSight clients can use the
following steps to access the NetSight Launch Page and run NetSight applications from
the remote client machine.

1. Open a browser window and enter the NetSight Launch page URL in the following
format:

http://<servername>:8080/

where <servername> is the NetSight server's IP address or hostname, and 8080 is
the required port number. For example,

http://10.20.30.40:8080/

2. The NetSight Launch Page opens. At the top of the web page you will see tabs for
the following functions:

l Home – Launch your NetSight applications by clicking on the names or icons
of any of the listed applications.

l Getting Started – In order to launch your NetSight applications, you must
have Java Runtime Environment (JRE) 6 (also referred to as 1.6) or higher
installed on your system. This page tells you if you have met this requirement
and provides instructions for installing the Java Runtime Environment (JRE),
if required.

l Administration – Provides access to specific server administration functions
such as client and server diagnostics, and server utilities.
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3. Verify that you have met the JRE requirement by accessing the Getting Started
tab, and install the JRE according to the instructions on the Install Java tab, if
required.

4. Click on the Home tab and launch the desired NetSight application by clicking the
name or icon.

5. A login window appears. NetSight requires a user login as a way to restrict access
to the NetSight server, perform audit trails, and assign user capabilities according
to the Authorization Group the user belongs. It is important to note that when you
log in, you are authenticating to the operating system of the NetSight server system
you are connecting to.

a. Select the NetSight server you wish to connect to.

b. Enter your username if you are authenticating to a Linux platform server or
enter your domain name\username if you are authenticating to a Windows
platform server.

c. Enter your password and click OK.

6. The application main window opens.

NOTE: User preferences and application data (such as FlexViews and MIBs) for remote
clients are stored in the following local directory on the client machine:
C:\Documents and Settings\<username>\Application Data\NetSight.

Uninstalling NetSight
Use the procedures below to uninstall your NetSight Suite of products. The uninstall will
remove all NetSight data from the database. Be sure to backup your database prior to
uninstalling.

Uninstalling on Windows

From the Start menu, select Programs > Extreme Networks > NetSight > Uninstall.

Uninstalling on Linux

Navigate to the <install directory>/uninstaller directory and start the Uninstaller by
issuing the command:
./uninstall.sh
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Extreme Networks Support
If you require assistance, contact Extreme Networks Global Technical Assistance Center
using one of the following methods.

Web www.extremenetworks.com/support/

Phone 1-800-872-8440 (toll-free in U.S. and Canada) or 1-603-952-5000
For the Extreme Networks Support phone number in your country:
www.extremenetworks.com/support/contact/

Email support@extremenetworks.com

07/2015
6.3 Revision -00
Contents Subject to Change Without Notice

http://www.extremenetworks.com/support/
http://www.extremenetworks.com/support/contact/
mailto:support@extremenetworks.com

	NetSight® Suite Installation
	General Information
	Operating System Requirements
	NetSight Server and Client Hardware Requirements
	NetSight Server
	NetSight Client

	NAC Appliance Version Requirements
	Screen Resolution
	Evaluation License
	NetSight Services

	Upgrade Information
	Important Upgrade Considerations
	Upgrading an Evaluation License
	Upgrading to NetSight NAC Manager 6.3
	Important Captive Portal Changes
	General Upgrade Information
	Agent Version for NAC Agent-Based Assessment
	Upgrading NAC Request Tool

	Upgrading to NetSight OneView 6.3
	Upgrading to NetSight Policy Manager 6.3
	Upgrading to NetSight Wireless Manager 6.3

	Pre-Installation Checklist
	NetSight Installation - Windows
	Stop Other Services
	Install and Launch NetSight
	Configure Antivirus Software

	NetSight Installation - Linux
	Preparing for CD Installation
	Install and Launch NetSight
	Performing a Silent Install
	Restoring a Database from a Windows Server to a Linux Server
	Console
	Syslog
	Traps

	Inventory Manager


	Systems with Multiple NICs
	Binding to One Interface
	Windows Systems
	Linux Systems

	Configuring Multiple Interfaces

	Remote Client Launch
	Uninstalling NetSight
	Uninstalling on Windows
	Uninstalling on Linux

	Extreme Networks Support


