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Extreme Management Center® Suite
Installation

This document provides instructions for installing and launching Extreme
Management Center, and for launching ExtremeManagement Center
applications on remote ExtremeManagement Center clients. It also includes
information for those upgrading from an earlier version of ExtremeManagement
Center.

IMPORTANT: Backup the ExtremeManagement Center database prior to performing the upgrade
and save it to a safe location. Use the Administration > Backup/Restore tab.

General Information
Before you install ExtremeManagement Center, read the Extreme Management
Center Release Notes. The most recent version of these release notes can be
found at the ExtremeManagement Center Documentation site. Click Release
Notes at the top of the page.

NOTE: The terms engine, gateway, and appliance are used interchangeably throughout Extreme
Management Center documentation.

Operating System Requirements
These are the operating system requirements for both the ExtremeManagement
Center server and remote ExtremeManagement Center client machines.

IMPORTANT:Beginning in ExtremeManagement Center version 7.0, only 64-bit operating systems are
officially supported on the ExtremeManagement Center server and remote Extreme
Management Center client machines. Upgrade any ExtremeManagement Center server
or client machine currently running a 32-bit OS to a 64-bit OS.

https://emc.extremenetworks.com/
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Operating System

Windows (qualified on the English version of the
operating systems)

Windows Server® 2012 and 2012
R2
Windows Server® 2016
Windows® 7

Linux Red Hat Enterprise Linux WS and
ES v6 and v7
Ubuntu 14

Mac OS X® (remote Extreme Management Center
client only)

El Capitan
Sierra

VMware® (Extreme Management Center Virtual
Engine

VMware ESXi™ 6.0 server
VMware ESXi™ 6.5 server
VMware ESXi™ 6.7 server
vSphere (client only)™

Hyper-V (Extreme Management Center Virtual
Engine)

Hyper-V Server 2012 R2
Hyper-V Server 2016

Extreme Management Center Server and Client Hardware
Requirements
These are the hardware requirements for the ExtremeManagement Center
server and ExtremeManagement Center client machines:

Extreme Management Center Server
Small Medium Enterprise LargeEnterprise

Total CPUs 1 2 2 2

Total CPU Cores 8 16 16 16

Memory 16 GB 32GB 64GB 64GB

Disk Size 240GB 480GB 960GB 1.92TB

IOPS 200 200 10,000 10,000

Extreme Management Center Client
Requirements

CPU Speed 3.0GHz Dual CoreProcessor

Memory 4 GB

Disk Size 300MB (User's homedirectory requires 50MB for file storage)

JavaRuntimeEnvironment (JRE) (Oracle Java only) Version 8



General Information

6 of 25

Requirements

Browser* (Enable JavaScript and Cookies) Microsoft Edge (version 41.16.199.10000.0 in compatibilitymode)
Mozilla Firefox (version 34 or later*)
GoogleChrome (version 33.0or later)

ExtremeControl Engine Version Requirements
For complete information on ExtremeControl engine version requirements, see
the Upgrade Information section of these Installation instructions.

Screen Resolution
For optimum display of ExtremeManagement Center windows and tables, the
recommended minimum screen resolution setting for ExtremeManagement
Center clients is 1024 by 768 pixels. For optimum display of graphs and tables,
the recommended minimum screen resolution setting is 1280 by 1024 pixels.

Evaluation License
If you request an ExtremeManagement Center evaluation license, you receive an
Entitlement ID. This Entitlement ID allows you to generate a product evaluation
license key. Refer to the instructions included with the Entitlement ID to
generate the license key. Use the key when you install the product.

To install ExtremeManagement Center using an evaluation license, refer to the
ExtremeManagement Center Installation instructions forWindows or Linux
contained in this guide.

To upgrade from an evaluation license to a purchased license, see the instruction
in the Upgrading an Evaluation License section.

Extreme Management Center Services
During the ExtremeManagement Center installation, you can enable the
ExtremeManagement Center Services, allowing it to run in the background on
the ExtremeManagement Center server. The service starts automatically by
default, and if you shut down and restart the machine, the service is restarted
automatically.

You can also restart the services manually or disable a service so it does not start
automatically when you restart the server.

The services offered depend on whether your platform is Windows or Linux.
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l SNMPTrap Service (Windows and Linux) - Enables SNMP trap messages to be
received and logged when problems or irregularities are detected on network
devices. Only one trap service may be running at a time on a server. If you are also
running a network management system on the server, you may wish to use the
network management trap service.
Windows Users: Windows users should check for and stop any other SNMP trap
service before enabling the Extreme Management Center version (see Stop Other
Services).

l TFTP (Windows and Linux) - Enables you to upload and download configuration
files, and download firmware to devices. Only one TFTP service may be running at a
time on a machine.

NOTE: The ExtremeManagement Center TFTP Service does not support IPv6.

Windows Users: Windows users should check for and stop any other TFTP service
before enabling the Extreme Management Center version (see Stop Other Services).
Linux Users: Typically, the TFTP service that exists in Linux is disabled; however, if it
is enabled, you may wish to disable it and enable the Extreme Management Center
version of TFTP which provides additional features for Extreme Management Center.
If you elect to enable the Extreme Management Center version on the Linux
platform, you must first disable the Linux TFTP service and perform some
configuration as follows:

1. Using a text editor, edit the file /etc/xinetd.d/tftp

2. Set disable = yes
Sample file:
service tftp
{ flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.tftp
disable = yes
}

3. Then run: /etc/rc3.d/S56xinetd restart

l BOOTP (Windows only) - Enables the Extreme Management Center server to also be
a BOOTP server. This allows the server to supply devices with firmware images (or
other basic identity information) in the event the device's current firmware image
becomes corrupt. Only one BOOTP service can be running at a time on a machine.
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l Syslog (Windows only) - Extreme Management Center Console maintains a record
of syslog messages in the Syslog tab of the Event View.

Upgrade Information
ExtremeManagement Center 8.4 supports upgrades from Extreme
Management Center version 8.2.x (except version 8.2.2) or 8.3.x. If you are
upgrading from version 8.1 or earlier of NetSight/ExtremeManagement Center,
you must perform an intermediate upgrade. For example, if you are upgrading
from NetSight 7.1, you must first upgrade to the latest ExtremeManagement
Center 8.1 release, then upgrade to the latest ExtremeManagement Center 8.2 or
8.3 release, then to 8.4.

IMPORTANT: When performing an upgrade, be sure to backup the ExtremeManagement Center
database prior to performing the upgrade, and save it to a safe location. Use the
Administration > Backup/Restore tab to perform the backup. Backup functionality is
enhanced in version 8.0 of ExtremeManagement Center andmay function differently
depending on themethod used by your version of ExtremeManagement Center.

When upgrading the ExtremeManagement Center server, ExtremeAnalytics engine,
or ExtremeControl engine to version 8.4, ensure the DNS server IP address is correctly
configured.

During the installation (if upgrading using the user interface installer), you have
the option to backup additional user files by selecting a checkbox on the
Previous Installation Detected screen. This option lets you backup user files such
as Inventory Manager archive files not automatically backed up during the install
because the backup could take several minutes.

Important Upgrade Considerations
l If your network is using ExtremeAnalytics or ExtremeControl engines, Fabric
Manager, or another add-on feature, you must first perform the Extreme
Management Center upgrade to version 8.4 and then add the feature.

l If you are running Data Center Manager (DCM), a Mobile Device Management (MDM)
integration, or other OneFabric Connect or Fusion integration with Extreme
Management Center:

l The OneFabric connect module is disabled on upgrade, and requires a new
version in order to operate with Extreme Management Center 8.4. You must
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install an updated module that supports Extreme Management Center 8.4.
Contact your account team for information on obtaining this update.

l You must install an Extreme Management Center Advanced (NMS-ADV)
license with 8.4 when you upgrade. Contact your account team for
information on obtaining this license.

l If you are accessing Web Services directly or through OneFabric Connect you need
to install an Extreme Management Center Advanced (NMS-ADV) license. Contact
your account team for information on obtaining this license.

l When upgrading a 64-bit Extreme Management Center server or when upgrading
from a 32-bit to a 64-bit Extreme Management Center server, if the -Xmx setting is
set below 1536m, it is increased to 1536m.

l Upgrading to ExtremeManagement Center version 8.4 requires you to
renew your NMS license if generated prior to November 30, 2018. Licenses
generated prior to November 30, 2018 expire 90 days after upgrading to
ExtremeManagement Center version 8.4.

l The 4.xx version of the NAC Request Tool is not compatible with the 8.4 Extreme
Management Center server. If you are using the NAC Request Tool you need to
upgrade the version of NAC Request Tool to version 8.4.

Upgrading an Evaluation License
To upgrade from an evaluation license to a purchased copy, contact your
Extreme Networks Representative to purchase the software and receive an
Entitlement ID. You do not need to reinstall the software to perform the
conversion.

Prior to installing ExtremeManagement Center, you should redeem your
Entitlement ID for a product license key. Refer to the instructions included with
the Entitlement sent to you.

If your Evaluation copy has not expired:

1. Open the Administration > Diagnostics > Server > Server Licenses.

2. In the tab, click Add.

3. Enter the license text that you received when you generated the product license key.

4. Click OK. The license file is updated with the new license text.

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-upgrade-a-NetSight-license-for-use-with-version-7
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If you have let your Evaluation Copy expire, when you launch Extreme
Management Center a window opens where you can enter the license text.

Upgrading to Extreme Management Center NAC Manager
8.4

General Upgrade Information

When upgrading to ExtremeManagement Center NAC Manager 8.4, you are not
required to upgrade your ExtremeControl engine version to 8.4. However, both
NAC Manager and the ExtremeControl engine must be at version 8.4 in order to
take advantage of the new ExtremeControl 8.4 features. ExtremeManagement
Center NAC Manager 8.4 supports managing ExtremeControl engine versions
8.2, 8.1, and 8.0.

NOTE:ExtremeControl 8.4 is not supported on the 2S Series and 7S Series NAC Controllers. You
cannot upgrade ExtremeControl Controllers to version 8.4, but you can use NACManager 8.4
to manage controllers running version 4.3.xx.

You can download the latest ExtremeControl engine version at the Extreme
Portal. Be sure to read through the Upgrading to ExtremeControl 8.4 document
(available on the ExtremeManagement Center Documentation page for
important information.

In addition, if your ExtremeControl solution utilizes a Nessus assessment server,
you should also upgrade your assessment agent adapter to version 8.4 if you
upgrade to ExtremeControl 8.4.

Agent Version for NAC Agent-Based Assessment

If you are using onboard agent-based assessment, be aware that the agent
version is upgraded during the ExtremeControl engine software upgrade. If you
would like end-systems to update their agent to the new version, you must
configure your assessment test set to test for the new agent version. Refer to the
Upgrade Information section in the Extreme Management Center Release Notes
for the agent version included in the ExtremeControl engine software.

https://extremeportal.force.com/
https://extremeportal.force.com/
https://www.extremenetworks.com/support/documentation/
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Upgrading to Policy Manager 8.4
l Policy Manager 8.4 only supports ExtremeWireless Controller version 8.01.03 and
higher. If you upgrade to Extreme Management Center 8.4 prior to upgrading your
controllers, then Policy Manager does not allow you to open a domain where the
controllers already exist or add them to a domain. A dialog is displayed indicating
your controllers do not meet minimum version requirements and that they must be
upgraded before they can be in a domain.

l Following an upgrade to Wireless Controller version 8.31 and higher, a Policy
Manager enforce fails if it includes changes to the default access control or any
rules that are set to contain. To allow Policy Manager to modify the default access
control or set rules to contain, you must disable the "Allow" action in policy rules
contains to the VLAN assigned by the role checkbox accessed from the Wireless
Controller's web interface on the Roles > Policy Rules tab. This will allow the enforce
operation to succeed.

Upgrading to Wireless Manager 8.4
Following aWireless Manager upgrade, you should clear the Java Cache before
starting the ExtremeManagement Center client.

Pre-Installation Checklist
Please review the following checklist prior to performing an Extreme
Management Center software installation or upgrade.

l Backup database. If performing an upgrade, be sure to backup the Extreme
Management Center database prior to performing the upgrade. Use the
Backup/Restore tab to perform the backup (Administration > Backup/Restore tab).

l Disable antivirus software. Disable any antivirus software running on the Extreme
Management Center server prior to beginning the installation. Be sure to re-enable
the antivirus software following the install. If you have installed or upgraded
Extreme Management Center on a Windows platform system, follow the instructions
in Configure Antivirus Software before you re-enable the antivirus software.

NOTE: Installing ExtremeManagement Center on a system on which McAfee version 8.0 is
installedmay prevent the installation from completing successfully without displaying
an error message. Ensure you disableMcAfee before installing.
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l Generate your Extreme Management Center product license key. When you
purchased Extreme Management Center, you received a Licensed Product
Entitlement ID for the license that you purchased. This Entitlement ID allows you to
generate a product license key. Refer to the instructions included with the
Entitlement ID to generate the license key. You use the key when you install the
product.

Extreme Management Center Installation -
Windows
Use the following instructions to install ExtremeManagement Center on a
Windows platform systemwhere you have administrative rights.

Stop Other Services
If you are using the ExtremeManagement Center version of SNMPtrap and/or
TFTP service, you cannot be running another version of that service on your
system. If you are running one of these non-ExtremeManagement Center
services on your system, you must shut it down before installing Extreme
Management Center, as follows:

1. Open the Services window on your system (Control Panel > Administrative Tools >
Services).

2. Scroll down to find the service in the list.

3. Right click on the service and select Stop from the popup menu.

4. Right click on the service again and select Properties from the popup menu.

5. In the Properties window, set the Startup Type for the service to Manual.

6. Repeat for any other services, if necessary.

7. Close the Services windows and Control Panel.

8. Open the Task Manager and check to be sure that the process is not running.

9. Close the Task Manager.



ExtremeManagement Center Installation - Windows

13 of 25

Install and Launch Extreme Management Center
1. Download the Extreme Management Center software from the Extreme Portal. If you
are installing from a CD, insert the CD into your system's CD drive.

2. Navigate to the NetSight_Suite.exe file and double-click it.

3. The Extreme Management Center Installer leads you through a series of windows
that asks for all the information required in order to install Extreme Management
Center. You need the following information for the Installer Program:

l License Text – Enter the license text for the Extreme Management Center
license you purchased. You received the license text when you generated your
Extreme Management Center product license key. If you choose not to enter
the license text during the installation, you are asked to enter it the first time
you launch an individual Extreme Management Center application.

l Service Configuration – Enable and start the Extreme Management Center
Services. (For more information on the services offered on the Windows
platform, see Extreme Management Center Services.)

l Destination Directory – This is the path to your Extreme Management Center
Installation Directory. In the Destination Directory window, click Choose to
navigate to the directory, or type the path in manually.

When you have finished with this series of windows, Extreme Management Center is
installed according to your specifications.

4. When the installation is complete, the database and server are started automatically.
You must wait until the Extreme Management Center server has started all its
various server components before you can connect to the server and launch the
Extreme Management Center applications. On the installation screen, you see an
hourglass icon while the server starts its components. When the server is ready for
connections, the installation screen displays a green check.

5. On the installation screen, click on the Show Launch Page link to open the Extreme
Management Center Launch Page. (You can also use the desktop shortcut to open
the Extreme Management Center Launch Page.)

6. The Extreme Management Center Launch Page opens. At the top of the web page
are tabs for the following functions:

l Home – Launch your Extreme Management Center applications by clicking on
the names or icons of any of the listed applications.

https://extremeportal.force.com/
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l Getting Started – In order to launch your Extreme Management Center
applications, you must have Java Runtime Environment (JRE) 6 (also referred
to as 1.6) or higher installed on your system. This page tells you if you have
met this requirement and provides instructions for installing the Java Runtime
Environment (JRE), if required.

l Administration – Provides access to specific server administration functions
such as client and server diagnostics, server utilities, the server log, and
ExtremeControl server diagnostics. To access the server diagnostics and
utilities, you will need to login with your username and password. (If the
Extreme Management Center server is a Windows platform system, in the
Username field you must enter a domain name and a username using the
following format: <domain name>\<username>).

7. Verify that you have met the JRE requirement by accessing the Getting Started tab,
and install the JRE according to the instructions on the Install Java tab, if required.

8. Click on the Home tab and launch the desired Extreme Management Center
application by clicking the name or icon.

9. A login window appears. Extreme Management Center requires a user login as a way
to restrict access to the Extreme Management Center server, perform audit trails,
and assign user capabilities according to the Authorization Group the user belongs.
It is important to note that when you log in, you are authenticating to the operating
system of the Extreme Management Center server system to which you are
connecting.

a. Select the Extreme Management Center server to which you wish to connect.

b. Enter your domain name\username.

c. Enter your password and click OK.

NOTE: The initial user to log in must be the user that performed the Extreme
Management Center installation. This is because the ExtremeManagement
Center server has a single pre-defined user that is the user who performed the
ExtremeManagement Center installation. OnWindows, this is the
domain\username of the person logged in to theWindows systemwhen the
installation was performed. Once the initial user has logged in, additional users
can be defined.

10. The application main window opens.
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Configure Antivirus Software
Using antivirus software such as McAfee® on ExtremeManagement Center
servers installed on aWindows platform system requires special consideration. If
the virus scanning software is used on directories containing MySQL data and
temporary tables, problems can result in both the performance of MySQL and
the virus-scanning software.

After installing or upgrading ExtremeManagement Center, we recommend you
add the MySQL data and tmp directories (<install directory>\mysql\data\tmp)
to the virus scanning exclusion list. Refer to your antivirus software
documentation for instructions.

Extreme Management Center Installation - Linux
Use the following instructions to install ExtremeManagement Center on a Linux
platform system. Please read through the following items before beginning the
installation.

l The user performing the installation must be the root user. During the installation
process you can specify another user to launch and run the server, if desired.

l If you are installing Extreme Management Center on a Linux system that doesn't
support a GUI, see Performing a Silent Install for information on installing Extreme
Management Center without using its GUI Installation wizard.

l If you are installing Extreme Management Center on a Linux system that requires an
operating system upgrade, you are prompted to upgrade using either an internet
connection or locally if no additional Ubuntu packages need to be installed.

l Prior to beginning installation, verify that your /etc/hosts file has the local host
name specified. It should have an entry that looks like:

127.0.0.1  localhost

l You may encounter a Java exception during the install when becoming the root user
with the su - command. Be sure that your system's root environment has a proper
DISPLAY variable setting. The Installation program reports a Java exception
(InvocationTargetException) if the DISPLAY variable is undefined. If this occurs:

Before using the su - command, set the system display variable to accept a remote
display with the command:
/usr/openwin/bin/xhost +test 111 lll
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After using the su - command, set the display variable in the environment where the
su - was done.

For C shell: setenv DISPLAY :0.0

For Korn shell: export DISPLAY=:0.0

Preparing for CD Installation
Perform the following steps if you will be installing the ExtremeManagement
Center software from a CD. The following procedures assume that the CD drive
fromwhich you are installing is physically attached to the systemwhere Extreme
Management Center is being installed.

1. Insert the Extreme Management Center CD into the CD drive.

2. Use an xterm where you are logged in as root. (Be sure that your system's root
environment has a proper DISPLAY variable setting. For more information see the
above note.)

3. Using the cd command, cd to the /mnt/cdrom directory.

4. Using the ls command, check to see if the CD drive is mounted. If no files are listed,
issue the following commands:
mount /mnt/cdrom

Install and Launch Extreme Management Center
1. Download the Extreme Management Center software from the Network Management
Suite (NMS) Download web page
http://extranet.extremenetworks.com/downloads/Pages/NMS.aspx.

2. Use an xterm where you are logged in as root. (Be sure that your system's root
environment has a proper DISPLAY variable setting. For more information see the
above note.)

3. Change the permissions on the upgrade file by entering the following command:

chmod u+x File_Name_<version>_install.bin

4. Start the Installer.

l If you have downloaded the software, cd to the directory where you
downloaded the installer and start the Installer with the following command:
./ExtremeManagementCenter_Suite_<version>_64bit_

https://extranet.extremenetworks.com/downloads/Pages/NMS.aspx
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install.bin

l If you are installing from a CD, start the installer with the command:
/mnt/cdrom/ExtremeManagementCenter.bin

5. The Extreme Management Center Installer leads you through a series of windows
that asks for all the information required in order to install Extreme Management
Center. You need the following information for the Installer Program:

l License Text – Enter the license text for the Extreme Management Center
license you purchased. You received the license text when you generated your
Extreme Management Center product license key. If you choose not to enter
the license text during the installation, you will be asked to enter it the first
time you launch an individual Extreme Management Center application.

l Service Configuration – There are two Service Configuration screens.

o In the first screen, you can specify a user other than root to own the
Extreme Management Center server and its supporting files, if desired.
This user becomes the admin user for the server. Select Use existing user
if you already have a user defined on the machine and enter the user
name. Select Create local netsight user if you want to create a new
"netsight" user (netsight is the user name) and enter the password for
this new user. Leave the Use existing user option set to root if you do not
want to specify another user.

o In the second screen, enable and start the Extreme Management Center
Services. (For more information on the services offered on the Linux
platform, see Extreme Management Center Services.)

l Destination Directory – This is the path to your Extreme Management Center
Installation Directory. In the Destination Directory window, click Choose to
navigate to the directory, or type the path in manually.

l Operating System Upgrade Method — If your Linux system requires an
operating system upgrade, you are prompted to upgrade using either an
internet connection or locally (without an internet connection) if no additional
Ubuntu packages need to be installed:

!!! ATTENTION !!!

We can attempt to upgrade the OS without using the Internet if there were no
extra Ubuntu packages installed. If there were extraneous packages installed,
the upgrade will fail with this method.
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Do you want to attempt a local in-place upgrade of the OS and reboot when
complete? (Y/n)

When you have finished with this series of windows, Extreme Management Center is
installed according to your specifications.

6. When the installation is complete, the database and server are started automatically.
You must wait until the Extreme Management Center server has started all its
various server components before you can connect to the server and launch the
Extreme Management Center applications. On the installation screen, you see an
hourglass icon while the server starts its components. When the server is ready for
connections, the installation screen displays a green check.

7. On the installation screen, click on the Show Launch Page link to open the Extreme
Management Center Launch Page.

8. The Extreme Management Center Launch Page opens. At the top of the web page
you will see tabs for the following functions:

l Home – Launch your Extreme Management Center applications by clicking on
the names or icons of any of the listed applications.

l Getting Started – In order to launch your Extreme Management Center
applications, you must have Java Runtime Environment (JRE) 6 (also referred
to as 1.6) or higher installed on your system. This page tells you if you have
met this requirement and provides instructions for installing the Java Runtime
Environment (JRE), if required.

l Administration – Provides access to specific server administration functions
such as client and server diagnostics, and server utilities.

9. Verify that you have met the JRE requirement by accessing the Getting Started tab,
and install the JRE according to the instructions on the Install Java tab, if required.

10. Click on the Home tab and launch the desired Extreme Management Center
application by clicking the name or icon.

11. A login window appears. Extreme Management Center requires a user login as a way
to restrict access to the Extreme Management Center server, perform audit trails,
and assign user capabilities according to the Authorization Group the user belongs.

a. Select the Extreme Management Center server to which you wish to connect.

b. Enter your username.
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c. Enter your password and click OK.

NOTES: The initial user to log in must be the user that performed the Extreme
Management Center installation, which is either root or the user defined in the
Service Configuration screen during the installation. This is because the Extreme
Management Center server has a single pre-defined user. Once the initial user
has logged in, additional users can be defined.

The password for the root user does not expire. To configure the password to
age so it expires after 60 days, see Configure Your Password to Expire.

12. The application main window opens.

Performing a Silent Install
If you are installing ExtremeManagement Center on a Linux system that doesn't
support a GUI, you must add the cli flag (--cli) to the install command, in order
to allow the ExtremeManagement Center installer to prompt for any required
input.

Start the installation with the following command:

./ExtremeManagementCenter_Suite_<version>_64bit_install.bin --
cli

If you are installing as a user other than root, you must use the --user command
to specify the different user. The user must already be configured on the
machine before you install. For example:

./ExtremeManagementCenter_Suite_<version>_64bit_install.bin --
cli --user <username>

To perform the install and create a new local "netsight" user (where netsight is
the user name), use the --password command to set the password for the new
"netsight" user. For example:

./ExtremeManagementCenter_Suite_<version>_64bit_install.bin --
cli --password <password>
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Restoring a Database from a Windows Server to a Linux
Server
This section describes several ExtremeManagement Center configuration
changes required if you are moving your ExtremeManagement Center
installation from aWindows platform system to a Linux platform system. The
steps are performed after restoring your database to the new server.

When restoring a saved database to a new ExtremeManagement Center server
installation, anymemory or database configuration changes on the original
server require a manual change on the new server in order to replicate the
configuration of the original ExtremeManagement Center server.

l Changes to the default -Xmx memory settings in the
<install directory>\services\nsserver.cfg file need to be duplicated on the new
server when the database is restored. To change the memory setting to match the
previous server, stop the Extreme Management Center server and edit the
nsserver.cfg file.

l The mySQL my.ini file also need to be manually updated to match any changes made
on the original server. For instructions on modifying the my.ini file, see the Change
the MySQL my.ini File section in the NAC Deployment Guide.

In addition, there are two changes that must bemade in the legacy Console java
application and one change in the legacy Inventory Manager application.

Console

Use the following instructions to change the location of syslog and trap
information to the new location on the Linux system.

Syslog

Change the Syslog Log Manager to point to the new location on the Linux
system. This allows the display of syslog information in the Syslog Event View
tab.

1. From the Console menu bar, select Tools > Alarm/Event > Event View Manager.

2. Click on the Syslog entry under Available Log Managers, and click the Edit button.
The Log Manager Parameters window opens.

3. Change the path in the Log Directory field to /var/log/syslog.
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4. Change the Pattern to Red Hat LINUX Syslog Pattern.

5. Click OK.

Traps

Change the Traps Log Manager to point to the new location on the Linux
system. This allows the display of trap information in the Traps Event View tab.

1. From the Console menu bar, select Tools > Alarm/Event > Event View Manager.

2. Click on the Traps entry under Available Log Managers, and click the Edit button.
The Log Manager Parameters window opens.

3. Change the path in the Log Directory field to %logdir%/traps.

4. Click OK.

Inventory Manager

If you are using Inventory Manager, you need to change the Data Storage
Directory path to point to the new location on the Linux system. The Data
Storage directory is where all Inventory Manager data is stored, including
capacity planning reports, configuration templates, archived configurations, and
property files.

1. From the Inventory Manager menu bar, select Tools > Options. Expand the Inventory
Manager options folder and select Data Storage Directory Path.

2. Change the path to the correct new location. On a default Linux install, the path
would be: <user's home directory>/appdata/InventoryMgr

3. Click OK.

Systems with Multiple NICs
This section provides instructions for configuring ExtremeManagement Center
servers with multiple NICs (Network Interface Cards). During the startup
process, the ExtremeManagement Center server automatically binds to the first
available NIC, which may not be the correct interface for the server to use. In
addition, changes on the network can cause the server to bind to an incorrect
interface, should the server restart during a change.

If the system has multiple NICs installed, it is a good practice to either:
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l configure the server to bind to a preferred IP address, if using only one interface for
connections or

l configure multiple network interfaces, if using more than one interface for
connections.

This ensures that local and remote clients, as well as ExtremeControl engines, are
able to connect to the ExtremeManagement Center server.

Binding to One Interface
If the ExtremeManagement Center server has multiple NICs installed but only
one interface is used to access ExtremeManagement Center, use the following
instructions to configure the preferred interface for the ExtremeManagement
Center server.

On Windows systems, you will need to set the binding order of the network
interface cards and configure the ExtremeManagement Center server to bind to
the correct address. On Linux systems, you need to configure the Extreme
Management Center server to bind to the correct address.

Windows Systems

Set the binding order of multiple network interface cards and configure the
ExtremeManagement Center server to bind to the correct IP address. These
steps may vary depending on your operating system.

1. Open the Network Connections window:

a. Click Start > Run.

b. Enter ncpa.cpl and click OK.

The Network Connections window opens. You can view the available connections in
the LAN and High-Speed Internet section of the window.

2. From the Network Connections window menu bar, select Advanced > Advanced
Settings. The Advanced Settings window opens.

3. The Adapters and Bindings tab lists the connections in the order in which the
connections are accessed by network services. The NIC that the Extreme
Management Center server connects to must be first in the list. You can use the
arrow buttons to change the binding order.



Remote Client Launch

23 of 25

4. Open the .netsight file. Edit the line JBOSS_HOSTNAME=<server IP> to add
the correct NIC IP address. (On Windows Server 2008 and Windows 7, the file is
located at C:\ProgramData\Extreme Networks. On Windows Server 2003, the file is
located at C:\Documents and Settings\All Users\Application Data\Extreme
Networks.)

5. Restart the Extreme Management Center server.

Linux Systems

Configure the ExtremeManagement Center server to bind to the correct IP
address.

1. Open the /var/Extreme_Networks/.netsight file. Edit the line JBOSS_
HOSTNAME=<server IP> to add the correct NIC IP address.

2. Restart the Extreme Management Center server.

Remote Client Launch
ExtremeManagement Center is a web-based application you access from the
ExtremeManagement Center Login page. Remote ExtremeManagement Center
clients can use the following steps to access the ExtremeManagement Center
Launch page and run ExtremeManagement Center applications from the
remote client machine.

1. Open a browser window and enter your Extreme Management Center information as
a URL in the following format:

http://servername:8080/

where servername is the ExtremeManagement Center server's IP address
or hostname, and 8080 is the required port number. For example,

http://10.20.30.40:8080/

2. The Extreme Management Center Login page opens.

Extreme Management Center requires a user login as a way to restrict access to the
Extreme Management Center server, perform audit trails, and assign user capabilities
according to the Authorization Group the user belongs. It is important to note that
when you log in, you are authenticating to the operating system of the Extreme
Management Center server system to which you are connecting.
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3. Enter your username if you are authenticating to a Linux platform server or enter
your domain name\username if you are authenticating to a Windows platform
server.

4. Enter your password and click Login.

5. The application main window opens.

The first time you log in, the embedded help window displays the Getting Started

NOTE: User preferences and application data (such as FlexViews andMIBs) for remote clients are
stored in the following local directory on the client machine: C:\Documents and
Settings\<username>\Application Data\NetSight.

Uninstalling Extreme Management Center
Use the procedures below to uninstall your ExtremeManagement Center Suite
of products. The uninstall removes all ExtremeManagement Center data from
the database. Be sure to backup your database prior to uninstalling.

Uninstalling on Windows
From the Start menu, select Programs > Extreme Networks
> NetSight > Uninstall.

Uninstalling on Linux
Navigate to the <install directory>/uninstaller directory and start the Uninstaller
by issuing the command:
./uninstall.sh

Extreme Networks Support
If you require assistance, contact Extreme Networks Global Technical Assistance
Center using one of the following methods.

Web www.extremenetworks.com/support/

https://www.extremenetworks.com/support/
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Phone 1-800-872-8440 (toll-free in U.S. and Canada) or 1-603-952-5000
For the Extreme Networks Support phone number in your country:
www.extremenetworks.com/support/contact/

Email support@extremenetworks.com

https://www.extremenetworks.com/support/contact/
mailto:support@extremenetworks.com
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