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Copyright © 2020 Extreme Networks, Inc. All Rights Reserved.

Legal Notices

Extreme Networks, Inc., on behalf of or through its wholly-owned subsidiary, Enterasys
Networks, Inc., reserves the right to make changes in specifications and other
information contained in this document and its website without prior notice. The reader
should in all cases consult representatives of Extreme Networks to determine whether
any such changes have been made.

The hardware, firmware, software or any specifications described or referred to in this
document are subject to change without notice.

Trademarks

Extreme Networks and the Extreme Networks logo are trademarks or registered
trademarks of Extreme Networks, Inc. in the United States and/or other countries.

All other names (including any product names) mentioned in this document are the
property of their respective owners and may be trademarks or registered trademarks of
their respective companies/owners.

For additional information on Extreme Networks trademarks, please see:
www.extremenetworks.com/company/legal/trademarks/

Contact
If you require assistance, contact Extreme Networks using one of the following methods.

« Global Technical Assistance Center (GTAC) for Immediate Support

« Phone: 1-800-998-2408 (toll-free in U.S. and Canada) or 1-603-952-5000.
For the Extreme Networks support phone number in your country, visit:
www.extremenetworks.com/support/contact

« Email: support@extremenetworks.com. To expedite your message, enter the
product name or model number in the subject line.

« GTAC Knowledge — Get on-demand and tested resolutions from the GTAC
Knowledgebase, or create a help case if you heed more guidance.

o The Hub — A forum for Extreme customers to connect with one another, get
questions answered, share ideas and feedback, and get problems solved. This
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community is monitored by Extreme Networks employees, but is not intended to
replace specific guidance from GTAC.

« Support Portal — Manage cases, downloads, service contracts, product licensing,
and training and certifications.
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Installation Prerequisites

Pre-Installation Configuration

Installation Prerequisites
o Ensure the Windows 2008R2 server has a valid Windows key.
« Ensure Remote Desktop Services is properly installed and has a valid license.
« Verify that certificates, if any, have been created and installed on the server.

User Accounts

The procedures in this document use the user accounts listed below. They are intended
to be examples of various users with certain sets of privileges. User account setup is at
the discretion of the Security Administrator.

« hetsightsrv — Extreme Management Center server administrator with full Remote
Desktop privileges

« hetsightadmin — Extreme Management Center administrator with only Extreme
Management Center Remote Desktop privileges

« hetsightuser — Extreme Management Center user with only Extreme Management
Center Remote Desktop privileges

« Xadministrator — non-default server administrator

« Xguest — non-default guest account

See Configuring Extreme Management Center Users for setting up user accounts.

Configuring Server Account Settings to be STIG-
Compliant
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Configuring Server Account Settings to be STIG-Compliant
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Setting the Password Policy

1. From your desktop, select Start > Administrative Tools > Local Security Policy >
Account Policies > Password Policy.
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Configuring Server Account Settings to be STIG-Compliant

=5 Local Security Policy =] C) [

File Action View Help
e nE = Heo

F Security Settings
4 _p Account Policies

Policy = Security Setting

I Enforce password history

7 Password Policy 10 passwords remembered

2 5 8 Masimum password age %
4 Account Lockout Policy e P E days
Local Policies 2 Minimum passward age 1day
& == o
Windows Firewall with Advanced Sec|| 25 Minimum password length 14 characters
] Metwork List Manager Policies 1 Password must meet complexity requirements Enabled
” Public Key Policies -J—:| Store passwords using reversible encryption Disabled

Software Restriction Policies
Application Contrel Policies
B, 1P Security Policies on Local Computs
| Advanced Audit Policy Configuration

2. For each of the following policies, double-click the policy name, set the new policy,
and then click OK.

For this policy... Set to...
Enforce password history 10 passwords remembered
Maximum password age 90 days
Minimum password age 1 day
Minimum password length 14 characters
Password must meet complexity requirements Enabled
Store passwords using reversible encryption Disabled

Setting the Account Lockout Policy

1. From your desktop, select Start > Administrative Tools > Local Security Policy >
Account Policies > Account Lockout Policy.
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Configuring Server Account Settings to be STIG-Compliant

: —— - - Lo | © ]
Fa Local Senunty Poliy e e S S =
File Action View Help
LI AN ol IERN ? o
i] St.curl’q.r Settings Palicy - Security Setting
ala "C‘:“"L pCI:IIcFI'ﬁI' 35 Account lockout duration 1 minute
a k:‘:"‘:"i 5 UlI::ylPol'< A Account lockeut threshold 3 invalid logon attempts
. L:cal ':O:_L_“ go = _jReset account lockout counter after 1 minute
a4 1

| Windows Firewall with Advanced Sec
| Metwork List Manager Policies
| Public Key Policies
| Software Restriction Policies
| Application Control Policies

8, 1P Security Pelicies on Lecal Compute
| Advanced Audit Policy Configuration

2. For each of the following policies, double-click the policy name, set the new policy,
and then click OK.

For this policy... Set to...
Account lockout duration 1 minute
Account lockout threshold 3 invalid logon attempts
Reset account lockout counter after 1 minute

Setting the Audit Policy

1. From your desktop, select Start > Administrative Tools > Local Security Policy >

Local Policies > Audit Policy.
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Configuring Server Account Settings to be STIG-Compliant
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2. Foreach of the following policies, double-click the policy name, set the new policy,
and then click OK.

For this policy... Enable...
Audit account logon events Success, Failure
Audit account management Success, Failure
Audit directory service access Success, Failure
Audit logon events Success, Failure
Audit object access Success, Failure
Audit policy change Success, Failure
Audit privilege user Success, Failure
Audit process tracking Success, Failure
Audit system events Success, Failure

Setting the Security Options

1. From your desktop, select Start > Administrative Tools > Local Security Policy >
Local Policies > Security Options.
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Configuring Server Account Settings to be STIG-Compliant
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<. Domain controller: Allow server operators to schedule tasks Mot Defined

.. Domain contreller: LDAP server signing requirements Mot Defined

«. Demain controller: Refuse machine account password chan... Not Defined

. Domain member: Digitally encrypt or sign secure channel d... Enabled
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2. Foreach of the following policies, double-click the policy name, set the new policy,
and then click OK.
For this policy... Set to...
Accounts: Rename
administrator account

Accounts: Rename guest
account

xadministrator

xguest
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Configuring Server Account Settings to be STIG-Compliant

For this policy...

Set to...

Interactive logon: Message
text for users attempting to
log on

Enter the following text:

You are accessing a U.S. Government (USG)
Information System (IS) that is provided for USG
authorized use only. By using this IS (which includes
any device attached to this IS), you consent to the
following conditions:

The USG routinely intercepts and monitors
communications on this IS for purposes including, but
not limited to, penetration testing, COMSEC
monitoring, network operations and defense,
personnel misconduct (PM), law enforcement (LE),
and counterintelligence (Cl) investigations. At any
time, the USG may inspect and seize data stored on
this IS.

Communications using, or data stored on, this IS are
not private, are subject to routine monitoring,
interception, and search, and may be disclosed or
used for any USG-authorized purpose.

This IS includes security measures (e.g.,
authentication and access controls) to protect USG
interests--not for your personal benéefit or privacy.

Notwithstanding the above, using this IS does not
constitute consent to PM, LE or Cl investigative
searching or monitoring of the content of privileged
communications, or work product, related to personal
representation or services by attorneys,
psychotherapists, or clergy, and their assistants. Such
communications and work product are private and
confidential. See User Agreement for details.

Interactive logon: Message
title for users attempting to
log on

Enter the following text:

U.S. Government (USG) Information System (IS) that
is provided for USG authorized use only.

System cryptography: Use
FIPS compliant algorithms
for encryption, hashing and
signing

Enable
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Configuring Windows Users and Groups

Configuring Windows Users and Groups

Creating an Extreme Management Center User Group

1. From your desktop, select Start > Administrative Tools > Server Manager > Local
Users and Groups > Groups.

2. Select Action > New Group.
3. Enter the following information:
« Group name: netsightusers

« Description: Users that are capable of using Extreme Management Center.

MNew Group l 7 - -

Group name: netsightusers
Description: Users that are capable of using Netsight]
Members:

Help Create ][ Closs

L= A

4. Click Create and Close.

Configuring Extreme Management Center Users

1. From your desktop, select Start > Administrative Tools > Server Manager > Local
Users and Groups > Users.
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Configuring Windows Users and Groups

2. Select Action > New User.
3. Enter the following information:
« User name: netsightadmin
« Password: Enter a password
« Confirm password: Confirm the password

 New User (B e

Iser name: netsightadmin

Full name:

Description:

Pazsword: I
Canfirm passward: LTI T

User must change password at next logon
User cannot change password
Password never expires

[] Account is disabled

Help Create ] I Close

e A

. Click Create and Close.
Double-click the netsightadmin user.
. Select the Member of tab.

. Click Add.

Enternetsightusers and Remote Desktop Users separated by a
semicolon.
Note: If this user is not already part of the "User"” group, add it now.

© N o oA
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Configuring Windows Users and Groups

17.
18.
19.
20.
21.

22.
23.
24.
25.

Select Groups - I. 2 &]

Select this object type:

Groups Object Types...

From this location:

CEFTEKHAR-PC Locations. ..

Enter the object names to select (examples):

netsightusers; Remote Desktop Users Check Mames

| Advanced... [ QK ]| Cancel |

e ~

. Click Check Names to validate the groups.
10.
11.
12.
13.
14.
15.
16.

Click OK.
Remove any other groups by selecting the group and clicking Remove.
From the Environment tab, enable Start the following program at logon.
In the Profile file name field, enter 1logoff.exe.
Click OK.
Select Action > New User
Enter the following information:
« User name: netsightuser
« Password: Enter a password
« Confirm password: Confirm the password
Click Create and Close.
Double-click the netsightuser user.
Select the Member of tab.
Click Add.

Enternetsightusers and Remote Desktop Users separated by a
semicolon.

Click Check Names to validate the groups.
Click OK.
Remove any other groups by selecting the group and clicking Remove.

From the Environment tab, enable Start the following program at logon.
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Configuring Windows Users and Groups

26.
27.
28.
29.

30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.

In the Profile file name field, enterlogof £ . exe.
Click OK.
Select Action > New User
Enter the following information:
« User name: netsightsrv
» Password: Enter a password
« Confirm password: Confirm the password
Click Create and Close.
Double-click the netsightsrv user.
Select the Member of tab.
Click Add.
Enternetsightusers and Administrators separated by a semicolon.
Click Check Names to validate the groups.
Click OK.
Remove any other groups by selecting the group and clicking Remove.
From the Environment tab, enable Start the following program at logon.
In the Profile file name field, enter 1logoff.exe.
Click OK.
Click Apply and OK.

16 of 47



Creating Extreme Management Center Users and Groups

Installing Extreme Management Center

To install Extreme Management Center, you must be logged in as "netsightsrv".

1.

ZER O

Initiate the Extreme Management Center install by double-clicking the install
package (via the .exe file) or install DVD.

From the Install GUI Welcome Screen, click Next.

Accept the terms of the license agreement, and click Next.

Enter your Extreme Management Center Product License, and then click Next.
From the next screen, clear TFTP and BOOTP, and then click Next.

Change the Install Folderto: C: \Enterasys Networks\NetSight, andthen
click Next.

7. Ifthe folder does not exist, click OK to create folder when prompted.

8. Wait until the following status is shown: Server is ready for

connections, and then click Finish.

Creating Extreme Management Center Users and
Groups

1.

Select Start > All Programs > Extreme Networks > Extreme Control Center >
Clients > Console.

When prompted to login, use the following credentials and click OK:
« Server: localhost
« User name: netsightsrv

« Password: [password defined in Configuring Extreme Management Center
Users]

3. Navigate to Tools > Authorization/Device Access.

4. Click Add Group and complete the following fields:

« Authorization Group name: netsightuser
« Membership Criteria: basic netsight capabilities

From the Capabilities tab, select or clear the user's capabilities depending on the
user's privileges.

Click Apply.
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Creating Extreme Management Center Users and Groups

Click Add Group and complete the following fields:
« Authorization Group name: netsightadmin
« Membership Criteria: admin netsight capabilities

From the Capabilities tab, select or clear the user's capabilities depending on the
user's privileges.

9. Click Apply and Close.

11.
12.

13.
14.
15.

. Click Add User and complete the following fields:

« User name: netsightuser
« Domain/Host name: localhost
« Authorization group: netsightuser
Click Apply.
Click Add User and complete the following fields:
« User name: netsightadmin
- Domain/Host nhame: localhost
« Authorization group: netsightadmin
Click Apply.
Click Close.

Exit the Extreme Management Center Console Program.
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Configuring Extreme Management Center Services

Configuring Extreme Management
Center

Configuring Extreme Management Center Services

1.

From your desktop, select Start > Administrative Tools > Server Manager >
Configuration > Services.

2. Double-click BootP Service.
3. From the General tab, select Disabled from the Startup type drop-down list.
4. From the Log On tab, enable This account.
5. Click Browse and enter the object name as netsightsrv.
6. Click Check Names to validate the object name.
7. Click OK.
8. Enter and confirm the password assigned in Configuring Extreme Management
Center Users.
9. Click OK.
10. Repeat the above steps for the following services:
For this service... Change ?;artup Type
Extreme Management Center Database Service Automatic
Extreme Management Center Server Service Automatic
Extreme Management Center SNMP Trap Service Automatic
Extreme Management Center Syslog Service Automatic
Extreme Management Center TFTP Service Disabled

11.
12.

Click OK.
Restart the computer and log in again as user netsightsrv.

Configuring Access Control of Extreme
Management Center Directory

1.
2.

Navigate to the C:\ drive (Start > Computer > OS (C:).
Right-click the directory named Extreme Networks and select Properties.
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Encrypting the File System Service

13.

14.
15.
16.

N o g s w

From the Security tab, click Advanced.

Click Change Permissions.

Clear the Include inheritable permissions from this object's parent checkbox.
Click Add.

Select Replace all child object permissions with inheritable permissions from this
object.

Click Add.

. In the Enter the object name to select field, type netsightusers.
10.
11.
12.

Click Check Names.
Click OK.

Select Allow for the following permissions:
Traverse folder / execute file

List folder / read data

Read attributes

Read extended attributes

Create files / write data

Create folders / append data

Write attributes

Write extended attributes

Read permissions

Select Apply these permissions to objects and/or containers within this container
only.

Click OK.
Select Users (NETSIGHT-1\Users) and then click Remove.
Click OK, Yes, and OK twice to exit.

Encrypting the File System Service

1.

From your desktop, select Start > Administrative Tools > Server Manager >
Configuration > Services.

2. Double-click Encrypting File System (EFS).

3. From the General tab, select Automatic from the Statrup type drop-down list.

Click Start.
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Encrypting the File System of the Extreme Management Center mysql Directory

5. Once the service starts, click OK.

Encrypting the File System of the Extreme

Management Center mysql Directory
1. From your desktop, select Start > Administrative Tools > Server Manager >
Configuration > Services.
. Double-click Database Service.
. From the General tab, click Stop.
. Once the Service has stopped, click OK.

. Navigateto C: \Extreme Networks\NetSight.
. Right-click on the mysql directory and select Properties.
. Click Advanced.
9. Select Encrypt contents to secure data.
10. Click Apply.
11. When prompted, select Apply changes to this folder, subfolders and files.
12. Click OK twice to exit.

13. From your desktop, select Start > Administrative Tools > Server Manager >
Configuration > Services.

2
3
4
5. From your desktop, navigate to the C:\ directory (Start > Computer > OS (C:)).
6
7
8

14. Double-click Database Service.
15. From the General tab, click Start.
16. Once the Service has started, click OK.

Configuring the Application Identity Service

1. From your desktop, select Start > Administrative Tools > Server Manager >
Configuration > Services.
2. Double-click Application Identity.

3. From the General tab, select Automatic from the Startup type drop-down list.
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Configuring Application Control Policies

4. Click Start.
5. Once the service has started, click OK.

Configuring Application Control Policies
1. From your desktop, select Start > Administrative Tools > Server Manager >
Configuration > Services.
2. Right-click AppLocker and select Properties.

3. Select Configured from the following sections:
Executable rules
Windows Installer rules
Script rules

4. Click OK.

Configuring AppLocker Executable Rules

1. From your desktop, select Start > Administrative Tools > Local Security Policy >
Application Control Policies > AppLocker > Executable Rules.

2. Right-click in blank area and select Create new Rule.....
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Configuring AppLocker Executable Rules

3, Local Security Policy o] B e
File Action View Help
% |70 = @rem
-ﬁ Security Settings Action User Mame Condition  Exceptions
+ [ Mecount Policies
4 Local Poligies There are no items to show in this view.
~| Windows Firewall with Advanced Seci
~| Metwork List Manager Policies
7| Public Key Policies
’| Software Restriction Policies Create New Rule... [}
4 | Application Control Policies Automatically Generate Rules...
4 [ AppLocker Create Default Rules
[ Executable Rules
) Windows Installer Rules View -
» 5] Seript Rules
— A b
b g IP Security Policies on Local Compute ) D
» ] Advanced Audit Policy Configuration Line up lcons
Help
|
4 m 13
Manually create a new rule

3. The Create Executable Wizard opens. Click Next and then select Allow if it is not
selected by default.
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Configuring AppLocker Executable Rules

Create Executable Rules ﬂ
Before You Begin
Before You Begin
Permissions This wizard helps you create an Applocker rule. A rule is based on file sttributes, such as the
file path or the software publisher contained in the file's digital signature.
Conditions
Publisher Before continuing, confirm that the following steps are complete:
Exceptions

+ Install the applications you want to create the rules for on this computer.
Mame = Back up your exsting rules.
= Review the Applocker documentation.

To continue, click MNext.

[ Skip this page by default

Mext > Cancel

Click Select.

Type netsightusers inthe following dialog.

-

Select User or Group

Select this object type:
User, Group, or Built4n security principal Object Types. ..

From this location:
corp extremenetworks.com Locations. ..
Erter the object name to select (2xamples):
netsightusers| Check Mames

11

o) (s

L

Click Check Names.
Click OK.
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Configuring AppLocker Executable Rules

8. Click Next.
9. Select the Path option, and click Next.

Create Executable Rules (i3]

I Conditions

Before You Begin

Permissions Select the type of primary condition that you would like to create.
Path
. Publisher
Exceptions T o o
Select this option if the application you want to create the rule for is signed by the
Name software publisher.
@ Path

Create a rule for a specific file or folder path. If you select a folder, all files in the
folder will be affected by the rule.

File hash
Select this option if you want to create a rule for an application that is not signed.

Maore about rule conditions

< Previous Cancel

10. Click Browse Folders... and selectthe C: \Extreme Networks path.
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Configuring AppLocker Executable Rules

Create Script Rules ]
Path
Before You Begin . - -
o Select the file or folder path that this rule should affect. If you specify a folder path, all files
Permissions undermneath that path will be affected by the rule.
Conditions

Path:
Exceptions

MName

| Browse Files... Browse Folders...
g

More about path rules and path variables

Cancel

11. Click OK and then Next twice.

12. In the Name field, type Net Sight, and then click Create.
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Configuring AppLocker Executable Rules

- ‘
Create Executable Rules ]
Mame and Description
Before You Begin . . .
o Enter a name to identify this mule.
Permissions
Conditions
Path Name:
Exceptions. NetSight]

Description: (Optional)

The wizard closes and returns to the Local Security Policy.

riLcﬂISem:ityPoliq
File Action View Help
eos| 2@ =EBm

B Security Settings Action Mame Condition Exceptions
b @ Account Policies @ Allow Netsight Path
> L Local Policies
b [1 Windows Firewall with Advanced Seci
[ Metwork List Manager Palicies
b ] Public Key Pelicies
p» [1 Software Restriction Policies
a4 | Application Control Policies
# 73 Applocker
"™ Executable Rules
» (] Windows Installer Rules
u v [i] Script Rules
» @, 1P Security Policies on Local Compute
p [ Advanced Audit Policy Configuration
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Configuring AppLocker Script rule

13. Repeat the preceding steps to create the following rules:

Rule Identification Name File Path

netsightsrv C:\Users\netsightsrv
netsightadmin C:\Users\netsightadmin
netsightuser C:\Users\netsightuser

Configuring AppLocker Script rule
1. From your desktop, select Start > Administrative Tools > Local Security Policy >
Application Control Policies > AppLocker > Script Rules.
2. Right-click in blank area and select Create New Rule

_?-3 Local Security Policy =1 = ﬁ
File Action View Help
L Al fin | BT

H Security Settings Action User Name
4 Account Policies
4 Local Policies There are no items to show in this view.
| Windows Firewall with Advanced Seci
| MNetwork List Manager Policies

Condition  Exceptions

Public Key Policies

Software Restriction Policies Create New Rule... [é
Fl Application Control Policies Automatically Generate Rules...
« [Ig Applocker Create Default Rules
= Executable Rules
(3 Windows Installer Rules View »
' Script Rules
Arrange lcons b
! IP Security Policies on Local Compute ) g
Advanced Audit Policy Configuration Line up leons
Help

rl ili [

Manually create a new rule

3. The Create Executable Wizard opens. Click Next and then select Allow if it is not
selected by default.
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Configuring AppLocker Script rule

Create Executable Rules ﬂ
Before You Begin
Before You Begin
Permissions This wizard helps you create an Applocker rule. A rule is based on file sttributes, such as the
file path or the software publisher contained in the file's digital signature.
Conditions
Publisher Before continuing, confirm that the following steps are complete:
Exceptions

+ Install the applications you want to create the rules for on this computer.
Mame = Back up your exsting rules.
= Review the Applocker documentation.

To continue, click MNext.

[ Skip this page by default

Mext > Cancel

Click Select.

Type netsightusers inthe following dialog.

-

Select User or Group

Select this object type:
User, Group, or Built4n security principal Object Types. ..

From this location:
corp extremenetworks.com Locations. ..
Erter the object name to select (2xamples):
netsightusers| Check Mames

11

o) (s

L

Click Check Names.
Click OK.
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Configuring AppLocker Script rule

8. Click Next.
9. Select the Path option, and click Next.

Create Executable Rules (i3]

I | Conditions

Before You Begin

Permissions Select the type of primary condition that you would like to create.
Path
Exceptions PI.IMIE'I!-! o o o
Select this option if the application you want to create the rule for is signed by the
Name software publisher.
@ Path

Create a rule for a specific file or folder path. If you select a folder, all files in the
folder will be affected by the rule.

File hash
Select this option if you want to create a rule for an application that is not signed.

Maore about rule conditions

< Previous Cancel

10. Click Browse Folders... and selectthe C: \Extreme Networks path.
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Configuring AppLocker Script rule

Create Script Rules ]
Path
Before You Begin . - -
o Select the file or folder path that this rule should affect. If you specify a folder path, all files
Permissions undermneath that path will be affected by the rule.
Conditions

Path:
Exceptions

MName

| Browse Files... Browse Folders...
g

More about path rules and path variables

Cancel

11. Click OK and then Next twice.

12. In the Name field, type Net Sight, and then click Create.
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Configuring AppLocker Script rule

r ‘
Create Executable Rules ]
Mame and Description
Before You Begin . . .
o Enter a name to identify this mule.

Permissions
Conditions

Path Name:

Exceptions. NetSight]

Description: (Optional)

The wizard closes and returns to the Local Security Policy.

riLcﬂISem:ityPoliq
File Action View Help
eos| 2@ =EBm

Y Security Settings Action Name Condition Exceptions
> B Account Policies @ Allew MetSight Path
v g Local Policies
b [1 Windows Firewall with Advanced Seci

[ Metwork List Manager Palicies
b ] Public Key Pelicies
p» [1 Software Restriction Policies
a4 | Application Control Policies

# 73 Applocker
"™ Executable Rules
o (5] Windows Installer Rules

u v [i] Script Rules
» 8, 1P Security Policies on Local Compute
b ] Advanced Audit Policy Configuration|
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Configuring RemoteApp Manager

13. Repeat the preceding steps to create the following rules:

Rule Identification Name File Path

netsightsrv C:\Users\netsightsrv
netsightadmin C:\Users\netsightadmin
netsightuser C:\Users\netsightuser

Configuring RemoteApp Manager

1.

From your desktop, select Start > Administrative Tools > Server Manager >
Roles > RemoteApp Manager.

2. Right-click RemoteApp Manager and select Add RemoteApp Programs.
3. Click Next.

Select the following Apps:
Automated Security Manager
Console

Inventory Manager

NAC Manager

Policy Manager

5. Click Next and then Finish.
6. In the right column under RemoteApp Programs, perform the following steps for

each program:
1. Right-click the program and select Create Windows Installer Package.
2. Click Next three times.
3. Click Finish.

7. From your desktop, navigate to C:\Program Files\Packaged Programs.

8. Copy the MSI packages just created onto a USB drive or other storage medium.

Transfer and install MS| packages onto the Extreme Management Center client
computer.
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Windows Firewall Configuration

Windows Firewall Configuration
1. From your desktop, select Start > Administrative Tools > Local Security Policy >
Windows Firewall with Advanced Security > (expand folder) > Inbound Rules.

2. Inthe blank area, right-click and select New Rule.
The New Inbound Rule Wizard opens.

& Mew Inbound Rule Wizard &

| Rule Type
|
Select the type of firewall nie to create

| Steps:

™ Rule Type What type of nube would you ke to create?
@ Action Program
i f
@ Profie Rule that controls connections for a program.
& Name @ Port

Rule that controls connections for a TCP or UDP port.

Predefined:

Rule that controls connactions for a Windows experience

Custom
Cuzstom nde.

Select the Port option and then click Next.

If not already selected, choose the TCP option.
Type 135 in the Specific local ports field.
Click Next.

o 0k w

34 of 47



Windows Firewall Configuration

7. Select the second option, Allow the Connection if it is secure.

& New Inbound Rule Wizard . )

Action
Specify the action 1o be taken when a connection matches the conditions specied in the nule.

Steps:
@ Rus Type ‘What action should be taken when a connection matches the specified condtions?
@ Pratocel and Pors
_ Allow the conneclion
L BT This inchudes connections that are protected with IPsac a5 wel a3 thoss are nat.
@ Users
@ Allow the connection if it is secure
¢ o This includes only connections that have been authenticated by using IPsec. Connections
@ Profie aummwmnlwmswmnMWimSew
nade,
@ MName

Block the connection

T MmN o

<Bac |[ Net> ][ Concel

8. Click Customize...
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Windows Firewall Configuration

9. Select Allow the connection if it is authenticated and integrity-protected.

Customize Allow if Secure Settings ﬁ

Select one of these options to determine which action Windows Firewall with Advanced
Security will take for the incoming or outgoing packets that match the firewall rule criteria.

@ Allow the connection if it is authenticated and integrity-protected

Allow only connections that are both authenticated and integrity-protected by using
|Psec. Compatible with Windows Vista and |ater.

Require the connections to be encrypted
Require privacy in addition to integrity and authentication

Allow the connection to use null encapsulation

Mull encapsulation allows you to require that the connection be authenticated, but
does not provide integrity or privacy protection for the packet payload. Compatible
with Windows 7 and later.

[] Owerride block rules

Useful for toals that must always be available, such as remote administration tools.
if you specify this option, you must also specify an authorized computer ar
computer group.

Leam more about these settings

ok || Cancel

b -

10. Click OK and then Next three times.

11. On the Profile page, leave Domain, Private, and Public selected, and then click
Next.
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Windows Firewall Configuration

12. In the Name field, type RDP 135 Access, and then click Finish.

& New Inbound Rule Wizard —

Name
Specify the name and descrption of this rule.

Steps:
Ruls Type
Pratocel and Ports

Action
Name:
Fude (RDP 135 Access)|

Protie Description foptional):

R
F
£

' ) o) (s

A

e

The wizard closes and returns to the Local Security Policy window.
3, Local Security Policy =)

File Action View Help
e 70 = @rm

B Security Settings Name Group Profile  Enablec
> L4 Account Policies CJRule (ROP 138 Access) Al Ve |
b L@ Local Policies
a | Windows Firewall with Advanced Sec

a4 P Windows Firewall with Advanced
&3 Inbound Rules
ES Outbound Rules
B Connection Security Rules
[ Network List Manager Policies

b [ Public Key Policies

] Software Restriction Policies

» [ Application Control Policies

o 8, 1P Security Policies on Local Compute

[ Advanced Audit Policy Configuration
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Windows Firewall Configuration

13. Repeat the preceding steps to create the following rules:

Port Type

Specific

local port

Connection Type

Rule Name

TCP

3389

Allow the Connection if itis secure / Allow the
connection if it is authenticated and integrity-
protected

RDP 3389
Access

UbDP

137

Allow the Connection

RDP UDP
137 Access

Custom

161

1. On the Protocols and Ports page, select
the following options:

« Protocol type: UDP
« Local port: Specific Ports / 161
2. On the Scope page, select the following
options:

« Local IP addresses: These IP
addresses > Add > enter ECC
server address [/64 or /24] > OK

« Remote IP addresses: These IP
addresses > Add > enter
management IP and 64 bit mask of
Management Subnet addresses
[/64 or /24] > OK

3. Select Allow the Connection.

SNMP
Access
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Windows Firewall Configuration

Port Type

Specific
local port

Connection Type

Rule Name

Custom

162

. On the Protocols and Ports page, select

the following options:
» Protocol type: UDP
« Local port: Specific Ports / 162

. On the Scope page, select the following

options:

« Local IP addresses: These IP
addresses > Add > enter ECC
server address [/64 or /24] > OK

« Remote IP addresses: These IP
addresses > Add > enter
management IP and 64 bit mask of
Management Subnet for
router/switch [/64 or /24] > OK

. Select Allow the Connection.

SNMP Trap

Custom

22

. On the Protocols and Ports page, select

the following options:
« Protocol type: TCP
o Local port: Specific Ports / 22

. On the Scope page, select the following

options:

o Local IP addresses: These IP
addresses > Add > enter ECC
server address [/64 or /24] > OK

« Remote IP addresses: These IP
addresses > Add > enter
management IP address and 64 bit
mask of management subnet for
router/switch [/64 or /24] > OK

3. Select Allow the Connection.

SSH Access

UbDP

514

Allow the Connection

Syslog UDP
514 Access
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Configuring IPsec

Configuring IPsec
1. From your desktop, select Start > Administrative Tools > Local Security Policy >
Windows Firewall with Advanced Security.

2. Right-click Windows Firewall with Advanced Security - Local Group Policy Object
and select Properties.

3. From the Domain Profile tab, select On from the Firewall state drop-down list.
4. Select Block from the Inbound connections drop-down list.
5. Select Allow from the Outbound connections drop-down list.

P

Windows Firewall with Advanced Security - Local Group Policy DI&

Domain Profile | Private Profile | Public Profile | IPsec Settings |

Specify behavior far when a computer is connected to its comporate

domain.
State
i F Firewall state: [On {recommended) ']
Inbound connections: [Eluc:k {default) v]
Outbound connections: [Nlnw (default) "]
Settings

) ) -
— Specify seﬂlng_s that control Windows
v— | Firewall behavior.

Logging

Specify logging settings for
troubleshooting.

Leam more about these settings

ok [Ccomee J [ oob

L -

6. From the IPsec Settings tab, click Customize... in the IPSec Defaults area.

7. In the resulting dialog, select the Advanced radio button in the Key exchange
(Main Mode) area.

8. Click Customize....
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Configuring IPsec

9. Click Add.
10. Ensure the following security methods are selected: SHA-1 is selected in the drop-
down list.
Drop-down List Selection
Integrity algorithm SHA-1
Encryption algorithm AES-CBC 128
Key exchange algorithm Diffie-Hellman Group 14

-

Add Security Method

==

Integrity algorthm:

| SHA1

)

Encryption algaorithm:

[:i:] Stronger than MD5, uses slighthy more resources.

AESLCBC 128

*)

with Windows Vista and later.

Key exchange algorthm:

nj:i:jn Faster and stronger than DES. Compatible onby

| Diffie-Hellman Group 14

[:i:] Stronger than DH Group 2.

Leam more about encreption and integrity algoithms

| oK

] l Cancel

L

11. Click OK when finished.

12. Back on the Customize Advanced Key Exchange Settings, do the following:

1. Enter 480 in the Minutes field (Key lifetimes area).

. Enter 0 in the Sessions field.

2
3. Select the Use Diffie-Hellman for enhanced security checkbox.
4

. Click OK.

41 of 47



Configuring IPsec

13.
14.
15.

-

Customize Advanced Key Exchange Settings

S5

Security methods

|Use the following securty methods for key exchange.
Thaose higher in the list are tried first.

Specify when a new key is generated. f you select
both options, a new key is generated when the first
threshold is reached.

Mirtes: 4801=

Sessions:

Leam more about key exchange settings
What are the default values?

Securty methods:
Integrity Encryption Key exchange algorthm
SHA-1 AESLCBC 128  Diffie-Hellman Group 2 {default)
SHAA IDES Diffie-Hellman Group 2
SHAA AESCBC 128 Diffie-Hellman Group 14
Add... ] [ Edit... ] [ Bemove
Key fetimes Key exchange options

Use Diffie-Hellman for enhanced
secunty.

Compatible with Windows Vista
and later.

| oK || Cancel |

L

Select the Advanced radio button in the Data protection (Quick Mode) area.

Click Customize... and then Add.

Select the Require encryption for all connection security rules that use these

settings checkbox.
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Configuring IPsec

Customize Data Protection Settings

]

| Integrity Key Lifetime fninutes/KB)
ESP SHA1 60/100.000
AH SHA- 60/100,000

[ Data protection settings are usad by connection sacurty nies to protect network: traffic

| Require encryption for all connection securly rules that use these settings.

Leam more about integrity, sncryption, and handwane acceleration for |Psec protected networs iraffic

Data integrity and encryption

Protect data from modification and preserve confidentiality on the
network with these integrity and encryption algorthms. Those
higher in the list are tried first

Data integrty and encrypbon algorthms:

Protocol  Integrity  Emcryption  Key Lfetime fmin...
ESP SHA1 AESCBC ..  &0/100,000
ESP SHA1 3DES £0/100.000

Add. |

Whiat are the default values?

I

:Cm':l

16. In the Data integrity and encryption area, click Add.

17. Select the following options:
Select ESP (recommended).

Choose AES-CBC 128 from the Encryption algorithm drop-down list.
Choose SHA-1 from the Integrity algorithm drop-down list.
In the Key lifetimes area, type 60 for Minutes and 100,000 for KB.
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Configuring IPsec

P

Add Integrity and Encryption Algonthms Iﬁ

Protacol

@ ESP {recommended)
ESP protocol provides privacy and integrity for the packet
payload. ESF is compatible with Metwork Address
Translation (NAT).

I ESP and AH
Adding the AH protocal provides additional integrity for the |P "

header. This option is not compatible with MAT.
Algorithms
| Encryption algorithm: [AES-CEE 128 v]

(i) Faster and stronger than DES. Compatible only with
— Windows Vista and later.

Integrity algorithm: SHA-1 -

.:i:. Stronger than MD5, uses slightly more resources.

Key lifetimes
Minutes: 60 =
KEB: 100,000 =

Leam mare about data encryption settings

I | oK ][Cancel]l

18. Click OK twice to exit.
19. Select Advanced for Authentication method, and then click Customize.

20. Click Add.
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Configuring IPsec

21.

22.
23.
24.
25.

Ensure that the First authentication is optional is not selected, and then click OK.

- —
Customize Advanced Aulimﬁ‘c:hon Methods

First authentication

[7] First authentication is optional

Lesm more about authentication settings
What are the default values?

Speciy computer authentication methods to use during IPsec
negatiations. Those higher in the list are tried first.

"W )

Sacond authentication
Specify user authentication methads or a health cerificate to use
during |Psec negotiations. Those higher in the list are tried first.
Sacond authentication methods:
Methad Addtional Information

i
] Second authentication is optional
A second authentication cannot be specified when a preshaned
key iz in the first authentication methods ket

—

—

Click OK again to exit the Customize IPsec Settings dialog.

Select None from the IPsec tunnel authorization area, and click OK to exit.

Back in the Local Security Policy window, click Connection Security Rules.

In the blank area, right-click and select New rule....

File Action View Help

| 7@ = e

H Security Settings

b @ Account Policies

b @ Local Policies
4[] Windows Firewall with Advanced Sec:
4 P Windews Firewall with Advanced
K3 Inbound Rules
Outbound Rules
M Connection Security Rules
71 Network List Manager Policies
r [ Public Key Policies
1+ [ Software Restriction Policies
a4 [ | Application Centrol Policies
4 [T Applocker
o [ Executable Rules
b Windows Installer Rules
[&] Script Rules
b S IP Security Policies on Local Compute
a [ 7] Advanced Audit Policy Configuration|
b Ny System Audit Policies - Local Groy

Enabled Endpoint 1 Endpoint2  Authen

There are ne items to show in this view.

HNew Rule...

Filter by Profile
Filter by State

Refresh

View

Amange lcons
Line up lcons

Help
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Configuring IPsec

26.
27.

28.

29.
30.

31.

32.
33.

34.
35.
36.
37.

The New Connection Security Rule Wizard opens.
Select Custom and then click Next.

For Which computers are in Endpoint 1?, choose These IP address and then click
Add....

In the This IP address or subnet, type the IP address of NetSight server in
XXXX . XXXX.xxXxXx.xxxx format.

Click OK.

For Which computers are in Endpoint 2?, choose These IP addresses and click
Add.

In the This IP address or subnet, type the IP address and 64-bit mask of Extreme
Management Center client(s) in

XXXX  XXXXXXXKXXXXX XXXX D XXXX XXXX. XXXX/ 64 or

XXX .XXX.XXX.xxx/24 format.

Click OK and then Next.

Select Require authentication for inbound and outbound connections (third
option), and then click Next.

Select Advanced (fourth option), and then click Customize....
In the First authentication area, click Add....

Select Preshared key, and Enter .

Click OK to exit.
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Configuring IPsec

38. Ensure that the First authentication is optional is not selected, and then click OK.

39.
40.

41.
42.

43.

44,

Customize Advanced Authentication Methods ﬁ
- - — — — - . —
First authentication Second authentication
Specfy computer authentication methods to use during |Peec Specify user authentication methods or a heaith cedificate to use
negotiations. Those higher in the list are tried first. during |Psec negotiations. Those higher in the list are tried first.
First authentication methods: Second authentication mathods
Method Addtional Infomation Method Additional Information
L 1]
Add. | | Add. |
First authentication is optional Second authentication is optional
A second suthentication cannot be specfied when a preshared
key is in the first authentication methods list
I oK | [ cacs
Click Next.

On the Protocols and Ports page, select the following options:
Protocol type: Any

Endpoint 1 port: All Ports

Endpoint 2: All Ports

Click Next.

On the Profile page, leave Domain, Private, and Public selected, and then click
Next.

On the Name page, enter the rule name and click Finish.
You are returned to the Local Security Policy dialog. If the new rule is
not enabled, right-click the rule and select Enable rule.

Repeat the above configure IPsec for the NetSight client, but reverse the Endpoint
1 and Endpoint 2 IP addresses.
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