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Extreme Networks® Software License Agreement

This Extreme Networks Software License Agreement is an agreement ("Agreement") between
You, the end user, and Extreme Networks, Inc. ("Extreme"), on behalf of itself and its Affiliates
(as hereinafter defined and including its wholly owned subsidiary, Enterasys Networks, Inc. as
well as its other subsidiaries).  This Agreement sets forth Your rights and obligations with
respect to the Licensed Software and Licensed Materials.  BY INSTALLING THE LICENSE KEY
FOR THE SOFTWARE ("License Key"), COPYING, OR OTHERWISE USING THE LICENSED
SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS AGREEMENT,
WHICH INCLUDES THE LICENSE AND THE LIMITATION OFWARRANTY AND DISCLAIMER
OF LIABILITY.  IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, RETURN THE
LICENSE KEY TO EXTREME OR YOUR DEALER, IF ANY, OR DO NOT USE THE LICENSED
SOFTWARE AND CONTACT EXTREME OR YOUR DEALERWITHIN TEN (10) DAYS
FOLLOWING THE DATE OF RECEIPT FOR A REFUND.  IF YOU HAVE ANY QUESTIONS
ABOUT THIS AGREEMENT, CONTACT EXTREME, Attn:  LegalTeam@extremenetworks.com. 

1. DEFINITIONS.  "Affiliates" means any person, partnership, corporation, limited liability company, or other
form of enterprise that directly or indirectly through one or more intermediaries, controls, or is controlled
by, or is under common control with the party specified. "Server Application" shall refer to the License Key
for software installed on one or more of Your servers.  "Client Application" shall refer to the application to
access the Server Application.  "Licensed Materials" shall collectively refer to the licensed software
(including the Server Application and Client Application), Firmware, media embodying the software, and
the documentation.  "Concurrent User" shall refer to any of Your individual employees who You provide
access to the Server Application at any one time.  "Firmware" refers to any software program or code
imbedded in chips or other media.  "Licensed Software" refers to the Software and Firmware collectively.

2. TERM.  This Agreement is effective from the date on which You install the License Key, use the Licensed
Software, or a Concurrent User accesses the Server Application.  You may terminate the Agreement at
any time by destroying the Licensed Materials, together with all copies, modifications and merged
portions in any form.  The Agreement and Your license to use the Licensed Materials will also terminate if
You fail to comply with any term of condition herein.

3. GRANT OF SOFTWARE LICENSE.  Extreme will grant You a non-transferable, non-exclusive license to use
the machine-readable form of the Licensed Software and the accompanying documentation if You agree
to the terms and conditions of this Agreement.  You may install and use the Licensed Software as
permitted by the license type purchased as described below in License Types. The license type purchased
is specified on the invoice issued to You by Extreme or Your dealer, if any.  YOU MAY NOT USE, COPY, OR
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MODIFY THE LICENSED MATERIALS, IN WHOLE OR IN PART, EXCEPT AS EXPRESSLY PROVIDED IN
THIS AGREEMENT.

4. LICENSE TYPES. 

l Single User, Single Computer.  Under the terms of the Single User, Single Computer license, the
license granted to You by Extreme when You install the License Key authorizes You to use the
Licensed Software on any one, single computer only, or any replacement for that computer, for
internal use only.  A separate license, under a separate Software License Agreement, is required for
any other computer on which You or another individual or employee intend to use the Licensed
Software.  A separate license under a separate Software License Agreement is also required if You
wish to use a Client license (as described below).

l Client.  Under the terms of the Client license, the license granted to You by Extreme will authorize
You to install the License Key for the Licensed Software on your server and allow the specific
number of Concurrent Users shown on the relevant invoice issued to You for each Concurrent User
that You order from Extreme or Your dealer, if any, to access the Server Application.  A separate
license is required for each additional Concurrent User.

5. AUDIT RIGHTS.  You agree that Extreme may audit Your use of the Licensed Materials for compliance with
these terms and Your License Type at any time, upon reasonable notice.  In the event that such audit
reveals any use of the Licensed Materials by You other than in full compliance with the license granted and
the terms of this Agreement, You shall reimburse Extreme for all reasonable expenses related to such
audit in addition to any other liabilities You may incur as a result of such non-compliance, including but
not limited to additional fees for Concurrent Users over and above those specifically granted to You. 
From time to time, the Licensed Software will upload information about the Licensed Software and the
associated devices to Extreme. This is to verify the Licensed Software is being used with a valid license. By
using the Licensed Software, you consent to the transmission of this information.  Under no
circumstances, however, would Extreme employ any such measure to interfere with your normal and
permitted operation of the Products, even in the event of a contractual dispute.

6. RESTRICTION AGAINST COPYING OR MODIFYING LICENSED MATERIALS.  Except as expressly
permitted in this Agreement, You may not copy or otherwise reproduce the Licensed Materials.  In no
event does the limited copying or reproduction permitted under this Agreement include the right to
decompile, disassemble, electronically transfer, or reverse engineer the Licensed Software, or to translate
the Licensed Software into another computer language.

The media embodying the Licensed Software may be copied by You, in whole or in part, into printed or
machine readable form, in sufficient numbers only for backup or archival purposes, or to replace a worn or
defective copy.  However, You agree not to have more than two (2) copies of the Licensed Software in
whole or in part, including the original media, in your possession for said purposes without Extreme’s prior
written consent, and in no event shall You operate more copies of the Licensed Software than the specific
licenses granted to You.  You may not copy or reproduce the documentation.  You agree to maintain
appropriate records of the location of the original media and all copies of the Licensed Software, in whole
or in part, made by You.  You may modify the machine-readable form of the Licensed Software for (1)
your own internal use or (2) to merge the Licensed Software into other program material to form a
modular work for your own use, provided that such work remains modular, but on termination of this
Agreement, You are required to completely remove the Licensed Software from any such modular work. 
Any portion of the Licensed Software included in any such modular work shall be used only on a single
computer for internal purposes and shall remain subject to all the terms and conditions of this Agreement. 
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You agree to include any copyright or other proprietary notice set forth on the label of the media
embodying the Licensed Software on any copy of the Licensed Software in any form, in whole or in part,
or on any modification of the Licensed Software or any such modular work containing the Licensed
Software or any part thereof.

7. TITLE AND PROPRIETARY RIGHTS

a. The Licensed Materials are copyrighted works and are the sole and exclusive property of Extreme,
any company or a division thereof which Extreme controls or is controlled by, or which may result
from the merger or consolidation with Extreme (its "Affiliates"), and/or their suppliers.  This
Agreement conveys a limited right to operate the Licensed Materials and shall not be construed to
convey title to the Licensed Materials to You.  There are no implied rights.  You shall not sell, lease,
transfer, sublicense, dispose of, or otherwise make available the Licensed Materials or any portion
thereof, to any other party.

b. You further acknowledge that in the event of a breach of this Agreement, Extreme shall suffer severe
and irreparable damages for which monetary compensation alone will be inadequate.  You therefore
agree that in the event of a breach of this Agreement, Extreme shall be entitled to monetary
damages and its reasonable attorney’s fees and costs in enforcing this Agreement, as well as
injunctive relief to restrain such breach, in addition to any other remedies available to Extreme.

8. PROTECTION AND SECURITY.  In the performance of this Agreement or in contemplation thereof, You
and your employees and agents may have access to private or confidential information owned or
controlled by Extreme relating to the Licensed Materials supplied hereunder including, but not limited to,
product specifications and schematics, and such information may contain proprietary details and
disclosures.  All information and data so acquired by You or your employees or agents under this
Agreement or in contemplation hereof shall be and shall remain Extreme’s exclusive property, and You
shall use your best efforts (which in any event shall not be less than the efforts You take to ensure the
confidentiality of your own proprietary and other confidential information) to keep, and have your
employees and agents keep, any and all such information and data confidential, and shall not copy,
publish, or disclose it to others, without Extreme’s prior written approval, and shall return such
information and data to Extreme at its request.  Nothing herein shall limit your use or dissemination of
information not actually derived from Extreme or of information which has been or subsequently is made
public by Extreme, or a third party having authority to do so.
     You agree not to deliver or otherwise make available the Licensed Materials or any part thereof,
including without limitation the object or source code (if provided) of the Licensed Software, to any party
other than Extreme or its employees, except for purposes specifically related to your use of the Licensed
Software on a single computer as expressly provided in this Agreement, without the prior written consent
of Extreme.  You agree to use your best efforts and take all reasonable steps to safeguard the Licensed
Materials to ensure that no unauthorized personnel shall have access thereto and that no unauthorized
copy, publication, disclosure, or distribution, in whole or in part, in any form shall be made, and You agree
to notify Extreme of any unauthorized use thereof.  You acknowledge that the Licensed Materials contain
valuable confidential information and trade secrets, and that unauthorized use, copying and/or disclosure
thereof are harmful to Extreme or its Affiliates and/or its/their software suppliers.

9. MAINTENANCE AND UPDATES.  Updates and certain maintenance and support services, if any, shall be
provided to You pursuant to the terms of an Extreme Service and Maintenance Agreement, if Extreme
and You enter into such an agreement.  Except as specifically set forth in such agreement, Extreme shall
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not be under any obligation to provide Software Updates, modifications, or enhancements, or Software
maintenance and support services to You.

10. DEFAULT AND TERMINATION. In the event that You shall fail to keep, observe, or perform any obligation
under this Agreement, including a failure to pay any sums due to Extreme, or in the event that you
become insolvent or seek protection, voluntarily or involuntarily, under any bankruptcy law, Extreme may,
in addition to any other remedies it may have under law, terminate the License and any other agreements
between Extreme and You.

a. Immediately after any termination of the Agreement or if You have for any reason discontinued use
of Software, You shall return to Extreme the original and any copies of the Licensed Materials and
remove the Licensed Software from any modular works made pursuant to Section 3, and certify in
writing that through your best efforts and to the best of your knowledge the original and all copies
of the terminated or discontinued Licensed Materials have been returned to Extreme.

b. Sections 1, 7, 8, 10, 11, 12, 13, 14 and 15 shall survive termination of this Agreement for any reason.

11. EXPORT REQUIREMENTS.  You are advised that the Software is of United States origin and subject to
United States Export Administration Regulations; diversion contrary to United States law and regulation is
prohibited.  You agree not to directly or indirectly export, import or transmit the Software to any country,
end user or for any Use that is prohibited by applicable United States regulation or statute (including but
not limited to those countries embargoed from time to time by the United States government); or
contrary to the laws or regulations of any other governmental entity that has jurisdiction over such export,
import, transmission or Use.

12. UNITED STATES GOVERNMENT RESTRICTED RIGHTS.  The Licensed Materials  (i) were developed solely
at private expense; (ii) contain "restricted computer software" submitted with restricted rights in
accordance with section 52.227-19 (a) through (d) of the Commercial Computer Software-Restricted
Rights Clause and its successors, and (iii) in all respects is proprietary data belonging to Extreme and/or
its suppliers.  For Department of Defense units, the Licensed Materials are considered commercial
computer software in accordance with DFARS section 227.7202-3 and its successors, and use, duplication,
or disclosure by the U.S. Government is subject to restrictions set forth herein.

13. LIMITED WARRANTY AND LIMITATION OF LIABILITY.  The only warranty that Extreme makes to You in
connection with this license of the Licensed Materials is that if the media on which the Licensed Software
is recorded is defective, it will be replaced without charge, if Extreme in good faith determines that the
media and proof of payment of the license fee are returned to Extreme or the dealer from whom it was
obtained within ninety (90) days of the date of payment of the license fee.
NEITHER EXTREME NOR ITS AFFILIATES MAKE ANY OTHER WARRANTY OR REPRESENTATION,
EXPRESS OR IMPLIED, WITH RESPECT TO THE LICENSED MATERIALS, WHICH ARE LICENSED "AS IS". 
THE LIMITED WARRANTY AND REMEDY PROVIDED ABOVE ARE EXCLUSIVE AND IN LIEU OF ALL
OTHER WARRANTIES, INCLUDING IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE, WHICH ARE EXPRESSLY DISCLAIMED, AND STATEMENTS OR
REPRESENTATIONS MADE BY ANY OTHER PERSON OR FIRM ARE VOID.  ONLY TO THE EXTENT SUCH
EXCLUSION OF ANY IMPLIED WARRANTY IS NOT PERMITTED BY LAW, THE DURATION OF SUCH
IMPLIED WARRANTY IS LIMITED TO THE DURATION OF THE LIMITED WARRANTY SET FORTH ABOVE. 
YOU ASSUME ALL RISK AS TO THE QUALITY, FUNCTION AND PERFORMANCE OF THE LICENSED
MATERIALS.  IN NO EVENT WILL EXTREME OR ANY OTHER PARTY WHO HAS BEEN INVOLVED IN THE
CREATION, PRODUCTION OR DELIVERY OF THE LICENSED MATERIALS BE LIABLE FOR SPECIAL,
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DIRECT, INDIRECT, RELIANCE, INCIDENTAL OR CONSEQUENTIAL DAMAGES, INCLUDING LOSS OF
DATA OR PROFITS OR FOR INABILITY TO USE THE LICENSED MATERIALS, TO ANY PARTY EVEN IF
EXTREME OR SUCH OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  IN
NO EVENT SHALL EXTREME OR SUCH OTHER PARTY'S LIABILITY FOR ANY DAMAGES OR LOSS TO
YOU OR ANY OTHER PARTY EXCEED THE LICENSE FEE YOU PAID FOR THE LICENSED MATERIALS.
Some states do not allow limitations on how long an implied warranty lasts and some states do not allow
the exclusion or limitation of incidental or consequential damages, so the above limitation and exclusion
may not apply to You.  This limited warranty gives You specific legal rights, and You may also have other
rights which vary from state to state.

14. JURISDICTION.  The rights and obligations of the parties to this Agreement shall be governed and
construed in accordance with the laws and in the State and Federal courts of the State of California,
without regard to its rules with respect to choice of law.  You waive any objections to the personal
jurisdiction and venue of such courts. None of the 1980 United Nations Convention on the Limitation
Period in the International Sale of Goods, and the Uniform Computer Information Transactions Act shall
apply to this Agreement.

15. GENERAL.

a. This Agreement is the entire agreement between Extreme and You regarding the Licensed Materials,
and all prior agreements, representations, statements, and undertakings, oral or written, are hereby
expressly superseded and canceled.

b. This Agreement may not be changed or amended except in writing signed by both parties hereto.

c. You represent that You have full right and/or authorization to enter into this Agreement.

d. This Agreement shall not be assignable by You without the express written consent of Extreme. The
rights of Extreme and Your obligations under this Agreement shall inure to the benefit of Extreme’s
assignees, licensors, and licensees.

e. Section headings are for convenience only and shall not be considered in the interpretation of this
Agreement.

f. The provisions of the Agreement are severable and if any one or more of the provisions hereof are
judicially determined to be illegal or otherwise unenforceable, in whole or in part, the remaining
provisions of this Agreement shall nevertheless be binding on and enforceable by and between the
parties hereto.

g. Extreme’s waiver of any right shall not constitute waiver of that right in future.  This Agreement
constitutes the entire understanding between the parties with respect to the subject matter hereof,
and all prior agreements, representations, statements and undertakings, oral or written, are hereby
expressly superseded and canceled.  No purchase order shall supersede this Agreement.

h. Should You have any questions regarding this Agreement, You may contact Extreme at the address
set forth below.  Any notice or other communication to be sent to Extreme must be mailed by
certified mail to the following address:

Extreme Networks, Inc.
145 Rio Robles
San Jose, CA 95134 United States
ATTN: General Counsel



8 of 253

Table of Contents
ExtremeControl Guest and IoT Manager User Guide 1

Extreme Networks® Software License Agreement 3

Table of Contents 8

About this Document 24

Purpose 24

Conventions 24

Text Conventions 24

Documentation and Training 25

Training 26

Getting Help 26

Subscribing to Service Notifications 27

Providing Feedback to Us 27

New in this Document 28

Ability to Create Helpdesk Provisioners 28

Onboarding Template based on Vouchers 28

Onboarding Template based on CSV load of Devices 28

Onboarding Template based on CSV load of Users 28

Zero Touch Guest Access Feature 29

Added New Sections in Troubleshooting 29

Added New Command in the Command Line Interface 29

Guest and IoT Manager Overview 30

Guest and IoT Manager Application Framework 31

User Roles and Access Controls 31

Guest and IoT Manager Administrator Role 31

Provisioner Role 32

Guest Users Role 32

Launching Guest and IoT Manager 32



9 of 253

Administrator Home Screen 33

Provisioner Home Screen 33

Running the Administrator Application 34

Procedure 34

Running the Provisioner Application 34

Procedure 34

Using the Online Help System 35

Accessing Help 36

Help Features 36

SearchingWithin Topics 36

Installing Guest and IoT Manager 37

System Requirements 37

VMware ESXi Server Requirements 37

Preventing Automatic VMware Tools Updates 38

Procedure 38

Example 39

Checking the VMware Tools Status on an ESXi Server 39

Procedure 39

Network Configuration for Guest and IoT Manager — Based Authentication 40

Installing the Guest and IoT Manager Virtual Appliance 40

Procedure 41

Configuring the Guest and IoT Manager Virtual Appliance 47

Procedure 47

Ports Used In Guest and IoT Manager 48

Port Details 48

Administering Guest and IoT Manager 49

Configuring the Administrator Account 49

Changing the Administrator Password 49

Procedure 49

Field Descriptions 50



10 of 253

Setting Inactivity Timeouts 50

Procedure 51

Field Descriptions 51

Setting FQDN 51

Procedure 51

Field Descriptions 51

Setting Preferences 52

Customizing General Preferences 52

Procedure 52

Field Descriptions 53

Setting the Locales 53

Procedure 53

Field Descriptions 54

Configuring the File Manager 55

Procedure 55

Field Descriptions 56

Guest User Attributes 57

Configuring Terms of Use 58

Customize Provisioner Login Page 58

Procedure 58

Configuring Privacy Policy 59

Procedure 59

Procedure 60

Backup and Restore Configurations 61

Storing Backup Configuration 61

Procedure 62

Field Descriptions 62

Scheduling Backup 63

Procedure 63

Field Descriptions 64



11 of 253

Restoring Configuration 64

Procedure 64

Managing HTTPD Certificates 66

Adding a Certificate 66

Procedure 66

Field Descriptions 67

Adding a Key 67

Procedure 67

Field Descriptions 68

Binding a Certificate 68

Before you begin 69

Procedure 69

Field Descriptions 69

Binding a Chain 70

Before you begin 70

Procedure 70

Field Descriptions 71

Managing Access Control Engine 71

Configuring Engine Details 71

Procedure 71

Field Descriptions 72

Configuring RADIUS Settings 73

Procedure 73

Field Descriptions 74

Adding Root Certificate 74

Procedure 74

Field Descriptions 75

Viewing License Status 76

Setting Notification Parameters 77

Enabling E-mail Notification 78



12 of 253

Procedure 78

Field Descriptions 79

Configuring SMS Gateway / Provider 80

Adding SMS Gateway 81

Procedure 81

Field Descriptions 82

Adding SMS Provider 83

Before you begin 83

Procedure 83

Field Descriptions 85

Modifying SMS Gateways / Providers 85

Procedure 85

Restore to Default SMS Gateways 86

Procedure 86

Two-Way SMS Provider 87

Procedure 87

Field Descriptions 88

Housekeeping 88

Scheduling Housekeeping Tasks 89

Procedure 89

Field Descriptions 90

Troubleshooting 91

Viewing the Log Files 91

Procedure 91

Generating a Show Support File 92

Procedure 92

REST API 92

Configuring Onboarding Template 94

Creating an Onboarding Template 94

Before you begin 94



13 of 253

Procedure 94

Configuring the Common Details 95

Procedure 95

Field Descriptions 96

Configuring the Guest User Account Details 100

Before you begin 100

Procedure 100

Field Descriptions 102

Configuring Sponsor Approval 108

Before you begin 108

Procedure 108

Field Descriptions 109

Configuring the Device Record Details 111

Before you begin 111

Procedure 112

Field Descriptions 112

Configuring Device Type Groups 115

Before you begin 115

Procedure 115

Field Description 116

Configuring the Account Notification Templates 117

Configuring General Details 117

Procedure 117

Field Descriptions 118

Configuring Sponsor Email 121

Before you begin 121

Procedure 121

Field Descriptions 122

Configuring Sponsor Action 123

Before you begin 123



14 of 253

Procedure 123

Field Descriptions 124

Configuring Advanced Details 124

Procedure 125

Field Descriptions 125

Configuring Guest User Provisioning Using Outlook Add-in 126

Before you begin 126

Procedure 126

Field Descriptions 127

Configuring Guest User Provisioning Using Vouchers 131

Before you begin 131

Procedure 131

Field Descriptions 132

Configuring Guest User and Device Provisioning Using CSV 138

Before you begin 138

Procedure 138

Field Descriptions 139

Configuring Device Record Details 144

Procedure 144

Field Descriptions 144

Configuring Zero Touch Guest User Provisioning 148

Before you begin 148

Procedure 148

Managing Onboarding Templates 151

Procedure 151

Modifying and Viewing an Onboarding Template 151

Procedure 151

Copying an Onboarding Template 152

Procedure 153

Deleting Onboarding Templates and Guest Accounts 153



15 of 253

Procedure 153

Field Descriptions 153

Configuring Custom Attributes 154

Configuring Guest User Custom Attributes 154

Procedure 154

Field Descriptions 155

Configuring Device Custom Attributes 156

Procedure 156

Field Descriptions 156

Configuring Access Groups 157

Configuring Guest User Access Groups 158

Procedure 158

Field Descriptions 158

Configuring Device Access Groups 159

Procedure 159

Field Descriptions 159

Configuring Provisioners 161

Prerequisite for Provisioner Function 161

Internal Provisioner Operations 162

Creating an Internal Provisioner 162

Procedure 162

Field Descriptions 164

Modifying Internal Provisioner Account 165

Procedure 165

Field Descriptions 166

Filtering Internal Provisioners 166

Procedure 167

Field Descriptions 167

Configuring Self-Services 169

Configuring Self-Service Provisioners 169



16 of 253

Creating Self-Service Provisioners 169

Procedure 169

Field Descriptions 171

Modifying Self-Service Provisioners 173

Procedure 174

Field Descriptions 175

Viewing Self-Provisioning Services 177

Self Provisioning Services 177

Managing GuestUsers 178

Accessing Guest Users 178

Using Guest User Features 178

Procedure 178

Searching Specific Guest Users 180

Procedure 180

Managing Devices 183

Accessing Devices 183

Using Devices Features 183

Procedure 183

Searching Specific Devices 184

Procedure 184

Configuring Guest and Devices 187

Configuring Guests 187

Guest User Connections 188

Creating Guest User Account 188

Procedure 188

Field Descriptions 193

Modifying Guest User Account 197

Procedure 197

Finding Guest User Account 198

Procedure 198



17 of 253

Extending Expiry of Guest User Account 199

Procedure 199

Configuring Devices 200

Adding a Device Record 200

Procedure 201

Field Descriptions 203

Modifying Device Record 206

Procedure 206

Finding Device Records 207

Procedure 207

Field Descriptions 207

Extending Expiry of a Device 208

Procedure 208

Managing Sponsor Actions 209

Viewing and Providing Guest Access 210

Procedure 210

Using Self-Provisioning Services 214

Registering a New Guest User 214

Before you begin 214

Procedure 214

Sponsor Details 215

Procedure 215

Sponsor Details Field Descriptions 215

Registering New Devices 216

Before you begin 216

Procedure 216

Using Self-Service for Zero Touch Guest Access 216

Before you begin 217

Procedure 217

Guest and IoT Manager Add-In for Outlook 218



18 of 253

Installing Guest and IoT Manager Add-In 218

Before you begin 218

Procedure 218

GIM Add-In 220

Provisioning Guest Access 220

Procedure 220

Automated Login of the Guest User using the Login URL 226

Procedure 227

Troubleshooting and FAQs 229

Testing RADIUS Connection Settings 229

Procedure 229

Restarting Guest and IoT Manager 229

Procedure 229

Problem: Virtual Appliance Troubleshooting 229

Condition 229

Guest and IoT Manager URL is not Accessible 229

Guest and IoT Manager HTTPS is not using the Custom Certificate 230

Guest and IoT Manager CLI 230

Problem: Saving Access Control Engine Settings 230

Problem 230

Solution 230

Problem: User Groups / End System Group Not Visible in Guest and IoT Manager 230

Problem 230

Solution 230

Problem: Provisioner Cannot Login 231

Problem 231

Solution 231

Problem 231

Solution 231

Problem 231



19 of 253

Solution 232

Problem 232

Solution 232

Problem: Guest and IoT Manager Email / SMS Notification Failed 232

Problem 232

Solution 232

Problem: Unable to Access Guest and IoT Manager Application URL 233

Problem 233

Solution 233

Problem: User and Device Troubleshooting 233

Problem 233

Solution 233

Problem 233

Solution 234

Problem: Sponsor List is Not Available 234

Problem 234

Solution 234

Problem: Modification in Network Interface settings does not reflect post deployment 234

Problem 234

Solution 234

Problem: Outlook Add-in Issues 234

Problem 234

Solution 234

Problem 235

Solution 235

Problem: Service Unavailable in Browser 235

Problem 235

Solution 235

Problem: Time Zone Issues for Schedule Tasks 235

Problem 235



20 of 253

Solution 235

Problem: Users/Devices are not getting cleaned up for Housekeeping Tasks 236

Problem 236

Solution 236

Problem: Unable to Access GIM UI 236

Problem 236

Solution 236

Problem: LDAP Provisioner login fails 237

Problem 237

Solution 237

Problem: LDAP Sponsors are not populating in the Self-Service Page 237

Problem 237

Solution 237

Problem: Server Error during bulk creation 237

Problem 237

Solution 238

Problem: Unable to Renew Password 238

Problem 238

Solution 238

Problem: Guest User account is not created post sending SMS 238

Problem 238

Solution 238

Problem: Login URL redirects to Captive Portal 239

Problem 239

Solution 239

Problem: “Server Error. Please contact Administrator" Error message on clicking Login
URL 240

Problem 240

Solution 240

Problem: FQDN not being used in URLs 240



21 of 253

Problem 240

Solution 241

Problem: Unable to Customize Provisioner Login page 241

Problem 241

Solution 241

Problem: "Login failed. Invalid credentials/Account Expired” message on clicking Login
URL 241

Problem 241

Solution 242

Problem: Outlook Add-in throws Security Exception post enabling FQDN 242

Problem 242

Solution 242

Command Line Interface 243

certificate 243

Syntax 243

Example 243

clear 243

Syntax 243

Example 244

dns 244

Syntax 244

Example 244

exit 244

Syntax 244

halt 245

Syntax 245

help 245

Syntax 245

Example 245

interface 245



22 of 253

Syntax 246

Example 246

interface hostname 246

Syntax 246

Example 246

ping 247

Syntax 247

Example 247

reboot 247

Syntax 247

reinit 247

Syntax 247

route 248

Syntax 248

Example 248

show certificates 248

Syntax 248

Example 249

show dns 249

Example 249

show interface 249

Syntax 249

Example 250

show route 250

Syntax 250

Example 250

show timezone 250

Syntax 250

Example 251

sshd 251



23 of 253

Syntax 251

Example 251

timezone 251

Syntax 251

Example 252

tomcat 252

Syntax 252

Example 252

user 253

Syntax 253

Example 253



Purpose

24 of 253

About this Document
This chapter provides basic background information that sets the support information of the
document into its perception.

Purpose
Guest and IoT Manager provides a simple and personalized web user interface through which an
operational team can quickly and securely manage visitor network access.

It is intended for system administrators who will be installing, managing, and configuring the
Guest and IoT Manager application.

Conventions
This section discusses the conventions used in this guide.

Text Conventions
The following tables list text conventions that can be used throughout this document.

Icon Alerts you to...

Important: Key information that does not carry with it the risk of personal injury,
death, system failure, service interruption, loss of data, damage to
equipment, or electrostatic discharge.

Note: Important features or instructions.

Tip: Helpful tips and notices for using the product.

Warning: A potential hazard exists that, if not avoided, can result in harm to
hardware or equipment.

Caution: Practices that are not safe or are potential hazards not covered by danger
or warning messages.

Table 1. Notice Icons
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Convention Description

Angle brackets
( < > )

Angle brackets ( < > ) indicate that you choose the text to enter based on the
description inside the brackets. Do not type the brackets when you enter the
command.

If the command syntax is cfm maintenance-domain maintenance-
level <0-7>, you can enter cfm maintenance-domain maintenance-
level 4.

Bold text Bold text indicates the GUI object name you must act upon.

Examples:

l Click OK.

l On the Tools menu, choose Options.

Italic Text Italics emphasize a point or denote new terms at the place where they are defined in
the text. Italics are also used when referring to publication titles that are not active
links.

Plain
Courier
Text

Plain Courier text indicates command names, options, and text that you must enter.
Plain Courier text also indicates command syntax and system output, for example,
prompts and system messages.

Examples:

l show ip route

l Error: Invalid command syntax [Failed][2018-09-12
13:37:03.303 -04:00]

Separator ( > ) A greater than sign ( > ) shows separation in menu paths.

For example, in the Navigation tree, expand the Configuration > Edit
folders.

Table 2. Text Conventions

Documentation and Training

Extreme Networks product guides, visit our documentation pages at:

Current Product Documentation www.extremenetworks.com/documentation/

Archived Documentation (for earlier
versions and legacy products)

www.extremenetworks.com/support/documentation-archives/

Release Notes www.extremenetworks.com/support/release-notes

http://www.extremenetworks.com/documentation/
http://www.extremenetworks.com/support/documentation-archives/
http://www.extremenetworks.com/support/release-notes/
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Hardware/Software Compatibility
Matrices

https://www.extremenetworks.com/support/compatibility-
matrices/

White papers, data sheets, case
studies, and other product resources

https://www.extremenetworks.com/resources/

Training
Extreme Networks offers product training courses, both online and in person, as well as
specialized certifications. For more information, visit www.extremenetworks.com/education/.

Getting Help
If you require assistance, contact Extreme Networks using one of the following methods:

Extreme Portal

Search the GTAC (Global Technical Assistance
Center) knowledge base, manage support cases
and service contracts, download software, and
obtain product licensing, training, and
certifications.

The Hub

Search the GTAC (Global Technical Assistance
Center) knowledge base, manage support cases
and service contracts, download software, and
obtain product licensing, training, and
certifications.

Call GTAC

For immediate support: 1-800-998-2408 (toll-free in U.S.
and Canada) or +1 408-579-2826. For the support phone
number in your country, visit:
www.extremenetworks.com/support/contact

Before contacting Extreme Networks for technical support, have the following information
ready:

l Your Extreme Networks service contract number and/or serial numbers for all involved Extreme
Networks products

l A description of the failure

l A description of any action(s) already taken to resolve the problem

l A description of your network environment (such as layout, cable type, other relevant environmental
information)

https://www.extremenetworks.com/support/compatibility-matrices/
https://www.extremenetworks.com/support/compatibility-matrices/
https://www.extremenetworks.com/resources/
http://www.extremenetworks.com/education/
https://extremeportal.force.com/ExtrSupportHome
https://community.extremenetworks.com/
http://www.extremenetworks.com/support/contact
http://www.extremenetworks.com/support/contact
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l Network load at the time of trouble (if known)

l The device history (for example, if you have returned the device before, or if this is a recurring problem)

l Any related RMA (Return Material Authorization) numbers

Subscribing to Service Notifications
You can subscribe to email notifications for product and software release announcements,
Vulnerability Notices, and Service Notifications.

1. Go to www.extremenetworks.com/support/service-notification-form.

2. Complete the form with your information (all fields are required).

3. Select the products for which you would like to receive notifications.

Note:

You can modify your product selections or unsubscribe at any time.

4. Click Submit.

Providing Feedback to Us
Extreme Networks, and we have made every effort to ensure the accuracy and completeness of
this document. We are always striving to improve our documentation and help you work better,
so we want to hear from you! We welcome all feedback but especially want to know about:

l Content errors or confusing or conflicting information.

l Ideas for improvements to our documentation so you can find the information you need faster.

l Broken links or usability issues.

If you would like to provide feedback to the Extreme Networks Information Development team,
you can do so in two ways:

l Use our short online feedback form at https://www.extremenetworks.com/documentation-feedback/.

l Email us at documentation@extremenetworks.com.

Please provide the publication title, part number, and as much detail as possible, including the
topic heading and page number if applicable, as well as your suggestions for improvement.

http://www.extremenetworks.com/support/service-notification-form
https://www.extremenetworks.com/documentation-feedback/
mailto:documentation@extremenetworks.com
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New in this Document
The following sections detail what is new in this document.

Ability to Create Helpdesk Provisioners
A Helpdesk Provisioner provides a Provisioner user with the ability to view and edit all the Guest
user and Device records of the Onboarding Templates to which they are assigned. Helpdesk
Provisioners can add records of assigned Onboarding Templates; edit, delete and extend user
expiration; and perform resend password, resend details, renew password, and print operations
on accessible records.

In order to support this feature, the Show and Onboarding Template drop-down lists are
available in the Guest Users and Devices tabs in the Provisioners application, allowing you to
filter content based on the Provisioner or Onboarding template. The Provisioned by field is no
longer available.

Onboarding Template based on Vouchers
The Voucher Type Onboarding Template allows creation of many Guest User accounts in Guest
and IoT Manager by specifying the number of Vouchers to be generated with a random
username and password.

For more information, see Configuring the Common Details , and Creating Guest User Account
using Vouchers.

Onboarding Template based on CSV load of Devices
The CSV Type Onboarding Template allows uploading a CSV file to onboard many devices in a
single go. The name of the device and MAC address are needed to be input from the file and the
rest of the fields as specified during the creation process is like the existing process of adding a
device to the Guest and IoT Manager.

For more information, see Configuring the Common Details, Configuring the Guest User
Account Details, and Configuring Guest User and Device Provisioning Using CSV.

Onboarding Template based on CSV load of Users
The CSV Type Onboarding Template allows creation of many Guest User accounts in Guest and
IoT Manager by uploading a CSV file. The fields to be entered by the CSV file are first name, last
name email and mobile number.

../../../../../Content/GIM Configuration/Topics/ConfiguringtheCommonDetails.html
../../../../../Content/GIM Configuration/Topics/CreatingGuestUserAccountUsingVouchers.html
../../../../../Content/GIM Configuration/Topics/CreatingGuestUserAccountUsingVouchers.html
../../../../../Content/GIM Configuration/Topics/ConfiguringtheGuestUserAccountDetails.html
../../../../../Content/GIM Configuration/Topics/ConfiguringtheGuestUserAccountDetails.html
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For more information, see Configuring the Common Details, Configuring the Guest User
Account Details, and Configuring Guest User and Device Provisioning Using CSV.

Zero Touch Guest Access Feature
The Zero-Touch feature is introduced in this release. The Guest Users can now create their own
Guest User Acount using Self-Provisioning Services.

For more information see, Automated Login of the Guest User using the Login URL .

Added New Sections in Troubleshooting
For more information see the following:

l Problem: Unable to Renew Password

l Problem: Guest User account is not created post sending SMS

l Problem: Login URL redirects to Captive Portal

l Problem: “Server Error. Please contact Administrator" Error message on clicking Login
URL

l Problem: FQDN not being used in URLs

l Problem: Unable to Customize Provisioner Login page

l Problem: "Login failed. Invalid credentials/Account Expired” message on clicking Login URL

l Problem: Outlook Add-in throws Security Exception post enabling FQDN

Added New Command in the Command Line Interface
Added new command interface hostname. For more information see, interface hostname.

../../../../../Content/GIM Configuration/Topics/ConfiguringtheGuestUserAccountDetails.html
../../../../../Content/GIM Configuration/Topics/ConfiguringtheGuestUserAccountDetails.html
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Guest and IoT Manager Overview
Welcome to the ExtremeControl Guest and IoT Manager Web Application! The Guest and IoT
Manager (GIM) is an application that integrates with ExtremeControl. The purpose is to provide
non-IT personnel with the ability to provision Guest Users and / or Devices within the constrains
defined by the Administrator. Guest and IoT Manager communicates with the ExtremeControl
Engine(s) for provisioning of Guest Users and Devices that may access the network through
standard process of authentication and authorization by ExtremeControl.

Guest and IoT Manager allows the Administrator to perform the following:

l Create and customize Onboarding Templates for Guest Users and Devices.

l Create Internal Provisioners.

l Assign one or more Onboarding Templates to Internal or External Provisioners
Provisioners (Provisioners on AD / LDAP)

l Enable and customize Guest and IoT Manager REST APIs for integration with third party
applications.

l Enable and customize Guest and IoT Manager Outlook Plug-in.

Furthermore, Guest and IoT Manager allows the Provisioners to use the Onboarding Template
(s) and provision Guest User and / or Devices based on their customized constrains.
Provisioners may be:

l External Provisioners : They can be Employees or Students that reside on an AD or LDAP
server.

l Internal Provisioners : These are created by the Administrator and are Business Partners,
Vendors, Suppliers, Contractors, Front Desk Personal, Security Guards and so on.

The Guest and IoT Manager Administrator and the Provisioner have different splash login pages.
When the Provisioner logs in;

l In case of external Provisioner, authentication happens by the Extreme Control engine
against AD / LDAP.

l While in case of an Internal Provisioner it is against the Local Repository.

Once the Provisioner logs in, then the Provisioner has access to the Onboarding Templates that
the Administrator has provided and is able to provision Guest User and / or Devices.

The Guest and IoT Manager Overview chapter provides information on the following:

l Guest and IoT Manager Application Framework

l User Roles and Access Controls

l Launching Guest and IoT Manager

l Using the Online Help System

../../../../../Content/GIM Configuration/Topics/GIMApplicationFramework.html
../../../../../Content/GIM Configuration/Topics/UserRolesAndAccessControls.html
../../../../../Content/GIM Configuration/Topics/LaunchingGuestAndIoTManager.html
../../../../../Content/GIM Configuration/Topics/UsingTheOnlineHelpSystem.html
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Guest and IoT Manager Application Framework
The ExtremeCloud IQ - Site Engine portfolio system for provisioning and managing guest
network access consists of the following components:

l Guest and IoT Manager Administrator Application for managing provisioners and for
performing bulk updates of Guests and Devices.

l Guest and IoT Manager Provisioner Application for managing Guests and Devices.

l Access Control Engine that authenticates and authorizes users who desire to connect to
your network.

l ExtremeCloud IQ - Site Engine Application to create the authorization policies that
determine which users can connect to specific parts of your network.

l (Optionally) ExtremeCloud IQ - Site Engine Captive Portal : The web-based
authentication helps users connect their “Bring Your Own Device” (BYOD) devices to
enterprise network even though if it is not equipped with 802.1X authentication software.

User Roles and Access Controls
Roles are an important concept in the Guest and IoT Manager application. Roles determine what
users can view or perform, including what they can monitor and the types of changes they can
make. Parts of the UI features are not available to users whose role does not authorize access to
those features. The Guest and IoT Manager application facilitates the following user roles.

The three roles defined with different access control in the system are:

l Guest and IoT Manager Administrator Role

l Provisioner Role

l Guest Users Role

Guest and IoT Manager Administrator Role
The Guest and IoT Manager Application has single Administrator account. The Administrator of
this account can set / modify access rights such as Username, Password, delete Guest User
accounts, Device records and can also perform the following actions.

l Create the Onboarding Template.

l Configure application settings.

l Create and manage the Provisioner accounts. Each account has its own Username and
Password.

../../../../../Content/GIM Configuration/Topics/GIMAdministratorRole.html
../../../../../Content/GIM Configuration/Topics/ProvisionerRole.html
../../../../../Content/GIM Configuration/Topics/GuestUsersRole.html
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l Connect the application to the ExtremeCloud IQ - Site Engine appliance. The
Administrator must ensure that the connection is stable for the Provisioners to use it.

l Manage Guest User accounts and Device records to remove the expired user accounts.

Provisioner Role
The Provisioner uses the Guest and IoT Manager application to manage Guest Users and
Devices that they have created.

Each provisioner account is stored either in the Local Password Repository (LPR) internal store
or in Lightweight Directory Access Protocol (LDAP).

Important:
Guest Users and Devices onboarded by the Provisioner can only be managed from Guest
and IoT Manager.

Guest Users Role
A Guest User is a visitor or other temporary user to whom you grant specific limited rights to
use the network. A Provisioner uses the Guest and IoT Manager Application to create any
number of Guest User accounts. Guest User accounts are stored in Local Password Repository
(LPR).

The created Guest User account contains the following attributes:

l Account Details: Includes Username and Password for the temporary account.

l Personal Data: Includes first name, last name, email address, and mobile number of the
User.

l Access Duration: Specifies the account activation time for network access usage and the
duration.

l Auto Expiry Deletion: Removes the Guest Users automatically after the specified duration.

l Notification Settings: Sends an Email or SMS notification stating that the Guest account
has been created. The notification contains the Guest User's Name and Password and is
usually sent directly to the Guest.

Launching Guest and IoT Manager
The Access Control Engine settings must be configured prior launching the Guest and IoT
Manager application for the first time. For more information, see the ExtremeControl Guest and
IoT Manager Configuration document.

Guest and IoT Manager consists of two applications:
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l Administrator Application: The Application that the Administrator uses to configure
Guest and IoT Manager to create Provisioner(s) and Self-Service accounts.

l Provisioner Application: The Application that Provisioners use to create Guest Users and
Devices.

Administrator Home Screen

When Administrator logs into Guest and IoT Manager Web UI, the Last Successful Login, date,
time, and the number of Failed Login Attempts between two successful logins of the
Administrator account are displayed on the footer of the page.

Note:
You can also change the password after your first login. For more information,
see the ExtremeControl Guest and IoT Manager Configuration document.

Provisioner Home Screen

The Onboarding Template associated with the logged in Provisioner is displayed in the Home
screen.
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Running the Administrator Application
Use this procedure to launch the Administrator Application.

Procedure

1. Open your web browser and enter the URL of the Administrator Application.

http://<Guest Manager machine>/GIM/admin/

OR

https://<Guest Manager machine>/GIM/admin/

2. In the Login screen, enter the Administrator login credentials.

3. Click Login.

a. If the login attempt succeeds, the Application displays the successful message: You have
successfully signed in as <UserName>.

b. If your login attempt fails, the Application displays an alert message.

4. (Optional) Click Download GIM Outlook Add-In to configure an outlook add-in to a Windows or MAC
machine.

Note: The Administrator web session disconnects, if it is inactive
for a period of time as specified in the inactive time-out
settings. You need to login again to use the Application.
For more information about how to configure the
administrator account,see the ExtremeControl Guest and
IoT Manager Configuration document.

5. Click close[x] to accept and close the cookie policy information displayed at the end of the login screen.
Click the hyperlink to view the organization Privacy and Cookies Policy as specified in the Administrator
Preference settings.

Running the Provisioner Application
Use this procedure to launch the Provisioner Application.

Procedure

1. Open your web browser and enter the URL of the Provisioner Application.

http://<Guest Manager machine>/GIM/provisioner/

OR
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https://<Guest Manager machine>/GIM/provisioner/

2. In the Login screen, enter the Provisioner login credentials.

Provisioner can be LPR user or LDAP user.

Note:
If you do not have a Provisioner account, contact Guest and IoT Manager
Administrator.

3. Click Login.

1. If the login attempt succeeds, the Application displays the successful message: You have
successfully signed in as <UserName>.

2. If your login attempt fails, the Application displays an alert message.

4. (Optional) Click Download GIM Outlook Add-In to configure an outlook add-in to a Windows or MAC
machine.

For more information on the GIM Outlook Add-In, see the ExtremeControl Guest and IoT
Manager Configuration document.

Note:

The Provisioner Application session disconnects, if
it is inactive for a period of time as specified in the
inactive time-out settings.

The Guest and IoT Manager Administrator sets the
time-out threshold limit. You need to login again to
use the Application.

For more information about setting the inactivity
timeouts, see the ExtremeControl Guest and IoT
Manager Configuration document.

Provisioner login associated with REST API
Onboarding Template and Outlook Add-in
Onboarding Template cannot create new Guest
User or Device. Only view option is available.

5. Click close[x] to accept and close the cookie policy information displayed at the end of the login screen.
Click the hyperlink to view the organization Privacy and Cookies Policy as specified in the Administrator
settings.

Using the Online Help System
The Guest and IoT Manager documentation is available as online help within the Application.

Important: The menu icon at the top right corner of the screen provides links to additional
information about your application.
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Accessing Help

There are several ways to access the online help system:

l Select the Help icon in the top right corner of your browser.

l Press F1 or Fn + F1 on the keyboard to open the Help to the context-sensitive topic
associated with the screen or dialog box you are using in the Application.

Help Features

The help is context-sensitive and as such, the topic displayed in the right panel changes as you
navigate. To prevent the help topic from changing when you change screens in the Application,

click the Pause icon at the top of the help screen. Click Resume icon to resume the help.

To open the help in a separate tab, click the Launch Help icon. The left panel contains the
Table of Contents. Items with a > indicate that clicking the TOC item opens another menu of
options.

The Help toolbar also contains buttons to search all topics. Use the Search tab to search for a
word or phrase in the help. In the Search for box type the word or combination of words you
want to find, and click Search. The topics that contain the word or words you entered is
displayed. Click the topic to be displayed in the topic pane.

SearchingWithin Topics

To search for specific instances of a term in only the currently accessed help topic, type Ctrl + F
to open your browser's search box. Use this to search for the term or phrase in the currently
accessed help topic.
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Installing Guest and IoT Manager
This chapter describes how to install Guest and IoT Manager Application. You can install Guest
and IoT Manager as a virtual appliance on a VMware ESXi 5.5, 6.0 or 6.5 server.

System Requirements
To install and configure Guest and IoT Manager Application, you need:

l A running Access Control Engine, reachable on the network from where you run Guest and IoT Manager.

l A system that meets the requirements listed in the Release Notes.

l An OVA file, if you are deploying the Guest and IoT Manager in ESXi.

l An installation of the ExtremeCloud IQ - Site Engine application on the system.

VMware ESXi Server Requirements
Hardware platforms supported by VMware's ESXi server versions 5.5, 6.0 or 6.5. For more
information on list of supported hardware platforms for ESXi, see http://www.vmware.com/

See the Release Notes for information about release-specific Guest and IoT Manager VM
minimum system requirements (memory, CPU, disk space, interfaces).

Installation on a VMware ESXi server is done using an OVA file that uses Ubuntu as base
Operating System.

https://emc.extremenetworks.com/content/common/releasenotes/release_notes/suite_release_notes.html#GuestandIoTManagerRequirements
https://emc.extremenetworks.com/content/oneview/install/suite_install.html
http://www.vmware.com/
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Warning: Guest and IoT Manager is provided as a Virtual Appliance. Do not
install or configure any other software on the VM shipped.

l Extreme Networks does not support the installation of any
VMware specific, UNIX specific, or any third-party vendor
package or RPM on its VM, other than what Extreme
Networks ships as a package, image, or OVA.

l Do not install or uninstall any software components unless
Extreme Networks specifically provides the software and / or
instructs you to do so. Do not modify the configuration or the
properties of any software components of the VMs (including
VMware Tools) unless Extreme Networks documentation and
/ or personnel specifically instructs you to do so. We do not
support any deviation from these guidelines.

l Extreme Networks determines which VMware Tools to install
and configure. When required, Extreme Networks provides
these tools as part of the installation package. Extreme
Networks provides these tools because VMware Tools
configures the kernel and network settings and unless
Extreme Networks tests and approves these tools, We cannot
guarantee that the VM works after the tool is installed and
configured.

Turn off automatic VMware Tools updates if you have enabled them. Refer to the following
instructions to disable automatic updates.

Preventing Automatic VMware Tools Updates

We strongly recommend you to prevent automatic VMware Tool updates and use only the tools
that are delivered bundled with the installation package. Use this procedure to prevent
automatic VMware Tools updates.

Use this procedure to prevent automatic VMware Tools updates.

Procedure

1. Use the vSphere client to log in to the ESXi Server.

2. Go to Getting Started > Edit Virtual Machine Settings > Options > VMware Tools > Advanced, and
ensure that the Check and upgrade Tools during power cycling checkbox is not selected. This is the
supported setting.

3. Click OK.
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Example

Checking the VMware Tools Status on an ESXi Server

The Summary tab of the VM describes the VMware Tools status. Use this procedure to check
the VMware Tools status on an ESXi server versions 5.5, 6.0 or 6.5.

Procedure

1. Use the vSphere client to log in to the ESXi Server.

2. Go to the Summary tab.

After a fresh install, the VMware Tools status displays as “VMware Tools: Running
(Current)”.
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Note: VMware Tools may show as not installed. This is a known
VMware issue where VMware Tools may not be detected
correctly on certain hardware. However, this does not
interfere with the functioning of the tools. It is a display issue
only.

Network Configuration for Guest and IoT Manager — Based
Authentication
Guest and IoT Manager has three network interfaces:

l Admin: The Admin interface provides connectivity to the Guest and IoT Manager
Administrator and Provisioner web sessions. By default, this interface is also used for
handling the connection with Access Control Engine.

l Service A: Depending on the network deployment, Access Control Engine can be in a
separate network. You can use Service A exclusively for handling the connection with
Access Control Engine (use interface and route commands).

l Service B: This is for future use.

Installing the Guest and IoT Manager Virtual Appliance
We strongly recommend that you use VMware vSphere Client to import the VM into your
system. Start the VMware vSphere Client and log in to the ESXi server on which you want to
install Guest and IoT Manager. Use the Virtual Appliance Deploy OVF option.
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Procedure

1. From the VSphere Client, select File > Deploy OVF Template.

2. On the Source screen, select the location from which you want to import the Guest and IoT Manager
virtual appliance and click Next.
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3. On the OVF Template Details screen, review your settings. Click Back to make changes, or click Next to
continue.
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4. On the End User License Agreement screen, click Accept to accept the license and click Next.
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5. On the Name and Location screen, enter a name for the virtual machine and click Next.

6. On the Disk Format screen, select a format in which to store the virtual machine’s virtual disks and click
Next.

We recommend to use Thin Provision mode.



System Requirements

45 of 253

7. On the Network Mapping screen, associate the Guest and IoT Manager network interfaces to the correct
VM network, based on your site configuration.

While Deploying

GIM-OVA in ESXI

GIM Interfaces

Internal Mapping

ESXI Interface

after Deployment

(Edit Settings)

Interface Inside
Console

NAT Admin Network Adapter 1 ens33

Internal Service B Network Adapter 3 ens35

Host-Only Service A Network Adapter 2 ens34
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8. On the Ready to Complete screen, review your settings. Use the Back button to make any changes or
click Finish to start the import.
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Configuring the Guest and IoT Manager Virtual Appliance
Use this procedure to configure the VM settings after you complete importing the VM to your
system. This is the minimum configuration required to start Guest and IoT Manager Application.

Procedure

1. Power on the VM and launch the Guest and IoT Manager console. Enter the User Name and Password.
The default User Name and Password is admin. The Guest and IoT Manager login screen is displayed.

2. Enter the hostname only (no domain) fot the Guest and IoT Manager GIM admin interface.

[Default: GIM]: gimappliance

3. Enter the IP address for Guest and IoT Manager administrator interface.

[Default: 192.168.220.5]: 10.133.133.143

4. Enter the IP netmask for Guest and IoT Manager.

[Default: 24]:

5. Enter the gateway address.

[Default: 10.133.133.1]:

6. Enter the Primary DNS address.

[Default: 192.168.220.5]: 134.141.162.20.

You will receive the status message as "Please wait while the configuration is set...".

Once completed, you will view the status as:

l "Generating new self-signed certificates for IP 10.133.133.143. Tomcat restart
completed successfully.

l Restarting the web services to listen on the new IP Address.

l Please verify the route setting using the "route command".

l Changing the DNS Setting. Tomcat restart completed successfully.

7. Enter the Domain name for GIM machine.

[Default: localdomain]: extremenetworks.com
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8. To continue setup of Guest and IoT Manager, open a browser to the following URL: https://<IP
address of GIM>/GIM/admin/. Use admin as the username and password to login and continue
the setup procedures as listed in the following sections.

9. Once the user has completed the procedures mentioned above, follow the steps from Guest and IoT
Manager Configuration inExtremeCloud IQ - Site Engine and Access Control in Extreme Control User
Guide. For more information, see
https://emc.extremenetworks.com/content/oneview/docs/network/docs/t_ht_gim_config.htm.

Ports Used In Guest and IoT Manager
This section contains information about used in Guest and IoT Manager.

Port Details

Use the data in the following table to use the ports for Guest and IoT Manager.

Port Description

25 This port is used for SMTP/SMS.

53 This port is used for DNS resolution.

443 This port is used for Guest and IoT Manager web GUI access for the
Administrator / Provisioners.

1812 This port is used for RADIUS.

1813 This port is used for RADIUS Accounting.

8444 This port is used as the default port for REST. However, this port can be
changed by the Administrator.

https://emc.extremenetworks.com/content/oneview/docs/network/docs/t_ht_gim_config.htm
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Administering Guest and IoT Manager
This module is intended for Guest and IoT Manager Administrator and describes how to manage
and troubleshoot the Application and its components.

If you are a Provisioner, you may skip this module and proceed to Configuring Onboarding
Template.

Configuring the Administrator Account
The Account tab in Administration menu allows you to modify the password and timeout values
for Administration, Provisioner, and Outlook sessions.

Changing the Administrator Password
Use this procedure to change the password of the Guest and IoT Manager Administrator.

Procedure

1. In the navigation pane, click Administration > Account tab.

2. In the Administrator section, select Change Password to modify the existing password details.

3. Enter the details in Current Password, New Password and Confirm New Password fields. The timeout for
administrator is from the ExtremeCloud IQ - Site Engine but the rest are from the Guest and IoT

../../../../../Content/GIM Configuration/Topics/ConfiguringOnboardingTemplate.html
../../../../../Content/GIM Configuration/Topics/ConfiguringOnboardingTemplate.html
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Manager (GIM) application.

4. Click Save to submit the configuration.

Field Descriptions

Use the data in the following table to use the Administrator section.

Name Description

Username By default, the Username field is disabled.

Current Password Specifies the current password that is used to login the Guest and IoT
Manager Application.

New Password and
Confirm New Password

Configures a new password for the Administrator account. The Guest and
IoT Manager encrypts the password. The new password must meet the
following complexity checks:

l Ensure that you use minimum of eight characters in the
password.

l Password must be a combination of Lowercase,
Uppercase, One Number, and at least one Special
character from the following:

! @ # $ % ^ & * ( ) - +

l New password cannot match the three recently used
passwords.

If the password does not meet the complexity criteria, the
system displays an error message.

Note: We recommend that you change the
Administrator password after you have completed
the initial setup of Guest and IoT Manager
Application.

Setting Inactivity Timeouts
Use this procedure to modify the timeout values for Administration, Provisioner and Outlook
sessions.
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Procedure

1. In the navigation pane, click Administration > Account tab.

2. In the Inactivity Timeout section, modify the duration and select the duration units from the Idle Timeout
and Outlook Idle Timeout drop-down list.

3. Click Save to save the configuration.

Field Descriptions

Use the data in the following table to use the Inactivity Timeout section.

Name Description

Admin Idle
Timeout

Displays the time-out configured in ExtremeCloud IQ - Site Engine. The timeout for
administrator is from ExtremeCloud IQ - Site Engine but the rest are from the Guest
and IoT Manager (GIM) application.

Provisioner Idle
Timeout

Configures the idle time-out period. The time-out period disconnects the Provisioner
Application after a period of inactivity that exceeds the applicable threshold. You
must log in again to use the application with the new changes.

The default time-out period is 30 minutes and the maximum period is 24
hrs.

Outlook Idle
Timeout

Configures the idle time-out period for Outlook. The time-out period disconnects the
Outlook Application after a period of inactivity that exceeds the applicable threshold.
You must log in again to use the application with the new changes.

The default time-out period and the maximum period is 24 hours.

Setting FQDN
Use this procedure to enable FQDN.

Procedure

1. In the navigation pane, click Administration > Account tab.

2. In the FQDN section, select the Use Fully Qualified Domain Name field to use FQDN instead of IP address
for the Guest and IoT Manager (GIM) application

Note:Ensure hostname and domain name is configured properly for FQDN to work.

Click Save to save the configuration.

Field Descriptions

Use the data in the following table to use the FQDN section.
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Name Description

Use Fully
Qualified
Domain
Name

Configures the Fully Qualified Domain Name to be used instead of IP
address for the Guest and IoT Manager (GIM) application.

Note: The hostname and domain name must be configured properly for
FQDN to work.

Setting Preferences
The Preferences tab in Administration menu allows you to customize the User Interface to fit
your personal preferences like changing the application logo, name, language, file manager,
terms of use and privacy policy information. You can use these settings to brand the
application's look and feel as per the requirement.

Customizing General Preferences
Use this procedure to modify the logo and application name.

Procedure

1. In the navigation pane, click Administration > Preferences tab.

By default, the Look and Feel screen is displayed along with the current logo used in the
application.

2. In the General section, configure the Logo, URL and Name as following:

1. Click Browse to navigate to the file you wish to upload in the Change Logo field, when the
navigation toolbar is expanded / collapsed.
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2. Optional: Enter the specified URL address in the Logo URL field.

3. Enter the application name that you want to change in the Application Name field.

3. Click Save to save the configuration or Restore to Defaults to cancel the changes and restore to default
value.

Field Descriptions

Use the data in the following table to use the General section.

Name Description

Current Logos Displays default or currentthe ly configured logo.

Change Logos Navigates to the file you prefer to upload when navigation toolbar is expanded or
collapsed.

Note:
The height and width of the expanded logo must be 210 * 45 pixels
and collapsed logo must be 50 * 45 pixels.

Logo URL Configures the URL to the Logo button. You can access the specified link in a new
window when you click on the Logo.

Application
Name

Customize the name of the Guest and IoT Manager application.

Setting the Locales
Use this procedure to change the language preference of the Application.

Note: This setting applies to only Provisioner, Self-Service and Outlook Add In Provisioner.
The Provisioner has to login again to view the modified changes.

Procedure

1. In the navigation pane, click Administration > Preferences tab.

2. In the Locales section, click Add.

The Add Locale screen is displayed.
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3. In the Add Locale screen, select the required language preference from the Language field drop-down
list and click Save. The selected language preference is added to the list.

4. Select the required language and click Set as Default. The selected language is displayed as default
language during Provisioner login.

5. (Optional) Select the required language(s) and click Delete to clear the added language.
The default language cannot be removed. Use Ctrl / Shift to select multiple records to delete.

6. Click Save to save the configuration or Restore to Defaults to cancel the changes and restore to default
value.

Field Descriptions

Use the data in the following table to use the Locales section.
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Name Description

Language Displays the preferred language in which you want the application to be displayed for
the Provisioner. Currently, the Guest and IoT Manager application is available in the
following languages: English, French, German, Spanish, Italian, Portuguese, Swedish,
Dutch, and Russian.

Administrator can select a maximum of five languages including default
language and also select any one of the five languages as default. Custom
Attributes in Onboarding Template can be configured using these
languages.

The configured languages are available for the Guest and IoT Manager
Provisioner, Self-Service Provisioner, and Outlook Add In.

l Provisioners / Outlook Add-In Page: The login page loads with the default
language selected. On clicking a desired language, the page reloads with the
selected language.

Note: The Provisioner has the option to select language only in the login
page. The selected language in the login page is used throughout
the Provisioner’s session.

Provisioner's language preference is stored in the browser as a
persistent cookie and used for subsequent sessions. Provisioner can
change this by selecting any other language to overwrite the cookie.

l Self-Provisioning Page: The languages are displayed in both Guest
User and Device Registration page. On clicking a desired language,
the page reloads with the selected language.

Configuring the File Manager
Use this procedure to upload a file and customize the printer friendly page.

Procedure

1. In the navigation pane, click Administration > Preferences tab.

2. In the File Manager section, click Add.

The Add File screen is displayed.
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3. In the Add File screen, click Browse to navigate to the file you wish to upload.

4. Click Upload, to upload the files to the File Manager. The uploaded file can be used in Onboarding
Template to customize the printer friendly page.

5. (Optional) Select the required file name from the displayed list and click Download to download the file.

6. (Optional) Select the required file(s) name from the displayed list and click Delete to delete existing
uploaded file.

Use Ctrl / Shift to select multiple records to delete. You cannot delete the file,

l If the selected sample file is an HTML file and used in any of the Onboarding
Template.

l If the selected file is a default file.

7. Click Save to save the configuration or Restore to Defaults to cancel the changes and restore to default
value.

Field Descriptions

Use the data in the following table to use the File Manager section.
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Name Description

Add File Uploads the files to customize the printer friendly page. By default, the application is pre-installed with
the following four samples:

l sample_print.css

l sample_print_page.html

l sample_style.css

l sample_logo.gif

Important
Ensure that the total size of all the files is less than 10 MB, though there is no
restriction on number of files in File Manager.

Guest User Attributes

Select the Guest User attributes that you want to display in the page by adding the following
appropriate variables in the HTML file:

Attributes Definition

$username Displays the Guest User Name.

$password Displays the Guest account password.

$firstname Displays the Guest first name.

$lastname Displays the Guest last name.

$email Displays the Guest email address.

$mobilephone Displays the Guest mobile phone number.

$starttime Displays the start time when the Guest account becomes usable.

$endtime Displays the end time of the Guest account.

$termsofuse Displays the terms of use text. For more information, see the Terms
of Use field description in Configuring General Details.

$usercustom1 to
$usercustom6

Displays additional information required during user creation.

Note: You can retrieve the uploaded External Images / CSS files from the File Manager by
using the URL in the following format and also entering the actual file name in place of
the file name variable:

/GIM/uploads/<file_name>

Sample: <img src=”/GIM/uploads/sample_logo.gif”>

../../../../../Content/GIM Configuration/Topics/ConfiguringGeneralDetails.html
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Configuring Terms of Use
Use this procedure to configure Terms of Use to be displayed on the login page.

1. In the navigation pane, click Administration > Preferences tab.

2. In the Terms of Use section, select Display Terms of Use in Login Pages to display the terms of use
information on the login page. By default, this is selected.

3. (Optional) Edit the default text given in the Terms of Use section as its a free form text box.

4. Click Save to save the configuration or Restore to Defaults to cancel the changes and restore to default
value.

Customize Provisioner Login Page
Use this procedure to customize Provisioner Login page

Procedure

1. In the navigation pane, click Administration > Preferences tab.

2. In the Provisioner Login Page Customization, select Background Image, Brand Logo, Title, Font Type,
and Font Color.

3. (Optional) Click Preview to Preview the changes made in the Provisioner Login Page.

4. Click Save to save the changes.
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Name Description

Brand Logo Configures the Brand Logo. The Brand Logo Dimension is 380X245.
Any uploaded image will be resized to this dimension.

Title Configures the title of Provisioner Login Page.

Font Type Configures the font type of all the text in Provisioner Login page.

Font Color Configures the font color of all the text in Provisioner Login page.

Preview Previews the changes made in the Provisioner Login Page

Background
Image

Configures the Background Image of Provisioner Login Page.

Configuring Privacy Policy
Use this procedure to configure Privacy Policy to be displayed on the login page.

Procedure

1. In the navigation pane, click Administration > Preferences tab.

2. In the Privacy Policy field enter the required privacy policy information.

3. (Optional) Edit the default text given in the Privacy Policy field as it is a free form text box. Maximum
length for the text allowed is 550 characters.

Note: You can change the privacy policy hyper link inside the “href” tag, if required. You can
also change the name specified for the hyperlink on need basis. gfgf
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4. Click Save to save the configuration or Restore to Defaults to cancel the changes and restore to default
value.

Use this procedure to configure the Outlook Add-In Download Link to be displayed on the login
page.

Procedure

1. In the navigation pane, click Administration > Preferences tab.

2. In the Provisioner Login Page Customization, select Show Outlook Add-In Download Link to configure
the Outlook Add-In Download Link Pages that is to be displayed on the login page.

3. Click Save to save the changes.
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Name Description

Outlook Add-
Iin Download
Link in Login
Page

Displays the Outlook Add-In Download Link in Login Page when the
Outlook Add-In Download Link in Login Page field is selected.

Backup and Restore Configurations
The Backup / Restore tab in the Administration menu allows you to backup and restore Guest
and IoT Manager configurations. This capability enables you to port the configurations between
multiple Guest and IoT Manager deployments.

The configurations you can backup and restore include:

l Access Control Engine configurations

l RADIUS configurations

l Root certificates

l HTTPDWeb server configuration (HTTP, HTTPD Certificates, SSL, and so on)

l Configuration such as SMTP, SMS Gateway, SMS Provider and files that are present in the
File Manager.

Note:

Guest Users, Devices, Provisioners, Self-Service Provisioner, and Onboarding Templates
configurations are stored on the ExtremeCloud IQ - Site Engine database for
corresponding Guest and IoT Manager domain and are not part of the Guest and IoT
Manager backup / restore operations.

You can only store a maximum of 25 backup configurations per Guest and IoT Manager
domain.

Storing Backup Configuration
Use this procedure to backup the configurations.
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Procedure

1. In the navigation pane, click Administration > Backup/Restore tab.

2. In the Backup section, enter the name of the file in the Backup Name field.

3. Perform one of the following:

l Click Backup Now to save the local configurations to XIQ-SE.

l Click Backup to PC to save the Backup the Guest and IoT Manager (GIM) application
Configurations to the Local Personal Computer.

Field Descriptions

Use the data in the following table to use the Backup screen.

Name Description

GIM Version Displays the Guest and IoT Manager Application version number.

IP Address / Host Name Displays the IP address / Host name of the Guest and IoT Manager
Application for readability.

Backup Name Configures the name of the backup file. When you specify the name for the
backup file, it will be saved with the same unique name and will be displayed
in the Restore screen.
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Scheduling Backup
Use this procedure for scheduling the backup configurations to do the following:

l Provide a name for the scheduled backup.

l Schedule the occurrence for the backup.

l Schedule a time for the backup.

l (Optional) Limit the number of backups to be saved.

Procedure

1. In the navigation pane, click Administration > Backup / Restore tab.

2. Within the Scheduled Backup section, in the Backup Name field, enter the name of the
Backup.

3. In the Occurrence field, select the occurrence for the scheduled backup as required.

4. In the At field, select the time for the scheduled backup.

5. (Optional) Click Limit Number of Backups Saved and select the number of backups to be
saved from the Maximum Backups Saved drop down list.

Note:

The Maximum Backups Saved is configured as 100 by default. If the number of saved
backups saved exceeds that value, Guest and IoT Manager automatically deletes the
oldest backups.

6. Click Save.
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l Once the scheduled backup occurs on a day and time, the backup configurations are then visible
in the Restore Panel. Where, the Backup name specified by the user is displayed with the date
and time at which it is scheduled. For example: BackupName_YYYYMMDD_HHMMSS.

l The required backups can be restored by selecting a backup from the restore panel.

Field Descriptions

Use the data in the following table to use the Backup screen.

Name Description

GIM Version Displays the Guest and IoT Manager Application version number.

IP Address / Host
Name

Displays the IP address / Host name of the Guest and IoT Manager Application
for readability.

Backup Name Configures the name of the backup file. When you specify the name for the
backup file, it will be saved with the same unique name and will be displayed in
the Restore screen.

Occurrence Configures the scheduled backup for a day.

At Configures the scheduled backup at a time in the day. This field is
enabled after you select the day for the scheduled backup in the
Occurrence field.

Limit Number of
Backups Saved

Configures a limit for the number of backups Guest and IoT Manager
saves.

Maximum Backups
Saved:

Configures the maximum number of backups Guest and IoT Manager saves. This
field is enabled when the Limit Number of Backups Saved field is selected.

Restore to Default Cancels the configuration and resets back to the default settings.

Restoring Configuration
Use this procedure to restore the configurations.

Procedure

1. In the navigation pane, click Administration > Backup / Restore tab.

2. Click Restore. The Restore screen displays all the available backup configurations in the Restore screen
along with Application Version, IP Address / Host Name and Backup Timestamp details.
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3. Do one of the following:

l Select the required backup entry and click Restore.

l Click on Restore from PC and upload the desired Backup file.

The Restore confirmation message is displayed requesting whether to restore the
network configuration.

4. In the Restore screen, do the following:

1. Click Yes, to include network configuration while restoring the backup configuration.

Network configuration includes:

l Interface IP addresses and subnet masks.

l Static routes.

l DNS IP addresses and domain.

2. Click No, to restore the configuration without network configuration..

Note:

The Guest and IoT Manager Application automatically reboots the Virtual
Appliance.

5. (Optional) Select the required backup(s) and click Delete to clear the added backup file. You will be
asked to confirm the deletion.

Tip:
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Use Ctrl / Shift to select multiple records to delete.

6. (Optional) Click Refresh to display the most recent changes.

Managing HTTPD Certificates
The Certificates tab in the Administration menu allows you to add, bind, or delete a certificate or
key.

Adding a Certificate
Use this procedure to add a new certificate.

Procedure

1. In the navigation pane, click Administration > Certificates tab.

The Certificates screen is displayed.

2. In the Certificates screen, click Add > Add Certificate to add a new certificate.

The Add Certificate screen is displayed.

3. In the Certificate File field, click Browse to select the certificate from the local folder and click Open to
upload.

4. In the Alias for this Certification field, enter the alias name to assign another name for the selected new
certificate.

5. Select Chain Certificate checkbox to upload a chain certificate.

6. Click Save to save the configuration or click Cancel to cancel the changes.

The added certificate and chain certificate details are displayed in the certificates table.
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7. (Optional) Select the required certificate(s) and click Delete to remove certificates.

Tip:

Active and default certificates cannot be deleted.

Use Ctrl / Shift to select multiple records to delete.

Field Descriptions

Use the data in the following table to use the Add Certificate screen.

Name Description

Certificate File Configures a new certificate for the application. This must be one of the
following:

l DER encoded binary X.509 file containing the certificate.

l Base64 encoded file containing the certificate.

Alias for this
certificate

Configures a unique string to identify the key entry of the certificate.

Chain
Certificates

Uploads a chain certificate. A chain certificate is a sequence of certificates,
where each certificate in the chain is signed by the subsequent certificate.
The purpose of a certificate chain is to establish a chain of trust from a peer
certificate to a trusted CA certificate.

Adding a Key
Use this procedure to add a new private key.

Procedure

1. In the navigation pane, click Administration > Certificates tab.

The Certificates screen is displayed.

2. In the Certificates screen, click Add > Add Key to a new private key.

The Add Private Key screen is displayed.
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3. In the Private Key File field, click Browse to select the private key from the local folder and click Open to
upload.

4. In the Passpharse field, enter the passphase for the selected private key.

5. In the Alias for this Key field, enter the alias name to assign another name for the selected new key.

6. Click Save to save the configuration or click Cancel to cancel the changes.

The added private key details are displayed in the certificates table.

7. (Optional) Select the required private key(s) and click Delete, to remove keys.

Tip:

Active and default private keys cannot be deleted.

Use Ctrl / Shift to select multiple records to delete.

Field Descriptions

Use the data in the following table to use the Add Private Key screen.

Name Description

Private Key File Configures a new private key for the certificate to encrypt messages
intended for a particular recipient. These messages can be deciphered
only by using the defined private key.

Passpharse Configures the passphrase that needs to be used to decrypt the file
containing the private key. If the private key is not encrypted, leave this
field blank.

Alias for this
Key

Configures a unique string to identify the key entry of the certificate
which you intend to use.

Binding a Certificate
Use this procedure to bind a Key and a certificate to the HTTPD server.
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Before you begin

Ensure that you have a added a certificate to the application and the same is listed in the
Administration > Certificates table.

Procedure

1. In the navigation pane, click Administration > Certificates tab.

The added certificates, chain certificates, and private key are displayed along with the
name and type details.

2. Select the required certificate you want to bind in the Name column.

3. Click Bind and select Bind Certificate from the drop-down list.

The Bind Certificate and Key screen is displayed.

Note:

Bind Certificate option in the drop-down list is disabled, if you select a incorrect
certificate.

4. In the Private Key field, select the required key from the drop-down list.

5. (Optional) In the Passpharse field, enter the passphase for the selected private key.

6. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Bind Certificate screen.

Name Description

Private Key Specifies a new private key for the certificate to encrypt messages intended
for a particular recipient. These messages can be decoded only by using the
defined private key.
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Passpharse Configures the passphrase that needs to be used to encrypt the file containing
the private key. If the private key is not encrypted, leave this field blank.

Note:

Ensure that you provide the valid passphrase, so that the bind
does not fail and result in HTTPD restart failure.

Binding a Chain
Use this procedure to bind a Certificate Chain to HTTPD server.

Before you begin

Ensure that you have a added a chain certificate to the application and the same is listed in the
Administration > Certificates table.

Procedure

1. In the navigation pane, click Administration > Certificates tab.

The added certificates, chain certificates, and private key are displayed along with the
name and type details.

2. Select the required chain certificate you want to bind in the Name column.

3. Click Bind and select Bind Chain from the drop-down list.

The Bind Chain screen is displayed.

Note:

If a chain certificate is not selected, the Bind Chain option in the drop-down list is
disabled.

4. In the Certificate field, select the required certificate from the drop-down list.

5. In the Private Key field, select the required private key from the drop-down list.

6. (Optional) In the Passpharse field, enter the required passpharse for the selected certificate and private
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key.

7. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Bind Chain screen.

Name Description

Certificates Specifies the available certificates for selection.

Private Key File Specifies a new private key for the certificate to encrypt messages intended for a
particular recipient. These messages can be decoded only by using the defined
private key.

Passpharse Configures the passphrase that needs to be used to encrypt the file containing
the private key. If the private key is not encrypted, leave this field blank.

Note:

Ensure that you provide the valid passphrase, so that the bind
does not fail and result in HTTPD restart failure.

Managing Access Control Engine
The Access Control Engine tab in the Administrator menu supports the Guest and IoT Manager
Application to configure Access Control Engine.

Important:

Guest and IoT Manager does not automatically connect to the Access Control Engine upon
start-up. You need to configure the Access Control Engine providing the necessary details.
And also, Guest and IoT Manager need not be connected to allow Guest Users to use their
accounts.

Configuring Engine Details
Use this procedure to configure Guest and IoT Manager to Access Control Engine.

Procedure

1. In the navigation pane, click Administration > Access Control Engine tab.

The Engine Details screen is displayed.
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2. In the Primary Engine field, enter the IP address or host name of Access Control Engine.

3. (Optional) In the Secondary Engine field, enter the IP address or host name of any other Access Control
Engine which is part of the same Engine Group as the Primary Engine.

4. In the Port field, enter the port number used for communicating with the Access Control Engine.

5. Enter the XIQ-SE Admin Username and XIQ-SE Admin Password of the ExtremeCloud IQ - Site Engine
administrative user having appropriate Guest and IoT Manager read / write access capability.

6. Click Save to store the valid configuration in Guest and IoT Manager Application.

Note:

The Guest and IoT Manager uses this configuration to establish connection with the
Access Control Engine.

In the absence of these settings, Guest and IoT Manager is no longer connected to
Provisioner and Self-Service Provisioning Application.

7. (Optional) Click Test to verify the Access Control Engine configuration.

The successful / failure test configuration message is displayed.

8. (Optional) Click Restore to Defaults to reset the configuration to default.

Field Descriptions

Use the data in the following table to use the Engine Details screen.

Name Description
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Primary Engine Configures the Primary Control Engine IP address / host name of the Access
Control Engine.

Secondary Engine (Optional) Configures Secondary Control Engine IP address / host name for the
Access Control Engine.

When the primary appliance goes down the application switches to
secondary appliances and vice verse with a maximum down time of 10
seconds.

Port Configures the Access Control Engine port number to identify a specific process
to which the connections needs to be forwarded when it arrives at a server. By
default, the proxy value 8444 is displayed.

XIQ-SE Admin
Username and XIQ-
SE Admin Password

Specifies the Username and Password of the the ExtremeCloud IQ - Site Engine
administrative user which has Guest and IoT Manager Application read / write
access.

Configuring RADIUS Settings
Use this procedure to specify the RADIUS settings in Guest and IoT Manager Application.

For more information on RADUIS settings, see Guest and IoT Manager Configuration Document
in ExtremeCloud IQ - Site Engine.

Procedure

1. In the navigation pane, click Administration > Access Control Engine tab.

2. Click RADIUS.

The RADIUS screen is displayed.

3. In the RADIUS Port field, enter the port number for authentication request.

4. In the Shared Secret field, enter the pre shared key to establish the connection.

5. In the Timeout field, enter the period in seconds.

https://emc.extremenetworks.com/content/oneview/docs/network/docs/t_ht_gim_config.htm
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6. Click Save to save the configuration or click Cancel to cancel the changes.

In Engine Group, you must have a Guest and IoT Manager Server record with the IP
address of the Server that hosts Guest and IoT Manager. Provisioners cannot login
without Server record.

Field Descriptions

Use the data in the following table to use the RADIUS screen.

Name Description

RADIUS Port Configures the RADIUS port number where the Access Control Engine is running for
centralized Authentication, Authorization, and Accounting (AAA) network access
management. The default number is 1812.

Access Control Engine uses RADIUS to authenticate Provisioners.

Shared
Secret

Configures the proof of identity for authentication. The Shared Secret can be randomly
selected bytes. The default shared secret is : ETS_TAG_SHARED_SECRET

Timeout (in
sec)

Configures the maximum length of time in seconds to wait (for the real-
time), so that Guest and IoT Manager Application retires the RADUIS login.

If no Response, the application displays an error message. The default is 3
seconds.

Adding Root Certificate
Use this procedure to add a new Root Certificate.

Procedure

1. In the navigation pane, click Administration > Access Control Engine tab.

2. Click Root Certificates > Add, to add a new certificate.

The Add Root Certificate screen is displayed.
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3. In the Certificate File field, click Browse to select the certificate from the local folder and click Open to
upload.

4. In the Alias for this Certification field, enter the alias name to assign another name for the selected new
certificate.

5. Click Save to save the configuration or click Cancel to cancel the changes.

The added Root Certificate details are displayed in the Root Certificates table and Update
Trust Mode is enabled.

6. Click Trust Mode.

There are two options under the Update Trust Mode:

1. Select All server certificates are accepted. By default, this option is selected where all the server
certificates are accepted. However, the Trust Mode gets highlighted in RED.

2. Select Any untrusted server certificate is rejected so that the certificate from the server is
validated against the root certificates available in Guest and IoT Manager. The untrusted
certificates are rejected if the identity is not verified. We recommend this as the safest option to
be selected.

3. Click Save to save the configuration or click Cancel to cancel the changes.

7. (Optional) Select the required Root Certificate(s) and click Delete to remove the certificates.

Tip:

Use Ctrl / Shift to select multiple records to delete.

Field Descriptions

Use the data in the following table to use the Add Root Certificate screen.

Name Description

Certificate File Adds a new Root Certificate for the application. The certificate file must contain
PEM-encoded certificate.

Make sure that the certificate does not have a password associated
with it. The certificate encoding format must be any one of the
following format.

Note:

l DER encoded binary X.509 file containing the certificate.

l Base64 encoded file containing both the certificate and the
private key.



Managing Access Control Engine

76 of 253

Name Description

Alias for this
certificate

Configures a short unique string to identify the key entry of the Root Certificate in
the keystore.

You can use any name; Access Control Engine uses this Alias name as a
key to identify the certificate in the keystore. All the installed certificate
resides in the Guest and IoT Manager keystore.

Important:

Do not confuse the Guest and IoT Manager keystore with the
browser keystore and the certificates that secure HTTPS browser
sessions.

Viewing License Status
When you deploy Guest and IoT Manager for the first time, ensure that a valid Guest and IoT
Manager license is added and enforced in ExtremeCloud IQ - Site Engine so that Access Control
Engine details can be configured in Guest and IoT Manager. For more information, see
Configuring Engine Details.

If the license is expired:

l License status is displayed as Not Installed / Expired.

l Provisioner users are logged out including Outlook Provisioner and all the configured self-
services become non-operational.

l Valid new license needs to be added again to function.

Different License Status

Scenario License Status

When engine details not configured Not Available

Invalid Credentials Not Available

Not compatible Not Available

Not Reachable Not Available

Not Trusted Not Available

Reachable and valid license present Valid

Reachable and there is no valid license present Not Installed / Expired

For more information on Server License, see Diagnostics in ExtremeCloud IQ - Site Engine.

../../../../../Content/GIM Configuration/Topics/ConfiguringEngineDetails.html
https://emc.extremenetworks.com/content/oneview/docs/admin/docs/ov_admin_main.htm#Diagnostics
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Note:

When the connection fails from Guest and IoT Manager to Access Control Engine, the
system waits for a minute and if the connection does not restore, all the configured self-
services become non-operational.

When the connection restores, all the services are reactivated automatically.

Setting Notification Parameters
The Notification tab in the Administrator menu specifies the Email and SMS configuration that
are used to notify the Guest Users created by the Provisioners. The usual way to provide the
credentials (User Name and Password) is through email. Alternatively, the Administrator can
send the credentials in an email to the front desk personnel who can pass them to the Guest as a
hard copy.

For more information, see Enabling E-mail Notification.

The Administrator can also configure the application to send the credentials via an SMS text
message to the mobile phone. The configured carrier Gateway / Provider communicate with the
Guest and IoT Manager on how to send the messages.

For more information, see Adding SMS Gateway and Adding SMS Provider.

Important:

You can use a public mail server such as Gmail or Yahoo as the Simple Mail Transfer
Protocol (SMTP) server. However, there are some limitations with these web-based SMTP
servers.

Emails sent usingWeb-based SMTP servers are likely to be marked as spam by mail clients
including Outlook. Guest Users need to be made aware of this so that they do not overlook
the mail.

Yahoo SMTP comes with a strict limit of 500 outbound emails per day (and each message
can be sent up to 100 recipients), to prevent spammers from using it for their unsolicited
messages.

Gmail SMTP comes with severe sending limits to prevent spammers from using its outgoing
server to blast out garbage emails. The boundary is 100 recipients a time and 500
messages per day. If you cross this restriction, Google blocks your account.

Google blocks sign-in attempts from unknown sources. To avoid this issue, you need to
allow access to apps to get authenticated. You can find this option in your Google Account
Security Setting. Select Allow less secure apps as ON to use these non-Google apps and
devices despite the risks. For more information, see Let less secure apps access your
account.

../../../../../Content/GIM Configuration/Topics/EnablingEmailNotification.html
https://support.google.com/accounts/answer/6010255?hl=en
https://support.google.com/accounts/answer/6010255?hl=en
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Enabling E-mail Notification
Use this procedure to configure SMTP email settings.

Procedure

1. In the navigation pane, click Administration > Notification tab.

By default, the E-mail screen is displayed.

2. In the E-mail screen, select the Enable Sending of Email Notification checkbox to configure SMTP.

3. In the From Address field, enter the email address that needs to be displayed in the From line of the
messages that application sends.

4. In the Server field, enter the fully-qualified domain name or the IP address.

5. In the Security field. select None, SSL/TLS or STARTTLS options from the drop-down list.

By default, None option is selected to process email with Non-SSL connections.

If you select STARTTLS option, enter the port number to send the encrypted email.

If you select SSL/TLS option, the SSL Certificate field is enabled. You can perform the
following:

1. Select System option from the SSL Certificate field drop-down list, to use the known Root
Certificates that are shipped along with Guest and IoT Manager Application.

2. Select Custom option from the SSL Certificate field drop-down list to import the SMTP server
certificate specified in Administration > Connection > Certificate tab. When you successfully
import the certificate, this certificate is used to establish trust with the SMTP server.

6. In the Port field, enter the SMTP port number.
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7. (Optional) Select User Authentication checkbox, if your SMTP server requires authentication.

The User Name and Change Password fields are enabled.

1. Enter the login credentials of SMTP server user in the Username field.

2. Select Change Password checkbox, to modify the password details.

8. (Optional) Click Test to verify that the application can reach the server using the specified email
address before saving the configuration.

The Test SMTP Configuration screen is displayed.

1. Enter the sample email address in the Test Destination Email field.

2. Click Send Test Email to send the email or click Cancel to cancel the operation.

Note:

Ensure that you set up an appropriate email notification template. For more
information, see Configuring the Account Notification Templates.

9. Click Save to save the configuration or Clear to clear the configuration.

For more information, sample email domains are listed as examples in the E-mail screen
beneath frame. For example, Yahoo, Gmail, and so on.

Field Descriptions

Use the data in the following table to use the E-mail screen.

Name Description

Enable Sending of
Email Notification

Configures the Application to send Guest Users, Provisioners, and / or others an
email notification, when Guest User accounts are created and / or updated.

From Address Configures email address that needs to be displayed in the From line of the
messages. For example, user provisioning notifications contains a From Address
such as guestreception@extremenetworks.com. This address appears in
all types of emails that Guest and IoT Manager Application sends.

Server Configures the domain name or the IP address assigned to the mail server that
transmits email notifications from the application.

The SMTP server name can be an email address.

You can enter a public mail server such as Gmail or Yahoo as the SMTP
server.

Security Specifies SSL/TLS and STARTTLS options.

../../../../../Content/GIM Configuration/Topics/ConfiguringTheAccountNotificationTemplate.html
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Name Description

SSL Certificate Specifies System and Custom options.

l System: Uses the shipped Root Certificate to establish trust with
the SMTP server. If the application fails to establish trust, the
email functionality does not work.

l Custom: Fetches the custom SMTP server certificates that are
binded in the Application. For more information, see Binding a
Certificate. Upon successful import this certificate is used to
establish trust with SMTP server.

Port Configures the SMTP port number to be used by the application for the SSL
connection.

Username Specifies the login name of the SMTP server user.

New Password and
Confirm Password

Configures a new password for the account.

Test Destination
Email

Verifies the SMTP settings by sending the sample email.

Restore to Default Cancels the configuration and resets back to the default settings.

Configuring SMS Gateway / Provider
The Administrator can perform the following procedures to send the login credentials to Guest
Users.

l AddingSMSGateway

l AddingSMSProvider

l ModifyingSMSGateway/Providers

l Restore to Default SMS Gateways
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Adding SMS Gateway

Use this procedure to configure carrier gateways settings to send SMS messages to mobile
service providers.

Procedure

1. In the navigation pane, click Administration > Notification > SMS tab.

2. Click Add and select Add SMS Gateway option from the drop-down list.

The Add SMS Gateway screen is displayed.

3. In the Carrier Name field, enter the name of the carrier.
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4. In the Carrier Gateway field, enter the carrier gateway address.

5. In the Phone Number field, select the required calling options from the drop-down list.

6. Click Test to test the added gateway service configuration.

The Test Gateway Configuration screen is displayed.

1. Enter the phone number in the Test Destination Mobile Number field.

2. Click Send Test SMS to send the SMS or click Close to close the screen.

Note:

Ensure that you set up an appropriate email notification template. For more
information, see Configuring the Account Notification Templates.

7. Click Save to save the configuration or click Cancel to cancel the changes.

The added carrier gateways details are displayed in the SMS Gateway screen along with
Phone Carrier and Gateway details.

8. (Optional) Select the required added carrier gateway and click Set as default option in the SMS
Gateway screen.

If you configure a default gateway, the default gateway is used to send SMS text
messages to each mobile service provider.

Note:

The first SMS gateway is always a default gateway. You can select the required
gateway and Set as default, if required.

9. (Optional) Select the required added carrier and click Edit to modify the SMS gateway. For more
information, see Modifying SMS Gateway/Providers.

10. (Optional) Select the required added carrier gateway(s) and click Delete option in the SMS Gateway
screen to clear the added carrier service. You will be asked to confirm the deletion.

Tip:

Use Ctrl / Shift to select multiple records to delete.

Field Descriptions

Use the data in the following table to use the Add SMS Gateway screen.

Name Description

Carrier Name Configures the carrier service provider name. It is mandatory to
configure a gateway for each mobile phone provider to whom
the application sends the Guest User login details.

../../../../../Content/GIM Configuration/Topics/ConfiguringTheAccountNotificationTemplate.html
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Name Description

Carrier Gateway Configures the carrier gateway address to send SMS text
messages.

Phone Number Specifies the phone number format of the selected country. If
you select specify length option from the drop-down list, the
Digits (single number or range. For example, 10 — 15) field is
enabled.

Digits (single number or
range. For example, 10 —
15)

Configures the number range for the phone number input field.

Test Destination Mobile
Number

Verifies the SMS configuration by sending a sample SMS to the
specified mobile number.

Adding SMS Provider

Use this procedure to configure Clickatell gateways settings to send bulk SMS messages to
mobile service providers.

Before you begin

Ensure that you have completed Clickatell registration and have activated your account ID. The
account activation email received includes User ID and Email address information.

Note:

If Do not Disturb (DND) service is enabled in your mobile network, you will not be able to
receive any SMS notification.

Procedure

1. In the navigation pane, click Administration > Notification > SMS tab.

2. Click Add and select Add SMS Provider option from the drop-down list.

The Add SMS Provider screen is displayed.
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3. In Provider field, select the name of the provider.

Currently, Clickatell is the only available service provider.

4. In the Provider Name field, enter the name of the provider.

5. In the Provider Gateway / Host field, check the available URL details.

The value displayed in this field is based on the option selected in the API Type field.

6. In the API Key field, enter the key details obtained from Clickatell.

7. In the API Type field, select the type from the drop-down list.

By default, REST option is selected.

8. Click Test, to test the added gateway services configuration.

The Test Gateway Configuration screen is displayed.

9. In the Add SMS Provider screen, do the following:

1. Enter the phone number in the Test Destination Mobile Number field.

2. Click Send Test SMS to send the SMS or click Close to close the screen.

10. Click Save to save the configuration or click Cancel to cancel the changes.

The added provider gateways details are displayed in the SMS Gateway screen along with
Phone Provider, Provider Gateway and Protocol (REST / HTTP) details.

11. Select the required added provider gateway and click Set as default option in the SMS Gateway screen..
On Guest User summary screen, the complete address as specified in the SMS provider configuration is
now displayed with the essential part of the name.
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12. (Optional) Select the required added carrier and click Edit to modify the SMS provider. For more
information, see Modifying SMS Gateway/Providers.

13. (Optional) Select the required added provider gateway(s) and click Delete option in the SMS Gateway
screen to clear the added provider service. You will be asked to confirm the deletion.

Tip:

Use Ctrl / Shift to select multiple records to delete.

Field Descriptions

Use the data in the following table to use the Add SMS Provider screen.

Name Description

Provider Specifies the list of Providers.

Currently, Clickatell is the only available service provider.

Provider Name Configures the Provider name.

Provider Gateway /
Host

Specifies the URL information.

The default value for Provider Gateway / Host field is provided
for both REST and HTTP API types.

API Key Configures the API key.

You need to copy the API key from Clickatell account.
(https://portal.clickatell.com/#/login)

API Type Specifies the API type available for the selected service provider.

The options available are:

l REST

l HTTP

Modifying SMS Gateways / Providers

Use this procedure to modify SMS Gateways / Providers.

Procedure

1. In the navigation pane, click Administration > Notification tab.

2. Click SMS tab. The added carrier / provider gateway details are displayed in the SMS screen along with
Phone Carrier, Gateway and Protocol (HTTP / REST) details.

3. Select the required phone carrier / provider from the list.
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4. Click Edit to view the carrier details.

Note:

You can also view by double-clicking the required phone carrier / provider from the
list.

5. In the Edit SMS Gateway screen, modify the fields required. The fields are displayed based on the
selected phone carrier / provider type.

6. (Optional) The Change Visibility option can be used to hide SMS Gateways/Providers
from the Provisioner application and the Self Registration page of Guest Users. This
option can be used to either enable or disable the visibility of the selected SMS
gateway/provider. The change visibility button is disabled when the default gateway is
selected.

7. Click Save, to save the configuration or click Cancel to cancel the changes.

Restore to Default SMS Gateways

Use this procedure to modify SMS Gateways / Providers.

Procedure

1. In the navigation pane, click Administration > Notification tab.

2. Click SMS tab. The added carrier / provider gateway details are displayed in the SMS screen along with
Phone Carrier, Gateway and Protocol (HTTP / REST) details.

3. Click Restore to Default to restore the default SMS Gateways.

Note:

When Restore to Default is selected the newly added/deleted Gateways are
removed and the Defalut SMS Gateways are displayed.

4. In the Restore windows pop-up, Do one of the following:

l Select Yes to restore the default SMS configurations.

l Select No to avoid restoring the default SMS configurations.
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Two-Way SMS Provider
Use this procedure to configure the Two-Way SMS Provider.

Procedure

1. In the navigation pane, click Administration > Notification tab.

2. Select the Two-Way SMS Provider tab and enter the field details as required.

3. Click Save to Save the changes.
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Field Descriptions

Use the data in the following table to use the Backup screen.

Name Description

Service Provider Service Provider Displays the name of the service provider.

Associated Phone
Number

Enter the Associated Phone Number with the country code.

Save Saves the configuration.

Restore to Defaults Cancels the configuration and resets back to the default settings.

Note:

Configure Webhook for Messaging in the Twilio Website, to make POST request to https://
{GIM-ServiceB-IP}:8443/GIM/twilioSMS.

Housekeeping
The Housekeeping section for Guest and IoT Manager will help clear out the records of Guest
Users and Devices which have their first login pending.

Housekeeping tab under the administration section allows you to specify Housekeeping tasks
that are set to show the details of the housekeeping tasks that are run on Guest and IoT
Manager. The administrator can configure the time when the housekeeping tasks must be
performed.
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When the tasks are not needed, they can be disabled. The results are displayed in the logs to
verify completion of process status.

Scheduling Housekeeping Tasks

Use this procedure to schedule housekeeping tasks.

Procedure

1. In the navigation pane, click Administration > Housekeeping tab.

2. In the Run Daily At field, select the time of occurrence.

3. Select the task for the targeted housekeeping task cleanup and do one of the following:

l Click Enable to enable the selected housekeeping task.

l Click Disable to disable the selected housekeeping task.

4. To delete Guest Users with First login pending, click the Edit button. In the Edit window
pop-up enter the number of days to schedule the housekeeping task for the targeted
task. The maximum value is 365 days.

Note:
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For Devices/Guest Users with First login pending to be deleted before 'x' days, the
scheduled tasks considers the period of 24 hours as 1 day. Therefore, for 'x' days the
period will be 'x' * 24 hours before running the task.

For Example:

If the current date is 24th of a month and time is 12:00 PM then, a task scheduled to
delete Guest Users with First login pending and created before 2 days will delete all
Guest Users with First Login pending and created before 12 PM on the 22nd of that
month.

Housekeeping tasks can be performed for the following:

l Guest Users

l Devices

l Guest Users and Devices

5. (Optional) To delete Guest Users with First login pending from a day before, click the Run
Now button.

By clicking the Run Now button a the period of 24 hours is considered as 1 day and hence
'x' days would be 'x' * 24 hours prior to running of the task now.

6. Do one of the following:

l Click Save to save the configuration.

l Click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Housekeeping tab.

Name Description

Run Daily At Specifies the time of day for the scheduled housekeeping task to be
completed.

Enable / Disable Enables or disables the scheduled housekeeping occurrence for the guest
user, device or both.

Edit The time in days for an enabled guest user, device, or both.

Run Now Enables the administrator to run the selected housekeeping task(s).

Save Saves the configuration.

Cancel Cancels the configuration.
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Troubleshooting
The Troubleshooting tab in the Administrator menu allows the Administrator to view the logs of
Guest and IoT Manager application. The default name of the log file is : GIM_Version_log_IP_
Date_Time.log.

For more information, see Viewing the Log Files.

For any debugging issues in the Guest and IoT Manager Application, Administrator can
generate a show support file that Extreme support staff can use to diagnose the problem.

For more information, see Generating a Show Support File.

Swagger tool allows connections directly to REST APIs through an interactive, HTML-based
user interface. Where, requests can be made directly from the UI and the options can be
explored by the user of the interface.

For more information, see REST API.

Viewing the Log Files
Use this procedure to view the log files.

Procedure

1. In the navigation pane, click Administration > Troubleshooting tab.

By default, the Logs screen is displayed along with Types (Info, Error) Message and
Timestamp details.

2. Click Enable Debug Logs to view the logs of type debug. By default, the debug logs are disabled.

3. (Optional) Click Download Logs to store and view the logs from the local drive.

Note:

../../../../../Content/GIM Configuration/Topics/ViewingTheLogFiles.html
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The log file size is 10 MB. If the size exceeds more than 10 MB, then roll over of log file
occurs.

4. Click the Page Numbers arrow at the bottom of the screen to page through the files.

5. Click the Refresh icon to reload the page being viewed with most recent generated logs.

Generating a Show Support File
Use this procedure to generate a show support file for debugging the issues.

Procedure

1. In the navigation pane, click Administration > Troubleshooting tab.

2. Click Show Support tab.

The Show Support screen is displayed.

3. In the Show Support screen, click Generate Show Support to download the zip file.

4. Save the Guest and IoT Manager show support zip file to an appropriate location and contact Extreme
Networks technical support. For more information, see Troubleshooting and FAQs .

REST API
Swagger tool allows connections directly to REST APIs through an interactive, HTML-based
user interface. Where, requests can be made directly from the UI and the options can be
explored by the user of the interface.

To enable the administrator to explore the REST API directly from the application, the Swagger
tool is integrated within the admin application under Administration > Troubleshooting > REST
API.
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For non-authentication based API, the API Information can be executed without any
authorization. The response contains the API Information details.

For any REST API that requires authentication, you must provide the Provisioner credentials by
clicking the Authorize Button. Post Authorization one can execute any APIs that require
authentication.

For all the APIs the api-version header is pre-populated with v1.0 as the default value that helps
the admin to determine how to use it. Similarly, the Device and Guest User JSONs are shown as
default body wherever applicable.

You can check for the sample JSON under Models. Each API can be tested to see the response.
For a ready reference, the possible response codes and the brief response message is also
displayed.

For more information about REST API see, the Guest & IoT Manager REST APIs document.

http://documentation.extremenetworks.com/extremecontrol/8.4.0/html-gim-restapi/index.html


Creating anOnboarding Template

94 of 253

Configuring Onboarding Template
This module is intended for Guest and IoT Manager Administrator to create and manage
Onboarding templates to be associated with Provisioner accounts.

The Guest and IoT Manager Administrator configures the Onboarding Template which specifies
how Users / Devices can be onboarded by the Provisioner. Administrator can also configure
Custom Attributes and Access Groups.

If you are a Provisioner, you may skip this section, see the ExtremeControl Guest and IoT
Manager Configuration document.

Creating an Onboarding Template
The Onboarding Templates tab in the Onboarding Templates menu is a collection of settings
that establishes the administrative rights and account settings of the Provisioners that associate
with it.

Use this procedure to create an Onboarding Template for each set of Provisioners that require a
unique set of rules for creating Guest Users account / Device records. Every Provisioner must
belong to at least one Onboarding Template.

Before you begin

Login to the Guest and IoT Manager application and ensure that it is connected with the Access
Control Engine. For more information, see Configuring Engine Details.

Procedure

1. In the navigation pane, click Onboarding Templates > Add.

2. In the Common tab, configure the name and common details for the Onboarding Template. For more
information, see Configuring the Common Details.

3. In the Guest Users tab, configure the Guest User Account Details For more information, see Configuring
the Guest User Account Details, Configuring Guest User Provisioning Using Outlook Add-in, ,
Configuring Guest User Provisioning Using Vouchers,Configuring Guest User and Device Provisioning
Using CSV, and Configuring Zero Touch Guest User Provisioning,.

4. In the Sponsor tab, configure Sponsor approval, if Self-Service Guest Users must be approved by a
Sponsor before they are granted access. For more information, see Configuring Sponsor Approval.

5. In the Devices tab, configure User Device details for this Onboarding Template. For more information,
see Configuring the Devices Record Details.

Important:

If Sponsor Approval is configured, Provisioners belonging to this Onboarding
Template cannot manage Devices.

../../../../../Content/GIM Configuration/Topics/ConfiguringEngineDetails.html
../../../../../Content/GIM Configuration/Topics/ConfiguringtheCommonDetails.html
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6. In the Device Type Groups tab, configure the Device Type(s) and Group(s) for the particular Onboarding
Template. For more information, see Configuring Device Type Groups.

7. In the Notification tab, configure the notification templates used for sending account details to Guest
User / Sponsor. For more information, see Configuring the Account Notification Templates.

8. In the Advanced tab, configure the advanced details for this Onboarding Template if required. For more
information, see Configuring Advanced Details.

9. Check your entries and click Save to save the configuration.

Guest and IoT Manager creates the Onboarding Template.

Note:

For more information on modifying, copying and deleting Onboarding Templates,
see Managing Onboarding Templates.

Configuring the Common Details
Use this procedure to configure common details for Onboarding Template.

Procedure

1. In the navigation pane, click Onboarding Templates >Add>Commontab. TheCommonscreen is
displayed.

../../../../../Content/GIM Configuration/Topics/ConfiguringDeviceTypeGroups.html
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2. In theOnboarding Template Details section, enter the name of the template, description, and any
template related notes.

3. In theOnboarding Template Type section, select an option as required. >

Note:

If Provisioners are associated with REST API or Outlook Onboarding Templates then
they will not be able to create new Guest Uses and Devices. Only view option is visible.

4. SelectProvisioners belonging to this Onboarding Template can view and edit each other's records
checkbox to manage Guest User / Device accounts of all the Provisioners belonging to this Onboarding
Template.

5. In theTemporary Accounts Validity section, enter the maximum account validity that can be granted to
a Guest / Devices in minutes, hours, or days.

6. ClickSaveto save the configuration or click Cancelto cancel the changes.

Field Descriptions

Use the data in the following table to use theCommontab.
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Name Description

Onboarding
Template Details

Configures the details of the Onboarding Template.

l Onboarding Template Name: Configures the template name.
The template name can be configured using alphanumeric /
special characters and space between words. Only these special
characters are allowed : # =()_-! []

l Description: Configures a short description of the Onboarding
Template. The description is limited to 60 characters.

l Notes: Configures any notes specific to the template. Only 250
characters are allowed.
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Name Description

Onboarding
Template Type

Specifies the type of Onboarding Template.

Note:If no Associated LDAP Group or Default Onboarding Template
configuration is selected, the system displays a pop-up message. 'No
Associated LDAP Group or Default Onboarding Template
configuration is selected. Without these settings LDAP Provisioner will
not be able to authenticate and onboard users/devices for this
template'.

l Guest User and Device Provisioning : Creates an Onboarding Template that
has Guest User and Device Provisioning rights. By default, this option is
enabled. The tabs enabled are:

l Guest User

l Devices

l Device Type Group

l Notification

l Advanced

l Self Service with Sponsor Approval : Creates an Onboarding Template with
Guest User Self-Provisioning rights with additional sponsor approval
requirements. The tabs enabled are:

l Guest User

l Sponsor

l Notification

l Advanced

l Guest User and Device Provisioning using API : Creates an Onboarding
Template with Guest User and Device provisioning rights for thrid party
APIs. The tabs enabled are:

l Guest User

l Devices

Note:

When you selectGuest User and Device Provisioning Using
API , a new checkbox Provisioners belonging to this
Onboarding Template can view all records of this GIM
Domain is displayed that allows the Provisioners belonging
to this template to view all Guest User / Device data in the
Guest and IoT Managerdomain irrespective of the template
they belong to.
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Name Description

l Guest User Provisioning using Outlook Add-in : Enables Provisioners to
login from the MS Outlook Add-in and to provision users in the meeting
invite. The tabs enabled are:

l Guest User

l Notification

l Advanced

l Guest User Provisioning using Vouchers: Enables Provisioners to create
Guest Users in bulk using Vouchers. The tabs enabled are:

l Guest Users

l Advanced

l Guest User and Device Provisioning using CSV: Enables Provisioners to
create Guest Users and Devices in bulk *.csv files. The tabs enabled are:

l Guest Users

l Devices

l Device Type Group

l Advanced

l Zero Touch Guest Provisioning:Enables Guest Users to create their own
accounts using Self Service Provisioning Service with the help of a QR
Code. The tabs enabled are:

l Guest Users

l Notification

l Advanced

Provisioners
belonging to this
Onboarding
Template can view
and edit each
other's records

Configures the Provisioners in this template to manage all the Guest Users /
Device accounts provisioned using this Onboarding Template. If you want to limit
each Provisioner to view only the guest accounts that they have created, do not
select this option.

Temporary
Accounts Validity

Configures the maximum account validity the Provisioners can grant to a Guest.
The access is denied if the account is expired.

l minutes: Indicates the minutes units for accounts validity.

l hours: Indicates the hours units for accounts validity.

l days: Indicates the days units for accounts validity.
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Configuring the Guest User Account Details
Use this procedure to configure the Guest User account details for the Onboarding Template.

Before you begin

In the Common tab, select Guest User and Device Provisioning or Self Service with Sponsor
Approval or Guest User and Device Provisioning using API option to configure the Guest User
account details.

Note:

l If you select Guest User Provisioning using Outlook Add-in option, skip this section and see
Configuring Guest User Provisioning Using Outlook Add-in.

l If you select Guest User Provisioning using Vouchers option, skip this section and see Configuring
Guest User Provisioning Using Vouchers.

l If you select Configuring Guest User and Device Provisioning Using CSV option, skip this section
and see Configuring Guest User and Device Provisioning Using CSV.

l If you select Configuring Zero Touch Guest User Provisioning option, skip this section and see
Configuring Zero Touch Guest User Provisioning.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Guest Users tab. The Guest Users screen is
displayed.

../../../../../Content/GIM Configuration/Topics/ConfiguringGuestUserProvisioningUsingOutlookAdd-in.html
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2. In the Guest Users screen, select the Onboarding Template for Guest Users checkbox to configure the
Guest User account details. By default it is selected.

3. In the Guest Notification section, select the required checkboxes.

4. In the Username section, select an option as required.

5. In the Password section, select an option as required.

6. In the Password Complexity Check section, set the password complexity selecting the required
alphanumeric checkbox.

7. (Optional) Select Guest User Account Limit checkbox to restrict the number of guest accounts created
within the specified duration in the Limit the number of Guest Accounts that can be created for a given
Email / Mobile Phone number within field.

8. (Optional) Select Customize Printer Friendly Page to enable printable Guest User information page. You
must select appropriate file from Select Uploaded HTML file drop-down list. For more information, see
Configuring the File Manager.

9. In the Access Groups section, select the Single and Multiple Memberships Access Groups as required.
For more information, see Configuring Access Groups.

10. In the Accessible to Provisioner section, configure the General and Custom Attributes as required.

../../../../../Content/GIM Configuration/Topics/ConfiguringAccessGroups.html
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11. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Guest User tab.

Name Description

Guest Notification Configures the mode of communication to notify guests about their new
account details.

l Email: Notifies Guest Users their new account details by Email.

l SMS: Notifies Guest Users their new account details by SMS.

l Display Username: Notifies Guest Users with Username in the
message that is displayed when a guest user account is
successfully created through Self-Service or Provisioner
Application.

l Display Password: Notifies Guest Users with password in the
message that is displayed when a Guest User account is
successfully created through Self-Service or Provisioner
Application.
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Name Description

Username Specifies the different available options of Username that the Administrator can
enable.

l Guest Defines Username: Allows the Provisioner / User to
specify Username during Provisioner Guest creation or Self
Service Provisioning Services.

l Generate UsernameWith: Specifies the format of the Guest
Username.

l

Random Generated Username: Random generated
Username is a combination of Uppercase letters,
Lowercase letters and Numbers. By default, all are
enabled. Enter the length as a single value / range
(within 3 - 40). Depending on the checkbox(es) selected
(lower case, upper case and number), a random
Username within the specified length is generated.

For example, the length specified is 6 characters, and
you have selected “lower case”, “upper case”, and
“number”; the Username / Password must contain at
least one lowercase, one uppercase, and one number.
Valid Usernames are: “a1Bacd”, “2aBBCD” and so on.

Note:

Provisioner Application and Self-Service Application
Create User Screen displays the randomly generated
Username in the Username text box.

l FirstnameLastname: Combination of Firstname and
Lastname of the Guest User with an optional suffix /
prefix. By default, No Prefix Suffix option is selected.

For example, if first name is "Tom" and the last name is
“Jones,” Guest and IoT Manager default the Username to
“TomJones”.

l firstintiallastname: Combination of the initial of the
Firstname and Lastname of the user with an optional
suffix / prefix. By default, No Prefix Suffix option is
selected.

For example, if firstname is "John" and the lastname is
“Smith", Guest and IoT Manager default his Username to
“jsmith”.
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Name Description

Note:

Administrator can restrict the Guest User and Provisioner
from editing the auto-generated Username. Deselect the
Username field editable checkbox to disable editing. By
default, it is enabled.

l Use Email as Username: Specifies to use the Email address as
Username.

l Use Cell Phone Number as Username: Specifies to use cell
phone number as Username.

Password Specifies the different available options of password that the Administrator can
enable.

l

Guest Defines Password: Allows the Provisioner / User to
specify Password during Provisioner Guest creation or Self
Service Provisioning Services.

Note:

On checking Guest Confirms Password, Provisioner/Self
Provisioning Service User must confirm the password
while creating the Guest User account.

l Random Generated Password: Generates random password
with the specified password complexity.

For example, the length specified is 6 characters, and you have
selected “lower case”, “upper case”, and “number”; the
Username / Password must contain at least one lowercase,
one uppercase, and one number. Valid Usernames are:
“a1Bacd”, “2aBBCD” and so on.

l Use Username as Password: Allows the Guest User to login
with only a Username.

l Static Password: Allows you to set the password as a fixed
string so that a single password can be used for multiple
accounts.
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Name Description

Password Complexity
Check

Configures the parameters to enforce when guests change their account
passwords. Different levels of password complexity is required to select
passwords that contain different combinations of characters, lowercase letters,
uppercase letters, digits and symbols.

If multiple combinations are selected, the different levels of
password complexity is selected appropriately.

l characters: Configures the number of characters in the
password.

l lower case: Indicates the password must have lower case only.

l upper case: Indicates the password must have upper case
only.

l number: Indicates the password must have number only.

l special characters: Indicates the password must have special
characters only. Special characters are: ! @ # $ % ^ & * ( 
) - +

Guest User Account
Limit

Limits the number of Guest User accounts that can be created for a given Email
/ Mobile Phone within the specified time period. For example, if the limit is set
to 2 for a time period of 1 hour, then the user can only create 2 distinct users
having the same Email / Mobile Phone in the 1 hour time frame.

Customize Printer
Friendly Page

Enables or disables printable Guest User information page. Uploads the
required file from Select Uploaded HTML file drop-down list.

Note:

Provisioner can print the Guest User details in the specified
HTML file.

For more information on customizing and uploading a file using File
Manager, see Configuring the File Manager.

Access Groups Configures the Access Groups for this Onboarding Template. Select the
required checkbox(s) from the available options. If there are no groups
available, click the links to select the required User Groups. For more
information, see Configuring Access Groups.

l User Groups - Single Membership: Configures Single
Membership User Groups for the Onboarding Template.

l User Groups - Multiple Memberships: Configures Multiple
Memberships User Groups for the Onboarding Template.

../../../../../Content/GIM Configuration/Topics/ConfiguringAccessGroups.html
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Name Description

Accessible to
Provisioner

Configures the Guest User settings accessible to Provisioner using this
Onboarding Template.

The options selected in this section are available to the Provisioner.
Each section allows you to customize the required fields to be
Optional / Mandatory.

l General: Configures the general Guest User settings.

Access Groups: Configures the selected Access Groups.

l Email: Configures the Email address of the Guest User.

l Mobile Phone: Configures the contact number of the
Guest User.

l Account State: Enables/disables the administrator to
select whether the Provisioner can view the option to
change the Guest User Account State.

If you select Account Enabled, then the Guest User
Account is enabled by default and default value for
Guest User Enabled field in the Provisioner application -
Guest User Add window is set to true.

If you select Account Disabled, then the Guest User
account is disabled by default and the default value for
Guest User Enabled field in the Provisioner application -
Guest User Add window is set to false.

l

SMS Gateway List: Enables the SMS Gateway list to be
accessible to Provisioner / Self-Service Guest User
registration. If disabled, SMS messages are sent using
the Administrator selected default SMS gateway for
each service provider.

Important:

If a Guest User’s mobile phone service provider
does not support the selected default gateway, the
SMS messages are not sent.

l Delete on Expire: Specifies if the account must be
deleted when account validity duration expires.

If you select Delete on Expire checkbox, Provisioner will
be able to view this field during Guest User creation.
Provisioner can select this to override the specified
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Name Description

conditions (Delete on Expire / Do Not Delete On Expire)
and remove the accounts upon expiry.

If you do not select Delete on Expire checkbox,
Provisioner will not be able to view this field during
Guest User account creation. If you select Delete on
Expire option, the Guest Account is removed on expiry.
If you select Do Not Delete On Expire option, the
account needs to be removed manually.

l

Account Activation: Specifies the type of account
activation to be accessible to Provisioner.

If you select Time Based, Provisioner can configure start
time and duration (upto to a maximum set limit) during
guest account creation.

If you select First Login, Provisioner can configure guest
account duration that is valid from the moment the
Guest User first logs in.

Note:

First Login option enabled Guest User account will
not expire until the user actually logs in. Once the
user logs in, the account expires as per the
specified duration.

l Account Expiration: Enables or disables the account
expiration to be accessible to the Provisioner.

If you select Max Expiration Time, Provisioner can
configure the account validity duration up to the
maximum value specified in the Onboarding Template >
Common > Temporary Accounts Validity field.

If you select Permanent, a permanent Guest User
account is created. This account does not have account
activation preference and will not be deleted on expiry.

l Firstname & Lastname: Allows the Provisioner to
configure first name and last name of the Guest User.

l Access Groups: Configures the selected Access Groups.

ll Resend Details: Enables or disables the Resend functionality on
the Self-Service Registration Screen. This option is not applicable
to REST API Onboarding Template.
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Name Description

If you select Resend All Details, the Resend All Details
functionality is available on Self Service Registration
Screen.

If you select Resend Password Only, the Resend
Password Only functionality is available on Self Service
Registration Screen.

l Custom Attributes: Configures the custom attributes for Guest
User. For more information, see Configuring Custom
Attributes.

Perform any one of the following:

l If Sponsor approval is required for the Self-Service Guest Users in this Onboarding
Template, go to Configuring Sponsor Approval.

l If this Onboarding Template manages devices, go to Configuring the Devices Record
Details.

l Otherwise go to Configuring the Account Notification Templates.

Configuring Sponsor Approval
Use this procedure to configure Sponsor approval if Self-Service Guest Users must be approved
by a Sponsor before they are granted access.

Before you begin

In theCommontab, selectSelf Service with Sponsor Approval to enableSponsortab.

Procedure

1. In the navigation pane, click Onboarding Templates >Add>Sponsortab.

TheSponsorscreen is displayed.

../../../../../Content/GIM Configuration/Topics/ConfiguringCustomAttributes.html
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2. In theSponsorscreen, select Sponsor approval required to configure the Sponsor approval details.

3. In theSponsor Detailssection, select the required options.

4. In theSponsor Configurationsection, select the required checkboxes.

5. In theSponsor Authenticationsection, select the Authentication Before Approvalcheckbox to login to the
Provisioner account and approve or deny the request.

6. ClickSaveto save the configuration or click Cancelto cancel the changes.

Field Descriptions

Name Description

Sponsor approval
required

Configures the Sponsor approval settings accessible in this Onboarding
Template.
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Name Description

Sponsor Details Configures any one of the Sponsor details

l Manually Enter Sponsor Details: Configures the Sponsor
Email Domains. You can add email domain name (2– 32
character length).

If the entered domain name is less than 2 characters or more
than 32 characters, theAddbutton is disabled.

For example, the domain name must be in the following the
format:

<name>@healthbenifits.co.in

<name>@companyname.org

<name>@extremenetworks.travelersinsurance.com

If you have added the Sponsor Email Domains, it forces the
Guest User to have a Sponsor in particular email domain.

l Predefined Sponsor:Configures the Sponsor email address.
Add the Sponsor email address in thePredefined Sponsor
Emailfield.

In theSponsor Email Field, do one of the following:

l SelectGuest Selects from Predefined Sponsor list to select
Sponsor email address from the predefined list .

l Select Guest must specify Sponsor Email to match to specify
the Sponsor email address that matches one of the email
address from the predefined list.

l Fixed Sponsor: Configures the optional First Name ,Last
Name fields. TheEmailfield is mandatory to be configured.
These details are not visible to the Guest User.

l Configured Sponsor LDAP Group: Configures the Sponsor
LDAP Group. This group contains all the sponsors that the
user must select for approval.

Note:

If you are using the GIM Sponsor Retrieval Advanced
Configuration inExtremeCloud IQ - Site Engine, the
check box for GIM Sponsor LDAP Group Filter controls
additional Sponsor look-up based on this LDAP Group.

For example,

Ex. CN=Gim,CN=Users,DC=SponGroup,DC=com
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Name Description

All the Sponsors are cached locally in Guest and IoT Manager
and the frequency of the refresh depends on the Sync
Duration.

l For example, if duration is specified as 1 hour, the cache refreshes
every hour.

Sponsor Configuration Configures sponsor additional details.

l Admin/Sponsor Email (Always Notified): Configures the email that will
always be notified for all the sponsor related mail notification.

l Sponsor Response Timeout: Configures the time limit for Sponsor
approval. If you select this, the Default action on timeoutfield is
displayed. You can Approve / Deny the request post specified timeout.
For example, (0 - 480 min; 0 = Immediate Default Action) .

l Send Initial Notification to Guest: Enables or disables email and SMS
notification sent to Guest Users as part of the Self-Service registration
flow.

l Send Sponsor Response Notification to Guest : Enables or disables
email and SMS notification sent to Guest Users as part of the Self-
Service registration flow when Sponsor approves or denies the access
request.

Sponsor
Authentication

Select if the Provisioner needs to login to the application prior
approving or denying the Sponsor request. By default, this is
enabled.

l Authentication Before Approval: Select to send an email to the
Provisioner to login to the account and approve or deny the request. If
it is unchecked, the Provisioner will receive an email with a link to
approve or deny the request.

Configuring the Device Record Details
Use this procedure to configure the Device record details for the Onboarding Template.

Before you begin

In the Common tab, select Guest User and Device Provisioning or Guest User and Device
Provisioning using API option to enable Devices tab.

If you select Provisioners belonging to this Onboarding Template can view each other’s records
checkbox, the Provisioner using this Onboarding Template can view all the records of this
particular Onboarding Template.
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Note: If you select Guest User and Device Provisioning using CSV option, skip this section.
For more information, see Configuring Guest User and Device Provisioning Using CSV.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Devices tab.. The Devices screen is
displayed.

2. In the Devices screen, select Onboarding Template for Devices to configure the Device record details. By
default, it is selected.

3. In the Access Groups section, select the Single and Multiple End-System Groups as required. For more
information, see Configuring Access Groups.

4. In the Accessible to Provisioner section, configure the General, Custom Attributes, Device Attributes and
Account Validity Period options as required.

5. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use Devices tab.
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Name Description

Access Groups Configures the Access Groups for this Onboarding Template. Select the required
checkbox(es) from the available options. If there are no groups available, click the
links to select the required End-System Groups. For more information, see
Configuring Access Groups.

The options available are:

l End-System Groups - Single Membership: Configures single End-
System Groups for the Onboarding Template.

l End-System Groups - Multiple Memberships: Configures multiple
End System Groups for the Onboarding Template.

../../../../../Content/GIM Configuration/Topics/ConfiguringAccessGroups.html
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Name Description

Accessible To
Provisioner

Configures the Devices record settings accessible to Provisioners in this Onboarding
Template.

The options selected in this section are available to the Provisioner. Each
section allows you to customize the required fields as Optional /
Mandatory.

l General: Configures the general Devices record settings.

l Name: Configures the Device name.

l Device State: Enables/Disables the administrator to select
whether the Provisioner can view the option to change the
Device State.

If you select Device Enabled, then the Device Record is
enabled by default and default value for Record Enabled field
in the Provisioner application - Device Add window is set to
true.

If you select Device Disabled, then the Device Record is
disabled by default and the default value for Record Enabled
field in the Provisioner application - Device Add window is
set to false.

l Limit number of enabled devices per Provisioner: Select this
to restrict the maximum number of enabled Devices allowed
for a Provisioner and enter the value in Maximum number of
enabled devices field. When the limit exceeds, though
Provisioner can create the Devices but disabled Devices
cannot be authenticated.

l Display Admin’s Comments: Select this checkbox to enable
Administrator's additional information to be displayed on the
Provisioner’s Create Device screen and enter the information
in Comments field.

l Source: Configures the default source value. If you select
Auto populate with GIM-[Onboarding Template] option, the
default value populated will be Guest and IoT Manager
Onboarding Template name. If you select Static option, user
defined custom Device source value can be provided.

l Custom Attributes: Configures the custom attributes for Device
record settings. For more information, see Configuring Custom
Attributes.

l Device Attributes: Configures the device attributes for Device record settings.

l Asset Type: Configures the Device Asset Type for Permanent

../../../../../Content/GIM Configuration/Topics/ConfiguringCustomAttributes.html
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Name Description

/ Temporary.

l Device Type Groups: Configures the Device Type Groups.

l Device Type : Configures the Device Type of the selected
Device Type Group.

l Access Groups: Configures the selected Access Groups.

l Account Validity Period: Configures the account validity period for
Device record settings. By default, it is enabled.

l Delete on Expire: Specifies if the Device must be deleted
when account validity duration expires.

l Account Activation: Specifies the type of account activation
to be accessible to Provisioner. If you select Time Based,
Provisioner can configure start time and duration (up to a
maximum set limit) during guest account creation. If you
select First Login, Provisioner can configure guest account
duration that is valid from the moment the Guest User first
logs in.

l Account Expiration: Enables or disables the account
expiration to Max Expiration Time to be accessible to
Provisioner.

Configuring Device Type Groups
Use this procedure to allow the Administrator to select a certain set of Device Type Groups to
be made available to the Provisioner while creating Devices.

Before you begin

In the Common tab, select Guest User and Device Provisioning or Guest User and Device
Provisioning using API option to enable Device Type Groups tab.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Device Type Groups tab. The Device Type
Groups screen is displayed:
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2. Click Select All to enable all the Device Type Groups. By default, it is enabled.

3. In the Available Device Type Groups tree list, select the Device Type Groups that are required.

4. Click Save to save the configuration or click Cancel to cancel the changes.

Note:

Configuring Device Type Groups limits the groups accessible to Provisioner while
creating Devices.

Field Description

Use the data in the following table to use Device Type Groups tab.

Name Description

Select All Selects all the Device Type Groups accessible to Provisioners.

Available Device Type
Groups

Specifies the available Device Type Groups accessible to Provisioner. By
default, all are selected. You can select the required Device Type Groups.
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Note:

The configured Device Type Groups apply to Self-Service, Provisioner, REST API while
creating Devices.

Configuring the Account Notification Templates
Guest and IoT Manager allows you to edit the information sent in account notifications to new
users. When a Guest User account is created or updated, notification is sent through an email,
an SMS message, or both. You can use SMS and Email templates to edit the account notification
details.

Use the Notification > General tab to send messages to the Guest User when a Provisioner
saves the Guest User account or an account is created through Self-Services. You can modify
the message if Sponsor Approval is required. For more information, see Configuring General
Details.

Use the Notification > Sponsor Email tab to notify the Sponsor for appropriate action. For more
information, see Configuring Sponsor Email.

Use the Notification > Sponsor Action tab to send messages to the Guest User when the
Sponsor approves or denies the user account access request. For more information, see
Configuring Sponsor Action.

Note:

Ensure that you have set up your Email and / or SMS gateways. For more information, see Setting
Notification Parameters.

Configuring General Details

Use this procedure to configure the account notification sent to Guest Users.

Note:

When using SMS Template and Email Template, if Sponsor approval is required, change the
default message and variables to indicate that the request is pending for Sponsor approval.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Notification > General tab. The General
screen is displayed.

../../../../../Content/GIM Configuration/Topics/ConfiguringGeneralDetails.html
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2. In the SMS Template > Message field, enter the text message. You can use the available displayed
variables.

3. In the Email Charset section, select an option as required.

4. In the Email Template > Subject field, enter the subject of email sent to the Guest User and enter the
message in the Message field.

5. If you select Guest User Provisioning using Outlook Add-in or Zero Touch Guest User
Provisioning, then an option to Select Interface is displayed to select the interface for the
$loginUrl variable.

6. In the Terms of Use and / or Additional information to be included as part of guest account confirmation
page field, enter the required information.

7. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the General tab.
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Name Description

SMS Template Specifies the SMS template that is used to send an SMS to the Guest User when
a Provisioner and Self-Service creates or updates the account.

The available options are:

l Message: Configures the message using displayed available
variables such as $username, $password, $sponsorname, and
$sponsoremail if required. 

If you select Zero Touch Guest User Provisioning option, the
available variables are $username, $password$username,
$loginUrl.

Note:

If Sponsor approval is required, update the message with
relevant variable.

l SMS characters: Displays the length of your message in
characters. The SMS message is limited to 160 characters.

Note:

This section is disabled for Outlook Add-in Onboarding
Template.

Email Charset Specifies the type of character set for the contents of the Guest User email
template.

The options available are:

l HTML Character Set: Configures the email template to
support HTML content. You can select the Font and Color
from the available list. By default, it is enabled.

l Plain Character Set: Configures the email template to contain
only plain characters.

Note:

l This Character Set is applicable for all Email Notifications.

l This section is disabled for Zero Touch Onboarding Template.
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Name Description

Email Template Specifies the email template that is used to send an email to the Guest User
when a Provisioner and Self-Service creates or updates the account.

The option available are:

l Subject: Configures the subject of the email to be sent to the
Guest User.

l Message: Configures the message using displayed available
variables such as $username, $password, $firstname,
$lastname, $email, $starttime, $endtime, $sponsorname,
$sponsoremail, $terms, and $userCustom1-6 if required.

If you select Guest User Provisioning using Outlook Add-in,
the available variables are $username, $password, $email,
$starttime, $endtime, $terms, $loginUrl, $ssid

For example, the variable $userCustom1-6 reflects the
additional information entered by the Provisioner while
creating Guest User accounts and the variable $terms is
included to add the "Terms of Use" confidential information in
the email template.

Note:

This section is disabled for Zero Touch Onboarding
Template.

Select Interface Configures the required interface through which the Guest User can
access the network. The options available are:

l Admin

l Service A

By default, Service A is selected.

For example, If Service A interface is selected, the login link that the
Guest User receives uses Service A interface IP address/FQDN. This
action affects the $loginUrl variable.

Terms of Use and/or
Additional information
to be included as part
of guest account
confirmation page

Configures a message to be displayed on the Guest account
confirmation screen when an account is created. The Provisioner
can print this confirmation and hand it to the Guest user. By default,
text entered is appended as part of email confirmation sent to the
user.

Note:

This section is disabled for Zero Touch Onboarding Template.
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Configuring Sponsor Email

Use this procedure to configure notification email sent to the Sponsor to approve or deny the
request for a Guest User account.

Before you begin

In the Common tab, select Self Service with Sponsor Approval option to enable the Sponsor
Email tab.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Notification > Sponsor Email tab. The
Sponsor Email screen is displayed.

2. In the Email Template > Subject field, enter the subject of the Sponsor request email and in the Message
field, enter the message to be sent to the sponsor to approve or deny the access request for a Guest
User account. You can use the available displayed variables.
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3. In the Select Interface field, select the required interface from the drop-down list. By default, Admin is
selected.

4. Click Save to submit the information or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Sponsor Email tab.

Name Description

Email Template Specifies the email template that is used to notify the Sponsor for appropriate
action.

The options available are:

l Subject: Configures the subject of the email to be sent to the
Sponsor.

l Message: Configures the message using displayed available
variables such as $username, $password, $firstname,
$lastname, $email, $starttime, $sponsoractionlink,
$endtime, and $userCustom1-6 if required. 

Note:

If you have selected Authentication Before Approval field in
Sponsor tab, $sponsoractionlink variable is available. If
you have unchecked, the $sponsorapprovelink and
$sponsordenylink variables are available.

Select Interface Configures the required interface to allow a Sponsor to have access to a certain
network to approve or deny received requests.

The options available are:

l Admin

l Service A

By default, Service A is selected.

For example, If Service A interface is selected, the email link that
Sponsor receives uses Service A interface IP address/ FQDN. This action
affects the $sponsorapprovelink and $sponsordenylink variable.

Note:

This field is available only if you have selected Authentication
Before Approval field in Sponsor tab. For more information, see
Configuring Sponsor Approval.

../../../../../Content/GIM Configuration/Topics/ConfiguringSponsorApproval.html
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Configuring Sponsor Action

Use this procedure to configure Guest User account notification when the Sponsor approves or
denies the user account access request.

Before you begin

In the Common tab, select Self Service with Sponsor Approval option to enable the Sponsor
Action tab.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Notification > Sponsor Action tab.

The Sponsor Action screen is displayed
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2. In the SMS Template > Message field, enter the text message. You can use the available displayed
variables.

3. In the Email Template > Subject field, enter the subject of the Sponsor request email and in the Message
field, enter the message to be sent to the sponsor to approve or deny the access request for a Guest
User account. You can use the available displayed variables.

4. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Sponsor Action tab.

Name Description

SMS
Template

Specifies the email template that is used to send an email to the
Guest User when a Sponsor approves or denies the Guest User
account.

The option available are:

l Message: Configures the message using displayed
available variables such as $username, $password,
$sponsorname, $sponsoremail, and
$sponsoraction if requried.

l SMS characters: Displays the length of your message
in characters. The SMS message is limited to 160
characters.

Email
Template

Specifies the email template that is used to send an email to the
Guest User when a Sponsor approves or denies the Guest User
account.

The options available are:

l Subject: Configures the subject of the email to be
sent to the Guest User.

l Message: Configures the message using displayed
available variables such as $username, $password,
$firstname, $lastname, $email, $starttime,
$endtime, $sponsorname, $sponsoremail,
$sponsoraction, and $sponsortext if required.

Configuring Advanced Details
Use this procedure to configure advanced details for the Onboarding Template.
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Procedure

1. In the navigation pane, click Onboarding Template > Add > Advanced tab.

The Advanced screen is displayed.

2. In the Time Zone drop-down list, select the required zone.

3. Select Default Onboarding Template for LDAP Provisioner to send the Onboarding Template as default
for Provisioners who are not associated with any Onboarding Template(s).

4. In the Associated LDAP Groups section, Add or Remove the required LDAP Groups to be associated
with the Onboarding Template(s).

5. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Advanced tab.

Name Description

Time Zone Configures the time zone.
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Name Description

Default Onboarding
Template for LDAP
Provisioner

Enables or disables the default Onboarding Template for LDAP Provisioner. By
default, it is enabled.

Note:

If you log in as a Provisioner:

l Case Scenario: The group that you are part of is not
associated with any Onboarding Template.

l Result: The Onboarding Template(s) marked as default
is / are sent to you.

Associated LDAP
Groups

Configures the LDAP group(s) associated with the Onboarding Template.

Note:

If the logged in Provisioner is a part of any of the
specified group(s), then the created Onboarding
Template must be sent to the Provisioner. You can
define the same group for multiple Onboarding
Templates.

For example,

Ex CN=GimTemplate,CN=Test,DC=ADGroup,DC=com

Configuring Guest User Provisioning Using Outlook Add-in
Use this procedure to configure Guest User record details for using Outlook Add-in.

Before you begin

In the Common tab, select Guest User Provisioning using Outlook Add-in option to configure
Guest User account details.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Guest Users tab.

The Guest Users screen is displayed.
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2. In the Guest Users screen, select the Onboarding Template for Guest Users checkbox to configure the
Guest User account details. By default, it is enabled.

3. In the Username section, by default Generate Username With option is enabled while other options are
disabled.

4. In the Password section, select an option as required.

5. In the Password Complexity Check section, set the password complexity by selecting the required
alphanumeric checkbox.

6. In the Access Groups section, select the Single and Multiple Memberships Groups as required. For more
information, see Configuring Access Groups.

7. In the User Email Domains section, enter the preferred domain names to be excluded from the user
creation and click Add.

8. In the Accessible to Provisioner section, configure the General and Custom Attributes as required.

9. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Guest User tab.
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Name Description

Guest Notification Email notification is checked and this field is disabled for Outlook Add-in
Onboarding Template.

Username Specifies the different available options of Username that the Administrator
can enable. Only Generate Username With field is enabled.

l Generate UsernameWith: Specifies the format of the Guest
User Name.

l Random Generated Username: Random generated
Username is a combination of Uppercase letters,
Lowercase letters and Numbers. By default, all are
enabled. Enter the length as a single value / range
(within 3 - 40). Depending on the checkbox(es)
selected (lower case, upper case and number), a
random Username within the specified length is
generated.

For example, the length specified is 6 characters, and
you have selected “lower case”, “upper case”, and
“number”; the Username / Password must contain at
least one lowercase, one uppercase, and one number.
Valid Usernames are: “a1Bacd”, “2aBBCD” and so on.

Password Specifies the different available options of password that the
Administrator can enable.

l Guest Defines Password: This option is disabled for Outlook
Add-in Onboarding Template.

l Random Generated Password: Generates random password
with the specified password complexity.

For example, the length specified is 6 characters, and you
have selected “lower case”, “upper case”, and “number”; the
Username / Password must contain at least one lowercase,
one uppercase, and one number. Valid Usernames are:
“a1Bacd”, “2aBBCD” and so on.

l Use Username as Password: Allows the Guest User to login
with only a Username. The Access Portal login screen must be
modified to accept a Username without a password.

l Static Password: Allows you to set the password as a fixed
string so that a single password can be used for multiple
accounts.
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Name Description

Password Complexity
Check

Configures the parameters to enforce when guests change their account
passwords. Different levels of password complexity is required to select
passwords that contain different combinations of characters, lowercase letters,
uppercase letters, digits and symbols.

If multiple combinations are selected, the different levels of
password complexity is selected appropriately.

l characters: Configures the number of characters in the
password.

l lower case: Indicates the password must have lower case
only.

l upper case: Indicates the password must have upper case
only.

l number: Indicates the password must have number only.

l special characters: Indicates the password must have special
characters only. Special characters are: ! @ # $ % ^ & * ( 
) - +.

Guest User Account
Limit

This field is disabled for Outlook Add-in Onboarding Template.

Customize Printer
Friendly Page

This field is disabled for Outlook Add-in Onboarding Template.

Access Groups Configures the Access Groups for this Onboarding Template. Select the
required checkbox(s) from the available options. If there are no groups
available, click the links to select the required User Groups. For more
information, see Configuring Access Groups.

l User Groups - Single Membership: Configures Single
Membership User Groups for the Onboarding Template.

l User Groups - Multiple Memberships: Configures Multiple
Memberships User Groups for the Onboarding Template.

User Email Domains Configures the domains that need to be excluded during Guest User creation.

For example, if the specified domain is "@extremenetworks.com";
Guest User accounts with email "name@extremenetworks.com" is
not created.
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Name Description

Accessible to
Provisioner

Configures the Guest User settings accessible to Provisioner using this
Onboarding Template.

The options selected in this section are available to the Provisioner.

l General: Configures the general Guest User settings.

l Email: Configures the Email address of the Guest User.
This option is checked and disabled for Outlook Add-in
Onboarding Template.

l Mobile Phone: This option is disabled for Outlook Add-
in Onboarding Template.

l SSID: Specifies if the Provisioner can configure the SSID
details.

l SMS Gateway List: This option is disabled for Outlook
Add-in Onboarding Template.

l Delete on Expire: Specifies if the account has to be
deleted when account validity duration expires.

If you select Delete on Expirecheckbox, Provisioner will
be able to view this field during Guest User creation.
Provisioner can select this to override the specified
conditions Delete on Expire / Do Not Delete On Expire
and remove the accounts upon expiry.

If you do not select Delete on Expire checkbox,
Provisioner will not be able to view this field during
Guest User account creation.

If you select Delete on Expire option, the Guest Account
is removed on expiry. If you select Do Not Delete On
Expire option, the account needs to be removed
manually.

l Account Activation: Specifies the type of account
activation to be accessible to Provisioner.

If you select Time Based, Provisioner can configure start
time and duration (upto to a maximum set limit) during
guest account creation.

If you select First Login, Provisioner can configure guest
account duration that is valid from the moment the
Guest User first logs in.

For Outlook Add-in Onboarding Template, Time based
is selected and the field is disabled.
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Name Description

l Account Expiration: Enables or disables the account
expiration to be accessible to Provisioner.

If you select Max Expiration Time, Provisioner can
configure the account validity duration up to the
maximum value specified in the Onboarding Template >
Common > Temporary Accounts Validity field.

If you select Permanent, a permanent Guest User
account is created. This account does not have account
activation preference and will not be deleted on expiry.

For Outlook Add-in Onboarding Template, Max
Expiration Time is checked and the field is disabled.

l Firstname & Lastname: This option is disabled for
Outlook Add-in Onboarding Template.

l Access Groups: Configures the selected Access Groups.

l Resend Details: This option is not applicable for
Outlook Add-in Onboarding Template.

l Custom Attributes: This option is disabled for Outlook
Add-in Onboarding Template.

Configuring Guest User Provisioning Using Vouchers
Use this procedure to configure Guest User record details for using Vouchers.

Before you begin

In the Common tab, select Guest UserProvisioning using Vouchers option to configure Guest
User account details.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Guest Users tab. The Guest Users screen is
displayed.
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2. In the Username section, by default Generate Username With along with Random Generated Username
option is enabled while other options are disabled.

3. In the Password section, select an option as required.

4. In the Password Complexity Check section, set the password complexity by selecting the required
alphanumeric checkbox.

5. In the Voucher Template section,you can select the printable templates available to the
Provisioner. The options are:

l Select Avery 5371 Business Card Template to print in Avery 5371 format.

l Select Default to print in grid format.

6. In the Access Groups section, select the Single and Multiple Memberships Groups as required. For more
information, see Configuring Access Groups.

7. In the Accessible to Provisioner section, configure the General section as required.

8. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Guest User tab.
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Name Description

Guest Notification Display Username and Display Password are checked and this field is disabled
for Voucher type Onboarding Template.

Username Specifies the different available options of Username that the Administrator can
enable. Only Generate Username With field is enabled.

l Generate UsernameWith: Specifies the format of the Guest
User Name.

l Random Generated Username: Random generated
Username is a combination of Uppercase letters,
Lowercase letters and Numbers. By default, all are
enabled. Enter the length as a single value / range
(within 3 - 40). Depending on the checkbox(es) selected
(lower case, upper case and number), a random
Username within the specified length is generated.

For example, the length specified is 6 characters, and
you have selected “lower case”, “upper case”, and
“number”; the Username / Password must contain at
least one lowercase, one uppercase, and one number.
Valid Usernames are: “a1Bacd”, “2aBBCD” and so on.

Password Specifies the different available options of password that the Administrator can
enable.

l Guest Defines Password: This option is disabled for Voucher
Type Onboarding Template.

Guest Confirms Password: This option is disabled for Voucher
Type Onboarding Template.

l Random Generated Password: Generates random password
with the specified password complexity.

For example, the length specified is 6 characters, and you have
selected “lower case”, “upper case”, and “number”; the
Username / Password must contain at least one lowercase, one
uppercase, and one number. Valid Usernames are: “a1Bacd”,
“2aBBCD” and so on.

l Use Username as Password : Allows the Guest User to login
with only a Username. The Access Portal login screen must be
modified to accept a Username without a password.

l Static Password: Allows you to set the password as a fixed
string so that a single password can be used for multiple
accounts.
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Name Description

Password
Complexity Check

Configures the parameters to enforce when guests change their account
passwords. Different levels of password complexity is required to select
passwords that contain different combinations of characters, lowercase letters,
uppercase letters, digits and symbols.

If multiple combinations are selected, the different levels of password
complexity is selected appropriately.

l characters: Configures the number of characters in the
password.

l lower case: Indicates the password must have lower case only.

l upper case: Indicates the password must have upper case only.

l number: Indicates the password must have number only.

l special characters: Indicates the password must have special
characters only. Special characters are: ! @ # $ % ^ & * ( 
) - +

Guest User Account
Limit

This field is disabled for Voucher Type Onboarding Template.

Customize Printer
Friendly Page

This field is disabled for Voucher Type Onboarding Template.
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Name Description

Voucher Template This field displays the templates accessible to the provisioner. They
are as follows:

Default: To print in the default grid view

Avery 5371 Business Card Template: To print in the Avery 5371
Business Card format view. The configurations are as follows:

l Title: Configures the Title of the Business card:

l Text: Configures the Text for the Title. A Maximum of 35
characters can be used in the Text of the Title.

l Font: Configures the font family for the Title.

l Color: Configures the color of font of the Title.

l Size: Configures the Font Size of the Title in Pixels.

Content: Configures the Content of the Business card.

l Text: Configures the Text for the Content. A Maximum of 145
characters can be used in the Text of the Content. The available
Variables are $username, $password, $ssid, $QRCode

l Font: Configures the Font family for the Content.

l Color: Configures the color of font of the Content.

l Size: Configures the Font Size of the Content.

Select Network Interface: Configures the Network Interface
used for the URL embedded in $QRCode. The available
interfaces are the Admin interface or Service A interface.

Preview: Displays the print version of Voucher Template.

Access Groups Configures the Access Groups for Voucher Type Onboarding Template. Select
the required checkbox(s) from the available options. If there are no groups
available, click the links to select the required User Groups. For more
information, see Configuring Access Groups.

l User Groups - Single Membership: Configures Single
Membership User Groups for the Onboarding Template.

l User Groups - Multiple Memberships: Configures Multiple
Memberships User Groups for the Onboarding Template.
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Name Description

Accessible to
Provisioner

Configures the Guest User settings accessible to Provisioner using this
Onboarding Template.

The options selected in this section are available to the Provisioner.

l General: Configures the general Guest User settings.

l Email: Configures the Email address of the Guest User.
This option is disabled for Voucher Type Onboarding
Template.

l Mobile Phone: This option is disabled for Voucher Type
Onboarding Template.

l SSID: Specifies if the Provisioner can configure the SSID
details.

l Account State: Enables Enables/disables the
administrator to select whether the Provisioner can view
the option to Enables/disables the administrator to
select whether the Provisioner can view the option to
change the Guest User Account State.

If you select Account Enabled, then the Guest User
Account is enabled by default and default value for
Guest User Enabled field in the Provisioner application -
Guest User Add window is set to true.

If you select Account Disabled, then the Guest User
Account is disabled by default and the default value for
Guest User Enable field in the Provisioner application -
Guest User Add window is set to false.

l SMS Gateway List: This option is disabled for Voucher Type
Onboarding Template.

l Delete on Expire: Specifies if the account has to be
deleted when account validity duration expires.

If you select Delete on Expire checkbox, Provisioner will
be able to view this field during Guest User creation.
Provisioner can select this to override the specified
conditions Delete on Expire / Do Not Delete On Expire
and remove the accounts upon expiry.

If you do not select Delete on Expire checkbox,
Provisioner will not be able to view this field during
Guest User account creation.

If you select Delete on Expire option, the Guest Account



Creating anOnboarding Template

137 of 253

Name Description

is removed on expiry. If you select Do Not Delete On
Expire option, the account needs to be removed
manually.

l Account Activation: Specifies the type of account activation to be
accessible to Provisioner.

If you select Time Based:, Provisioner can configure start
time and duration (upto to a maximum set limit) during
guest account creation

If you select First Login:, Provisioner can configure guest
account duration that is valid from the moment the
Guest User first logs in.

Note:

First Login option enabled Guest User account will
not expire until the user actually logs in. Once the
user logs in, the account expires as per the specified
duration.

l Account Expiration: Enables or disables the account
expiration to be accessible to Provisioner.

If you select Max Expiration Time, Provisioner can
configure the account validity duration up to the
maximum value specified in the Onboarding Template >
Common > Temporary Accounts Validity field.

If you select Permanent, a permanent Guest User
account is created. This account does not have account
activation preference and will not be deleted on expiry.
For Voucher Type Onboarding Template, Max Expiration
Time is selected and the field is disabled.

l Firstname & Lastname: This option is disabled for
Voucher Type Onboarding Template.

l Access Groups: Configures the selected Access Groups.

l Resend Details: This option is not applicable to Voucher
Type Onboarding Template.

l Custom Attributes: This option is disabled for Voucher
Type Onboarding Template.
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Configuring Guest User and Device Provisioning Using CSV
Use this procedure to configure Guest User record details for using CSV and Device Record
details for using CSV.

Before you begin

In the Common tab, select Guest User and Device Provisioning using CSV option to configure
Guest User account and Device Record details.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Guest Users tab. The Guest Users screen is
displayed.

2. In the Username section, by default Generate Username With along with Random Generated Username
option is enabled while other options are disabled.

3. In the Password section, select an option as required.

4. In the Password Complexity Check section, set the password complexity by selecting the required
alphanumeric checkbox.
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5. In the Access Groups section, select the Single and Multiple Memberships Groups as required. For more
information, see Configuring Access Groups.

6. In the Accessible to Provisioner section, configure the General section as required.

7. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use the Guest User tab.

Name Description

Guest Notification Display Username and Display Password are checked and this field is disabled
for CSV type Onboarding Template.

Username Specifies the different available options of Username that the Administrator can
enable. Only Generate Username With field is enabled.

l Generate UsernameWith: Specifies the format of the Guest
User Name.

l Random Generated Username: Random generated
Username is a combination of Uppercase letters,
Lowercase letters and Numbers. By default, all are
enabled. Enter the length as a single value / range (within
3 - 40). Depending on the checkbox(es) selected (lower
case, upper case and number), a random Username
within the specified length is generated.

For example, the length specified is 6 characters, and
you have selected “lower case”, “upper case”, and
“number”; the Username / Password must contain at
least one lowercase, one uppercase, and one number.
Valid Usernames are: “a1Bacd”, “2aBBCD” and so on.
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Name Description

Password Specifies the different available options of password that the Administrator can
enable.

l Guest Defines Password: This option is disabled for CSV Type
Onboarding Template.

Guest Confirms Password: This option is disabled for CSV Type
Onboarding Template.

l Random Generated Password: Generates random password
with the specified password complexity.

For example, the length specified is 6 characters, and you have
selected “lower case”, “upper case”, and “number”; the
Username / Password must contain at least one lowercase, one
uppercase, and one number. Valid Usernames are: “a1Bacd”,
“2aBBCD” and so on.

l Use Username as Password : Allows the Guest User to login
with only a Username. The Access Portal login screen must be
modified to accept a Username without a password.

l Static Password: Allows you to set the password as a fixed
string so that a single password can be used for multiple
accounts.

Password
Complexity Check

Configures the parameters to enforce when guests change their account
passwords. Different levels of password complexity is required to select
passwords that contain different combinations of characters, lowercase letters,
uppercase letters, digits and symbols.

If multiple combinations are selected, the different levels of password
complexity is selected appropriately.

l characters: Configures the number of characters in the
password.

l lower case: Indicates the password must have lower case only.

l upper case: Indicates the password must have upper case only.

l number: Indicates the password must have number only.

l special characters: Indicates the password must have special
characters only. Special characters are: ! @ # $ % ^ & * ( 
) - +

Guest User Account
Limit

This field is disabled for CSV Type Onboarding Template.
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Name Description

Customize Printer
Friendly Page

This field is disabled for CSV Type Onboarding Template.

Access Groups Configures the Access Groups for CSV Type Onboarding Template. Select the
required checkbox(s) from the available options. If there are no groups available,
click the links to select the required User Groups. For more information, see
Configuring Access Groups.

l User Groups - Single Membership: Configures Single
Membership User Groups for the Onboarding Template.

l User Groups - Multiple Memberships: Configures Multiple
Memberships User Groups for the Onboarding Template.
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Name Description

Accessible to
Provisioner

Configures the Guest User settings accessible to Provisioner using this
Onboarding Template.

The options selected in this section are available to the Provisioner.

l General: Configures the general Guest User settings.

l Email: Configures the Email address of the Guest User.
This option is disabled for CSV Type Onboarding
Template.

l Mobile Phone: This option is disabled for CSV Type
Onboarding Template.

ll Account State: Enables Enables/Disables the
administrator to select whether the Provisioner can view
the option to Enables/Disables the administrator to
select whether the Provisioner can view the option to
change the Guest User Account State.

If you select Account Enabled, then the Guest User
Account is enabled by default and default value for
Guest User Enable field in the Provisioner application -
Guest User Add window is set to true.

If you select Account Disabled, then the Guest User
account is disabled by default and the default value for
Guest User Enable field in the Provisioner application -
Guest User Add window is set to false.

l SMS Gateway List: This option is disabled for CSV Type
Onboarding Template.

l Delete on Expire: Specifies if the account has to be
deleted when account validity duration expires.

If you select Delete on Expire checkbox, Provisioner will
be able to view this field during Guest User creation.
Provisioner can select this to override the specified
conditions Delete on Expire / Do Not Delete On Expire
and remove the accounts upon expiry.

If you do not select Delete on Expire checkbox,
Provisioner will not be able to view this field during Guest
User account creation.

If you select Delete on Expire option, the Guest Account
is removed on expiry. If you select Do Not Delete On
Expire option, the account needs to be removed
manually.
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Name Description

l Account Activation: Specifies the type of account activation to be
accessible to Provisioner.

If you select Time Based:, Provisioner can configure start
time and duration (upto to a maximum set limit) during
guest account creation

If you select First Login:, Provisioner can configure guest
account duration that is valid from the moment the
Guest User first logs in.

Note:

First Login option enabled Guest User account will
not expire until the user actually logs in. Once the
user logs in, the account expires as per the specified
duration.

l Account Expiration: Enables or disables the account
expiration to be accessible to Provisioner.

If you select Max Expiration Time, Provisioner can
configure the account validity duration up to the
maximum value specified in the Onboarding Template >
Common > Temporary Accounts Validity field.

If you select Permanent, a permanent Guest User
account is created. This account does not have account
activation preference and will not be deleted on expiry.
For CSV Type Onboarding Template, Max Expiration
Time is selected and the field is disabled.

l Firstname & Lastname: This option is disabled for CSV
Type Onboarding Template.

l Access Groups: Configures the selected Access Groups.

l Resend Details: This option is not applicable to CSV Type
Onboarding Template.

l Custom Attributes: This option is disabled for CSV Type
Onboarding Template.
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Configuring Device Record Details

Procedure

1. In the navigation pane, click In the navigation pane, click Onboarding Templates > Add > Devices tab.
The Devices screen is displayed.

2. In the Devices screen, select Onboarding Template for Devices to configure the Device
record details. By default, it is selected.

3. In the Access Groups section, select the Single and Multiple End-System Groups as
required. For more information, see Configuring Access Groups.

4. In the Accessible to Provisioner section, configure the General, Custom Attributes, Device Attributes,
and Account Validity Period options as required.

5. Click Save to save the configuration or click Cancel to cancel the changes.

Field Descriptions

Use the data in the following table to use Devices tab.
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Name Description

Access Groups Configures the Access Groups for this Onboarding Template. Select the
required checkbox(es) from the available options. If there are no groups
available, click the links to select the required End-System Groups. For more
information, see Configuring Access Groups.

The options available are:

l End-System Groups - Single Membership: Configures single
End-System Groups for the Onboarding Template.

l End-System Groups - Multiple Memberships: Configures
multiple End System Groups for the Onboarding Template.
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Name Description

Accessible To
Provisioner

Configures the Devices record settings accessible to Provisioners in this
Onboarding Template.

The options selected in this section are available to the Provisioner.
Each section allows you to customize the required fields as
Optional / Mandatory.

l General: Configures the general Devices record settings.

l Name: Configures the Device name.

l Device State: Enables/Disables the administrator to
select whether the Provisioner can view the option to
change the Device State.

If you select Device Enabled, then the Device Record is
enabled by default and default value for Record
Enabled field in the Provisioner application - Device
Add window is set to true.

If you select Device Disabled, then the Device Record
is disabled by default and the default value for Record
Enabled field in the Provisioner application - Device
Add window is set to false.

l Limit number of enabled devices per Provisioner:This
option is disabled for CSV type Onboarding Template.

l Display Admin’s Comments: This option is disabled for
CSV type Onboarding Template.

l Source: Configures the default source.

If you select Auto populate with GIM-[Onboarding
Template] option, the default value populated will be
Guest and IoT Manager Onboarding Template name.

If you select Static option, user defined custom Device
source can be provided.

l Custom Attributes: Configures the custom attributes for
Device record settings. For more information, see
Configuring Custom Attributes.

l Device Attributes: Configures the device attributes for Device record
settings.

l Asset Type: Configures the Device Asset Type for
Permanent / Temporary.

l Device Type Groups: Configures the Device Type
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Name Description

Groups. By default, Device Type Groups is checked
and Mandatory option is selected.

l Device Type : Configures the Device Type of the
selected Device Type Group. By default, Device Type
is checked and Mandatory option is selected.

l Access Groups: Configures the selected Access
Groups.

l Account Validity Period: Configures the account validity
period for Device record settings. By default, it is enabled.

l Delete on Expire: Specifies if the Device has to be
deleted when account validity duration expires.

If you select Delete on Expire checkbox, Provisioner
will be able to view this field during Device Record
Creation. Provisioner can select this to override the
specified conditions Delete on Expire / Do Not Delete
On Expire and remove the devices upon expiry.

If you do not select Delete on Expire checkbox,
Provisioner will not be able to view this field during
Device Record creation.

If you selectDelete on Expire option, the Device is
removed on expiry. If you select Do Not Delete On
Expire option, the device needs to be removed
manually.

l Account Activation: Specifies the type of account
activation to be accessible to Provisioner.

If you select Time Based, Provisioner can configure
start time and duration (up to a maximum set limit)
during guest account creation.

If you select First Login, Provisioner can configure
guest account duration that is valid from the moment
the Guest User first logs in.

l Account Expiration: Enables or disables the account
expiration to Max Expiration Time to be accessible to
Provisioner.
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Configuring Zero Touch Guest User Provisioning
Use this procedure to configure Guest User Account Details for using Zero Touch Guest User
Provisioning.

Before you begin

In the Common tab, select Zero Touch Guest User Provisioning.

Procedure

1. In the navigation pane, click Onboarding Templates > Add > Guest Users tab.

The Guest Users screen is displayed.

2. In the Guest Users screen, select the Onboarding Template for Guest Users checkbox to configure the
Guest User account details. By default, it is enabled.

3. In the Username section, by default Generate Username With option is enabled while other options are
disabled.

4. In the Password section, select an option as required.

5. In the Password Complexity Check section, set the password complexity by selecting the required
alphanumeric checkbox.
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6. In the Access Groups section, select the Single and Multiple Memberships Groups as required. For more
information, see Configuring Access Groups.

7. In the Accessible to Provisioner section, configure the General and Custom Attributes as required.

8. Click Save to save the configuration or click Cancel to cancel the changes.

Name Description

Guest Notification SMS notification is checked and this field is disabled for Zero Touch Guest User
Provisioning Template.

Username Specifies the different available options of Username that the
Administrator can enable. Only Generate UsernameWith field is
enabled.

l Generate UsernameWith: Specifies the format of the Guest
User Name. this field is disabled for Zero Touch Guest User
Provisioning Template.Guest Defines User Name: Specifies
the Guest User name this field is disabled for Zero Touch
Guest User Provisioning.

l Guest Defines User Name: Specifies the Guest User name this
field is disabled for Zero Touch Guest User Provisioning.

l Generate Username With: Specifies the format of the Guest User
Name this field is disabled for Zero Touch Guest User
Provisioning.

l Use Email as Username: Specifies to use the Email address as
Username this field is disabled for Zero Touch Guest User
Provisioning.

l Use Mobile Phone as Username: Specifies to use the Mobile
Phone number as Username.

../../../../../Content/GIM Configuration/Topics/ConfiguringAccessGroups.html
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Name Description

Password Specifies the different available options of password that the
Administrator can enable.

l Guest Defines Password: This option is disabled for this field is
disabled for Zero Touch Guest User Provisioning Template.

l Random Generated Password: Generates random password
with the specified password complexity.

For example, the length specified is 6 characters, and you
have selected “lower case”, “upper case”, and “number”; the
Username / Password must contain at least one lowercase,
one uppercase, and one number. Valid Usernames are:
“a1Bacd”, “2aBBCD” and so on.

l Use Username as Password: Allows the Guest User to login
with only a Username. The Access Portal login screen must be
modified to accept a Username without a password.

l Static Password: Allows you to set the password as a fixed
string so that a single password can be used for multiple
accounts.

Password Complexity
Check

Configures the parameters to enforce when guests change their account
passwords. Different levels of password complexity is required to select
passwords that contain different combinations of characters, lowercase letters,
uppercase letters, digits and symbols.

If multiple combinations are selected, the different levels of
password complexity is selected appropriately.

l characters: Configures the number of characters in the
password.

l lower case: Indicates the password must have lower case
only.

l upper case: Indicates the password must have upper case
only.

l number: Indicates the password must have number only.

l special characters: Indicates the password must have special
characters only. Special characters are: ! @ # $ % ^ & * ( 
) - +.

Guest User Account
Limit

This field is disabled for this field is disabled for Zero Touch Guest User
Provisioning Template.
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Name Description

Access Groups Configures the Access Groups for this Onboarding Template. Select the
required checkbox(s) from the available options. If there are no groups
available, click the links to select the required User Groups. For more
information, see Configuring Access Groups.

l User Groups - Single Membership: Configures Single
Membership User Groups for the Onboarding Template.

l User Groups - Multiple Memberships: Configures Multiple
Memberships User Groups for the Onboarding Template.

Accessible to
Provisioner

This section is disabled for Zero Touch Onboarding Template.

Managing Onboarding Templates
Onboarding Template is a collection of settings that establishes the administrative rights and
account settings of the Provisioners that associate with it.

Use this procedure to manage an Onboarding Template.

Procedure

1. In the navigation pane, Click Onboarding Templates.

2. Click the required Onboarding Template to manage.

3. Click Add to create a new Onboarding Template. For more information, see Creating an Onboarding
Template.

4. Click Edit to modify and view the existing Onboarding Template. For more information, see Modifying
and Viewing an Onboarding Template.

5. Click Copy to create a copy of the existing Onboarding Template. For more information, see Copying an
Onboarding Template.

6. Click Delete to delete the selected Onboarding Templates, Onboarding Template Members, and Expired
Guest Accounts. For more information, see Deleting Onboarding Templates and Guest Accounts.

Tip:

Use Ctrl / Shift to select multiple records to delete.

Modifying and Viewing an Onboarding Template
Use this procedure to edit and view an existing Onboarding Template.

Procedure

../../../../../Content/GIM Configuration/Topics/ConfiguringAccessGroups.html
../../../../../Content/GIM Configuration/Topics/CreatingAnOnboardingTemplate.html
../../../../../Content/GIM Configuration/Topics/CreatingAnOnboardingTemplate.html
../../../../../Content/GIM Configuration/Topics/ModifyingandViewingOnboardingTemplate.html
../../../../../Content/GIM Configuration/Topics/ModifyingandViewingOnboardingTemplate.html
../../../../../Content/GIM Configuration/Topics/CopyingOnboardingTemplate.html
../../../../../Content/GIM Configuration/Topics/CopyingOnboardingTemplate.html
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1. In the navigation pane, Click Onboarding Templates.

2. Select the required Onboarding Template from the list.

3. Click Edit > Summary tab to view an Onboarding Template summary.

Note:

You can also view by double-clicking the required Onboarding Template from the
list. The Edit screen is displayed.

4. In the Edit Onboarding Template screen, modify the changes in the required tabs.

5. Click Copy to Clipboard to copy the Onboarding Template summary to clipboard.

6. Click Print to print the Onboarding Template.

7. Click Save to save the configuration or Cancel to cancel the changes.

Copying an Onboarding Template
Use this procedure to create a copy of an existing Onboarding Template.

Note:

The Copy option in the Onboarding Template only creates a new Onboarding Template.
The Provisioner(s) or Guest User(s) or Device(s) associated with the source Onboarding
Template are not added to the copied Onboarding Template.
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Procedure

1. In the navigation pane, click Onboarding Templates.

2. Click the required Onboarding Template from the list.

3. Click Copy.

4. In the Onboarding Template Name field, enter the name, description and notes for the new Onboarding
Template.

5. Modify the required changes in all the tabs for the new Onboarding Template.

6. Click Save to save the configuration or click Cancel to cancel the changes.

Deleting Onboarding Templates and Guest Accounts
Use this procedure to delete Onboarding Template(s), Onboarding Template Member(s) and
Expired Guest User(s).

Procedure

1. In the navigation pane, click Onboarding Templates.

2. Select the required Onboarding Template(s).

3. In the Delete drop-down list, click an option as required.

4. Click Yes or No in the confirmation message to delete the selected Onboarding Template(s),
Onboarding Template Member(s), and Expired Guest User(s).

Field Descriptions

Use data in the following table to use Delete option.

Name Description

Delete Onboarding
Template(s)

Deletes the selected Onboarding Template(s).

Note

You cannot delete an Onboarding Template, if it is associated
with the Guest User(s) or Device(s) or Provisioner(s). Use Delete
Onboarding Template Member(s) Option to proceed in such
scenarios. In case of failure, appropriate error message is
displayed.
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Delete Onboarding
Template Member
(s)

Deletes all the Internal Provisioner(s) or Self Service Provisioner(s), or Guest User
(s), or Device(s) of the selected Onboarding Template. If you select this option,
the Guest and IoT Manager displays a screen that allows you to select the type of
records to delete.

If this option is selected, you need to select the required selection in
the Delete Member screen.

Delete Expired
Guest User(s)

Deletes all the expired Guest User accounts of the selected Onboarding
Template(s).

Configuring Custom Attributes
The Custom Attributes tab in Onboarding Templates menu allows the Administrator to specify
human readable labels for Custom Field (1-6). You can set custom labels differently for Guest
User and Device in their respective tabs.

The Administrator configures custom labels, whereas the Provisioner and Self-Service guest
configures values for these custom labels.

For more information, see Configuring Guest User Custom Attributes and Configuring Device
Custom Attributes.

Configuring Guest User Custom Attributes
Use this procedure to configure Guest User Custom Attributes.

Procedure

1. In the navigation pane, click Onboarding Templates > Custom Attributes > Guest User tab. The Guest
User screen is displayed.

../../../../../Content/GIM Configuration/Topics/ConfiguringGuestUserCustomAttributes.html
../../../../../Content/GIM Configuration/Topics/ConfiguringDeviceCustomAttributes.html
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The languages displayed are based on the locales configured in Preferences tab. For more
information, see

the Setting the Locales section in Setting the Locales.

2. In the Custom Field, enter one or more labels as required in the (1-6) fields.

3. Click Save to save the configuration or click Clear to clear the configuration.

You cannot clear the default and other languages available in this screen.

Field Descriptions

Use the data in the following table to use Guest User tab.

Name Description

Custom Field Specifies the labels for the custom fields to be displayed during Guest User
Registration.

For example,

If Administrator specifies Country Code as the label for Custom Field 1
for the language English-US and the Provisioner or Self Service Guest
User selects English-Us as the language to be displayed. Then depending
on the Onboarding Template settings, the country code needs to be
specified during Guest User registration.

For more information, see Registering a New Guest User.

../../../../../Content/GIM Configuration/Topics/RegisteringNewGuestUser.html
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Configuring Device Custom Attributes
Use this procedure to configure Device Custom Attributes.

Procedure

1. In the navigation pane, click Onboarding Templates > Custom Attributes > Device tab. The Devices
screen is displayed.

The languages displayed are based on the locales configured in Preferences tab. For more
information, see the Setting the Locales section in Setting Preferences.

2. In the Custom Field field, enter one or more labels as required in the (1-6) fields.

3. Click Save to save the configuration or click Clear to clear the configuration.

Note:

You cannot clear the default and other languages available in this screen.

Field Descriptions

Use the data in the following table to use Device tab.

Name Description

../../../../../Content/GIM Configuration/Topics/SettingPreferences.html
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Custom
Field

Specifies the labels for the custom fields to be displayed during Guest User Registration.

For example,

If the Administrator specifies Location as the label for the Custom Field 1 for
the language English-US and the Provisioner or Self Service Guest User
selects English-Us as the language to be displayed. Then depending on the
Onboarding Template settings, the location needs to be specified during
Guest User registration.

For more information, see Registering a New Guest User.

Configuring Access Groups
The Access Groups tab in Onboarding Templates menu allows the Administrator to map the
Access Groups as Single and Multiple Memberships that are available to the Provisioner during
Guest User Registration as per the Onboarding Template settings.

There are two types of Access Groups. The Netsight Administrator needs to create “User
Groups - Single Membership” and “User Groups - Multiple Memberships” types of accounts in
the server prior Provisioner provides network access to the users at your facility. These groups
are customized for your site; the Administrator structure the fields that needs to be available
during Guest User creation.

l User Groups - Single Membership: Configures the specific network to which the Guest
User has access. The Provisioner may select only one Single Membership as the user must
be assigned to one segment of the network. For example, you can select south east
regional sales department VLAN as the Single Membership for the people belonging to
the sales department of the south east region.

l User Groups - Multiple Memberships: Configures wired, wireless or secured wireless and
typically the location of a switch or access point.

You can set Access Groups differently for Guest User and Device in their respective tabs. The
User Groups configured in ExtremeCloud IQ - Site Engine are available to the Guest and IoT
Manager Administrator to map as Single and Multiple Memberships. For more information on
configuring User Groups, see User Groups in ExtremeCloud IQ - Site Engine.

The End System Groups configured on ExtremeCloud IQ - Site Engine are available to Guest and
IoT Manager Administrator to map as Single and Multiple Memberships. For more information
on configuring End System Groups, see End-System Groups in ExtremeCloud IQ - Site Engine.

Note:

The Access Groups settings are optional. If you do not map the Access Groups as Single
and Multiple Memberships, then a link to the Access Groups tab is displayed while creating
an Onboarding Template.

../../../../../Content/GIM Configuration/Topics/RegisteringNewGuestUser.html
https://emc.extremenetworks.com/content/oneview/docs/control/access_control/docs/c_ov_ia_rule_at_add_user_group.html
https://emc.extremenetworks.com/content/oneview/docs/control/access_control/docs/l_ov_ia_at_add_es_group.html
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Configuring Guest User Access Groups
Use this procedure to configure Guest User access groups.

Procedure

1. In the navigation pane, Click Onboarding Templates > Access Groups > Guest Users tab. The Guest
Users screen is displayed.

2. In the Available User Groups section, drag and drop the required User Groups to Single and Multiple
Group Memberships. This can be used for customizing the Onboarding Templates.

You can also perform the same action in reverse order.

3. Click Save to save the configuration.

Field Descriptions

Use the data in the following table to use Guest Users tab.

Name Description

Available User
Groups

Specifies the list of User Groups available for mapping with Single or
Multiple Memberships.
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User Groups -
Single
Membership

Specifies the list of User Groups that provide specific network access to the
Guest User.

User Groups -
Multiple
Memberships

Specifies the User Groups that provide general network access to the
Guest User.

Configuring Device Access Groups
Use this procedure to configure Device access groups.

Procedure

1. In the navigation pane, Click Onboarding Templates > Access Groups > Device tab. The Devices screen
is displayed.

2. In the Available End-System Groups section, drag and drop the required End-System Groups to End-
System Groups - Single Memberships or End-System Groups - Multiple Memberships.

3. Click Save to save the configuration.

Field Descriptions

Use the data in the following table to use Device tab.

Name Description

Available End-
System Access
Groups

Specifies the list of End-System Groups available for mapping as Single and Multiple
Groups.
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End-System
Groups - Single
Memberships

Specifies the list of End-System Groups that provide specific network access to the
Guest User.

End-System
Groups - Multiple
Memberships

Specifies the End-System Access Groups that provide general network access to
the Guest User.



Prerequisite for Provisioner Function

161 of 253

Configuring Provisioners
This module is intended for Guest and IoT Manager Administrator to perform operations on
Provisioner accounts that are stored in the Access Control Engine local password repository. A
Provisioner is a member of the organization whose account is stored either in the Access
Control Engine or in LDAP. These internally stored Provisioners are referred as Internal
Provisioners.

If the Administrator desires to create Guest User accounts to test policies, it is essential to have
a Provisioner account. Administrator can only set up rules to place the Guest Users in the
appropriate Onboarding Template and not modify the Guest Users. For more information, see
Configuring Advanced Details.

Prerequisite for Provisioner Function
The Administrator must ensure that the following criterion is met before the Provisioners start
functioning.

l Provisioner Accounts: Each provisioner must have a Provisioner Account stored in Access
Control Engine or mapped via Access Control Engine to your LDAP store.

l Access to the Provisioner Application: Each provisioner must be able to connect to the
Provisioner Application via the web browser.

l Connection to an Access Control Engine: The Guest and IoT Manager Application must
have connectivity to the Access Control Engine in order to save and retrieve guest data.

l Configurations: The Access Control Engine must have the Single Membership Access
Group and Multiple Memberships Access Groups that form the set of assignable access
constraints for Guest Users.

l Notification Settings: The Guest and IoT Manager Application must have configuration to
send Email and SMS notifications to the Guest Users. For more information, see Enabling
E-mail Notification and Configuring SMS Gateway / Provider.

Note:

Ensure that you have created an Onboarding Template to which the new Internal
Provisioner belongs. For more information, see Creating an Onboarding Template.

It is necessary to train the Provisioners to use the Guest and IoT Manager Provisioner
Application. For more information, see the ExtremeControl Guest and IoT Manager
Configuration document.

../../../../../Content/GIM Configuration/Topics/ConfiguringAdvancedDetails.html
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Internal Provisioner Operations
The Internal Provisioners tab in Provisioners menu allows you to create and manage Internal
Provisioners. You can also view and reassign the Internal Provisioner to one or more Onboarding
Template(s). For more information, see Prerequisite for Provisioner Function.

Creating an Internal Provisioner
Use this procedure to create an Internal Provisioner account in the local password repository.

Procedure

1. In the navigation pane, click Provisioner > Internal Provisioners tab.

2. In the Internal Provisioners screen, click Add to add the internal provisioners. The Add Internal
Provisioner screen is displayed.

../../../../../Content/GIM Configuration/Topics/PrerequisiteForProvisionersFunction.html
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3. Configure the Provisioner login credentials details in the respective fields as required.

4. Select the Helpdesk Provisioner checkbox to provide the Provisioner user with the ability to view and
edit all the Guest user and Device records of the Onboarding Templates to which they are assigned.
Helpdesk Provisioners can add records of assigned Onboarding Templates; edit, delete and extend user
expiration; and perform resend password, resend details, renew password, and print operations on
accessible records.

5. In the Member of Onboarding Templates(s) section, select the Onboarding Templates that need to be
associated with the Provisioners.

6. Click Save to save the configuration or click Cancel to cancel the changes.

l The added Internal Provisioners details are displayed in Internal Provisioners screen along with all
the specified information.

l The URL to access the Provisioner application is https://<Guest Manager & IOT
Manager IP/Host Name>/GIM/provisioner/
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l Provisioner URL can be also access through IP address or host name. For example:
https://<Guest Manager & IOT Manager IP / Host Name>.

7. (Optional)Select the required Provisioner account and click Edit, to modify a provisioner account. For
more information, see Modifying Internal Provisioner Account.

8. (Optional) Click Show Filter to narrow the search parameters and quickly find all similar Provisioner
accounts. For more information, see Filtering Internal Provisioner Account.

9. (Optional) Select the required Internal Provisioner(s) and click Delete, to remove the created Internal
Provisioner(s).

Tip:

Use Ctrl / Shift to select multiple records to delete.

When you delete a Provisioner(s), the application retains all Guest Users and Device
Accounts that were provisoned by the deleted Provisioner.

Field Descriptions

Use data in the following table to use Add Provisioner screen.

Name Description

Username, First Name,
and Last Name

Configures the username, first name, and last name of the Provisioner account
details. The length of the name can be 30 characters or less.

Note:

These fields should only contain letters, number, hyphen, and
underscore.

Password and Confirm
Password

Configures the password of the Provisioner. Since Guest and IoT Manager
encrypts the password, ensure that you make a note of the password for
future reference.

Note:

These fields should only contain alphanumeric and special
characters. Only these special characters are allowed :

! @ # $ % ^ & * ( ) + - .

Email Configures the email address of the Provisioner.

Comments Configures the additional information.

Member of Onboarding
Template(s)

Configures the Onboarding Template that needs to be associated with the
Provisioner. Select the required Onboarding Template and ensure that
Provisioner must be part of atleast one Onboarding Template.

#GUID-58AAF259-5F68-4119-92BC-C1711F493AB9
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Modifying Internal Provisioner Account
Use this procedure to modify a Internal Provisioner account.

Procedure

1. In the navigation pane, click Provisioner > Internal Provisioner tab.

The Internal Provisioners screen is displayed with the list of provisioners currently
authorized to set up Guest access.

2. In the Internal Provisioners screen, select the Provisioner account that you wish to modify.

3. Click Edit, to view the Provisioner account details.

The Edit Internal Provisioner screen is displayed.

Note:
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You can also view by double-clicking the required Provisioner account from the list.
By default, the Username field is disabled.

4. In the Edit Internal Provisioner screen, modify the fields required.

5. (Optional) Select Change Password to modify the Internal Provisioner’s password. You must specify
New Password and Confirm New Password.

6. Click Save to save the configuration or click Cancel to cancel the changes.

The modified internal provisioners details are displayed in the Internal Provisioners screen.

Field Descriptions

Use data in the following table to use Edit Provisioner screen.

Name Description

First Nameand Last
Name

Modify the First Name, and Last Name of the Provisioner account details. The
length of the name can be 30 characters or less.

Note:

These fields should only contain letters, number, hyphen, and
underscore.

Change Password Select this to modify the current password details. If selected, you must also
specify New Password and Confirm New Password. Change Password is optional.

New Password and
Confirm New
Password

Configures a new password for the Provisioner account. Since Guest and IoT
Manager encrypts the password, ensure that you make a note of the password
for future reference.

Note:

These fields should only contain alphanumeric and special
characters. Only these special characters are allowed : ! @ # $ %
^ & * ( ) + - .

Email Modify the email address of the Provisioner, if required.

Comments Modify the additional information, if required.

Member of
Onboarding
Template(s)

Reassign the Internal Provisioner to one or more Onboarding Template, if
required.

Filtering Internal Provisioners
Use this procedure to filter Internal Provisioner account.
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Procedure

1. In the navigation pane, click Provisioner > Internal Provisioner tab.

The Internal Provisioners screen is displayed with the list of provisioners currently
authorized to set up Guest access.

2. In the Internal Provisioners screen, click Show Filter to narrow the search parameters and quickly
find all similar provisioners.

The Filter Internal Provisioner screen is displayed.

3. In the Filter Internal Provisioner screen, do the following:

1. Select All, and click Apply Filter to view all the Internal Provisioners.

2. Select Specify Filter to include the additional fields to narrow the quick search and click Apply
Filter.

3. Click Cancel to cancel the changes.

Use the paging control at the bottom of the list to move forward or backward by one
page, or to the first or last page of the list. You can control number of records to be
displayed per page and also click an individual page number to navigate to the specific
page. Click Refresh icon to refresh the view.

Field Descriptions

Use data in the following table to use Filter Internal Provisioner screen.

Name Description

All Displays the list of all the Internal Provisioner account data.



Internal ProvisionerOperations

168 of 253

Name Description

Specify Filter Simplifies the search parameters to quickly find the selected search
criterion that includes specified parameters.

Additionally you can also enter the operator conditions to match the
selected search criteria to obtain precise search results of each
Provisioner.

The search conditions are:

l Username

l First Name

l Last Name

l Email

The search conditions operators are:

l Starts with

l Ends with

l Contains

l Equals

l Not Equals
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Configuring Self-Services
This module is intended for Guest and IoT Manager Administrator to create Self-Service
Provisioner. A Self-Provisioned Guest User and Devices that appears as a Guest User account
and Devices is managed similar to other Guest User account and Devices. For more information,
see the ExtremeControl Guest and IoT Manager Configuration document.

Configuring Self-Service Provisioners
TheSelf-Service Provisioners tab in Self-Services menu allows you to select the Service Type
and Onboarding Template to create Self-Service URLs and also creates a dedicated Provisioner
account for each Self-Service. The dedicated Provisioner owns the Guest User and Devices
created through the Self-Service. You can direct arriving Guests to these Self-Service URLs to
use the self-registering feature.

Generally, an arriving Guest uses a kiosk computers / BYOD devices to fill out the Self-
Provisioning information. When their account is created, this service sends the login credentials
to the user through email, SMS message, or to a front desk personal who can print it as hard
copy.

Note:

Ensure that you have configured email and / or SMS gateway details to send account
access details. For more information, see Enabling E-mail NotificationandConfiguring SMS
Gateway / Provider.

Creating Self-Service Provisioners
Use this procedure to create a Self-Service Provisioners.

Procedure

1. In the navigation pane, click Self-Services>Self-Service Provisioners tab.

2. In theSelf-Service Provisionersscreen, clickAddto add a Self-Service Provisioner.

TheAdd Self-Service Provisioner screen is displayed.

../../../../../Content/GIM Configuration/Topics/EnablingEmailNotification.html
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3. In theSelf-Service Username field, enter the name of the Provisioner account.

4. In theService Type field, select the required service type from the drop-down list.

If you selectDeviceoption asService Type, the User account with provisioning rights must
be successfully authenticated to create a device account andConfirmation Template
fields are enabled.

l SelectUser account with provisioning rights must be successfully authenticated to
create a device account , to allow the successfully authenticated Provisioners to
create a Device account.

l Use theConfirmation Templatefield, to specify how the confirmation messages
needs to be displayed.

If you selectZero Touch Guest Accessoption asService Type, the QR Code Validity (in
mins)andRedirect to this URL post successful authentication on clicking login URLfields
are enabled.

l Use theQR Code Validity (in mins)field, to configure the validity of theQR code.

l Use theRedirect to this URL post successful authentication on clicking login
URLfields to specify the URL to which the Guest User must be redirected after a
successful authentication when the Guest User clicks the login URL.

5. In thePassword,Confirm Password and Service Email fields, configure the Provisioner login credentials.
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6. In theOnboarding Template field, select the required Onboarding Template from the drop-down list to
set the access restrictions.

7. In theTerms of use to be displayed on self-provisioning page field, enter the terms of use to be displayed
on the Self-Provisioning page.

8. ClickSaveto save the configuration or click Cancelto cancel the changes.

The created Self-Service Provisioner is displayed in theSelf-Service Provisioners screen
with all the added details.

9. (Optional) Select the required Self-Service Provisioner and click Editto modify a Self-Service
Provisioners. For more information, see Modifying Self-Service Provisioners.

10. (Optional) Select the required Self-Service Provisioner(s) and click Deleteto delete the Self-Service and
its Provisioner account. >

Tip:

UseCtrl / Shiftto select multiple records to delete.

When you delete a Self-Service Provisioner(s), the application retains all Guest Users
and Device Accounts that were provisoned by the deleted Self-Service Provisioner.

Field Descriptions

Use data in the following table to useAdd Self-Service Provisionerscreen.

Name Description

Self-Service Username Configures the name of the Provisioner account that manages the Self-
Service and also used in URL of the Self-Service. The length of the name
can be 30 characters or less.

Note:

These fields should only contain letters, number, hyphen,
and underscore.
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Name Description

Service Type Configures basic properties of Self-Provisoning Service. The Registration
Page does not exist until you specify the options. The options are:

l Guest User: If you select Guest User option as Service
Type and the Onboarding Template of the type as Guest
User, the users can create their account directly. If the
Onboarding Template is of type Sponsor, then Sponsor
Approval is required. For more information, see
Configuring Sponsor Approval.

l Devices: If you selectDeviceoption asService Type , then
you must selectOnboarding Template of the type
aDevicesonly.

l Zero Touch Guest Access: If you select Zero Touch Guest Access
option asService Type , then you must selectOnboarding
Template of the type aZero Touch Guest Accessonly.

Password and Confirm
Password

Configures the password of the Provisioner. Since Guest and
IoT Manager encrypts the password, ensure that you make a
note of the password for future reference.

Note:

These fields should only contain alphanumeric and special
characters. Only these special characters are allowed: ! @ # $ %

^ & * ( ) + -.

Service Email Configures the email address of the Provisioner.

Onboarding Template Associates this Onboarding Template to the Self-Service Provisioner.

User account with
provisioning rights must be
successfully authenticated
to create a device account

Select to provision a Device only after successful authentication of the
Provisioner.

This field is enabled, if the selected Service Type is Device only.

../../../../../Content/GIM Configuration/Topics/ConfiguringSponsorApproval.html
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Name Description

Confirmation Template Specifies the confirmation message format and also contains the
variables to display the Username and MAC address as part of the
confirmation message. You can also specify variables to display the start
time and end time of the Device account in the confirmation message.

This field is enabled, if the selected Service Type is Device only.

Note:

If you have not provided any information in this field, then
the default template will be used.

Terms of use to be displayed
on self-provisioning page

Displays terms and condition information in the Self-Service Provisioning
page.

Auto-refresh interval for
self-registration page (sec)

Configures the time value for the refresh interval of the Self-Service
Provisioning page. Default value is 10 seconds.

After a self-provisioned
guest account is created,
perform the following action
when auto-refresh interval
expired

Specifies the actions that needs to be performed after the Guest account
creation. The options are:

l Redirect to the self-service registration page

l Redirect to the specified URL

l Don’t do anything

QR Code Validity (in mins) Enter the time value in minutes to ensure the QR code is valid
for that period.

The maximum time limit that a valid QR code can be set is 1440
minutes.

This field is applicable only for Zero Touch Guest Access.

Redirect to this URL post
successful authentication on
clicking login URL.

Enter the URL to which the Guest User must be redirected after a
successful authentication when the Guest User clicks the login URL.This
field is applicable only for Zero Touch Guest Access.

Modifying Self-Service Provisioners
Use this procedure to modify a Self-Service Provisioners.
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Procedure

1. In the navigation pane, click Self-Services>Self-Service Provisioners tab.

TheSelf-Service Provisionersscreen is displayed with list of Self-Service Provisioners and
their accounts.

2. In theSelf-Service Provisioners screen, select the Self-Service Provisioners account that you wish to
modify.

3. ClickEdit, to view the Provisioner account details. The Edit Self-Service Provisionerscreen is displayed.

Note:

You can also edit by double-clicking the required Self-Service Provisioner account from the list. By
default, the Self-Service User name field is disabled.

4. In theEdit Self-Service Provisioner screen, modify the fields required.
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5. (Optional) Select Change Passwordto modify the Self-Service Provisioner’s password. You must specify
New Password and Confirm New Password.

6. ClickSaveto save the configuration or click Cancelto cancel the changes.

The modified Provisioners details are displayed in theSelf-Service Provisionersscreen.

Field Descriptions

Use data in the following table to useEdit Self-Service Provisionerscreen.

Name Description

Service Type Modify the Service Type.

The Options are:

l Guest User

l Device

l Zero Touch Guest Access

Device option enablesUser account with provisioning
rights must be successfully authenticated to create a
device account andConfirmation Template field.

Zero Touch Guest Accessoption enables the QR Code
Validity (in mins)andRedirect to this URL post successful
authentication on clicking login URL.fields.

Change Password Select this to modify the current password details. If selected, you
must also specify New Password and Confirm New Password.
Change Password is optional.

New PasswordandConfirm New
Password

Modify the password and reconfirm. Since Guest and IoT
Managerencrypts the password, ensure that you make a note of the
password for future reference.

Note:

These fields should only contain alphanumeric and
special characters. Only these special characters are
allowed : ! @ # $ % ^ & * ( ) + - .

Service Email Modify the email address of the Provisioner, if required.

Onboarding Template Select the different Onboarding Template from the drop-down list
to associate, if required.
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Name Description

User account with provisioning
rights must be successfully
authenticated to create a device
account

Select to provision a Device only after successful authentication of
the Provisioner.

This field is enabled, if the selected Service Type is Device
only.

Confirmation Template Modify the confirmation message, if required

This field is enabled, if the selected Service Type is Device
only.

Note:

If you have not provided any information in this field,
then the default template will be used.

Terms of use to be displayed on
self-provisioning page

Modify the terms of use message, if required.

Auto-refresh interval for self
registration page (sec)

Modify the auto refresh value, if required.

After a self-provisioned guest
account is created, perform the
following action when auto-
refresh interval expired

Specifies the options that needs to be performed once the Self-
Provisioners Guest account is created. The options are:

l Redirect to the self-service registration page

l Redirect to the specified URL

l Don't do anything

QR Code Validity (in mins) Enter the time value in minutes to ensure the QR code is
valid for that period.

The maximum time limit that a valid QR code can be set is
1440 minutes.

The Guest User is redirected to this URL post successful
authentication on clicking login URL.

This field is applicable only for Zero Touch Guest Access.

Redirect to this URL post
successful authentication on
clicking login URL.

Enter the URL to which the Guest User must be redirected after a
successful authentication when the Guest User clicks the login URL.

This field is applicable only for Zero Touch Guest Access.
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Viewing Self-Provisioning Services
The Self-Provisioning Services tab in Self-Services menu allows you to view and identify Self-
Provisioning Services that you have created. The created Self-Provisioning Services are
displayed along with Self-Service Name, Service Type, Status, and the URL. The different URL
represents the particular service type pages that has been generated for registering the Guest
Users and Devices.

You can also copy these URLs to access the Self Service page. For more information on using
Self-Provisioning page, see Using Self-Provisioning Services.

Self Provisioning Services

../../../../../Content/GIM Configuration/Topics/UsingSelfProvisioningServicesPortal.html


Accessing GuestUsers

178 of 253

Managing GuestUsers
This module is intended for Guest and IoT Manager Administrator to manage and carry out bulk
Guest User operations. A Guest User account can be permanent, temporary, automatically
expiring account with specific limited rights to use the network based on the associated
Onboarding Template.

Accessing Guest Users
The Guest Users tab in the Guest Users menu allows you to view and manage all the users
created by the Provisioner(s).

Using Guest User Features
Use this procedure to manage the Guest User Administrator features.

Procedure

1. In the navigation pane, click Guest Users > Guest Users tab.

The Guest Users screen is displayed along with the user details created by the Provisioner
(s). By default, 25 users are displayed and you can extend up to 75 users.

You can also click the column headers to sort the list view by that column. Click the
column header a second time to reverse the direction of the sort.

2. Select the required user and click View to view the selected user information.

3. (Optional) Select the required Guest User(s) and click Extend Expiration to extend the validity of Guest
User(s) account. The validity is extended based on the duration specified during the creation.

The duration of each selected Guest User is calculated as:

DURATION = END_TIME – START_TIME

Then the account is modified to:

START_TIME = CURRENT_TIME

END_TIME = START_TIME + DURATION

Extend Expiration Example:

Consider two Guest Users, User 1 valid for a duration of one month and User 2 is valid for a
duration of two months, both are expiring tomorrow and the current time is 02:00 P.M.
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When you select these two accounts and click Extend Expiration option, their expiry is
extended as follows:

1. User 1 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 1 month.

2. User 2 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 2 months.

Note:

The Provisioners can use Extend Expiration option to extend the duration of expiry
for expired Guest User account(s) also.

Expiry of First Login Pending and Permanent Guest User accounts cannot be
extended.

4. (Optional) Select the required Guest User Accounts(s) and click Resend Password to resend the
password to Guest Users.

5. (Optional) To resend Details to Guest User(s), select the required Guest User Accounts(s) and click
Resend Details.

When Guest User(s) are selected to resend the password, resend details, or both the
application validates the following prior sending the password:

l Notification options has either SMS / Email or both enabled.

l Account is not locked / expired.

6. (Optional) To renew password to Guest Users(s), select required Guest User Accounts(s) and click
Renew Password to generate new password and send the credentials to the Guest User(s)

When Guest User are selected to renew password, the application validates the following
prior sending the renewed password:

l Notification options has either SMS / Email or both enabled.

l Account is not locked / expired.

l Account cannot be of CSV or Voucher Type.

l Account must belong to an Onboarding Template with Randomly generated Password for Guest
Accounts.

l Guest User account must not be in First login pending state.

7. (Optional) To remove Guest User account(s), select the required user account(s) and select Delete >
Delete Selected to remove only the Guest User accounts you selected, or Delete > Delete All to remove
all Guest User accounts.

Tip:

Use Ctrl / Shift to select multiple records to delete.
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8. (Optional) In the Guest Users screen, click Show Filter to specify the search parameters and quickly
find all similar records. The filter is applied to all columns displayed in the list view. For more information,
see Searching Specific Guest Users.

9. (Optional) Select the Guest User and click Print, to print the account summary.

Note:

Use the paging control at the bottom of the list to move forward or backward by one
page, or to the first or last page of the list. You can control number of records to be
displayed per page and also click an individual page number to navigate to the
specific page. Click Refresh icon to refresh the view.

Searching Specific Guest Users
Use this procedure to retrieve specific Guest Users based on the search parameters.

Procedure

1. In the navigation pane, click Guest Users > Guest Users tab.

The Guest Users screen is displayed along with the user details created by the Provisioner.
By default, 25 users are displayed and you can extend up to 75 users.

2. In the Guest User screen, click Show Filter to specify the search parameters and quickly find all
similar records.

The Filter Guest Users screen is displayed.

3. To retrieve specific Guest Users, do the following:

1. For Guest Users added by the Provisioner:

1. In the Specify Filter section, select Provisioner from the drop-down list.

2. Enter the operation (Starts with, Equals, Not Equals, Contains, Ends
With) and the name of the Provisioner.

3. Click Apply Filter. A list of Guest Users provisioned by the selected
Provisioner are displayed.

2. For Guest Users that belong to an Onboarding Template:

1. In the Specify Filter section, select Onboarding Template and required
template of the selected Onboarding Template from the drop-down
list.

2. Click Apply Filter. A list of guest users that belong to the selected
Onboarding Templates are displayed.
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3. For Guest Users First Login Pending Accounts:

1. In the Specify Filter section, select First Login Pending and Created
Before and the required search conditions operator from the drop-
down list.

2. Enter the date in YYYY/MM/DD format or click the calendar icon to select
a date

3. Enter the Time and select AM or PM from the drop-down list.

4. Select the Time Zone from the drop-down list.

5. Click Apply Filter. The list of all the first login pending accounts created
before the specified date as entered are displayed.

4. For Guest Users based on Sponsor Response

1. In the Specify Filter section, select Sponsor Response and the required
search values from the drop-down list.

l Approved

l Denied

l Pending

l Auto-Approved

l Auto-Denied

l Not Applicable

2. Click Apply Filter. The list of all the Guest Users that have the selected
Sponsor Response are displayed.

5. For Guest Users activated in last X number hours:

1. In the Specify Filter section, select Guest Users Activated in the Last
from the drop-down list and enter number of hours in the Hours field.
You can search up to a maximum of two years from the current time.

2. Click Apply Filter. The list of all the Guest Users activated in last X
number hours are displayed.

6. For expired Guest User account details:

1. In the Specify Filter section, select Expired Guest Users from the drop-
down list.

2. Click Apply Filter. A list of guest users that belong to the selected
Onboarding Templates are displayed.

Tip:
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When Guest User accounts are expired, the affected accounts
cannot access the network. You can also use this procedure to
delete all the expired Guest User accounts.

3. (Optional) Select the required expired Guest User(s) and click Delete to
remove the guest account.

Note:

Use Ctrl / Shift to select multiple records to delete.

7. Click Show Filter to specify the search parameters and quickly find all similar records.
The filter is applied to all columns displayed in the list view. For more information, see
Searching Specific Guest Users

8. (Optional) Select the Guest User and click Print, to print the account summary.

Note:

Use the paging control at the bottom of the list to move forward or
backward by one page, or to the first or last page of the list. You can
control number of records to be displayed per page and also click an
individual page number to navigate to the specific page. Click Refresh
icon to refresh the view.
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Managing Devices
This module is intended for Guest and IoT Manager Administrator to carry out bulk operations
on the Device records. A Device record can be permanent, temporary, automatically expiring
record with specific limited rights to use the network based on the associated Onboarding
Template.

Accessing Devices
The Devices tab in the Devices menu allows you to view and manage all the Device actions
created by the Provisioner(s).

Using Devices Features
Use this procedure to manage the Device Administrator features. The Administrator can also
perform bulk operations of Devices.

Procedure

1. In the navigation pane, click Devices > Devices tab.

The Devices screen is displayed along with the Device details created by the Provisioner
(s). By default, 25 Devices are displayed and you can extend up to 75 Devices.

You can also click the column headers to sort the list view by that column. Click the
column header a second time to reverse the direction of the sort.

2. Select the required Device record and click View to view the Device record summary.

3. (Optional) Select the required Device record(s) and click Extend Expiration to extend the validity
duration of the Device record(s). The validity is extended based on the duration specified during the
creation.

The duration of expiry of each selected Devices is calculated as:

DURATION = END_TIME – START_TIME

Then the account is modified to:

START_TIME = CURRENT_TIME

END_TIME = START_TIME + DURATION

Extend Expiration Example:
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Consider two Devices, Device 1 valid for a duration of one month and Device 2 is valid for a
duration of two months, both are expiring tomorrow and the current time is 02:00 P.M.
When you select these two Devices and click Extend Expiration option, their expiry is
extended as follows:

1. Device 1 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 1 month.

2. Device 2 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 2 months.

Note:

The Provisioners can use Extend Expiration option to extend the duration of expiry
for expired Device record(s) also.

Expiry of First Login Pending and Permanent Device record(s) cannot be extended.

4. (Optional) Select the required Device record(s) and select Delete > Delete Selected to remove Device
records you selected or Delete > Delete All to remove all Device records.

Tip:

Use Ctrl / Shift to select multiple records to delete.

5. (Optional) In the Devices screen, click Show Filter to specify the search parameters and quickly find
all similar records. The filter is applied to all columns displayed in the list view. For more information, see
Searching_Specific_Devices.

Note:

Use the paging control at the bottom of the list to move forward or backward by one
page, or to the first or last page of the list. You can control number of records to be
displayed per page and also click an individual page number to navigate to the
specific page. Click Refresh icon to refresh the view.

Searching Specific Devices
Use this procedure to retrieve specific Device record summary based on the search parameters

Procedure

1. In the navigation pane, click Devices > Devices tab.

The Devices screen is displayed along with the Device details created by the Provisioner.
By default, 25 Devices are displayed and you can extend up to 75 Devices.

2. In the Devices screen, click Show Filter to specify the search parameters and quickly find all similar
records.

The Filter Devices screen is displayed:
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3. To retrieve the specific Devices, do the following:

1. For Devices added by the Provisioner:

1. In the Specify Filter section, select Provisioner from the drop-down list.

2. Enter the operation (Starts with, Equals, Not Equals, Contains, Ends
With) and the name of the Provisioner.

3. Click Apply Filter. A list of Devices provisioned by the selected
Provisioner are displayed.

2. For Devices that belong to an Onboarding Template:

1. In the Specify Filter section, select Onboarding Template and required
template of the selected Onboarding Template from the drop-down
list.

2. Click Apply Filter. A list of Devices that belong to the selected
Onboarding Templates are displayed.

3. Devices activated in last X number of hours:

1. In the Specify Filter section, select Devices Activated in the Last and
enter the number of hours in the Hours field. You can search up to a
maximum of two years from the current time.

2. Click Apply Filter. The list all the selected Devices activated in last X
number hours are displayed. Here, X represents the number of hours as
entered in Hours field are displayed.

4. For pending Devices list:

1. In the Specify Filter section, select First Login Pending and Created
Before and the required search conditions operator from the drop-
down list.

2. Enter the date in YYYY/MM/DD format or click the calendar icon to select
a date.

3. Enter the Time and select AM or PM from the drop-down list.

4. Select the Time Zone from the drop-down list.

5. Click Apply Filter. The list of all the first login pending Device records
created before the specific date as entered are displayed.

5. For Device record expiring in limited hours:

1. In the Specify Filter section, select Devices Expiring in the Next and
enter the number of day in the Days field. You can search up to a
maximum of two years from the current time.

2. Click Apply Filter. The list of all the Device records expiring in next few
days are displayed.
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6. To retrieve the specific Devices, do the following:

1. In the Specify Filter section, select Expired Devices from the drop-
down list.

2. Click Apply Filter. The list of all the expired Device records are
displayed.

3. (Optional) Select the required expired Device and click Delete to
remove the Device record(s).

Note:

You can also use this procedure to delete all the expired Device
records.
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Configuring Guest and Devices
This module is intended for Guest and IoT Manager Provisioner to create and manage Guest
User and Device account(s). Your Provisioner account is part of one or more Onboarding
Templates that establish rights, such as the maximum lifetime of accounts you create, and which
“Single Membership” and “Multiple Memberships” Access groups you can provide to those
accounts.

A Guest User is a visitor, or other temporary user, to whom you grant specific, limited rights to
use your network. As a Provisioner you can set the duration of access for the Guest User. The
account can be valid for only a few minutes, hours, for a number of weeks, or permanent. The
account expires automatically after a specified period of time. However, if the account expires,
you can renew it, if needed.

When a Guest User is created, you can determine how and when the user can use your network.
These are the groups that can be configured in Access Control Engine. You can do the
following:

l Establish the set of allowed connection mechanisms a guest can use: 802.1X-secured
wired connection, 802.1X-secured wireless connection, web-authenticated wireless
connection, and so on.

l Determine the network ports or access points the user can connect. That is, you can
specify the access points or conference room network jacks that allows the user to
connect.

l Specify the segments of your network the user can reach once connected. For example,
you can give a user only Internet access or you can give access to the corporate Intranet.

Configuring Guests
The Guest Users tab in Guest Users menu provides complete control over the user account
creation process. Guest User features for managing guest accounts allows you:

l Create guest accounts

l View and manage guest accounts

l Handle the account activation time for network access usage and the duration.

l Remove the guest accounts automatically after expiration.

Note:

The assigned Onboarding Template needs to permit the Guest User management operations to the
Provisioner.
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Guest User Connections

When guests have their temporary Username and Password, they can connect in one of two
ways:

l Standard Login: In most networks, the Guest User plugs in their Device into the wired
network or connects to an open wireless access point. The networking client (known as
the “supplicant”) on the user’s Device brings up a login dialog. The user can provide the
login credentials for the configuration.

l Captive Portal: If the captive portal tool is used, the user plugs in their Device into the
wired network or connects to an open wireless access point and launch web browser. The
captive portal intercepts the user’s web traffic and displays a login page in the browser.
The user can provide the login credentials.

Creating Guest User Account
Use this procedure to create a Guest User account.

Procedure

1. In the navigation pane, click Guest Users > Guest Users tab.

2. In the Guest User screen, click Add to create a new Guest User.

3. In the Onboarding Template field, select the required Onboarding Template the Guest User is to be
associated with from the drop-down list..

The Guest User screen is displayed for Guest and Device type Onboarding Template.
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The Guest User screen is displayed for Voucher Type Onboarding Template.

The Guest User screen is displayed for CSV Type Onboarding Template.
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4. In the Guest User Info section, configure the account details as required.

5. In the Send Notification section, configure the notification conditions as required.

6. Click Save to save the configuration or click Cancel to cancel the changes.

The Successful Guest Creation message is displayed along with Username and Password
details if specified in the Onboarding Template.

Note:

For Voucher Type Onboarding Template, the Successful Guest Creation message is
displayed along with Usernames and Passwords. The Provisioner can copy these details
to the clipboard in the supported browsers or print them.
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Note:

For CSV Type Onboarding Template, the Successful Guest Creation message is displayed
along with Username and Password details. The Provisioner can copy these details to the
clipboard in the supported browsers or print them.
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The added new user is displayed in the Guest User screen along with all the specified
information and also sends Email / SMS notifications to the user.

7. (Optional) Click Print to print the result of the operation. This is applicable only to
Voucher and CSV type Onboarding Template. For Voucher, the options are as follows:

l Select Default to print in the default grid view.

l Select the Avery 5371 Business card Template to print in Avery business card template view.

Note: The new window to Select Voucher Print Template appears only when both
Default and Avery 5371 Business card Template options are selected in the Onboarding
Template.

8. (Optional) Select the required Guest User(s) and click Extend Expiration to extend the validity of Guest
User(s) account. The validity is extended based on the duration specified during the creation. For more
information, see Extending Expiry of Guest User Account.

9. (Optional) To send the password to Guest Users, select the required user and click Resend Password.

The password is shared via email / SMS or both depending on the notification options of
the Onboarding Template to which the user is associated with.

The following checks are performed prior the password is shared when one or more users
are selected:

l Notification options has either SMS / Email or both enabled

l Account is not locked / expired

10. (Optional) To send the password and details to Guest Users, select the required user and click Resend
Details to send the password and details to Guest Users.

../../../../../Content/GIM Configuration/Topics/ExtendingExpiryOfGuestUserAccount.html
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The password is shared via email / SMS or both depending on the notification options of
the Onboarding Template to which the user is associated with.

The following checks are performed prior the password is shared when one or more users
are selected:

l Notification options has either SMS / Email or both enabled

l Account is not locked / expired

11. (Optional) Select the required Guest User and click Edit to modify Guest User accounts. For more
information, see Modifying Guest User Account.

12. (Optional) Select the required Guest User(s) and click Delete, to remove accounts.

Tip:

Use Ctrl / Shift to select multiple records to delete.

13. Click Show Filter to specify the search parameters and quickly find all similar records. The filter is
applied to all columns displayed in the list view. For more information, see Finding Guest User Account.
(Optional)

14. (Optional) (Optional) Select the Guest User and click Print, to print the account summary.

Note:

Use the paging control at the bottom of the list to move forward or backward by one
page, or to the first or last page of the list. You can control number of records to be
displayed per page and also click an individual page number to navigate to the
specific page. Click Refresh icon to refresh the view.

Field Descriptions

Use data in the following table to use New Guest User screen. The fields are enabled based on
the associated Onboarding Template settings.

../../../../../Content/GIM Configuration/Topics/ModifyingGuestUserAccount.html
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Name Description

Onboarding
Template

Specifies the list of Onboarding Templates that the Provisioner is a member of.
The provisioner can add the Guest User to any one of the available Onboarding
Templates.

The Onboarding Templates imposes certain account guidelines (for
example, prompt the Username, auto-generation of the password,
maximum validity period, allowable access groups, and so on),
depending on how the Administrator has configured the Guest User
account details for the particular selected Onboarding Template. As a
result, the fields and defaults of the screen changes when you select a
Onboarding Template.

Note:

Onboarding Template limits the rights that can be granted to the
user.

First Name and Last
Name

Configures the first and last name of the Guest User. The length of the name can
be 30 characters or less.

Note:

These fields should only contain letters, number, hyphen, and
underscore.

Username Generates Username for the created users first name. Ensure that the first name
entered does not have any spaces. The length of the name can be 30 characters
or less.

Note:

You can edit the Username and provide a unique name, if the
Administrator has selected Generate Username with option
while creating an Onboarding Template.

User Name is auto-generated, if the Administrator has selected
Random Generated Password option while creating an
Onbarding Template.

This field should only contain alphanumeric and special
characters. Only these special characters are allowed : ! @ # $ 
% ^ & * ( ) + - .

For more informaiton about configuring the guest user account
details, see the ExtremeControl Guest and IoT Manager Configuration
document.
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Name Description

Password Specifies the password for the Guest User login. The password must meet the
specified complexity checks.

If the Onboarding Template is configured to auto-generate
password, this field does not appear while creating a new Guest User.

Confirm Password Confirm the password by typing again. This field appears based on Onboarding
Template setting.

Number of Vouchers Enter the number of vouchers as required. The maximum number of
vouchers is 1000. Only applicable to Voucher Type Onboarding
Template.

WifiSSID The Wifi SSID to join the device to the network. Only applicable to Voucher Type
Onboarding Template.

Guest User Details
File

Select Browse.. to select the *.csv file. The expected CSV file format
must have at least one field entry. This is only applicable to CSV Type
Onboarding Template.

The default carrier Gateway/Provider is used for Mobile

For Example: First Name, Last Name, Email, Mobile.

Note: Any row in the CSV file that begins with character "#" will be
ignored for processing.

The maximum number of records that will be processed from the
*.csv file is 5000. Records exceeding will be ignored

Delete on Expire Deletes the Guest User from the Access Control Engine. Select this option to
automatically remove expired guest account.

If you do not select this option, you need to manually remove the
guest account after it expires. The expired user accounts remains in
the Access Control Engine.

As a Provisioner you can renew or remove the expired accounts at
any point of time. The account validity is indicated in RED color in the
End Time column of Guest User screen attributes.

Email Configures the email address of the Guest User.

When this account is created, you can instruct Guest and IoT
Manager Application to send a notification to specified or another
address. For more information, see Send Notification row beneath.

Mobile Configures the contact number of the Guest User. Guest and IoT Manager
Application uses this number is to send account notification via SMS messaging.

Carrier / Provider Specifies the list of phone carrier and provider service details.
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Name Description

Activate Account On Configures the date and time at which the Guest User account is activated. The
value in these fields defaults to the current date and time on the Guest and IoT
Manager. You can also view the time zone that has been set to the current
Onboarding Template.

l Date: Enter the start date for activating Guest User account.
The date should be in YYYY/MM/DD format.

l Time: Enter the time in hours and minutes based on a 12-hour
setting. The time should be in hh:mm:ss format.

l AM / PM: Select the time of the day.

Activate On First
Login

Specifies that guest account will be valid only after the first login.

Note:

This field is available only if the Administrator has selected First
Login option while creating an Onboarding Template and the
Provisioner selects the same Onboarding Template during Guest
User account creation from the Onboarding Template drop-
down list.

The Activate Account On option is replaced by Activate on First
Login: Yes option.

Duration Configures the duration validity of the guest account. The account validity
period starts from the activation time and lasts for the specified duration.

By default, the application sets the durations to the maximum time
period specified in the Temporary Account Validity field during
creation of Onboarding Template. Specify the period as an integer
and set the units by selecting minutes, hours, and days.

Single Membership
Access Group

Specifies one of the access group that has been configured in the Onboarding
Template.

Multiple
Memberships Access
Group

Configures the access to the Guest User. You can select multiple options.

For example, if the access has to be provided for a specific
department, the Administrator defines which access group are
available for you.

Custom Fields: 1 to 6 Specifies the label values configured for Guest Users.
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Name Description

Send Notification Specifies the address / number that is required to share the account notification
details. The application automatically sends the notification via Email or SMS to
the Guest and / or others to provide the new guest account details.

A notification message has the format of Email / SMS template
configured in the Onboarding Template of which the Guest User is a
member.

For more information about configuring account notification
templates, see the ExtremeControl Guest and IoT Manager
Configuration document.

The options available are:

l Guest User Email: Sends an email to guest with account details.
The variables specified in the guest's Onboarding Template >
Email Template field are sent.

l Other Email: Sends the guest’s account details to the address
specified. The variables specified in the guest’s Onboarding
Template > Email Template field are sent.

l Password to Guest User Mobile Phone: Sends an SMS message
to guest with account details. The variables specified in the
guest’s Onboarding Template > SMS Template fields are sent.

The options are available only if the Guest and IoT Manager
Administrator has configured the Application to send messages.

For more information about enabling e-mail notifications and
configuring the SMS gateway or provider, see the ExtremeControl
Guest and IoT Manager Configuration document.

Note:

Different types of Guest User accounts created based on the validity are:

l Permanent

l Temporary - Time Based

l Temporary - First Login

Modifying Guest User Account
Use this procedure to modify Guest User accounts.

Procedure
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1. In the navigation pane, click Guest Users > Guest Users tab.

The Guest User screen is displayed with list of Guest User accounts created by the
Provisioner.

2. Select the required user account to be modified and click Edit.

You can also edit by double-clicking the required user account from the list.

The Onboarding Template field is editable only during creating an Guest User.

3. In the Guest User Info section, modify the fields required.

4. In the Send Notification section, select the required fields.

Note:

Guest User account(s) that was created using Voucher type Onboarding Template
will not have this option.

5. Click Save to save the configuration or click Cancel to cancel the changes.

The modified Guest User details are displayed in the Guest User screen.

6. (Optional) To modify the validity of a Guest User account, do the following:

1. Select the required user account and scroll left to view the Start Time and End Time Guest User
attributes column. The RED text indicates an expired account.

2. Double-click the user account to view the Edit Guest User screen.

3. Modify the duration period in Duration field or modify the Activate Account On field to change
the validity period to desired time frame.

7. (Optional) To remove Guest User account(s), select the required user account(s) and select Delete >
Delete Selected to remove only the Guest User accounts you selected, or Delete > Delete All to remove
all Guest User accounts.

Tip:

Use Ctrl / Shift to select multiple records to delete.

For more information, see Creating Guest User Account Field Descriptions.

Finding Guest User Account
Use this procedure to find a Guest User account.

Note:

Use the paging control at the bottom of the list to move forward or backward by one page,
or to the first or last page of the list. You can control number of records to be displayed per
page and also click an individual page number to navigate to the specific page. Click
Refresh icon to refresh the view.

Procedure
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1. In the navigation pane, click Guest Users > Guest Users tab.

The Guest User screen is displayed with the list of Guest Users created by the Provisioner.

2. Select the Show drop-down list to filter the users in the table to display only those users added by a
specific Provisioner or the Onboarding Template drop-down list to filter the users in the table to display
only those users added through a specific Onboarding Template.

3. In the Guest User screen, click Show Filter to specify the search parameters and quickly find all
similar user records. . The Guest User Search Filters screen is displayed.

4. To search the Guest Users:

l Select All Guest Users to view all the Guest Users.

l Select Specify Filter to define additional fields by which you can filter the list of
Guest Users.

5. Click Apply Filter.

The corresponding records are displayed in the Guest User screen table.

In the Guest User screen, select the required Guest User and scroll towards left to view the
permanent access user accounts. The End Time Guest User attributes column status is
displayed as blank (–).

Extending Expiry of Guest User Account
Use this procedure to extend the duration of expiry of a Guest User account(s) at one go.

Procedure

1. In the navigation pane, click Guest Users > Guest Users tab.

The Guest User screen is displayed with the list of users provisioned.

2. Select the required Guest User(s) and click Extend Expiration to extend the validity of Guest User(s)
account. The validity is extended based on the duration specified during the creation.

The duration each selected Guest User is calculated as:

DURATION = END_TIME – START_TIME

Then the account is modified to:
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START_TIME = CURRENT_TIME

END_TIME = START_TIME + DURATION

Extend Expiration Example:

Consider two Guest Users, User 1 valid for a duration of one month and User 2 is valid for a
duration of two months, both are expiring tomorrow and the current time is 02:00 P.M.
When you select these two accounts and click Extend Expiration option, their expiry is
extended as follows:

1. User 1 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 1 month.

2. User 2 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 2 months.

Note:

The Provisioners can use Extend Expiration option to extend the duration of expiry
for expired Guest User account(s) also.

Expiry of First Login Pending and Permanent Guest User accounts cannot be
extended.

3. Click Save to save the configuration or click Cancel to cancel the changes.

Configuring Devices
The Devices tab in Devices menu provides complete control over the Device records creation
process. Device features allows you:

Devices feature allows you:

l Adding device records

l View and manage devices

Note:

The assigned Onboarding Template need to permit the Device management operations to
the Provisioner.

Adding a Device Record
Use this procedure to add a Device record.
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Procedure

1. In the navigation pane, click Devices > Devices tab.

The Devices screen is displayed.

2. In the Devices screen, click Add to create a new Device record. The New Device screen is displayed.

3. In the Onboarding Template field, select the required Onboarding Template the Guest User is to be
associated with from the drop-down list..

The Guest User screen is displayed for Guest and Device type Onboarding Template.

The Guest User screen is displayed for CSV Type Onboarding Template.
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4. In the Onboarding Template field, select the required Onboarding Template the Device is to be
associated with from the drop-down list.

5. In the Device Info section, configure the Device details as required.

6. Click Save to save the configuration or click Cancel to cancel the changes.

The added new Device record is displayed in the Devices screen along with all the
specified information. For CSV creation Result dialog is displayed.
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7. (Optional) Click Print to print the result of the operation in the the default grid view. This is
applicable only to CSV type Onboarding Template.

8. (Optional) Select the required Device record(s) and click Extend Expiration to extend the validity
duration of the Device record(s). The validity is extended based on the duration specified during the
creation. For more information, see Extending Expiry of a Device.

9. (Optional) Select the required Device record(s) and click Delete to remove the Device record(s).

Tip:

Use Ctrl / Shift to select multiple records to delete.

10. (Optional) Click Show Filter to specify the search parameters and quickly find all similar records. The
filter is applied to all columns displayed in the list view. For more information, see Finding Device
Records.

11. Note:

Use the paging control at the bottom of the list to move forward or backward by one
page, or to the first or last page of the list. You can control number of records to be
displayed per page and also click an individual page number to navigate to the
specific page. Click Refresh icon to refresh the view.

Field Descriptions

Use data in the following table to use New Device screen. The fields are enabled based on the
associated Onboarding Template settings.

../../../../../Content/GIM Configuration/Topics/ExtendingExpiryOfADevice.html
../../../../../Content/GIM Configuration/Topics/FindingDeviceRecords.html
../../../../../Content/GIM Configuration/Topics/FindingDeviceRecords.html
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Name Description

Onboarding
Template

Specifies the list of Onboarding Template(s) that the Provisioner is a member of.
The Provisioner can add the Device using any one of the available Onboarding
Template(s).

Load Devices
From File

Specifies the the path of the file containing the Devices records in CSV
format to be uploaded. This applies only to CSV Type Onboarding
Template. Specifications of the file contents are as follows:

Any row beginning with # will not be processed.

A maximum of 200 records will be created in a single operation,
exceeding will not be processed.

Post operation a dialog with the operation status is displayed over the
created Device details.

MAC Address Configures the MAC address of the Device.

Format of MAC address: xx:xx:xx:xx:xx:xx.

For example: 10:00:01:02:21:10.

Device Name Configures the name of the Device.

Source Displays the source of the Device. By default, the information is available.

Device Type
Groups

Specifies the list of Device type groups available for the selected Onboarding
Template.

Device Type Specifies the list of Device types available for the selected Device type group.

Records Enabled Select to enable the record. If you do not select this option, the Device is disabled.

Delete on Expire Deletes the Devices from the Access Control Engine. Select this option to
automatically remove expired Device records.

If you do not select this option, you need to manually remove the Device
records after it expires. The expired Device records remains in the
Access Control Engine.

As a Provisioner you can renew or remove the expired records at any
point of time.
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Name Description

Assest Type Specifies the list of assets types to configure the record duration.

The options available are:

l Permanent

l Temporary

If the Asset Type is selected as Permanent, the Application creates a
permanent record for the Device and the End Time column displays “—”.

If the Asset Type is selected as Temporary, the Application creates a
temporary record for the Device and allows you to specify the record
validity details in Activate Account On field.

Activate Account
On

Configures the date and time at which the Device record is activated. The value in
these fields defaults to the current date and time on the Guest and IoT Manager.
You can also view the time zone that has been set to the current Onboarding
Template.

l Date: Enter the start date for activating Device records . The date
should be in YYYY/MM/DD format.

l Time: Enter the time in hours and minutes based on a 12-hour
setting. The time should be in hh:mm:ss format.

l AM / PM: Select the time of the day.

Activate on First
Login

Specifies that guest account will be valid only after the first login.

Note:

This field is available only if the Administrator has selected First
Login option in Account Validity Period section while creating an
Onboarding Template and the Provisioner selects the same
Onboarding Template during Device record creation from the
Onboarding Template drop-down list.

The Activate Account On option is replaced by Activate on First
Login: Yes option.

Duration Configures the duration validity of the Device record. The record validity period
starts from the activation time and lasts for the specified duration.

By default, the application sets the durations to the maximum time
period specified in the Temporary Account Validity field during creation
of Onboarding Template. Specify the period as an integer and set the
units by selecting minutes, hours, and days.
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Name Description

Single
Membership
Access Group

Specifies one of the access groups that has been configured in Onboarding
Template.

Multiple
Memberships
Access Group

Configures the access to the Devices. You can select multiple options.

For example, if the access has to be provided for a specific department,
the Administrator defines which access group are available for you.

Custom fields: 1
to 6

Specifies the label values configured for Device records.

Modifying Device Record
Use this procedure to modify Device records.

Procedure

1. In the navigation pane, click Devices > Devices tab.

The Devices screen is displayed with list of Device records created by the Provisioner.

2. Select the required Device record to be modified and click Edit.

You can also edit by double-clicking the required Device record from the list.

The Onboarding Template field is editable only during creating an Device.

3. In the Device Info section, modify the fields required.

4. Click Save to save the configuration or click Cancel to cancel the changes.

The modified Device record details are displayed in the Devices screen.

5. (Optional) To modify the validity of a Device record, do the following:

1. Select the required Device record and scroll left to view the Start Time and End Time Device
attributes column. The RED text indicates expired record.

2. Double-click the Device record to view the Edit Device screen.

3. Modify the duration period in Duration field or modify the Activate Account On field to change
the validity period to desired time frame.

6. (Optional) Select the required Device record(s) and select Delete > Delete Selected to remove Device
records you selected or Delete > Delete All to remove all Device records.

Tip:

Use Ctrl / Shift to select multiple records to delete.

For more information, see Adding a Device Record Adding a Device Record.
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Finding Device Records

Procedure

1. In the navigation pane, click Devices > Devices tab.

The Devices screen is displayed with the list of Devices created by Provisioner.

2. Select the Show drop-down list to filter the devices in the table to display only those devices added by a
specific Provisioner or the Onboarding Template drop-down list to filter the devices in the table to
display only those devices added through a specific Onboarding Template.

3. In the Devices screen, click Show Filter to specify the search parameters and quickly find all similar
Device records. The Filter Devices screen is displayed.

4. To search the devices:

l Select All Devices to view all the Devices.

l Select Specify Filter to define additional fields by which you can filter the list of devices.

The appropriate Device records are displayed in the Devices screen table.

5. Click Apply Filter.

Use the paging control at the bottom of the list to move forward or backward by one page, or to
the first or last page of the list. You can control number of records to be displayed per page and
also click an individual page number to navigate to the specific page. Click Refresh icon to
refresh the view.

Field Descriptions

Name Description

All Devices Displays the list of all the devices available. By default, this option is selected.
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Name Description

Specify Filter Simplifies the search parameters to quickly find the selected search criterion that
includes specified parameters. Additionally, you need to enter the operator
conditions to match the selected search criteria to obtain precise search results
of the selected Onboarding Template.

The search conditions are:

l MAC Address

l Name

l Type

l Source

l Start Time

l End Time

l Devices Activated in the Last: Fetches all the Device records
activated in the last X number of hours.

l First Login Pending and Created Before: Fetches all the Device
records that have been created before the X date entered and
awaiting first login.

l Devices Expiring in the Next: Calculates and fetches the Devices
according to:

CURRENT_TIME < END_TIME < CURRENT_TIME + X days

‘X’ is a variable here. So, if you want to filter all Devices expiring
tomorrow, you can select this filter condition.

l Expired Devices: Fetches all the expired Device records.

The search conditions operators depends on the selected search
conditions. For example, you can provide explicit operations such as
Start With, Equal, Not Equal, Contains, Ends With and the name of the
search value.

Some conditions have multiple condition operators. For example, you
can search for multiple values when using the equal (=) or not equal
!=) operators.

Extending Expiry of a Device
Use this procedure to extends the duration of expired Device(s) by “X” days at one go.

Procedure
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1. In the navigation pane, click Devices > Devices tab. The Devices screen is displayed with the list of
Devices provisioned

2. Select the required Device record(s) and click Extend Expiration to extend the validity duration of the
Device record(s). The validity is extended based on the duration specified during the creation.

The duration of expiry of each selected Devices is calculated as:

DURATION = END_TIME – START_TIME

Then the account is modified to:

START_TIME = CURRENT_TIME

END_TIME = START_TIME + DURATION

Extend Expiration Example:

Consider two Devices, Device 1 valid for a duration of one month and Device 2 is valid for a
duration of two months, both are expiring tomorrow and the current time is 02:00 P.M.
When you select these two Devices and click Extend Expiration option, their expiry is
extended as follows:

1. Device 1 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 1 month.

2. Device 2 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 2 months.

Note:

The Provisioners can use Extend Expiration option to extend the duration of expiry
for expired Device(s) also.

Expiry of First Login Pending and Permanent Device accounts cannot be extended.

Managing Sponsor Actions
The Sponsor tab in Sponsor menu allows a Sponsor to manage guest accounts that require
Sponsor's attention. A Sponsor can either be an internal Provisioner or a Provisioner belonging
to a Sponsor LDAP.

Sponsor feature allows you:

l View all the sponsored Guest Users

l Manage Sponsor actions

The Sponsor tab will only be visible in the Provisioner Application on the left panel of the screen
only if there are records to be viewed.

When there are no records to be displayed the left navigation will not have the Sponsor tab and
once there are records added the tab will be seen on login.
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If the Provisioner is already logged in, the Provisioner can refresh the page and the tab will be
seen. Vice-versa is also applicable, once the records are deleted or not available the Sponsor tab
will not be visible again on refresh or re-login whichever occurs first.

Viewing and Providing Guest Access
Use this procedure to view all sponsored Guest Users and allow actions such as approve, bulk
approve, bulk deny / lock,bulk extend expiration, send email, and print the Guest Users.

Procedure

1. In the navigation pane, click Sponsor > Sponsor tab.

The Sponsor screen is displayed with all the list of guests for which the Provisioner is a
Sponsor.

You can also click the column headers to sort the list view by that column. Click the
column header a second time to reverse the direction of the sort.

2. Select the required user and click View to view the selected user information.

The Guest User Info screen is displayed.
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Note:

The view functionality is available only if the following conditions are met:

l If a valid Email ID is present for the Sponsor.

l LDAP Sponsor Username must be mentioned along with the complete domain.
Though Guest and IoT Manager-LDAP authentication is not case sensitive, the
Sponsor view functionality is case sensitive. For example, if the Provisioner
Username in LDAP is <<name>> and the domain is test.local, then the
Sponsor managing Guest Users view works only if the Provisioner logs in as
<<name>>@test.local.

3. Select the required user accounts and click Approve to approve the access.

The Approve screen is displayed. You can include a message that needs to be sent as part
of the approval email.
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4. Select the required user accounts and click Deny/Lock to deny the access.

The Deny / Lock screen is displayed. You can include a message that needs to be sent as
part of the denial email.

5. Select the required user accounts and click Extend Expiration to extend the duration of Guest User
account.

The Extend Expiration screen is displayed and enables you to extend the validity of Guest
User(s) account. The validity is extended based on the duration specified during the
creation.

The duration of each selected Guest User is calculated as:

DURATION = END_TIME – START_TIME

Then the account is modified to:

START_TIME = CURRENT_TIME

END_TIME = START_TIME + DURATION

Extend Expiration Example:

Consider two Guest Users, User 1 valid for a duration of one month and User 2 is valid for a
duration of two months, both are expiring tomorrow and the current time is 02:00 P.M.
When you select these two accounts and click Extend Expiration option, their expiry is
extended as follows:

1. User 1 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 1 month.

2. User 2 is extended as Start Time = 02:00 P.M. today and End Time = 02:00 P.M.
today + 2 months.

Note:

Expiry of First Login Pending and Permanent Guest User accounts cannot be
extended.

6. Select the required user and click Send Email.

The Email screen is displayed. You can include a message that needs to be sent as part
the email.

7. Select the required user and click Print the information, if required.

8. (Optional) Click Show Filter to specify the search parameters and quickly find all similar records.

The filter is applied to all columns displayed in the list view. Additionally you can also enter
the operator conditions to match the selected search criteria to obtain precise search
results.
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For more information about how to search specific guest users, see the ExtremeControl
Guest and IoT Manager Configuration document.
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Using Self-Provisioning Services
This chapter is intended for Guest Users to understand the Self-Provisioning Services
functionality that offers guest the ability to create an account or register their devices.

The available service types are:

l Guest User: A Self-Provisioning Service that allows users to self-register to create their
own accounts.

l Devices: A Self-Provisioning Service that allows users to register a Device.

l Using Self-Service for Zero Touch Guest Access: A Self-Provisioning Service that allows users to create
a new Guest User account by just scanning a QR code and sending an SMS.

Registering a New Guest User
Use this procedure to create a new Guest User using the Self-Provisioning Services.

Before you begin

Ensure that you have the URL that is available in the Self-Provisioning Services tab.

The URL’s are different for each service type. For Guest User: https://<server_
name>/GIM/user/<service_name>

Procedure

1. In the Register New Guest User screen, enter the Guest User details in the respective fields as required.

2. If the Onboarding Template type is Sponsor Approval, users has to enter the Sponsor details. The
Sponsor details need to be entered depends on the associated Onboarding Template setting.

3. Click Submit / Request Approval to create the guest account.

If the Sponsor approval is not required, the Guest User account is created and the
credentials are shared with the user via email / SMS or displayed. If the associated
Onboarding Template has settings that requires Sponsor approval, then the Request
Approval option is displayed. The Sponsor must approve for the account to be activated.

4. (Optional) Click Clear, to clear the configuration.

5. (Optional) To resend the password to Guest User, in the Username field enter the
username and click Resend Password.

6. (Optional) To resend the complete user details, in the Username field enter the username and click
Resend Details.

The application validates the following prior to resending the Password or Resend Details.

../../../../../Content/GIM Configuration/Topics/RegisteringNewGuestUser.html
../../../../../Content/GIM Configuration/Topics/RegisteringNewDevices.html
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l Notification options has either SMS/Email or both enabled

l Account is not locked/expired

Important:

We strongly recommend that Administrator must disable unnecessary features in the
web browser that displays in the Self-Service Provisioning service. Disable all menus,
tool bars, and the URL.

Guest and IoT Manager must be connected to the Access Control Engine all the times
for the Self-Service Provisioning service to operate.

Sponsor Details

Procedure

1. In the Register New Guest User > Sponsor section, enter the Sponsor contact details in the respective
fields as required.

2. Click Request Approval to create the Guest User.

For more information, see the ExtremeControl Guest and IoT Manager Configuration
document.

3. (Optional) Click Clear, to clear the configuration.

4. (Optional) To resend the password to Guest Users, select the required user and click Resend Password
to resend the Password.

5. (Optional) To resend the password and Details to Guest Users, select the required user and click Resend
Details to resend the Password and Details to Guest Users.

When Guest Users are selected to resend the Password or User Details, the application
validates the following prior to resending the Password or User Details.

l Notification options has either SMS / Email or both enabled.

l Account is not locked / expired.

Sponsor Details Field Descriptions
Name Description

First Name
and Last
Name

Specifies the first and last name of the Sponsor.
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Name Description

Email Specifies the email ID and allows to select the domain from the drop-down list.

You can either select the email ID from the drop-down list, or enter the
corresponding name to search and select the appropriate Sponsor.

Mobile
Phone

Specifies the Sponsor contact number that is required to send SMS notification.

Based on OT template settings, one of the following Sponsor Details options is available. They
are listed below:

l Manually Enter Sponsor: In this scenario, enter you must enter the First Name and Last Name, Email, and
Mobile Phone Details of the sponsor.

l Predefined Sponsor: In this scenario, the guest must select from the predefined sponsor list or specify
the sponsor email match the list of sponsor emails specified by the administrator.

l Fixed Sponsor: In this scenario, the sponsor is defined by the administrator and user need not specify
the Sponsor details.

l LDAP Sponsor: In this scenario, the sponsor is defined by the associated LDAP group. Where, the user
can search and select from the list of the available sponsors.

Registering New Devices
Use this procedure to create a new Device using the Self-Provisioning Services.

Before you begin

Ensure that you have the URL that is available in the Self-Provisioning Services tab.

The URL’s are different for each service type. For new Devices: https://<server_
name>/GIM/device/<service_name>

Procedure

1. In the Register New Guest User screen, enter the Device details in the respective fields as required.

2. Click Submit to create the Device record.

3. (Optional) Click Clear, to clear the configuration.

Using Self-Service for Zero Touch Guest Access
Use this procedure to create a new Guest User using the Zero Touch Guest Access Self-
Provisioning Services.
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Before you begin

Ensure that you have the URL that is available in the Self-Provisioning Services tab.

The URL’s are different for each service type. For Zero Touch Guest Access Self-service: the
URL is https://<server_ name>/GIM/qr-user/<service_name>

.

Procedure

1. The Guest User Scans the QR code. An SMS will be triggered after the scan is complete
and is sent to the service provider (Twilio).

Note: Ensure Two-way SMS configuration is done properly. For more information see,
Two-Way SMS Provider.

2. The service provider sends the SMS to GIM and GIM creates a Guest User account.

3. Guest and IoT Manager then send an SMS through the same service provider back to the
Guest User with the newly created account details for the new Guest User.

For more information see, Automated Login of the Guest User using the Login URL .
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Guest and IoT Manager Add-In for Outlook
The Guest and IoT Manager Add-in provosions and provides guest access credentials to
meeting invitees. You can download the add-in from both Administrator and Provisioner login
page.

This section provides information on how to install Add-in for Outlook that works with Windows
and Macintosh computers (Outlook 2016 for Windows and Mac) and also on how to provision
guest access using the installed Add-in.

Installing Guest and IoT Manager Add-In
Use this procedure to install Guest and IoT Manager Add-In for Outlook 2016 for Windows and
Mac that helps in automating tasks when you view or create meetings.

Before you begin

Internet Explorer must be installed and needs to be enabled in the Turn Windows features on or
off screen for an Outlook Add-in to work.

Procedure

1. In the Guest and IoT Manager Administrator / Provisioner login page, click Download GIM Outlook Add-
in to download the installer and store it in the local drive.

2. In the local folder, extract the files. You can see the following files in the folder:

l GIM Certificate File: Guest and IoT Manager certificate is the HTTPD certificate
bound to the HTTPD service.

l GIM Manifest File

l Readme File

Note:

The GIM certificate file contains a certificate to certify the identity and Readme file
contains the instructions to install.

Install the GIM certificate only if it is Self-Signed SSL certificate. For more information
on certificate installation, refer Readme file.

3. Start the Outlook application and click Store or Get Add-ins in the Home menu.



Installing Guest and IoT Manager Add-In

219 of 253

The ADD-INS screen is displayed. In the ADD-INS screen, you can install the add-in either
from the local drive or Administration can side-load this add-in to all the Provisioner(s).

4. To install the add-in from the local drive, do the following:

1. In the ADD-INS screen, click My add-ins > + Add a custom add-in > Add from file…. to import the
add-in manifest file.

2. Select Browse and navigate to the location of the add-in manifest file that you want to install.

3. Select the "gim-manifest.xml" add-in file and click Open.

4. Click Install.

The added add-in is displayed in the Custom add-ins section of ADD-INS screen.

5. To side-load the add-in to the Provisioner(s) as an Administrator, use Exchange Administration Center
(EAC).

Side-loading add-ins requires at minimum the My Custom Apps role for your Exchange
Server. For more information, see Install an Add-In for Outlook.

https://docs.microsoft.com/en-us/exchange/clients-and-mobile-in-exchange-online/add-ins-for-outlook/install-or-remove-outlook-add-ins#what-do-you-want-to-do
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GIM Add-In

Note:

The added add-in is activated only when the Provisioner(s) wants to raise a meeting
request.

An example of added add-in:

Provisioning Guest Access

Procedure

1. Start the Outlook application.

2. In the Meeting mode, select Guest Access add-in. If you do not see the Guest Access add-in, then you
need to install.
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3. Click Guest Access.

The task pane displays the Guest and IoT Manager Provisioner login page.
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4. Login to the application using Provisioner credentials.

The Guest User Provisioning screen is displayed on successful authentication and if the
Provisioner being part of atleast one Onboarding Template of type Outlook.

Note:

Ensure that the Guest and IoT Manager Application is connected to Access Control
Engine to authenticate.

All the fields that are mandatory in the provisioner's application is highlighted with a
red ‘*’ that is added with the label field.
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5. Select the required Onboarding Template to which the users in the meeting needs to be associated from
the drop-down list.

6. Select the required Access Groups.

The Single and Multiple Memberships Access Groups are available based on the
Onboarding Template configuration.

7. (Optional) Select the Activate prior to meeting (mins) or Remain activated after meeting (mins) and
enter the minutes to add a buffer time between the scheduled guest access. The maximum buffer time
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is 30 minutes.

The Guest Users obtain the access duration equal to scheduled duration along with buffer
/ padding duration. Whereas, the outlook calendar shows only the scheduled meeting
duration.

8. Set up the meeting as you typically do:

1. In the To field, enter the email address of the Guest User(s), separated by semicolons.

2. Select Room... to find a conference room if you need your Guest Users to be accommodated in
one location.

3. Select a Start Time and End Time; enter an agenda in the meeting area.

9. Click Submit in the Guest User Provisioning screen prior sending the meeting invite. Alternatively, you
can also provision the Guest Users by reopening this meeting invite from the calendar. The email sent
summary is displayed.

l If the Guest User is present in the database, then the invite is updated with the
scheduled start and end time.

l If a new Email ID is added, then the Guest User is created and confirmation email is
sent to the corresponding Guest User.

l If any Email ID is removed, then the corresponding Guest Users will also be removed
from the Guest and IoT Manager Application.

Note:

l If the Administrator has excluded a domain during Guest User Onboarding
Template creation, then the Guest User account is not created for any emails
available in that specific domain.

l Ensure that you always expand the distribution list.

l You need to click Submit in the add-in once again, if there are any changes in
the recipient list or meeting duration.

l If the scheduled meeting duration along with added padding is greater than
the maximum expiration time configured in the Onboarding Template, then the
access duration will be reduced to maximum duration configured in the
Onboarding Template.

l Recurring meetings are not supported. Access will be provided only for the
first occurrence.

Tip:

If you want to extend the access for the second occurrence, resubmit in
the Guest and IoT Manager add-in when the first meeting is ended and so
on.
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10. (Optional) Click Delete in the Guest User Provisioning screen to remove all the Guest Users in the
meeting. For example, if you need to cancel the guest access / meetings.

Note:

The application displays a warning message prior removing all the Guest Users.

The Delete option is available only if you have created the Guest Users for the current
meeting schedule.
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Automated Login of the Guest User using the
Login URL

This procedure explains the Automated Login of the Guest User using the Login URL.
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Procedure

1. The User scans the QR code and the scanned QR code triggers a SMS to Guest and IoT
Manager

2. Guest and IoT Manager application validates the SMS.

3. Guest and IoT Manager application then creates a Guest User account number with the
Username.

4. The Response is then sent to Guest User with the account details along with the login
URL.

5. Once the Guest User connects to the Wifi-SSID, the Guest User gets the IP address from
DHCP.

6. The client’s Mac Address and IP address gets updated in the Extreme Cloud Application
(XCA) and the details get auto populated in the XIQ-SE’s end system table.

Note:

Ensure all the wireless clients connected to XCA are getting listed in End-System
table for this feature to work as expected.

.

7. Guest User clicks on the Login URL and is redirected to the Guest and IoT Manager
application.

Note:

GIM’s IP/Hostname should be whitelisted in the NAC’s captive portal setting and the
HTTPS traffic to GIM should be allowed even when the device is in Unregistered Rule
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8. On clicking the Login URL that contains the encrypted details of the Guest User the
details are validated by RADIUS request to NAC.

9. After the successful authentication, the end system details are fetched from XIQ-SE from
the XIQ-SEs end system data.

10. The Guest and IoT Manager application associates the Guest User with the corresponding
end system and forces the reauthentication of the device that is enforced through XCA.

11. Finally, Guest and IoT Manager application redirects the Guest User to the URL configured
in self-service.
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Troubleshooting and FAQs
This chapter describes the basic concepts and general troubleshooting guidelines for problems
that may occur when configuring and using the Guest and IoT Manager Application. The
solutions to common questions helps you troubleshoot quires when you encounter errors.

Testing RADIUS Connection Settings
Use this procedure to test the RADIUS setup.

Procedure

1. Create a Provisioner. For more information, see Creating an Internal Provisioner.

2. Open your web browser and enter the URL of the Provisioner Application.

https://<Guest Manager machine>/GuestManager/provisioner/

3. In the Login screen, enter the Provisioner login credentials.

4. Click Login. If your login attempt fails, see Problem: Provisioner Cannot Login.

Restarting Guest and IoT Manager
Use this procedure to restart Guest and IoT Manager Application.

Procedure

1. Log in to the Guest and IoT Manager Virtual Appliance console.

2. Enter the Username and Password.

3. Enter tomcat restart, to restart the web server.

4. Launch the Guest and IoT Manager Virtual Appliance console.

Problem: Virtual Appliance Troubleshooting

Condition

Problem in Guest and IoT Manager Virtual Appliance.

Guest and IoT Manager URL is not Accessible

1. Log in to the Guest and IoT Manager Virtual Appliance as Administrator.

2. From the CLI, enter command tomcat restart.

../../../../../Content/GIM Configuration/Topics/InternalProvisionerOperations.html
../../../../../Content/GIM Configuration/Topics/ProblemProvisionerCannotLogin.html
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Guest and IoT Manager HTTPS is not using the Custom Certificate

If the Guest and IoT Manager HTTPS connection is not using the associated certificate and key
after you uploaded the custom certificate and associated it with tomcat, do the following:

1. Log in to Guest and IoT Manager Virtual Appliance as Administrator.

2. From the CLI, enter tomcat restart.

Guest and IoT Manager CLI
If you are not able to ping the Guest and IoT Manager Virtual Appliance after assigning the IP
address and configure the route, enter reboot from the CLI.

Problem: Saving Access Control Engine Settings

Problem

Unable to save Access Control Engine details in Guest and IoT Manager.

Solution

1. Ensure that the DNS is configured correctly if hostname is used to connect.

2. Ensure ExtremeCloud IQ - Site Engine / Access Control Engine version is compatible with the Guest and
IoT Manager version.

3. Ensure that the ExtremeCloud IQ - Site Engine administrative user has Guest and IoT Manager read and
write permissions.

4. Ensure that the Access Control Engine is added in the required Engine Group in ExtremeCloud IQ - Site
Engine.

Problem: User Groups / End System Group Not Visible in
Guest and IoT Manager

Problem

Any newly created User Groups / End System Groups created in ExtremeCloud IQ - Site Engine
is not visible in the Access Group tab of the Onboarding Template module.

Solution

1. User Groups of type Username and End System Groups of type MAC are only visible in the Guest and
IoT Manager.

2. Ensure that the Groups created in ExtremeCloud IQ - Site Engine are of the appropriate type.
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Problem: Provisioner Cannot Login

Problem

No login button found.

Solution

1. If Access Control Engine or ExtremeCloud IQ - Site Engine is not reachable, ensure that Access Control
Engine and ExtremeCloud IQ - Site Engine are up and reachable.

2. If invalid ExtremeCloud IQ - Site Engine credentials are entered, ensure that Guest and IoT Manager is
configured with valid ExtremeCloud IQ - Site Engine administrator credentials which has Guest and IoT
Manager read and write access.

3. Ensure that the Access Control Engine is added in the required Engine Group in ExtremeCloud IQ - Site
Engine.

4. If no valid Guest and IoT Manager license installed, ensure that the valid Guest and IoT Manager license is
installed in the ExtremeCloud IQ - Site Engine.

Problem

Provisioner login fails with an error stating Server error please contact administrator.

Solution

1. If Access Control Engine or ExtremeCloud IQ - Site Engine is not reachable, ensure that Access Control
Engine and ExtremeCloud IQ - Site Engine are up and reachable.

2. If Guest and IoT Manager is not configured in the Engine Group, ensure to add Guest and IoT Manager IP
address and RADIUS shared secret in Engine details on ExtremeCloud IQ - Site Engine.

3. If Guest and IoT Manager management IP address is changed but not updated the Guest and IoT
Manager Server settings in the Engine Group, update the Guest and IoT Manager IP address in Engine
details on ExtremeCloud IQ - Site Engine.

4. If RADIUS shared secret mismatch, ensure that you have entered the same RADIUS shared secret on
Guest and IoT Manager and in the Engine details on ExtremeCloud IQ - Site Engine.

5. If Guest and IoT Manager is not licensed, install valid Guest and IoT Manager license on ExtremeCloud IQ
- Site Engine.

6. If the Provisioner is an LDAP Provisioner and is not associated with any Onboarding Template, ensure
that an Onboarding Template is associated with that LDAP group or there is a default Onboarding
Template present. For more information, see Configuring Onboarding Template.

Problem

Invalid credentials

../../../../../Content/GIM Configuration/Topics/ConfiguringOnboardingTemplate.html
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Solution

1. If wrong credentials are entered, ensure a valid username and password is entered.

2. If Guest and IoT Manager domain LPR and Access Control Engine AAA LPR settings are not same,
ensure that both are same.

3. If Internal Provisioner and AAA rule does not have local authentication selected in the AAA rule, ensure
that the local authentication is selected with LPR same as GIM domain LPR

4. If LDAP Provisioner and AAA rule does not have LDAP authentication selected as the authentication
type in the AAA configuration, ensure the LDAP authentication is selected and required LDAP details
are provided.

Problem

If fall through is enabled in the AAA configuration and both Local Authentication and LDAP
Authentication is enabled, then the fall through does not work as expected and the second rule
is not evaluated.

Solution
Do not enable fall through option for Provisioner login.

Problem: Guest and IoT Manager Email / SMS
Notification Failed

Problem

Unable to send Email / SMS notifications for Guest Users.

Solution

1. Make sure that the email notification is properly configured.

Log in to the Guest and IoT Manager Administrator User Interface. In the navigation pane,
click Administration > Notification > Email > Enable Sending of Email Notification. Check
the details and click Save.

2. Log in to the Guest and IoT Manager Virtual Appliance console as Administrator.

a. Enter command show dns to check if the dns is configured. If dns is not configured,
configure dns. For more information, see dns.

b. Enter reboot.

3. Send a test email using Test option. For more information, see Setting Notification
Parameters.

../../../../../Content/GIM Configuration/Topics/Command3.html
../../../../../Content/GIM Configuration/Topics/SettingNotificationParameters.html
../../../../../Content/GIM Configuration/Topics/SettingNotificationParameters.html
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4. Ensure that the Guest User Email and / or Password to Guest User Mobile Phone options
are selected in the Send Notification section of the New Guest User screen.

Problem: Unable to Access Guest and IoT Manager
Application URL

Problem

When the admin interface IP address is updated manually through CLI command, Guest and IoT
Manager URL is not reachable.

Solution
Verify the route settings and make appropriate change if needed. For more information, see
route.

Problem: User and Device Troubleshooting

Problem

Newly created Guest Users / Devices from Guest and IoT Manager are not authenticated.

Solution

1. Ensure that the records are enabled.

For more information,see the ExtremeControl Guest and IoT Manager Configuration
document.

2. Ensure that the Guest User / Device is not expired. You can identify the expired record in the End Time
attributes column that is highlighted in RED.

3. Ensure that the start time is not in the future.

Problem

../../../../../Content/GIM Configuration/Topics/Command11.html
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Expired Guest User / Device record is not available Guest and IoT Manager.

Solution
Ensure that the Delete on Expiry option is unchecked while creating the new Guest User /
Device.

Problem: Sponsor List is Not Available

Problem

The Sponsor list is not available error is seen when logging to the self-service URL.

Solution
Ensure that the LDAP group which has the sponsors is correctly entered in the Onboarding
Template setting.

Problem: Modification in Network Interface settings does
not reflect post deployment

Problem

If Network Interface information is modified during the deployment, the changes will not get
updated post deployment.

Solution

1. Delete the installed OVA.

2. Re-install the OVA with default Network Interface settings.

Retain the default Network interface settings on deployment of OVA. Any changes in the
Network interface settings can be done post bring up.

Problem: Outlook Add-in Issues

Problem

Any changes to the meeting invite, either invitees or meeting time, is not reflecting in the Guest
User records.

Solution
Ensure to click on submit after making the changes and before clicking Send Update in the
meeting invite.
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Problem

Outlook Add-in icon disappears from Outlook.

Solution
Restarting the Outlook application resolves this issue.

Problem: Service Unavailable in Browser

Problem

Post GIM reboot (manually from CLI) or post a config restore workflow, Service Unavailable
message is observed in the browser while accessing GIM Application.

Solution
Restart tomcat service from the CLI. Enter command tomcat restart.

Problem: Time Zone Issues for Schedule Tasks

Problem

All the scheduled tasks for Backup / Housekeeping, have the time displayed either in GMT, or
some other timezone. Therefore, calculating the local time is difficult.

Solution

1. Log into the GIM console and check the time zone using the show time zone command. By default, time
zone setting for GIM is in GMT.

2. Change the time zone using the timezone command in the console.
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Problem: Users/Devices are not getting cleaned up for
Housekeeping Tasks

Problem

Housekeeping task is used to delete Guest Users/Devices that have their first login pending.

For Devices/Guest Users with First login pending to be deleted before 'x' days, the scheduled
tasks considers the period of 24 hours as 1 day. Therefore, for 'x' days the period will be 'x' * 24
hours before running the task.

For example, a scheduled task that is configured as, Delete all First Login Pending Guest User
created before 1 day but when the task is executed, the Guest Users that were created a day
before and meet this criteria are not removed.

Solution

The time period used to identify the eligible Guest Users/Devices is calculated from the time the
task is executed. Therefore, ensure that the identification of eligible Guest Users/Devices is
calculated keeping in mind the time at which the task executes.

For example,

If the task is defined as Delete all First Login Pending Guest Users created before 1 day. Where,
the task is executed at 10 AM on the 4th June. Then all the Guest Users created before 10 AM 3rd
June are eligible for this clean up.

Similarly, if the Guest User was created on 11 AM on the 3rd June and may seem to fit the created
before one day criteria, this Guest User is not eligible for clean up.

Problem: Unable to Access GIM UI

Problem

Unable to access the GIM UI after having disabled and then enabled the interface or after doing
a restore operation or after reboot.

Solution

Some routes are deleted when the GIM interfaces are disabled or when GIM VM is rebooted.

Check if the added routes are deleted after having disabled the interface or after rebooting.

If there are some routes that are disabled, then add the routes manually and restart tomcat.

<interface <Port> ipaddr <ip address/netmask>

<route add <dest ip > gateway
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Problem: LDAP Provisioner login fails

Problem

LDAP login fails with a Server Error. In the logs, an error 'Login successful but No Onboarding
Templates recived form NAC' is displayed, indicating that no Onboarding template was
received from NAC.

Solution

This occurs when the LDAP Provisioner is not mapped to any Onboarding Template.

In the Onboarding Template(s) – Advanced section, check the following:

l If the Default Onboarding Template for LDAP Provisioner checkbox is selected

OR

l If the LDAP Group to which the Provisioner belongs is specified in one or more of the Onboarding
Templates in the Associated LDAP Groups section. Then, you must specify the LDAP group and not the
User search root as previously specified in 8.2.x.

l Only the Onboarding Templates that have the LDAP group mapped (to which the Provisioner belongs)
or have the Default Onboarding Template checkbox marked as checked are sent back by NAC for LDAP
Provisioners.

Problem: LDAP Sponsors are not populating in the Self-
Service Page

Problem

The list of LDAP sponsors that was populating in GIM 8.2.x does not populate after migrating to
GIM 8.3.0

Solution

The LDAP Sponsor configuration done in GIM 8.2.x does not work in GIM 8.3.0.

As, Guest and IoT Manager lists the Sponsor details with matching LDAP groups in 8.3.0, unlike
matching User Search Root as in 8.2.x

Problem: Server Error during bulk creation

Problem

When Guest Users or Devices are being imported using CSV. This occurs only when a very large
number such as 1000 records are attempted in continuous batches of 1000 (maximum limit for
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each upload is 1000).

Solution

This occurs due to the time required in enforcement of the created Guest Users / Devices
between XIQ-SE and NAC.

The time taken to complete the enforcement is the reason for the Server Error displayed.

To overcome this wait for some time before attempting to create more records so that the
enforcement can complete.

The error is more frequent if there are multiple GIM's associated with a NAC and all of them are
bulk creating Guest User / Device records.

Problem: Unable to Renew Password

Problem

The Guest User Renew Password fails.

Solution

l The reason for the failure is stated on the result dialog of the operation.

l Only the Guest User accounts which have been created using an Onboarding Template
which meets the following criteria can be renewed:

l Password must be randomly generated.

l Notification options - At least one method must be enabled (Email/ SMS).

l Account must not be Expired.

l Onboarding Template cannot be of the Type Voucher/ CSV.

Problem: Guest User account is not created post sending
SMS

Problem

When Guest User scans the QR code and sends the SMS, No Guest User account is created for
that request..

Solution

l Ensure GIM’s REST API (with Service-B IP/FQDN) end point is configured in the Twilio’s Configuration.
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l Ensure reachability of Service-B out of corporate firewall.

l Strict-SSL configuration should turned OFF or ON in Twilio Configuration page as per the
scenario.

Problem: Login URL redirects to Captive Portal

Problem

On clicking Login URL, the URL gets redirected to NAC Captive Portal.

Solution

l Ensure that the HTTPS traffic to GIM IP is enabled for Unregistered Profile of End-System.

l GIM IP/FQDN should be added in the whitelisted domain in Captive Portal settings.

l Make sure that MAC Address and IP Address of the Client device are getting populated in
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End-System table of ExtremeCloud IQ - Site Engine when it gets connected to AP

Problem: “Server Error. Please contact Administrator"
Error message on clicking Login URL

Problem

Guest User Auto Login fails with error message “Server Error. Please contact Administrator."

Solution

l Ensure Connectivity of NAC and ExtremeCloud IQ - Site Engine from GIM.

l Make sure that MAC Address and IP Address of the Client device are getting populated in End-System
table of XIQ-SE when it gets connected to AP.

Problem: FQDN not being used in URLs

Problem

FQDN is not being used in URLs sent in Sponsor emails/ messages and UI checkbox is checked.
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Solution

Ensure Hostname and Domain name is configured in the CLI. You can use the show interface CLI
to check if hostname is configured on the interface.(FQDN is derived from the hostname +
domain name).

Problem: Unable to Customize Provisioner Login page

Problem

The changes are not reflected in the Provisioner Login Page.

Solution

Select the required settings for the customization and make sure you save the changes (at the
bottom of the screen). Merely selecting the values will not result in the customization.

Problem: "Login failed. Invalid credentials/Account
Expired” message on clicking Login URL

Problem

Guest User Auto Login fails with error message – “Login failed. Invalid credentials/Account
Expired” and no network access.
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Solution

l Ensure the Login URL is not corrupted.

l Ensure the Guest User account is not expired/disabled.

l If both the scenarios are satisfied and still not able to login, ensure that time of GIM, NAC, XIQ-SE and
XCA are in sync.

Problem: Outlook Add-in throws Security Exception post
enabling FQDN

Problem

After enabling FQDN settings, Outlook Add-in throws Security Exception.

Solution

This problem occurs when Add-in Manifest was downloaded by accessing GIM using IP address
and not Hostname.

In order to fix this issue, download the manifest again and re-install (Either individually or Admin
can push to desired users through Microsoft Exchange Center).
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Command Line Interface
This chapter describes the Command Line Interface (CLI) used in Guest and IoT Manager
Application to operate the system and to perform specific tasks required by Administrator.

The Guest and IoT Manager CLI provides a limited set of administrative actions that you can
perform on the Application. The CLI has a default timeout of 5 minutes.

The following section briefs the CLI commands available on Guest and IoT Manager.

certificate
Important:

HTTP, HTTPS, and FTP are the only supported protocols for the URL.

The URL must point to the file location directly and not through a proxy server.

Make sure that the imported certificate or key does not have an associated password.

Make sure that the FTP server is an anonymous FTP server (that is, no user name/password
needed).

Syntax

certificate [reset, reset-all]

Example

clear
The clear command clears the terminal screen.

Syntax

clear
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Example

dns
The dns command configures the DNS settings.

Syntax

dns server primary NNN.NNN.NNN.NNN

dns server secondary NNN.NNN.NNN.NNN

dns server <domain.com>

dns clear server all

dns clear server primary

dns clear server secondary

dns clear domain

Example

exit
The exit command closes the current active session and logout the console.

Syntax

exit
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halt
The halt command ends running system and power off the Guest and IoT Manager virtual
machine.

Syntax

halt

help
The help command displays the list of Guest and IoT Manager CLI commands.

Syntax

help

Example

interface
The interface command configures the interface settings.
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Important:

You must enter an httpd restart command after you configure the interface settings.

Syntax

interface <port> <[enable|disable|stats]|[ipaddr <A.B.C.D>/netmask in bits]>

port

is one of eth0, eth1, eth2, or Admin, ServiceA, ServiceB

Example

interface hostname
The Interface CLI has been modified to accept hostname for Admin, ServiceA and ServiceB
interfaces. It takes only the hostname as the input, not the complete FQDN. The FQDN is
derived from the hostname and domain name.

Syntax

Interface <port> hostname <interface hostname>

Example

To assign a hostname to ServiceA interface you can, interface ServiceA hostname
serviceahostname.
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ping
The ping command pings a remote system to test the connection between ExtremeControl
Guest and IoT Manager and another network device. After you ping a device, the switch sends
an Internet Control Message Protocol (ICMP) packet to the target device. If the device receives
the packet, it sends a ping reply. After the switch receives the reply, a message is displayed that
indicates traffic can reach the specified IP address. If the switch does not receive a reply, the
message indicates the address is not responding.

Syntax

ping

ping [ttl <nnn> [ count <nnn> ]] <NNN.NNN.NNN.NNN >:<DNS Name >

Example

reboot
The reboot command restarts the Guest and IoT Manager virtual machine instance.

Syntax

reboot

reinit
The reinit command restores the Guest and IoT Manager virtual machine instance to the factory
default and reset all configurations.

Syntax

reinit
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route
The route command adds static routes to the system.

Syntax

route add|delete <subnet><[prefix|netmask] <gateway_ip> [<interface>]

Example

show certificates
The show certificates command shows information about the certificates and keys in the
certificate/key database. The command displays the name of the certificate, if deleting the
certificate is allowed (you cannot delete the factory / default certificate), and if the item in the
database is key or a certificate. It also displays the certificate and key that the HTTPD server is
currently configured to use.

Syntax

show certificates
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Example

show dns
The show dns command displays the current DNS settings, including the search domain, and the
primary and secondary DNS server settings.

show dns

Example

show interface
The show interface command displays interface information for a specific port or ports. If you
do not provide a port, all of the ports in the operating system are shown. Separate the ports
with white space or commas.

Syntax

show interface [port[,port]...]

port

is one of eth0, eth1, eth2, or Admin, ServiceA, ServiceB.
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Example

show route
The show route command displays the operating system routing table in the same format as the
RedHat Linux operating system at the Unix shell.

Syntax

show route

Example

show timezone
The show tomzone command displays the current timezone of the Guest and IoT Manager
Virtual Machine.

Syntax

show timezone
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Example

sshd
The sshd command lets you enable or disable sshd service.

Syntax

sshd <enable|disable>

Important

In this Release, only sshd enable and sshd disable are supported. The optional interface
and port parameters are supported in a future release.

Example

timezone
The timzone command lets you setup the timezone of the Guest and IoT Manager Virtual
Machine.

Syntax

timezone
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Example

tomcat
The tomcat command lets you start, stop, restart, or view the status of the Tomcat service that
is hosting the Guest and IoT Manager web application.

Syntax

tomcat <start|stop|restart|status>

To restart the Tomcat service, enter tomcat restart.

Example
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user
The user command is used to enable / disable the root and debug users.

Syntax

user root enable

Example
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