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Bay Networks Software License

This Software License shall govern the licensing of all software provided to licensee by Bay Networks (“Software”). 
Bay Networks will provide licensee with Software in machine-readable form and related documentation 
(“Documentation”). The Software provided under this license is proprietary to Bay Networks and to third parties from 
whom Bay Networks has acquired license rights. Bay Networks will not grant any Software license whatsoever, either 
explicitly or implicitly, except by acceptance of an order for either Software or for a Bay Networks product 
(“Equipment”) that is packaged with Software. Each such license is subject to the following restrictions:

1. Upon delivery of the Software, Bay Networks grants to licensee a personal, nontransferable, nonexclusive license 
to use the Software with the Equipment with which or for which it was originally acquired, including use at any 
of licensee’s facilities to which the Equipment may be transferred, for the useful life of the Equipment unless 
earlier terminated by default or cancellation. Use of the Software shall be limited to such Equipment and to such 
facility. Software which is licensed for use on hardware not offered by Bay Networks is not subject to restricted 
use on any Equipment, however, unless otherwise specified on the Documentation, each licensed copy of such 
Software may only be installed on one hardware item at any time.

2. Licensee may use the Software with backup Equipment only if the Equipment with which or for which it was 
acquired is inoperative.

3. Licensee may make a single copy of the Software (but not firmware) for safekeeping (archives) or backup 
purposes.

4. Licensee may modify Software (but not firmware), or combine it with other software, subject to the provision 
that those portions of the resulting software which incorporate Software are subject to the restrictions of this 
license. Licensee shall not make the resulting software available for use by any third party.

5. Neither title nor ownership to Software passes to licensee.

6. Licensee shall not provide, or otherwise make available, any Software, in whole or in part, in any form, to any 
third party. Third parties do not include consultants, subcontractors, or agents of licensee who have licensee’s 
permission to use the Software at licensee’s facility, and who have agreed in writing to use the Software only in 
accordance with the restrictions of this license.

7. Third-party owners from whom Bay Networks has acquired license rights to software that is incorporated into 
Bay Networks products shall have the right to enforce the provisions of this license against licensee.

8. Licensee shall not remove or obscure any copyright, patent, trademark, trade secret, or similar intellectual 
property or restricted rights notice within or affixed to any Software and shall reproduce and affix such notice on 
any backup copy of Software or copies of software resulting from modification or combination performed by 
licensee as permitted by this license.

Note:  This is Bay Networks basic license document. In the absence of a 
software license agreement specifying varying terms, this license — or the 
license included with the particular product — shall govern licensee’s use of 
Bay Networks software.
Bay Networks, Inc. 
4401 Great America Parkway, Santa Clara, CA 95054

8 Federal Street, Billerica, MA 01821



      
Bay Networks Software License (continued)

9. Licensee shall not reverse assemble, reverse compile, or in any way reverse engineer the Software. [Note: For 
licensees in the European Community, the Software Directive dated 14 May 1991 (as may be amended from time 
to time) shall apply for interoperability purposes. Licensee must notify Bay Networks in writing of any such 
intended examination of the Software and Bay Networks may provide review and assistance.]

10. Notwithstanding any foregoing terms to the contrary, if licensee licenses the Bay Networks product “Site 
Manager,” licensee may duplicate and install the Site Manager product as specified in the Documentation. This 
right is granted solely as necessary for use of Site Manager on hardware installed with licensee’s network. 

11. This license will automatically terminate upon improper handling of Software, such as by disclosure, or Bay 
Networks may terminate this license by written notice to licensee if licensee fails to comply with any of the 
material provisions of this license and fails to cure such failure within thirty (30) days after the receipt of written 
notice from Bay Networks. Upon termination of this license, licensee shall discontinue all use of the Software 
and return the Software and Documentation, including all copies, to Bay Networks.

12. Licensee’s obligations under this license shall survive expiration or termination of this license.
Bay Networks, Inc. 
4401 Great America Parkway, Santa Clara, CA 95054

8 Federal Street, Billerica, MA 01821
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 Read Me First

This document supplements the Release Notes for Router Software Version 10.0, 
Release Notes for Site Manager Software Version 4.0, and Known Anomalies: 
Router Software 10.0 and Site Manager 4.0.

It contains information about

• Upgrading for Hardware Compression Support

• Using the ASCII Version of the Bay Networks™ MIB

• Configuration file and image file volume locations

• Router Redundancy

• Socket Binding Message with Network Management Systems

• Using the Online Library with Site Manager

• Corrections for router and BNX™ cables

• Change in Diagnostic PROM revision number

• An incorrect reference to Implementing BayRS Version 10.0 in a Bay 
Networks Router Environment 

• Support for the show process cpu Script

• Router image sizes and Flash card requirements

• Upgrading router software using Quick2Config™
1
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Upgrading for Hardware Compression Support

The information in this section explains how to upgrade a Version 9.0 or 10.0 
configuration that already contains an Octal Sync link module to a Version 10.0 
configuration that contains an Octal Sync link module equipped with a hardware 
compression daughterboard.

To upgrade for hardware compression support you must

1. Hot-swap the hardware and use Site Manager in dynamic mode to ensure that 
the hardware compression driver registers with the router MIB.

2. Modify the Engine Type parameter for the circuit or line.

3. Allocate History Size for the virtual circuits (VCs) that you want to configure 
for hardware compression.

Hot-Swapping and Registering

To hot-swap and register the hardware:

1. Use the Version 10.0 image to boot the router containing the Octal Sync 
link module you plan to replace.

2. Hot-swap the Octal Sync link module with the Octal Sync link module 
equipped with a hardware compression daughterboard.

3. Start Site Manager Version 4.0, and select the router containing the new 
Octal Sync link module.

4. Open the Configuration Manager in dynamic mode.

The hardware compression driver loads on all slots containing an Octal Sync 
link module equipped with a hardware compression daughterboard.

Changing the Engine Type Parameter

Depending on your previous configuration, the Engine Type parameter may 
contain various settings. For example, the configuration file can assign an Engine 
Type value of “Software” or “Inherit from Line” for each line or for individual 
circuits on a line. You must change the Engine Type value to “Hardware” for each 
line or each specific circuit that you want to configure for hardware compression.
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When changing the WCP Engine Type parameter, keep the following in mind:

• We recommend setting only your most active lines to use hardware 
compression.

• You must change the Engine Type parameter value in dynamic mode for it to 
take effect in the router MIB.

• To change the Engine Type parameter value for the entire line, you must 
modify the parameter in the WCP Line Interfaces List window.

• To change the Engine Type parameter value for an individual circuit, you 
must modify the parameter in the WCP Circuit Interfaces List window.

Refer to Configuring Data Compression Services for additional information about 
setting the Engine Type parameter.

History Size Considerations

The existing settings for circuit and line parameters automatically apply when you 
change the Engine Type parameter. This means that any VC already running 
software compression, the router uses the existing history size when that VC 
switches to running hardware compression.

Hardware compression resources are limited. Due to these limitations, we 
recommend that you carefully consider which VCs you want to configure for 
hardware compression.

When upgrading for hardware compression, keep the following in mind:

• We recommend setting only your most active lines to use hardware 
compression.

• Software compression default History Size is 32 KB. Switching to hardware 
compression, and using these defaults, can consume memory quickly.

• The History Size on the local VC and the remote VC should agree. For 
example, if you have a 32 KB History Size configured on a local VC, you 
should also have a 32 KB History Size configured on the remote VC (this also 
applies to 8 KB History Sizes).

• If the local VC and remote VC have different History Size values, the line 
negotiates down to use the smaller of these two values.
3
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• On the 32 context hardware compression daughterboard, you can configure up 
to thirty-one, 8 KB contexts or seven, 32 KB contexts (or various 
combinations of the two).

• On the 128 context hardware compression daughterboard, you can configure 
one hundred twenty-seven (127), 8 KB contexts or thirty-one, 32 KB contexts 
(or various combinations of the two).

Refer to Configuring Data Compression Services for additional information about 
setting the History Size parameter.

Configuration File and Image File Volume Locations

When booting a router that contains the configuration file and image file on 
separate memory volumes, the configuration file must reside on the higher 
numbered volume. For example, if the configuration file resides on volume 3 and 
the image file resides on volume 4, the router does not find the configuration file. 

By changing the volume location of the two files (that is, by placing the image file 
in volume 3 and the configuration file in volume 4), the router boots successfully.

Using the ASCII Version of the Bay Networks MIB

The Bay Networks ASCII MIB file /usr/wf/lib/WFMIB.asn no longer exists. We 
have divided the file into several segments, and placed those segments in the 
appropriate MIB files (such as ip.mib, telnet.mib, tokenrng.mib) in the directory 
/usr/wf/mibs.

You can load the MIB files into local MIB browser tools as necessary. However, 
you must first load the file wfcommon.mib; otherwise, errors result.

Router Redundancy

Router Redundancy is a Bay Networks proprietary protocol. It is a multinode 
protocol, and you use Site Manager differently for Router Redundancy than for 
other Bay Networks products. When you configure Router Redundancy, do not 
select local, remote, or dynamic mode for your group and member configuration 
files. In the main Site Manager Configuration window, select Tools➔Router 
Redundancy➔Group Configuration (see Configuring Interface and Router 
Redundancy, page 5-2).
4



 

Read Me First

     
Other critical details of configuring Router Redundancy include:

• Resources are defined as hosts external to the router. Resources are 
determined by IP address, so all resources must be running TCP/IP.

• A router assumes the primary role according to the following criteria, and 
considers the criteria in the following order. For example, if two routers in a 
Router Redundancy group have the same number of active interfaces, the 
protocol considers the number of reachable resources each router has. But if 
one router has a larger number of active interfaces, that router becomes 
primary without consideration of subsequent criteria.

1. Number of active interfaces

2. Number of reachable resources

3. The router’s priority to become primary, which you configure.

4. The router with the lowest Member ID.

• If your backup router is performing network functions and you want the 
primary router to assume these functions after it switches out of the primary 
role, both the primary and secondary configuration files for both routers must 
be identical. The only parameters that are different between the two routers 
are the primary configuration file name and the Member ID. You must also 
boot the primary router directly into its primary configuration, and the backup 
router into its backup configuration, bypassing the bidding process. Failure to 
do so can result in connection problems related to both routers having the 
same IP address on a LAN.

• When you enter the primary configuration file name in the Router 
Redundancy Member Global Parameters Configuration window, be sure to 
include the Volume ID.

• Ensure that the router contains image files (for example, bn.exe or ace.out) 
before it attempts to change roles. If the router changes roles when no image 
file is available, the router does not boot.
5
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Socket Binding Message with Network Management Systems

The Release Notes for Site Manager Version 4.0 state that network management 
systems such as OpenView or SunNet Manager may prevent Site Manager from 
binding to the SNMP sockets. To solve this problem, you must stop the network 
management system that is binding to the socket (kill the process ID). Instead, if 
you want to receive traps in Site Manager, you must first exit from the network 
management system.

Using the Online Library with Site Manager

Consider the following issues when accessing the Online Library 10.0 CD from 
Site Manager.

On a PC

Site Manager links in this version of the Online Library do not access the 
appropriate information for the Site Manager tool. If you access the Online 
Library from the main window of a Site Manager tool, you will see a screen that 
identifies the Online Library version. Use the hot links to access the appropriate 
information. 

On an HP 9000

To access the Online Library from Site Manager on an HP 9000, you must add the 
following lines to the libcfg.unx file, after the line that reads browse=true.

# Use WELLFLEET as the application name when connecting to krsm.
IPCApps=WELLFLEET

# list of databases to search for brief help
WELLFLEET.bh=getstart,hardware,soft10,soft900,kschelp

# list of databases to search for full help
WELLFLEET.fh=getstart,hardware,soft10,soft900,kschelp

This file appears in the following directory:

<installation directory>/KRSLIBS/ROUTERS

For example, if you install the library in the directory /usr/krs3, the libcfg.unx file 
appears in the directory /usr/krs3/KRSLIBS/ROUTERS.
6
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Corrections for Router and BNX Cables

The Cable Guide for Routers and BNX Platforms includes the following 
corrections:

• Clarification of Terminal Timing Signals

• Correct Pin Assignments for Cable 7932

• Correct Categories for Cables 7932 and 7934

Clarification of Terminal Timing Signals

Throughout the Cable Guide for Routers and BNX Platforms, the pinout tables 
refer to VTT+, VTT-, Terminal Timing+, Terminal Timing-, Terminal Timing A 
and Terminal Timing B signals. To better understand these signals, apply the 
following information:

• V preceding the TT (as in VTT+) indicates a V.35 interface

• + is equivalent to A and - is equivalent to B

• + and - are Bay Networks designators

• A and B are network designators

Incorrect Pin Assignments for Cable 7932

On page 7-33, the pinout table for the 50-pin to V.35 standard (Order No. 7932) 
cable provides incorrect information for the VTT+, Terminal Timing+, and VTT- 
signals. The following table excerpt shows the correct pinouts:

Correct Categories for Cables 7932 and 7934

Cable 7932, a 50-pin to V.35 standard cable, and 7934, a 50-pin to RS-232 
standard cable, correctly appear in Chapter 7 as dial-up services cables. These 
cables should also appear in Chapter 6 as standard synchronous cables.

Bay Networks Termination Remote Termination

Signal Pin # to Pin # Signal

VTT+ 45 U Terminal Timing+

VTT- 20 W Terminal Timing-
7
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Change in 10.0 Diagnostic PROM Revision Number

Bay Networks has changed the revision number for the Version 10.0 Diagnostic 
PROM, arediag.ppc, from Version 1.10 to Version 1.11.

Incorrect Reference to Implementing BayRS Version 10.0 in a Bay 
Networks Router Environment

Upgrading Routers from Version 7–9.xx to Version 10.0 incorrectly references 
Implementing BayRS Version 10.0 in a Bay Networks Router Environment for 
Flash memory requirements. The Version 10.0 upgrade kit does not include this 
document. To obtain information regarding the Flash memory requirements, 
contact the Bay Networks Technical Response Center in your area.

Support for the show process cpu Script

The show process <option> commands display information about the use of 
resources (buffers, cpu, memory, lists, and so forth) on the router. The show 
process cpu option is not supported by the FRE®-1. The FRE-1 does not 
currently contain a timebase with a fine enough resolution to measure CPU use.

Router Image Sizes and Flash Card Requirements

Table 1. shows the Version 10.0 router suite, router software image size, and the 
Flash card required to accommodate the Version 10.0 router software image. 
Refer to this table before you upgrade your existing router software to Router 
Software Version 10.0. 
8
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Upgrading Router Software Using Quick2Config

This section provides general guidelines for upgrading your existing AN, ASN, or 
ANH router to Router Software Version 10.0 using Quick2Config. For detailed 
information about using Quick2Config, refer to Installing and Getting Started 
with the Quick2Config Tool and Configuring Your Router Using the Quick2Config 
Tool.

Perform these steps:

1. Start the Quick2Config application.

a. Locate the Quick2Config program group icon in the Windows 
Program Manager window.

b. Double-click the program group icon.

c. Double-click on the Quick2Config application icon.

2. Select the Connect to a router on your network option (default).

3. Click on OK.

Table 1. Router Image Sizes and Flash Card Requirements 

Router Type Router Suite 
Software Image 
Size 

Flash Card Required

AN® IP Suite 2089 KB 
4 MB and 8 MB 
PCMCIA Flash cards

Remote office suite 2433 KB

Corporate suite 3201 KB

ASN™ System Suite 3209 KB 4 MB and 8 MB

LAN Suite 3561 KB 4 MB and 8 MB

WAN Suite 3313 KB 4 MB and 8 MB

Corporate Suite 4242 KB 8 MB only

BN® System Suite 3025 KB 4 MB

LAN Suite 3377 KB 4 MB

WAN Suite 3129 KB 4 MB

Corporate Suite  4209 KB 8 MB only

ATM Suite 6658 KB 8 MB only

VNR Suite 7674 KB 8 MB only
9
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If the IP address for the router displays in the Connection List, select it. 
Otherwise, enter the router’s IP address in the IP address box.

4. Transfer the existing an.exe or asn.exe image from the router to a PC. 

Select File➔Get from Router➔TFTP from the menu bar.

This ensures that you have a back up of the existing image in case you need it.

Keep the Quick2Config main window active on your desktop.

5. Connect to the router using a serial port and a terminal session (for 
example, terminal emulation using the Terminal application, which is 
located in the accessories program group on your PC).

This establishes a direct console session with the router.

6. Establish a Technician Interface session.

Enter the following command at the Technician Interface prompt:

Manager

This is the default setting. If this setting has changed, enter the appropriate 
login name.

7. From the Technician Interface prompt, enter

dinfo

This command lists the slots that contain a Flash card.

8. Locate the Flash card containing the image file (for example, the asn.exe 
or an.exe image file)

From the Technician Interface prompt, enter

dir 

9. Remove the existing router software image from your router.

From the Technician Interface prompt, enter

delete <vol>:<filename>

where:

<vol> is the slot number of the volume containing the file.

<filename> is the name of the file (an.exe or asn.exe).
10
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10. Compact the contents of the Flash card.

From the Technician Interface, enter

Compact <vol>:

where <vol> is the slot number of the Flash card.

You compact the Flash card to ensure that the Flash card contains enough 
contiguous free space to accommodate the new Version 10.0 software image.

11. Exit the Technician Interface session by selecting File➔Exit.

12. Copy the router software image files (asn.exe or an.exe) from the CD to 
your PC.

13. Return to the Quick2Config main window.

14. Transfer the Version 10.0 an.exe or asn.exe image files from the PC to the 
Flash card.

Select File➔Send to Router➔TFTP from the menu bar.

Be sure to transfer the new Version 10.0 software image to the same slot from 
which you removed the previous one.

15. Boot the router with the Version 10.0 image (an.exe or asn.exe).

Quick2Config boots the router using the specified router software image and 
configuration file.

Refer to Configuring Your Router Using the Quick2Config Tool Router for 
detailed instructions on booting a router using Quick2Config.
11




	Read Me First Router�Software�10.0 Site�Manager�4....
	Read Me First
	Upgrading for Hardware Compression Support
	Hot-Swapping and Registering
	Changing the Engine Type Parameter
	History Size Considerations

	Configuration File and Image File Volume Locations...
	Using the ASCII Version of the Bay Networks MIB
	Router Redundancy
	Socket Binding Message with Network Management Sys...
	Using the Online Library with Site Manager
	On a PC
	On an HP 9000

	Corrections for Router and BNX Cables
	Clarification of Terminal Timing Signals
	Incorrect Pin Assignments for Cable 7932
	Correct Categories for Cables 7932 and 7934

	Change in 10.0 Diagnostic PROM Revision Number
	Incorrect Reference to Implementing BayRS Version ...
	Support for the show process cpu Script
	Router Image Sizes and Flash Card Requirements
	Upgrading Router Software Using Quick2Config



