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Release Notes for Enterprise Switch
Manager Release 6.0.1

These Release Notes support the Nortel Enterprise Switch Manager (ESM)
Release 6.0.1. They provide the same basic information as the Release 6.0
Release Notes, with additional sections for the updated known and resolved
issues for Release 6.0.1. For details, see "Known issues in ESM 6.0.1"
(page 13) and "Resolved issues in ESM 6.0.1" (page 13).

New features of Enterprise Switch Manager 6.0
This section summarizes the new features of the Nortel Enterprise Switch
Manager (ESM), software release 6.0.

Topology Manager
The following sections describe the new Topology Manager features:

Support for IEEE 802.1ab
Topology Manager now supports the discovery of devices using IEEE
802.1ab, Station and Media Access Control Connectivity Protocol (also
known as Link Layer Discovery Protocol [LLDP]). Topology manager now
uses both IEEE 802.1ab and the Bay Networks Auto-Topology Discovery
Protocol to discover devices on a network.

With 802.1ab support, ESM is no longer restricted to the discovery of Nortel
devices: it can discover any 802.1ab-enabled devices on the network,
including third-party switches, routers, and IP Phones. ESM can also
display MED devices in the network.

The following are the Nortel devices which currently support 802.1ab:

• Ethernet Routing Switch 5500 Release 5.0

• Ethernet Routing Switch 8300 Release 3.0

• Ethernet Switch 325/425 Release 3.6

• All Nortel IP Phones
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8 Release Notes for Enterprise Switch Manager Release 6.0.1

Additional Topology Manager features
Topology Manager also provides the following new features:

• Enhanced capability to zoom in on the topology map with increased
granularity using the Zoom In and Zoom Out toolbar buttons.

• Ability to obtain a view of the zoomed-in area in relation to the larger
topology map using the Navigator (View > Navigator).

• Ability to undo and redo node movements in the topology map using the
Previous Transform and Next Transform toolbar buttons.

• Ability to view mismatched links (View > Link Mismatch)

• Ability to update task files without specifying the tm.jar file version (File
> Upgrade)

• Ability to configure additional interface preferences, (Edit > Preferences
> Others), including:

— e-mail server properties

— the color of the Topology Manager background and link mismatches

— default configuration file editor for File/Inventory Manager

— ring tone preference during ESM launch

User Manager
User Manager is a new ESM submanager that allows you to manage user
profiles for access to ESM. You can set read and write permissions and
specify passwords for multiple users. Users, in turn, can create their own
topologies to manage and configure their own personal preferences related
to ESM and its submanagers.

Administrators can view and modify any user settings. Non-administrator
users are only allowed to view and modify their own user information.

To access User Manager, click Tools > User Manager or click on the User
Manager toolbar icon.

Routing Manager
Routing Manager is a new ESM submanager that allows you to configure
routing parameters for devices across a network discovered by ESM. With
Routing Manager, you can create, delete, or modify routes across multiple
devices. Routing Manager supports the following protocols:

• IP

• RIP

• OSPF

• VRRP
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• IPv6

• IPv6 OSPF

To access Routing Manager, click Tools > Routing Manager or click on
the Routing Manager toolbar icon.

VLAN Manager
New features of the VLAN Manager include the following:

• Ability to modify STG membership on Ethernet Switch 460/470

• MSTP and RSTP support for Ethernet Routing Switch 8600 and
Ethernet Routing Switch 5500

• Support for enabling and disabling OSPF on a VLAN

• Support for inserting VRRP routing interfaces on a VLAN

File and Inventory Manager
New features of the File and Inventory Manager include the following:

• Auto Upgrade Wizard support for upgrading devices that are in NNCLI
mode

• Ability to specify the default editor used for viewing and editing
configuration files (Edit > Preferences > Others)

• Ability to compare a saved configuration with the current runtime
configuration (Actions > Compare Runtime Config with Existing
Config)

• Ability to archive a configuration file only if it has changed from the last
saved file (using the Archive Changed Config Only option)

• In Smart Diff, the ability to navigate the Show and Compare report using
forward and backward jump buttons

Trap and Log Manager
New features in the Trap and Log Manager include the following:

• Support for notifications related to traps/events received (Edit > Trap
Preferences)

• Ability to parse traps using the Trap Parser (Tools > Trap Parser and
Tools > Select Trap Parser)

• Support for enabling trap acknowledgement (Edit > Acknowledge
Traps)

Management Information Base (MIB) Browser
MIB Browser provides support for AES.
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Compatibility
This section lists operating systems, hardware, and software that are
compatible with ESM 6.0.1.

Operating system compatibility
Table 1 "ESM 6.0.1 compatibility matrix for operating systems" (page 10)
contains the list of operating systems that are compatible with ESM 6.0.1.

Table 1
ESM 6.0.1 compatibility matrix for operating systems

Operating system Version File type

Windows 98 (Second Edition),
2000 (Professional),
XP, and 2003

esm_6010.exe

Linux Kernel version 2.2 and
above

esm_6010_linux.sh

Sun Solaris/SunOS 2.8, 2.9, 2.10/5.8, 5.9,
5.10

esm_6010_solaris.sh

Supported devices and software versions
Table 2 "Supported platforms and software releases" (page 10) lists the
devices and software versions that ESM 6.0.1 currently supports.

Table 2
Supported platforms and software releases

Platform Software release

Ethernet Routing
Switch 8600,
including the
following new
hardware: 8681XLW
module, 8681XLR
module, 8616GTE
module, 8672ATME
MDA, 8608GBM
module, 8608GTM
module, 8632TXM
module, 8648TXM
module, 8672ATMM
module, 8683POSM
module.

3.0, 3.0.x, 3.1.x, 3.2.0, 3.2.0.2, 3.2.1.0, 3.2.2 (OSM
2.0), 3.3 (OSM 3.0),3.5,3.7(OSM 4.0) 4.0 (ESM 5.0)
4.1 (ESM 6.0, ESM 6.0.1)

Ethernet Routing
Switch 8600 Web
Switching Module

WebOS 9.x (OSM 2.0), 10.0.x (OSM 3.0)
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Platform Software release

Ethernet Routing
Switch 8100

2.0, 2.0.1.1, 3.1.x, 3.2.0, 3.2.0.2, 3.2.1.0, 3.2.2 (OSM
2.0), 3.3 (OSM 3.0)

Ethernet Routing
Switch 8300

2.0 (OSM 4.0) 2.1, 2.2 (ESM 5.0), 2.2.8, 2.3 (ESM 5.1)
3.0 (ESM 6.0, ESM 6.0.1)

Passport 1050/1150/
1200/1250

2.0.5.6, 2.0.5.7, 2.0.7.2, 2.0.7.3, 2.0.7.4, 2.1.0, 2.1.3
(OSM 2.0, OSM 3.0)

Ethernet Routing
Switch 1424T

2.1 (OSM 3.0)

Ethernet Routing
Switch 1612G,
1624G, 1648T

1.0 (OSM 3.0),1.1(OSM 4.0) 1.2 (ESM5.0) 2.1 (ESM
6.0, ESM 6.0.1)

BayStack 350/410/
450

3.0, 3.1, 4.0, 4.1 (OSM 2.0), 4.2,4.3,4.4 (OSM 3.0)

Business Policy
Switch 2000

1.0 (OSM 1.0), 1.0.1, 1.1, 1.2, 2.x (OSM 2.0), 3.0
(OSM 3.0), 3.1 (OSM 4.0)

BayStack 380-24 T 2.0 (OSM 3.0), 3.0 (OSM 4.0)

BayStack 380-24 F 2.1.0 (OSM 3.0), 3.0 (OSM 4.0)

BayStack 420 1.0 (OSM 1.0), 1.0.2, 1.1 (OSM 2.0), 1.1.1, 1.1.2,1.1.3
(OSM 3.0), 3.0 (OSM 4.0), 3.1 (OSM 4.1)

Ethernet Switch 460 2.3, 3.0 (OSM 3.0), 3.1 (OSM 4.0), 3.5 (OSM 4.1),
3.6 (ESM 5.0)

Ethernet Switch
470-24 T

3.0 (OSM 3.0), 3.0 (OSM 4.0), 3.1 (OSM 4.0), 3.5
(OSM 4.1), 3.6 (ESM 5.0)

Ethernet Switch
470-48 T

2.1.0 (only standalone supported); 2.2.0, 2.2.1 (stack
also supported), 3.0, 3.0 (OSM 4.0), 3.1 (OSM 4.0), 3.5
(OSM 4.1), 3.6 (ESM 5.0)

Ethernet Switch
425-24T

2.0, 3.0(OSM 3.0), 3.0(OSM 4.0), 3.1(OSM 4.0), 3.5
(ESM 5.0), 3.6 (ESM 5.1)

Ethernet Switch
425-48T

3.1(OSM4.0), 3.5 (ESM 5.0), 3.6 (ESM 5.1)

Ethernet Routing
Switch 5510, 5520

3.0, 3.0.0.1(OSM 3.0), 3.0(OSM 4.0),4.0(OSM 4.0),
4.1 (OSM 4.1), 4.2 (ESM 5.0), 4.3 (ESM 5.1) 5.0 (ESM
6.0, ESM 6.0.1)

Ethernet Routing
Switch 5530

4.2 (ESM 5.0), 4.3 (ESM 5.1) 5.0 (ESM 6.0, ESM 6.0.1)

Ethernet Routing
Switch 3510

4.0 (ESM 5.0)

OPTera Metro
1200/1400/1450

1.0, 1.2(OSM 3.0), 1.3 (OSM 4.0)
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Platform Software release

Alteon 2208, 2216,
2224, 2424, 2424
SSL, 3408

AOS 21.0

WLAN AP 1.3 (OSM 4.0)

Upgrading and downgrading ESM on your system
This section lists step-by-step instructions on how to upgrade to ESM 6.0.1
and how to downgrade to previous versions of the software.

Upgrading to ESM 6.0.1
To upgrade to ESM, software release 6.0.1 , complete the following steps.

Step Action

1 Install ESM 6.0.1 in a separate directory.

2 Launch ESM 6.0.1.

3 To migrate existing scheduled tasks from previous software versions
of ESM (4.0, 4.1, 5.0, 5.1,6.0), use the Scheduled Tasks Upgrade
Utility feature (File > Upgrade).

Note: To ensure that scheduled tasks have migrated
successfully, open and test ESM 6.0.1.

4 Uninstall previous versions of ESM (4.0, 4.1, 5.0, 5.1, 6.0).

—End—

Downgrading from ESM 6.0.1
To downgrade from ESM 6.0.1 to a previous version, complete the following
steps:

Step Action

1 Uninstall ESM 6.0.1.

2 Create a new directory.

3 Install the previous version (6.0) of ESM.

—End—
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Understanding the issues in ESM 6.0.1
This section describes the known issues and resolved issues in 6.0.1.

Known issues in ESM 6.0.1
The following are the known issues specific to ESM 6.0.1.

Topology Manager

• With Solarix and Linux platforms, if you right-click on a device in
the Topology Manager and click Open Home Page, ESM does not
launch the Web-based management interface for the selected device.
(Q01521246)

• Some devices appear in the Topology Manager without device labels.
When this occurs, click on the topology map, and the device labels
should re-appear. (Q01520097)

File/Inventory Manager

• When archiving configuration files, the Archive Changed Config Only
option functions properly only with Ethernet Routing Switch 8600 and
Ethernet Routing Switch 8300. (Q01500763, Q01503628, Q01510675)

• Auto image upgrade is not supported for Ethernet Routing Switch 1600
Series for upgrades to Release 2.1 software. (Q01500759)

VLAN Manager

• With Ethernet Routing Switch 1600 Release 2.1, if you move port
members from one VLAN (for example, VLAN 1) to another VLAN (for
example VLAN 2), VLAN Manager may not properly display the new
VLAN membership, but instead may continue to show the ports as being
members of the first VLAN (VLAN 1). (Q01499882)

• If you delete an MSTI in VLAN Manager, the MSTI and all associated
VLANs are deleted on the affected switches. However, you must reload
VLAN Manager to display that the MSTI and VLANs are deleted.
(Q01510725)

Security Manager

• Access Policies configured for Telnet, http, rlogin, FTP, SSH, and TFTP
are not being applied to the devices in the security group. (Q01513956)

Resolved issues in ESM 6.0.1
Topology Manager

• Under Edit > Preferences, if you choose Non-highlighted are Invisible,
and then rediscover the topology map, all devices and links no longer
disappear. (Q01473424)
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• Choosing Actions > Finding Unsaved Configurations now finds
unsaved configurations for the Ethernet Routing Switch 1600.
(Q01493506)

File/Inventory Manager

• File/Inventory Manager now supports Ethernet Routing Switch 1600
Release 2.1 devices. (Q01490339).

• When scheduling firmware upgrades for a list of devices, if one device in
the list fails the upgrade, then the process is no longer halted, and the
remaining upgrades are attempted. (Q01495687)

• The Close (x) button in the Reload window is now functioning correctly.
(Q01496530)

• Ethernet Routing Switch 8600 devices are no longer appearing under
Passport 1000 devices. (Q01513961)

VLAN Manager

• The Close (x) button in the Reload window is now functioning correctly.
(Q01496530)

• With Ethernet Routing Switch 8600 and 1600 Series running MSTP,
VLAN Manager no longer returns an error when you try to create a
VLAN with an ID above 64. (Q01510858)

• Under Network > Unassigned, Unassigned ports from the Ethernet
Routing Switch 1600 Series are now displayed properly. Also, under
Network > Tagging > Insert, the 1600 Series devices are now displayed
properly in the Insert/Update TagPort dialog box. (Q01505370)

• Under Network > Nortel STG > Insert the EnableSTP and
STPTrapEnable options now function properly with the Ethernet Routing
Switch 1600 Series. (Q01502640)

Outstanding issues from ESM 6.0
This section describes the known issues and resolved issues in ESM 6.0.

Known issues in ESM 6.0
The following are the known issues specific to ESM 6.0.

User Manager

• In User Manager, under the Preferences tab, the Email
Preference/Reporting Email address field is not currently used and is
reserved for future use. (Q01471569)
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• Users configured in User Manager with read-only permissions may have
access to editable fields in Multicast Manager; specifically under IGMP
> Snoop > 1424T > Snoop Control tab (Q01492384).

• Users configured in User Manager with read-only permissions may have
access to editable fields in Routing Manager; specifically, under IPv4
Networks > RIP > Interfaces > Interfaces Advance tab. (Q01493522)

Topology Manager

• After you display the full screen (by either clicking View > Full Screen
or pressing F12), pressing F12 again may not switch the view back to
the standard screen. To revert to the standard view, you must first click
on the full screen and then press F12. (Q01396406)

• When running ESM on SUSE Linux, the online help files are
inaccessible. (Q01490331)

• If you hide a device in one .topo file (for example, topologyA.topo), and
then open another .topo file (for example topologyB.topo), ESM does
not prompt you to save the first file (topologyA.topo). As a result, the
next time you open topologyA.topo, the device is not hidden from the
topology. To save the hidden device view, you must manually save the
topology file. (Q01490281)

• After you save a .topo file (for example "restrict.topo") for a topology
discovered using the Restrict Discovery option, if you open a different
.topo file and then re-open the original "restrict.topo" and rediscover the
network, this results in an "Invalid Seeds" error. (Q01496535)

Routing Manager

• ARP entries cannot be added for Ethernet Routing Switch 8600 release
4.1. (Q01457972)

• With Ethernet Routing Switch 8600 Release 4.1, under IPv4 Networks
> OSPF > Interfaces, you cannot add a brouter port as an interface
entry. An error is displayed. (Q01458889)

• With Ethernet Routing Switch 8300 Release 3.0, and Ethernet Routing
Switch 5510 Release 5.0, under IPv4 Networks > OSPF > Interfaces,
you cannot change the Type property from Broadcast to Passive. An
error is displayed. (Q01494730)

• With Ethernet Routing Switch 8300 Release 3.0, and Ethernet Routing
Switch 8600 Release 3.7/4.1, you cannot delete VRRP entries displayed
under IPv4 Networks > VRRP > Interfaces. (Q01488332)

VLAN Manager

• When configuring an existing VLAN in VLAN Manager, if you try to
assign an IP address or subnet mask that is not formatted correctly (for
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example, 0.0.0.0.0), the field changes to the default IP address (0.0.0.0)
or subnet mask (255.0.0.0). However, if you click Apply Changes
to accept the new default value, a "java.lang.string" error appears.
(Q01490413)

Outstanding issues from ESM 5.1
The following issues are outstanding from ESM 5.1 and are also applicable
to ESM 6.0.

Outstanding issues from ESM 5.0
The following issues are outstanding from ESM 5.0 and are also applicable
to ESM 6.0.

Topology Manager

• Discovered network may show an extra hub between directly connected
devices (Q01194082).

• When BS380 is used as a seed device, ESM may not display all devices
in the topology (Q01120787).

VLAN Manager

• For Ethernet Switch devices, STG priority must be a multiple of 4096. If
a number other than a multiple of 4096 is entered in the STG priority
field, the switch rounds the value down to the nearest multiple of 4096.
No warning message is provided (Q01140840).

MLT Manager

• LACP configuration is not supported in ESM.(Q01165408).

Resolved issues in ESM 6.0
Topology Manager

• ESM is no longer limited to 700 nodes across different subnets and
seeds (Q01256442).

• When ESM discovers two separate subnets, the topology map no longer
overlaps the display of the two subnets (Q01128155).

• ESM topology files (.topo) from previous releases of ESM can now be
recognized by later ESM versions. For example, .topo files created in
Release 5.1 can now be opened by ESM 6.0 (Q00955340).

VLAN Manager and MLT Manager

• In VLAN Manager, applying changes to source MAC address-based
VLANs no longer produces a null pointer exception error. And in MLT

Enterprise Switch Manager (ESM)
Release Notes for Enterprise Switch Manager

NN47300-400 02.02 Standard
6.0.1 18 December 2006

Copyright © 2005-2006, Nortel Networks Nortel Networks Confidential

.



Related publications 17

Manager, adding multiple SSMLTs to a device no longer produces a null
pointer exception error (Q01223326).

• In VLAN Manger, deleting a port-based VLAN no longer produces a null
pointer exception error (Q01277255).

• In VLAN Manager, creating a protocol-based VLAN no longer produces
an intermittent null pointer exception error (Q01236482).

Security Manager

• Security Manager now allows users to update existing IP addresses.
This affects the configuration of Radius servers and access policies
for security groups (Q01255307).

Upgrade Wizard

• With ESM 6.0, you can now upgrade an ERS 8300 switch using the Auto
Upgrade Wizard when the device is in NNCLI mode. (Q01267923).

File/Inventory Manager

• With ESM 6.0, backing up configuration files on Ethernet Switch
470-24T, Release 3.5, no longer fails intermittently. (Q01247755)

Related publications
For additional information about the features in Enterprise Switch Manager
6.0.1, refer to the following publications:

• Using Enterprise Switch Manager (NN47300-100)

• Installing Enterprise Switch Manager (NN47300-300)

• Configuring and Managing Security: Ethernet Routing Switch 8600
Software Release 4.1 (314724-E)

• Configuring VLANs, Spanning Tree, and Link Aggregation: Ethernet
Routing Switch 8600 Software Release 4.1 (314725-E)

• Configuring Network Management: Ethernet Routing Switch 8600
Software Release 4.1 (314723-E)

• Nortel Ethernet Routing Switch 8300 Configuration — Security using
Device Manager (NN46200-508)

• Nortel Ethernet Routing Switch 8300 Configuration — VLANs,
Spanning Tree, and Static Link Aggregation using the Device Manager
(NN46200-510)

• Nortel Ethernet Routing Switch 8300 Configuration — IP Routing and
Multicast Operations using Device Manager (NN46200-505)

• Nortel Ethernet Routing Switch 5500 Series Configuration — IP Routing
Protocols (NN47200-503)

Enterprise Switch Manager (ESM)
Release Notes for Enterprise Switch Manager

NN47300-400 02.02 Standard
6.0.1 18 December 2006

Copyright © 2005-2006, Nortel Networks Nortel Networks Confidential

.



18 Release Notes for Enterprise Switch Manager Release 6.0.1

• Nortel Ethernet Routing Switch 5500 Series Security — Configuration
(NN47200-501)

• Nortel Ethernet Routing Switch 5500 Series Configuration — VLANs,
Spanning Tree, and MultiLink Trunking (NN47200-502)

• Configuring and Managing Security: Nortel Ethernet Switches 460 and
470 Software Release 3.6 (217104-A)

• Configuring VLANs, Spanning Tree, and MultiLink Trunking Nortel
Ethernet Switches 460 and 470 Software Release 3.6 (217460-A)

• Reference for the BayStack 350/410/450 Management Software
Operations Version 5.0 (210245-C)

• Networking Concepts for the Passport 1000 Series Switch (205588-B)

• Reference for the Passport 1000 Series Management Software
Switching Operations, Release 2.1 (211192-A)

• Reference for the Passport 1000 Series Management Software Routing
Operations, Release 2.1 (211193-A)

How to get help
This section explains how to get help for Nortel products and services.

Getting Help from the Nortel web site
The best way to get technical support for Nortel products is from the Nortel
Technical Support web site:

www.nortel.com/support

This site provides quick access to software, documentation, bulletins, and
tools to address issues with Nortel products. More specifically, the site
enables you to:

• download software, documentation, and product bulletins

• search the Technical Support web site and the Nortel Knowledge Base
for answers to technical issues

• sign up for automatic notification of new software and documentation
for Nortel equipment

• open and manage technical support cases

Getting Help through a Nortel distributor or reseller
If you purchased a service contract for your Nortel product from a distributor
or authorized reseller, contact the technical support staff for that distributor
or reseller.
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Getting Help over the phone from a Nortel Solutions Center
If you do not find the information you require on the Nortel Technical Support
web site, and have a Nortel support contract, you can also get help over the
phone from a Nortel Solutions Center.

In North America, call 1-800-4NORTEL (1-800-466-7865).

Outside North America, go to the following web site to obtain the phone
number for your region:

www.nortel.com/callus

Getting Help from a specialist by using an Express Routing Code
An Express Routing Code (ERC) is available for many Nortel products and
services. When you use an ERC, your call is routed to a technical support
person who specializes in supporting that product or service. To locate the
ERC for your product or service, go to:

www.nortel.com/erc
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