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Chapter 1
Getting started

Network Configuration Manager (NCM ) is a management application that provides 
centralized configuration and system management capabilities for a multi-BCM network. 
NCM  automates data backups and supports efficient distribution of common files. You 
can automate common configuration tasks by scheduling optimized work flows. With 
NCM , bulk distribution of BCM software updates become a simple, efficient, and 
automated process. The NCM  client software is the user interface to the NCM  server. 

NCM  provides remote support capabilities for all of the following BCM devices:

• BCM 5.0 (SRG50 5.0)
• BCM450 1.0
• BCM50 3.0 (SRG50 3.0)
• BCM50 2.0 (SRG50 2.0)
• BCM 4.0
• BCM50 1.0 (SRG50 1.0)
• BCM 3.7
• BCM 3.6

About this guide

This guide is part of the NCM  documentation suite and lists the release notes associated 
with the NCM 5.0.

Note: The complete NCM  documentation suite is located on the 
documentation CD that is included in the NCM  package. 
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Audience
This guide is intended for network engineers who use the Network Configuration Manager 
to configure and maintain networks. This guide is based on the assumption that you have 
the following background:

• understanding of networking terminology, theories, and practices
• familiarity with BCM configuration and management
• knowledge of the Windows operating system and graphical user interfaces (GUI)

Installation recommendations
Review the following installation recommendations when installing Network 
Configuration Manager (NCM) 5.0. For more details and procedures on installing NCM 
5.0, see NCM 5.0 Installation Guide (NN40120-303).

NCM installed application (Windows)
1 Install NCM 5.0 by double clicking on the ncm5.0_full.exe installation file.

NCM installed application (Windows) post installation
1 Start or restart the NCMServer by double clicking on NCMServer executable located 

in the NCM Installed Folder.

2 Start or restart the NCMClient by double clicking on NCMClient executable located 
in the NCM Installed Folder.

NCM standalone client application (Windows)
1 Install the NCM5.0 standalone Client by double clicking on the ncm5.0_full.exe 

installation file.

Note: This guide distinguishes between NCM  users and the NCM  
administrator. NCM  users, the intended audience of this guide, are 
network engineers who use the NCM  software to configure networks. 
The NCM  administrator administers the NCM  server software.
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2 Choose the Client Installation option.

NCM standalone client application (Windows) post installation
1 Start or restart the NCMClient by double clicking on NCMClient executable located 

in the NCM Installed folder.

NCM service (Windows)
1 Install NCM 5.0 as a service by double clicking on the ncm5.0_full.exe installation 

file.

2 Choose the Install server as system service option.

NCM service (Windows) post installation
1 Start or restart the NCMServer by running the startservice.bat file located in <NCM 

Installed Folder>\service.

2 Start or restart the NCMClient by double clicking on the NCMClient executable 
located in the NCM Installed folder.

NCM Upgrade Patch application (Windows)
1 Ensure that the one of the following has already been successfully installed in your 

PC:

• NCM 4.0 Full Installation (ncmfull.exe)

• NCM 4.0 Release Pack 1

• NCM 4.0 Release Pack 2

• NCM 4.0 Release Pack 3

• NCM 4.0 Release Pack 3.1

2 Stop the NCMClient session if it is running by selecting File > Exit.

3 Stop the NCMServer session if it is running by selecting File > Exit.

4 Install the NCM 5.0 Upgrade Patch on top of the current NCM 4.0 RPX installation by 
double clicking on the NCM50UpgradePatch.exe installation file.
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NCM Upgrade Patch application (Windows) post installation
1 Start or restart the NCMServer by double clicking on the NCMServer executable 

located in the NCM Installed folder.

2 Start or restart the NCMClient by double clicking on the NCMClient executable 
located in NCM Installed folder.

NCM standalone Upgrade Patch client application (Windows)
1 Stop the NCMClient session if it is running by selecting File > Exit.

2 Install the NCM5.0 Upgrade Patch Client on top of the current NCM 4.0 client by 
double clicking on the NCM5.0UpgradePatchClient.exe installation file.

NCM standalone Upgrade Patch client application (Windows) 
post installation

1 Start or restart the NCMClient by double clicking on NCMClient executable located 
in NCM Installed folder.

NCM service (Windows)
1 Ensure that the one of the following has already been successfully installed in your 

PC:

• NCM 4.0 Full Installation (ncmfull.exe)

• NCM 4.0 Release Pack 1

• NCM 4.0 Release Pack 2

• NCM 4.0 Release Pack 3

2 NCM 4.0 Release Pack 3.1Stop the NCMClient session if it is running by selecting 
File > Exit.

3 Stop the NCM Service by running the stopservice.bat file located in <NCM Installed 
Folder>\service".

4 Install the NCM 5.0 Upgrade Patch on top of the current NCM 4.0 Release Pack 
installation by double clicking on the NCM50UpgradePatch.exe installation file.
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NCM service (Windows) post installation
1 Start or restart the NCMServer by running the startservice.bat file located in <NCM 

Installed Folder>\service.

2 Start or restart the NCMClient by double clicking on the NCMClient executable 
located in the NCM Installed folder.
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Symbols and text conventions
These symbols highlight critical information for the NCM  system:    

Caution: Alerts you to conditions where you can damage the equipment.

Danger: Alerts you to conditions where you can get an electrical shock.

Warning: Alerts you to conditions where you can cause the system to fail or 
work improperly.

Tip: Alerts you to additional information that can help you perform a task.

Note: A Note alerts you to important information.

!
Security Note: Indicates a point of system security where a default should be 
changed, or where the administrator needs decide the level of security required 
for the system.

Warning: Alerts you to ground yourself with an antistatic grounding strap before 
performing the maintenance procedure.

Warning: Alerts you to remove the NCM  main unit and the expansion unit 
power cords from the AC outlet before performing any maintenance procedure.
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These text conventions are used in this guide to indicate the information described:

Convention Description

bold Courier 
text

Indicates command names and options and text that you need 
to enter.
Example: Use the info command. 
Example: Enter show ip {alerts|routes}.

plain Courier 
text

Indicates command syntax and system output (for example, 
prompts and system messages).
Example: Set Trap Monitor Filters

angle brackets (< >) Indicate that you choose the text to enter based on the 
description inside the brackets. Do not type the brackets when 
entering the command.
Example: <InstallDir>\database\tftp

braces ({}) Indicate required elements in syntax descriptions where there 
is more than one option. You must choose only one of the 
options. Do not type the braces when entering the command.
Example: If the command syntax is 
setAccess {o|g|w}, you must enter
setAccess o, setAccess g, or setAccess w.

brackets ([ ]) Indicate optional elements in syntax descriptions. Do not type 
the brackets when entering the command.
Example: If the command syntax is
echo [-nonewline], you can enter either 
echo or echo -nonewline.

ellipsis points (. . . ) Indicate that you repeat the last element of the command as 
needed.

Example: If the command syntax is
which [<command_name>] . . . , you enter
which and as many command names as needed.
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Related publications

For more information about using NCM , refer to the following publications: 

• Using NCM  5.0 to Manage BCM 5.0 (NN40020-601)
• NCM 5.0 Installation Guide (NN40120-303)
• NCM 5.0 Administration Guide (NN40120-601)

italic text Indicates new terms, book titles, and variables in command 
syntax descriptions. Where a variable is two or more words, 
the words are connected by an underscore.

Example: If the command syntax is
spawn telnet <ip_address> , you enter
spawn telnet 192.48.33.7.

separator ( > ) Shows menu paths.
Example: Choose View > Sort > by Name.

vertical line ( | ) Separates choices for command keywords and arguments. 
Enter only one of the choices. Do not type the vertical line 
when entering the command.
Example: If the command syntax is
array NewArray = [<reference> | 
<referenceList>] 
you enter either
array NewArray = <reference> or 
array NewArray = <referenceList>, 
but not both.

Convention Description
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How to get Help
This section explains how to get help for Nortel products and services.

Getting Help from the Nortel Web site

The best way to get technical support for Nortel products is from the Nortel Technical 
Support Web site:

http://www.nortel.com/support

This site provides quick access to software, documentation, bulletins, and tools to address 
issues with Nortel products. More specifically, the site enables you to:
• download software, documentation, and product bulletins
• search the Technical Support Web site and the Nortel Knowledge Base for answers to 

technical issues
• sign up for automatic notification of new software and documentation for Nortel 

equipment
• open and manage technical support cases

Getting Help over the phone from a Nortel Solutions Center

If you don’t find the information you require on the Nortel Technical Support Web site, 
and have a Nortel support contract, you can also get help over the phone from a Nortel 
Solutions Center.

In North America, call 1-800-4NORTEL (1-800-466-7835).

Outside North America, go to the following Web site to obtain the phone number for your 
region:

http://www.nortel.com/callus

Getting Help from a specialist by using an Express Routing Code

To access some Nortel Technical Solutions Centers, you can use an Express Routing Code 
(ERC) to quickly route your call to a specialist in your Nortel product or service. To locate 
the ERC for your product or service, go to:

http://www.nortel.com/erc

http://support.avaya.com
http://www.avaya.com/gcm/master-usa/en-us/tasks/connect/contacts/sales/salescontact.htm
http://support.avaya.com/supportfaqs
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Getting Help through a Nortel distributor or reseller 

If you purchased a service contract for your Nortel product from a distributor or 
authorized reseller, contact the technical support staff for that distributor or reseller.
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Chapter 2
Introduction

This guide lists the release notes associated with the NCM 5.0.

This chapter provides the following information:

• “Known anomalies in NCM 5.0 for all BCM devices” on page 15

• “Known anomalies in NCM 5.0 for BCM 4.0 devices” on page 16

• “Known anomalies in NCM 5.0 for BCM50 1.0 devices” on page 17

• “Operational notes” on page 17

Known anomalies in NCM 5.0 for all BCM devices

NCM Keycode not found issue
In some circumstances, the NCM server reports the following error, NCM Keycode not 
found, when trying to perform an import operation from the network, although the NCM 
keycode actually is installed on the BCM. If you encounter this situation, contact Nortel 
Support for instructions on how to resolve this issue. 

Reboot after applying keycodes
When applying keycodes through NCM that require a reboot to take effect, NCM does not 
prompt for a reboot, in some cases. After applying a keycode in NCM, you must reboot 
your system for the changes to take effect.

Note: The complete NCM  documentation set is located on the 
documentation CD that is included in the NCM 5.0 package. 
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Unable to manually update run time when scheduling wizards
When scheduling a Wizard you cannot type the time to run the Wizard directly in the 
Date/Time field on the Schedule tab.

Click on the arrow beside the date and time to show a calendar. Select the date to run the 
Wizard on from the calendar and use the scroll arrows beside the hour, minute, second, 
and AM/PM fields to select the time for the Wizard to run. (CR Q01287591)

Known anomalies in NCM 5.0 for BCM 4.0 devices

BCM service affected during NCM import of telephony data
Running an NCM  import to retrieve configuration information from a BCM system can 
cause degradation of BCM services. Some examples of what the BCM end customer can 
experience are slow response times when the end user invokes a feature, delays in 
receiving a dial tone when a telephone goes off-hook, delays in processing end user key 
presses, and telephone time displays become out of sync with the BCM.

Use the NCM  scheduler to set up imports to run during off-peak hours. (CR Q01289358)

Copy tree functionality available only for BCM 3.x devices
NCM 3.6 RP3 can copy trees and subtrees from one imported device configuration to 
another imported device configuration listed in the NCM configuration tree for imported 
BCM 3.x devices only. 

Blank lines received when retrieving list of common files
When archiving common files from the network, NCM can return blank lines in the 
Device Files box that appears listing the files available from the network device. This can 
cause you to believe that there are no files available from the Network device.

NCM returns a message if there are no common files available on the network device. If 
the Device Files box appears empty after clicking Choose Files, in the Archive Files from 
Network pane, and no message appears, use the scroll bar on the side of the Device Files 
box to scroll to the next page to see if there are any files available. (Q01310398) 
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Known anomalies in NCM 5.0 for BCM50 1.0 devices

Declined integrated router connections
NCM  cannot import or export any router configuration data from a BCM50 device if 
there is another active management connection running, for example the Web GUI router 
interface. The BCM50 integrated router allows only one management connection at a 
time; therefore, NCM  connections will be refused if there is another active management 
connection. (CR Q01096896) 

Service Access Points table updates must be done through
BCM50 SNMP Wizard

Modifications made in the Service Access Points table located in Telephony > 
Configuration > Administrator Access > SNMP > Service Access Points tab are not 
exported when exporting device configurations and will cause an error to occur on export. 
Use the BCM50 SNMP Wizard to add or delete Service Access Points settings. 
(CR Q01128851) 

Operational notes
This section provides operational notes for the Network Configuration Manager 4.0 
release.

General issues and recommendations
• NCM 5.0 supports multiple login sessions for a particular user ID. You can use this 

feature so that first-level support engineers can log in with one user ID, second-level 
support engineers can log in with another user ID, and so on. Note, however, that the 
audit log records information is based on user ID. Therefore, in this scenario, you 
determine only the level of the engineer who performed a particular task; you can not 
determine the identity of the particular engineer who performed a particular task. 

• If you change the settings on the system clock, you must restart the NCM 5.0 server 
and client software; otherwise, NCM 5.0 continues to operate based on the old system 
clock settings. 
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