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Preface

The NCM application offers a solution for one of the most problematic areas of 
networking—configuration management. By taking advantage of the unique capabilities 
of the Java* programming language, NCM provides comprehensive, 
platform-independent management capabilities that revolutionize the approach to 
configuring networks. 

This guide is part of the NCM documentation set and describes how to install the NCM 
server and the NCM standalone client software. 

Before you begin
This guide is intended for the network administrator who is responsible for administering 
the NCM server (the NCM administrator). 

Although you do not need prior knowledge of the NCM software, you should have: 

• Working knowledge of the Windows∗  operating system or Solaris* windowing 
systems and graphical user interfaces (GUIs) 

• Familiarity with basic networking terminology, theories, and practices 

Symbols used in this guide
This guide uses these symbols to draw your attention to important information:

Note: The complete NCM documentation set is located on the 
documentation CD that is included in the NCM package. 

Note: Note/Tip symbol
Alerts you to important information.
Network Configuration Manager 3.0 Release Notes
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Text conventions
This guide uses the following text conventions:

angle brackets (< >) Indicate that you choose the text to enter based on the 
description inside the brackets. Do not type the 
brackets when entering the command.
Example: If the command syntax is
ping <ip_address>, you enter
ping 192.32.10.12

bold Courier text Indicates command names and options and text that 
you need to enter.
Example: Use the dinfo command. 
Example: Enter show ip {alerts|routes}.

brackets ([ ]) Indicate optional elements in syntax descriptions. Do 
not type the brackets when entering the command.
Example: If the command syntax is
show ip interfaces [-alerts], you can enter 
either show ip interfaces or 
show ip interfaces -alerts.

italic text Indicates new terms, book titles, and variables in 
command syntax descriptions. Where a variable is two 
or more words, the words are connected by an 
underscore.
Example: If the command syntax is
show at <valid_route>, valid_route is one 
variable and you substitute one value for it.

plain Courier
text

Indicates command syntax and system output, for 
example, prompts and system messages.
Example: Set Trap Monitor Filters

separator ( > ) Shows menu paths. 
Example: Protocols > IP identifies the IP option on the 
Protocols menu. 
P0607178
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Installation directory
This guide uses the variable <InstallDir> to indicate the directory that you specify as the 
destination directory for the NCM server software. 

Similarly, this guide uses the variable <ClientInstallDir> to indicate the directory that you 
specify as the destination directory for the NCM standalone client software. 

Acronyms
This guide uses the following acronyms:

Related publications
For more information about using NCM, refer to the following publications: 

• Network Configuration Manager 3.0 Installation Guide
• Network Configuration Manager 3.0 Administration Guide
• Network Configuration Manager 3.0 Client Software User Guide
• Business Communications Manager 3.5 Programming Operations Guide

How to get help
• USA and Canada

BCM Business Communications Manager

NCM Network Configuration Manager

SNMP Simple Network Management Protocol

TFTP Trivial File Transfer Protocol
Network Configuration Manager 3.0 Release Notes
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Authorized Distributors - ITAS Technical Support 

Telephone: 1-800-4NORTEL (1-800-466-7835)

If you already have a PIN Code, you can enter Express Routing Code (ERC) 196# 

If you do not yet have a PIN Code, or for general questions and first line support, enter 
ERC 338#

Website: http://www.nortelnetworks.com/support 
email: naitas@nortelnetworks.com

Presales Support (CSAN) 

Telephone: 1-800-4NORTEL  (1-800-466-7835)

Use Express Routing Code (ERC) 1063#

• EMEA (Europe, Middle East, Africa)
Technical Support - CTAS

Telephone: 00800 800 89009

Fax: 44-191-555-7980

email: emeahelp@nortelnetworks.com

• CALA (Caribbean & Latin America)
Technical Support - CTAS

Telephone: 1-954-858-7777

email: csrmgmt@nortelnetworks.com

• APAC (Asia Pacific)
Technical Support - CTAS

Telephone: +61 388664627

Fax: +61 388664644

email: asia_support@nortelnetworks.com
P0607178
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Introduction

These release notes, which describe the latest enhancements and changes to the 
Network Configuration Manager* (NCM) software, supplement the Network 
Configuration Manager documentation set. Read these notes before you install or 
use the software.

Network Configuration Manager works with Business Communications Manager 
Release 3.5, 3.0 and Business Communications Manager 2.5 Feature Pack 1.

New Features

The following are new features that have been included in NCM 3.0:

Import/Export of new OA&M elements in BCM 3.5

NCM 3.0 will import and export new configuration data elements in BCM 3.5. 
Some of these features are:

• System Speed Dial list data

• CallPilot holiday scheduling

• CallPilot Park & Page custom digit prompts

• Universal T1 data

• SIP Trunking data

• SNMP Trap-Dial out

• Secure dial-back

• IP Music files (Playlist + Audio)

Patch distribution

You can now distribute patches to multiple BCM systems using the patch process. 
This includes the capability to schedule deployment of patches, initiation of the 
patch process, and confirmation by the NCM audit logs of the successful 
completion of the patch operation.
Network Configuration Manager 3.0 Release Notes
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Granular backup and restore

This feature gives you the ability to pick and choose which components you want 
to archive and restore rather than selecting an entire device tree. You can also 
select whether to include or exclude voicemail messages in the backup.

FTP workflows

FTP allows the transfer of files larger than 32 Mb. NCM 3.0 provides workflows 
for transferring files from/to an external server to/from NCM using standard FTP 
protocol.

Configuration report enhancements

Configuration reports that were provided in NCM 2.0 are enhanced to support 
new information that is imported into the NCM database in NCM 3.0. NCM 3.0 
also provides a way to export the configuration data to other 
document-interchange formats, enabling you to view and reformat the report 
using other applications.

Migration from NCM 2.0 to NCM 3.0

NCM 3.0 provides an upgrade path for NCM 2.0 customers. You will be able to 
upgrade to 3.0 without losing any stored configurations or archives.

In order for migration to be completed successfully, make sure that NCM 2.0 has 
the log to file option enabled. Under Server Setup > Log Setup, select the Log tab 
and check the log to file box. If this option is not checked, the migration will fail.
P0607178
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Known Problems in NCM 3.0

Timeout errors when importing device configurations 

When you import a BCM configuration for the first time, increase the timeout to 
at least 600 (the default is 60) in the Import from Network dialog box. Increasing 
the timeout will prevent the driver from timing out should the inventory process 
take longer than the original timeout value.

When you import and export configurations to and from devices on the network, 
NCM waits for a response from the device. If the timeout period (which is 
device-dependent) expires and NCM has not received a response from the device, 
NCM displays a timeout error message. 

To increase or decrease the timeout period for a device, open its Properties dialog 
box and click on the Import or Export tab. Change the timeout period and click 
OK.

In some situations (for example, over a busy WAN connection), the default 
timeout period might not be a long enough time to receive a response from a 
device. In these situations, you can increase the timeout variable. You can set the 
timeout variable for devices on the Import tab and the Export tab for each device. 

IVR Service start

When using IVR, the IVR service is not started automatically after a restore 
operation. IVR service can be started from Unified Manager > Diagnostics > 
Service Manager. Search for Nortel Networks Startup Service, change the Startup 
to Automatic, the Status to Started, and the IVR will be functional. (CR 
Q00504754).

Progress bar

If you choose more than one configuration in the Configuration Data sub-tree and 
import or export them to the network, the progress bar behaves erratically and is 
inconsistent with the actual progress of the operation. (CR Q00681693)
Network Configuration Manager 3.0 Release Notes
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Migration file cleanup

During migration, the installer rewrites the old server’s .lax file, adding several 
new arguments. These arguments are not removed after migration is complete, 
which makes the old server unable to start. In order to continue to run the old 
server, you should make a copy of the .lax file for back up purposes. (CR 
Q00709701)

To restart your NCM 2.0 server after migrating it to NCM 3.0, open the 
NCMServer.lax file in a text editor. Find the line that starts with 
“lax.command.line.args=” and remove the two options named “-dumpXML” and 
“-port 9193” from that line. Save the lax file. You can then successfully start your 
NCM 2.0 server.

NCM potentially unreachable with dual NIC

If the NCM server machine has multiple IP addresses, it is advisable to include the 
command line argument -host <ipaddress of NCM server> and let all NCM clients 
know the IP address. (CR Q00743108)

Archive label not migrated from Oracle database

When you migrate archived entries, the label and comments are not migrated with 
the entries. Instead, a timestamp appears in place of the label and any comments 
are gone. (CR Q00715339)

Patch distribution

You will also need to specify a longer timeout interval when running a Send 
Image to Network operation. 

Drop down menu not available

In NCM 3.0 under IP Firewall Filters > LAN/WAN/UTWAN > Destination Port 
Range, a drop down menu is not available as it is in Unified Manager. You should 
type in the label of the port, port number, or port range. (CR Q00671770)
P0607178
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Naming conventions do not match Unified Manager

Naming conventions for dial-up items such as Modem and ISDN interfaces in the 
Resources node do not match that of Unified Manager. In NCM, the convention is 
Interface ID <interface or user name>.

Password change wizard

When the export checkbox in the Password Change wizard is selected, the 
password is changed on the physical device. However, the device representation in 
NCM still contains the old password within its connection parameters. (CR 
Q00531581)

Log rotators after migration

Log rotator settings are not migrated from NCM 2.0 to NCM 3.0. Instead, default 
log rotator settings are created when the NCM 3.0 database is first created.

Server messages incorrectly formatted in File > Send

When selecting multiple Common Files to send to the network, the operation’s 
server log message combines all the file names into one string and the message is 
formatted as though the multiple files are a single file. (CR Q00741834)

Wrong filename shown after using Browse function

When sending Common Files to the network, you have the option of using 
Browse to select Configuration Data devices. However, when you use the Browse 
function, the progress label displays “sending file to null”. (CR Q00732291)

Wrong filename shown in FTP Send

When performing a File > Send to FTP operation, you can change the filename by 
double-clicking it. However, the progress label does not register the change and 
instead reports “sending <old filename>”. (CR Q00732289)
Network Configuration Manager 3.0 Release Notes
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Known Problems in 2.0

Starting syslog with the webserver

When you start the server, if the webserver cannot start on it's port, it fails and 
does not set a “docroot” value for the path to the install directory.  The syslog 
server needs this value to locate the appropriate syslog.txt file. Once the 
webserver starts successfully at least once, the docroot will be defined and the 
syslog server will be able to start from then on, with or without the webserver.

Increasing the limit of concurrent user sessions

To avoid overloading, NCM has a default limit of 10 concurrent server operations 
at any time with a maximum of 5 operations per client request. If you wish to 
change the number, you may do so in the datastore.ini file in the installation 
directory. The semaphores can be modified by changing the “maxConnections=” 
line in the datastore.ini file on the server. Semaphore count can be up to 40 for a 
high powered server machine.

Truncated menus

If you rely on the right-click method for running operations, you may not be able 
to view all menu options. The calculation for screen placement of the popup menu 
only uses the size of the main menu, without incorporating the size of any 
cascading submenus. It is possible, in some cases, to have a submenu truncated. In 
these cases, use the menu bar to perform the operations, or move the NCM client 
window to allow for the submenus to fully display.

Audit log inconsistencies

Tools > Audit Log > on selected item will not display an audit log for these object 
types:

• device > subnodes

• Schedule folder > Log rotator objects

Audit log entries are not recorded for these operations:
P0607178
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• Operations on a device as a result of running a wizard

• Archive of common files

• File > Send to Network (CR Q00741839)

• File > Send to FTP contains an incomplete audit log entry (CR Q00739318)

Telnet session history list

The Telnet session panel history list remains empty regardless of how many 
device sessions you open.

Send to TFTP using a remote server

When you Send to TFTP using a remote server across a WAN, a timeout message 
may appear even though the operation was successful. To prevent the timeout 
message from displaying, make sure that all Send to TFTP operations use a 
remote server on the LAN. You can also place the files you want to send on your 
TFTP server and then perform an Archive From TFTP from the remote server, 
rather than sending from a local server.

Using the Netscape browser on Solaris

NCM may have a problem automatically starting Netscape when using Web Links 
or the Report Wizard. If this occurs, start a browser session separately, and NCM 
will display links using the existing browser window.

Log rotators

The log rotators can sometimes stop archiving log files after changes are made to 
the rotation schedule. If this occurs, uncheck and re-check the “Rotate Log Files 
by Date” checkbox under Server Setup > Log Setup > <log_file>. This will reset 
the log rotator and solve the problem. 

Operation progress bar

During several operations such as Import from Network and Send to Network, the 
progress bar will remain at a percentage for a long time. This is normal and may 
last for several minutes.
Network Configuration Manager 3.0 Release Notes
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Import data

Telephony changes to lines and sets are not reflected in import data until the next 
day. Changes made to the Business Communications Manager are not reflected in 
the import data immediately. You must schedule an import to take place after 
3:00 a.m. (the time that the line and set inventory takes place) in order to update 
NCM.

Viewing syslog messages

When you change the IP address for remote logging or change from remote to 
local logging, you are unable to view syslog messages. You must disable and then 
reenable the syslog server to properly view syslog messages.

TFTP server on Solaris platforms

The NCM server does not recognize alternate IP addresses assigned to interfaces 
on machines running Solaris 8. As a result, NCM does not populate the list for the 
internal TFTP server. 

Operational notes

This section provides operational notes for the Network Configuration Manager 
release.

General issues and recommendations

• NCM supports multiple login sessions for a particular user ID. You can use 
this feature so that first-level support engineers can log in with one user ID, 
second-level support engineers can log in with another user ID, and so on. 
Note, however, that the audit log records information based on user ID. 
Therefore, in this scenario, you could determine only the level of the engineer 
who performed a particular task; you would not be able to determine the 
identity of the particular engineer who performed a particular task. 

• If you change the settings on the system clock, you must restart the NCM 
server and client software; otherwise, NCM continues to operate based on the 
old clock settings. 
P0607178



17
How to get help

• USA and Canada
Authorized Distributors - ITAS Technical Support 

Telephone: 1-800-4NORTEL (1-800-466-7835)

If you already have a PIN Code, you can enter Express Routing Code (ERC) 196# 

If you do not yet have a PIN Code, or for general questions and first line support, enter 
ERC 338#

Website: http://www.nortelnetworks.com/support 
email: naitas@nortelnetworks.com

Presales Support (CSAN) 

Telephone: 1-800-4NORTEL  (1-800-466-7835)

Use Express Routing Code (ERC) 1063#

• EMEA (Europe, Middle East, Africa)
Technical Support - CTAS

Telephone: 00800 800 89009

Fax: 44-191-555-7980

email: emeahelp@nortelnetworks.com

• CALA (Caribbean & Latin America)
Technical Support - CTAS

Telephone: 1-954-858-7777

email: csrmgmt@nortelnetworks.com

• APAC (Asia Pacific)
Technical Support - CTAS

Telephone: +61 388664627

Fax: +61 388664644

email: asia_support@nortelnetworks.com
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