Configure Multicast IP Fabric with L3 VNI

Draft comment: pputtasiddaiah
New for SLX OS 20.2.1. Please review the steps.
Multicast IP Fabric supports L3 VNI configuration.

  • Each L3 VNI is treated as a separate VNI that needs to be mapped to MDT.
  • For deployments where user VNIs are not configured on all leaf nodes, L3 VNI serves as an Intermediate Hop to forward the traffic.
  • There is no change in the Unicast traffic forwarding behavior as Unicast traffic does not use MDT.
  • Each L3 VNI must be configured and mapped to MDT Group. It can have a unique MDT or a shared VNI MDT.
To support IP Multicast routing using L3 VNI, each L3 VNI must be configured as PIM interface. This enables the PIM protocol to form Multicast forwarding tree over L3 VNIs.
  1. Configure the following on the device:
    • VRF
    • Route target for EVPN
    • Interface for L3 VNI
    Note

    Note

    L3 VNI interface must be configured with IP address.

    On LVTEP, the VLAN associated with L3VNI must also be added as MCT VLAN member.

    vrf mc
    rd 102:3
    evpn irb ve 300
    address-family ipv4 unicast
    route-target export 102:102 evpn
    route-target import 102:102 evpn
    !
    !
  2. For L3 multicast routing, enable Router PIM for the selected VRF domain on each leaf node, as required.
    router pim vrf mc
    !
  3. Select a leaf node to act as RP per VRF Domain and create a loopback interface on the node.
  4. Enable PIM-SM for the loopback interface.
    interface Loopback 2
    vrf forwarding mc
    ip address 30.30.30.30/32
    ip pim-sparse
    no shutdown
    !
  5. Configure IP address of the selected RP interface as RP-address on each leaf node where PIM is running for the selected VRF.
    router pim vrf mc
    rp-address 30.30.30.30
    !
  6. Enable the following on each leaf node as required.
    • PIM on L3 VNI interface.
    • For L3 Multicast Routing, PIM on all selected VE interfaces associated with EVPN VLANs/BDs.
    interface Ve 300
    vrf forwarding mc
    ip address 3.4.5.3/24
    ip pim-sparse
    no shutdown
    !

Example

vrf mc
rd 102:3
evpn irb ve 300
address-family ipv4 unicast
route-target export 102:102 evpn
route-target import 102:102 evpn
!
address-family ipv6 unicast
route-target export 102:102 evpn
route-target import 102:102 evpn
!
!
vlan 300
router-interface Ve 300
!
interface Ve 300
vrf forwarding mc
ip address 3.4.5.3/24
ip pim-sparse
no shutdown
!
overlay-gateway 10
type layer2-extension
optimized-replication
underlay-mdt-group 239.0.0.100 default ! default MDT for all VNIs
underlay-mdt-group 239.0.0.1 vlan add 300