Configuration Example CLI Input

This tunnel configuration example provides the CLI input for both Router 1 and Router 2 as displayed in Tunnel Configuration Example:

Router 1

  1. Configures loopback interface 1 with an IP address of 88.88.88.1, to be used as the source for the tunnel from the perspective of Router 1
  2. Creates tunnel 1 (tun.0.1) configured for:
    • GRE mode
    • Source address 88.88.88.1
    • Destination address 99.99.99.1
    • Tunnel interface IPv6 address 2111::10/64
    • A default tunnel probe to monitor the tunnel destination address 99.99.99.1
    • A GRE keyword of 123456
  3. Establishes reachability with the tunnel destination address using a static route with the tunnel destination address 99.99.99.1 as the route destination over VLAN 50
  4. Configures an IPv6 static route to prefix 2333::0/64 over tunnel 1
    System(su)->configure
    System(su-config)->interface loopback 1
    System(su-config-intf-loop.0.1)->ip address 88.88.88.1 255.255.255.255 primary
    System(su-config-intf-loop.0.1)->no shutdown
    System(su-config-intf-loop.0.1)->exit
    System(su-config)->interface tunnel 1
    System(su-config-tun.0.1)->tunnel mode gre
    System(su-config-tun.0.1)->tunnel source 88.88.88.1
    System(su-config-tun.0.1)->tunnel destination 99.99.99.1
    System(su-config-tun.0.1)->ipv6 address 2111::10/64
    System(su-config-tun.0.1)->tunnel probe 99.99.99.1 probe-name default
    System(su-config-tun.0.1)->tunnel keyword 123456
    System(su-config-tun.0.1)->no shutdown
    System(su-config-tun.0.1)->exit
    System(su-config)->ip route 99.99.99.1/32 vlan 50
    System(su-config)->ipv6 route 2333::0/64 interface tun.0.1

Router 2

  1. Configures loopback interface 1 with an IP address of 99.99.99.1, to be used as the source for the tunnel from the perspective of Router 2
  2. Creates tunnel 1 (tun.0.1) configured for:
    • GRE mode
    • Source Address 99.99.99.1
    • Destination Address 88.88.88.1
    • Tunnel interface IP address 2.2.2.2
    • A default tunnel probe to monitor the tunnel destination address 88.88.88.1
    • A GRE keyword of 123456
  3. Establishes reachability with the tunnel destination address using a static route with the tunnel destination address 88.88.88.1 as the route destination over VLAN 50
  4. Configures an IPv6 static route to prefix 2111::0/64 over tunnel 1
    System(su)->configure
    System(su-config)->interface loopback 1
    System(su-config-intf-loop.0.1)->ip address 99.99.99.1 255.255.255.255 primary
    System(su-config-intf-loop.0.1)->no shutdown
    System(su-config-intf-loop.0.1)->exit
    System(su-config)->interface tunnel 1
    System(su-config-tun.0.1)->tunnel mode gre
    System(su-config-tun.0.1)->tunnel source 99.99.99.1
    System(su-config-tun.0.1)->tunnel destination 88.88.88.1
    System(su-config-tun.0.1)->ipv6 address 2111::10
    System(su-config-tun.0.1)->tunnel probe 88.88.88.1 probe-name default
    System(su-config-tun.0.1)->tunnel keyword 123456
    System(su-config-tun.0.1)->no shutdown
    System(su-config-tun.0.1)->exit
    System(su-config)->ip route 88.88.88.1/32 vlan 50
    System(su-config)->ipv6 route 2111::0/64 interface tun.0.1