Configuring VE route-only mode on a physical port

Do the following to configure VE route-only mode on a physical port.

  1. Enter global configuration mode.
    device# configure terminal
  2. Create a VLAN.
    device(config)# vlan 100
  3. Specify an Ethernet interface.
    device(config)# interface ethernet 0/2
  4. Enter the switchport command to configure Layer 2 characteristics.
    device(conf-if-eth-0/2)# switchport
  5. Specify trunk mode.
    device(conf-if-eth-0/2)# switchport mode trunk
  6. Tag the port to a VLAN.
    device(conf-if-eth-0/2)# switchport mode trunk allowed vlan add 100
  7. Enter the route-only command to enable Layer 3 routing exclusively on the port.
    device(conf-if-eth-0/2)# route-only
    Use the no route-only command to revert to default Layer 2 and Layer 3 behavior.
  8. Enable the interface and exit to global configuration mode.
    device(conf-if-eth-0/2)# no shutdown
    device(conf-if-eth-0/2)# exit
    
  9. Verify the Ethernet configuration.
    device(conf-if-eth-0/2)# do show running-cocnfig interface ethernet 0/2
    switchport
    switchport mode trunk
    switchport trunk allowed vlan add 100
    route only
    no shutdown
    
  10. Verify the port statistics for switching packets dropped.
    device(conf-if-eth-0/2)# do show interface ethernet 0/2        
                   Ethernet 0/2 is up, line protocol is up (connected)
                   Hardware is Ethernet, address is 768e.f80a.033c
                   Current address is 768e.f80a.033c
               ….
              Rate info:
                   Input 0.001008 Mbits/sec, 0 packets/sec, 0.00% of line-rate
                   Output 0.000252 Mbits/sec, 0 packets/sec, 0.00% of line-rate
                   Route-Only Packets Dropped: 17
                   Time since last interface status change: 21:35:41
    
  11. Enter virtual Ethernet (VE) configuration mode and specify the VLAN.
    device(config)# interface ve 100
  12. Assign an IP address and mask and enable the interface.
    device(config-Ve-100)# ip address 10.2.2.2/24
    device(config-Ve-100)# no shutdown
  13. Confirm the VE configuration.
    device(config-Ve-100)# do show running-config interface ve 100
    interface Ve 100
     ip proxy-arp
     ip address 10.2.2.2/24
     no shutdown