Configuring VXLAN LVTEP support

This task configures VXLAN LVTEP support, which includes loopback, VLAN, Ethernet, and bridge domain (BD), overlay gateway, and MCT cluster configurations.

  1. Configure multiple loopback interfaces to support BGP neighbor address-family and the LVTEP IP address.
    1. Enter global configuration mode.
      device# configure terminal
      
    2. In global configuration mode, specify a loopback port number.
      device(config)# interface loopback 1
      
    3. Configure a loopback interface with OSPF area 0 and an IP address, and enable the interface to support BGP neighbor address-family.
      device(config-Loopback-1)# ip ospf area 0 
      device(config-Loopback-1)# ip address 6.6.100.6/32
      device(config-Loopback-1)# no shutdown
      
    4. Configure a second loopback interface to support the LVTEP IP address.
      interface Loopback 2   
       ip ospf area 0
       ip address 6.7.100.67/32
       no shutdown
      
      The same address is used for both nodes in the cluster.
  2. In global configuration mode, create two VLANs to support a pair of logical interfaces (LIFs) and BDs.
    device(config)# vlan 11-12
    
  3. Configure the LIFs and BDs.
    1. Specify an Ethernet interface.
      device(config)# interface ethernet 0/5
    2. Configure the parent interface as switchport.
      device(conf-if-eth-0/5)# switchport
    3. Specify trunk mode.
      device(conf-if-eth-0/5)# switchport mode trunk
    4. Enable the interface.
      device(conf-if-eth-0/5)# no shutdown
    5. Specify a service instance and enter LIF configuration mode.
      device(conf-if-eth-0/5)# logical-interface ethernet 0/5.1
    6. Specify an interface and create a dual-tagged (inner VLAN) VLAN.
      device(conf-if-eth-lif-0/5.1)# vlan 10 inner-vlan 1
      The VLAN in the LIF configuration is for VLAN tag classification. This example shows a dual-tagged LIF being configured. The expected packet that enters through this port must be dual-tagged, without VLAN 10 and the inner VLAN 1, in order to be classified as a packet received for this LIF.
    7. (Optional) By default, the administrative state of the LIF is "no shutdown." To remove the port from participating in any data traffic without having to shut down the physical interface, enter the no form of the shutdown (LIF) command.
      device(conf-if-eth-lif-0/5.1)# no shutdown
    8. Repeat Step 3e through Step 3g for the second logical interface, and specify a second inner VLAN.
      logical-interface ethernet 0/5.2
        vlan 10 inner-vlan 2 
       
       
  4. Create and configure a BD.
    1. Create BD 1.
      device(config)# bridge-domain 1 p2mp
      
      
      By default, the bridge-domain service type is point-to-multipoint (p2mp).
    2. Bind the logical interfaces for attachment circuit (AC) endpoints to the BD.
      device(config-bridge-domain-1)# logical-interface ethernet 0/5.1
      
      
      Logical interfaces representing BD endpoints must be created before they can be bound to a BD. For further information, refer to Logical Interfaces.
    3. Ensure that local switching is enabled for BD 1.
      device(config-bridge-domain-1)# local-switching
      
      
      Local switching is enabled by default.
    4. Enable the dropping of Layer 2 bridge protocol data units (BPDUs) for BD 1.
      device(config-bridge-domain-1)# bpdu-drop-enable
      
      
      A default pseudowire (PW) profile is automatically configured, with the following defaults:
      Vc_mode = RAW Mode
      mtu = 1500
      mtu_enforce = NO
      pw_profile_control_word = 0
      pw_profile_flow_label = 0
      
    5. Repeat the above BD configuration for the second BD, as in the following example.
      bridge-domain 2 p2mp
       logical-interface ethernet 0/5.2
       pw-profile default
       bpdu-drop-enable
       local-switching
      
  5. Configure an overlay gateway.
    1. In global configuration mode, specify a gateway.
      device(config)# overlay-gateway gw1
      
    2. Specify the type as Layer 2 extension.
      device(config-overlay-gw-gw1)# type layer-2-extension
      
    3. Specify the LVTEP loopback interface.
      device(config-overlay-gw-gw1)# ip interface loopback 2
      
    4. Configure the automatic mapping of VLANs/BDs to Virtual Network Identifiers (VNIs).
      device(config-overlay-gw-gw1)# map vni auto
      
    5. Activate the gateway.
      device(config-overlay-gw-gw1)# activate
      
  6. In global configuration mode, enable EVPN configuration mode and configure the EVPN instance.
    1. Enter default EVPN configuration mode.
      device(config)# evpn
      
      Default mode is the only available mode.
    2. Enable the auto-generation of the import and export route-target community attributes for the default EVPN instance.
      device(config-evpn-default)# route-target both auto
      
    3. Enable the auto-generation of a route distinguisher (RD) for the default EVPN instance.
      device(config-evpn-default)# rd auto
      
    4. Add the BDs to the default EVPN instance.
      device(config-evpn-default)# bridge-domain add 1-2
      
    5. Add the VLANs to the default EVPN instance.
      device(config-evpn-default)# vlan add 11-12
      
  7. Configure the cluster.
    1. In global configuration mode, specify an MCT cluster name (in this example, "c1") to enable cluster configuration mode.
      device(config)# cluster c1
      
    2. Specify a port channel interface through which to reach the MCT cluster peer.
      device(config-cluster-c1)# peer-interface port-channel 1
      
    3. Specify the IP address of the MCT cluster peer.
      device(config-cluster-c1)# peer 7.7.100.7
      
    4. Exit to Privileged EXEC mode.
  8. Configure BGP routing with neighbor and address-family attributes.
    1. In global configuration mode, enable BGP routing and enter BGP router configuration mode.
      device(config)# router bgp
      
    2. Specify the autonomous system number (ASN) for the AS in which the remote neighbor resides.
      device(config-bgp-router)# neighbor 7.7.100.7 remote-as 100
      
    3. Configure the BGP device to communicate with a neighbor through a specified interface, in this case loopback 1.
      device(config-bgp-router)# neighbor 7.7.100.7 update-source loopback 1
      
    4. Repeat the above two substeps for the other peer address, as in the following example.
       neighbor 8.8.100.8 remote-as 100
       neighbor 8.8.100.8 update-source loopback 1
      
    5. Enable IPv4 and IPv6 unicast address-family.
      device(config-bgp-router)# address-family ipv4 unicast
      device(config-bgp-router)# address-family ipv6 unicast
      
  9. Enable the L2VPN address-family configuration mode to configure a variety of BGP EVPN options.
    1. Enable L2VPN address-family configuration mode and enter BGP EVPN configuration mode.
      device(config-bgp-router)# address-family l2vpn evpn
      
    2. Specify VXLAN encapsulation for the first peer.
      device(config-bgp-evpn)# neighbor 8.8.100.8 encapsulation vxlan 
      
    3. Enable the exchange of information with BGP neighbors and peer groups.
      device(config-bgp-evpn)# neighbor 8.8.100.8 activate
        
  10. Repeat the above steps for the other node in the cluster, with modifications as appropriate.