Enabling MVRP over a port channel

About this task

Perform the following steps to enable MVRP over a port channel.

Procedure

  1. From privileged EXEC mode, enter global configuration mode.
    device# configure terminal
  2. Enable MVRP globally on the device.
    device(config)# protocol mvrp
    
    This command accesses MVRP configuration mode.
    device(config-mvrp)#
  3. Access global configuration mode.
    device(config-mvrp)# exit
  4. Configure an Ethernet interface.
    device(config)# interface ethernet 0/1,2
    
    This command accesses interface configuration mode.
    device(conf-if-eth-0/1,2)#
  5. Enable static link aggregation on the interface.
    device(conf-if-eth-0/1,2)# channel-group 10 mode on
    
  6. Enable the interface.
    device(conf-if-eth-0/1,2)# no shutdown
  7. Access global configuration mode.
    device(conf-if-eth-0/1,2)# exit
  8. Configure the port-channel interface and access port-channel configuration mode.
    device(config)# interface Port-channel 10
    
  9. Enable the port channel in Layer 2 mode.
    device(config-Port-channel-10)# switchport
    
  10. Set trunk mode on the port channel.
    device(config-Port-channel-10)# switchport mode trunk
    
  11. Enable MVRP on the port channel.
    device(config-Port-channel-10)# mvrp enable
    
  12. Enable the port channel.
    device(config-Port-channel-10)# no shutdown
    
  13. Display the MVRP status of the configuration.
    device(config-Port-channel-10)# do show mvrp
    ---------------------------------------------------------------------------------------------
    Total configured mvrp ports     :       1
    Global Status                   :       Enabled
    Join-timer(in centiseconds)     :       20
    Leave-timer(in centiseconds)    :       100
    Leaveall-timer(in centiseconds) :       1000
    ---------------------------------------------------------------------------------------------
    MVRP Port(s): Po10
    

Example

The following example provides the steps in the previous configuration.

device# configure terminal
device(config)# protocol mvrp
device(config-mvrp)# exit
device(config)# interface ethernet 0/1,2
device(conf-if-eth-0/1,2)# channel-group 10 mode on
device(conf-if-eth-0/1,2)# no shutdown
device(conf-if-eth-0/1,2)# exit
device(config)# interface Port-channel 10
device(config-Port-channel-10)# switchport
device(config-Port-channel-10)# switchport mode trunk
device(config-Port-channel-10)# mvrp enable
device(config-Port-channel-10)# no shutdown
device(config-Port-channel-10)# do show mvrp
---------------------------------------------------------------------------------------------
Total configured mvrp ports     :       1
Global Status                   :       Enabled
Join-timer(in centiseconds)     :       20
Leave-timer(in centiseconds)    :       100
Leaveall-timer(in centiseconds) :       1000
---------------------------------------------------------------------------------------------
MVRP Port(s): Po10