Enabling MVRP on an Ethernet interface

About this task

Perform the following steps to enable MVRP on an Ethernet interface.

Procedure

  1. From privileged EXEC mode, enter global configuration mode.
    device# configure terminal
  2. Add a VLAN on a device that will be added to the interface.
    device(config)# vlan 10
    
    This command accesses VLAN configuration mode.
    device(config-vlan-10)#
  3. Access global configuration mode.
    device(config-vlan-10)# exit
  4. Enable MVRP globally on the device.
    device(config)# protocol mvrp 
    
    This command accesses MVRP configuration mode.
    device(config-mvrp)#
  5. Access global configuration mode.
    device(config-mvrp)# exit
  6. Configure an Ethernet interface and access interface configuration mode.
    device(config)# interface ethernet 0/1
    
  7. Place the interface in Layer 2 mode.
    device(conf-if-eth-0/1)# switchport
    
  8. Set the Layer 2 interface as trunk.
    device(conf-if-eth-0/1)# switchport mode trunk
    
    Trunk mode makes the port linkable to other switches and routers.
  9. Add the VLAN to the interface as tagged.
    device(conf-if-eth-0/1)# switchport trunk allowed vlan add 10
    
    
  10. Enable MVRP on the interface.
    device(conf-if-eth-0/1)# mvrp enable
    
  11. Enable the interface.
    device(conf-if-eth-0/1)# no shutdown
    
  12. Display the MVRP status of the configuration.
    device(conf-if-eth-0/1)# do show mvrp
    ---------------------------------------------------------------------------------------------
    Total configured mvrp ports     :       1
    Global Status                   :       Enabled
    Join-timer(in centiseconds)     :       20
    Leave-timer(in centiseconds)    :       100
    Leaveall-timer(in centiseconds) :       1000
    ---------------------------------------------------------------------------------------------
    MVRP Port(s): ethe 0/1
    

Example

The following example provides the steps in the previous configuration.

device# configure terminal
device(config)# vlan 10
device(config-vlan-10)# exit
device(config)# protocol mvrp
device(config-mvrp)# exit
device(config)# interface ethernet 0/1
device(conf-if-eth-0/1)# switchport
device(conf-if-eth-0/1)# switchport mode trunk
device(conf-if-eth-0/1)# switchport trunk allowed vlan add 10
device(conf-if-eth-0/1)# mvrp enable
device(conf-if-eth-0/1)# no shutdown
device(conf-if-eth-0/1)# do show mvrp
---------------------------------------------------------------------------------------------
Total configured mvrp ports     :       1
Global Status                   :       Enabled
Join-timer(in centiseconds)     :       20
Leave-timer(in centiseconds)    :       100
Leaveall-timer(in centiseconds) :       1000
---------------------------------------------------------------------------------------------
MVRP Port(s): ethe 0/1