Configure Local ASN during VRF Create

  1. Run the following command:
    efa fabric show --name fabric1
    Fabric Name: fabric1, Fabric Description: , Fabric Type: non-clos
    +--------------+-------+-----------+------------+------+--------------+-------------+-------------------+-----------------+---------+-------+
    |  IP ADDRESS  | RACK  | HOST NAME |    ASN     | ROLE | DEVICE STATE |  APP STATE  | CONFIG GEN REASON | PENDING CONFIGS | VTLB ID | LB ID |
    +--------------+-------+-----------+------------+------+--------------+-------------+-------------------+-----------------+---------+-------+
    | 10.20.246.15 | rack1 | SLX       | 4200000000 | leaf | provisioned  | cfg in-sync | NA                | NA              | 2       | 1     |
    | 10.20.246.16 | rack1 | SLX       | 4200000000 | leaf | provisioned  | cfg in-sync | NA                | NA              | 2       | 1     |
    +--------------+-------+-----------+------------+------+--------------+-------------+-------------------+-----------------+---------+-------+
    
    efa fabric setting show --name fabric1 --advanced | grep -i "backup routing“
    | Backup Routing Enable          | Yes                    |
    | Backup Routing IPv4 Range      | 10.40.40.0/24          |
    | Backup Routing IPv6 Range      | fd40:4040:4040:1::/120 |
    
    efa tenant show
    +------+---------+------------+-------------+-------------+-----------+-----------+----------------------+
    | Name |  Type   | VLAN Range | L2VNI Range | L3VNI Range | VRF Count | Enable BD |        Ports         |
    +------+---------+------------+-------------+-------------+-----------+-----------+----------------------+
    | ten1 | private |   11-20    |             |             |    10     |   false   | 10.20.246.16[0/1-10] |
    |      |         |            |             |             |           |           | 10.20.246.15[0/1-10] |
    +------+---------+------------+-------------+-------------+-----------+-----------+----------------------+
    
    efa tenant vrf show
    +----------+--------+--------------+---------------------+--------------+----------+-----------+-----------+--------------------+-------------+-------------+
    |   Name   | Tenant | Routing Type | Centralized Routers | Redistribute | Max Path | Local Asn | Enable GR |       State        |  Dev State  |  App State  |
    +----------+--------+--------------+---------------------+--------------+----------+-----------+-----------+--------------------+-------------+-------------+
    | ten1vrf1 |  ten1  | distributed  |                     |  connected   |    8     |   5000    |   false   | vrf-device-created | provisioned | cfg-in-sync |
    +----------+--------+--------------+---------------------+--------------+----------+-----------+-----------+--------------------+-------------+-------------+
    
    efa tenant epg show –detail
    ===============================================================================================================================================================
    Name          : ten1epg1
    Tenant        : ten1
    Type          : extension
    State         :
    Ports         : 10.20.246.15[0/1]
    POs           :
    Port Property : SwitchPort Mode     : trunk
                  : Native Vlan Tagging : false
    NW Policy     : Ctag Range          : 11
                  : VRF                 : ten1vrf1
                  : L3Vni               : 8192
    +------+-------------------------+-------+---------+--------------+--------------+-----------------------+---------+----------------+--------------+-------------+-------------+
    | Ctag |          Ctag           | L2Vni | BD Name | Anycast IPv4 | Anycast IPv6 |       Local IP        | IPv6 ND |    IPv6 ND     |   IPv6 ND    |  Dev State  |  App State  |
    |      |       Description       |       |         |              |              | [Device-IP->Local-IP] |   Mtu   | Managed Config | Other Config |             |             |
    +------+-------------------------+-------+---------+--------------+--------------+-----------------------+---------+----------------+--------------+-------------+-------------+
    |  11  | Tenant L3 Extended VLAN |  11   |         | 10.0.11.1/24 |              |                       |         |     false      |    false     | provisioned | cfg-in-sync |
    +------+-------------------------+-------+---------+--------------+--------------+-----------------------+---------+----------------+--------------+-------------+-------------+
    ================================================================================================================================================================================
    
  2. Complete the following configuration on SLX:
    L1# show running-config bridge-domain 4095
    bridge-domain 4095 p2mp
     description Tenant L3 Extended BR BD
     pw-profile Tenant-profile
     router-interface Ve 8191
    !
    
    L1# show running-config interface Ve 8191
    interface Ve 8191
     vrf forwarding ten1vrf1
     ip address 10.40.40.252/31
     ipv6 address fd40:4040:4040:1::fe/127
     no shutdown
    !
    
    L1# do show running-config router bgp
    router bgp
     local-as 4200000000
     capability as4-enable
     fast-external-fallover
     neighbor 10.20.20.3 remote-as 4200000000
     neighbor 10.20.20.3 next-hop-self
     address-family ipv4 unicast
      network 172.31.254.203/32
      network 172.31.254.226/32
      maximum-paths 8
      graceful-restart
     !
     address-family ipv4 unicast vrf ten1vrf1
      local-as 5000
      redistribute connected
      neighbor 10.40.40.253 remote-as 5000
      neighbor 10.40.40.253 next-hop-self
      maximum-paths 8
     !
     address-family ipv6 unicast vrf ten1vrf1
      redistribute connected
      neighbor fd40:4040:4040:1::ff remote-as 5000
      neighbor fd40:4040:4040:1::ff next-hop-self
      neighbor fd40:4040:4040:1::ff activate
      maximum-paths 8
     !
    !
    L1# show running-config bridge-domain 4095
    bridge-domain 4095 p2mp
     description Tenant L3 Extended BR BD
     pw-profile Tenant-profile
     router-interface Ve 8191
    !
    
    L1# show running-config interface Ve 8191
    interface Ve 8191
     vrf forwarding ten1vrf1
     ip address 10.40.40.252/31
     ipv6 address fd40:4040:4040:1::fe/127
     no shutdown
    !
    
    L1# do show running-config router bgp
    router bgp
     local-as 4200000000
     capability as4-enable
     fast-external-fallover
     neighbor 10.20.20.3 remote-as 4200000000
     neighbor 10.20.20.3 next-hop-self
     address-family ipv4 unicast
      network 172.31.254.203/32
      network 172.31.254.226/32
      maximum-paths 8
      graceful-restart
     !
     address-family ipv4 unicast vrf ten1vrf1
      local-as 5000
      redistribute connected
      neighbor 10.40.40.253 remote-as 5000
      neighbor 10.40.40.253 next-hop-self
      maximum-paths 8
     !
     address-family ipv6 unicast vrf ten1vrf1
      redistribute connected
      neighbor fd40:4040:4040:1::ff remote-as 5000
      neighbor fd40:4040:4040:1::ff next-hop-self
      neighbor fd40:4040:4040:1::ff activate
      maximum-paths 8
     !
    !