Application of QoS Profile

You can apply QoS profiles to the interfaces in a hierarchical manner.

You can apply a QoS profile at the following three conceptual levels:

  1. Fabric Interface level: Configuration is applied to the physical interfaces that are part of devices in a fabric.
  2. Tenant interface level: Configuration is applied to all the interfaces that are part of the tenant.
  3. Individual Interface level: Configuration is applied to a subset of interfaces within a specified Tenant.
Note

Note

XCO 3.3.0 and later supports application of profile only at fabric level.

The QoS profiles applied at individual interface level will have highest precedence than the QoS profiles applied at the fabric level. If no profile is applied on an interface, system level defaults will take effect.

Device Application

A QoS profile contains five configuration elements but not all the five configuration elements are applied to every interface. How the information is applied to an interface is dependent on the “switchport mode” of the interface. The following table describes the mapping between QoS configuration element and switchport mode:

Switchport mode “l2 access” Switchport mode “l2 trunk” Switchport mode “l3”
Trust DSCP Applied Applied N/A
dscp-tc Applied if “Trust = DSCP” Applied if “Trust = DSCP” Applied
tc-dscp Applied Applied Applied
pcp-tc N/A Applied N/A
tc-pcp N/A Applied N/A

L3 mode

DSCP is always trusted and the “Trust DSCP” element is ignored or not required to associate dscp-tc or tc-dscp. L3 interfaces do not operate on L2 headers and therefore the pcp-tc and tc-pcp have no bearings on the L3 interface. The results of applying the five configuration on an L3 port will result in the following configuration on a device:

interface Ethernet 0/5
 qos traffic-class-dscp tc2dscp
 qos dscp-traffic-class dscp2tc
 no shutdown
!

L2 Access mode

No mapping or mutation is performed using PCP on access interfaces to the defined maps are not applied. The dscp-tc map is only applied to the interface if the “trust” element is set to “dscp”. If the Trust element is not specified or is set explicitly to “auto” the dscp-tc mapping will not be configured on the interface. If tc-dscp is contained in the profile it will be configured on the interface along with the "remark dscp” configuration. The results of applying the five configuration on an L2 Access port will result in the following configuration on a device:

interface Ethernet 0/1
 switchport
 switchport mode access
 switchport access vlan 1
 qos trust dscp
 qos remark dscp
 qos traffic-class-dscp tc2dscp
 qos dscp-traffic-class dscp2tc
 no shutdown
!

L2 Trunk mode

L2 Trunks use the PCP of the l2 header to map to and from different traffic classes on the device so any pcp-tc or tc-pcp specified configuration is mapped to an interface operating in this mode. As for the use of dscp-tc or tc-dscp are handled as is for l2 access interface. The dscp-tc map is only applied to the interface if the “trust” element is set to “dscp”. If the Trust element is not specified or is set explicitly to “auto” the dscp-tc mapping will not be configured on the interface. If tc-dscp is contained in the profile it will be configured on the interface along with the "remark dscp” configuration. The results of applying the five configuration on an L2 Trunk port would result in the following configuration on a device:

interface Ethernet 0/2
 switchport
 switchport mode trunk
 switchport trunk tag native-vlan
 qos trust dscp
 qos remark dscp
 qos traffic-class-cos tc2pcp
 qos cos-traffic-class pcp2tc
 qos traffic-class-dscp tc2dscp
 qos dscp-traffic-class dscp2tc
 no shutdown