Sample VPLS configurations

PE1 sample configuration

The following is a sample configuration on PE 1.
interface Loopback 1
no shutdown
ip address 18.1.1.1/32
!

ip route 19.1.1.1/32 1.1.1.19

interface Ethernet 1/2
ip proxy-arp
ip address 1.1.1.18/24
no shutdown
!

interface Ethernet 1/1
switchport
switchport mode trunk
switchport trunk tag native-vlan
logical-interface ethernet 1/1.50
  vlan 50
!
exit
no shutdown
!

bridge-domain 50 P2MP
vc-id 5
peer 19.1.1.1
logical-interface ethernet 1/1.50
no bpdu-drop-enable
pw-profile default
local-switching
!
router mpls
ldp
hello-timeout-target 180
  hello-interval-target 60
  ka-interval 100

mpls-interface ethernet 1/2
  ldp-enable
  ldp-params
   hello-interval 60 hello-timeout 180
  !
!

PE2 sample configuration

The following is a sample configuration on PE 2.
interface Loopback 1
no shutdown
ip address 19.1.1.1/32
!

ip route 18.1.1.1/32 1.1.1.18

interface Ethernet 1/1
switchport
switchport mode trunk
switchport trunk tag native-vlan
logical-interface ethernet 1/1.50
  vlan 50
!
exit
!
no shutdown
!
interface Ethernet 1/2
ip proxy-arp
ip address 1.1.1.19/24
no shutdown
!       

bridge-domain 50 P2MP 
vc-id 5
peer 18.1.1.1
logical-interface ethernet 1/1.50
no bpdu-drop-enable
pw-profile default
local-switching
!
router mpls
ldp
  hello-timeout-target 180
  hello-interval-target 60
  ka-interval 100

mpls-interface ethernet 1/2
  ldp-enable
  ldp-params
   hello-interval 60 hello-timeout 180
  !
!

Similar configuration is applicable for VLL with one peer and bridge domain type as P2P.