Configure Egress ACL Rate Limiting

Before you begin

Before you begin, perform the following tasks:
  • For VLAN-based or ACL-based rate limiting, create a VLAN and bind it to a port.
  • For bridge domain-based rate limiting, configure the logical interfaces, create the pseudowire for VPLS, and create the bridge domain.
    Note

    Note

    For egress rate limiting, each bridge domain can have only one logical interface from one egress port.
  • Create an ACL for the VLAN and logical interfaces.

About this task

Important

Important

The egress ACL rate limiting feature is not supported on SLX 9150.

Procedure

  1. Create a VLAN, BD, or ACL class map and bind the associated VLAN, bridge domain, or ACL to it. The following example creates a VLAN class map and binds VLAN 1000 to it.
    device(config)# class-map eVLAN100
     device(config-classmap)# match vlan 100
    device(config-classmap)# exit
    Note

    Note

    To configure BFD, you must configure the timing and interval parameters on each interface. When two adjacent interfaces with BFD are configured, they negotiate the conditions for determining if the connection between them is still active.
  2. Create a policy map and bind the class map to it.
    device(config)# policy-map epol
     device(config-policymap)# class eVLAN100
     
    A policy map is used to apply the policer and QOS attributes to a particular interface. Each policy map can have different class maps. Each class map in the policy map can be associated with separate policing and QOS parameters.
  3. Configure the scheduling scheme or policing rate.
     device(config-policymap-class)# police cir 800000000 
    device(config-policymap)# exit
  4. Bind the policy map to a port.
    device(config)# interface ethernet 3/1
    device(conf-if-eth-3/1)# service-policy out epol
    device(conf-if-eth-3/1)# end
    A policy map is attached to the interface for the ingress or egress direction with the service-policy command. For egress rate limit, only an egress port is supported.

    For each egress port, only one policy map is allowed. However, each policy map can have multiple class maps. To configure a port with different shaping criteria for multiple traffic streams, configure a policy map with multiple classes and configure a different criteria for each class.

Example

This example summarizes the steps in the procedure.

class-map eVLAN100
 match vlan 100
!
class-map eVLAN200
 match vlan 200
!
class-map eBDpol
 match bridge-domain 100

policy-map epol
   class eVLAN100
   police cir 800000000
   !
    class eBDpol
    police cir 1000000000
    !
    class eVLAN200
    police cir 500000000
  !
 interface Ethernet 3/1
  service-policy out epol
 switchport
 switchport mode trunk-no-default-native
 no shutdown
 logical-interface ethernet 3/1.100
  vlan 100
 !
 logical-interface ethernet 3/1.200
  vlan 200
 !
!