Configuring an EVPN LVTEP for MAC IP routes

This configuration is similar to that for Layer 2 EVPN MAC routes.
  1. Configure the TCAM profile to support L3GW. Complete the steps in Configure the TCAM Profile for Layer 3 Gateway.
  2. Create VLANs to be extended on the tunnel.
    vlan 1-4
    
  3. Configure an EVPN instance.
    evpn r1
     route-target both auto
     rd auto
     vlan add 2-4
    
  4. Configure BGP.
    router bgp
     local-as 100
      neighbor 3.3.3.3 remote-as 101 <-- The VXLAN peer
     address-family ipv4 unicast
     !
     address-family ipv6 unicast
     !
     address-family l2vpn evpn
      graceful-restart
      neighbor 3.3.3.3 encapsulation vxlan <-- The VXLAN peer
      neighbor 3.3.3.3 activate
  5. Configure a loopback interface for BGP neighborship.
    interface Loopback 1
     no shutdown
     ip ospf area 0
     ip address 40.40.100.40/32
    
  6. Configure a loopback interface for VXLAN. (MCT peers must have the same address.)
    interface Loopback 2
     no shutdown
     ip ospf area 0
     ip address 2.2.2.2/32
    
  7. Configure a tunnel interface.
    interface Ethernet 0/4
     ip ospf area 0
     ip proxy-arp
     ip address 98.0.0.2/24
     no shutdown
    
  8. Configure the overlay gateway.
    overlay-gateway g1
     type layer2-extension
     ip interface Loopback 1
      map vni auto
     activate
    
  9. Configure the MCT cluster.
    cluster c1 1
     peer-interface Ve 45
     peer 40.40.100.50
     deploy