Configuring an EVPN Layer 3 gateway for MAC IP routes

Do the following to configure a Layer 3 gateway for MAC IP routes.

About this task

This configuration is similar to that for Layer 2 EVPN MAC routes.

Procedure

  1. Configure the TCAM profile to support L3GW. Complete the steps in Configure the TCAM Profile for Layer 3 Gateway.
  2. Create VLANs to be extended on the tunnel.
    vlan 1-4
    
  3. Configure an EVPN instance.
    evpn r1
     route-target both auto
     rd auto
     vlan add 2-4
    
  4. Configure BGP.
    router bgp
      local-as 100
        neighbor 98.0.0.1 remote-as 100
      address-family ipv4 unicast
      !
      address-family ipv6 unicast
      !
      address-family l2vpn evpn
        graceful-restart
        neighbor 98.0.0.1 encapsulation vxlan
        neighbor 98.0.0.1 activate
  5. Configure a loopback interface.
    interface Loopback 1
     no shutdown
     ip ospf area 0
     ip address 1.2.3.4/32
    
  6. Configure a tunnel interface.
    interface Ethernet 0/4
     ip ospf area 0
     ip proxy-arp
     ip address 98.0.0.2/24
     no shutdown
    
  7. Configure the overlay gateway.
    overlay-gateway g1
    type layer2-extension
    ip interface Loopback 1
      map vni auto
    activate