For more information about ACL-based rate
limiting, see the Extreme SLX-OS QoS and Traffic Management Configuration Guide.
-
Access global configuration
mode.
device# configure terminal
-
Create an ACL.
device(config)# mac access-list extended rate-limit-acl_1
This example creates an ACL
named rate-limit-acl_1.
-
Create the ACL rules that you
want to implement.
device(conf-macl-ext)# permit host 0014.2211.1111 any vlan 100 arp arp-guard
device(conf-macl-ext)# permit host 0014.2211.1112 any vlan 101 arp arp-guard
device(conf-macl-ext)# deny any any arp
device(conf-macl-ext)# permit any any
-
Create a class map.
device(config)# class-map arp-guard-class
-
Associate the class map with
the ACL.
device(config-classmap)# match access-group rate-limit-acl_1
-
Return to global configuration
mode.
device(config-classmap)# exit
-
Create a policy map.
device(config)# policy-map arp-guard-pmap
-
Associate the class map with the policy map.
device(config-policymap)# class arp-guard-class
-
Specify class police parameters.
device(config-policymap-class)# police cir 100000
-
Return to global configuration
mode.
device(config-policymap-class-police)# end
-
Enter configuration mode for the relevant interface.
device# configure terminal
device(config)# interface ethernet 1/2
-
Bind the policy map to the
interface.
device(conf-if-eth-1/2)# service-policy in arp-guard-pmap
The following example summarizes the commands in this
procedure.
device# configure terminal
device(config)# mac access-list extended rate-limit-acl_1
device(conf-macl-ext)# permit host 0014.2211.1111 any vlan 100 arp arp-guard
device(conf-macl-ext)# permit host 0014.2211.1112 any vlan 101 arp arp-guard
device(conf-macl-ext)# deny any any arp
device(conf-macl-ext)# permit any any
device(config)# class-map arp-guard-class
device(config-classmap)# match access-group rate-limit-acl_1
device(config-classmap)# exit
device(config)# policy-map arp-guard-pmap
device(config-policymap)# class arp-guard-class
device(config-policymap-class)# police cir 100000
device(config-policymap-class-police)# end
device# configure terminal
device(config)# interface ethernet 1/2
device(conf-if-eth-1/2)# service-policy in arp-guard-pmap