Configuring a single-VTEP static VLAN/VE Layer 3 gateway

Follow these steps to configure a single-VTEP static VLAN/VE Layer 3 gateway.

Procedure

  1. Configure the TCAM profile to support L3GW. Complete the steps in Configure the TCAM Profile for Layer 3 Gateway
  2. Configure a loopback address.
    interface Loopback 100
     no shutdown
     ip address 40.40.40.1/32
  3. Configure an IP interface to be the interface of the VXLAN tunnel.
    interface Ethernet 0/10 
     ip proxy-arp
     ip address 50.50.50.1/24
     no shutdown
  4. Create a VLAN.
    vlan 500
  5. Configure an attachment circuit (AC) endpoint.
    interface Ethernet 0/20
     switchport
     switchport mode trunk
     switchport trunk allowed vlan add 500
     switchport trunk tag native-vlan
     no shutdown
    
  6. Configure the VTEP.
    overlay-gateway test
     type layer2-extension
     ip interface Loopback 100
     map vlan 500 vni 15000
     activate
     site VCS_2
     ip address 40.40.40.2  << This must be the remote-end loopback IP address and be reachable
     extend vlan add 500
    
  7. Configure VE over VXLAN by configuring a VE over the VLAN associated with VXLAN.
    vlan 500
     router-interface ve 500
    
    int ve 500
     ip address 15.15.15.1/24
     ipv6 address 1001::1/64 
     no shutdown