Example of Static Inter-VRF Route Leaking

In this example, one of the static routes in VRF "Blue" (10.50.2.0/24) is being allowed to communicate with one in VRF "Green" (10.55.2.0/24).

About this task

The ovals represent virtual partitions (VRFs) in the router. The destination VRF ("Green") is where the route is being leaked to, and the source VRF ("Blue") is where the route is being leaked from.

Click to expand in new window
Static inter-VRF route leaking

Procedure

  1. In global configuration mode, create and configure VRF "Green".
    device(config)# vrf Green
    device(conf-vrf-Green)# address-family ipv4 unicast
    device(vrf-Green-ipv4-unicast)# 
  2. Repeat the above for VRF "Blue".
    device(config)# vrf Blue
    device(conf-vrf-Blue)# address-family ipv4 unicast
    device(vrf-Blue-ipv4-unicast)# 
    
  3. Configure an interface in the destination VRF "Green" by using the using the vrf forwarding command and configuring a corresponding IP address and subnet mask.
    device(config)# interface eth 0/2
    device(conf-eth-0/2)# vrf forwarding Green
    device(conf-eth-0/2)# ip address 10.55.1.2/24
  4. Repeat the above for the source VRF "Blue", with an appropriate interface and network.
    device(config)# interface eth 0/3
    device(conf-eth-0/3)# vrf forwarding Blue
    device(conf-eth-0/3)# ip address 10.50.1.2/24
  5. Enter address-family IPv4 unicast configuration mode for the source VRF address family context for configuring static route leak.
    device(config)# vrf Blue
    device(conf-vrf-Blue)# address-family ipv4 unicast
  6. Configure route leaking for a network (using the IP address and subnet mask), by specifying the destination next-hop VRF instance and the next hop in the destination VRF.
    Note

    Note

    The destination VRF can also be a specific port on an Ethernet interface. Refer to the Extreme SLX-OS Command Reference for details on the ip route next-hop-vrf command.
    device(vrf-Blue-ipv4-unicast)# ip route 10.55.2.0/24 next-hop-vrf Green 10.55.1.1
  7. Configure route leaking for the default VRF for a network (using the IP address and subnet mask), by specifying the destination next-hop VRF instance and the default-vrf in the destination VRF.
    device(vrf-Blue-ipv4-unicast)# ip route 20.0.0.0/24  next-hop-vrf default-vrf 10.1.1.1
  8. (Optional) For bidirectional route-leak traffic, you can also configure route leaking from VRF "Green" to VRF "Blue".