Configure a BGP4+ Neighbor with a Link-local Address

You can configure a BGP4+ neighbor with a link-local address.

Procedure

  1. Access global configuration mode.
    device# configure terminal
  2. Access BGP configuration mode.
    device(config)# router bgp
  3. Specify the autonomous system which your device resides.
    device(config-bgp-router)# local-as 1000
  4. Specify the autonomous system in which the remote neighbor resides.
    device(config-bgp-router)# neighbor fe80:4398:ab30:45de::1 remote-as 1001
    This example specifies the neighbor command, the neighbor address of fe80:4398:ab30:45de::1, the remote-as keyword, and autonomous system 1001.
  5. Specify the interface through which the neighbor and the local device communicate to exchange prefixes.
    device(config-bgp-router)# neighbor fe80:4398:ab30:45de::1 update-source ethernet 3/1
    This example specified the neighbor command, the neighbor address, the update-source keyword, and Ethernet interface slot 3, port 1.
  6. Access IPv6 address family configuration mode.
    device(config-bgp-router)# address-family ipv6 unicast
  7. Enable the exchange of information with the neighbor.
    device(config-bgp-ipv6u)# neighbor fe80:4398:ab30:45de::1 activate
    This example specifies the neighbor command, the neighbor address, and the activate keyword.
  8. Apply a route map to outgoing routes.
    device(config-bgp-ipv6u)# neighbor fe80:4398:ab30:45de::1 route-map out myroutemap
    This example specifies the neighbor command, the neighbor address, the route-map out keyword, and the route map titled myroutemap.
  9. Return to global configuration mode.
    device(config-bgp-ipv6u)# exit
    device(config-bgp-router)# exit
    device(config)#
  10. Define the route map and enter route map configuration mode.
    device(config)# route-map myroutemap permit 10
    This example specifies the route-map command, the name of the route map, and a matching pattern. The route map sets up the global next hop for packets that are destined for the neighbor.
  11. Specify the IPv6 address of the next hop.
    device(config-routemapmap-myroutemap/permit/10)# set ipv6 next-hop 2001::10

Example

The following example summarizes the commands in this procedure.

device# configure terminal
device(config)# router bgp
device(config-bgp-router)# local-as 1000
device(config-bgp-router)# neighbor fe80:4398:ab30:45de::1 remote-as 1001
device(config-bgp-router)# neighbor fe80:4398:ab30:45de::1 update-source ethernet 3/1
device(config-bgp-router)# address-family ipv6 unicast
device(config-bgp-ipv6u)# neighbor fe80:4398:ab30:45de::1 activate
device(config-bgp-ipv6u)# neighbor fe80:4398:ab30:45de::1 route-map out myroutemap
device(config-bgp-ipv6u)# exit
device(config-bgp-router)# exit
device(config)# route-map myroutemap permit 10
device(config-routemapmap-myroutemap/permit/10)# set ipv6 next-hop 2001::10