ERP topology and configuration

Example ERP topology

The following is an example three-node topology for reference in the configuration examples. The topology consists of three devices: an RPL owner, and RPL node, and a non-RPL node. This is a basic configuration. Additional commands can be used to provide additional features.

Do the following before configuring any ERP settings:
  • Configure the VLAN.
  • Configure the interface as a switchport.
  • Add the VLAN to the switchport in either trunk or access mode.
  • Configure the switchport mode trunk-no-default-native command on ports configured as trunk ports.
Click to expand in new window
Example ERP topology

ERP configuration examples

The following are example configuration examples on the nodes.

Node 1 (RPL owner)
configure terminal
vlan 222
end
configure terminal
interface Ethernet 0/1
 switchport
 switchport mode trunk-no-default-native
 switchport trunk allowed vlan add 222
 no shutdown
!
end

configure terminal
interface Ethernet 0/2
 switchport
 switchport mode trunk-no-default-native
 switchport trunk allowed vlan add 222
 no switchport trunk tag native-vlan
 no shutdown
!
end

configure terminal
erp 1
 left-interface vlan 222 ethernet 0/1
 right-interface vlan 222 ethernet 0/2
 rpl-owner
 rpl vlan 222 ethernet 0/1
 enable
!
end
Note

Note

Optionally, you can configure the non-revertive node feature. This setting can be configured only on the RPL owner.
Node 2 (RPL node)
configure terminal
vlan 222
end

configure terminal
interface Ethernet 0/1
 switchport
 switchport mode trunk-no-default-native
 switchport trunk allowed vlan add 222
 no shutdown
!
end

configure terminal
interface Ethernet 0/2
 switchport
 switchport mode trunk-no-default-native
 switchport trunk allowed vlan add 222
 no shutdown
!
end

configure terminal
erp 2
 left-interface vlan 222 ethernet 0/2
 right-interface vlan 222 ethernet 0/1
 rpl vlan 222 ethernet 0/1
 enable
!
end
Node 3 (Non-RPL node)
configure terminal
vlan 222
end

configure terminal
interface Ethernet 0/1
 switchport
 switchport mode trunk-no-default-native
 switchport trunk allowed vlan add 222
 no shutdown
!
end

configure terminal
interface Ethernet 0/2
 switchport
 switchport mode trunk-no-default-ntive
 switchport trunk allowed vlan add 222
 no shutdown
!
end

configure terminal
erp 3
 left-interface vlan 222 ethernet 0/1
 right-interface vlan 222 ethernet 0/2
 enable
!
end