Using MCT with VRRP and VRRP-E

Standard VRRP and VRRP-E configuration commands, VMAC generation login, and scaling numbers apply when used with MCT. VRRP advertisement packets are exchanged through the MCT ICL.

The MCT device that acts as the Virtual Routing Redundancy Protocol (VRRP) and VRRP Extended (VRRP-E) backup router performs as a Layer 2 switch to pass the packets to the VRRP or VRRP-E master router for forwarding. Through MAC synchronization, the VRRP or VRRP-E backup router learns the virtual MAC (VMAC) on the Inter-Chassis Link (ICL). The data traffic and control traffic both pass through the ICL cloud from the backup router. If VRRP-E short path forwarding is enabled, the backup router can forward the packets directly, instead of sending them to the master.

Note

Note

Short path forwarding is only supported on VRRP-E.

In the MCT short path forwarding diagram below, when an ARP request from the S1 switch device is sent through the direct link to the VRRP or VRRP-E backup router (PE2), that same request is flooded through the ICL and received by the VRRP/E master router (PE1) for processing. When the ARP request is received by the PE1 device, PE1 sends a reply through the direct link to S1. If the ARP reply was received before the MAC address for the MCT on S1 is learned, the reply packet may be flooded to both the Customer Client Edge Port (CCEP) ports and ICL ports.

Using VRRP or VRRP-E, data traffic received from a client device on a backup router is Layer 2 switched to the master device. If VRRP-E short path forwarding is enabled, traffic received on the backup device may be forwarded by the backup if the route to the destination device is shorted than through the master device.

MCT short path forwarding configuration using VRRP-E example

In this example configuration, we are assuming that MCT is using the VRRP-E short path forwarding. When short path forwarding is enabled, packets from either the E1 or E2 devices with a destination of the E4 device can be routed through the PE 2 device which is a VRRP-E backup device. Short path forwarding is designed for load-balancing and allows packets to use the shortest path, and in this case, PE2 is directly connected to E4 so the packets will travel through PE2.

Click to expand in new window
MCT short path forwarding

PE1 configuration

The following example configures the cluster for the PE1 router in the diagram. A VRRP-E priority value of 110 (higher than the device at PE2) allows the PE1 device to assume the role of VRRP-E master.

 interface Ethernet 0/3
  ip address 10.1.8.19/24 
  no shutdown
! 
 vlan 100
!
 interface Ethernet 0/5
  switchport
  switchport mode trunk-no-default-native
  switchport trunk allow vlan add 100
  no shutdown
!
 cluster <optional-cluster-name>
  peer 10.1.8.32
  peer-interface Ethernet 0/3
  peer-keepalive
    auto
!
 member vlan all
 member bridge-domain all
!
 vlan 100
  router-interface Ve 100
!
 protocol vrrp-extended
!
 interface Ve 100 
 ip proxy-arp
 ip address 10.2.3.6/24
 vrrp-extended-group 1
   priority 110
   short-path-forwarding
   virtual-ip 10.2.3.4
 no shutdown
!
 interface Ve 100
 ipv6 address fe80::1:2 link-local
 ipv6 address 3313::2/64
 ipv6 vrrp-extended-group 1
 virtual-ip 3313::1

PE2 configuration

The following example configures the cluster for the PE2 router in the diagram. A VRRP-E priority value of 80 (lower than the device at PE1) allows the PE2 device to assume the role of a VRRP-E backup device.

interface Ethernet 0/3
ip address 10.1.8.32/24
no shutdown
!
vlan 100
!
interface Ethernet 0/7
switchport
switchport mode trunk-no-default-native
switchport trunk allow vlan add 100
no shutdown
!
cluster <optional-cluster-name>
peer 10.1.8.19
peer-interface Ethernet 0/3
peer-keepalive
  auto
!
member vlan all
member bridge-domain all
!
vlan 100
router-interface Ve 100
!
protocol vrrp-extended
!
interface Ve 100
ip proxy-arp
ip address 10.2.3.5/24
vrrp-extended-group 1
  priority 80
  short-path-forwarding
  virtual-ip 10.2.3.4
no shutdown
!
interface Ve 100
ipv6 address fe80::1:1 link-local
ipv6 address 3313::3/64
ipv6 vrrp-extended-group 1
virtual-ip 3313::1