ip

interface-config-vlan-instance

Configures the VLAN interface‘s IP settings

Supported in the following platforms:

  • Access Points — AP505i, AP510i/e, AP560i/h
  • Service Platforms — NX5500, NX7500, NX9500, NX9600, VX9000

Syntax

ip [address|dhcp|helper-address|nat|ospf]
ip helper-address <IP>
ip address [<IP/M>|<NETWORK-ALIAS-NAME>|dhcp|zeroconf]
ip address [<IP/M>|<NETWORK-ALIAS-NAME>|zeroconf] {secondary}
ip address dhcp
ip dhcp client request options all
ip nat [inside|outside]
ip ospf [authentication|authentication-key|bandwidth|cost|message-digest-key| priority]
ip ospf authentication [message-digest|null|simple-password]
ip ospf authentication-key simple-password [0 <WORD>|2 <WORD>]
ip ospf [bandwidth <1-10000000>|cost <1-65535>|priority <0-255>]
ip ospf message-digest-key key-id <1-255> md5 [0 <WORD>|2 <WORD>]

Parameters

ip helper-address <IP>
helper-address <IP> Enables DHCP and BOOTP requests forwarding for a set of clients. Configure a helper address on the VLAN interface connected to the client. The helper address should specify the address of the BOOTP or DHCP servers to receive the requests. If you have multiple servers, configure one helper address for each server.
  • <IP> – Specify the IP address of the DHCP or BOOTP server.
ip address [<IP/M>|<NETWORK-ALIAS-NAME>|zeroconf] {secondary}
address Sets the VLAN interface‘s IP address
<IP/M> Specifies the interface IP address in the A.B.C.D/M format
  • secondary – Optional. Sets the specified IP address as a secondary address
<NETWORK-ALIAS-NAME> Uses a pre-defined network alias to provide this VLAN interface‘s IP address. Specify the network alias name.
  • secondary – Optional. Sets the network-alias provided IP address as the secondary address
zeroconf {secondary} Uses Zero Configuration Networking (zeroconf) to generate an IP address for this interface.
  Zero configuration can be a means of providing a primary or secondary IP addresses for the virtual interface. Zero configuration (or zero config) is a wireless connection utility included with Microsoft Windows XP and later as a service dynamically selecting a network to connect based on a user's preferences and various default settings. Zero config can be used instead of a wireless network utility from the manufacturer of a computer's wireless networking device.
  • secondary – Optional. Sets the generated IP address as a secondary address
ip address dhcp
address Sets the VLAN interface‘s IP address
dhcp Uses a DHCP client to obtain an IP address for this VLAN interface
ip dhcp client request options all
dhcp Uses a DHCP client to configure a request on this VLAN interface
client Configures a DHCP client
request Configures DHCP client request
options Configures DHCP client request options
all Configures all DHCP client request options
ip nat [inside|outside]
nat [inside|outside] Defines NAT settings for the VLAN interface. NAT is disabled by default.
  • inside – Enables NAT on the inside interface. The inside network is transmitting data over the network to the intended destination. On the way out, the source IP address is changed in the header and replaced by the (public) IP address.
  • outside – Enables NAT on the outside interface. Packets passing through the NAT on the way back to the managed LAN are searched against the records kept by the NAT engine. There, the destination IP address is changed back to the specific internal private class IP address in order to reach the LAN over the network.
ip ospf authentication [message-digest|null|simple-password]
ospf authentication Configures OSPF authentication scheme. Options are message-digest, null, and simple-password.
message-digest Configures md5 based authentication
null No authentication required
simple-password Configures simple password based authentication
ip ospf authentication-key simple-password [0 <WORD>|2 <WORD>]
ospf authentication-key Configures an OSPF authentication key
simple-password [0 <WORD>|2 <WORD>] Configures a simple password OSPF authentication key
  • 0 <WORD> – Configures clear text key
  • 2 <WORD> – Configures encrypted key
ip ospf [bandwidth <1-10000000>|cost <1-65535>|priority <0-255>]
bandwidth <1-10000000> Configures bandwidth for the physical port mapped to this layer 3 interface
  • <1-10000000> – Specify the bandwidth from 1 - 10000000.
cost <1-65535> Configures OSPF cost
  • <1-65535> – Specify OSPF cost value from 1 - 65535.
priority <0-255> Configures OSPF priority
  • <0-255> – Specify OSPF priority value from 0 - 255.
ip ospf message-digest-key key-id <1-255> md5 [0 <WORD>|2 <WORD>]
ospf message-digest Configures message digest authentication parameters
key-id <1-255> Configures message digest authentication key ID from 0 - 255
md5 [0 <WORD>|2 <WORD>] Configures md5 key
  • 0 <WORD> – Configures clear text key
  • 2 <WORD> – Configures encrypted key

Example

nx9500-6C8809(config-profile-default-rfs4000-if-vlan8)#ip address 10.0.0.1/8

nx9500-6C8809(config-profile-default-rfs4000-if-vlan8)#ip nat inside

nx9500-6C8809(config-profile-default-rfs4000-if-vlan8)#ip helper-address 172.16.10.3

nx9500-6C8809(config-profile-default-rfs4000-if-vlan8)#ip dhcp client request options all

nx9500-6C8809(config-profile-default-rfs4000-if-vlan8)#show context
 interface vlan8
  description "This VLAN interface is configured for the Sales Team"
  ip address 10.0.0.1/8
  ip dhcp client request options all
  ip helper-address 172.16.10.3
  ip nat inside
  crypto map map1
  dhcp-relay-incoming
nx9500-6C8809(config-profile-default-rfs4000-if-vlan8)#

Related Commands

no Removes or resets IP settings on this interface