adoption-mode

Profile Config Commands

Configures the mode of adoption in an access point profile. This command is also applicable to the device configuration context.

By default, any WiNG AP, on being powered-up for the first time, starts the following auto-discovery process. The AP:
  1. Moves to MLCP_DISCOVERY state and tries to discover a local controller. If a local controller is found, it
    1. adopts to the controller, and
    2. marks itself as “local-controller” adopted, and
    3. moves to the MLCP_MODE.
  2. If a local controller is not found, the AP switches to the CLOUD_DISCOVERY state, and tries connecting to the ExtremeCloud. If the AP succeeds in connecting to the cloud, it
    1. marks itself as “cloud-adopted”, and
    2. moves to the CLOUD_MODE.
  3. If the AP is unable to discover and adopt to the ExtremeCloud, it switches to the WS_CONTROLLER_DISCOVERY state, and tries connecting to the WebSocket (WS) Controller. If it succeeds in connecting to the ws_controller, it
    1. marks itself as “ws-controller-adopted”, and
    2. moves to the WS_CONTROLLER_MODE.
  4. The AP continues to switch between the three discovery states (local controller, cloud, and ws_controller) until it gets adopted.
  5. Once adopted, an AP‘s adoption mode does not change unless,
    1. It is changed from the controller‘s CLI (using the adoption-mode command), the Cloud dashboard, or the WS controller dashboard.
    2. If the AP is reverted to factory settings, in which case the AP starts the auto-discovery process on bootup.

Supported in the following platforms:

  • Access Points — AP505i, AP510i/e, AP560i/h
  • Service Platforms — NX5500, NX7500, NX9500, NX9600, VX9000

Syntax

adoption-mode [cloud|controller|ws-controller]

Parameters

adoption-mode [cloud|controller|ws-controller]
adoption-mode [cloud|controller|ws-controller] Use to set the adoption-mode to:
  • cloud – Sets the adoption-mode to Extreme Cloud. The factory-default, management server setting, in WiNG AP profiles contexts, points to the Extreme Cloud Web address. If the adoption-mode is set to cloud, the AP on coming up, will search for and adopt to the ExtremeCloud.
  • controller – Sets the adoption mode to the local WiNG controller. This is the default setting. Note, APs with the ‘controller > host > configuration‘ specified are marked as local-controller APs and never try adopting to the CLOUD or WS-Controller
  • ws-controller – Sets the adoption mode to the EAE (Edge Application Engine) ws-controller. If selecting this option, use the ‘management-server‘ command to configure the EAE controller‘s IP address or hostname. For information on configuring the management-server, see management-server.
Note: Alternately, the AP auto-adopts to the WS controller, if its receives DHCP IP address, and the DHCP option 191 poo1 string configuration is as shown in the following examples:
In the DHCP server policy, define an alias for option 191:
VX(config-dhcp-policy-DHCP)#
 dhcp-server-policy DHCP
  option AP-adoption 191 ascii
In the DHCP pool config, define the option 191 string:
dhcp-pool AP
  option AP-adoption pool1=<ws-controller-ip-adress>;
adoption-mode=ws-controller

Examples

nx9500-6C8809(config-profile-testAP8432)#adoption-mode cloud
nx9500-6C8809(config-profile-testAP8432)#show context
profile ap8432 testAP8432
 no autoinstall configuration
 no autoinstall firmware
 crypto ikev1 policy ikev1-default
  isakmp-proposal default encryption aes-256 group 2 hash sha
 crypto ikev2 policy ikev2-default
  isakmp-proposal default encryption aes-256 group 2 hash sha
 crypto ipsec transform-set default esp-aes-256 esp-sha-hmac
 crypto ikev1 remote-vpn
 crypto ikev2 remote-vpn
 crypto auto-ipsec-secure
 crypto load-management
 crypto remote-vpn-client
 interface radio1
 interface radio2
 interface bluetooth1
  shutdown
 interface ge1
 interface ge2
 interface pppoe1
 use firewall-policy default
 service pm sys-restart
 router ospf
 adoption-mode cloud
nx9500-6C8809(config-profile-testAP8432)#
ap505-13403B(config-device-94-9B-2C-13-40-38)#aadoption-mode ws-controller
ap505-13403B(config-device-94-9B-2C-13-40-38)#show context
ap505 94-9B-2C-13-40-38
 use profile default-ap505
 use rf-domain default
 hostname ap505-13403B
 mint mlcp vlan
 mint mlcp ip
 ip default-gateway 10.234.160.254
 ip route 134.141.244.0/24 10.234.160.254
 ip route 10.233.84.0/24 10.234.160.254
 interface ge1
  switchport mode access
  switchport access vlan 1
 interface vlan1
  ip address 10.234.160.36/24
 logging on
 logging console debugging
 adoption-mode ws-controller
ap505-13403B(config-device-94-9B-2C-13-40-38)#

Related Commands

no Reverts the adoption-mode to default (controller)