CLI Input for PE3

VRF5

PE3(su)->router vrf5
PE3(su-vrf5)->configure
PE3(su-vrf5-config)->rd 1:12
PE3(su-vrf5-config)->route-target both 1:10
PE3(su-vrf5-config)->route-target import 1:1
PE3(su-vrf5-config)->exit
PE3(su-vrf5)->exit

Global VRF (L3 Tunnel)

Use the following example input when configuring L3 VPN using L3 tunnels. If you are configuring L3 VPN using Native MPLS see Global VRF (Native MPLS).

PE3(su)->configure
PE3(su-config)->mpls ip (Native MPLS only)
PE3(su-config)->mpls label-protocol-ldp ipv4 (Native MPLS only)
PE3(su-config)->interface loopback 1
PE3(su-config-intf-loop.0.1)->ip address 192.168.3.254 255.255.255.255 primary
PE3(su-config-intf-loop.0.1)->ip address 192.168.300.1 255.255.255.255 secondary
PE3(su-config-intf-loop.0.1)->no shutdown
PE3(su-config-intf-loop.0.1)->exit
PE3(su-config)->interface vlan 4002
PE3(su--config-intf-vlan.0.4002)->ip address 10.10.1.3 255.255.255.0 primary
PE3(su--config-intf-vlan.0.4002)->no shutdown
PE3(su--config-intf-vlan.0.4002)->exit
PE3(su-config)->interface tunnel 2
PE3(su-config-tun.0.2)->tunnel mode gre
PE3(su-config-tun.0.2)->tunnel destination 192.168.1.254
PE3(su-config-tun.0.2)->tunnel source 192.168.3.254
PE3(su-config-tun.0.2)->no shutdown
PE3(su-config-tun.0.1)->exit
PE3(su-config)->ip route 192.168.100.1/24 interface tun.0.2 1
PE3(su-config)->interface tunnel 3
PE3(su-config-tun.0.3)->tunnel mode gre
PE3(su-config-tun.0.3)->tunnel destination 192.168.2.254
PE3(su-config-tun.0.3)->tunnel source 192.168.3.254
PE3(su-config-tun.0.3)->no shutdown
PE3(su-config-tun.0.3)->exit
PE3(su-config)->ip route 192.168.200.1/32 interface tun.0.3 1

Global VRF (Native MPLS)

Use the following example input when configuring L3 VPN using Native MPLS. If you are configuring L3 VPN using L3 tunnels see Global VRF (L3 Tunnel).

PE3(su)->configure
PE3(su-config)->mpls ip
PE3(su-config)->mpls label-protocol-ldp ipv4
PE3(su-config)->interface loopback 1
PE3(su-config-intf-loop.0.1)->ip address 92.168.300.1 255.255.255.255 primary
PE3(su-config-intf-loop.0.1)->no shutdown
PE3(su-config-intf-loop.0.1)->exit
PE3(su-config)->interface vlan 4002
PE3(su--config-intf-vlan.0.4002)->ip address 10.10.1.3 255.255.255.0 primary
PE3(su--config-intf-vlan.0.4002)->no shutdown
PE3(su--config-intf-vlan.0.4002)->exit

Global VRF (BGP)

PE3(su-config)->router bgp 64520
PE3(su-config-bgp)->bgp router-id 192.168.300.1
PE3(su-config-bgp)->log-up-down
PE3(su-config-bgp)->neighbor 192.168.100.1 remote-as 64520
PE3(su-config-bgp)->neighbor 192.168.200.1 remote-as 64520
PE3(su-config-bgp)->address-family vpnv4
PE3(su-config-bgp-af-vpn)->enable
PE3(su-config-bgp-af-vpn)->exit
PE3(su-config-bgp)->address-family ipv4 vrf vrf5
PE3(su-config-bgp-af-vrf)->redistribute ospf 1
PE3(su-config-bgp-af-vrf)->exit
PE3(su-config-bgp)->exit
PE3(su-config)->exit
PE3(su)->