Source Address Only Configuration

Multiple tunneled port mirrors can be configured to use a single source address configured L2 tunnel (VPPS) at its destination, by configuring the destination end as an any-remote tunnel. An any-remote tunnel accepts any remote IP as the source IP address, as long as the destination IP address matches this tunnel's source IP. When any-remote is enabled on the destination end of a VPPS tunnel:

Virtual Private Port Service Any-Remote Configuration Example presents an example of an any-remote enabled L2 tunnel. In this example port mirroring is enabled on Router 1 packet sources:

Two mirror enabled VPPS tunnels (one for each mirrored source) with a single tunnel destination are created on Router1 and Router2:

On the Router 3 destination side of the VPPS tunnel, an any-remote L2 tunnel is created as tun.0.1 with a tunnel source of IP address 99.99.99.1 on loopback interface of loop.0.1 (Callout 4) and a bound physical port of ge.1.3. No tunnel destination is configured and will have on affect if one is configured.

A static route with VPPS tunnel destination as its destination assures a route exists for the VPPS tunnels.

Packets from Packet Source 1 are port mirrored on port ge.1.1 and targeted to port tg.1.1 (Router1) which is the bound physical port for tun.0.1. Packets are tunneled to Router 3 loopback interface loop.0.1. Returning packets will be sourced to loopback interface 1 on Router 3, but will be decapsulated and will be switched or routed out port ge.1.3 on Router 3 to its destination.

Packets from Packet Source 2 are port mirrored on port ge.1.2 and targeted to port tg.1.2 (Router2) which is the bound physical port for tun.0.2. Packets are tunneled to Router 3 loopback interface loop.0.1. Returning packets will be sourced to loopback interface 1 on Router 3, but will be decapsulated and will be switched or routed out port ge.1.3 on Router 3 to its destination.

Router 1 VPPS Configuration

This example shows how to set:

  • Loopback interface 1 is used as the tunnel sources for VPPS tunnel 1
  • VLAN interface 20 to be used with the static route that assures a route exists to the tunnel destination
  • Port mirror enabled VPPS tunnel 1 with destination 99.99.99.1
  • A static route to the VPPS tunnel destination
    System(rw)->configure
    System(rw-config)->interface loopback 1
    System(rw-config-intf-loop.0.1)->ip address 77.77.77.1 255.255.255.255 primary
    System(rw-config-intf-loop.0.1)->ipv6 address 2007::1/128
    System(rw-config-intf-loop.0.1)->no shutdown
    System(rw-config-intf-loop.0.1)->exit
    System(rw-config)->interface vlan 20
    System(rw-config-intf-vlan.0.20)->ip address 6.1.1.1 255.255.255.0 primary
    System(rw-config-intf-vlan.0.20)->ipv6 address 2666::1/64
    System(rw-config-intf-vlan.0.20)->ipv6 nd ra suppress
    System(rw-config-intf-vlan.0.20)->ipv6 forwarding
    System(rw-config-intf-vlan.0.20)->no shutdown
    System(rw-config-intf-vlan.0.20)->exit
    System(rw-config)->interface tunnel 1
    System(rw-config-intf-tun.0.1)->tunnel source 77.77.77.1
    System(rw-config-intf-tun.0.1)->tunnel destination 99.99.99.1
    System(rw-config-intf-tun.0.1)->tunnel mode gre l2 tg.1.1
    System(rw-config-intf-tun.0.1)->tunnel mirror enable
    System(rw-config-intf-tun.0.1)->no shutdown
    System(rw-config-intf-tun.0.1)->exit
    System(rw-config)->ip route 99.99.99.1/32 6.1.1.2 interface vlan.0.20 1

Router 2 VPPS Configuration

This example shows how to set:

  • Loopback interface 2 is used as the tunnel sources for VPPS tunnel 2
  • VLAN interface 20 to be used with the static route that assures a route exists to the tunnel destination
  • Port mirror enabled VPPS tunnel 2 is configured with destination 99.99.99.1
  • A static route to the VPPS tunnel destination
    System(rw)->configure
    System(rw-config)->interface loopback 2
    System(rw-config-intf-loop.0.2)->ip address 88.88.88.1 255.255.255.255 primary
    System(rw-config-intf-loop.0.2)->ipv6 address 2008::1/128
    System(rw-config-intf-loop.0.2)->no shutdown
    System(rw-config-intf-loop.0.2)->exit
    System(rw-config)->interface vlan 20
    System(rw-config-intf-vlan.0.20)->ip address 6.1.1.2 255.255.255.0 primary
    System(rw-config-intf-vlan.0.20)->ipv6 address 2666::2/64
    System(rw-config-intf-vlan.0.20)->ipv6 nd ra suppress
    System(rw-config-intf-vlan.0.20)->ipv6 forwarding
    System(rw-config-intf-vlan.0.20)->no shutdown
    System(rw-config-intf-vlan.0.20)->exit
    System(rw-config)->interface tunnel 2
    System(rw-config-intf-tun.0.2)->tunnel source 88.88.88.1
    System(rw-config-intf-tun.0.2)->tunnel destination 99.99.99.1
    System(rw-config-intf-tun.0.2)->tunnel mode gre l2 tg.1.2
    System(rw-config-intf-tun.0.2)->tunnel mirror enable
    System(rw-config-intf-tun.0.2)->no shutdown
    System(rw-config-intf-tun.0.2)->exit
    System(rw-config)->ip route 99.99.99.1/32 6.1.1.2 interface vlan.0.20 1

Router 2 Any-Remote Configuration

This example shows how to set:

  • Loopback interface 1 to be used as the VPPS tunnel destination for VPPS tunnels 1 and 2 and the Any-Remote tunnel source
  • VLAN interface 20 to be used with the static route that assures a route exists to the VPPS tunnel destination
  • Any-Remote tunnel 1
    System(rw)->configure
    System(rw-config)->interface loopback 1
    System(rw-config-intf-loop.0.1)->ip address 99.99.99.1 255.255.255.255 primary
    System(rw-config-intf-loop.0.1)->ipv6 address 2009::1/128
    System(rw-config-intf-loop.0.1)->no shutdown
    System(rw-config-intf-loop.0.1)->exit
    System(rw-config)->interface vlan 20
    System(rw-config-intf-vlan.0.20)->ip address 6.1.1.3 255.255.255.0 primary
    System(rw-config-intf-vlan.0.20)->ipv6 address 2666::3/64
    System(rw-config-intf-vlan.0.20)->ipv6 nd ra suppress
    System(rw-config-intf-vlan.0.20)->ipv6 forwarding
    System(rw-config-intf-vlan.0.20)->no shutdown
    System(rw-config-intf-vlan.0.20)->exit
    System(rw-config)->interface tunnel 1
    System(rw-config-intf-tun.0.1)->tunnel source 99.99.99.1
    System(rw-config-intf-tun.0.1)->tunnel mode gre l2 ge.1.3
    System(rw-config-intf-tun.0.1)->tunnel any-remote enable
    System(rw-config-intf-tun.0.1)->no shutdown
    System(rw-config-intf-tun.0.1)->exit