Example MSDP Configuration

The following shows an example S- or K-Series device configuration that sets up an inter-domain MSDP peering relationship.

Define the loop back or VLAN interfaces for PIM RP / MSDP peers. In the example, loop.0.1 is used as PIM RP/ MSDP peer.

[On router A:]

interface loop.0.1
  ip address 121.1.1.1 255.255.255.0 primary
  no shutdown
  exit

[On router B:]

interface loop.0.1
  ip address 122.2.2.2 255.255.255.0 primary
  no shutdown
  exit

Define a PIM RP for each domain.

[On router A:]

ip pim bsr-candidate 121.1.1.1
 ip pim rp-candidate 121.1.1.1 224.0.0.0 240.0.0.0

[On router B:]

ip pim bsr-candidate 122.2.2.2
 ip pim rp-candidate 122.2.2.2 224.0.0.0 240.0.0.0

Configure BGP for each domain.

[On router A:]

router bgp 5100
  bgp router-id 121.1.1.1
  neighbor 122.2.2.2 remote-as 5200
  neighbor 122.2.2.2 ebgp-multihop 10
  neighbor 122.2.2.2 update-source 121.1.1.1
  redistribute connected
  exit

[On router B:]

router bgp 5200
  bgp router-id 122.2.2.2
  neighbor 121.1.1.1 remote-as 5100
  neighbor 121.1.1.1 ebgp-multihop 10
  neighbor 121.1.1.1 update-source 122.2.2.2
  redistribute connected
  exit

Configure OSPF for each domain so that unicast routes work for PIM. This is basic for PIM.

Configure MSDP peers between the two domains.

[On router A:]

ip msdp peer 122.2.2.2 connect-source loop.0.1  remote-as 5200

[On router B:]

ip msdp peer 121.1.1.1 connect-source loop.0.1  remote-as 5100