anycast-rp

Configures PIM Anycast rendezvous points (RPs) in IPv4 multicast domains.

Syntax

anycast-rp rp-address [anycast-rp-peer-prefix-list]
no anycast-rp rp-address

Command Default

By default, PIM Anycast RPs are not configured.

Parameters

rp-address
Specifies a shared RP address used among multiple PIM routers.
anycast-rp-peer-prefix-list
Specifies the list of Anycast IPv4 or IPv6 peers that are configured with the same Anycast RP address.

Modes

PIM router configuration mode

Usage Guidelines

PIM Anycast RP provides load balancing and fast convergence to PIM RPs in an IPv4 multicast domain. The RP address of the Anycast RP is a shared address used among multiple PIM routers, known as PIM RP. The PIM RP routers create an Anycast RP set. Each router in the Anycast RP set is configured using two IP addresses: a shared RP address in their loopback address and a separate, unique IP address. The loopback address must be reachable by all PIM routers in the multicast domain. The separate, unique IP address is configured to establish static peering with other PIM routers and communication with the peers.

When the source is activated in a PIM Anycast RP domain, the PIM first hop (FH) registers the source to the closest PIM RP. The PIM RP decapsulates the packet and creates the (s,g) state. If there are external peers in the Anycast RP set, the router re-encapsulates the packet with the local peering address as the source address of the encapsulation. The router distributes the packet to all Anycast RP peers. This re-encapsulation ensures source state distribution to all RPs in a multicast domain.

The no anycast-rp form of this command removes the Anycast RP configuration.

Examples

The following example shows how to configure IPv4 PIM Anycast RP.

device # configure terminal
device(config)#router-pim
device(config-pim-router)# anycast-rp 101.101.101.101 my-anycast-rps
device(config-pim-router)# exit
device(config)# ip prefix-list my-anycast-rpspermit 1.1.1.1/32
device(config)# ip prefix-list my-anycast-rpspermit 2.2.2.2/32
device(config)# interface loopback 1
device(config-Loopback-1)# ip address 1.1.1.1/32
device(config-Loopback-1)# ip pim-sparse
device(config)#interface loopback 2
device(config-Loopback-2)# ip address 2.2.2.2/32
device(config-Loopback-2)# ip pim-sparse
device(config-Loopback-11)# ip address 101.101.101.101/32
device(config-Loopback-11# ip pim-sparse

The following example shows how to configure IPv6 PIM Anycast RP, with 1234::22/128 configured on the other Anycast RP router in the domain.

Note

Note

NOTE Use an IPv6 prefix list only with the anycast-rp command in an IPv6 environment. Likewise, only use an IPv6 prefix list when running the command in an IPv6 environment. If you use an IPv4 prefix list in an IPv6 environment, no error is generated and prefixes are ignored.
device(config)# ipv6 router pim
device(config-ipv6-router-pim-vrf-default-vrf)# anycast-rp 1234::100 anycast-rp-peer-plist
device(config-ipv6-router-pim-vrf-default-vrfr)# exit
device(config)# ipv6 prefix-list anycast-rp-peer-plist permit 1234::5/128
device(config)# ipv6 prefix-list anycast-rp-peer-plist permit 1234::22/128
device(config)# interface loopback 1
device(config-Loopback-2)# ipv6 address 1234::5/128
device(config-Loopback-1)# ipv6 pim-sparse
device(config)#interface loopback 10
device(config-Loopback-10)# ipv6 address 1234::100/24
device(config-Loopback-10)# ipv6 pim-sparse