route-only

Configures VE route-only mode on physical ports and port-channels (LAG ports), to enable the exclusive IP routing of incoming packets. Incoming switching packets on the port are dropped, and outgoing switching packets are forwarded.

Syntax

route-only
no route-only

Command Default

This feature is disabled.

Modes

Interface subtype configuration mode

Usage Guidelines

Use the no form of this command to disable this feature.

Examples

To configure VE route-only mode on a physical port.

device# configure terminal
device(config)# interface ethernet 1/2
device(conf-if-eth-1/2)# switchport
device(conf-if-eth-1/2)# switchport mode trunk
device(conf-if-eth-1/2)# switchport mode trunk allowed vlan add 100
device(conf-if-eth-1/2)# route-only
device(conf-if-eth-1/2)# no shutdown

To disable VE route-only mode on a physical port.

device# configure terminal
device(config)# interface ethernet 1/2
device(conf-if-eth-1/2)# no route-only

To configure VE route-only mode on a LAG port:

device# configure terminal
device(config)# interface port-channel 1
device(config-Port-channel-1)# switchport
device(config-Port-channel-1)# switchport mode trunk
device(config-Port-channel-1)# switchport mode trunk allowed vlan add 100,200
device(config-Port-channel-1)# switchport trunk tag native-vlan
device(config-Port-channel-1)# route only
device(config-Port-channel-1)# no shutdown

To disable VE route-only mode on a LAG port:

device# configure terminal
device(config)# interface port-channel 1
device(config-Port-channel-1)# no route-only