IPv6 Alternative Routes Configuration Example

To avoid traffic interruption, you can enable alternative routes globally to replace the best route with the next-best route, if the best route becomes unavailable.

The concept of alternative route applies between routing protocols. For example, if an OSPFv3 route becomes unavailable and an alternative RIPng route is available, the system activates the RIPng route immediately without waiting for an update interval to expire.

By default, the alternative routes feature is globally enabled on the switch.

The following example demonstrates this behavior.

In this example, you configure OSPFv3 and RIPng routes on two switches Switch-1 and Switch-2, as shown in the following figure.

Click to expand in new window

Configuration on Switch-1

VLAN configuration:

On Switch-1, configure VLAN 2 and the IPv6 interface address 2000:0:0:0:0:0:0:1/64.

Switch1:1:1>enable
Switch1:1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Switch1:1(config)#vlan create 2 type port-mstprstp 0
Switch1:1(config)#vlan members 2 4/5
Switch1:1(config)#interface vlan 2
Switch1:1(config-if)#ipv6 interface address 2000:0:0:0:0:0:0:1/64
Switch1:1(config-if)#ipv6 interface enable
Switch1:1(config-if)#exit
Switch1:1(config)#show vlan basic

=======================================================================================
                          Vlan Basic
=======================================================================================
VLAN                        MSTP
ID    NAME     TYPE         INST_ID PROTOCOLID   SUBNETADDR      SUBNETMASK      VRFID
---------------------------------------------------------------------------------------
1     Default  byPort       0       none         N/A             N/A             0 
2     VLAN-2   byPort       0       none         N/A             N/A             0 

All 2 out of 2 Total Num of Vlans displayed
Switch1:1>show vlan members
==========================================================================
                                   Vlan Port

==========================================================================
VLAN PORT               ACTIVE             STATIC             NOT_ALLOW
ID   MEMBER             MEMBER             MEMBER             MEMBER
--------------------------------------------------------------------------
1    1/1-1/16,1/17/1-   1/1-1/16,1/17/1-
     1/17/4,1/18/1-     1/17/4,1/18/1-
     1/18/4,2/1-2/16,   1/18/4,2/1-2/16,
     2/17/1-2/17/4,     2/17/1-2/17/4,
     2/18/1-2/18/4,3/1- 2/18/1-2/18/4,3/1-
     3/6,4/1-4/4,4/6    3/6,4/1-4/4,4/6

2    4/5                4/5


All 2 out of 2 Total Num of Port Entries displayed
Switch1:1(config)#show ipv6 interface vlan 2

=================================================================================================================
                           Vlan Ipv6 Interface
=================================================================================================================
IFINDX VLAN PHYSICAL          ADMIN   OPER  TYPE  MTU  HOP REACHABLE RETRANSMIT MCAST   IPSEC    RPC      RPCMODE
INDX        ADDRESS           STATE   STATE            LMT TIME      TIME       STATUS
-----------------------------------------------------------------------------------------------------------------
2050   2    b0:ad:aa:4e:59:00 enable  up    ETHER 1500 64  30000     1000       disable disable  disable  existonly

=================================================================================================================
                               Vlan Ipv6 Address

=================================================================================================================
IPV6 ADDRESS                            VLAN-ID      TYPE    ORIGIN    STATUS
-----------------------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64                   V-2          UNICAST MANUAL    PREFERRED
fe80:0:0:0:b2ad:aaff:fe4e:5900/64       V-2          UNICAST LINKLAYER PREFERRED

1 out of 1 Total Num of Interface Entries displayed.
2 out of 2 Total Num of Address Entries displayed.

Port configuration:

Switch1:1(config)#interface gigabitEthernet 4/5
Switch1:1(config-if)#encapsulation dot1q
Switch1:1(config-if)#no shutdown
Switch1:1(config-if)#exit

IPv6 global configuration:

Switch1:1(config)#ipv6 forwarding

Switch1:1(config)#show ipv6 forwarding
        Ipv6 forwarding - GlobalRouter : enable
        ecmp                           : disable
        ecmp-max-path                  : 1

IPv6 OSPFv3 VLAN configuration:

Switch1:1(config)#interface vlan 2
Switch1:1(config-if)#ipv6 ospf area 0.0.0.0
Switch1:1(config-if)#ipv6 ospf enable

Switch1:1(config-if)#show ipv6 ospf interface vlan 2
        admin-status         : enable
        area                 : 0.0.0.0
        dead-interval        : 40
        hello-interval       : 10
        metric               : 1
        poll-interval        : 120
        priority             : 1
        retransmit-interval  : 5
        transit-delay        : 1
        type                 : BROADCAST

IPv6 OSPFv3 router configuration:

Switch1:1(config-if)#exit
Switch1:1(config)#router ospf ipv6-enable
Switch1:1(config)#show ipv6 ospf

==================================================================================
                   OSPFv3 Global Information - GlobalRouter

==================================================================================
        router-id                      : 170.78.88.0
        admin-state                    : ENABLED
        version                        : 3
        area-bdr-rtr-state             : FALSE
        as-bdr-rtr-state               : FALSE
        helper-mode                    : ENABLED
        as-scope-lsa-count             : 0
        lsa-checksum                   : 0
        originate-new-lsas             : 22
        rx-new-lsas                    : 11
        ext-lsa-count                  : 0
Switch1:1(config)#show ipv6 ospf neighbor

=======================================================================================
                        OSPF Neighbor - GlobalRouter

=======================================================================================
IFINDX(VID/BRT) NBRROUTERID     NBRIPADDR                               STATE     TTL
---------------------------------------------------------------------------------------
2050   (2)     170.78.84.0     fe80:0:0:0:b2ad:aaff:fe4e:5500           Full      31

1 out of 1 Total Num of Neighbor Entries displayed.

=======================================================================================
                      OSPF Virtual Neighbor - GlobalRouter

=======================================================================================
NBRAREAID       NBRROUTERID     VIRTINTFID NBRIPV6ADDR                STATE 
---------------------------------------------------------------------------------------

0 out of 0 Total Num of Virtual Neighbor Entries displayed.

=======================================================================================
                               OSPF NBMA Neighbor - GlobalRouter

=======================================================================================

INTERFACE NBRROUTERID     NBRIPADDR                                STATE

---------------------------------------------------------------------------------------


0 out of 0 Total Num of NBMA Neighbor Entries displayed.


H = Helping a Restarting neighbor

Switch1:1(config-if)#exit

IPv6 RIPng configuration on VLAN:

Switch1:1(config)#interface vlan 2
Switch1:1(config-if)#ipv6 rip
Switch1:1(config-if)#ipv6 rip enable
Switch1:1(config-if)#show ipv6 rip interface

Total RIPng interfaces: 1

================================================================================
                 RIPng Interface - GlobalRouter

================================================================================
IFINDX         COST     POISON       SEND         ADMIN        OPER
                        STATUS       DEFAULT      STATUS       STATUS
--------------------------------------------------------------------------------
2050 (2    )   1        disable      disable      enable       enable

1 out of 1 Total Num of RIPng interfaces displayed

IPv6 RIPng global router configuration:

Switch1:1(config)#router rip ipv6-enable
Switch1:1(config)#router rip
Switch1:1(config)#show ipv6 rip

==========================================================================
               RIPng Global - GlobalRouter 

===========================================================================
                   Rip : Enabled
         HoldDown Time : 120
      Timeout Interval : 180
           Update Time : 30
   Default Info Metric : 1
    Default Info State : Disabled
 Default Import Metric : 1

Configuration on Switch–2

On Switch-2, configure VLAN 2 and VLAN 3 with the IPv6 interfaces 2000:0:0:0:0:0:0:2/64 and 3000:0:0:0:0:0:0:2/64 respectively.

VLAN configuration:

Switch2:1>enable
Switch2:1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Switch2:1(config)#vlan create 2 type port-mstprstp 0
Switch2:1(config)#vlan members 2 4/5 portmember
Switch2:1(config)#interface vlan 2

Switch2:1(config-if)#ipv6 interface address 2000:0:0:0:0:0:0:2/64
Switch2:1(config-if)#ipv6 interface enable
Switch2:1(config-if)#ipv6 forwarding
Switch2:1(config-if)#exit
Switch2:1(config)#vlan create 3 type port-mstprstp 0
Switch2:1(config)#vlan members 3 4/6 portmember
Switch2:1(config)#interface vlan 3

Switch2:1(config-if)#ipv6 interface address 3000:0:0:0:0:0:0:2/64
Switch2:1(config-if)#ipv6 interface enable
Switch2:1(config-if)#ipv6 forwarding
Switch2:1(config-if)#exit
Switch2:1(config)#show vlan basic

===================================================================================
                           Vlan Basic
===================================================================================
VLAN                        MSTP
ID    NAME     TYPE         INST_ID PROTOCOLID   SUBNETADDR   SUBNETMASK      VRFID
-----------------------------------------------------------------------------------
1     Default  byPort       0       none         N/A          N/A             0 
2     VLAN-2   byPort       0       none         N/A          N/A             0 
3     VLAN-3   byPort       0       none         N/A          N/A             0 

All 3 out of 3 Total Num of Vlans displayed
Switch2:1(config)#show vlan members

=======================================================================
                                   Vlan Port

========================================================================
VLAN PORT               ACTIVE             STATIC             NOT_ALLOW
ID   MEMBER             MEMBER             MEMBER             MEMBER
------------------------------------------------------------------------
1    1/1-1/16,1/17/1-   1/1-1/16,1/17/1-
     1/17/4,1/18/1-     1/17/4,1/18/1-
     1/18/4,2/1-2/16,   1/18/4,2/1-2/16,
     2/17/1-2/17/4,     2/17/1-2/17/4,
     2/18/1-2/18/4,3/1- 2/18/1-2/18/4,3/1-
     3/6,4/1-4/4        3/6,4/1-4/4

2    4/5                4/5

3    4/6                4/6


All 3 out of 3 Total Num of Port Entries displayed
Switch2:1(config)#show ipv6 interface vlan

==================================================================================================================
                         Vlan Ipv6 Interface
==================================================================================================================
IFINDX VLAN PHYSICAL          ADMIN   OPER  TYPE  MTU  HOP REACHABLE RETRANSMIT  MCAST    IPSEC    RPC      RPCMODE
INDX        ADDRESS           STATE   STATE            LMT TIME      TIME        STATUS  
------------------------------------------------------------------------------------------------------------------
2050   2    b0:ad:aa:4e:55:00 enable  up    ETHER 1500 64  30000     1000        disable  disable  disable  existonly
2051   3    b0:ad:aa:4e:55:01 enable  up    ETHER 1500 64  30000     1000        disable  disable  disable  existonly

===================================================================================================================
                               Vlan Ipv6 Address

===================================================================================================================
IPV6 ADDRESS                            VLAN-ID      TYPE    ORIGIN    STATUS
-------------------------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:2/64                   V-2          UNICAST MANUAL    PREFERRED
fe80:0:0:0:b2ad:aaff:fe4e:5500/64       V-2          UNICAST LINKLAYER PREFERRED
3000:0:0:0:0:0:0:2/64                   V-3          UNICAST MANUAL    PREFERRED
fe80:0:0:0:b2ad:aaff:fe4e:5501/64       V-3          UNICAST LINKLAYER PREFERRED

2 out of 2 Total Num of Interface Entries displayed.
4 out of 4 Total Num of Address Entries displayed.

Port configuration:

Switch2:1(config)#interface GigabitEthernet 4/5
Switch2:1(config)#encapsulation dot1q
Switch2:1(config)#no shutdown

Switch2:1(config)#interface GigabitEthernet 4/6
Switch2:1(config)#encapsulation dot1q
Switch2:1(config)#no shutdown

IPv6 global configuration:

Switch1:1(config)#ipv6 forwarding

Switch1:1(config)#show ipv6 forwarding
        Ipv6 forwarding - GlobalRouter : enable
        ecmp                           : disable
        ecmp-max-path                  : 1

IPv6 OSPFv3 VLAN configuration:

Switch2:1(config)#interface vlan 2
Switch2:1(config-if)#ipv6 ospf area 0.0.0.0
Switch2:1(config-if)#ipv6 ospf enable

Switch2:1(config)#interface vlan 3
Switch2:1(config-if)#ipv6 ospf area 0.0.0.0
Switch2:1(config-if)#ipv6 ospf enable
Switch2:1(config-if)#show ipv6 ospf

=================================================================================
                   OSPFv3 Global Information - GlobalRouter

=================================================================================
        router-id                      : 170.78.84.0
        admin-state                    : ENABLED
        version                        : 3
        area-bdr-rtr-state             : FALSE
        as-bdr-rtr-state               : FALSE
        helper-mode                    : ENABLED
        as-scope-lsa-count             : 0
        lsa-checksum                   : 0
        originate-new-lsas             : 56
        rx-new-lsas                    : 62
        ext-lsa-count                  : 0
Switch2:1(config-if)#show ipv6 ospf interface

Total ospf areas: 1

Total ospf interfaces: 2

==================================================================================
                          OSPF Interface - GlobalRouter

==================================================================================
IFINDX(VID/BRT) AREAID          ADM IFSTATE  METRIC PRI DR/BDR          IFTYPE
----------------------------------------------------------------------------------
2050  (2      ) 0.0.0.0         ena BDR      1      1   170.78.88.0     BROADCAST
                                                       170.78.84.0
2051  (3      ) 0.0.0.0         ena DR       1      1   170.78.84.0     BROADCAST
                                                       0.0.0.0

2 out of 2 Total Num of ospf interfaces displayed

Total ospf virtual interfaces: 0

==================================================================================
                     OSPF Virtual Interface - GlobalRouter

==================================================================================

AREAID          NBRIPADDR       STATE

----------------------------------------------------------------------------------


0 out of 0 Total Num of ospf virtual interfaces displayed
Switch2:1(config-if)#show ipv6 ospf neighbor

==================================================================================
                           OSPF Neighbor - GlobalRouter

==================================================================================
IFINDX(VID/BRT) NBRROUTERID     NBRIPADDR                     STATE     TTL
----------------------------------------------------------------------------------
2050   (2)     170.78.88.0     fe80:0:0:0:b2ad:aaff:fe4e:5900 Full      30

1 out of 1 Total Num of Neighbor Entries displayed.

===================================================================================
                       OSPF Virtual Neighbor - GlobalRouter

===================================================================================
NBRAREAID       NBRROUTERID     VIRTINTFID NBRIPV6ADDR        STATE
-----------------------------------------------------------------------------------

0 out of 0 Total Num of Virtual Neighbor Entries displayed.

===================================================================================
                          OSPF NBMA Neighbor - GlobalRouter

===================================================================================

INTERFACE NBRROUTERID     NBRIPADDR                           STATE

------------------------------------------------------------------------------------


0 out of 0 Total Num of NBMA Neighbor Entries displayed.


H = Helping a Restarting neighbor

IPv6 OSPFv3 global router configuration:

Switch2:1(config-if)#exit
Switch2:1(config)#router ospf ipv6-enable
Switch1:1(config)#show ipv6 ospf

=====================================================================================
                  OSPFv3 Global Information - GlobalRouter

=====================================================================================
        router-id                      : 170.78.88.0
        admin-state                    : ENABLED
        version                        : 3
        area-bdr-rtr-state             : FALSE
        as-bdr-rtr-state               : FALSE
        helper-mode                    : ENABLED
        as-scope-lsa-count             : 0
        lsa-checksum                   : 0
        originate-new-lsas             : 22
        rx-new-lsas                    : 11
        ext-lsa-count                  : 0

IPv6 RIPng configuration:

Switch2:1(config)#interface vlan 2
Switch2:1(config-if)#ipv6 rip
Switch2:1(config-if)#ipv6 rip enable
Switch2:1(config-if)#exit

Switch2:1(config)#interface vlan 3
Switch2:1(config-if)#ipv6 rip
Switch2:1(config-if)#ipv6 rip enable
Switch2:1(config-if)#exit
Switch2:1(config)#
Switch2:1(config)#show ipv6 rip interface

Total RIPng interfaces: 2

========================================================================
               RIPng Interface - GlobalRouter

========================================================================
IFINDX         COST     POISON       SEND         ADMIN        OPER
                        STATUS       DEFAULT      STATUS       STATUS
-------------------------------------------------------------------------
2050 (2    )   1        disable      disable      enable       enable
2051 (3    )   1        disable      disable      enable       enable

2 out of 2 Total Num of RIPng interfaces displayed

IPv6 RIPng global router configuration:

Switch2:1(config)#router rip ipv6-enable
Switch2:1(config)#router rip

Switch2:1(config)#show ipv6 rip

=============================================================
              RIPng Global - GlobalRouter

==============================================================
                   Rip : Enabled
         HoldDown Time : 120
      Timeout Interval : 180
           Update Time : 30
   Default Info Metric : 1
    Default Info State : Disabled
 Default Import Metric : 1

Viewing route and alternative route configuration on the switches

On Switch-1 and Switch-2, the route 3000:0:0:0:0:0:0:2/64 is learned using the protocols RIPng and OSPFv3. The OSPFv3 route is learned as the best route because of its route preference value of 20. The RIPng route is added as alternative route as it has the route preference 100, which is greater than the OSPFv3 route preference of 20. On Switch-2, the route 3000:0:0:0:0:0:0:2/64 is a local route.

Viewing route and alternative route configuration on Switch-1:

Switch1:1(config)#show ipv6 route alternative

====================================================================================================
                           IPv6 Routing Table Information - GlobalRouter
====================================================================================================
Destination Address/PrefixLen  NEXT HOP                    VID/BID/TID  PROTO   COST  AGE TYPE PREF 
----------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64          0:0:0:0:0:0:0:0                 V-2          LOCAL   1     0   B    0
3000:0:0:0:0:0:0:2/64          fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          OSPF    2     0   B    20
3000:0:0:0:0:0:0:2/64          fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          RIP     2     0   A    100
----------------------------------------------------------------------------------------------------

4 out of 4 Total Num of Route Entries displayed.
----------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route
Switch1:1(config)#show ipv6 route

===================================================================================================
                         IPv6 Routing Table Information - GlobalRouter
===================================================================================================
Destination Address/PrefixLen NEXT HOP                        VID/BID/TID  PROTO COST  AGE TYPE PREF
---------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64         0:0:0:0:0:0:0:0                 V-2          LOCAL 1     0   B    0
3000:0:0:0:0:0:0:2/64         fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          OSPF  2     0   B    20
---------------------------------------------------------------------------------------------------

3 out of 3 Total Num of Route Entries displayed.
---------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route

Viewing route and alternative route configuration on Switch-2:

Switch2:1(config)#show ipv6 route alternative

======================================================================================================
                           IPv6 Routing Table Information - GlobalRouter
======================================================================================================
Destination Address/PrefixLen  NEXT HOP                        VID/BID/TID  PROTO   COST  AGE TYPE PREF
------------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:2/64          0:0:0:0:0:0:0:0                 V-2          LOCAL   1     0   B    0
3000:0:0:0:0:0:0:2/64          fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          LOCAL   2     0   B    20
3000:0:0:0:0:0:0:2/64          fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          LOCAL   2     0   A    100
------------------------------------------------------------------------------------------------------

4 out of 4 Total Num of Route Entries displayed.
------------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route
Switch2:1#show ipv6 route

==========================================================================================
                          IPv6 Routing Table Information - GlobalRouter
==========================================================================================
Destination Address/PrefixLen  NEXT HOP          VID/BID/TID  PROTO   COST  AGE   TYPE PREF
------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:2/64          0:0:0:0:0:0:0:0   V-2          LOCAL   1     0     B    0
3000:0:0:0:0:0:0:2/64          0:0:0:0:0:0:0:0   V-3          LOCAL   1     0     B    20
------------------------------------------------------------------------------------------

4 out of 4 Total Num of Route Entries displayed.
------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route

Changing the route preference on Switch-1

On the switch, default preferences are assigned to all standard routing protocols. You can modify the global preference for a protocol to give it a higher or lower priority than other protocols. When you change the preference for a static route, if all best routes remain best routes, only the local route tables change. However, if changing the protocol preference causes best routes to no longer be best routes, neighboring route tables can be affected.

In the following example scenario, you configure a different routing preference for the RIPng protocol on Switch-1 and observe the learning of best and alternative routes. The existing route preference for RIPng is 100.

Switch1:1#show ipv6 route alternative

========================================================================================================
                             IPv6 Routing Table Information - GlobalRouter
========================================================================================================
Destination Address/PrefixLen  NEXT HOP                        VID/BID/TID  PROTO   COST  AGE   TYPE PREF
--------------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64          0:0:0:0:0:0:0:0                 V-2          LOCAL   1     0     B    0
3000:0:0:0:0:0:0:2/64          fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          OSPF    2     0     B    20
3000:0:0:0:0:0:0:2/64          fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          RIP     2     0     A    100
--------------------------------------------------------------------------------------------------------

4 out of 4 Total Num of Route Entries displayed.
--------------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route
Switch1:1(config)#show ipv6 route

===================================================================================================
                          IPv6 Routing Table Information - GlobalRouter
===================================================================================================
Destination Address/PrefixLen NEXT HOP                        VID/BID/TID  PROTO COST  AGE TYPE PREF
---------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64         0:0:0:0:0:0:0:0                 V-2          LOCAL 1     0   B    0
3000:0:0:0:0:0:0:2/64         fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          OSPF  2     0   B    20
---------------------------------------------------------------------------------------------------

3 out of 3 Total Num of Route Entries displayed.
---------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route

Configure a different route preference for the RIPng protocol, for example, 19:

Switch1:1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1:1(config)#ipv6 route preference protocol ripng 19
Switch1:1(config)#exit

Verify the route preference configuration:

Switch1:1#show ipv6 route preference

========================================================================================
                             IPv6 Route Preference - GlobalRouter

========================================================================================
PROTOCOL        DEFAULT    CONFIG
----------------------------------------------------------------------------------------
LOCAL           0          0
STATIC          5          5
SPBM_L1         7          7
OSPFv3_INTRA    20         20
OSPFv3_INTER    25         25
EBGP            45         45
RIPNG           100        19
OSPFv3_E1       120        120
OSPFv3_E2       125        125
IBGP            175        175

View the updated route preference (for RIPng) on Switch-1. The RIPng route is now learnt as the best route as it has lesser value of route preference (19) than that of OSPFv3 (20), as shown below.

Switch1:1(config)#show ipv6 route

===================================================================================================
                         IPv6 Routing Table Information - GlobalRouter
===================================================================================================
Destination Address/PrefixLen NEXT HOP                        VID/BID/TID  PROTO COST  AGE TYPE PREF
---------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64         0:0:0:0:0:0:0:0                 V-2          LOCAL 1     0   B    0
3000:0:0:0:0:0:0:2/64         fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          RIP   2     0   B    19
---------------------------------------------------------------------------------------------------

3 out of 3 Total Num of Route Entries displayed.
---------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route
Switch1:1#show ipv6 route alternative

===========================================================================================================
                                IPv6 Routing Table Information - GlobalRouter
===========================================================================================================
Destination Address/PrefixLen   NEXT HOP                          VID/BID/TID  PROTO   COST  AGE   TYPE PREF
-----------------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64           0:0:0:0:0:0:0:0                   V-2          LOCAL   1     0     B    0
3000:0:0:0:0:0:0:2/64           fe80:0:0:0:b2ad:aaff:fe4e:5500    V-2          RIP     2     0     B    19
3000:0:0:0:0:0:0:2/64           fe80:0:0:0:b2ad:aaff:fe4e:5500    V-2          OSPF    2     0     A    20
-----------------------------------------------------------------------------------------------------------

4 out of 4 Total Num of Route Entries displayed.
-----------------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route

Disable alternative route learning on Switch-1

The following example demonstrates disabling alternative route learning on Switch-1.

View the alternative routes on Switch-1.

Switch1:1(config)#show ipv6 route alternative

=======================================================================================================
                            IPv6 Routing Table Information - GlobalRouter
=======================================================================================================
Destination Address/PrefixLen  NEXT HOP                        VID/BID/TID  PROTO   COST  AGE TYPE PREF
-------------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64          0:0:0:0:0:0:0:0                 V-2          LOCAL   1     0   B    0
3000:0:0:0:0:0:0:2/64          fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          OSPF    2     0   B    20
3000:0:0:0:0:0:0:2/64          fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          RIP     2     0   A    100
-------------------------------------------------------------------------------------------------------

4 out of 4 Total Num of Route Entries displayed.
-------------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route

Disable IPv6 alternative routes on Switch-1.

Switch1:1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1:1(config)#no ipv6 alternative-route
Switch1:1(config)#exit

Verify that alternative route learning is disabled.

Switch1:1#show ipv6 global
        forwarding                     : enable
        default-hop-cnt                : 64
        number-of-interfaces           : 1
        icmp-error-interval            : 1000
        icmp-error-quota               : 50
        icmp-unreach-msg               : disable
        icmp-echo-multicast-request    : enable
        static-route-admin-status      : enable
        alternative-route              : disable
        ecmp                           : disable
        ecmp-max-path                  : 1
        source-route                   : disable
Switch1:1(config)#show ipv6 route

===================================================================================================
                         IPv6 Routing Table Information - GlobalRouter
===================================================================================================
Destination Address/PrefixLen NEXT HOP                        VID/BID/TID  PROTO COST  AGE TYPE PREF
---------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64         0:0:0:0:0:0:0:0                 V-2          LOCAL 1     0   B    0
3000:0:0:0:0:0:0:2/64         fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          OSPF  2     0   B    20
---------------------------------------------------------------------------------------------------

3 out of 3 Total Num of Route Entries displayed.
---------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route

Note that the alternative route (RIPng) is not learnt.

Switch1:1(config)#show ipv6 route alternative

======================================================================================================
                         IPv6 Routing Table Information - GlobalRouter
======================================================================================================
Destination Address/PrefixLen  NEXT HOP                        VID/BID/TID  PROTO   COST  AGE TYPE PREF
------------------------------------------------------------------------------------------------------
2000:0:0:0:0:0:0:1/64          0:0:0:0:0:0:0:0                 V-2          LOCAL   1     0   B    0
3000:0:0:0:0:0:0:2/64          fe80:0:0:0:b2ad:aaff:fe4e:5500  V-2          OSPF    2     0   B    20
------------------------------------------------------------------------------------------------------

3 out of 3 Total Num of Route Entries displayed.
------------------------------------------------------------------------------------------------------
TYPE Legend:
A=Alternative Route, B=Best Route, E=Ecmp Route