Virtual interswitch trunk (vIST)

Creating a Virtual IST

Use this procedure to create a virtual IST (vIST).

vIST creates a virtualized channel through the SPBM cloud, and this channel connects two SMLT devices to form a virtualized Switch Cluster. Note that the SPBM cloud can consist of as few as two nodes.

Important

Important

  • When you create a vIST, VLANs assigned to SMLT ports must have an I-SID assigned.

  • If you assign a VLAN to an I-SID on one SMLT-BEB node, then you must create the same VLAN and assign it to the same I-SID on the peer SMLT-BEB node even if no devices are connected to this second node.

  • The vIST VLAN must also be associated with an I-SID. You can use the same vIST VLAN in another part of your network, but the I-SID associated with the vIST VLAN must not be used anywhere else.

Note

Note

Simplified Virtual-IST (vIST) is for non-SPB customers who use SMLT with legacy IST. Simplified VIST is available for legacy multicast deployments only when the boot flag (spbm-config-mode) is disabled.

For more information, see Configuring Simplified vIST in SMLT topologies .

About this task

The following list provides an overview of the configuration steps:

  • Enable SPBM and IS-IS globally.

  • Configure SPBM and IS-IS.

  • Configure an Layer 2 VSN by assigning an I-SID to the C-VLAN, which is used by the vIST.

For information about SPBM and IS-IS, see SPBM and IS-IS Infrastructure Fundamentals.

Important

Important

Do not change the system MTU to less than the default value of 1950 bytes. The system MTU must be 1950 or jumbo because of the header size increase when transmitting packets over the SPBM cloud.

Procedure

  1. Enter Global Configuration mode:

    enable

    configure terminal

  2. Create a vIST:

    virtual-ist peer-ip <A.B.C.D> vlan <1-4059>

  3. Verify your vIST configuration:

    show virtual-ist

Example

The configuration example contains annotations (in parenthesis) to explain the configuration information.

Click to expand in new window
SMLT with vIST configuration example
Note

Note

This configuration example is for vIST peer B.

#
# ISIS SPBM CONFIGURATION
#

router isis
spbm 1
spbm 1 nick-name 0.00.16
spbm 1 b-vid 10,20 primary 10
spbm 1 smlt-virtual-bmac 00:00:84:04:01:01
spbm 1 smlt-peer-system-id a051.c6eb.c865
exit

#
# MLT CONFIGURATION
#

mlt 1 enable
mlt 1 member 1/28

                    
mlt 2 enable
mlt 2 member 1/10
mlt 2 encapsulation dot1q

#
# VLAN CONFIGURATION
#

vlan members remove 1 1/28,1/10

(The rest of this VLAN section are all prerequisites for configuring a vIST.)
vlan create 10 type spbm-bvlan  (This command and the next create the B-VLANs.)
vlan create 20 type spbm-bvlan
vlan create 33 type port-mstprstp 0
vlan i-sid 33 33
mlt 1 vlan 33

vlan create 100 type port-mstprstp 0  (Creates the C-VLAN for the vIST VLAN.)
vlan i-sid 100 100  (Creates a Layer 2 VSN for the vIST VLAN.)
interface Vlan 100

ip address 192.0.2.2 255.255.255.0 0  (Assigns an IP to the vIST VLAN.)
exit

#
# VIRTUAL vIST CONFIGURATION
#

virtual-ist peer-ip 192.0.2.1 vlan 100  (vIST configuration.)

#
# MLT INTERFACE CONFIGURATION
#

interface mlt 1
smlt
exit 
               
interface mlt 2
isis
isis spbm 1
isis enable
exit

#
# PORT CONFIGURATION - PHASE II
#

interface GigabitEthernet 1/28
no shutdown
no spanning-tree mstp force-port-state enable
exit

interface GigabitEthernet 1/10
no shutdown
exit

#

# ISIS CONFIGURATION
#

router isis
is-type l1
manual-area 11.1111 
exit
router isis enable

Variable definitions

Use the data in the following table to use the ist peer-ip command.

Variable

Value

<A.B.C.D>

Specifies the peer IP address—the IP address of the vIST VLAN on the other aggregation switch.

<1-4059>

Specifies the VLAN ID for this vIST.

Viewing vIST Statistics

View virtual IST (vIST) statistics for the switch.

Procedure

  1. Enter Privileged EXEC mode:

    enable

  2. Display the vIST statistics:

    show virtual-ist stat

  3. To clear the vIST statistics:

    clear virtual-ist stats

Example

Switch:1#show virtual-ist stat 
================================================================================
                             IST Message Statistics
================================================================================
PROTOCOL MESSAGE            COUNT       
--------------------------------------------------------------------------------

Ist Down                 :  0           
Hello Sent               :  0           
Hello Recv               :  0           
Learn MAC Address Sent   :  0           
Learn MAC Address Recv   :  0           
MAC Address AgeOut Sent  :  0           
MAC Address AgeOut Recv  :  0           
MAC Address Expired Sent :  0           
MAC Address Expired Sent :  0           
Delete Mac Address Sent  :  0           
Delete Mac Address Recv  :  0           
Smlt Down Sent           :  0           
Smlt Down Recv           :  0           
Smlt Up Sent             :  0           
Smlt Up Recv             :  0           
Send MAC Address Sent    :  0           
Send MAC Address Recv    :  0           
IGMP Sent                :  0           
IGMP Recv                :  0           
Port Down Sent           :  0           
Port Down Recv           :  0           
Request MAC Table Sent   :  0           
Request MAC Table Recv   :  0           
Unknown Msg Type Recv    :  0           
Mlt Table Sync Req Sent  :  0           
Mlt Table Sync Req Recv  :  0           
Mlt Table Sync Sent      :  0           
Mlt Table Sync Recv      :  0           
Port Update Sent         :  0           
Port Update Recv         :  0           
Entry Update Sent        :  0           
Entry Update Recv        :  0           
Dialect Negotiate Sent   :  0           
Dialect Negotiate Recv   :  0           
Update Response Sent     :  0           
Update Response Recv     :  0           
Transaction Que HiWaterM :  0           
Poll Count Hi Water Mark :  0  

Editing a virtual IST

If you need to change the virtual IST (vIST) peer-ip or vlan, use this procedure to delete the vIST first.

Note

Note

  • You must disable IS-IS globally before deleting a vIST, and then re-enable it after creating a new vIST.

  • You do not have to set the SMLT peer system ID or the virtual B-MAC to 0 before you change the vIST peer IP address or VLAN ID number.

Procedure

  1. Enter Global Configuration mode:

    enable

    configure terminal

  2. Disable IS-IS globally:

    no router isis enable

  3. Delete the vIST:

    no virtual-ist peer-ip

  4. Create a vIST:

    virtual-ist peer-ip <A.B.C.D> vlan <1-4059>

  5. Enable IS-IS globally:

    router isis enable

Configuring Simplified vIST in SMLT topologies

This procedure shows how to configure Simplified vIST in an SMLT environment. It includes steps to configure the following:

  • Setting the boot config flag

  • Configuring the vIST peer

  • Enabling Simplified vIST

Important

Important

When you enable Simplified vIST with the virtual-ist enable command, two VLANs are automatically created to support vIST. The VLAN IDs are: 4086 and 4087.

Before you begin

  • SPBM must not be enabled on the vIST peers.

  • Disable PIM Infinite Threshold Policy.

About this task

Important

Important

Do not change the system MTU to less than the default value of 1950 bytes. The system MTU must be 1950 or jumbo because of a header size increase.

Procedure

  1. Enter Global Configuration mode:

    enable

    configure terminal

  2. Disable the boot flag:

    no boot config flags spbm-config-mode

    The system responds with these messages:

    Warning: Please save the configuration and reboot the switch for this to take effect.

    Warning: Please carefully save your configuration file before rebooting the switch. Saving configuration file when spbm-config-mode is changed to disable, removes SPBM configurations from the configuration file.

  3. Save the configuration, and then reboot the switch.
    Important

    Important

    Any change to the spbm-config-mode boot flag requires a reboot for the change to take effect.

  4. Create the vIST VLAN:

    vlan create <2-4059> type port-mstprstp <0–63>

    interface vlan <1-4059>

    ip address <A.B.C.D/X>

  5. Configure the vIST peer address and VLAN:

    virtual-ist peer-ip <A.B.C.D> vlan <1-4059>

  6. Configure the SMLT MLT:

    mlt <1-512> enable

    mlt <1-512> member {slot/port[/sub-port] [-slot/port[/sub-port]] [,...]}

    interface mlt <1-512>

    smlt

  7. Configure the vIST MLT:

    mlt <1-512> enable

    mlt <1-512> member {slot/port[/sub-port] [-slot/port[/sub-port]] [,...]}

    mlt <1-512> encapsulation dot1q

    interface mlt <1-512>

    virtual-ist enable

    Note

    Note

    The virtual-ist enable command enables Simplified vIST and is only available when the spbm-config-mode boot flag is disabled.

  8. Create a customer VLAN and assign the SMLT MLT ID:

    vlan create <2-4059>

    vlan mlt <1-4059> <1-512>

    interface vlan <1-4059>

    ip address <A.B.C.D/X>

Example

enable
configure terminal
no boot config flags spbm-config-mode

Save the configuration and reboot the switch.

virtual-ist peer-ip 192.0.2.1 vlan 50

mlt 3 enable
mlt 3 member 1/35,1/36
interface mlt 3
smlt
exit
mlt 5 enable
mlt 5 member 2/15,2/17
mlt 5 encapsulation dot1q
interface mlt 5
virtual-ist enable
exit
vlan create 50 type port-mstprstp 0
interface vlan 50
ip address 192.0.2.2 255.255.255.0 1
exit
vlan create 100
vlan mlt 100 3
interface vlan 100
ip address 198.51.100.1 255.255.255.0 2
exit