Fabric Extend over IP using the GRT

This example shows a typical Fabric Extend deployment with a 10/40/100 Gbps switch in the core and a 1 Gbps switch in one of the branch offices. The 10/40/100 Gbps switch supports Fabric Extend natively and is connected over an IP network to a 1 Gbps switch, which requires an ONA to encapsulate SPB traffic with a VXLAN header. The ONA sets up a bridge between the ONA device-side port and the ONA network-side port. Fabric Extend uses a VXLAN tunnel to send traffic to and from the 10/40/100 Gbps switch through the 1 Gbps switch to the ONA.

Note

Note

  • This deployment uses the GRT so the tunnel source IP address must be on the GRT, not on a VRF.

  • If IP Shortcuts is enabled, you must configure an IS-IS accept policy or exclude route-map to ensure that tunnel destination IP addresses are not learned through IS-IS.

  • Add any IP address used for setting up the logical tunnel (such as local network and loopback IP addresses) to the IS-IS accept policy or exclude route-map to prevent these addresses from being advertised into IS-IS.

The following figure shows a sample Fabric Extend deployment over IP using the GRT.

Click to expand in new window
IP using GRT traffic flow
Click to expand in new window
IP (GRT) traffic flow component view

For 10/40/100 Gbps Switches

(The tunnel source IP address is configured in the GRT.)

Switch(config)# interface GigabitEthernet 2/14
Switch(config-if)# no shutdown
Switch(config-if)# default-vlan-id 0
Switch(config-if)# name "ospf-intf-SP-core"
Switch(config-if)# brouter port 2/14 vlan 3036 subnet 197.1.1.2/255.255.255.0 
Switch(config-if)# no spanning-tree mstp  force-port-state enable
Switch(config-if)# ip ospf enable
Switch(config-if)# exit

Switch(config)# router isis
Switch(config-isis)# ip-tunnel-source-address 197.1.1.2
Switch(config-isis)# exit

Switch(config)# logical-intf isis 255 dest-ip 197.1.6.2 name "Tunnel-to-Branch1"
Switch(config-isis-255-197.1.6.2)# isis
Switch(config-isis-255-197.1.6.2)# isis spbm 1
Switch(config-isis-255-197.1.6.2)# isis enable
Switch(config-isis-255-197.1.6.2)# exit

Switch(config)# ip prefix-list "isis-tunnel-addr" 197.1.0.0/16  ge 16 le 32
Switch(config)# route-map "deny-isis-tunnel-network" 1
Switch(route-map)# no permit
Switch(route-map)# enable
Switch(route-map)# match network "isis-tunnel-addr"
Switch(route-map)# match protocol isis
Switch(route-map)# exit

Switch(config)# router isis
Switch(config-isis)# accept route-map "deny-isis-tunnel-network"
Switch(config-isis)# exit
Switch(config)# isis apply accept

For 1 Gbps Switches

(The tunnel source address is a CLIP address on the GRT. This address is configured on the 1 Gbps switch and then automatically assigned to the ONA.)

Switch(config)# interface loopback 256
Switch(config-if)# ip address 256 197.1.6.2/255.255.255.0
Switch(config-if)# ip ospf 256
Switch(config-if)# exit

Switch(config)# interface GigabitEthernet 1/7-1/8; enables ports to ONA
Switch(config-if)# no shutdown
Switch(config-if)# exit

Switch(config)# vlan create 3037 name "ospf-intf-SP-core" type port-mstprstp 0
Switch(config)# vlan members 3037 1/49-1/50 portmember
Switch(config)# mlt 11
Switch(config)# mlt 11 encapsulation dot1q
Switch(config)# mlt 11 mem 1/49-1/50
Switch(config)# mlt 11 vlan 3037
Switch(config)# interface vlan 3037
Switch(config-if)# ip address 197.1.11.2 255.255.255.0 0
Switch(config-if)# ip ospf enable
Switch(config-if)# exit

Switch(config)# vlan create 3025 name "ONA-Mgmt-vlan" type port-mstprstp 0
Switch(config)# vlan members 3025 1/7 portmember
Switch(config)# interface vlan 3025
Switch(config-if)# ip address 197.2.1.1 255.255.255.0 3
Switch(config-if)# exit

Switch(config)# ip dhcp-relay fwd-path 197.2.1.1 197.10.1.11
Switch(config)# ip dhcp-relay fwd-path 197.2.1.1 197.10.1.11  enable
Switch(config)# ip dhcp-relay fwd-path 197.2.1.1 197.10.1.11  mode bootp_dhcp

Switch(config)# router isis 
Switch(config-isis)# ip-tunnel-source-address 197.1.6.2 port 1/8 mtu 1950
Switch(config-isis)# exit
Switch(config)# logical-intf isis 255 dest-ip 197.1.1.2 name "Tunnel-to-HQ"
Switch(config-isis-255-197.1.1.2)# isis
Switch(config-isis-255-197.1.1.2)# isis spbm 1
Switch(config-isis-255-197.1.1.2)# isis enable
Switch(config-isis-255-197.1.1.2)# exit

Switch(config)# ip prefix-list "isis-tunnel-addr" 197.1.0.0/16  ge 16 le 32
Switch(config)# route-map "deny-isis-tunnel-network" 1
Switch(route-map)# no permit
Switch(route-map)# enable
Switch(route-map)# match network "isis-tunnel-addr"
Switch(route-map)# match protocol isis
Switch(route-map)# exit

Switch(config)# router isis 
Switch(config-isis)# accept route-map "deny-isis-tunnel-network"
Switch(config-isis)# exit
Switch(config)# isis apply accept

For Intermediate Router 1

Intermediate routers are typically configured by an Internet service provider (ISP). The following configurations are for reference only.

Switch(config)# interface GigabitEthernet 8/19
Switch(config-if)# default-vlan-id 0
Switch(config-if)# name "ospf-intf-from-Headoffice"
Switch(config-if)# no shutdown
Switch(config-if)# brouter port 8/19 vlan 3036 subnet 197.1.1.3/255.255.255.0 mac-offset 2
Switch(config-if)# ip ospf enable
Switch(config-if)# exit

Switch(config)# vlan create 3039 name "core-ospf-vlan" type port-mstprstp 0
Switch(config)# vlan members 3039 8/1 portmember
Switch(config)# interface Vlan 3039
Switch(config)# ip address 197.1.8.1 255.255.255.0 2 
Switch(config)# ip ospf enable
Switch(config)# exit

For Intermediate Router 2

Switch(config)# vlan create 3039 name "core-ospf-vlan" type port-mstprstp 0
Switch(config)# vlan members 3039 8/1 portmember
Switch(config)# interface Vlan 3039
Switch(config)# ip address 197.1.8.2 255.255.255.0 0 
Switch(config)# ip ospf enable
Switch(config)# exit

Switch(config)# vlan create 3037 name "ospf-intf-from-branch1" type port-mstprstp 0
Switch(config)# vlan members 3037 8/21-8/22 portmember
Switch(config)# mlt 11
Switch(config)# mlt 11 encapsulation dot1q
Switch(config)# mlt 11 mem 8/21-8/22
Switch(config)# mlt 11 vlan 3037
Switch(config)# interface Vlan 3037
Switch(config)# ip address 197.1.11.1 255.255.255.0 5 
Switch(config)# ip ospf enable
Switch(config)# exit