Fabric Extend with ONAs in the Core and Branches

This example shows a Fabric Extend deployment with 1 Gbps switches in the core of the network and in the branch sites. This type of deployment is not only a lower cost Fabric Extend solution, it also addresses situations where large MTU sizes (over 1594 bytes) are a problem for the Service Provider.

MTU sizes less than 1594 bytes require fragmentation and reassembly of packets and the 1 Gbps switch with ONA supports fragmentation and reassembly. However, you must have 1 Gbps switches with ONAs at BOTH ends of the IP WAN connection.

Important

Important

There is no fragmentation/reassembly support in Layer 2 core solutions.

The following figure shows a sample Fabric Extend deployment using VRFs with both switches.

Click to expand in new window
Fabric Extend traffic flow
Click to expand in new window
Fabric Extend traffic flow component view

Core switch configuration

(The tunnel source address is a CLIP address on the VRF. This address is configured on the switch and then automatically assigned to the ONA.)

Switch(config)# ip vrf vrf24
Switch(config)# router vrf vrf24
Switch(router-vrf)# ip ospf
Switch(router-vrf)# ip ospf admin-state
Switch(router-vrf)# exit 

Switch(config)# interface loopback 256
Switch(config-if)# ip address 197.1.5.2 255.255.255.255 vrf vrf24
Switch(config-if)# ip ospf vrf vrf24
Switch(config-if)# exit

Switch(config)# interface GigabitEthernet 1/7-1/8; enables ports to ONA
Switch(config-if)# no shutdown
Switch(config-if)# exit

Switch(config)# vlan create 3036 name "ospf-intf-SP-core" type port-mstprstp 0
Switch(config)# vlan members 3036 1/14 portmember
Switch(config)# interface vlan 3036
Switch(config)# vrf vrf24
Switch(config-if)# ip address 197.1.1.2 255.255.255.0 0
Switch(config-if)# ip ospf enable
Switch(config-if)# exit

Switch(config)# vlan create 3024 name "ONA-Mgmt-vlan" type port-mstprstp 0
Switch(config)# vlan members 3024 1/8 portmember
Switch(config)# interface vlan 3024
Switch(config-if)# ip address 197.3.1.1 255.255.255.0 3
Switch(config-if)# exit

Switch(config)# ip dhcp-relay fwd-path 197.3.1.1 197.10.1.11
Switch(config)# ip dhcp-relay fwd-path 197.3.1.1 197.10.1.11  enable
Switch(config)# ip dhcp-relay fwd-path 197.3.1.1 197.10.1.11  mode bootp_dhcp

Switch(config)# router isis 
Switch(config-isis)# ip-tunnel-source-address 197.1.5.2 port 1/7 vrf vrf24 mtu 1950
Switch(config-isis)# exit
Switch(config)# logical-intf isis 255 dest-ip 197.1.6.2 name "Tunnel-to-Branch1"
Switch(config-isis-255-197.1.6.2)# isis
Switch(config-isis-255-197.1.6.2)# isis spbm 1
Switch(config-isis-255-197.1.6.2)# isis enable
Switch(config-isis-255-197.2.1.1)# exit

Branch switch configuration

(The tunnel source address is a CLIP address on the VRF. This address is configured on the switch and then automatically assigned to the ONA.)

Switch(config)# ip vrf vrf24

Switch(config)# router vrf vrf24
Switch(router-vrf)# ip ospf
Switch(router-vrf)# ip ospf admin-state
Switch(router-vrf)# exit 

Switch(config)# interface loopback 256
Switch(config-if)# ip address 197.1.6.2 255.255.255.255 vrf vrf24
Switch(config-if)# ip ospf vrf vrf24
Switch(config-if)# exit

Switch(config)# interface GigabitEthernet 1/7-1/8; enables ports to ONA
Switch(config-if)# no shutdown
Switch(config-if)# exit

Switch(config)# vlan create 3037 name "ospf-intf-SP-core" type port-mstprstp 0
Switch(config)# vlan members 3037 1/49-1/50 portmember
Switch(config)# interface vlan 3037
Switch(config-if)# vrf vrf24
Switch(config-if)# ip address 197.1.11.2 255.255.255.0 0
Switch(config-if)# ip ospf enable
Switch(config-if)# exit

Switch(config)# vlan create 3025 name "ONA-Mgmt-vlan" type port-mstprstp 0
Switch(config)# vlan members 3025 1/8 portmember
Switch(config)# interface vlan 3025
Switch(config-if)# ip address 197.2.1.1 255.255.255.0 3
Switch(config-if)# exit

Switch(config)# ip dhcp-relay fwd-path 197.2.1.1 197.10.1.11
Switch(config)# ip dhcp-relay fwd-path 197.2.1.1 197.10.1.11  enable
Switch(config)# ip dhcp-relay fwd-path 197.2.1.1 197.10.1.11  mode bootp_dhcp

Switch(config)# router isis 
Switch(config-isis)# ip-tunnel-source-address 197.1.6.2 port 1/7 vrf vrf24 mtu 1950
Switch(config-isis)# exit
Switch(config)# logical-intf isis 255 dest-ip 197.1.5.2 name "Tunnel-to-HQ"
Switch(config-isis-255-197.1.1.2)# isis
Switch(config-isis-255-197.1.1.2)# isis spbm 1
Switch(config-isis-255-197.1.1.2)# isis enable
Switch(config-isis-255-197.1.1.2)# exit

Intermediate routers are typically configured by an Internet service provider (ISP). The following configurations are for reference only.

Intermediate Router 1 Configuration

Switch(config)# interface GigabitEthernet 8/19
Switch(config-if)# default-vlan-id 0
Switch(config-if)# name "ospf-intf-from-Headoffice"
Switch(config-if)# no shutdown
Switch(config-if)# brouter port 8/19 vlan 3036 subnet 197.1.1.3/255.255.255.0 mac-offset 2
Switch(config-if)# ip ospf enable
Switch(config-if)# exit

Switch(config)# vlan create 3039 name "core-ospf-vlan" type port-mstprstp 0
Switch(config)# vlan members 3039 8/1 portmember
Switch(config)# interface Vlan 3039
Switch(config)# ip address 197.1.8.1 255.255.255.0 2 
Switch(config)# ip ospf enable
Switch(config)# exit

Intermediate Router 2 Configuration

Switch(config)# vlan create 3039 name "core-ospf-vlan" type port-mstprstp 0
Switch(config)# vlan members 3039 8/1 portmember
Switch(config)# interface Vlan 3039
Switch(config)# ip address 197.1.8.2 255.255.255.0 0 
Switch(config)# ip ospf enable
Switch(config)# exit

Switch(config)# vlan create 3037 name "ospf-intf-from-branch1" type port-mstprstp 0
Switch(config)# vlan members 3037 8/21-8/22 portmember
Switch(config)# mlt 11 
Switch(config)# mlt 11 encapsulation dot1q 
Switch(config)# mlt 11 mem 8/21-8/22 
Switch(config)# mlt 11 vlan 3037
Switch(config)# interface Vlan 3037
Switch(config)# ip address 197.1.11.1 255.255.255.0 5 
Switch(config)# ip ospf enable
Switch(config)# exit