VXLAN Gateway configuration example

This example shows how to configure the VXLAN Gateway. Remember that there are two modes:

Important

Important

Changing the mode requires a reboot for the change to take effect, which can cause a loss of traffic.

Click to expand in new window
VXLAN Gateway configuration example
#
#SPBM CONFIGURATION
#
spbm
spbm ethertype 0x8100

#
#VLAN CONFIGURATION
#
vlan members remove 1 1/1,1/30,2/1/1,2/1/4
vlan create 3000 type port-mstprstp 0
vlan members 3000 1/30 portmember
interface Vlan 3000
ip address 192.168.30.1 255.255.255.0 0 
ip ospf enable 
exit

#
#PORT CONFIGURATION - PHASE II
#
interface GigabitEthernet 1/1
default-vlan-id 0
flex-uni enable

#
#CIRCUITLESS IP INTERFACE CONFIGURATION – GlobalRouter
#
interface loopback 1
ip address 1 203.0.113.3/255.255.255.255
ip ospf 1
exit

#
#VTEP CONFIGURATION
#
vtep source-ip 198.51.100.1

#
#REMOTE VTEP CONFIGURATIONS
#
vtep 1 ip 203.0.113.3

#
#OSPF CONFIGURATION - GlobalRouter 
#
router ospf enable
router ospf
exit

#
#IP REDISTRIBUTION CONFIGURATION - GlobalRouter 
#
router ospf
redistribute direct 
redistribute direct enable 
exit

#
#I-SID CONFIGURATION
#
i-sid 300 elan
c-vid 10 port 1/1
exit

#
#VNID CONFIGURATION
#
vnid 100 i-sid 300
vtep 1
exit

#
#IP REDISTRIBUTE APPLY CONFIGURATIONS
#
ip ospf apply redistribute direct