running-config
Displays configuration files (where
all configured MAC and IP access lists are applied to an interface)
Supported on the following devices:
- Access Points: AP5010, AP310i/e, AP410i/e, AP505i, AP510i, AP510e, AP560i, AP6522, AP6562, AP7161, AP7502,
AP7522, AP7532, AP7562, AP7602, AP7612, AP7622, AP763, AP7662, AP8163, AP8543,
AP8533.
- Service Platforms:
NX5500, NX7500, NX9500, NX9600
- Virtual Platforms: CX9000, VX9000
Syntax
show running-config {aaa-policy|application|application-group|application-policy|
association-acl-policy|auto-provisioning-policy|captive-portal-policy|device|database-client-policy|
database-policy|device|device-overrides|dhcp-server-policy|dhcpv6-server-policy|
ex3500-management-policy|ex3500-qos-class-map-policy|ex3500-qos-policy-map|exclude-devices|
firewall-policy|flag-unwritten-changes|guest-management-policy|hide-encrypted-values|
include-factory|interface|ip-access-list|ipv6-access-list|mac-access-list|management-policy|
meshpoint|nsight-policy|profile|radio-qos-policy|rf-domain|roaming-assist-policy|rtl-server-policy|
schedule-policy|smart-rf-policy|url-filter|url-list|web-filter-policy|wlan|wlan-qos-policy}
show running-config {aaa-policy|application-policy|association-acl-policy|auto-provisioning-policy|
captive-portal-policy|database-client-policy|database-policy|dhcp-server-policy|dhcpv6-server-policy|
ex3500-management-policy|ex3500-qos-class-map-policy|ex3500-qos-policy-map|guest-management-policy|
firewall-policy|management-policy|nsight-policy|radio-qos-policy|roaming-assist-policy|rtl-server-policy|
schedule-policy|smart-rf-policy|web-filter-policy|wlan-qos-policy}<POLICY-NAME> {include-factory}
show running-config {flag-unwritten-changes}
show running-config {application <APPLICATION-NAME>|application-group <APPLICATION-GROUP-NAME>}
show running-config exclude-devices
show running-config {device [<MAC>|self]} {include-factory}
show running-config {device-overrides {brief}}
show running-config {hide-encrypted-values {exclude-devices|include-factory}}
show running-config {include-factory}
show running-config {interface} {<INTERFACE-NAME>|ge|include-factory|me|port-channel|
pppoe1|vlan|wwan1}
show running-config {interface} {<INTERFACE-NAME>|ge <1-4>|include-factory|me1|
port-channel <1-2>|pppoe1|vlan <1-4094>|wwan1} {include-factory}
show running-config {ip-access-list <IP-ACCESS-LIST-NAME>|ipv6-access-list <IPv6-ACCESS-LIST-NAME>|
mac-access-list <MAC-ACCESS-LIST-NAME} {include-factory}
show running-config {meshpoint <MESHPOINT-NAME>} {include-factory}
show running-config {profile [anyap|ap505|ap510|rfs4000|nx5500|nx75xx|nx9000|nx9600|vx9000] <PROFILE-NAME>} {include-factory}
show running-config {rf-domain <DOMAIN-NAME>} {include-factory}
show running-config {wlan <WLAN-NAME>} {include-factory}
show running-config url-filter <URL-FILTER-NAME>
show running-config url-list <URL-LIST-NAME> {include-factory}
Parameters
show running-config {flag-unwritten-changes}
running-config flag-unwritten-changes |
Flags unsaved changes in the show >
running-config command output. Optionally
use the flag-unwritten-changes keyword to view changes
that have been committed but not saved in the startup
configuration. When used, all unsaved changes are marked
with a “===” marker, as shown in the following show >
running-config > flag-unwritten-changes
output:nx9500-6C8809(config)#show running-config flag-unwritten-changes
!
! Configuration of NX9500 version 7.1.0.0-114D
!
!
version 2.6
!
!
client-identity-group default
load default-fingerprints
!
client-identity-group test2
load default-fingerprints
!
===alias encrypted-string $WRITE 2 o5gA2zqj/q/REWi8rTa7vQAAAAh4yA1YNBjqTVf4mMBsGA4i
!
===alias encrypted-string $enAlias2 2 JI4lPuMaCdMMx7rfBeyIAwAAAAoZ6tR1FfTlFXWvSicTMVZc
!
--More--
nx9500-6C8809(config)#
Execute
the write > memory command to save these
changes.
|
show running-config {aaa-policy|application-policy|association-acl-policy|
auto-provisioning-policy|captive-portal-policy|database-client-policy|database-policy|
dhcp-server-policy|dhcpv6-server-policy|ex3500-management-policy|ex3500-qos-class-map-policy|
ex3500-qos-policy-map|guest-management-policy|firewall-policy|management-policy|nsight-policy|
radio-qos-policy|roaming-assist-policy|rtl-server-policy|schedule-policy|smart-rf-policy|
web-filter-policy|wlan-qos-policy} <POLICY-NAME> {include-factory}
running-config |
Displays current running configurationOptionally, execute the command
along with one of the associated keywords to view the running
configuration for that top-level object. For example, to view a policy
and its configuration, specify the policy type and provide the policy
name. Note: If the
command is executed without a keyword, the system displays the entire
running configuration.
|
<POLICY-TYPE> <POLICY-NAME> |
Optional. Select the policy type, for example, aaa-policy,
auto-provisioning-policy, captive-portal-policy, etc. and then specify the
policy name. The system displays the selected policy‘s configuration.
- <POLICY-NAME> –
Specify the name of the policy (should be existing and
configured).
|
include-factory |
The following keyword is common to all policies:
- include-factory –
Optional. Includes factory defaults
|
show running-config {application <APPLICATION-NAME>|apllication-group <APPLICATION-GROUP-NAME>}
running-config |
Displays current running configurationOptionally, execute the command
along with one of the associated keywords to view the running
configuration for that top-level object. For example, to view a policy
and its configuration, specify the policy type and provide the policy
name. Note: If the
command is executed without a keyword, the system displays the entire
running configuration.
|
application <APPLICATION-NAME> |
Displays an application‘s configuration. The application can be
system-provided or user-defined.
- <APPLICATION-NAME> – Specify the application name (should be
existing).
|
application-group <APPLICATION-GROUP-NAME> |
Displays an application-group‘s configuration
- <APPLICATION-GROUP-NAME> – Specify the application-group name
(should be existing and configured).
|
show running-config {device [<MAC>|self]} {include-factory}
running-config |
Displays current running configurationOptionally, execute the command
along with one of the associated keywords to view the running
configuration for that top-level object. For example, to view a policy
and its configuration, specify the policy type and provide the policy
name. Note: If the
command is executed without a keyword, the system displays the entire
running configuration.
|
device [<MAC>|self] |
Optional. Displays device configuration
- <MAC> – Displays
a specified device configuration. Specify the MAC address of the
device.
- self – Displays the
logged device‘s configuration
|
include-factory |
This keyword is common to all of the above keywords:
- include-factory –
Optional. Includes factory defaults
|
show running-config {hide-encrypted-values {exclude-devices|include-factory}}
running-config |
Displays current running
configurationOptionally, execute the command along with one of the
associated keywords to view the running configuration for that top-level
object. For example, to view a policy and its configuration, specify the
policy type and provide the policy name. Note: If the command is executed
without a keyword, the system displays the entire running
configuration.
|
hide-encrypted-values {exclude-devices|include-factory} |
Optional. Replaces all encrypted passwords with the standard characters
****** in the show > running-config output
- exclude-devices –
Optional. Excludes devices from the running configuration
displayed
- include-factory –
Optional. Includes factory default values in the running configuration
displayed
|
show running-config {device-overrides {brief}}
running-config |
Displays current running configuration |
device-overrides brief |
Optional. Displays overrides applied at the device‘s configuration
- brief – Optional. Displays a brief summary of device overrides
|
show running-config {exclude-devices}
running-config |
Displays current running configuration |
exclude-devices |
Optional. Excludes device configuration details from the running
configuration displayed |
show running-config {include-factory}
running-config |
Displays current running configuration |
include-factory |
Optional. Includes factory defaults
|
show running-config {interface} {<INTERFACE-NAME>|ge <1-4>|include-factory|
me1|port-channel <1-2>|pppoe1|vlan <1-4094>|wwan1} {include-factory}
running-config |
Displays current running configuration |
interface |
Optional. Displays interface configuration |
<INTERFACE-NAME> |
Optional. Displays a specified interface configuration. Specify the
interface name. |
ge <1-4> |
Optional. Displays GigabitEthernet interface configuration
- <1-4> – Specify
the GigabitEthernet interface index from 1 - 4.
|
me1 |
Optional. Displays FastEthernet interface configuration |
port-channel <1-2> |
Optional. Displays port channel interface configuration
- <1-2> – Specify
the port channel interface index from 1 - 2.
|
pppoe1 |
Optional. Displays PPP over Ethernet interface configuration |
vlan <1-4094> |
Displays VLAN interface configuration
- <1-4094> –
Specify the VLAN interface number from 1 - 4094.
|
wwan1 |
Optional. Displays Wireless WAN interface configuration |
include-factory |
The following keyword is common to all interfaces:
- include-factory -
Optional. Includes factory defaults
|
show running-config {ip-access-list <IP-ACCESS-LIST-NAME>|ipv6-access-list
<IPv6-ACCESS-LIST-NAME>|mac-access-list <MAC-ACCESS-LIST-NAME} {include-factory}
running-config |
Displays current running configurationOptionally, execute the command
along with one of the associated keywords to view the running
configuration for that top-level object. For example, to view a policy
and its configuration, specify the policy type and provide the policy
name. Note: If the
command is executed without a keyword, the system displays the entire
running configuration.
|
ip-access-list <IP-ACCESS-LIST-NAME> |
Optional. Displays IP access list configuration
- <IP-ACCESS-LIST-NAME> – Specify the IP access list name
|
<ACL-TYPE> <IP/IPv6/MAC-ACL-NAME> |
Optional. Select the ACL type, for example, ip-access-list,
ipv6-access-list, or mac-access-list, and then specify the ACL name. The
system displays the selected ACL‘s configuration.
- <IP/IPv6/MAC-ACL-NAME> – Specify the name of the ACL (should be
existing and configured).
|
include-factory |
The following keyword is common to the ‘ip-access-list' and
‘mac-access-list' parameters:
- include-factory -
Optional. Includes factory defaults
|
show running-config {meshpoint <MESHPOINT-NAME>} {include-factory}
running-config |
Displays current running configuration |
meshpoint <MESHPOINT-NAME> |
Optional. Displays meshpoint configuration
- <MESHPOINT-NAME>
– Specify the meshpoint name
|
include-factory |
Optional. Includes factory defaults along with running configuration
details |
show running-config {profile [anyap|ap505|ap510|rfs4000|nx5500|nx75xx|
nx9000|nx9600] <PROFILE-NAME>} {include-factory}
running-config |
Displays current running configuration |
profile <DEVICE-TYPE> <PROFILE-NAME> |
Optional. Displays current configuration for a specified profile. Select
the device type, and then specify the profile name.
- <DEVICE-TYPE> – Select the device type. The
options are: AP505, AP510, RFS4000, NX5500,
NX7500, NX9500, NX9600, and VX9000
- <PROFILE-NAME> – Specify the profile
name for the selected
<DEVICE-TYPE>.
Note: Select the ‘anyap‘
option to view the running configuration of any type of
device.
|
include-factory |
Optional. This parameter is common to all profiles. When selected, it
includes factory defaults in the output. |
show running-config {rf-domain <DOMAIN-NAME>} {include-factory}
running-config |
Displays current running configuration |
rf-domain <DOMAIN-NAME> |
Optional. Displays current configuration for a RF Domain
- <DOMAIN-NAME> –
Displays current configuration for a specified RF Domain. Specify the
RF Domain name.
|
include-factory |
Optional. Includes factory defaults |
show running-config {wlan <WLAN-NAME>}{include-factory}
running-config |
Displays current running configuration |
wlan <WLAN-NAME> |
Optional. Displays current configuration for a WLAN
- <WLAN-NAME> –
Displays current configuration for a specified WLAN. Specify the WLAN
name.
|
include-factory |
Optional. Includes factory defaults |
show running-config url-filter <URL-FILTER-NAME>
running-config |
Displays current running configuration |
url-filter <URL-FILTER-NAME> |
Optional. Displays current configuration for the URL filter identified
by the <URL-FILTER-NAME> keyword
- <URL-FILTER-NAME> – Specify the URL filter‘s name.
|
show running-config url-list <URL-LIST-NAME> {include-factory}
running-config |
Displays current running configuration |
url-list <URL-LIST-NAME> |
Optional. Displays current configuration for the URL list identified by
the <URL-LIST-NAME> keyword
- <URL-LIST-NAME>
– Specify the URL list‘s name.
|
include-factory |
Optional. Includes factory defaults |
Examples
nx9500-6C8809#show running-config device self
!
version 2.6
!
!
ip snmp-access-list default
permit any
!
firewall-policy default
no ip dos tcp-sequence-past-window
!
!
mint-policy global-default
!
!
management-policy default
no telnet
no http server
https server
no ftp
ssh
user admin password 1 fd07f19c6caf46e5b7963a802d422a708ad39a24906e04667c8642299c8462f1 role superuser access all
--More--
nx9500-6C8809#
nx9500-6C8809#show running-config profile ap505 default-ap505
profile ap505 default-ap505
no autoinstall configuration
no autoinstall firmware
crypto ikev1 policy ikev1-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ikev2 policy ikev2-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ipsec transform-set default esp-aes-256 esp-sha-hmac
crypto ikev1 remote-vpn
crypto ikev2 remote-vpn
crypto auto-ipsec-secure
crypto load-management
crypto remote-vpn-client
interface radio1
interface radio2
interface ge1
interface ge2
interface pppoe1
use firewall-policy default
service pm sys-restart
router ospf
adoption-mode controller
nx9500-6C8809#
nx9500-6C8809#show running-config url-filter URL_FILTER_Shopping include-factory
url-filter URL_FILTER_Shopping
no description
blacklist category-type p2p precedence 20 description description
blacklist category-type news-sports-general category shopping precedence 10 description description
blockpage path internal
blockpage internal org-name Your Organization Name
blockpage internal org-signature Your Organization Name, All Rights Reserved.
blockpage internal title This URL may have been filtered.
blockpage internal header The requested URL could not be retrieved.
blockpage internal footer If you have any questions please contact your IT department.
blockpage internal content The site you have attempted to reach may be considered inappropriate for access.
no blockpage internal main-logo
no blockpage internal small-logo
no blockpage external
nx9500-6C8809#
nx9500-6C8809#show running-config management-policy default
management-policy default
no telnet
no http server
https server
rest-server
ssh
user admin password 1 1f61a6bae8aeb0f5205628a5e88a635b8f76eb11f1c44b2dcf1381a8f681f44d role superuser access all
snmp-server community 0 private rw
snmp-server community 0 public ro
snmp-server user snmptrap v3 encrypted des auth md5 0 admin123
snmp-server user snmpmanager v3 encrypted des auth md5 0 admin123
t5 snmp-server community public ro 192.168.0.1
t5 snmp-server community private rw 192.168.0.1
nx9500-6C8809#